Interface - Maple Programming Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : System : Information : Updates : Maple 2018 : updates/Maple2018/Interface

Interface

 

Protecting Your Content from Changes

File Path Autocompletions

Menu Updates

Context Menu Updates

New Shortcut Keys

Protecting Your Content from Changes

Maple 2018 has added the ability to mark both documents as well as tables in documents as editable or noneditable.

Editable Documents

Marking a document as noneditable can be viewed as a "player-mode" for Maple documents. When a document is marked as noneditable, any existing content in that document cannot be modified. It is not possible to add any new content such as embedded components or to run computations in execution groups or document blocks. Any interactive embedded components inside of a document will continue to work. When a worksheet is "Editable", it will continue to work as normal.

Marking a document as editable or noneditable

In order to make the current document editable or noneditable, simply toggle the Editable check box in the Maple window's Status Bar.

If this check box is cleared, the current document can no longer be modified.

Editable Tables

Tables can also now be marked as editable or noneditable. The editable property for tables is independent of the document editability, though if a document is marked as noneditable, tables cannot be edited. After a table has been marked as noneditable, any content stored in the table cannot be modified. It is not possible to add any new content such as embedded components or to run computations in execution groups or document blocks. Existing interactive embedded components inside of a table will continue to work.

Marking a table as editable or noneditable

A table can be marked as editable or noneditable in its Table Properties using either the DocumentTools:-SetProperty command or the Context Panel. To make a table editable or noneditable using the Context Panel, in the Table properties, select or clear the Editable check box:

Example:

1+1

2

(1.2.1.1)

DocumentTools:-SetProperty("Table1", editable, false);

DocumentTools:-GetProperty("Table1", editable);

false

(1.2.1.2)

 

File Path Autocompletions

When a file path is detected in an entered string, it is now possible to use command completion to autocomplete the file path or to browse the specified directory.

Menu Updates

There are some new and updated items in Maple menus. Some of the changes are highlighted here.

Edit Menu

• 

The new Copy Special menu group contains the Copy as image, Copy full precision, and Copy as MathML menu items.

• 

Remove Section has been added to the Edit menu (it was previously called Outdent in the Format menu).

• 

Image Properties has been added to the Edit menu.

• 

Hyperlinks has been moved to the Format menu.

• 

The Edit Annotation and Delete Annotations menu items have been moved to the Format menu.

View Menu

• 

A new menu item Context Panel controls the display of the context panel.

• 

The Header Footer... menu item has been moved to the Insert Menu.

• 

The Open in a New Window menu item has been moved to the Window menu.

• 

The Clickable Math Popups toggle has been removed. Clickable Math Popups are now available by default.

• 

The Hide arrow and stay expanded toggle has been added to the Sections submenu. This was previously available in the right-click context menu.

Insert Menu

• 

The Header Footer... menu item has been added to this menu.

• 

The Subsection menu item has been removed.

Format Menu

• 

The new Annotations menu group now contains the Annotate Selection, Edit Annotation and Delete Annotations menu items.

• 

The new Hyperlinks menu group now contains the Hyperlink Editor and Hyperlink Properties menu items. The Hyperlink Properties menu item was previously available from the right-click context menu.

• 

The Indent and Outdent menu items have been removed. The Outdent menu item has been moved to the Edit menu and renamed Remove Section. Indent can be found under the Insert - Section menu item.

Tools Menu

Several options have changed in the Options / Preferences Dialog.

Display Options

• 

Syntax check level has been added. This option controls the defaults for the syntax checker in the Code Editor and the Code Edit Region component.

• 

Syntax check automatically has been added. This option controls if the syntax checker in the Code Editor and the Code Edit Region automatically checks for syntax issues. This is enabled by default.

See the following for details on Display options.

Interface Options

• 

The Arrangement of math context menus menu item has been removed.

• 

The Quick Help popup on new documents toggle has been removed. The Quick help is now automatically available in the Context Panel.

See the following for details on Interface options.

Window Menu

• 

The Open in a New Window menu item has been added to this menu.

Markers Panel

The right-click (Control-click, for Mac) context menu for the Markers panel has the following updates:

• 

Added Units Formatting to the Formatting menu group.

• 

Added Annotation menu group containing Annotate Selection, Delete Annotation, and Edit Annotation menu items.

• 

Added Select Document Block to the Document Block menu group.

• 

Added Select Execution Group to the Execution Group menu group.

• 

Added Show/Hide Contents to the View menu group.

Context Menu Updates

The new Context Panel on the right side of the Maple window contains the context-sensitive options previously found through the right-click menu. In addition, more operations are now available:

• 

Commands from the DynamicSystems package are now available in the Context Panel without having to load the package.

• 

Added Student:-Calculus1:-Distance command to Calculus1 menu.

• 

The identify command is now accessible for floating-point values.

• 

Added the ability to use Plot Builder on inequalities.

• 

Added number of elements for sets.

• 

Removed language translations for Units.

New Shortcut Keys

Several new shortcut keys have been added for Maple's Help Browser. For a full list, see Shortcut Keys Summary for:

• 

Windows

• 

Mac OS X

• 

Linux