Interface - Maple Programming Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : System : Information : Updates : Maple 2016 : updates/Maple2016/Interface

Interface

 

Improved Equation Editing

Improvements in Command Completion

New Interface Icons

New Options

New Shortcut Keys

Context Menu Updates

New Palettes

Menu Updates

Improved Equation Editing

A number of changes make authoring mathematical documents in Maple easier.

Executable Math

Maple 2016 includes better user controls of math in documents. You can now toggle a 2-D expression, which by default is executable math, to nonexecutable math.

1. 

Click in the expression, and then hover over the expression. A small circular popup appears.
Tip: If the popup does not appear, move your mouse away, and then move back over the expression.

2. 

Click the circular popup to toggle between executable and nonexecutable math.

 

Alternatively, use the shortcut key Shift + F5 or, under the Edit menu, clear the check box beside Executable Math.

When editing a 2-D math expression, executable math is displayed with a blue background, such as:

Nonexecutable math is displayed with a gray background:

 

Use nonexecutable math for expressions that are only for display purposes, that you do not want to execute. Often these are mathematical formulas which are not valid Maple syntax. If an expression, such as x__i, is executed accidentally, it can lead to error messages or unwanted output. If this happens, toggling the expression to nonexecutable math removes the error message or output and changes the math to nonexecutable.

Multiplication

Maple 2016 enhances 2-D math equation editing by displaying a visible multiplication symbol () between side-by-side closing and opening parentheses. For example, if you write f+g x,y, Maple inserts the multiplication symbol:

This makes it clear that the expression with adjacent parentheses is interpreted as multiplication. This change is designed to help you avoid common errors in writing expressions and troubleshoot your work more quickly.

If you did not mean multiplication (for example you meant to apply the functions f+g to x,y ), delete the dot.

Multiplication:

f+gx,y

f+gx,y

(1.2.1)

Function application:

f+gx,y

fx,y+gx,y

(1.2.2)

You can control whether an expression with adjacent parentheses in 2-D math is interpreted to mean multiplication or function application. For details, see the Smart Operators section of the Options dialog.

For more details about these and other features of 2-D math, see 2-D Math Details.

Improvements in Command Completion

As you are typing a Maple name or command, Maple checks both your current session and Maple's archive of known names and commands to try to anticipate what you are planning to enter. This process goes by the name command completion. For Maple 2016, several adjustments have been made to this process to make entering names and commands into your Maple session easier:

• 

If the command completion mechanism determines that all known completions of what you have typed thus far share a prefix which is longer than what you have typed, a tooltip showing that prefix, followed by "...", appears. For example, if you type Lin, then a tooltip showing "Linear..." will appear, as all of the stored Maple commands which start "Lin" also share the full prefix "Linear". To accept this prefix completion, just press Enter.

• 

If the command completion mechanism anticipates that you are entering a command which has been marked as deprecated, a tooltip appears showing the completion of what you are entering but it also indicates that this is deprecated and suggests a more modern replacement.

• 

If you use the command completion shortcut key Esc to display a popup menu of all possible completions of what you have entered thus far and Maple determines that you are entering a deprecated command, the menu will include the modern replacement(s) above the direct completion of your command.

• 

The command completion system will not suggest as a possible completion any undocumented commands.

For more information on command completion, see Complete Command.

New Interface Icons

The redesigned interface icons offer improved scaling on high resolution monitors for Maple 2016. Icons across the Maple user interface have been updated, including all toolbars.

New Look for the Worksheet Toolbar

New Look for the Plotting Toolbar

For more information on the icons, see Worksheet Toolbar.

New Options

Interface Zoom

The icons for zooming on the main toolbar have been changed to Zoom In, Zoom Out, and Default Zoom ( ), respectively. Previously, there were three icons that set the zoom level to 100%, 150%, or 200%.

The current zoom level is now shown in the status bar at the bottom of the Maple window.

The hotkey Ctrl + 0 has been changed from setting the zoom level to 50% to setting the current zoom level to the default zoom level. Other previous behavior, such as the ability to use Ctrl + 1, Ctrl + 2, ... to set a defined zoom level, is unchanged. Similarly, the ability to zoom in or out using the combination Ctrl + Mouse Scroll wheel is also unchanged.

Another change for zoom is that the zoom level is no longer stored in the Maple worksheet. Any worksheet that is opened in a Maple session is now opened to the zoom level as set in the Tools menu > Options... > Interface tab > Default Zoom (Windows and Linux) or Maple 2016 menu > Preferences > Options Dialog  > Default Zoom level (Mac).

For more information on zoom levels, see Maple Preferences or for more comprehensive shortcut key lists by platform, see lists for Windows, Mac, and Linux.

Show or Hide Table Borders

The display of interior and exterior table borders can be optionally turned off in Maple worksheets using the Table Properties dialog. When borders are turned off, Maple provides a worksheet-level setting to control the display of "invisible" borders when hovering over a table with the mouse (View > Show/Hide Contents > Hidden Table Borders ).  However, there can be cases where it is desirable to set the table border visibility on a per table basis. As such, table borders can be changed using the following options found in the Table Properties dialog:

 

• 

Always – hidden table borders are always displayed on mouse hover.

• 

Never – hidden table borders are never displayed.

• 

According to Show/Hide Setting – the table obeys the global worksheet setting. (This is the default.)

Full Screen Mode on Mac

For Mac users, Maple can now be used in full screen mode. To switch to full screen mode, select View > Full Screen Mode or use the shortcut key for toggling full screen mode, Control + Command + F.

Control the Display of Sections

Sections are one of the main tools to control the flow of content in a Maple document. Maple 2016 offers a new optional way to display a section. By default, sections are delimited with an arrow beside the section heading and a line along the left border. The section is collapsible by clicking the arrow or line.

Default look of sections

 

 

If preferred, you can change the look so sections are not collapsible and no visible delimiter is shown. From the context-sensitive menu, select Section > Hide arrow and stay expanded.

New look of sections

The help pages use this setting.

New Shortcut Keys

Several new shortcut keys have been added to Maple 2016:

 

• 

To move the preceding term to the denominator in a rational expression, type // and then enter the numerator. Examples:
Entering a//b produces ba.
Entering (1+x)//1 produces 11+x.
For more information on shortcut keys for entering rationals and other 2-D math, see 2-D Math Shortcut Keys.

 

• 

To toggle between executable and nonexecutable math, use Shift + F5.

 

• 

To toggle to full screen mode on Mac, use the key combination Control + Command + F.
For more comprehensive shortcut key lists by platform, see lists for Windows, Mac, and Linux.

Context Menu Updates

Inserting Rows or Columns into a Matrix

It is now possible to insert rows and columns into Matrices using the context-sensitive menu for 2-D math input.  Previously, a new row or column could only be added to an existing matrix using the Ctrl + Shift + R (row) or Ctrl + Shift + C (column) shortcut keys. Right-click on a matrix and look for the context menu options Insert Column and Insert Row.

DataFrame Context Menu

The Maple programming language provides many commands that are useful for exploring DataFrames. The right-click context menu provides easy access to a selection of these commands, displaying context specific commands that can be applied to DataFrames or DataSeries.

The DataFrame context menu contains many commands that can be applied to entire DataFrames as well as to a single DataSeries in a DataFrame. The second section of the DataFrame context menu includes commands for conversions, operations, queries, and visualization of DataFrames and DataSeries. The third section includes more commands relating to statistics and data analysis, including data analysis, data manipulation, properties and quantities, and summary and tabulation.

A useful feature of the context menu is the ability to quickly filter the DataFrame by value or to select columns to apply operations to. This can be beneficial when dealing with heterogeneous data that includes non-numeric DataSeries. In many cases, commands in Statistics assume an entirely numeric DataFrame. Selectively removing the non-numeric data makes it possible to use the routines natively on the given DataFrame.

DataFrame Context Menu

More Operations in the Context Menu

Many more commands are now available in the context menu, including operations for number theory, multivariate calculus, and more.

New Palettes

Group Constructors Palette

A new Group Constructors Palette contains buttons for constructing groups.

 

Each entry is a template. To fill in the content, navigate through the placeholders using the Tab key.

 

By default, the Group Constructors palette will not be visible on start-up in the left pane of the Maple window. To enable the palette, click the View menu, and select Palettes>Show Palette>Group Constructors.

Group Constructors Palette

Menu Updates

There are some new and updated items in Maple menus. Some of the changes are highlighted here.

File Menu

Four new entries in the File > New submenu pertain to content inside of a Workbook:

• 

Document in Workbook: Create a new document inside of the current workbook file.

• 

Worksheet in Workbook: Create a new worksheet inside of the current workbook file.

• 

Folder in Workbook: Create a new folder in the Workbook Navigator tree.

• 

Maple Code Attachment: Create a new code attachment inside of the current workbook file.

Edit Menu

Under the Edit menu, the new entry Executable Math enables toggling between executable and nonexecutable math.

 

For ease of use, some menu items have been rearranged.  All menu items pertaining to Document Blocks are now found under Edit > Document Blocks. One menu item has a new name: Expand Document Block is now Show Command.

 

This new submenu also includes the following menu items that were previously found under other menus:

• 

View: Group and Block Management

• 

View: Toggle Input/Output Display

• 

View: Inline Document Output

• 

Format: Create Document Block

• 

Format: Remove Document Block

View Menu

A new menu item for Mac users puts Maple in Full Screen Mode.

 

The View > Workbook Navigator submenu collects all commands relevant to the display of content in Workbook Navigator palette.