Interface - Maple Programming Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : System : Information : Updates : Maple 2015 : updates/Maple2015/Interface

Interface

With every new release, the Maple user interface undergoes many small changes. In Maple 2015, there have been updates and additions to the palettes, menus, shortcut keys, and more, including:

 

Data Sets in the Help Search Box

Improved Equation Editing

Plot Thumbnails

New Shortcut Keys

New Options

New Palettes

Menu Updates

Plot toolbar

More Updates

Data Sets in the Help Search Box

The help search box can now also search for any data sets that match the search keyword.

Improved Equation Editing

Maple 2015 enhances 2-D math equation editing by automatically inserting a space between side-by-side closing and opening brackets. This means that for expressions like x+ya+b, a space is inserted and the expression is treated as an implicit multiplication of the terms x+y and (a+b). For example:

 

x+y a+b

x+ya+b

(2.1)

expand(  )

ax+ay+bx+by

(2.2)

 

For those who prefer the previous interpretation as function application, the default behavior can be changed by using the new Smart Operators option accessed from Tools > Options > Interface (see more details in the New Options section later).

Plot Thumbnails

Thumbnails of plots are now displayed in output for cases where Maple would have previously displayed elided placeholders. This does not affect return values or underlying output structures.

psinx,plotsinx,cosx,plotcosx

p:=sinx,PLOT...,cosx,PLOT...

(3.1)

In previous versions, this was displayed as:

New Shortcut Keys

Several new shortcut keys have been added to Maple 2015:

 

• 

Zoom in or out from your Maple worksheet:

 - Ctrl + mouse scroll wheel : Windows

 - Command + mouse scroll wheel : Macintosh

 

• 

Ctrl + = and Alt + Enter evaluate Maple code everywhere:

 - On a 1-D or 2-D input prompt: in which case the result would not be printed inline but below the prompt, as if the Enter key was pressed

 - Inside a Code Edit Region: where Ctrl + = and Alt + Enter would behave identical to what Ctrl + E currently does

 

• 

Keyboard shortcut to expand or collapse code edit regions:

 - Alt + C : to collapse code edit region (Command + Alt + C on Macintosh)

 - Alt + X : to expand code edit region (Command + Alt + X on Macintosh)

 

• 

Open the User Profile dialog

 - Ctrl + Shift + I : Windows

 - Command + Alt + I : Macintosh

 

• 

To insert a new Unit:

 - Ctrl + Shift + U : Windows

 - Command + Shift + U : Macintosh
 - Alt + Shift + U : Linux  

 

For more comprehensive shortcut key lists by platform, see lists for Windows, Macintosh, and Linux.

New Options

In the Options dialog, accessed from Tools menu, there are several new options:

 

Display Tab:

• 

Default Point Probe: Change the default coordinate information that the point probe displays for plots.

 

Interface Tab:

• 

Smart Operators: When this is selected, Maple automatically inserts a space to act as a multiplication operator when an opening bracket ‘(‘ is entered immediately after a closing bracket ’)’.

 

Network Tab:

• 

The Network tab collects any functionality in Maple that relies on external network connectivity. Several options have been relocated to this tab and a new section for proxy server management has been added.

New Palettes

Trigonometric & Hyperbolic Functions Palette

A new Trigonometric & Hyperbolic Functions Palette contains buttons for constructing expressions involving trigonometric and hyperbolic functions.

 

Each entry is a template. To fill in the content, navigate through the placeholders using the Tab key.

 

By default, the trigonometric and hyperbolic functions palette will not be visible on start-up in the left pane of the Maple window. To enable the palette, click the View menu, and select Palettes>Show Palette>Trigonometric and Hyperbolic Functions.

Trigonometric & Hyperbolic
Functions Palette

Student Random Variables Palette

A new Student Random Variables Palette contains buttons for constructing random variables based on distributions in the Student Statistics package.

 

By default, the student random variables palette will not be visible on start-up in the left pane of the Maple window. To enable the palette, click the View menu, and select Palettes>Show Palette>Student Random Variables.

 

 

Student Random Variables Palette

 

For more information on palettes, see Overview of Palettes.

 

Menu Updates

There are some new and updated items in Maple menus.

File menu

There are two new entries:

• 

Open from cloud: Open a Maple worksheet stored in the MapleCloud

• 

Save to cloud: Save a Maple worksheet to the MapleCloud

Edit menu

There is a new User Profile entry.

A User Profile is a text file that contains commands that select your system of units; set your preferred numeric formatting; and insert Maple commands into a worksheet's Startup Code region. Use this command to open the User Profile dialog.

From the User Profile dialog you can do the following:

• 

apply a User Profile to the current worksheet

• 

apply a User Profile and also set it as the default User Profile

If you set a default User Profile, Maple applies the User Profile to every new (blank) worksheet you open. The default User Profile is not applied to existing worksheets.  

For more information, see User Profile.

View menu

Sections: This new group collects section management commands

Group and Block Management: This new group collects group and block management commands

Insert menu

Drawing: The Insert - Canvas menu item has been renamed 'Drawing'

Formatting menu

Unit Formatting: A new dialog that allows for global or local control over unit formatting. For more details, see the Units updates page.

Numeric Formatting: It is now possible to apply numeric formatting as a global default for all new worksheets using the 'Apply and Set as Default' button.

Tools menu

There are two new reference tutors in the Statistics Tutors menu:

• 

Probability Distribution Tables: Show probability distribution tables from various distributions

• 

Critical Value Tables: Show tables of critical values from various distributions

 

The Unload Packages menu has been changed to show only loaded packages.

Help menu

The Help menu is noticeably shorter in Maple 2015. Several items from the help menu have been removed, including the former 'Manuals, Resources, and more' section, which has been moved into higher profile locations in the Help system table of contents.

 

Plot toolbar

Previously the plot toolbar contained one icon for 'scale', which made it possible to zoom in and out on a plot. In Maple 2015, this action has been split into 'zoom in' and 'zoom out' buttons:

For more information, see Zoom Into a Plot and Change the View of a Plot.

More Updates

Previously, if a command was entered in 1-D without a semi-colon, a warning would be returned. In Maple 2015, the missing semicolon warning has been removed for 1-D math.

diff( sin(x), x)

cosx

(9.1)