Platform Specific Issues - Maple Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : System : platform

Platform Specific Issues

 

Worksheets

Mac OS X

Worksheets

  

Maple provides two worksheet interfaces. Both have access to the full mathematical engine of Maple and take advantage of the new functionality in Maple 2016.

  

By default, worksheets open in the enhanced and more modern Standard Worksheet. The Classic Worksheet, available on 32-bit Windows platforms, has the traditional Maple worksheet look and uses less memory. Changing the Maple worksheet file association can be performed through your operating system.

  

If your system has less than the recommended amount of physical memory, it is suggested that you use the Classic Worksheet version of Maple.

  

In general, worksheets created using any version of Maple can be read by the same version or a newer version of Maple on all platforms. There are some exceptions described below. For more information, see the Worksheet Compatibility Issues help page.

Mac OS X

• 

The Mac OS X specific kernel option, freebundle can be set to a Boolean value. Due to a bug in Mac OS X, the memory allocated when an external library is loaded is not freed when that library is unloaded.  Many Maple library functions utilize external libraries.  These libraries are unloaded on a restart.  Therefore, if you use functions that utilize external libraries in conjunction with restart, you may notice that the Maple memory usage increases. If the freebundle option is set to true, Maple releases this memory when the libraries are unloaded.  However, setting this option to true may cause Maple to become unstable at exit.  Instabilities include segmentation faults and the kernel, mserver, staying active after Maple has exited.

• 

Note that the Classic Worksheet is not included on the Maple installation disc. For more information, see the Maple Versions help page.

• 

The Export to RTF feature is not available. For more information, see the Export Worksheets help page.

• 

To export a worksheet to a PDF, use the Save as PDF option in the File>Print dialog. This functionality is not available on the File > Export As menu. For more information, see the Export as Portable Document Format (PDF) help page.

• 

The About Maple menu item is on the Maple menu, which is located at the left end of the menu bar, and not on the Help menu as in other operating systems.

• 

The Preferences menu is located on the Maple menu, and not on the Tools>Options menu as in other operating systems.

See Also

Maple Versions

trademark

Worksheet Compatibility Issues

 


Download Help Document

Was this information helpful?



Please add your Comment (Optional)
E-mail Address (Optional)
What is ? This question helps us to combat spam