MaplePortal/HowDoI - Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : MaplePortal/HowDoI

How Do I...

Go to Maple Portal

 

Maple's Tutorials are designed to help you get started with Maple, learn about the key tools available in Maple, and lead you through a series of problems.

 

The How do I... topics cover essentials for doing mathematics in Maple.  Learn more about Maple's tools and features, such as palettes and context-sensitive menus.  Step-by-step examples are included to enhance your understanding.

 

Refer to Help > Quick Reference for basic getting started tips.

How do I...

...enter a simple expression?

...enter a function?

...enter a matrix?

...evaluate an expression?

...plot a function?

...plot multiple functions?

...plot a straight line?

...enter a complex number?

...select a math style?

...solve an ordinary differential equation?

...work with random generators?

 

Tools and Features

Palettes

Context-Sensitive Menus

Command Completion

Equation Labels

Assistants

Maple Help

Plotting Guide

Applications

Example Worksheets

Manuals

Note for non-Windows users: The keystrokes given in this document are for Windows.  There will be differences for other platforms. If you are using a different platform, see Help > Quick Help for the list of the most common keystrokes.

Tools and Features

This section details the point-and-click tools and core features available in Maple to help you accomplish tasks quickly and easily. These features include palettes, context sensitive menus, and assistants.

Palettes

Maple has over thirty palettes containing an extensive collection of symbols, templates, and other features. These palettes are located beside the Maple workspace.

 

A template is an editable expression containing placeholders that can be easily overwritten. Use the Tab key to move to and highlight the next placeholder in a template, and Shift + Tab to move back to the previous placeholder. The How do I... section contains many examples where a template from a palette is used.

 

• 

The Expression palette contains many common mathematical expressions—such as exponents, subscripts, nth roots, elementary functions, operators, and piecewise functions—as easily editable templates. See the How do I... subsection on entering a simple expression for an example of its use.

 

 

 

The Calculus palette , similar to the Expression palette, contains buttons for constructing expressions—such as integrals, derivatives, dot derivatives, etc.

 

 

• 

The Matrix palette is a tool used to insert a matrix template of a specified size, type, shape, and data type for entering a matrix quickly. See the How do I... subsection on entering a matrix for an example of its use.

 

 

By default, not all palettes are shown; to show a hidden palette, navigate to View → Palettes → Show Palette, and select a palette. Alternatively, navigate to View → Palettes → Arrange Palettes... to show, hide, and rearrange palettes interactively. Note that as more palettes are enabled, you may want to display some palettes to the right of the Maple workspace.

 

Return to the top of the page

Context-Sensitive Menus

One of the most useful features in Maple is the Context-Sensitive Menu, or Context Menu. Together with inline evaluation, the use of Context Menus is one of the fastest ways to perform a string of successive computations.

 

To access the Context Menu menu for a specific Maple object, right-click the object. The Menu will contain common operations associated with the object; for example, the Context Menu for a matrix will include the inverse operation, and for an expression, the Menu will contain the simplify operation.

 

Before you proceed with the example below, be sure to familiarize yourself with entering simple mathematical expressions (see the How do I... subsection on entering a simple expression). Open a new worksheet in Document mode, and ensure that you are in Math mode.

 

Example: simplify and factor

Follow the steps below to simplify and factor the expression sinx2x2+cosx2 x2+2 x+1.

 

Step

Description

Illustration

1

Right-click any part of the expression (within the dotted outline) and a Context Menu is displayed. Select Collect → Name → x.

2

Right-click on the resulting expression and select Simplify>Simplify.

3

Right-click on the resulting expression and select Factor.

Note

If you were working with an equation, some of these functionalities would not be available. Equations cannot be simplified or explicitly differentiated and must therefore first be converted into an expression. To do this, right-click the equation and select Right-hand side.

 

Return to the top of the page

Command Completion

Command and symbol completion is a feature that automatically suggests a command to use as you enter a phrase in Maple. To access the command completion menu, press Esc after typing the phrase. A popup list displays commands that begin with the phrase typed. Maple lists symbols, commands, functions, and package names that match the entered text. To insert an item from this list, select it with the mouse or navigate to it by using the arrow keys and press Enter.

 

For example, to get the Greek letter ρ (rho), type rho and press Esc.  Select ρ.

 

This command completion list can include command completion templates.  These provide the full syntax of common Maple commands including arguments, so that these commands can be easily entered.  Simply choose the desired command completion template and replace the placeholders with the desired values.

 

For example, to get an integral, type int and press Esc.  Select int(definite).

Return to the top of the page

Equation Labels

Equation Labels are automatically generated after executing a Maple command on a new line. The result returned is labeled so that you can refer to it later in the document. As an example, compute the reduced row echelon form of a matrix using equation labels. Maple's equation labels are automatically re-numbered in sequential order if any labeled result is deleted or moved.

 

Before you proceed with the example below, be sure to familiarize yourself with entering simple mathematical expressions (see the How do I... subsection on entering a simple expression). Open a new worksheet in Document mode, and ensure that you are in Math mode.

 

Computing the reduced row echelon form of a matrix

Follow the steps below to find the reduced row echelon form of the three-by-four matrix 12364561578924.

 

Step

Description

Illustration

1

Follow the instructions in either of the two examples given in the How do I subsection on entering matrices. Press Enter, and the resulting Matrix is labeled.

2

Type LinearAlgebra[ReducedRowEchelonForm].

3

Now pass the Matrix as an argument to this procedure by typing a left parenthesis [(], followed by the equation label. To enter the equation label, either press Ctrl + L or select Insert → Label.... Type the label value into the dialogue box; in this case, since it is the first labeled result, the label value is 1. Click OK. Now type a right parenthesis [ ) ].

4

Press Enter. The reduced row echelon form of this Matrix is displayed and labeled.

 

Return to the top of the page

Assistants

Maple has many interactive assistants that provide graphical user interfaces to various Maple packages and functionalities. Here are some of the assistants available in Maple.

 

Back-Solver

Solve for an unknown parameter in an equation whose other parameters are known

Curve Fitting

Compute regressions and fit curves on a collection of data

Data Analysis

Display textual and graphical information about data sets, traverse data sets, and generate new data sets via standard operations on existing ones

Equation Manipulator

Perform a series of operations on an equation

Import Data

Import data from an external file into Maple as an rtable

Installer Builder

Build installers for your own toolboxes, or return a Build command which you can store and execute later

Library Browser

Manipulate the libraries in a specified directory

ODE Analyzer

Investigate and solve ordinary differential equations and ordinary differential equation systems

Optimization

Graphically minimize or maximize an objective function under given constraints

Plot Builder

Build a Maple plot interactively

Scientific Constants

Browse an extensive collection of physical constants and properties of chemical elements

Special Functions

View properties of over 200 special mathematical functions

Thermophysical Properties Calculator

Calculate state-dependent and state-independent properties for pure fluids, mixtures, certain incompressible fluids and the properties of humid air

Units Calculator

Convert between over 500 units of measurement

 

Return to the top of the page

Maple Help

Maple's help system provides extensive help on topics and commands in Maple. Access the help system from the Help > Maple Help menu item or enter a query in the search box in the worksheet toolbar and then press Enter.

 

Tip: You can also put your cursor in a word and press F2 to get help on that word.

Plotting Guide

The Plotting Guide provides a visual guide to Maple's plots and a summary of plotting features.

Applications

The sample application worksheets provide demonstrations of solutions to specific problems.

 

To see a list of applications, from the help table of contents, choose Manuals, Resources, and more > Applications and Examples.

Example Worksheets

Maple provides a number of example worksheets to supplement the examples in the help pages.  Example worksheets demonstrate the syntax of popular commands and packages, such as solve, Calculus, and Linear Algebra, as well as more sophisticated topics such as lexical scoping. You can execute all the commands in the example worksheets.

 

To view a list of example and application worksheets, see the examples index.

Manuals

Access the Maple User Manual and Maple Programming Guide within Maple.

1. 

From the Maple help system, expand the Manuals entry.

2. 

Expand the desired manual, and then select a chapter.

The chapter opens in Maple as a worksheet that you can execute.

Other Resources

The Application Center offers thousands of Maple applications, Maplet applications, tutorials, Maple PowerTools, MapleSim models, and Maple packages for free download.

 

Maple Primes is a web community dedicated to sharing experiences, techniques, and opinions about Maple and related products, as well as general interest topics in math and computing.

 

Return to the top of the page

 

Go to Maple Portal


Download Help Document

Was this information helpful?



Please add your Comment (Optional)
E-mail Address (Optional)
What is ? This question helps us to combat spam