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Preface
Maple Software
MapleTM software is a powerful system that you can use to solve mathematical problems from simple to complex. You can also create professional
quality documents, presentations, and custom interactive computational tools
in the Maple environment.
You can access the power of the Maple computational engine through a
variety of interfaces.
Interface

Description

Standard (default)

A full-featured graphical user interface that helps you create
electronic documents to show all your calculations, assumptions,
and any margin of error in your results. You can also hide the
computations to allow your reader to focus on the problem setup
and final results. The advanced formatting features lets you create
the customized document you need. Because the documents are
live, you can edit the parameters and, with the click of a button,
compute the new results. The Standard interface has two modes:
Document mode and Worksheet mode.

Classic

A basic worksheet environment for older computers with limited
memory. The Classic interface does not offer all of the graphical
user interface features that are available in the Standard interface.
The Classic interface has only one mode, Worksheet mode.

Command-line version A command-line interface for solving very large complex problems
or batch processing with scripts. No graphical user interface features are available.
MapletTM Applications Graphical user interfaces containing windows, textbox regions,
and other visual interfaces, which gives you point-and-click access
to the power of Maple. You can perform calculations and plot
functions without using the worksheet.

ix
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Interface

Description

MaplesoftTM Graphing A graphical calculator interface to the Maple computational engine.
Using it, you can perform simple computations and create customCalculator
izable, zoomable graphs. This is available on Microsoft® Windows® only.

This manual describes how to use the Standard interface. As mentioned, the
Standard interface offers two modes: Document mode and Worksheet mode.
Using either mode, you can create high quality interactive mathematical
documents. Each mode offers the same features and functionality, the only
difference is the default input region of each mode.

Document Mode vs.Worksheet Mode
Before you can begin using Maple, you need to decide if you want to interact
in an interface that hides all commands used to perform calculations by default (Document mode) or to show all commands by default (Worksheet
mode). Regardless of which mode you are working in, you have the opportunity to show or hide your calculations, i.e. you can hide commands in
Worksheet mode by adding a Document Block from the Format menu,
Format → Create Document Block or you can show commands in Document mode by adding a Maple prompt from the Insert menu, Insert → Execution Group → Before / After Cursor.

Document Mode
Document mode uses Document Blocks as the default input region to hide
Maple syntax. The Document Block region is indicated by two triangles
located in the vertical Markers column along the left pane of the Maple
Document,
. If the Markers column is not visible, select View →
Markers. This allows you to focus on the problem instead of the commands
used to solve the problem. For example, when using context menus on Maple
input in Document mode (invoked by right-clicking or Control-clicking for
Macintosh), input and output are connected using an arrow or equal sign

Preface • xi
with self-documenting text indicating the calculation that had taken place.
The command used to solve this expression is hidden.

When starting Standard Maple, the default mode is Document mode.

Worksheet Mode
Worksheet mode uses a Maple prompt as the default input region. The Maple
input prompt is a red greater then symbol where the black square bracket
indicates the full execution region,
. When using content menus on Maple
input in Worksheet mode, all commands are displayed.

To work in Worksheet mode, select File → New → Worksheet Mode.

Math Mode vs. Text Mode
Within each interface mode, you have the choice of entering input using
Math mode or Text mode. Math mode allows you to enter input as 2-D Math
regardless if you are working in Document mode or Worksheet mode. Text
mode is quite different depending on where you are working. Toggling modes
is done using the Text and Math buttons on the toolbar.
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Entry
mode →
Interface
mode ↓

Math mode (default setting)

Text mode

Document •

Input is made at a Document Block •

(default setting)

with slanted cursor,
•

Input is entered using 2-D Math,
•

•

Worksheet •
•

•

Input is made at a Document
Block with vertical cursor,
Input is entered as regular text,

Commands are hidden when using
context menus,

Input is made at an input prompt with (Default setting for earlier versions
of Maple)
a slanted cursor,
• Input is made at an input prompt
Input is entered using 2-D Math,
with a vertical cursor,
•

Input is entered using 1-D Math
and requires a semi-colon or
colon to end your input,

•

Commands display when using
context menus on the expression
output,

Commands display when using context menus,

For more information, see Document Mode vs. Worksheet Mode (page 53).

Preface • xiii

Invoking Context Menus, Command
Completion, and Copy & Drag
This manual will frequently refer to context menus and command completion
when entering expressions. We will also discuss dragging input into another
region by copying the input using a keystroke while dragging. By not using
this keystroke, the input is deleted from the input region. The keyboard keys
used to invoke these features differ based on the operating system you're
using.

Context Menus
•

Right-click, Windows and UNIX®

•

Control-click, Macintosh®

That is, place the mouse over input or output region and press the right button
on the mouse or press and hold the Control key and click the mouse key for
Macintosh.

Command Completion
•

Ctrl + Space or Esc, Windows

•

Command + Shift + Space or Esc, Macintosh

•

Ctrl + Shift + Space or Esc, UNIX

Begin entering a command in a Maple document. Press and hold the Ctrl
key and then press the Space bar for Windows. Press and hold the Command
key, press and hold the Shift key, and then press the Space bar for Macintosh.
Alternatively, press the Esc key. The steps for Macintosh are the same for
UNIX with the exception of pressing the Ctrl key instead of the Command
key.

xiv • Preface

Copy & Drag
•

Ctrl + drag, Windows and UNIX

•

Command + drag, Macintosh

That is, highlight the region you want to copy. Press and hold the Ctrl key
while you drag the input to the new region using the mouse. The steps are
the same for Macintosh with the expression of pressing the Command key.
This manual will only refer to the keyboard keys needed for a Windows
operating system. When working through the examples, use the keyboard
keys needed for your operating system. For more information on Context
Menus and Copy & Drag, see Context Menus and Copy & Drag (page 12).
For more information on Command Completion, see Command Completion (page 46).

In This Manual
This manual provides an introduction to the following Maple features:
•

Ease-of-use when entering and solving problems

•

Point-and-click interaction with various interfaces to help you solve
problems quickly

•

Maple commands and standard math notation

•

Clickable Calculus

•

The help system

•

Accessing resources

The Getting Started Guide was created using the Standard interface to Maple.
An interactive version of this manual is available in the Standard interface.
From the Help menu, select Manuals, Dictionary, and more → Manuals
→ Getting Started Guide. For a complete list of manuals, study guides,
toolboxes, and other resources, visit the Maplesoft Web site at http://www.maplesoft.com
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Audience
The information in this manual is intended for first-time Maple users.

Conventions
This manual uses the following typographical conventions.
•

bold font - Maple command, package name, option name, dialog, menu,
and text field

•

italics - new or important concept

•

Note - additional information relevant to the section

•

Important - information that must be read and followed

Customer Feedback
Maplesoft welcomes your feedback. For suggestions and comments related
to this and other manuals, contact doc@maplesoft.com.
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1 Introduction to Maple
Don't worry about your difficulties in Mathematics. I can assure you
mine are still greater.
~Albert Einstein
Mathematics touches us every day—from the simple chore of calculating
the total cost of our purchases to the complex calculations used to construct
the bridges we travel.
To harness the power of mathematics, Maplesoft provides a tool in an accessible and complete form. That tool is Maple.
In this chapter:
Working in Maple

Describes the capabilities of the Maple Environment.

Starting the Standard Explains what happens the first time you start Maple and shows
Document Interface how to begin a Document.
Entering 2-D Math

Illustrates how to enter an expression in 2-D Math.

Shortcuts for Enter- Provides a table of the common keystrokes when entering 2-D
ing Mathematical
Math.
Expressions
Palettes

Illustrates how to enter a problem using Maple palettes.

Toolbar Icons

Illustrates how to enter text and math on the same line.

Context Menus and Illustrates how to take advantage of Maple's context menus
Copy & Drag
and copy & drag functionality to solve a problem.
Saving a Maple Doc- Explains how to save a Maple document and indicates the file
ument
extension used for Maple documents.

1
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1.1 Working in Maple
With Maple you can create powerful interactive documents. The Maple environment lets you start solving problems right away by entering expressions
in 2-D Math and solving these expressions using point-and-click interfaces.
You can combine text and math in the same line, add tables to organize the
content of your work, or insert images, sketch regions, and spreadsheets.
You can visualize and animate problems in two and three dimensions, format
text for academic papers, or books, and insert hyperlinks to other Maple
files, Web sites, or email addresses. You can embed and program graphical
user interface components, as well as devise custom solutions using the
Maple programming language.

Figure 1.1: The Maple Environment
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1.2 Starting the Standard Document
Interface
To start Maple on:
Windows

From the Start menu, select All Programs → Maple 12 → Maple 12.
Alternatively:
Double-click the Maple desktop icon.

Macintosh

1. From the Finder, select Applications and Maple 12.
2. Double-click Maple 12.

UNIX

Enter the full path, for example, /usr/local/maple/bin/xmaple
Alternatively:
1. Add the Maple directory (for example, /usr/local/maple/bin) to your
command search path.
2. Enter xmaple.

The first Maple session opens with a Startup dialog explaining the difference
between Document Mode and Worksheet Mode. Using either mode, you can
create high quality interactive mathematical documents. Each mode offers
the same features and functionality, the only difference is the input region
of each mode.
Document Mode - The default input region is a Document Block. Document
Blocks hide Maple syntax allowing you to focus on the problem instead of
the commands used to solve the problem.
Worksheet Mode - The default input region is a Maple input prompt where
all commands are displayed.
Regardless of which mode you are working in, you have the opportunity to
show or hide your calculations.
This guide discusses features common to Document mode. Instructions for
using Worksheet mode are provided in the section, Document Mode vs.
Worksheet Mode (page 53).
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The Startup dialog also contains links to items, such as various document
options, help resources including updates and other introductory help pages,
and application resources on the Maplesoft Web site. Subsequent sessions
display Tip of the Day information.
To start a Maple session in Document Mode:
1. In the Startup dialog, select Blank Document. A blank document displays.
or
1. Close the Startup dialog.
2. From the File menu, select New, and then Document Mode. A blank
document displays.
In subsequent sessions, Maple starts in Document mode. Every time you
open a document, Maple displays a Quick Help pop-up list of important
shortcut keys. To invoke Quick Help at any time, press the F1 key.

1.3 Entering 2-D Math
In Maple, the default behaviour to enter mathematical expressions is in 2-D
Math. This results in mathematical expressions that are equivalent to the
quality of math found in textbooks. Entering 2-D Math in Maple is done
using common key strokes or palette items. For more information on palettes,
see Palettes (page 8). An example of entering an expression using common
key strokes is presented in the following section. An example of entering an
expression using palette items is presented in Example 2 - Enter an Expression Using Palettes (page 8).

1.3 Entering 2-D Math
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Example 1 - Enter and Evaluate an Expression
Using Keystrokes
Review the following example:
=

In this example, we will enter

and evaluate the expression.

Action
To enter the expression:
1. Enter (x.
2. Press Shift + 6 (the ^ or caret key). The cursor moves to the
superscript position.
3. Enter 2.
4. Press the right arrow key. The cursor moves right and out of
the superscript position.
5. Enter the + symbol.
6. Enter y.
7. Press Shift + 6 to move to the superscript position.
8. Enter 2 and press the right arrow key.
9. Enter ) to close the parenthesis.
10. Enter the / symbol. The cursor moves to the denominator.

Result in Document
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Action

Result in Document

11. Enter 2.

12. Press the right arrow key to move right and out of the denominator position.
To evaluate the expression and display the result inline:
13. Press Ctrl + = (Command + = for Macintosh).

=

To execute 2-D Math, you can use any of the following methods.
•

Pressing Ctrl + = (Command + =, for Macintosh). That is, press and
hold the Ctrl (or Command) key, and then press the equal sign (=) key.
This evaluates and displays results inline.

•

Pressing the Enter key. This evaluates and displays results on the next
line and centered.

•

Right-click (Control-click for Macintosh) the input to invoke a context
menu item. From the context menu, select Evaluate and Display Inline.
See Context Menus and Copy & Drag (page 12) for more details.

•

Using the context-menu item Evaluate.

1.4 Shortcuts for Entering Mathematical Expressions
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1.4 Shortcuts for Entering Mathematical Expressions
Table 1.1: Common Keystrokes for Entering Symbols and Formats
Symbol/Formats

Key

implicit multiplication

Space key

explicit multiplication

* (asterisk)

fraction

/ (forward slash)

exponent (superscript)

^ (Shift + 6 or caret key)

subscript

_ (Shift + underscore )

navigating expressions

Arrow keys

command / symbol com- •

Ctrl + Space, Windows

pletion

•

Esc, Macintosh

•

Ctrl + Shift + Space, UNIX

square root

sqrt then command completion

exponential function

exp then command completion

enter / exit 2-D Math

Math and Text icons in the toolbar

Example

versus 1/4

required for products of numbers
use right arrow key to leave denominator, superscript, or subscript region
for more information, see Command Completion (page 46).
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1.5 Palettes
Palettes are collections of related items that you can insert into a document
by clicking or drag-and-dropping. The Maple environment provides access
to over 20 palettes containing items such as symbols
, layouts
mathematical operations

and much more. For more in-

formation on the available palettes, see Palettes (page 37).
By default, palettes are displayed in the left pane of the Maple environment
when you launch Maple. If the palettes are not displayed,
1. From the View menu, select Palettes.
2. Select Expand Docks.
3. Right-click (Control-click, for Macintosh) the palette dock. From the
context menu, select Show All Palettes.
Alternatively, from the main menu, select View → Palettes → Arrange
Palettes to display specific palettes.

Example 2 - Enter an Expression Using Palettes
Review the following example:

=

In this example, we will enter

and evaluate the expression.

1.5 Palettes
Action
1. In the Expression palette, click the summation

template
. Maple inserts the summation
symbol with the range placeholder highlighted.
2. Enter i and then press Tab. The left endpoint
placeholder is selected. Notice that the color of the
range placeholder has changed. Each placeholder
must have an assigned value before you execute
the expression, i.e. all placeholders will display in
black font. The Tab key advances you through the
placeholders of an inserted palette item.
3. Enter 1 and then press Tab. The right endpoint
placeholder is selected.

4. Enter 10 and then press Tab. The expression
placeholder is selected.

5. Enter

6. Press Ctrl + = (Command + = for Macintosh)
to evaluate the summation.

Result in Document

• 9
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1.6 Toolbar Icons
Using Maple, you can enter math and text on the same line with the Text
and Math icons on the toolbar. See Figure 1.2. When the Text icon is selected, you can enter text and format it using the available tools. If you then
select the Math icon, you change the mode to allow entry of 2-D Math. The
same formatting options are available when the Math icon is selected.

Figure 1.2: Icons for Text and Math Entry Mode

Example 3 - Enter Text and 2-D Math in the Same
Line Using Toolbar Icons
Review the following example:
Evaluate
Action
To enter this sentence:
1. Select the Text icon and enter Evaluate.

2. Select the Math icon.
3. From the Expression palette, select the

definite integration template,
. The
expression is displayed with the first placeholder highlighted.

Result in Document
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Action

Result in Document

4. With the first placeholder highlighted,
enter 1.
5. Press Tab and enter 5.
6. Press Tab to highlight the integrand region.
7. Enter (3x^2 and press the right arrow to
leave the superscript position.
8. Enter + 2.

9. Press the Space bar for implicit multiplication. Enter sqrt and press Ctrl + Space to
show the command completion options.
Maple displays a pop-up list of exact
matches. Select the square root symbol,

.

Maple inserts the symbol with the x placeholder selected. You can also select the
square root symbol from the Expression
palette.
10. Enter x.
11. Press the right arrow to leave the square
root region
12. Enter +3.
13. Press the Space bar.
14. Select the n-th root symbol from the
Expression palette

.

15. Enter 3.
16. Press the Tab key and enter x).
17. Press the Tab key and enter x for the integration variable.
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1.7 Context Menus and Copy & Drag
Context Menus
Maple dynamically generates a context menu of applicable options when
you right-click an object, expression, or region. The actions available in the
context menu depend on the selected input region. For example, you can
manipulate and graph expressions, enhance plots, format text, manage
palettes, structure tables, and more. When using context menus to perform
an action on an expression, the input and output are connected with a selfdocumenting arrow or equal sign indicating the action that had taken place.
For more information, see Context Menus (page 32).

Copy & Drag
To save time entering information, Maple has the ability to drag input into
a new input region. This is done by highlighting the input and dragging it
with your mouse into a new input region. Dragging the highlighted region
will cut or delete the original input. To prevent this, press and hold the Ctrl
key and then the drag the input. This makes a copy of the highlighted region.

Example 4 - Solve and Plot an Equation Using
Context Menus and Copy & Drag
Review the following example:

In this example, we will enter the equation and then solve and plot the
equation using context menus and Maple's copy & drag feature. This example
will only refer to the keystrokes needed on a Windows operating system to
invoke the context menus and the copy & drag feature. For your operating
system, refer to section Invoking Context Menus, Command Completion,
and Copy & Drag (page xiii) for the equivalent keystrokes.
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To solve the equation:
1. Enter the equation.
2. Right-click the equation and select Move to Left.
Input:

Result:

A brief description, "move to left" is placed above the arrow connecting the input and
output.
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3. Right-click the output from the previous action,
Input:

Result:

and select Left-hand Side.
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4. Right-click the new output,
Input:

Result:

and select Solve → Isolate Expression for → x.
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Now that we have solved the equation, we can plot it. To do this, we will copy the expression
to a new Document Block and use context menus once again.
5. From the Format menu, select Create Document Block.
6. To copy the expression

, highlight only this expression from the previous result.

Press and hold the Ctrl key and drag the expression to the new document block region.
Result:
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To plot the expression:
7. Right-click the expression and select Plots → 2-D Plot.
Input:
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Result:

1.8 Saving a Maple Document
To save these examples you created, from the File menu, select Save. Maple
documents are saved as .mw files.

2 Point-and-Click Interaction
Maple contains many built-in features that allow you to solve problems
quickly without having to know any commands.
In this chapter:
Assistants

Interactive tools that help you accomplish many specialized tasks,
such as solving ODEs and ODE systems, creating plots and
matrices, calculating optimization problems, performing unit
conversions, and more.

Tutors

Interactive tools that aid in the learning of precalculus, calculus,
multivariate calculus, vector calculus, differential equations, and
linear algebra concepts.

Context Menus

Context menus to manipulate expressions, plot regions, text regions, and objects easily.

Task Templates

Templates to help you learn how to perform mathematical computations, construct Maple objects, and create a detailed Maple
document.

Palettes

A collection of templates representing items such as predefined
symbols, expressions, operators, and matrices.

19
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2.1 Assistants
Maple offers a set of assistants in the form of graphical user interfaces to
perform many tasks without you needing to use any syntax. An example of
an assistant is shown in Figure 2.1.

Figure 2.2: Optimization Assistant

Using the Tools → Assistants menu, you can access tools to help you accomplish these various tasks. See Figure 2.2. In some cases, you can launch
the assistants by entering an expression and selecting the assistants from the
context menu that displays.
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Figure 2.2: Accessing the Assistants from the Tools Menu

Plot Builder
The Plot Builder is a point-and-click interface to the Maple plotting functionality. The interface displays plot types based on the expression you specify. The available plot types include plots, interactive plots, animations, or
interactive animations. Depending on the plot type you enter, you can create:
•

2-D / 3-D plot

•

2-D polar plot

•

2-D / 3-D conformal plot of a complex-valued function

•

2-D / 3-D complex plot

•

2-D density plot

•

2-D gradient vector-field plot

•

2-D implicit plot
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Using the Plot Builder, you can:
(1) Specify the plotting domain before you display the graph
(2) Specify the endpoints of the graph as symbolic, for example, Pi, sqrt(2)
(3) Apply plot options using drop-down menus.
The output from the Plot Builder is a plot of the expression or the command
used to generate the plot. Figure 2.3 - 2.5 shows three of the main dialogs
in the Plot Builder.

Figure 2.3: Specify Expressions

Figure 2.4: Select Plot Type

2.1 Assistants • 23

Figure 2.3: Specify Expressions dialog allows you to add, edit, or remove expressions
and variables.
Figure 2.4: Select Plot Type dialog allows
you to select the plot type and corresponding
plot, and edit the ranges.
Figure 2.5: Plot Options dialog allows you
to apply plot options.

Figure 2.5: Plot Options

Example 1- Plot an Expression Using the Interactive Plot Builder
Review the following example:
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In this example, we will use the Plot Builder to plot the expression
and apply the following plot options:
•

change the default

-axis range

•

change the thickness of the line

•

change the color of the line

•

apply gridlines

•
Launch the Plot Builder and add the expression:
1. From the Tools menu, select Assistant → Plot Builder. The Specify Expressions dialog
displays. See Figure 2.3.
2. In the Expressions region, click Add.
3. In the Add/Edit Expression dialog, enter sin(x)/x and click Accept. Select a plot type
and change the default x-axis range:
4. Click OK and the Select Plot Type dialog displays. See Figure 2.4. Alternatively, you
could have entered the expression and used the context menus to launch the Plot Builder
by selecting Plots → Plot Builder. See Figure 2.6. This will launch the Plot Builder and
automatically insert the expression.

Figure 2.6: Using Context Menus to launch the Plot Builder
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5. From the Select Plot Type dialog, you can edit or add functions, select a plot type,
change the -axis range, or even preview the plot with the current default settings. With
2-D Plot selected, change the

-axis range to span from -25 to 25.

Change the plot options:
6. To edit the plot options, click Options. The 2-D Plot (plot) dialog displays. Refer to 2D Plot Options Available in the Plot Builder (page 27) for more information on each plot
option available in this dialog.
7. Before we change any options, click Preview to display the plot with the current default
options. Use this feature after applying each plot option described in the following steps
to see how the curve has changed.
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8. Click Done to return to the 2-D Plot (plot) dialog.
7. To change the thickness of the line, from the Line region, select thick from the right
drop-down menu.
10. To change the color of the expression, from the Color region, select Blue from the
drop down menu. Notice that the color swatch below the drop-down menu now shows
blue.
11. To alter the axes settings, in the Axes region, click Advanced Settings.
12. In the

-axis row, select 50 from the Gridlines drop-down menu. In the Major

Gridlines drop-down menu, select 5. In the second row, select 10 from the Gridlines dropdown menu and select 5 from the Major Gridlines drop-down menu.

13. Click Apply to apply this setting and return to the 2-D Plot (plot) dialog.
14. To close the Plot Builder and return the plot to the document, in the 2-D Plot (plot)
dialog, click Plot.
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2-D Plot Options Available in the Plot Builder
Table 2.1: 2-D Plot Options Available in the Plot Builder
Plot option

Description

expression(s)

Using the Plot Builder, you can plot multiple expressions in the same
plot region. To apply different options for each line, you would select
an expression from the drop-down menu and apply the line style settings.
You would do this for each line. In the previous example, only one expression is available.

-axis

To edit the

-axis range, you need to click the Back button to return

to the Select Plot Type dialog. In the 2-D Plot options dialog, you can
change the -axis label and orientation of the label by altering the default entries for the
-axis

To edit the

-axis row.

-axis range, enter a range, label, and orientation in the

row beginning with Range from.
Style

Specifies the line style, one of line or point. The default setting is line.

Line

Line style and size options available when Style is set to line.

Symbol

Symbol style and size options available when Style is set to point.
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Plot option

Description

Color

Select a color from the drop down menu or click Custom to select a
color from the color dialog.

Axes

Select from the axes styles available, edit the style of the axes labels or
apply advanced axis options such as gridlines by clicking Advanced
Settings.

View

Constrained or non-constrained view. The default setting is non-constrained.

Title

Adds a title to the plot and allows you to alter the font style.

Caption

Adds a legend to the plot and allows you to alter the font style.

Resolution

Sets the horizontal display resolution of the device in pixels. The default
is 200.

Adaptive Plotting

When plotting a function over an interval, the interval is sampled at a
number of points, controlled by sample and numpoints. Adaptive plotting, where necessary, subdivides these intervals to attempt to get a
better representation of the function.

Find Discontinu- Determines the discontinuities of the input and then breaks the horizontal
ities
axis into appropriate intervals where the expression is either continuous
or contains only removable discontinuities.
Number of
Points

Specifies the minimum number of points to be generated. The default
is 50.

Fill to

Fills the region between the curve and the

-axis

-axis.

Coordinate Sys- Select from the coordinate systems available.
tem

Descriptions of Assistants
The remaining Assistants are described below. Some of the Assistants are
interfaces to package commands. For more information on package commands, see Package Commands (page 45).
•

Back-Solver - an interface that allows you to take a mathematical formula, involving multiple parameters, enter values for all but one of the
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parameters and solve for the remaining value. You can also plot the behaviour of the formula as one of the parameters change.
•

Curve Fitting - an interface to commands in the CurveFitting package.
Data points can be entered as independent and dependent values, and
interpolated with polynomials, rational functions, or splines.

•

Data Analysis - an interface to the data analysis commands in the Statistics package.

•

Import Data - an interface to read data from an external file into Maple.

•

Installer Builder - an interface to the InstallerBuilder package in which
you can create installers for your Maple toolboxes. For information on
toolboxes, go to http://www.maplesoft.com/developers/index.aspx.

•

Library Browser - an interface to manipulate the libraries in a specified
directory.

•

Maplet Builder - an interface to the Maplets package. The Maplets
package contains commands for creating and displaying Maplet applications (point-and-click interfaces). Using the Maplet Builder, you can
define the layout of a Maplet, drag-and-drop elements (visual and functional components of Maplets), set actions associated with elements, and
directly run a Maplet application. The Maplet Builder is available in the
Standard interface only.

•

ODE Analyzer - an interface to obtain numeric or symbolic solutions
to a single ODE or a system of ODEs and plot a solution of the result.

•

Optimization - an interface to the solver commands in the Optimization
package. The Optimization package is a collection of commands for
numerically solving optimization problems, which involves finding the
minimum or maximum of an objective function possibly subject to constraints.

•

Plot Builder - an interface for creating two and three-dimensional plots,
animations, and interactive plots.

•

Scientific Constants - an interface to over 20 000 values of physical
constants and properties of chemical elements. All of these constants
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come with the corresponding unit and, if applicable, with the uncertainty
or error, that is, how precisely the value of this constant is known.
•

Special Functions - an interface to the properties of over 200 special
functions, including the Hypergeometric, Bessel, Mathieu, Heun and
Legendre families of functions.

•

Units Calculator - an interface to convert between 500 units of measurement.

2.2 Tutors
Maple provides over 40 interactive tutors to aid in the learning of
•

Precalculus

•

Calculus

•

Multivariate Calculus

•

Vector Calculus

•

Differential Equations

•

Linear Algebra

These tutors are easily accessible by selecting Tools → Tutors. See Figure
2.7.
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Figure 2.7: Accessing Tutors from the Tools Menu

Some of the tutors are also accessed through the Student package. The
Differential Equations tutor, DE Plots, is accessible through the DEtools
package. For a definition of the term package, see Package Commands (page 45).
The Student package is a collection of subpackages designed to assist with
the teaching and learning of standard undergraduate mathematics. The subpackages contain many commands for displaying functions, computations,
and theorems in various ways, and support for stepping through important
computations.
•

The visualization commands are tools that create plots and animations
showing the geometric interpretation of important concepts.

•

The computation commands help you to study the techniques of computation while solving problems. For example, using the Calculus1 package,
you can differentiate a function one step at a time by specifying the
needed differentiation rule applied at each step. At any time during a
single-step computation, you can request a hint about the next step, which
you can then apply to the problem, or you can proceed directly to the final
answer.
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•

The interactive commands help you explore concepts and solve problems
using a point-and-click interface. These commands launch tutors that
provide a graphical interface to visualization and computation commands
described above. See Figure 2.8 for an example of one of the interactive
commands.

Figure 2.8: Calculus - Single Variable → Differentiation Methods Tutor

2.3 Context Menus
A context menu is a dynamically generated menu of actions that are applicable for the region upon which it is invoked. Context menus allow you to
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perform calculations and manipulations on expressions without using Maple
syntax. To display a context menu, right-click an object, expression, or region.
Context menus are available for many input regions including:
•

expressions to perform calculations, manipulations, or plotting

•

plot regions to apply plot options and manipulate the plot

•

tables to modify the table properties

•

palette regions to add or remove palettes and palette regions

•

text regions to add annotations and format text

•

spreadsheets to manipulate the spreadsheet

When performing calculations or manipulations on an expression, a selfdocumenting arrow or equal sign connects the input and output indicating
the action that took place. See Figure 2.9 and 2.10 for two examples of
context menus.
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Figure 2.9: Right-click the expression to Figure 2.10: Right-click the plot to see a
see a menu of applicable options.
menu of plot options.

2.4 Task Templates
Task templates help you perform specific tasks in Maple, such as:
•

performing a mathematical computation such as solving an equation
symbolically or numerically, or determining the Taylor approximation
of a function of one variable

•

constructing a Maple object such as a function

•

creating a document such as an application

Each task contains a description along with a collection of content that you
can directly insert into your document. Content consists of 2-D mathematics,
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commands, embedded components (for example, buttons) and plots. You
need to specify the parameters of your problem and then run the document.
See Figure 2.11 for an example of a Task Template.

Figure 2.11 Browse Tasks Dialog

Previewing Tasks
To preview Maple tasks,
•

From the Tools menu, select Tasks, and then Browse. The Browse
Tasks dialog opens and displays the list of tasks.
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The tasks are sorted by subject to help you quickly find the desired task. In
the Browse Tasks dialog, you can view tasks without inserting them into
your document.

Inserting a Task into the Document
To insert a task into your document,
1. Select the Insert into New Worksheet check box to insert the task into
a new document.
2. Click Insert Default Content or Insert Minimal Content.
•

Default content includes the task title and description.

•

Minimal content inserts only the major components (commands and
buttons).

Note: You can view the history of previously inserted tasks. From the Tools
menu, select Tasks. Previously selected task names are displayed below
the Browse menu item.
Before inserting a task, Maple checks whether the task variables have assigned values in your document. If any task variable is assigned, the Task
Variables dialog opens to allow you to modify the names. Maple uses the
edited variable names for all variable instances in the inserted task.
By default, the Task Variables dialog is displayed only if there is a naming
conflict. You can set it to display every time you insert a task.
To specify that the Task Variables dialog be displayed every time you
insert a task:
1. From the Tools menu, select Options.
2. Click the Display tab.
3. In the Show task variables on insert drop-down list, select Always.
4. Click Apply to Session, or Apply Globally, as necessary.
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Updating Parameters and Running the Commands
In inserted Task Templates, parameters are marked as placeholders or specified using sliders or other embedded components. Update the parameter
values as required.
Note: To navigate between placeholders in the document, press the Tab key.
After updating any parameters, execute the commands or click the buttons.

2.5 Palettes
The Maple document environment provides access to over 20 palettes.
Palettes are collections of related items that you can insert by clicking or
drag-and-dropping into a document. Palettes contain:
•

Symbols such as π, ∞, and ∇

•

Layouts such as an item with a superscript

•

Mathematical operations such as a definite integral with placeholders
for the integrand, variable of integration, and endpoints of the interval

and subscript

of integration
You can create a Favorites palette of the expressions and entities you use
often by right-clicking (Control-click for Macintosh) the palette template
you want to add and selecting Add To Favourites Palette from the context
menu.
The Handwriting palette provides another way to find and insert desired
symbols easily. Draw the symbol with your mouse in the space provided
and then click
. Maple matches your input against symbols
available in the system. See Figure 2.12.
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Figure 2.12: Handwriting Palette

By default, palettes display in palette docks at the right and left sides of the
Maple window. To view and manage palettes and palette docks, see Table
2.2.
Table 2.2: Managing Palettes
To view palette docks:
From the View menu, select Palettes, and then
Expand Docks.

2.5 Palettes
To add a palette:
1. Right-click the palette dock. Maple displays
a context menu near the palette.
2. From the context menu, select Show Palette
and then select the palette.

To expand a palette in a palette dock:
Click the triangle at the left of the palette title.
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To move a palette in a palette dock:
Move the palette by clicking the title and
dragging the palette to the new location.

To expand/collapse the palette docks:
Select the appropriate triangle at the top right
or top left side of the palette region.
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Table 2.3: Palette Categories
Palette Category

Palette Description

Expression Palettes

Expression - a palette for constructing expressions such as integrals
.
Matrix - a palette allowing you to enter the number of rows
and columns required, designate type, such as zero-filled, and
designate shape, such as diagonal.
Layout - a palette that allows you to add math content that has
specific layout, such as expressions with one or more superscripts and subscripts
.
Components - a palette that allows you to embed graphical interface components such as a button into your document or
worksheet. Components can be programmed to perform an action when selected such as executing a command when clicking
a button
.
Handwriting - a palette that provides an easy way to find a
desired symbol.
Units (SI) - a palette that inserts a unit from the International
System of Units (SI), or any general unit
.
Units (FPS) - a palette that inserts a unit from the Foot-PoundSecond System (FPS), or any general unit
.
Accents - a palette that allows you to insert decorated names
such as an

with an arrow over it to denote a vector

.

Favorites - an empty palette where you can add templates that
you use most often from other palettes.

42 • 2 Point-and-Click Interaction
Palette Category

Palette Description

Mathematical Palettes

Palettes for constructing expressions
Common Symbols, Relational
Operators

, Relational Round

, Large Operators

, Negated

,

, Fenced

, Arrows , Constants and Symbols .
Punctuation - a palette of punctuation symbols such as the registered trademark symbols
for inserting into text regions
Miscellaneous - a palette of miscellaneous math and other
symbols outside the above categories

Alphabetical Palettes

Greek, Script

, Fraktur

Diacritical Marks

.

, Open Face

, Cyrillic

, Roman Extended Upper Case

Roman Extended Lower Case

.

,
,

3 Commands
Even though Maple comes with many features to solve problems and manipulate results without entering any commands, you may find that you prefer
greater control and flexibility by using the set of commands and programming
language that Maple offers.
In this chapter:
The Maple Library

Explains the structure of the commands in the Maple
system and provides resources for learning Maple
commands.

Entering Commands

Provides examples of entering top-level commands
and package commands, and explains the benefits of
using equation labels and command completion.

Accessing Help with Commands and Packages

Explains one of the main resources available when
learning Maple commands.

Viewing Maple Code in Doc- Explains how to view the Maple code hidden in Docuument Mode
ment blocks.
Document Mode versus
Worksheet Mode

Explains the Worksheet mode and how it differs from
Document mode.

Math Mode versus Text
Mode

Compares Math mode and Text mode forms of entering
information in Maple.

Maple Toolbar Options

Describes the Maple toolbar options.

Top Packages and Commands Provides a list of the top packages and commands in
Maple.
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3.1 The Maple Library
Commands are contained in the Maple library, which is divided into two
groups: the main library and packages.
•

The main library contains the most frequently used Maple commands.

•

Packages contain related commands for performing tasks from disciplines
such as Student Calculus, Statistics, or General Relativity Theory. For
example, the Optimization package contains commands for numerically
solving optimization problems.

3.2 Entering Commands
If you want to interact with Maple using commands, simply enter the command using 2-D math. You will notice that commands and variable names
display in italics. Maple commands are constructed in a format similar to
command(arguments) based on the command you are using.
To factor an expression, enter:

To differentiate an expression, enter:
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To integrate an expression in the range [

enter:

To plot an expression, enter:

For a list of the top commands in Maple, see Top Commands and Packages (page 61).

Package Commands
There are two ways to access commands within a package, using the long
form of the package command or the short form.
Long Form of Accessing Package Commands
The long form specifies both the package and command names using the
syntax package[command](arguments).
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Short Form of Accessing Package Commands
The short form loads all of the commands in the package using the with
command, with(package). If you are using a number of commands in a
package, loading the entire package is recommended. Using the with command, a list of all commands in the package displays. To suppress the display
of all command names, end the with(package) command with a colon. Alternatively, you can load packages through Tools → Load Package.

After loading a package, you can use the short-form names, that is, the
command names, without the package name.

For a list of the top packages in Maple, see Top Commands and Packages (page 61).

Command Completion
To help with syntax and reduce the amount of typing when entering Maple
commands, you can use command completion. Command completion displays
a list of all Maple packages, commands, and functions that match the entered
text.
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To use command completion:
1. Begin entering a command or package name.
2. Select Tools → Complete Command or use short cut keys:
•

Ctrl + Space or Esc, Windows

•

Command + Shift + Space or Esc, Macintosh

•

Ctrl + Shift + Space or Esc, UNIX

If there is a unique completion, it is inserted. Otherwise, a list of matches is
displayed.
3. Select the correct completion from the list.

Equation Labels
Equation labels help to save time entering expressions by referencing Maple
output. The label is associated with all output within an execution group.
See Figure 3.1 and 3.2. You cannot apply equation labels to the following:
•

Error, warning, and information messages

•

Tables, images, plots, sketches, or spreadsheets

By default, equation labels are displayed. If equation labels are not displayed,
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1. From the Tools menu, select Options, and click the Display tab. Ensure
that the Show equation labels check box is selected.
2. From the Format menu, select Labels. Ensure that Execution Group is
selected.

Figure 3.1: Inserting an Equation Label

Figure 3.2: Equation Label

To apply equation labels:
1. Enter an expression and press Enter. Note that the equation label is displayed to the right of the answer in the document.
2. In a new execution group, enter another expression that will reference the
output of the previous execution group.
3. From the Insert menu, select Label. Alternatively, press Ctrl+L (Command+L, for Macintosh) to open the Insert Label dialog. Enter the label
number in the Insert Label dialog and click OK. The item is now a label.
4. Press Enter to obtain the result.
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To change the format of equation labels:
•

Select Format → Labels → Label Display. In the Format Labels dialog, select one of the numbering schemes.

•

Optionally, enter an appropriate numbering prefix.

Figure 3.3: Format Labels Dialog: Adding a Prefix

The Label Reference menu item allows you to switch between the label
name and its reference content. Place the cursor on the referenced equation
label and select Format → Labels → Label Reference.

Figure 3.4: Label Reference
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3.3 Accessing Help with Commands
and Packages
Most command names in Maple are quite intuitive, but if you are unable to
determine the command or proper syntax you need, you can search the Maple
help system. The Maple help system is complete with help pages for every
command available, along with tours, examples, and a mathematical dictionary. Each help page contains the correct syntax for a command: calling sequences, parameters, and description of use. See Figure 3.5. Examples and
links to related subjects are provided at the bottom of each help page.
To launch the Help browser:
1. You can launch the Maple help browswer in three ways:
•

From the Help menu in your worksheet, select Maple Help

•

Click

•

In the document or worksheet, enter ?topicname. For example, enter
?LinearAlgebra and then press Enter.

in the toolbar

To search the help system:
2. In the left pane, enter a search string in the text region provided.
3. By default, a topic search is performed. To perform a text search, select
the Text radio button. For more information on topic searches, see Using
the Help Navigator (page 67).
4. Enter the term and click Search.
5. The left pane is populated with matches to your search term in the Search
Results tab. With text searches, the help page with the highest number of
instances that term appears in the help page displays first followed by the
second highest and so forth.

3.4 Viewing Maple Code in Document Mode
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For more information on the Maple Help system, see The Maple Help System (page 65).

Figure 3.5: Search Results for Optimization

3.4 Viewing Maple Code in Document
Mode
In Document mode, content is created as a series of document blocks. Document blocks allow you to hide the syntax used to perform calculations,
which in turn lets you focus on the concept presented instead of the command
used to manipulate or solve the problem. Document blocks are typically
collapsed to hide the Maple code, but these regions can also be expanded to
reveal this code.
Document block regions are identified using markers that are located in a
vertical bar along the left pane of the document. See Figure 3.6. In addition
to document block boundaries, these markers (icons) indicate the presence
of hidden attributes in the document such as annotations, bookmarks, and
numeric formatting.
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To activate markers:
From the View menu, select Markers. See Figure 3.6.

Figure 3.6: Document Block Markers

To view code in Document mode:
1. Place the cursor in a document block to be expanded.
2. From the View menu, select Expand Document Block.

Figure 3.7: Expanded Document Block

With the Document Block expanded, you can see the Maple command that
was used to perform this calculation. In Figure 3.7, the solve command was
used.
You will also notice a red prompt ( > ) before the original expression and
the solve command. Entering commands outside of a document block region
is done at this input region. To insert an input region, click the
button in
the toolbar menu.
In Figure 3.7, an equation label was used to refer to the expression. For more
information, see Equation Labels (page 47).

3.5 Document Mode vs. Worksheet Mode
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To collapse a Document Block:
With your cursor inside the document block, select View → Collapse Document Block.
You can use this process of expanding document blocks to begin learning
Maple commands.

3.5 Document Mode vs. Worksheet
Mode
Worksheet Mode and Document Mode are identical in the functionality that
they both offer; therefore in each mode context menus and palettes are
available when entering expressions; tables, spreadsheets, and images can
be inserted; and access to the complete Maple library is available. You can
even insert a document block while in Worksheet mode or insert a Maple
prompt while in Document Mode. The only difference between the two
modes is the default input format.
Table 3.1: Worksheet Mode vs. Document Mode
Document Mode

Worksheet Mode

To start a document session:
To start a worksheet session:
From the File menu, select New, and then From the File menu, select New, and then
Document Mode.
Worksheet Mode.
Default input region is a document block. Default input region is a Maple input prompt.

Syntax is hidden when using context
menus.

Syntax is displayed when using context menus.
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Document Mode

Worksheet Mode

Context menus offer an option to evaluate
and display an expression inline. All other
context menu options are identical when
using context menus in Worksheet Mode.

Context menus do not offer an option to evaluate and display an expression inline. All other
context menu options are identical when using
context menus in Document Mode.
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3.6 Math Mode vs. Text Mode
The default mode of entry in Document or Worksheet mode is Math Mode
which displays input in 2-D Math. In earlier releases of Maple, commands
and expressions were entered using Maple Input or 1-D Math.
Important: With Maple Input, you must terminate commands with a semicolon or colon.
> cos(alpha)^2+sin(alpha)^2;

> a*int(exp(sqrt(2)*x),x);

> limit(f(x),x=infinity);

> sum(a[k]*x^k, k=0..m)=product(b[j]*x^j, j=0..n);

To enter input using Maple Input mode, insert a Maple prompt by clicking
in the toolbar and then click the Text button in the toolbar,

.
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Table 3.2: Math Mode vs. Text Mode
Math Mode

Text Mode*

Maple's default setting. Executable standard Executable Maple notation. This is also remath notation. This is also referred to as 2- ferred to as 1-D Math Input or Maple Input.
D Math Input.

Access from the Insert → 2-D Math menu. Access from the Insert → Maple Input
menu.
When using 2-D Math, the Math mode icon When entering Maple Input or text in a text
region, the Text mode icon is highlighted in
is highlighted in the toolbar.
the toolbar.
To convert a 2-D Math expression to 1-D
Math, right-click the expression (Command-click for Macintosh) and select 2-D
Math → Convert To → 1-D Math Input.

To convert a 1-D Math expression to 2-D
Math, right-click the expression (Commandclick for Macintosh) and select Convert To
→ 2-D Math Input.

No termination symbol is required.

All input must end with a semi-colon ( ; ) or
a colon ( : ).

If you are a new Maple user, palettes make Using palettes while in 1-D Math teaches you
entering expressions in familiar notation
the related Maple command syntax.
easier than entering foreign syntax and reduces the possibility of introducing typing
errors.

* In a Document Block, Text Mode displays regular text.
If you prefer 1-D Math input, you can change the default math input notation.

3.7 Maple Toolbar Options • 57
To change math input notation for a session or globally across all documents:
1. From the Tools menu, select Options. The Options Dialog opens.
2. Click the Display tab.
3. In the Input Display drop-down list, select Maple Notation.
4. Click the Apply to Session or Apply Globally button.
Important: The new input display becomes the default setting after selecting
the Enter key.

3.7 Maple Toolbar Options
The Maple toolbar offers several buttons to assist you when interacting with
Maple. See Table 3.3.
Table 3.3: Maple Toolbar Options
Basic Usage

Icon

Equivalent Menu Option or Command

Insert Plain Text after the current
execution group.

From the Insert menu, select Text.

Insert Maple Input after the current execution group.

From the Insert menu, select Execution
Group and then After Cursor.

Enclose the selection in a subsection.

From the Format menu, select Indent.

Remove any section enclosing
the selection.

From the Format menu, select Outdent.

Executes all commands in the
worksheet or document

From the Edit menu, select Execute and
then Worksheet.

Executes a selected area.

From the Edit menu, select Execute and
then Selection.
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Basic Usage

Icon

Equivalent Menu Option or Command

Causes Maple to clear its internal memory.

Enter restart.

Adjusts the display size of document content. Note: plots,
spreadsheets, images, and
sketches remain unchanged.

From the View menu, select Zoom Factor
and then a zoom size.

Opens the Maple help system.

From the Help menu, select Maple Help.

For 1-D Math and text regions, the Tab icon in the toolbar allows you to set
the Tab key to move between placeholders or to indent text.
Table 3.4: Tab Icon Description
Tab Icon

Description
Tab icon off. Allows you to move between placeholders using the Tab
key.
Tab icon on. Allows you to indent in the worksheet using the Tab key.
The Tab icon is disabled when using 2-D Math (Math mode), and as such,
the Tab key allows you to move between placeholders.

Toolbar icons are controlled by the location of the cursor in the document.
For example, place the cursor at an input region and the Text and Math
icons are accessible while the others are greyed out. See Table 3.5 for a list
of the tools available in each icon.
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Table 3.5: Toolbar Icons and their Tools
Toolbar Icon Options
Text tools

Math tools

Drawing tools

Plot tools

Animation tools

Table 3.6: Toolbar Icon Availability
Region

Available Tools

Input region

Text and Math icons

Plot region

Drawing and Plot icons

Animation region

Drawing, Plot, and Animation icons

Canvas and Image regions

Drawing icon
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The Text and Math icons allow you to enter text and math in the same line
by choosing the appropriate input style at each stage when entering the sentence.
The derivative of

is

Using the tools available in these icons, you can customize the input style
of the text and 2-D Math. For the Text and Math icons, the icon that is selected remains in that state until prompted otherwise; therefore if the Text
icon is selected and you press the Enter key, the new input region remains
a Text region.
The Text and Math icons differ while at a Maple input prompt. The Math
icon displays input as 2-D Math, whereas the Text icon displays Maple input.
>
> x^2/2;
To access the tools available in the Plot and Drawing icons, click a plot region. The tools available in these icons allow you to manipulate the plot or
draw shapes and enter text on the plot region. By clicking an animation region, you have the same features available for a plot region, in addition to
tools for playing the animation in the Animation icon.
For the remaining icons, hover the mouse over the icon to display the icon
description.
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3.8 Top Commands and Packages
After you have reviewed the contents of the first few chapters, you can scan
the top Maple commands and packages (topics).
Table 3.7: Top Commands
Command Name Description
plot and plot3d

Create a two-dimensional and three-dimensional plot of functions.

solve

Solve one or more equations or inequalities for their unknowns.

fsolve

Solve one or more equations using floating-point arithmetic.

eval

Evaluate an expression at a given point.

evalf

Numerically evaluate expressions.

dsolve

Solve ordinary differential equations (ODEs).

int

Compute an indefinite or definite integral.

diff

Compute an ordinary or partial derivative, as the context dictates.

limit

Calculate the limiting value of a function.

sum

For symbolic summation. It is used to compute a closed form for an
indefinite or definite sum.

assume/is

Set variable properties and relationships between variables. Similar
functionality is provided by the assuming command.

assuming

Compute the value of an expression under assumptions.

simplify

Apply simplification rules to an expression.

expand

Distribute products over sums.

normal

Normalize a rational expression.

convert

Convert an expression to a different type or form.

type

Type-checking command. In many contexts, it is not necessary to
know the exact value of an expression; it suffices to know that an
expression belongs to a broad class, or group, of expressions that share
some common properties. These classes or groups are known as types.
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Command Name Description
series

Generalized series expansion.

map

Apply a procedure to each operand of an expression.

A complete list of top-level commands is available at Help → Manuals,
Dictionary, and more → List of Commands.
Table 3.8: Top Packages
Package Name

Description

CodeGeneration

The CodeGeneration package is a collection of commands and
subpackages that enable the translation of Maple code to other
programming languages, such as C, Fortran, MATLAB®, Visual
Basic, and

LinearAlgebra

The LinearAlgebra package contains commands to construct and
manipulate Matrices and Vectors, and solve linear algebra problems.
LinearAlgebra routines operate on three principal data structures:
Matrices, Vectors, and scalars.

Optimization

The Optimization package is a collection of commands for numerically solving optimization problems, which involve finding the
minimum or maximum of an objective function possibly subject
to constraints.

Physics

The Physics package implements computational representations
and related operations for most of the objects used in mathematical
physics computations.

RealDomain

The RealDomain package provides an environment in which Maple
assumes that the basic underlying number system is the field of
real numbers instead of the complex number field.

ScientificConstants

The ScientificConstants package provides access to the values of
various physical constants, for example, the velocity of light and
the atomic weight of sodium. This package provides the units for
each of the constant values, allowing for greater understanding of
an equation. The package also provides units-matching for error
checking of the solution.
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Package Name

Description

ScientificErrorAna- The ScientificErrorAnalysis package provides representation and
lysis
construction of numerical quantities that have a central value and
an associated uncertainty (or error), which is a measure of the degree of precision to which the quantity's value is known. Various
first-order calculations of error analysis can be performed with
these quantities.
Statistics

The Statistics package is a collection of tools for mathematical
statistics and data analysis. The package supports a wide range of
common statistical tasks such as quantitative and graphical data
analysis, simulation, and curve fitting.

Student

The Student package is a collection of subpackages designed to
assist with teaching and learning standard undergraduate mathematics. The many commands display functions, computations, and
theorems in various ways, including stepping through important
computations.
The Student package contains the following subpackages:
• Calculus1 - single-variable calculus

Units

•

LinearAlgebra - linear algebra

•

MultivariateCalculus - multivariate calculus

•

Precalculus - precalculus

•

VectorCalculus - multivariate vector calculus

The Units package contains commands for unit conversion and
provides environments for performing calculations with units. It
accepts approximately 300 distinct unit names (for example, meters
and grams) and over 550 units with various contexts (for example,
standard miles and U.S. survey miles). Maple also contains two
Units palettes that allow you to enter the unit for an expression
quickly.
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Package Name

Description

VectorCalculus

The VectorCalculus package is a collection of commands that
perform multivariate and vector calculus operations. A large set of
predefined orthogonal coordinate systems is available. All computations in the package can be performed in any of these coordinate
systems. It contains a facility for adding a custom but orthogonal
coordinate system and using that new coordinate system for your
computations.

A complete list of packages is available in the Maple help system at Help
→ Manuals, Dictionary, and more → List of Packages.
For detailed information about features you have reviewed in this book, and
other advanced features, refer to the Maple User Manual.
To access the Maple User Manual:
1. From the Help menu, select Manuals, Dictionary, and more.
2. Select Manuals, and then User Manual.

4 The Maple Help System
The Maple program provides a custom help system consisting of almost
5000 reference pages. The help system is a convenient resource for determining the syntax of Maple commands and for learning about Maple features.
In this chapter:
Accessing the Help System

Describes the different ways you can access the Maple
help system.

Using the Help Navigator

Explains the types of searches available in Maple help
system.

Viewing Help Pages as
Worksheets

Explains how to open a help page as a worksheet.

Copying Examples

Explains how to copy examples to a Maple worksheet.
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4.1 Accessing the Help System
To access the Maple help system:
•

From the Help menu, select Maple Help

•

Click

•

In the document, enter ?topic, i.e. enter ?LinearAlgebra and press Enter

in the toolbar

The Maple help system opens in a separate window with two panes. The left
pane contains the Help Navigator where you initiate searches and the right
pane displays the final search result, such as a specific help page.

Figure 4.1: Example Help Page

4.2 Using the Help Navigator
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Every help page in Maple lists the command's calling sequence, parameters,
a description, and examples of the command at the end of the page. Some
help pages also contain hyperlinks to related help pages and hyperlinks to
dictionary definitions. Hyperlinks to help pages display in green while hyperlinks to dictionary definitions display in rust.

4.2 Using the Help Navigator
The Help Navigator contains a field for topic or text-based searches.
•

Topic searches reveal a list of matching topics sorted by exactness of
match.

•

Text searches reveal a list of topics based on keyword frequency.

•

You can search all of the help system or specific Resources such as Help
Pages, Tasks, definitions in the Math and Engineering Dictionary, Tutorials, and Manuals by selecting the Resources drop-down menu.

•

Search results are displayed as a list in the Search Results tab of the left
pane. Click the Table of Contents tab to view a structured list of all
topics in the help system.

Help System Table of Contents
The Table of Contents tab provides a structured list of all topics in the help
system.
To display potential matches in the right pane, click a topic preceded by an
icon.
A folder icon in the Table of Contents tab indicates that a topic can be expanded into subtopics.
Question mark icon indicates a help page and displays the associated help page
in the right pane when selected.
WS icon indicates an example worksheet. Example worksheets open in a new
tab in the Maple document.
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D icon indicates a definition and displays the associated dictionary definition
in the right pane when selected.
T icon indicates a Task template and displays the associated Task Template
in the right pane when selected.
M icon indicates a manual. Manuals open in a new tab in the Maple document.

4.3 Viewing Help Pages as Documents
In help pages, examples are not executable.
The Maple help system allows you to open help pages as documents that
you can execute.
To open a help page as a document or worksheet:
•

With the help page displayed in the right pane of the help system, from
the View menu, select Open Page as Worksheet. A new worksheet
window opens.
Alternatively, in the help system toolbar, click the open current help page in
a worksheet window icon.

4.4 Copying Examples
Instead of opening the entire page as a document, you can copy the Examples
section only.
To copy examples:
1. With the help page displayed in the right pane of the help system, from
the Edit menu, select Copy Examples.
2. Close or minimize the Help Navigator and return to your document.
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3. In your document, place the cursor at the location where the examples are
to be pasted.
4. From the Edit menu, select Paste. The Examples section of the help page
is now executable content in your document.
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5 Using Maple
Maple is a powerful application with many resources to guide you and assist
you in solving problems of different types.
In this chapter:
Clickable Math in Provides steps to solving various problems using some of the
Maple
different methods available in Maple.
Calculus Examples Provides two word problems and illustrates the various resources
available to solve these problems.
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5.1 Clickable Math in Maple
As we have seen, Maple has incorporated several features that eliminate the
learning curve for new users. With drag-and-drop functionality, contextsensitive menus, built-in tutors, command completion, and over 20 palettes,
using Maple has never been so easy. This chapter is designed to show several
of the ways to solve the same problem in Maple. Recall the keyboard keys
for the different operating systems mentioned in Invoking Context Menus,
Command Completion, and Copy & Drag (page xiii).

Example 1 - Graph a function and its derivatives
On

graph

,

, and

if

.

Solution by Context Menus
1. Enter the expression
Make a copy of the expression and calculate the derivative:
2. Insert a new document block region by selecting from the Format menu Create Document Block.
3. Highlight the original expression. Ctrl + drag the expression to the new document block.
4. Right-click the expression and select Differentiate → x.
Make a copy of the derivative and calculate the second derivative:
5. Insert a new document block. Highlight the derivative of the expression. Ctrl + drag
the expression to a new document block.
6. Right-click the derivative and select Differentiate → x.
Result:
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Plot the expression:
7. Insert a new document block. Highlight the original expression. Ctrl + drag the expression
to the new document block.
8. Right-click the expression and select Plots → Plot Builder.
9. In the Interactive Plot Builder : Select Plot Type dialog, change the x Axis range to
-Pi .. Pi.
Enhance the plot using context menus:
Add the first and second derivative to the plot
10. Highlight the derivative of the expression. Ctrl + drag the expression on to the plot
region. Do the same for the second derivative. Note: You can also drag a curve off of the
plot region by placing the mouse over the curve, selecting it with the mouse, and dragging
it of of the plot region. A new plot region with this curve displays.
Add a legend:
11. Right-click in the plot region and select Legend → Show Legend.
12. In the legend, double-click Curve 1. Notice that the Text icon is selected in the toolbar,
. Delete the text and select the Math icon in the toolbar,
. This allows you
to enter 2-D Math. Enter the original expression,
. Do the same for Curve 2 and
Curve 3.
Add a title:
13. To enter a title, click the Drawing icon in the toolbar,
. If the Drawing icon
is not accessible, click the plot region. Notice that the Plot and Drawing icons are now
available while the others are grayed out,

.

14. Click T in the Drawing menu,
.
15. Click the plot region and a text region appears. Notice that the toolbar has changed
once again with the Text icon selected. To enter Text and 2-D Math on the same line, you
will use the Text icon when entering text and the Math icon when entering 2-D Math.
With the Text icon selected, enter Plot the expression. Click the Math icon and enter the
expression. Click the Text icon and enter and its derivatives.
16. Click the text region and the border becomes highlighted. You can now reshape the
text region and move it around the plot region using the mouse.
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Result:

Solution by Tutor
The Student Calculus I package contains a tutor called Derivatives which
displays a plot of the expression along with its derivates. In this section, we
will solve the same problem as previously using this tutor.
1. Load the Student Calculus 1 package by selecting Tools → Load Package → Student
Calculus 1. Notice the message inserted in the Document indicating the package that was
loaded.
Result:
Loading Student:-Calculus1
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2. Ctrl + drag the expression for

to a blank document block region.

3. Right-click the expression and select Tutors → Calculus - Single Variable → Derivatives. Note: The Tutors menu option would not be available in the context menu had we
not loaded the Student Calculus 1 package in step 1.
The Derivatives tutor displays a plot of the expression as well as its derivative. The color
swatch shown beside the expression is the colour used for the curve in the plot region. This
is the same for
and
See Figure 5.1.

Figure 5.1: Derivative Tutor
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4. Select the check box to display

in the plot. Click Display to make this change

take effect.
5. You can change the expression, ranges, or plot options from within this tutor. For each
change made, click Display. When complete, select Close to display the resulting plot in
the document.
Result:

Access the Tutor from a Task Template
Maple also comes with a Task Template to solve this problem without using
and commands.
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1. Launch the Task Template Browser by selecting Tools → Tasks → Browse.
2. In the table of contents of the Task Template dialog, expand Calculus → Derivatives
→ Graph
and Its Derivatives.
3. Click Insert Minimal Content at the top of the dialog to insert the task template into
the current document.
4. Enter the new expression in the f(x) region.
5. Enter the interval.
6. Click Launch Differentiation Tutor to launch the same tutor from the previous example.
7. When complete, click Close. A plot of the expression and its derivative(s) will display
in the plot region.
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Result:

Example 2 - Solve for x in the linear equation
Solve for

in the equation

Solution through Equation Manipulator
Maple contains a dialog that allows you to single-step through the process
on manipulating an expression. This manipulator is available from the context
menu.
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1. Ctrl + drag the expression to a new document block region.
2. Right-click this equation and select Manipulate Equation. The Manipulate Equation
dialog displays. See Figure 5.2.

Figure 5.2: Manipulate Expression
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Group all of the terms to the left:
4. In the Addition region, the Group terms row allows us to group terms on a specified
side. Accept the default side of left, click Do.
Expand the left side of the equation:
5. In the Miscellaneous Operations region, we can manipulate the equation by applying
a command from one of the drop-down menus. Since we want to apply a command on the
left side of the equation only, click the drop-down menu in the second row and select expand. Since the left side is already selected, click Do.
Factor the equation:
6. In the same drop-down menu, select factor and click Do.
Return all of the steps to the Maple document and close the dialog:
7. Click Return Steps.
Result:

8. Ctrl+drag the factored form of the original equation to a new document block region.
9. Right-click and select Solve → Solve For Variable → x.
Result:

Instant Solution
To apply an instant solution to this problem, we can use the context menus.
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1. Ctrl + drag the equation to a new document block region.
2. Right-click the expression and select Solve → Solve for Variable → x.
Result:

Point-and-click Interactive Solution
By making use of equation labels, we can refer to each successive equation
and add, subtract, multiply, and divide as appropriate, one step at a time.
1. Ctrl + drag the equation to a blank document block and press the Enter key.
To group all terms on the right, we need to subtract

from both sides of the

equation:
2. Ctrl + L. In the dialog that displays, enter the equation label for the previous result.
With the equation label inserted, enter
3. Repeat step 2 for
Result:

.
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We now need to use Maple's expand, factor, and solve commands to complete the problem:
4. Using Maple's expand command, we will expand the equation using equation labels to
refer to the equation.
5. Enter expand(.
6. Ctrl + L and enter the value for the previous result.
7. Enter a closing parenthesis, ).
8. Repeat steps 5 → 7 to factor and solve the problem.
Result:

Graphical Solution
Now that we've seen several methods to solve this problem, lets check our
answer by plotting the expression.
We must manipulate the equation to become an expression before we can plot this
problem.
1. Copy the equation to a new document block region and press Enter
2. Right-click the output and select Move to Left. Notice the difference in the alignment
of the equation when using context menus on output rather then input.
3. Right-click the output and select Left-hand Side.
4. Right-click the output and select Expand.
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Result:

Now that the equation has been manipulates into its simplest form, plot the result.
5. Ctrl + drag the output to a new document block.
6. Right-click the expression and select Plots → 2-D Plot.
7. Right-click the plot and select Axes and then Properties. In the Horizontal tab of the
Axes Properties dialog, de-select Use data extents and change the Range min and Range
max to 0 and 5 respectively. Click the Vertical tab and de-select the Use data extents.
Chang the Range min and Range max to -5 and 10 respectively.
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Result:

Example 3 - A Quadratic Trig Equation
For the equation

, find all solutions in the interval

Graphical Solution
1. Ctrl+drag the equation to a blank document block and press the Enter key.
2. Right-click and select Left-hand Side.
3. Right-click and select Plots → Plot Builder.
4. Modify the plot range appropriately. (Use 2*Pi for the right endpoint.)
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Result:

Solution by Task Template
1. Ctrl + drag the equation to a blank document block region.
2. From the Format menu, select Tasks → Browse. Expand the Algebra folder and select
Solve Analytically in a Specified Interval.
3. Click Insert Minimal Content.
4. Replace the current expression with the one in this example.
5. Notice Equation Labels are used to reference the result from the calculation.
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Result:
Solve Analytically in a Specified Interval
Enter an expression:

>
(5.11)

Find the roots in a specified interval:

>
(5.12)

Express the roots in
floating-point form:

>
(5.13)

Analytic Solution
1. Ctrl+drag the equation to a blank document block region.
2. Right-click and select Left-hand Side.
3. Ctrl+drag the output to a blank document block region.
4. Right-click and select Factor.
5. Ctrl+drag the first factor to a blank document block region.
6. Right-click and select Solve.
7. Ctrl+drag the first factor to a blank document block region.
8. Delete x from the expression.
9. Ctrl+drag the solution to replace the value of

.

10. Right-click and select Evaluate and Display Inline.
11. Ctrl+drag the second factor to a blank document block region.
12. Right-click and select Solve.
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Result:

=

=

Example 4 - Inverse Functions
If
tional inverse.

, find and graph the rule for

, and its func-

Implement the Definition Graphically
The graph of the inverse function is the set of ordered pairs formed by interchanging the ordinates and abscissas.
1. In a blank document block, enter

and press Enter.

2. Right-click the output and select Plots → Plot Builder.
3. In the Plot Builder : Select Plot Type dialog, ensure 2-D Parametric Plot is selected in
the Select Plot region
4. Adjust the domain for x to the interval
5. Select Plot to return the plot to the document.
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Result:

6. Ctrl + drag the expression for
7. Ctrl + drag the expression for
The resulting graph is the graph of

onto this graph. Notice that the axis ranges alter.
onto this graph.
Adjust the

and

axis ranges.

8. Right-click on the graph and select Axes → Properties.
9. In the Axes Properties dialog, de-select Use data extents and change the range to
10. Click the Vertical tab and repeat step 10. Click OK to apply this setting and close the
Axes Properties dialog.
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Result:

Solution by Tutor
1. Load the Student Calculus 1 package via the Tools/Load Package menu.
2. To a blank document block, Ctrl + drag the expression for the function
3. Right-click and select Tutors → Calculus - Single Variable → Function Inverse. See
Figure 5.3.
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Figure 5.3: Function Inverse
4. Adjust the domain
5. From the Formula of the Inverse region, select the appropriate branch.
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Result:
Loading Student:-Calculus1

Example 5 - Methods of Integration - Trig Substitution
Evaluate the integral

by making the substitution

Immediate Evaluation of the Integral
1. Ctrl + drag the integral to a blank document block region.
2. Right-click and select Evaluate.
Result:
=
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Solution by Integration Methods Tutor
1. Load the Student Calculus 1 package by selecting Tools → Load Package →
Student Calculus 1.
2. Ctrl + drag the integral to a blank document block region.
3. Right-click and select Tutors → Calculus Single Variable → Integration Methods.
4. Change the expression by selecting Change and entering
5.4.
5. Apply the constant multiple rule.
6. Apply the revert rule.

Figure 5.4: Integration Methods Tutor

. See Figure
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5. Apply the constant multiple rule.
6. Apply the revert rule.
7. Close the tutor.
Result:
Loading Student:-Calculus1

Solution by First Principles
1. Ctrl + drag the integrand in a blank document block region.
2. Right-click and select Evaluate at a point. In the dialog that displays, enter
3. Right-click and select Simplify → Symbolic.
4. Ctrl + drag the result to a blank document block region and press Enter.
5. Referencing this result by its equation label, multiply by the derivative of

and

press the Enter key.
6. Right-click and select Constructions → Integral → u.
7. To revert the substitution:
8. In a blank document block, place the equation

and press the Enter key.

9. Right-click and select Solve → Solve for a Variable → u.
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Result:

Example 6 - Initial Value Problem
Solve the initial value problem

On the same set of axes, obtain a graph of
and
of the orbit this solution makes in the phase plane.

. Obtain a graph

Solution by ODE Analyzer Assistant
The ODE Analyzer Assistant lets you solve ODE's numerically or symbolically and displays a plot of the solution.
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1. Ctrl + drag the ODE to a blank document block.
2. Right-click and select Solve DE Interactively. The ODE Analyzer Assistant displays
with the ODE automatically inserted. See Figure 5.5.

Figure 5.5: ODE Analyzer Assistant
To insert the initial conditions: 3. In the Conditions region, click Edit. The Edit Conditions dialog opens. 4. In the Add Condition region, with y selected in the drop-down
menu, enter 0 in the text field to the right and then 2 in the second text region. Click Add.
Your entry should match Figure 5.6.
5. To enter the initial condition for y', select y' from the drop-down menu. In the text field
to the right, enter 0 and then 1 in the second text field. Click Add. Click Done to close
this dialog and return to the main dialog.
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Figure 5.6: Edit Conditions Dialog
5. Click Solve Numerically.
To solve the initial value problem:
6. Click Solve.
To plot the solution of the DE:
7. Click Plot.
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Figure 5.7: Solve Numerically Dialog
8. To change the plot options:
Click the Plot Options button to modify the default graph.
9. Click Quit to close the ODE Analyzer and return a plot of the DE to the Maple document.
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Result:

5.2 Calculus Examples
Maple is a powerful application with many resources to guide you. The following examples provide you with scenarios to learn about using Maple resources and the Maple program.
When using Maple to solve a problem, consider the following process.
1. Formulate your problem.
2. Obtain Maple resources that allow you to solve it.
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Problem
Scenario A:
Your company is designing a bottle for its new spring water product.
The bottle must contain 18 ounces of water and the height is fixed. The
design includes an undulating curved surface. You know the amplitude
and equation of the curve, but you must find the radius. You require
the Volume of Revolution.

Scenario B:
You want to teach your students the concept of a Volume of Revolution. Specifically, you want to plot and compute the volume of a solid
of revolution generated by rotating f(x), a ≤ x ≤ b, about an axis or a
line parallel to an axis.

Figure 5.8: Flowchart of solving a problem
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Check for Existing Tools: Tutor
Begin by examining the Tools menu for a Tutor to a Volume of Revolution
problem.
To access a Tutor for the Volume of Revolution:
1. From the Tools menu, select Tutors, and then Calculus-Single Variable.
Notice that a Volume of Revolution tutor exists.
2. Click the Volume of Revolution menu item. The document is populated
with the following Maple command.
>
The Volume of Revolution Tutor is displayed. See Figure 5.9. Use this tutor
to enter a function and an interval, view and manipulate the corresponding
plot, and view the full Maple command associated with your entries and selections.
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Figure 5.9: Volume of Revolution Tutor

After you Close the tutor, the plot is inserted into your worksheet.

Check for Existing Tools: Task Template
1. From the Tools menu, select Task, and then Browse. The Browse Tasks
dialog opens, displaying a list of tasks. The tasks are sorted by subject to
help you quickly find the desired task.
2. Expand the Calculus folder.
3. From the displayed list, select Volume of Revolution. The Volume of
Revolution task is displayed in the right pane of the Browse Tasks dialog.
4. Select the Insert into New Worksheet check box.
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5. Click Insert Default Content. Before inserting a task, Maple checks
whether the task variables have assigned values in your worksheet. If any
task variable is assigned, the Task Variables dialog opens allowing you to
modify the names. Maple uses the edited variable names for all variable instances in the inserted task. The content is inserted into your document. See
Figure 5.10.

Figure 5.10: Inserted Task Template

6. When a Task Template is inserted, parameters are marked as placeholders.
To navigate between placeholders, press the Tab key. After updating any
parameters, run the command by pressing Enter.

Check for Instructions: Help Page and Example
Worksheet
The help system provides command syntax information.
To access a help page:
1. From the Help menu, select Maple Help.
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2. In the search field, enter volume of revolution and click Search. The
search results include the command help page, the dictionary definition, and
the associated tutor help page.
3. Review the calling sequence, parameters, and description in the Student[Calculus1][Volume of Revolution] help page.
4. Copy the examples into your worksheet: From the help system Edit menu,
select Copy Examples.
5. Close the Help Navigator.
6. In your document, from the Edit menu, select Paste. The examples are
pasted into your document.
7. Run the examples and examine results.
To accesss an example worksheet:
1. In the worksheet, enter ?index/examples. The Example Worksheet Index
opens.
2. Expand the Calculus topic.
3. Click the Calculus1IntApps link. The Calculus1: Applications of Integration worksheet opens. See Figure 5.11.
4. Expand the Volume of Revolution topic.
5. Examine and run the examples.
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Figure 5.11: Example Worksheet

Check for Other Ready-To-Use Resources: Application Center
The Maple Application Center contains free user-contributed applications
related to mathematics, education, science, engineering, computer science,
statistics and data analysis, finance, communications, graphics, and more.
To access a free application for volume of revolution:
1. Go to the Maplesoft Web site, http://www.maplesoft.com.
2. In the menu of the main Web page, click User Community, and then
Application Center.
3. In the sidebar, click Education PowerTools.
4. Click the Calculus II link, and then the CalculusII: Complete Set of
Lessons link.
5. From the Options area and click Download Maple Worksheet. See
Figure 5.12.
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6. Login in as a guest or Maplesoft Member.
7. Download the .zip file.
8. Extract the L2-volumeRevolution.mws file.
9. Run the worksheet and examine the results.

Figure 5.12: Maple Application Center: PowerTools

106 • 5 Using Maple

6 Available Resources
Your work with Maple is supported by numerous resources.
In this chapter:
Online Help and
Examples

Maple's online help system offers help pages, example and applications, and a dictionary of mathematical and engineering
terms.

Maple Tour and
New User
Roadmap

For new users, the Maple Tour and New User Roadmap helps
get you started.

Web Site Resources

Illustrates the numerous resources available from the Maplesoft
Website.
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6.1 Online Help and Examples
Help Pages
The online help system helps you find information about a specific topic,
command, package, or feature. You can access help three ways.
•

From the Help menu, select Maple Help.

•

In the toolbar, click the Help icon

•

In the document or worksheet, enter ?topicname. For example, enter
?LinearAlgebra and then press Enter.

.

Dictionary
More than 5000 mathematical and engineering terms with over 300 figures
and plots.
1. From the Help menu, select Maple Help.
2. In Resources drop-down list, select Definition.
3. Enter search word or expand alphabetical listing.

Applications and Example Worksheets
Applications
Sample applications demonstrate how Maple can be used to find and document a solution to a specific problem. Some applications allow for input or
contain animations that you can run; however, their primary use is for
demonstrations. Topics include DC Motor Control Design, Digital Filter
Design, Frequency Domain System Identification, Harmonic Oscillator,
Mathematical Model to Simulation Code, Mobile Robot Modeling and
Simulation, and Black-Scholes Model.
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Examples
Sample examples are executable documents covering topics that demonstrate
syntax or invoke a user interface to make complex problems easy to solve
and visualize. You can copy and modify the examples as needed. Topics
include Algebra, Calculus, Connectivity, Discrete Mathematics, General
Numerics and Symbolics, and Integral Transforms.
•

From the Help menu, select Manuals, Dictionary, and more, and then
Applications and Examples.

6.2 Maple Tour and New User
Roadmap
Maple Tour
The Maple Tour consists of interactive sessions on several of the following
topics: Ten Minute Tour, Numeric and Symbolic Computations, Matrix
Computations, Differential Equations, Statistics, Programming and Code
Generation, Units and Tolerances, and Education Assessment, Maple T.A.
•

From the Help menu, select Take a Tour of Maple.

New User Roadmap
Find the most efficient path to solving a problem immediately or learning
principles and reviewing major features.
•

From the Help menu, select Manuals, Dictionary, and more, and then
New User Roadmap.
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6.3 Web Site Resources
Welcome Center
A Maple Web site offering all of Maplesoft's key user resources in one
central location. In the Welcome Center you can view sample applications,
participate in user forums, access exclusive premium content, and listen to
Podcasts. In addition, you will have access to our support services, be able
to view training videos, download user manuals, and much more.
1. Go to http://www.maplesoft.com.
2. In the menu of the main Web page, click Site Resources and then Welcome Center.

Student Help Center
The Student Help Center offers a Maple Student Forum, Online Math Oracles,
Training Videos, and a Math Homework Resource Guide.
1. Go to http://www.maplesoft.com.
2. In the menu of the main Web page, click Site Resources and then Student
Help Center.

Teacher Resource Center
The Teacher Resource Center is designed to ensure you get the most out of
your Maple teaching experience. It provides sample applications, course
material, training videos, white papers, eBooks, Podcasts, and tips.
1. Go to http://www.maplesoft.com.
2. In the menu of the main Web page, click Site Resources and then
Teacher Resource Center.
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Application Center
Maple Web site resource for free applications related to mathematics, education, science, engineering, computer science, statistics and data analysis,
finance, communications, graphics. Many applications are available in
translation (French, Spanish, and German).
1. Go to http://www.maplesoft.com.
2. In the menu of the main Web page, click User Community and then
Application Center.

PowerTools
A Maple Web site resource for free complete course curricula and add-on
Maple packages and courses, developed by experts in their fields to help
users configure Maple for research in specific application areas.
1. Go to http://www.maplesoft.com.
2. In the menu of the main Web page, click User Community and then
Application Center.
3. In the sidebar of the Web page, click Research PowerTools or Education
PowerTools.

Training
Maplesoft offers a comprehensive set of complementary training materials.
From complete training videos to recorded training seminars to downloadable
documentation, you have many options to get up to speed with Maplesoft
products. In addition, whether you are an expert or someone who is considering a new license purchase, we can provide a custom training session that
is right for you and/or your organization.
1. Go to http://www.maplesoft.com.
2. In the menu of the main Web page, click Site Resources and then
Training.
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MaplePrimes
A Web community dedicated to sharing experiences, techniques, and opinions
about Maple and related products, as well as general interest topics in math
and computing.
1. Go to http://www.maplesoft.com.
2. In the menu of the main Web page, click User Community and then
MaplePrimes.

Technical Support
A Maple Web site and resources for FAQs, downloads and service packs,
links to discussion groups, and request technical support form.
1. Go to http://www.maplesoft.com.
2. In the menu of the main Web page, click Customer Support and then
Support & Customer Service.
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