This tutorial is designed to help you become familiar with the Maple environment and teach you fundamental concepts and tools you need to become productive quickly. To try this material on your own, start with an empty Maple document. Perform the steps found in the left column of each table below. The results of each step are displayed in the right column for your reference.

**Note:** This guide assumes you are working in Document mode. Most information applies equally to Worksheet mode, with minor visual differences. Any important differences are noted in the text.

### Talking to Maple

<table>
<thead>
<tr>
<th>Steps</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Start Page</strong></td>
<td></td>
</tr>
<tr>
<td>When you first open Maple, you will see the Start page. This page points you to important resources for new users, and can be turned off later if desired. Click on the New Document icon, on the top left of the page to open a blank document.</td>
<td><img src="image" alt="Start Page" /></td>
</tr>
</tbody>
</table>
### Using [ENTER]

You can start by typing math into your Maple document and pressing [ENTER] in order to see the result.

**Example:** Type "1+2 [ENTER]."

Notice that the result appears on the next line.

<table>
<thead>
<tr>
<th>Expression</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 + 2</td>
<td>3</td>
</tr>
</tbody>
</table>

### Using [Alt]+[ENTER]

If you would like to have the result returned on the same line, press [ALT]+[ENTER].

**Example:** Type "x+5-2" then [Alt]+[ENTER].

Worksheet mode: Inline evaluation is not available in Worksheet mode. When working through this guide, simply press [ENTER] instead.
Context Panel

Maple’s context panel is one of the most important tools in Maple. It can be used to perform a wide variety of operations, and the options change depending on what expression or object your cursor is on. The context panel is on the right side of your Maple workspace.

**Example:** Place your cursor on the last result. The context panel offers several operations to choose from according to the expression that you are using. To integrate this expression, select **Integrate**, then $x$.

It is also possible to generate plots from the context menu;

**Example:** To plot the result of the integration, click on the result, and then select **Plots > 2-D Plot**.

**Worksheet mode:**

In worksheet mode, you enter your problem at the input prompt `[ > ]` and press [ENTER] to see the result (the output). In a typical workflow, to use the context menus, you put your cursor on your last result, and then choose an operation from the context panel to apply to that expression. Maple will insert the relevant command at the next input prompt, and evaluate it to return your result.

The context menu operations use equation labels to refer to the expression Maple is performing the operation on. You can learn more about equation labels later in this document.
Changing the Problem

Math in a Maple document is live. You can go back, make changes, and re-execute the problem to obtain a new result.

**Example:** Go back to your original calculation of "1 + 2", change the number "1" to a "3" and press [ENTER]. Note the change in output.

**Example:** In the context panel example, above, change the "x" to "10 x". Highlight everything from "10 x" to the plot, then click the Execute selection button, found on the toolbar at the top of the Maple window. All selected calculations are updated.

**Tip:** Clicking the Execute the entire worksheet button, re-calculates the entire document.

Smart Popups

At the top of the context panel, you'll find Smart Popups, which give you a preview of the result of an operation before you apply it.

**Example:** Enter \( \sin(2x) \). From the Context Panel, you can convert this expression to an equivalent form using trig identities.
## Entering Math

<table>
<thead>
<tr>
<th>Steps</th>
<th>Results</th>
</tr>
</thead>
</table>

### Entering Fractions

Use `/` to enter a fraction. When you type `/`, you will automatically move into the denominator. Use the right-arrow key to come out again.

When your numerator contains multiple terms, you can use brackets to enclose the numerator...

...or you can select the terms you want, using the mouse or by holding down Shift and using the arrow keys, before pressing `/`. The selected expression will become the numerator of the fraction when you press `/`.

\[
\frac{a}{b} + 1
\]

\[
\frac{(a + 2)}{b}
\]

\[
\frac{a + 2}{b}
\]
Exact Answers and Numeric Approximations

Maple calculates exact answers (for example, fractions remain as fractions, and \( \pi \) stays as \( \pi \)).

**Example:** On a new line, evaluate \( \pi + \frac{1}{2} + \frac{1}{3} \). Use the **Common Symbols** palette to enter \( \pi \) (you'll learn other methods later).

\[
\pi + \frac{1}{2} + \frac{1}{3} = \pi + \frac{5}{6}
\]

Maple also calculates numeric approximations.

**Example:** Click on the result above and select **Approximate** from the context panel. Select an accuracy of 5 digits.

\[
\pi + \frac{1}{2} + \frac{1}{3} = \pi + \frac{5}{6} \quad \text{at 5 digits} \rightarrow 3.9749
\]

If your problem uses decimal approximations already, Maple will return the answer in the same format.

**Example:** Try the example on the right.

\[
0.33 x + \frac{1}{3} x = 0.6633333333 x
\]

\[
0.33 x + \frac{1}{3} x = 6.63 \times 10^{-1} x
\]

You can apply different formatting to numeric results.

**Example:** On the context panel, under **Number Format**, select **Scientific**.
Palettes

Maple has over 1000 expressions and symbols within its collection of palettes, found on the left side of your Maple window. Some of them insert fill-in-the-blank templates into your document, and are useful for problem entry.

Example: Using the Expression Palette, find the definite integral of \( x^2 - 3x \) from 0 to 1. Open the expression palette (click Expression on the left-hand side of your Maple document) and click the definite integral \( \int_a^b f(x) \, dx \) symbol. A definite integral template will appear in your worksheet. Fill in the place-holders (use [TAB] to move to the next placeholder). When done, press [ENTER] to evaluate.

Important! Use ^ to create an exponent/superscript, and right-arrow to get out again.

Tip: You can put frequently used palette entries on the Favorites Palette. To do so, right-click on the desired expression in the palette and select Add to Favorites Palette.
Entering Symbols using Symbol Completion

You can enter common symbols, like \( \pi \) or \( \infty \), using palettes. In addition, the symbol completion mechanism provides an alternative to palettes for entering symbols using the keyboard.

Type the first few characters of the symbol name, and press [Esc]. Choose the desired symbol from the list.

**Example:** Try entering \( \sqrt{e^x + \pi^2} \). For the square root symbol, enter `sqrt [Esc]` and choose the symbol from the menu. Type `e [Esc]` for the exponential constant. To enter \( \pi \), type `pi [Esc]`. The right-arrow will take you outside the square root symbol.

**Important!** Use symbol completion to enter single letter symbols, such as the exponential \( e \), the imaginary unit \( i \), and the differential symbol \( d \). If you simply type \( e \), Maple will treat \( e \) as a variable, like \( x \). Notice the difference: \( e^x \) (symbol) vs. \( e^x \) (variable, so \( e \) is italicized).

The same mechanism can be used to enter templates.

**Example:** Type `int [Esc]`. Choices include various integration templates.

\[
\sqrt{e^x + \pi^2}
\]
## Case-Sensitivity

Maple is case-sensitive. This means, for example, that a lower case `x` and an upper case `X` will be treated as two different variables.

**Example:** Enter " `x + x` ".

**Example:** Enter " `y + Y` ".

Compare the results.

\[
\begin{align*}
x + x &= 2x \\
y + Y &= y + Y
\end{align*}
\]
## Multiplication

In the case of a number multiplied by a variable only, you have the option of leaving out the multiplication symbol entirely, as the examples up to now have shown.

**Example:** Type "3x + 4x".

Maple will insert a space to indicate the implicit multiplication.

<table>
<thead>
<tr>
<th>Example</th>
<th>Expression</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>$3x + 4x$</td>
<td>$7x$</td>
</tr>
</tbody>
</table>

In general, you can **use * or a space to denote multiplication**. When using standard math notation, the * appears as a center dot (·).

**Example:** Type "$3 \times x + 5 \cdot x$".

Implicit multiplication offers convenience and additional typesetting options, but if you use spaces for multiplication, be careful.

"x y" means "x times y", but "xy" means the variable whose name is "xy".

**Example:** Type "$x \times y + xy$".

The result is not $2xy$ because the two expressions are not the same. If you choose to **Differentiate** using the context panel, you will see that x, y, and xy all appear as variables in this expression.

<table>
<thead>
<tr>
<th>Example</th>
<th>Expression</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>$3 \times x + 5 \cdot x$</td>
<td>$8x$</td>
</tr>
<tr>
<td></td>
<td>$xy + xy = xy + xy$</td>
<td></td>
</tr>
</tbody>
</table>
Mathematical Notation

Maple understands familiar mathematical notation.

For example, Maple understands that \( y'' + y' + y = 0 \) is a differential equation in \( y(x) \).

**Example:** Enter the equation listed above (using the single quote key for the prime notation). To verify that it is in fact a differential equation, select **Solve DE** from the context panel.

\[
y'' + y' + y = 0 \quad \rightarrow \quad \text{solve DE}
\]

\[
y(x) = _C1 e^{-\frac{1}{2} x} \sin \left( \frac{1}{2} \sqrt{3} \, x \right) + _C2 e^{-\frac{1}{2} x} \cos \left( \frac{1}{2} \sqrt{3} \, x \right)
\]

Label References

Maple uses label references.

Whenever you use **[ENTER]** to get a response, the result is automatically given a label reference. To refer to a previous result in a computation, use **[Ctrl]+[L]** and enter the label reference number.

**Example:** Multiply the result \( \pi^2 + \sqrt{x} \) (from above) by \( x \), using labels. Your label number may be different than the one shown.

\[
(2.2) \cdot x^2 \rightarrow (\sqrt{e^x + \pi^2}) \cdot x^2 \quad (2.3)
\]
### Variable Assignment

In order to assign a value to a variable name, use the assignment statement, denoted by a colon followed by the equals sign, in the form `var := value`.

**Example:** To assign the value "10" to the variable name "cost", type "cost := 10". After a value has been assigned to "cost", it can be used in subsequent calculations.

You can see any assigned variables and their respective values in the Variables palette.

**Tip:** Maple performs calculations only when you ask it to. If you change the value of a variable, you need to re-execute the statements that depend on that value to see updated results. Until you do, your document will continue to display the result based on the previous value.

### Defining Functions

To define a function, use arrow notation, such as \( x \rightarrow x^2 \). Enter the arrow operator by typing a hyphen \([-\)] followed by a greater than sign \([>\] . Maple automatically reformats those characters as a single arrow character.

**Example:** Define a function \( f \) to take a value, \( w \), and return its square.

You can then call the function, as shown.

**Tip:** You can also enter math into Maple by taking a picture of it with your phone using the free Maple Calculator app. The app also lets you solve many problems directly on your phone. [Learn more](#)
# Adding Text

You can include text throughout your Maple document.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td>Your document can contain math, text, and nonexecutable math, which is math that you don't want Maple to evaluate because it's part of your explanation, not a calculation, You can press [F5] to cycle between modes, or use the buttons in the toolbar:</td>
<td>The solution can be expressed as $\int x^3 + x^2 + 3 , dx$, so it's easily found.</td>
</tr>
<tr>
<td>These buttons also show you which mode you are currently in.</td>
<td></td>
</tr>
<tr>
<td>Press [F5] to change from math input to text input, and start typing text. Try typing the start of the sentence on the right.</td>
<td></td>
</tr>
<tr>
<td><strong>In Worksheet mode:</strong> Create a text region by pressing the [T] button on the toolbar, or choosing <strong>Insert &gt; Text</strong> from the menu. Once in a text region, you can add math to your text using [F5] or the buttons on the toolbar.</td>
<td></td>
</tr>
<tr>
<td>You can combine text and math in the same line. Place your cursor at the end of your sentence, and press [F5] again to move to nonexecutable math input. Once you have entered your mathematical expression, press [F5] again twice to return to text.</td>
<td></td>
</tr>
<tr>
<td>Using nonexecutable math in your text instead of live math is especially important if you want to be able to execute your worksheet using the Execute All button. If the math is live, Maple will execute the expression and show the results at the end of the paragraph.</td>
<td></td>
</tr>
</tbody>
</table>
You can include live calculations inside your paragraph by using live, executable math in combination with inline evaluation or context menu operations (**Document mode only**). You can even replace the = sign or context menu descriptions with text.

Enter the example to the right, using the Factor context menu. This time, press [F5] twice so that you move from text to math mode.

Now delete the equal sign, switch to text mode, and add the replacement text.

Change the +1 to -15, highlight the entire sentence and click **execute all selected groups** to re-execute the computation.

| We know that $x^2 - 2x + 1 = (x - 1)^2$, so...
| We know that $x^2 - 2x + 1$ can be rewritten as $(x - 1)^2$, so...
| We know that $x^2 - 2x - 15$ can be rewritten as $(x + 3) (x - 5)$, so...

**Tip:** If you are trying to enter math but it doesn't seem to be formatting properly, you are most likely in text mode. If the math looks right but it doesn't seem to get executed, you are probably in nonexecutable math mode. In live math mode, the cursor is slanted, and has a blue box around it. In nonexecutable math mode, the cursor is slanted and has a gray box. In text mode, the cursor appears as a vertical bar. Remember you can always use the toolbar to check, and change, your mode:

![Text, Nonexecutable Math, Math]({})

**Tip for Worksheet mode:** If the cursor is at an input prompt, [F5] will toggle your input mode between math notation and Maple syntax, for example, int(exp(x)/2, x) instead of $\int \frac{e^x}{2} \, dx$.  

Maple Fundamentals Guide
## Plotting

Maple can produce a large variety of 2-D and 3-D plots and animations.

### Steps

<table>
<thead>
<tr>
<th>2-D Plots</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td>The fastest way to plot an expression in Maple is to use the context panel.</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td><strong>Example:</strong> Enter an expression in x (for example, $-x^2 + 15$), then select <strong>Plots &gt; 2-D Plot</strong> from the context panel.</td>
<td></td>
</tr>
<tr>
<td>You can manipulate this plot in several ways using the Plot Manipulator tools, found on the Plot toolbar and also on the context panel.</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td><strong>Example:</strong> To pan the plot, click on (or select <strong>Manipulator&gt;Pan</strong> from the context panel). Hold down the left mouse button and use the mouse to move the plot around.</td>
<td></td>
</tr>
<tr>
<td><strong>Example:</strong> To zoom in and out, use . Hold down the left mouse button and draw a rectangle around the area you wish to zoom in on.</td>
<td></td>
</tr>
<tr>
<td><strong>Example:</strong> Different styles of point probe are available. To use the point probe to find the coordinates of points on your curve, select <strong>Manipulator&gt;Point Probe</strong> and <strong>Probe Info&gt;Nearest point on line</strong>, or select the corresponding options using .</td>
<td></td>
</tr>
</tbody>
</table>
Combining Plots

You can easily add another plot on the same set of axes.

Example: Plot \( \sin^2(x) \). Then enter another equation in \( x \) into your worksheet (e.g. \( \sin\left(\frac{x}{2}\right) \)), highlight the new expression with your mouse, hold down the [Ctrl] key and drag it onto the plot.

Annotating Plots

You can add additional information to plots by using the drawing tools. Lines, arrows, text, 2-D math, and shapes are available.

Example: Click on the plot, then select Drawing from the drop-down menu on the left side of the toolbar. Use the Text Tool (T) to enter labels for the curves. Use [F5] to toggle between text and math, and standard Maple math editor entry keystrokes.

When you are finished, select Plot from the drop-down menu to exit Drawing mode.
3-D Plots

Example: Enter an expression in x and y (e.g. $\sin(x) \cdot y$). Select Plots > 3-D Plots > x, y from the context panel.

Example: To rotate the plot: Click on the plot, and then hold down the left mouse button and move the mouse.

Example: Pan and zoom the plot by selecting the appropriate tool from the toolbar or the Manipulator list on the context panel. Now when you hold down and move the mouse, the new action is performed.

Plot Options

You can modify the look of your plot in a variety of ways.

Plot options can be changed using the context panel. The available options depend on the type of plot.

Example: Click Transparency and modify the plot transparency.
Using the Plot Builder

Plots can easily be created and customized in Maple using the Plot Builder. Using the Plot Builder, you can choose the type of plot you want and set options all at the same time. The plot is updated instantly so you can see the results of your choices.

**Example:** Enter the expression you want to plot, for example, \( x^2 + y^2 \). From the context panel, select **Plot Builder**, then choose **2-D contour plot** as the plot type.

**Example:** Using the drop-down menu, change the plot type to **3-D plot**. The plot changes from a contour plot to a 3-D plot. Then use the options to customize the plot. For example:

Under Basic Options, for shading, select **zhue**, and set style to **surface**. Select **Axes and Text**, then enter a title for the plot and press **[ENTER]**.

**Tip:** You can use the Plot Builder to create and customize your plot, and then use the **show command** option under Basic Options to see the corresponding Maple command that produces exactly that plot.
Using Plotting Commands

The most commonly used plot commands are plot(), for 2-D plots, and plot3d().

Plot \( \sin(x) \) using the plot command as shown.

Note that you can still use the context menus to change the properties of this plot.

Plot commands take many different customization options. For example, the 3-D plot from the previous example could also be created using the command on the right.

Enter "Plotting Guide" in the search box on the toolbar and select the Plotting Guide. This guide is a good place to go when you want to create something other than a regular 2-D or 3-D graph.

More information on using commands and the help system can be found later in this document.
Assistants, Tutors, and Math Apps

In addition to the Plot Builder, Maple includes many other interactive tools for performing simple and complex tasks, as well as for exploring concepts. Some examples are below. See the **Tools** menu for the full list.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Using the Exploration Assistant</strong></td>
<td><em>plot3d(cos(a x) + b sin(y))</em></td>
</tr>
<tr>
<td>The <strong>Exploration Assistant</strong> allows you to instantly create</td>
<td><img src="image" alt="plot3d graph" /></td>
</tr>
<tr>
<td>interactive mini-applications used to explore the parameters of an</td>
<td></td>
</tr>
<tr>
<td>expression, even if that expression involves Maple commands.</td>
<td></td>
</tr>
<tr>
<td>Explore generates a user interface with interactive sliders, dials</td>
<td></td>
</tr>
<tr>
<td>or gauges that can vary the values for the parameters and show the</td>
<td></td>
</tr>
<tr>
<td>results.</td>
<td></td>
</tr>
<tr>
<td><strong>Example:</strong> Type <em>plot3d(cos(a x) + b sin(y))</em> but don't press</td>
<td></td>
</tr>
<tr>
<td>[ENTER]. Select <strong>Explore</strong> from the context panel. From here, you</td>
<td></td>
</tr>
<tr>
<td>can set the range of values you want to explore, as well as specify</td>
<td></td>
</tr>
<tr>
<td>any variables to <strong>skip</strong>. When you select <strong>skip</strong>, that parameter</td>
<td></td>
</tr>
<tr>
<td>remains as a symbolic unknown in the expression; no slider will be</td>
<td></td>
</tr>
<tr>
<td>created to control that value. With this expression, choose to skip</td>
<td></td>
</tr>
<tr>
<td><strong>x</strong> and <strong>y</strong>. Move the sliders to change the plot.</td>
<td></td>
</tr>
<tr>
<td>The Explore functionality is also available through the Explore()</td>
<td></td>
</tr>
<tr>
<td>command, which provides even more functionality and customization</td>
<td></td>
</tr>
<tr>
<td>options.</td>
<td></td>
</tr>
</tbody>
</table>
Using Tutors in Maple

Maple provides many tutors, which are useful for teaching and exploring mathematical concepts in calculus, precalculus, linear algebra, statistics, and more.

*Example:* From the menu, select **Tools > Tutors > Calculus - Single Variable > Integration Methods**. Enter a function and follow the example through by applying the correct rule at each step and using **Get Hint** for help.
Math Apps

Math Apps in Maple provide interactive explorations of various mathematical and scientific concepts. Math Apps are available for many different fields including algebra, functions, calculus, discrete math, engineering, finance, statistics, and more.

Examples: From the menu, select Tools > Math Apps. Choose from the different categories by clicking on the corresponding icon.

For instance, click on Algebra and Geometry, and then click on Conic Sections, which is in the Geometry section. Move the sliders to see how the intersection of the plane through the cone results in different curves.

From the Calculus>Integral section, choose Solids of Revolution: Volume by Disks, and then enter, or even draw a curve and see an animation of its revolution.

In addition to interactive Math Apps, in the Engineering and Applications section, you will also find example applications that illustrate how to solve and explore particular problems using a command-driven approach.

Tip: You can also view Math Apps online in the MapleCloud (at maple.cloud), using only a web browser.
Tasks

For more task-specific help, choose **Tools>Tasks...** to browse through a large collection of task templates for solving problems from calculus, algebra, geometry, differential equations, statistics, and more. Even if you choose not to use the template themselves, the Task Templates are a still good resource for learning how to use Maple to solve various problems.
## Entering Commands

While many operations in Maple can be done through the use of the context panel and other interactive tools, Maple also has an extensive set of commands, as well as a rich programming language.

### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Results</th>
</tr>
</thead>
</table>
| **Entering Maple Commands** | **factor( x^4 - y^4 )**  
  \( (x - y) (x + y) (x^2 + y^2) \) (6.1) |
| Maple has over 5000 commands, which you can call directly. | **M := \begin{bmatrix} 1 & 2 \\ 3 & 5 \end{bmatrix}** (6.2)  
  \( \text{LinearAlgebra[Determinant]}(M) \)  
  -1 (6.3)  
  \( \text{Determinant}(M) \)  
  \( \text{Determinant}\left( \begin{bmatrix} 1 & 2 \\ 3 & 5 \end{bmatrix} \right) \) (6.4) |
| Many commands are organized into packages, When calling these commands, you have to tell Maple where to find them. | **Example:** Using the Matrix palette, create a Matrix, M, and then use the Determinant command from the LinearAlgebra package, \( \text{LinearAlgebra[Determinant]} \), to find the determinant of M. |
| **Tip:** If you do not provide the package name, Maple does not know the definition of this function, and so it simply returns the unevaluated expression, as shown. If you see something like this, it usually means that you need to tell Maple which package the command comes from, or that you have mistyped the command name. | You can avoid having to type the long-form of each command by loading the desired package using \textit{with(Package)}. This command loads the package and returns a list of all the commands in that package. You can put a colon at the end of any command to suppress its output. |
**Example:** Load the LinearAlgebra package. Now add a colon to the end to see the difference.

**Example:** Now calculate the Determinant of M using the short-form of the command.

Command completion is very useful when typing long command names.

**Example:** Type Gau, then press [Esc] to see a list of possible completions. Use the arrow key to select the desired command and press [Enter], or select the command with the mouse.

**Tip:** Many packages can be loaded through Tools > Load Package. See Tools > Load Package > List All Packages... to see the complete list of packages.

\[
\text{with(LinearAlgebra)} : \\
\text{Determinant}(M) \\
\begin{bmatrix}
-1
\end{bmatrix}
\]

\[
\text{GaussianElimination}(M) \\
\begin{bmatrix}
1 & 2 \\
0 & -1
\end{bmatrix}
\]
Getting Help

Many resources are available to help you find your way around Maple, from "How do I?" guides for new users to information for advanced Maple programmers.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the Help System</td>
<td><img src="image" alt="Maple Help System" /></td>
</tr>
</tbody>
</table>

You can open the help system at any time from the Help menu, **Help>Maple Help**. From here, you can browse the entire help system through the Table of Contents, or search for what you need.

If you know the name of the command you are interested, you can bring up its help page using the ? command.

**Example:** Type `?isprime` to bring up the help page for the primality test command `isprime`.

**Tip:** You can place your cursor on a Maple command in your worksheet and press `[F2]` to bring up the help page for that command.
Maple Portal

The Maple Portal brings together a collection of useful resources for learning about Maple, including:

• Getting started resources
• How do I...? mini-tutorials
• Training videos
• User and programming manuals
• Examples and applications
• Additional resources for students and educators
• How to get additional help

*Example:* Type `?MaplePortal` to open the Portal.