MapleSim Product Installation and Licensing Guide


MapleSim 2019 and Add-ons Installation and Licensing Guide
Maple Requirements
Compiler Requirements
MapleSim 2019 and Add-ons Installation Using a Single User License
Activating Single User Versions
MapleSim 2019 and Add-ons Installation Using a Network License
Silent (Unattended) Installation
Configure the License Manager
Named Network Licensing
Installing and Setting Up a Microsoft Visual C++ Compiler for 64-bit Operating Systems
Getting Started
Verifying Video Card Driver Requirements
Graphics Requirements
Virtual Machines
Third Party Supported Platforms
System Requirements
Trademarks

MapleSim 2019 and Add-ons Installation and Licensing Guide

This installation guide contains information on how to install MapleSim™ and the MapleSim add-ons. Use it to install the products that you have purchased.

Maple Requirements

MapleSim 2019 requires that Maple 2019.1 be installed. If you have Maple 2019, installing MapleSim 2019 will automatically upgrade your Maple version to Maple 2019.1. If you do not have Maple 2019 and require Maple 2019 installation and activation instructions, you can view the Maple 2019 Installation and Licensing Guide from the Maplesoft Documentation Center.

Compiler Requirements

MapleSim will automatically detect the presence of a compiler. If you do not have Microsoft Visual Studio installed, MapleSim will use the built-in LLVM compiler (64-bit platform) or built-in Watcom compiler (32-bit platform).

On Macintosh and Linux platforms, if you do not have GCC installed, MapleSim will use the built-in LLVM compiler. There is no option to switch between compilers; if Microsoft Visual Studio or GCC is installed and configured it will be used to compile.

Note: Microsoft Visual C++ is required for FMU Generation.

MapleSim 2019 and Add-ons Installation Using a Single User License

During the installation process, you will need the purchase code that was sent to you in an email.

Add-Ons Install Directory

MapleSim add-on products are installed in subdirectories within the Maple directory.

  • In Windows, the add-on installation path is <Maple_directory>\toolbox\toolbox_name, where Maple_directory is the install location of Maple 2019, for example, C:\Program Files\Maple 2019.
  • In Linux®, the add-on installation path is $MAPLE/toolbox/toolbox_name, where $MAPLE is the Maple path environment variable.
  • In Macintosh®, the toolbox installation path is Library/Frameworks/Maple.framework/Versions/2019/toolbox/toolbox_name

32-bit Windows Single User Installation

  1. Choose one of the following two options to launch the installer:
  • From download

Double-click MapleSim2019.1ProductWindowsX86Installer.exe from where you downloaded the file.

  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click MapleSim2019.1ProductWindowsX86Installer.exe from the install disc.
  1. At the Setup - MapleSim screen click Next to begin the installation process.
  1. Accept the License Agreement to continue with the installation.
  1. From the Choose the Type of Licensing screen select Single User License.
  1. Specify the path to your existing Maple 2019 installation.
  1. Enter your purchase code for your product (MapleSim, MapleSim Add-ons, or MapleSim Explorer).
  1. Follow the on-screen instructions to complete the installation process.
  1. If you activated successfully, you are ready to use the installed product. If you chose not to activate during installation, see Activating Single User Versions for specific instructions on single user activation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Return to Start.

64-bit Windows Single User Installation

  1. Choose one of the following two options to launch the installer:
  • From download

Double-click MapleSim2019.1ProductWindowsX64Installer.exe from where you downloaded the file.

  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click MapleSim2019.1ProductWindowsX64Installer.exe from the install disc.
  1. At the Setup - MapleSim screen click Next to begin the installation process.
  1. Accept the License Agreement to continue with the installation.
  1. From the Choose the Type of Licensing screen select Single User License.
  1. Specify the path to your existing Maple 2019 installation.
  1. Enter your purchase code for your product (MapleSim, MapleSim Add-ons, or MapleSim Explorer).
  1. Follow the on-screen instructions to complete the installation process.
  1. If you activated successfully, you are ready to use the installed product. If you chose not to activate during installation, see Activating Single User Versions for specific instructions on single user activation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Return to Start.

Macintosh Single User Installation

  1. Choose one of the following two options to launch the installer:
  • From download

Double-click MapleSim2019.1ProductMacInstaller.dmg from where you downloaded the file, then double-click MapleSim2019.1ProductMacInstaller.

  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click MapleSim2019.1ProductMacInstaller.dmg from the install disc, then double-click MapleSim2019.1ProductMacInstaller.
  1. At the Setup - MapleSim screen click Next to begin the installation process.
  1. Accept the License Agreement to continue with the installation.
  1. From the Choose the Type of Licensing screen select Single User License.
  1. Specify the path to your existing Maple 2019 installation.
  1. Enter your purchase code for your product (MapleSim, MapleSim Add-ons, or MapleSim Explorer).
  1. Follow the on-screen instructions to complete the installation process.
  1. If you activated successfully, you are ready to use the installed product. If you chose not to activate during installation, see Activating Single User Versions for specific instructions on single user activation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Return to Start.

64-bit Linux Single User Installation

  1. Choose one of the following two options to launch the installer:
  • From download

Run MapleSim2019.1ProductLinuxX64Installer.run from where you downloaded the file.

  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and run MapleSim2019.1ProductLinuxX64Installer.run from the install disc.
  1. At the Setup - MapleSim screen click Next to begin the installation process.
  1. Accept the License Agreement to continue with the installation.
  1. From the Choose the Type of Licensing screen select Single User License.
  1. Specify the path to your existing Maple 2019 installation.
  1. Enter your purchase code for your product (MapleSim, MapleSim Add-ons, or MapleSim Explorer).
  1. Follow the on-screen instructions to complete the installation process.
  1. If you activated successfully, you are ready to use the installed product. If you chose not to activate during installation, see Activating Single User Versions for specific instructions on single user activation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Return to Start.

Activating Single User Versions

MapleSim and each Add-on product require license files to operate. License files for earlier versions will not work with MapleSim 2019 and Add-ons. You must activate the single user versions of MapleSim 2019 and Add-ons to obtain your license files. If you are running a single user installer, you can activate during the installation process. If you do not activate during the installation process, follow the steps below.

Note: Activation requires an Internet connection. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.

Windows

  1. Launch the Maplesoft Activation window.
  • On Windows 7, select Start > (All) Programs > MapleSim 2019 > Tools > Activate <product name>, where <product name> is either MapleSim 2019 or the Add-on product you want to activate. Note: If you are using Windows 7, right-click Activate <product name> and select Run as administrator.
  • On Windows 8.1, right-click anywhere in the Start window. The toolbar opens at the bottom of the screen. Next, click the All apps icon. Under the MapleSim 2019 heading, right-click on the Activate <product name> tile. Next, click the Run as administrator icon.
  1. When the window opens, you will be prompted to enter your purchase code. After you have entered your purchase code, click Next. Note: If you are activating behind a proxy server, select the Yes option, and make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information. Click Next when this is complete.

A license (.dat) file will be saved in the toolbox\<product name>\license folder of your Maple 2019 installation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Linux

  1. To launch the Maplesoft Activation window, run the activation script located in the $HOME/Maple2019/toolbox/<product name>/license directory.
  1. When the window opens, you will be prompted to enter your purchase code. After you have entered your purchase code, click Next. Note: If you are activating behind a proxy server, select the Yes option, and make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information. Click Next when this is complete.

A license (.dat) file will be saved in the toolbox/<product name>/license folder of your Maple 2019 installation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Macintosh

  1. To launch the Maplesoft Activation window, run the activation script located in the toolbox/<product name>/license folder of your Maple 2019 installation. By default, /Library/Frameworks/Maple.framework/Versions/2019/toolbox/<product name>/license.
  1. When the window opens, you will be prompted to enter your purchase code. After you have entered your purchase code, click Next. Note: If you are activating behind a proxy server, select the Yes option, and make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information. Click Next when this is complete.

A license (.dat) file will be saved in the in the toolbox/<product name>/license folder of your Maple 2019 installation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Return to Start.

MapleSim 2019 and Add-ons Installation Using a Network License

Note: For network license installations, the system administrator must activate a network license and configure the license manager. For full instructions on how to configure the license manager, refer to the Install.html file in your Maple 2019 install directory.

Add-Ons Install Directory

MapleSim add-on products are installed in subdirectories within the Maple directory.

  • In Windows, the add-on installation path is <Maple_directory>\toolbox\toolbox_name, where Maple_directory is the install location of Maple 2019, for example, C:\Program Files\Maple 2019.
  • In Linux®, the add-on installation path is $MAPLE/toolbox/toolbox_name, where $MAPLE is the Maple path environment variable.
  • In Macintosh®, the toolbox installation path is Library/Frameworks/Maple.framework/Versions/2019/toolbox/toolbox_name

32-bit Windows Installation Using a Network License

  1. Choose one of the following two options to launch the installer:
  • From download

Double-click MapleSim2019.1ProductWindowsX86Installer.exe from where you downloaded the file.

  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click MapleSim2019.1ProductWindowsX86Installer.exe from the install disc.
  1. Follow the on-screen instructions.
  1. At the Setup - MapleSim screen click Next to begin the installation process.
  1. Accept the License Agreement to continue with the installation.
  1. In the Choose the Type of Licensing screen, select Use Network License Server.
  1. Select either MapleSim or MapleSim Explorer in the MapleSim License Type dialog.
  1. Specify the path to your Maple 2019 installation.
  1. Select the components you want to install.
  1. In the Single or Redundant Server screen, do one of the following, depending on whether you have a single or redundant license server setup.
  • If you have a single license server setup:
  1. Select Single Server, and then click Next.
  1. Enter the name or IP address of the license server in License server.
  1. Enter the port number of the license server in Port number.
  1. Click Next.
  • If you have a redundant license server setup:
  1. Select Redundant Server, and then click Next.
  1. Enter the names or IP addresses of the license servers in License server 1, License server 2, and License server 3.
  1. Enter the port numbers of the license servers in Port number 1, Port number 2, and Port number 3.
  1. Click Next.
  1. Click Install, then click Done.

Return to Start.

64-bit Windows Installation Using a Network License

  1. Choose one of the following two options to launch the installer:
  • From download

Double-click MapleSim2019.1ProductWindowsX64Installer.exe from where you downloaded the file.

  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click MapleSim2019.1ProductWindowsX64Installer.exe from the install disc.
  1. Follow the on-screen instructions.
  1. At the Setup - MapleSim screen click Next to begin the installation process.
  1. Accept the License Agreement to continue with the installation.
  1. In the Choose the Type of Licensing screen, select Use Network License Server.
  1. Select either MapleSim or MapleSim Explorer in the MapleSim License Type dialog.
  1. Specify the path to your Maple 2019 installation.
  1. Select the components you want to install.
  1. In the Single or Redundant Server screen, do one of the following, depending on whether you have a single or redundant license server setup.
  • If you have a single license server setup:
  1. Select Single Server, and then click Next.
  1. Enter the name or IP address of the license server in License server.
  1. Enter the port number of the license server in Port number.
  1. Click Next.
  • If you have a redundant license server setup:
  1. Select Redundant Server, and then click Next.
  1. Enter the names or IP addresses of the license servers in License server 1, License server 2, and License server 3.
  1. Enter the port numbers of the license servers in Port number 1, Port number 2, and Port number 3.
  1. Click Next.
  1. Click Install, then click Done.

Return to Start.

Macintosh Installation Using a Network License

  1. Choose one of the following two options to launch the installer:
  • From download

Double-click MapleSim2019.1ProductMacInstaller.dmg from where you downloaded the file, then double-click MapleSim2019.1ProductMacInstaller.

  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click MapleSim2019.1ProductMacInstaller.dmg from the install disc, then double-click MapleSim2019.1ProductMacInstaller.
  1. Follow the on-screen instructions.
  1. At the Setup - MapleSim screen click Next to begin the installation process.
  1. Accept the License Agreement to continue with the installation.
  1. In the Choose the Type of Licensing screen, select Use Network License Server.
  1. Select either MapleSim or MapleSim Explorer in the MapleSim License Type dialog.
  1. Specify the path to your Maple 2019 installation.
  1. Select the components you want to install.
  1. In the Single or Redundant Server screen, do one of the following, depending on whether you have a single or redundant license server setup.
  • If you have a single license server setup:
  1. Select Single Server, and then click Next.
  1. Enter the name or IP address of the license server in License server.
  1. Enter the port number of the license server in Port number.
  1. Click Next.
  • If you have a redundant license server setup:
  1. Select Redundant Server, and then click Next.
  1. Enter the names or IP addresses of the license servers in License server 1, License server 2, and License server 3.
  1. Enter the port numbers of the license servers in Port number 1, Port number 2, and Port number 3.
  1. Click Next.
  1. Click Install, then click Done.

Return to Start.

64-bit Linux Installation Using a Network License

  1. Choose one of the following two options to launch the installer:
  • From download

Run MapleSim2019.1ProductLinuxX64Installer.run from where you downloaded the file.

  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and run MapleSim2019.1ProductLinuxX64Installer.run from the install disc.
  1. Follow the on-screen instructions.
  1. At the Setup - MapleSim screen click Next to begin the installation process.
  1. Accept the License Agreement to continue with the installation.
  1. In the Choose the Type of Licensing screen, select Use Network License Server.
  1. Select either MapleSim or MapleSim Explorer in the MapleSim License Type dialog.
  1. Specify the path to your Maple 2019 installation.
  1. Select the components you want to install.
  1. In the Single or Redundant Server screen, do one of the following, depending on whether you have a single or redundant license server setup.
  • If you have a single license server setup:
  1. Select Single Server, and then click Next.
  1. Enter the name or IP address of the license server in License server.
  1. Enter the port number of the license server in Port number.
  1. Click Next.
  • If you have a redundant license server setup:
  1. Select Redundant Server, and then click Next.
  1. Enter the names or IP addresses of the license servers in License server 1, License server 2, and License server 3.
  1. Enter the port numbers of the license servers in Port number 1, Port number 2, and Port number 3.
  1. Click Next.
  1. Click Install, then click Done.

Return to Start.

Silent (Unattended) Installation

It is possible to install both single user and network versions of MapleSim and Add-ons using an unattended mode option. There are two ways to perform an unattended installation of MapleSim and Add-ons:

  • Using options specified directly in the command line
  • Using a resource file

Note: While you can install the single user version of MapleSim and Add-ons using an unattended mode option, it is not possible to activate the product at this time. After the silent installation of the single user version of MapleSim 2019 and Add-ons is complete, follow the activation instructions in Activating Single User Versions.

Using options specified directly in the command line

You can run an unattended installation without a resource file by specifying the installation options directly in the command line. To run the unatttended installation this way, do the following:

32-bit and 64-bit Windows

  1. Open a command prompt window.
  1. Browse to the directory in which your MapleSim 2019 install file is located.
  1. Run the unattended installation process with the appropriate command for your platform.

For 32-bit Windows use the following syntax:

MapleSim2019.1ProductWindowsX86Installer.exe --option optionvalue

For 64-bit Windows use:

MapleSim2019.1ProductWindowsX64Installer.exe --option optionvalue

For example, on 32-bit Windows, use the command

MapleSim2019.1ProductWindowsX86Installer.exe --mode unattended

to install MapleSim and Add-ons in unattended mode.

Linux

  1. Browse to the directory where your MapleSim 2019 install file is located.
  1. Run the following command:

./MapleSim2019.1ProductLinuxX64Installer.run --option optionvalue

For example, use the command

MapleSim2019.1ProductLinuxX64Installer.run --mode unattended

to install MapleSim and Add-ons in unattended mode.

Mac OS X

  1. Open a command terminal.
  1. Browse to the directory where your MapleSim 2019 install file is located.
  1. Run the following command:

MapleSim2019.1ProductMacInstaller.app/Contents/MacOS/installbuilder.sh --option optionvalue

For example, on Mac OS X, use the command

MapleSim2019.1ProductMacInstaller.app/Contents/MacOS/installbuilder.sh --mode unattended

to install MapleSim and Add-ons in unattended mode.

Using a Resource File

32-bit and 64-bit Windows

  1. Check the Windows System Requirements.
  1. Close all programs, particularly any previous release of MapleSim and Add-ons
  1. Log on as administrator or ensure that you have administrator privileges
  1. Create a resource file.

You can create your own installer.properties file using the following example as a template:

mode=unattended

defaultapp=1

desktopshortcut=1

maplepath= <Path to Maple 2019 installation>

licenseType=network

serverName=myServerName

portNumber=27000

  1. Open a command prompt window.
  1. Browse to the directory in which your MapleSim2019.1ProductWindowsX86Installer.exe or MapleSim2019.1ProductWindowsX64Installer.exe file is located.
  1. Run the silent installation process with the command MapleSim2019.1ProductWindowsX86Installer.exe --optionfile <optionfile> (32-bit Windows) or MapleSim2019.1ProductWindowsX64Installer.exe --optionfile <optionfile> (64-bit Windows), where <optionfile> is the name of the option file.

Note: If you created your option file in a directory other than the directory in which the MapleSim2019.1ProductWindowsX86Installer.exe or MapleSim2019.1ProductWindowsX64Installer.exe file is located, you must specify the path to the option file when you run this command.

Linux

  1. Check the Linux System Requirements.
  1. Close all programs, particularly any previous release of MapleSim and Add-ons
  1. Log on as administrator or ensure that you have administrator privileges.
  1. Create a resource file.

You can create your own installer.properties file using the following example as a template:

mode=unattended

desktopshortcut=1

maplepath=<Path to Maple 2019 installation>

licenseType=network

serverName=myServerName

portNumber=27000

  1. Open a command prompt window.
  1. Browse to the directory in which your MapleSim2019.1ProductLinuxX64Installer.run file is located.
  1. Run the silent installation process with the command MapleSim2019.1ProductLinuxX64Installer.run --optionfile <optionfile>, where <optionfile> is the name of the option file.

Note: If you created your option file in a directory other than the directory in which the MapleSim2019.1ProductLinuxX64Installer.run file is located, you must specify the path to the option file when you run this command.

Mac OS X

  1. Check the Mac OS X System Requirements.
  1. Close all programs, particularly any previous release of MapleSim and Add-ons
  1. Log on as administrator or ensure that you have administrator privileges.
  1. Create a resource file.

You can create your own installer.properties file using the following example as a template:

mode=unattended

desktopshortcut=1

maplepath=<Path to Maple 2019 installation>

licenseType=network

serverName=myServerName

portNumber=27000

  1. Open a command prompt window.
  1. Browse to the directory in which your MapleSim2019.1ProductMacInstaller file is located.
  1. Run the silent installation process with the command MapleSim2019.1ProductMacInstaller.app/Contents/MacOS/installbuilder.sh --optionfile <optionfile> where <optionfile> is the name of the option file.

Note: If you created your option file in a directory other than the directory in which the MapleSim2019.1ProductMacInstaller.dmg file is located, you must specify the path to the option file when you run this command.

Available Installation Options

Option Name

Description

Allowed Values

Default Value

Platform Availability

optionfile

Name of option file

string

 

Mac; Linux; Windows

mode

Installation mode

win32; unattended

win32

Windows

installer-language

 

en

en

Mac; Linux; Windows

upgradeOrReinstall

If an existing installation is found, specify whether to upgrade the current installation or uninstall the old installation before reinstalling.

upgrade; reinstall

 

Mac; Linux; Windows

defaultapp

Make Maple 2019 the default application for Maple worksheet (.mw and .mws) files

0 or 1

1

Windows

desktopshortcut

Install desktop shortcuts

0 or 1

1

Mac;Linux;Windows

defaulttoolbox

Default toolbox is either Maple or MATLAB® (only valid if the MATLAB® installation contains the MATLAB® Symbolic Math Toolbox™)

Maple; MATLAB

 

Mac; Linux; Windows

licenseType

Type of Licensing

single; network

single

Mac; Linux; Windows

activate

Activate Maplesoft product license

now; later

now

Mac; Linux; Windows

serverName

Name of license server

string

 

Mac; Linux; Windows

portNumber

Port number on license server

numeric

27000

Mac; Linux; Windows

maplepath

Path to Maple 2019 installation

string

 

Mac; Linux; Windows

enable-components <enable-components>

Comma-separated list of components

maplesim ControlDesign CadToolbox MapleSimConnectors MapleSimConnector BRConnector FMIConnector JMAGRTConnector LabVIEWVeriStandConnector MapleSimComponents DrivelineComponentLibrary HeatTransferLibrary TireComponentLibrary ModelonEngineDynamics ModelonHydraulics ModelonPneumatics BatteryComponentLibrary

maplesim, ControlDesign, CadToolbox, MapleSimConnectors, MapleSimConnector, BRConnector, FMIConnector, JMAGRTConnector, LabVIEWVeriStandConnector, MapleSimComponents, DrivelineComponentLibrary, HeatTransferLibrary, TireComponentLibrary, ModelonEngineDynamics, ModelonHydraulics, ModelonPneumatics, BatteryComponentLibrary

Mac†; Linux‡; Windows

disable-components <disable-components>

Comma-separated list of components

maplesim ControlDesign CadToolbox MapleSimConnectors MapleSimConnector BRConnector FMIConnector JMAGRTConnector LabVIEWVeriStandConnector MapleSimComponents DrivelineComponentLibrary HeatTransferLibrary TireComponentLibrary ModelonEngineDynamics ModelonHydraulics ModelonPneumatics BatteryComponentLibrary

 

Mac†; Linux‡; Windows

†: The JMAGRTConnector and CadToolbox options are not available for Macintosh installers.

‡: The CadToolbox option is not available for Linux installers.

Additional Information

  • You are not provided with any feedback when you run the installer in this mode

Silently Uninstalling MapleSim and Add-ons

  1. To perform a silent uninstallation of MapleSim and Add-ons, at a command prompt, run the uninstall command, located in the toolbox/<product name>/uninstall directory, as follows:

toolbox/<product name>/uninstall/uninstall --mode unattended

Return to Start.

Configure the License Manager

Configure the License Manager for Windows

Before starting the Windows Network version of MapleSim 2019 and Add-ons, you must obtain your license file and start the license manager by completing the following tasks.

Install FlexNet Publisher and Activation Utilities

  1. Choose one of the following:
  1. On Windows 32-bit, double-click the NetworkToolsWindowsX86Installer.exe file from the install disc or from where you downloaded the file.
  1. On Windows 64-bit, double-click the NetworkToolsWindowsX64Installer.exe file from the install disc or from where you downloaded the file.
  1. Close all programs, particularly Microsoft® Excel® and any previous release of MapleSim and Add-ons.
  1. Follow the on-screen instructions.

Activate a Network License

MapleSim 2019 and Add-ons requires a MapleSim 2019 and Add-ons license file to operate. License files for earlier versions of MapleSim and Add-ons do not work with MapleSim 2019 and Add-ons. To obtain your license file, you must use the Maple Network Tools activation program or activate off-line by following the instructions at http://www.maplesoft.com/contact/webforms/offlineactivation/. Ensure that you can connect to the Internet as activation requires an Internet connection. If your computer does not have an Internet connection, please contact Maplesoft customer service.

  1. Depending on your version of Windows, do one of the following:
  • If you are using Windows 8.1, from Start screen swipe up from the middle of the screen or alternatively, move the mouse to the bottom left of the screen and click the downward arrow that appears. Under the Maple Network Tools heading, right-click on the Activate Maple tile. Next, click the Run as administrator icon.
  • For all other supported versions of Windows, from the Start menu, select (All) Programs > Maple Network Tools > Activate Maple.

Note: If you are using Windows 7, right-click Activate Maple and select Run as administrator.

  1. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is complete.
  1. A license file (.lic), will be saved to the C:\Program Files\Maple Network Tools\activate folder. You will need this license file in the next step.

Start the License Manager for Multiple Maplesoft Products

To run Maple and associated products, you must place all license files in the same directory. If you have other FlexNet Publisher license files stored in one central location, you can store Maple and associated product license files there as well.

Complete the following tasks:

Stop the License Manager
  1. Go to the directory of the FlexNet Publisher utilities that are currently being used and double-click lmtools.exe. Alternatively, in the Start menu, select (All) Programs>Maple Network Tools>LMTools11.13.1.2 Note: On Windows 8.1, from Start screen swipe up from the middle of the screen or alternatively, move the mouse to the bottom left of the screen and click the downward arrow that appears. Under the Maple Network Tools heading, click LMTools11.13.1.2
  1. Under the Service/License File tab, click Configuration using Services.
  1. Click the Config Services tab. From the Server Name list, select the service currently being used.
  1. Click the Start/Stop/Reread tab, then click Stop Server.
Move all MapleSim and Add-ons License Files to a Common Directory

Using Windows Explorer, move all of the license files to a common directory, for example, C:\Program Files\Maple Network Tools\activate.

Start the License Manager Daemons
  1. From the Start menu, select (All) Programs>Maple Network Tools >LMTools11.13.1.2. Note: On Windows 8.1, from Start screen swipe up from the middle of the screen or alternatively, move the mouse to the bottom left of the screen and click the downward arrow that appears. Under the Maple Network Tools heading, click LMTools11.13.1.2
  1. Under the Service/License File tab, click Configuration using Services.
  1. Click the Config Services tab.
  1. In the Config Services property sheet, enter or browse for the following:

Service Name

Enter a name for the service (optional)

Path to the lmgrd.exe file

C:\Program Files\Maple Network Tools\FLEXlm\11.13.1.2\windows\lmgrd.exe

Path to the license file Note: The path to the license file should not contain a terminating backslash

C:\Program Files\Maple Network Tools\activate

Path to the debug log file Enter the path to the directory containing the debug log file. You must create this file manually (log.txt is the manually created file in the example below), as it is not automatically generated.

C:\Program Files\Maple Network Tools\FLEXlm\11.13.1.2\windows\log.txt

  1. To set up the daemons as a service (recommended), select the Use Services check box. This is available for Windows 7 and Windows 8.1.
  1. To start the daemons at boot time (recommended), select the Start Server at Power Up check box.
  1. Click Save Service. When prompted to save the service, click Yes.
  1. Click the Start/Stop/Reread tab. In that property sheet, click Start Server to start the license manager daemons.

You can now use your network licensed Maplesoft products.

Novell Networks

FlexNet Publisher does not run on Novell or IPX/SPX. Follow these instructions to install the license manager on any network that is exclusively a Novell environment.

  1. Install TCP/IP on all client machines.
  1. Select a Windows computer that has TCP/IP installed to act as a license server and run the license daemons using the Start License Manager for MapleSim 2019 and Add-ons Only instructions.

Return to Start.

Configure the License Manager for Mac OS X

Before starting the Mac OS® X Network version of MapleSim 2019 and Add-ons, you must obtain your license file and start the license manager by completing the following tasks.

Install FlexNet Publisher and the Activation Utilities

  1. To begin installing the FlexNet Publisher and Activation Utilities, choose one of the following:
  1. Place the MapleSim 2019 and Add-ons DVD in the DVD-ROM drive.
  1. Double-click NetworkToolsMacInstaller.dmg from where you downloaded the file.
  1. Run the installer by double-clicking the NetworkToolsMacInstaller icon.
  1. Follow the on-screen instructions.

Activate a Network License

MapleSim 2019 and Add-ons requires a MapleSim 2019 and Add-ons license file to operate. License files for earlier versions of MapleSim and Add-ons do not work with MapleSim 2019 and Add-ons. To obtain your license file, you must use the Maple Network Tools activation program or activate off-line by following the instructions at http://www.maplesoft.com/contact/webforms/offlineactivation/. Ensure that you can connect to the Internet as activation requires an Internet connection. If your computer does not have an Internet connection, please contact Maplesoft customer service.

  1. From the Finder, open a terminal window from Applications -> Utilities.
  1. Change to the location of the activation utility directory. By default, /Users/<username>/Applications/Maple_Network_Tools/activate.
  1. Run the activation script by issuing the command ./activation. To launch activation in console mode, use the -console option.
  1. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is complete.
  1. When prompted, enter the name or IP address of the license server.
  1. A license file (.lic), will be saved to the /Users/<username>/Applications/Maple_Network_Tools/activate directory. You will need this license file for the next step.

Start the License Manager for Multiple Maplesoft Products

To run Maple and associated products, you must place all license files in the same directory. If you have other FlexNet Publisher license files stored in one central location, you can store Maple and associated product license files there as well.

Complete the following tasks:

Stop the License Manager

Go to the location of the FlexNet Publisher utilities that are currently being used. For MapleSim 2019 and Add-ons, the default location is /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.13.1.2/. Enter the command:

./lmdown

Move all MapleSim and Add-ons License Files to a Common Directory

Copy all the MapleSim and Add-ons network license files to /Users/<username>/Applications/Maple_Network_Tools/activate.

Start the License Manager Daemons
  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.13.1.2/.
  1. When starting license manager daemons, you must enter the path to the directory containing all license files. By default, /Users/<username>/Applications/Maple_Network_Tools/activate.

Note: Point to the directory only, not an actual license file.

  1. To start the license manager, enter the following command:

./lmgrd -c license_file_path -l debug_log

where license_file_path is the full path to the directory containing the license files and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

You can now use your network licensed Maplesoft products.

Return to Start.

Configure the License Manager for Linux

Before starting the Linux Network version of MapleSim 2019 and Add-ons, you must obtain your license file and start the license manager by completing the following tasks.

Install FlexNet Publisher and the Activation Utilities

  1. Run the NetworkToolsLinuxX64Installer.run file from the install disc or from where you downloaded the file.
  1. Follow the on-screen instructions.

Activate a Network License

MapleSim 2019 and Add-ons requires a MapleSim 2019 and Add-ons license file to operate. License files for earlier versions of MapleSim and Add-ons do not work with MapleSim 2019 and Add-ons. To obtain your license file, you must use the Maple Network Tools activation program or activate off-line by following the instructions at http://www.maplesoft.com/contact/webforms/offlineactivation/. Ensure that you can connect to the Internet as activation requires an Internet connection. If your computer does not have an Internet connection, please contact Maplesoft customer service.

  1. Change to the location of the activation utility directory. By default, $HOME/MapleNetworkTools/activate.
  1. Run the activation command. To launch activation in console mode, use the -console option.
  1. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is completed.
  1. A license file (.lic), will be saved to the $HOME/MapleNetworkTools/activate directory. You will need this license file for the next step.

Start the License Manager for Multiple Maplesoft Products

To run Maple and associated products, you must place all license files in the same directory. If you have other FlexNet Publisher license files stored in one central location, you can store Maple and associated product license files there as well.

Complete the following tasks:

Stop the License Manager

Go to the location of the FlexNet Publisher utilities that are currently being used. For MapleSim 2019 and Add-ons, the default location is /usr/local/MapleNetworkTools/FLEXlm/11.13.1.2/. Enter the command:

./lmdown
Move all MapleSim and Add-ons License Files to a Common Directory

Copy all of the MapleSim and Add-ons network license files to one folder, for example, $HOME/MapleNetworkTools/activate.

Start the License Manager Daemons
  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, $HOME/MapleNetworkTools/FLEXlm/11.13.1.2/.
  1. When starting license manager daemons, you must enter the path to the directory containing all of your license files. By default, $HOME/MapleNetworkTools/activate.

Note: Point to the directory only, not an actual license file.

  1. To start the license manager, enter the following command:

./lmgrd -c license_file_path -l debug_log

where license_file_path is the full path to the directory containing the license files and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

You can now use your network licensed Maplesoft products.

Return to Start.

Named Network Licensing

Named Network Users run MapleSim and Add-ons on their own client machines. These client machines are connected to the license server over the network. The Network Named User licensing option allows system administrators to strictly enforce which users, or client machines, may run MapleSim and Add-ons.

When you install Maple Network Tools, an options file (.opt) is automatically created in the $Maple Network Tools/activate directory.

Note: By default, the vendor daemon looks for the options file (maplelmg.opt) in the same directory that contains the license file used by the license server manager.

Setting Up Named Network Licensing

To set up Named Network User licensing, perform the following steps:

Edit the Options File

To manually edit the options file, perform the following steps:

  • Go to the directory that contains the options file. By default, this is $Maple Network Tools/activate.
  • INCLUDE lines in an options file state which users can run the product. Add an INCLUDE line for each product. If there is more than one user per product, add an INCLUDE line for each user, as well. Alternatively, you can use the GROUP syntax to combine authorized Named Users for a specific product.
Example 1: Specifying Maple 2019, MapleSim 2019, and Add-Ons users

INCLUDE Maple USER User1

INCLUDE Maple USER User2

INCLUDE Maple USER User3

INCLUDE Maple USER User4

INCLUDE MapleSim USER User3

INCLUDE MapleSim USER User4

INCLUDE <PRODUCTLICENSE>2019 USER User4

In the example above, <PRODUCTLICENSE> could be any of the following:

  • BRConnector
  • FMIConnector
  • JMAGRT
  • LabVIEWConnector
  • MapleSimConnector
  • MSBCL
  • MSDCL
  • MSHTL
  • MSTCL
  • MSMEDCL
  • MSPLFM
  • MSMHCL
  • ControlDesign
  • CADToolbox
  • MapleSimExplorer
  • MapleExplorer
Example 2: Using GROUP syntax to specify Maple 2019, MapleSim 2019, and Add-Ons users

GROUP Maple_users User1 User2 User3 User4

GROUP MapleSim_users User3 User4

INCLUDE Maple GROUP Maple_users

INCLUDE MapleSim GROUP MapleSim_users

INCLUDE <PRODUCTLICENSE>2019 USER User4

In the example above, <PRODUCTLICENSE> could be any of the following:

  • BRConnector
  • FMIConnector
  • JMAGRT
  • LabVIEWConnector
  • MapleSimConnector
  • MSBCL
  • MSDCL
  • MSHTL
  • MSTCL
  • MSMEDCL
  • MSPLFM
  • MSMHCL
  • ControlDesign
  • CADToolbox
  • MapleSimExplorer
  • MapleExplorer

Restart the License Manager.

You must restart the license manager for the changes to the options file to take effect.

Return to Start.

Installing and Setting Up a Microsoft Visual C++ Compiler for 64-bit Operating Systems

MapleSim is packaged with the Low Level Virtual Machine (LLVM) Compiler, which is installed with Maple. Particularly, the compiler consists of a built-in, library-callable version of clang, which is stored in memory. Previously, the Microsoft Visual C++ Compiler was required for MapleSim on Windows, and the GNU Compiler Collection (GCC) on Macintosh and Linux, but these are now only required in a couple of cases:

  • Exporting an FMU with the FMI Connector.
  • Using the Simulink Component Block Generation app with the Generate and Compile S-Function option.
  • Simulation of JMAG models

For instructions on installing and setting up the required software on your computer, see https://www.maplesoft.com/support/install/2016/Setting-VS-Compiler-MapleSim.pdf

Note: You need to log into an account with administrative privileges to set up and install the Microsoft Visual C++ compiler.

Return to Start.

Getting Started

When the installation and activation process is complete, start MapleSim. Examples are available for MapleSim and any activated Add-on product. To access the examples, from the Help menu, select Examples.

For more information, see the Getting Started Guide for your Add-on product, which can be found on your desktop.

Return to Start.

Verifying Video Card Driver Requirements

To optimize the performance of graphics in MapleSim 2019 and Add-ons, it is strongly recommended that you install the latest driver software available for your video card. Before using MapleSim 2019 and Add-ons, follow the steps in this section to verify and, if necessary, upgrade your video card driver software.

Identifying Your Video Card Type

32-bit and 64-bit Windows

  1. Do the following to open the Device Manager window:
  • Open the Start menu. In the Start Search field, search for devmgmt.msc. From the search results, click Device Manager.
  1. In the Device Manager window, expand the Display adapters section. Your video card type is listed in this section (for example, RADEON X600 Series).

Linux

Note: This step requires that you are logged into your computer as a root user or have sudo access. If you are using a network or shared computer, you may need to contact your system administrator.

  1. At a command prompt, run the lspci command (the lspci command might be located in /sbin or /usr/sbin directories).
  1. In the output, search for a line that contains "VGA" or "Display controller". For example,

01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)

01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)

Macintosh

  1. From the Apple menu, select About this Mac.
  1. Click More Info...
  1. In the System Profiler, expand the Hardware section in the left pane and click Graphics/Displays. Your video card is displayed beside Chipset Model in the panel at the right of the window (for example, Chipset Model: ATI Radeon HD 2600Pro).

Return to Start.

Verifying and Upgrading Your Driver Software

32-bit and 64-bit Windows

  1. In the Device Manager window, in the Display adapters section, right-click the entry for the video card used by your computer and select Update Driver... The Hardware Update Wizard is displayed.
  1. When prompted to connect to Windows Update, select Yes, this time only and click Next.
  1. Select Install the software automatically (Recommended) and click Next. The wizard checks whether a more current version of the driver software is available.

If the wizard indicates that the latest driver software is installed, click Finish to close the wizard. Your computer is configured to display graphics in MapleSim 2019 and Add-ons.

If the wizard indicates that a more current version of the driver software is available, follow the on-screen instructions to install the update.

Linux

  1. Identify the driver version used by your video card. See Identifying the Driver Version Used By Your Video Card for instructions.
  1. Visit your video card vendor's web site to check whether a more current version of the driver software is available. See Obtaining the Latest Driver Software for instructions.

If the version number of the latest driver software available from the vendor matches the version number of the driver software installed on your computer, your computer is configured to display graphics in MapleSim 2019 and Add-ons. If a more current version is available, download the driver software from the web site and install it on your computer.

Note: It is not recommended that you use driver software updates automatically detected by Linux software upgrade utilities

Macintosh

  • From the Apple menu, select Software Update...

If no driver software update is listed for your video card in the Software Update window, the latest version is installed on your computer. Your computer is configured to display graphics in MapleSim 2019 and Add-ons.

If a driver software update is listed, select the entry from the list and click Install. Follow the on-screen instructions to complete the installation.

Return to Start.

Downloading and Installing Driver Updates From a Vendor's Web Site

If you are using a Linux operating system, or if you are using a Windows or Macintosh operating system and the driver software that was automatically detected does not function as expected, download and install the latest driver from the web site of the video card vendor.

Identifying the Driver Version Used By Your Video Card

32-bit and 64-bit Windows
  1. In the Device Manager window, expand the Display adapters section.
  1. Right-click the entry for the video card used by your computer and select Properties. A dialog box that contains information related to your video card is displayed.
  1. Click the Driver tab. The driver version used by your video card is listed beside Driver Version at the top of the window.
Linux

First, determine whether hardware accelerated graphics are turned on.

  • In the root of your Linux installation, run the glxinfo | head command.

If hardware accelerated graphics are turned on, you will see a line that reads direct rendering: Yes. If this line reads direct rendering: No, hardware accelerated graphics are not turned on.

You can search the package management system of your Linux installation for drivers installed on your computer. Linux distributions use different package management systems; the instructions below are provided for the two most common Linux distributions.

dpkg-based Linux distributions such as Ubuntu

To query which packages are installed on your system, run the dpkg -l command. (Note that this is a lower-case letter L.) This command will display several lines of output, so it is useful to limit the output using the grep command. Continuing with the example above, enter the following command to search for NVIDIA® drivers.

dpkg -1 | grep -i nvidia

If you have a hardware accelerated driver installed, you will see an output line such as nvidia-glx-177. In this example, 177 is the major version number of the driver. The full driver version number is displayed in the second column. For example, it will look like 177.82-0ubuntu0.1 on a Ubuntu system.

Hardware accelerated AMD® and ATI™ drivers are named fglrx on Linux. For example, the package name could be fglrx-amdcccle and the version number may look like 2:8.543-0ubuntu4.1 on a Ubuntu system.

Intel® integrated accelerated graphics hardware may contain intel in the package name or just the chipset information, such as i810.

rpm-based Linux distributions such as SuSE and Red Hat Enterprise Linux

To query which packages are installed on an rpm-based Linux system, run the rpm -qa command. This command will list every package installed on your computer, so you can limit the search by using the grep command. For example,

rpm -qa | grep nvidia

Obtaining the Latest Driver Software

To download the latest driver software for your video card, visit the web site of your video card vendor

AMD or ATI Video Cards

Visit http://support.amd.com/us/gpudownload/Pages/index.aspx and search for the driver software for your operating system and video card type. Download and install the latest driver software available for your video card.

Note: If you are using an AMD Catalyst™ or ATI Catalyst video card, download the Catalyst Software Suite.

Intel Video Cards

Visit http://www.intel.com/support/graphics/ and search for the driver software for your chipset type. Download and install the latest driver software available for your video card.

For more information about identifying your chipset type in Windows, visit http://www.intel.com/support/chipsets/sb/cs-009245.htm.

For more information on upgrading your driver software in Linux, visit http://www.intel.com/support/graphics/sb/cs-010512.htm.

NVIDIA Video Cards

Visit http://www.nvidia.com/Download/index.aspx and search for the driver software for your operating system and video card type. Download and install the latest driver software available for your video card.

Return to Start.

Graphics Requirements

To optimize the performance of graphics in MapleSim and Add-ons, it is strongly recommended that you use the latest driver software available for your video card. For more information on verifying your video card driver software, see Verifying Video Card Driver Requirements.

Virtual Machines

For optimal performance, you should install and run MapleSim 2019 and Add-ons on a physical computer. If you run MapleSim 2019 and Add-ons on a virtual machine, you may experience performance issues.

Third Party Supported Platforms

For information about supported platforms for MapleSim Add-ons please see, http://www.maplesoft.com/products/system_requirements.aspx#maplesimaddons

Return to Start.

System Requirements

32-bit Windows System Requirements

Version

CPU

Recommended RAM

Hard Disk

Windows 7

Intel Pentium III 1 GHz

4 GB

4 GB

Windows 8.1

Intel Pentium III 1 GHz

4 GB

4 GB

Windows 10

Intel Pentium III 1 GHz

4 GB

4 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.

64-bit Windows System Requirements

Version

CPU

Recommended RAM

Hard Disk

Windows 7

AMD X86_64 1 GHz Intel Xeon, Intel 64

4 GB

4 GB

Windows Server 2012 R2

AMD X86_64 1 GHz Intel Xeon, Intel 64

4 GB

4 GB

Windows 8.1

AMD X86_64 1 GHz Intel Xeon, Intel 64

4 GB

4 GB

Windows 10

AMD X86_64 1 GHz Intel Xeon, Intel 64

4 GB

4 GB

Windows Server 2016

AMD X86_64 1 GHz Intel Xeon, Intel 64

4 GB

4 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform.

Macintosh System Requirements

Vendor

CPU

Operating System

Version

Recommended RAM

Hard Disk

Apple

64-bit Intel

OS X

10.12, 10.13, 10.14

4 GB

4 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform.

64-bit Linux System Requirements

Vendor

Operating System Version

CPU

Recommended RAM

Hard Disk

Additional required packages

Red Hat Enterprise Linux

7

Intel 64 or AMD X86_64

4 GB

4 GB

redhat-lsb

SUSE Linux Enterprise Desktop

15

Intel 64 or AMD X86_64

4 GB

4 GB

lsb

Ubuntu

18.04 LTS, 18.10

Intel 64 or AMD X86_64

4 GB

4 GB

lsb-base, lsb-core

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • X11 R6.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform.

Supported C++ Compilers

The following is a list of supported C++ compilers. Note that some add-ons have specific compiler requirements (see http://www.maplesoft.com/products/system_requirements.aspx#maplesimaddons for details).

Platform

Supported Compilers

Windows (32-bit)

Watcom*, Microsoft Visual Studio 2013, Microsoft Visual Studio 2015 and Microsoft Visual Studio 2017

Windows (64-bit)

Microsoft Visual Studio 2013, Microsoft Visual Studio 2015 and Microsoft Visual Studio 2017

Linux (64-bit)

GCC

Macintosh**

Xcode 5.1.1 (or greater) with the Command Line Tools

*: The Watcom compiler comes with the Maple 32-bit installer as an optional install.

**: For information on how to install and configure Xcode, see http://www.maplesoft.com/support/faqs/detail.aspx?sid=99396.

Return to Start.

Trademarks

Note: Maple uses the Flexera Software Corporation FlexNet Publisher as its license manager. This document contains all the information you require for a standard Maple installation. For more information, refer to the FlexNet Publisher documentation at http://www.flexerasoftware.com/.

Maple, MapleSim, Maplesoft, and Waterloo Maple are trademarks of Waterloo Maple Inc.

Intel is a registered trademark of Intel Corporation.

Linux is a registered trademark of Linus Torvalds.

Microsoft, Windows, Windows Server, Excel, Visual Studio, Visual C++, and Internet Explorer are registered trademarks of Microsoft Corporation.

Macintosh and Mac OS are registered trademarks of Apple Computer, Inc.

NVIDIA is a registered trademark of NVIDIA Corporation.

AMD, ATI, AMD Catalyst, and Catalyst are either trademarks or registered trademarks of Advanced Micro Devices, Inc.

Java and JRE are registered trademarks of Oracle and/or its affiliates.

FLEXlm and FlexNet are registered trademarks of Flexera Software Corporation.

JMAG is a registered trademark of JSOL Corp. in the US and other countries.

Watcom is a trademark of Sybase, Inc.

MATLAB and Symbolic Math Toolbox are trademarks or registered trademarks of The MathWorks, Inc.

All other brand names or product names are trademarks or registered trademarks of their respective companies.

Return to Start.