Maple Quick Start - Maple Programming Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : Getting Started : worksheet/help/quickstart

Maple Quick Start

 

Introduction

Talking to Maple

Entering Math

Combining Text and Math

Plotting

Task Assistants, Tutors and Math Apps

Entering Commands

Document Editing and Formatting Tools

Configuring the Maple Environment

Introduction

In this introductory course, you will become familiar with and comfortable in the Maple environment. You will learn how to use context menus, task assistants, and palettes to perform powerful analyses and create high-impact graphics with only a minimal knowledge of commands. You will also learn how to create technical reports that capture the knowledge behind an analysis directly in the Maple document. This course will give you the tools you need to get started quickly, and a solid foundation upon which to build your future Maple explorations.

To try this material on your own, start with an empty Maple document. Perform the steps found in the left column of each table below. The results of each step are displayed in the right column for your reference.

Note for non-Windows or international users: The keystrokes given in this document are for Windows using a QWERTY keyboard. If you are using a different platform or keyboard, see Help> Quick Help for the list of the most common keystrokes or the 2-D math shortcut keys help page.

Talking to Maple

In this section, you will learn the basics of asking Maple a question and getting a result.

Steps

Results

Using [ENTER]

 

When you launch Maple you start with a blank document, with menus and toolbars at the top, palettes on the side. At the cursor, you can start typing math. Press [ENTER] to see the result.

 

Example: Type "1+2 [ENTER]".

Notice that the result appears on the next line.

1+2

3

(2.1)

Using [Alt]+[ENTER]

 

In the example above, we obtained a result by pressing [ENTER] after our input.

 

You can also get Maple to return the result on the same line as your question by typing [Alt]+[ENTER] (hold down the alt key, then press the enter key).

 

Example: Type "x+5-2" then [Alt]+[ENTER].

x+52 = x+3

Context Menus

 

You can use Maple's context menus to perform a wide variety of operations.

 

Example: Place your cursor on the last result, and right-click. The context menu offers several operations to choose from according to the expression that you are using. To integrate this expression, select Integrate, then x.

 

Example: To plot the result of the integration, right-click on the result, and then select Plots > 2-D Plot.

 

The context menus are self-documenting. The text above the arrow shows what operation has been performed.

 

 

 x+52 = x+3integrate w.r.t. x12x2+3x

x+52 = x+3integrate w.r.t. x12x2+3x

Smart Popups

 

It is also possible to generate plots and to apply commands using Smart Popups. To turn on smart popups, select Clickable Math Popups option in the View menu.

Example: Enter 12x2+3x and click [Enter]. Hover the mouse over the output and then choose 2-D Plot.

 

 

12x2+3x = 12x2+3x

 

Changing the Problem

 

Mathematics in a Maple document are live. You can go back, make changes, and re-execute the problem to obtain a new result.

 

Example: Go back to your original calculation of "1 + 2", change the number "1" to a "3" and press [ENTER]. Note the change in output.

 

Example: In the context menu example, above, change the "x" to "10 x". Highlight the entire line, including the plot, then click Execute all selected groups, , found at the top of the Maple worksheet. All selected calculations are updated.

 

 

3+2

5

(2.2)

10  x+52 = 10x+3integrate w.r.t. x5x2+3x

 

Tip: Clicking Execute the entire worksheet,  , re-calculates the entire document

Entering Math

There are a number of methods to enter math into Maple. You can enter math using a combination of palettes, keyboard shortcuts, context menus and commands. Most operations can be entered in more than one way, so you can choose the method you are most comfortable with.

Steps

Results

Exact Answers and Numeric Approximations

 

Maple calculates exact answers (for example, fractions remain as fractions).

Example: On a new line, enter 1/2 + 1/3.

Note that the slash (/) automatically moves you to the denominator. The right-arrow will revert you back. Press [Alt]+[ENTER] to see the result on the same line.

 

Maple also calculates numeric approximations.Example: Right-click the result above and select Approximate from the context menu. Select accuracy of 5 digits.

 

If your problem uses decimal approximations already, Maple will return the answer in the same format.

Example: Try the example on the right.

 

You can apply different formatting to numeric results.

Example: Right-click the result above and select Numeric Formatting... from the context menu. Select Scientific, then click Apply Formatting.

12+13 = 56

12+13 = 56at 5 digits0.83333

0.5 x+13x = 0.8333333333x

0.5 x+13x = 8.33×10-1x

Palettes

 

Maple has over 1000 palette symbols within the palette menus. You can also use Maple's expression palette to input expressions. The expression palette contains fill-in-the-blank templates for common operations.

 

Example: Using the Expression Palette, find the integral of 4 t6+sint dt. Open the expression palette (click Expression on the left-hand side of your Maple document) and click the indefinite integral ( ) symbol. An indefinite integral template will appear in your worksheet. Fill in the place-holders (use [TAB] to move to the next placeholder). When done, press [ENTER] to evaluate.

 

Note: Use the caret symbol (^) to create a superscript, and right-arrow to revert back to normal text.

 

Example: Use the expression palette to find the limit of a function.

 

 

Tip: Put frequently used palette entries on the Favorites Palette. To do so, right-click on the desired expression in the palette and select Add to Favorites Palette.

 

Tip: Maple has many different palettes for entering expressions. To see all of the available palettes, right-click on the palette dock and select Arrange Palettes.

4t6+sint ⅆt

47t7cost

(3.1)

limx0sinx2x = 0

Symbol Completion

 

The symbol completion mechanism provides an alternative to palettes for entering symbols.

 

Type the first few characters of the symbol name, and press [Ctrl]+[Space]. Choose the desired symbol from the list.

 

Example: Try entering π2+x. To enter π, type Pi [Ctrl]+[Space]. For x, enter sqrt [Ctrl]+[Space].

 π2+x

π2+x

(3.2)

Case-Sensitivity

 

Maple is case-sensitive.

 

Example: Enter " x+x ".

Example: Enter " y+Y ".

Compare the results.

x+x = 2x

y+Y = y+Y

Implicit Multiplication

 

Maple understands implicit multiplication.

 

Example: Type " 3 x " for "3 times x".

 

To multiply two variables, use a space.

" x y " means "x times y", but " xy " means the

variable whose name is "xy".

 

Example: Type "x [space] y +  xy ".

If you choose to Differentiate using the context menu, you will see that x, y, and xy are treated as three separate variables due to the way they were entered.

 

You should be careful using implicit multiplication in Maple to avoid confusion with function calls. To us, fx+1 looks like a function call, and xx+1 looks like implied multiplication. Maple understands both of these as function calls.

 

Example: Enter xx+2x using no space, a space, and an explicit multiplication sign. Ask Maple to calculate each result so you can see the differences.

 

When multiplying with brackets you can use a space to achieve implicit multiplication, but it is usually safest to explicitly use the multiplication symbol.

 

Maple also automatically inserts a space between side-by-side closing and opening brackets. This means that for expressions like x+ya+b, a space is inserted and the expression is treated as an implicit multiplication of the terms x+y and (a+b).

3  x+5  x = 8x

x y+xy = xy+xy

fx+1 = fx+1

xx+2x = xx+2x

x x+2x = x+2

xx+2x = x+2

x+y a+b = x+ya+b

Mathematical Notation

 

Maple understands familiar mathematical notation.

 

For example, Maple understands that y''+y'+y=0 is a differential equation in yx .

 

Example: Enter the equation listed above (using the single quote key for the prime notation). To verify that it is in fact a differential equation, select Solve DE from the context menu.

y''+y'+y=0solve DEyx=_C1ⅇ12xsin123x+_C2ⅇ12xcos123x

Label References

 

Maple uses label references.

 

Whenever you use [ENTER] to get a response, the result is automatically given a label reference. To refer to a previous result in a computation, use [Ctrl]+[L] and enter the label reference number.

 

Example: Multiply the result π2+x (from above) by x, using labels.

 

To reference an equation from another document, use Insert > Reference...

x

π2+xx

(3.3)

Variable Assignment

 

In order to assign a value to a variable name, the colon-equals operator is used.

 

Example: To assign the value "5*x" to the variable name "costA", the assignment statement, := (colon equals) is used. After a value has been assigned to "costA", it can be used in subsequent calculations.

 

Note: Anything you want Maple to evaluate (for example, assignment statements), must be entered in Math mode. Anything entered in Text mode will be non-executable.

costA5 x

5x

(3.4)

costA

5x

(3.5)

costB4 x

4x

(3.6)

costA+costB

9x

(3.7)

 

Tip: Find the list of keyboard shortcuts for your platform. Click Help > Quick Help menu, and select Math Editor Shortcuts.

Combining Text and Math

In Maple you can combine math and text in the same paragraph to help formulate mathematical sentences.

Steps

Results

Example: Start by entering a simple computation.

 

 

Go back to the start of your computation (place the cursor to the left of your expression), press [F5] to change from math input to text input, and start typing text.

x3+x2+3 ⅆx = 14x4+13x3+3x

The integral x3+x2+3 ⅆx = 14x4+13x3+3x.

Place your cursor at the end of the output, press [F5], and complete the rest of the sentence.

 

The integral x3+x2+3 ⅆx = 14x4+13x3+3x, as you can see.

Modify some of the terms in the problem, highlight the entire sentence and click execute all selected groups ( ) to re-execute the computation.

 

The integral 5 x3+x2+4 ⅆx = 54x4+13x3+4x, as you can see.

Tip: Pressing [F5] allows you to easily toggle between math input and text input.

Tip: In math mode, the cursor is slanted and has a dotted box around it. In text mode, the cursor appears as a vertical bar.

Tip: To check what mode you are in, look at the top left of the toolbar. In text mode it will look like  . In math mode it will look like  . You can also use these toolbar buttons to change modes as an alternative to pressing [F5].

Plotting

Maple can produce 2-D and 3-D plots of equations and expressions.

Steps

Results

2-D Plots

 

Now we will demonstrate plotting in Maple. The fastest way to plot an expression in Maple is to use the context menu.

 

Example: Enter an expression in x (for example, sin2x), right-click on the expression, and select Plots > 2-D Plot.

 

Example: Use the point probe to find the coordinates of different points in the graph. To turn on the point probe, right-click on the plot and choose Nearest point on line.

 

Example: To pan the plot, right-click on the plot, and select Manipulator>Pan. Hold down the left mouse button and use the mouse to move the plot around. To scale the plot, perform the same steps, but select Manipulator>Scale.

 

Tip: You can also change the manipulator tool by clicking on the plot, and then selecting the appropriate tool from plot toolbar at the top of the Maple window:

  

 

The enhanced point probe tool can find the point on the curve closest to your cursor, and allows you the ability to extract the coordinates of the cursor and paste them anywhere in the document.

sin2x

Combining Plots

 

You can easily add another plot on the same set of axes.

 

Example: Enter another equation in x (e.g. sinx2), highlight the new expression with your mouse, hold down the [Ctrl] key and drag it onto the plot.

sin2x

Annotating Plots

 

You can add additional information to plots by using the drawing tools. Lines, arrows, text, 2-D math, and shapes are available.

 

Example: Click on the plot, then click on the  toolbar. Use the Text Tool (T) to enter labels for the curves. Use [F5] to toggle between text and math, and standard Maple math editor entry keystrokes.

 

3-D Plots

 

Example: Enter an expression in x and y (e.g. sinxy).  Right-click on the expression and use Plots > 3-D Plots > x,y from the context menu.

 

Example: To rotate the plot: Click on the plot, hold down the left mouse button and move the mouse.

 

Example: Pan and scale the plot by selecting a different tool from the Manipulator list on the context menu.  Now when you hold down and move the mouse, the new action is performed.

 

Tip: You can also change the manipulator tool by clicking on the plot, and then selecting the appropriate tool at the top of the Maple window:

sinxy

Plot Options

 

You can modify the look of your plot in a variety of ways.

 

Plot options can be changed by right-clicking on the plot and modifying the options within the contest menu.  Note that the choices available in the context menu are specific to 3-D plots.

 

Example: Right-click on the plot to obtain the context menu.  Click Transparency and modify the plot transparency.

 

Plot options can also be changed by clicking on the plot, selecting the Plot toolbar at the top of your Maple worksheet, and selecting the relevant options.

 

Example: Click on the image, from the top toolbar select Plot > Axes > Boxed or use the axis selection button on the Plot toolbar:

sinxy

Task Assistants, Tutors and Math Apps

As explored above, context menus are one way to solve problems without using Maple commands. Task assistants provide another method. Tutors are useful for teaching and exploring mathematical concepts. The full list of assistants and tutors can be found on the Tools menu.

Steps

Results

Using the Plot Builder Assistant

 

Plots can easily be created in Maple using the builtin Plot Builder.

 

 

Example: Enter the expression you want to plot. From the context menu, select Plots > Plot Builder. Using the Plot Builder, you can choose the type of plot you want, add titles, and set options all at once. This example shows a 3-D plot with the use of plot title, normal axes and style of surface with contours.

 

x2+y2

The Plot Builder allows you to create more than just ordinary 2-D and 3-D plots. The example on the right is a polar plot.

 

Example: Enter the expression 2 sin 4 t+1. Select Plots > Plot Builder from the context menu. Select 2-D Polar Plot from the Select Plot Type list box, then click Plot.

 

2 sin4 t+1

You can also create an animation using the Plot Builder assistant.

 

Example: Enter the expression on the right, right-click to invoke the context menu.

Select Plots > Plot Builder > Animation from the Select Plot Type drop-down list, click Plot.

 

Now click on the plot image - some new animation-specific buttons will appear on the animation toolbar. Click and watch the animation.

sinax2+y2π2

Using the Exploration Assistant

 

The Exploration Assistant allows you to instantly create interactive mini-applications used to explore the parameters of the expressions.

 

Example: Enter the expression you want to explore. Select Explore from the context menu. In the submenu, input the parameters you would like to test. If you do not want to explore a variable, check the box Next to skip.

With the given expression, choose to skip x and y.

Explore, the parameters of the expressions. generates a user interface with interactive sliders, dials or gauges that can vary the values for the parameters and show the results.

plot3dcosa x+b siny

a

b

 

Using Tutors in Maple

 

Maple provides several tutors which are useful for teaching and exploring mathematical concepts in the subjects of:

• 

Calculus - Single-Variable

• 

Calculus - Multi-Variable

• 

Complex Variables

• 

Differential Equations

• 

Linear Algebra

• 

Numerical Analysis

• 

Precalculus

• 

Statistics

• 

Vector Calculus

 

Example: From the menu, select Tools > Tutors > Calculus - Single Variable > Integration Methods. Enter a function and follow the example through by applying the correct rule at each step and using Get Hint for help.

Math Apps

 

Math Apps and other interactive applications provide demonstrations that illustrate various mathematical and scientific concepts. The Math App Guide provides an overview of all of the available applications in many different fields including Discrete Math, Engineering, Finance, Statistics, and more.

 

Example: From the menu, select Tools > Math Apps. To open a Math App, simply click on its icon.

Drum Vibrations

 

Tip: You can also view Math Apps online using the Maple Cloud.

Entering Commands

While many operations in Maple can be done through the use of context menus and other interactive tools, Maple also has a rich programming language.

Steps

Results

Entering Maple Commands

 

Many commands are grouped together in packages. You can type the long name, or enter a with command prior to using a command from that particular package.

 

Example: Create a Matrix, M, and apply the command LinearAlgebraDeterminantM to find the determinant of M.

 

Note: If you do not provide the package name, Maple does not know the definition of this function, and so it simply returns the unevaluated expression.

 

You can avoid having to type the long-form of each command by pre-loading the desired package. You can use a colon at the end of the command to suppress output.

 

Example: Load the LinearAlgebra package first using a colon. Try again without the colon to see the difference.

 

Example: Now calculate the Determinant of M using the short-form of the command.

 

Command completion is very useful when typing long command names.

 

Example: Type Gau, then press [Ctrl]+[Space] to see a list of possible completions. Use the arrow key to select the desired command and press [Enter], or select the command with the mouse.

 

Tip: Many packages can be loaded through Tools > Load Package. See Tools > Load Package > List All Packages... or click here to see the complete list.

 

M1235

1235

(7.1)

LinearAlgebraDeterminantM

1

(7.2)

DeterminantM

Determinant1235

(7.3)

withLinearAlgebra:

DeterminantM

1

(7.4)

GaussianEliminationM

1201

(7.5)

 

Document Editing and Formatting Tools

Maple contains numerous word processing tools to help you create professional-looking reports. For your reference, here is a list of some of the more common ones.

Feature

Where to Find It

Built-in title and headings styles

Drop-down list on toolbar

Sections and subsections

Insert > Section, Insert > Subsection

Tables

Insert > Table

Ability to edit table properties

Right-click anywhere in the table, then select Table>

Drawing canvas

Insert > Canvas

Font control and ability to define new styles

Format > Styles...

The ability to insert images, tables, and other objects

Insert > Image, Insert > Table

A spell-checker that is aware of mathematical terms

Tools > Spellcheck

Hyperlinks and bookmarks

Format > Convert to > Hyperlink

Format > Bookmarks...

The ability to add headers and footers

View > Header Footer

Export to HTML, PDF, etc.

File > Export As

 

Tip: The user manual contains a chapter on creating mathematical documents.

Configuring the Maple Environment

You can customize the Maple environment in many ways. Below is a list of the most common ones. Note that any option set through the Options menu can be set just for this session, or globally (every time you start Maple).

Feature

How to Control Feature

Start-up dialog.

Turn it off by clearing the check box on the dialog.

Turn it on again through Tools > Options, Interface tab.

See it anytime by Help > Startup Dialog...

Quick Help displayed on new documents.

Turn it off by clearing the check box on the quick help.

Turn it on again through Tools > Options, Interface tab.

See it anytime by pressing [F1].

Option for new documents to start in Document mode (no prompt, context menu commands are hidden) or Worksheet mode (prompts, all commands shown).

Tools > Options, Interface tab.

See the Default format for new worksheets drop-down menu.

Option to enter math in 2-D (default) or 1-D.

(Note: This choice is only available in worksheet mode. All math must be entered in 2-D in document mode.)

 

You can also control the input type for individual lines, without changing the overall default.

Tools > Options, Display tab.

See the Input Display drop-down menu.

x2 vs. x^2

 

Use context menu on the line above. Selecting Convert to > 2-D Math Input turns the above line into x2.

Number of digits displayed in calculation results.

Maple displays 10 digits by default (though it calculates more).

Tools > Options, Precision tab.

See the Round screen display to drop-down menu.

 

For example, show the floating point value of π. The default result is:

  evalfπ

3.141592654

(9.1)

After setting the screen display to 5, the result is:

  evalfπ

3.141592654

(9.2)

Add the item to Favorites Palette.

 

Palettes can be reordered, and individual palettes can be moved from one dock to the other, or turned off completely.

 

Palette docks can also be expanded and collapsed.

Right-click on the palette, select Add to Favorites Palette.

 

View > Palettes > Arrange Palettes...

 

Use the View> Palettes menu, or the small arrows at the top of the palette to expand and collapse. For the left-hand-side dock, these arrows are in the top-right corner of the palette, to the right of the scroll bar.

 

© Maplesoft, a division of Waterloo Maple Inc. 2015.

All rights reserved. This product and content is protected by copyright. You may not copy, modify, transmit or reproduce this content without permission in writing from Maplesoft.