Interface - Maple Programming Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : What's New and Release Notes : updates/Maple2020/Interface

Interface

 

Reordering Worksheet Tabs

Components

Reactivating a License

Context Panel

View Menu

New Shortcut Key

Command Line Interface Updates

Reordering Worksheet Tabs

It is now possible to rearrange the order of worksheet tabs by click and drag.

Components

• 

Button components can now be given a specific width and height instead of just being wide enough to fit the caption, giving you more control over your document layout.

• 

MathContainers now have an option that automatically scrolls the container to the bottom if the content grows too large.

• 

ListBoxes now correctly display tooltips.

Reactivating a License

If your Maple license has changed, for example because you have extended a time-limited license, you need to reactivate your Maple license for the change to take effect. In Maple 2020, it is now easy to reactivate your license directly from inside Maple, using a new button in the Help > About Maple dialog. Click Reactivate License to launch the activation utility.

Context Panel

The Context Panel on the right-hand side of the Maple window has been enhanced.

• 

Many visualizations have been added to the Student:-LinearAlgebra context panel, including CrossProductPlot, EigenPlot, LeastSquaresPlot, LinearSystemPlot, LinearTransformPlot, PlanePlot, ProjectionPlot, and VectorSumPlot.

• 

After performing a self-documenting operation from the context panel, you can now right-click (Control-click, Mac) on the context operation, and from the context menu select the new Copy Command menu item.  This gives you access to the Maple command syntax that performs that task.

2103inverse1216013

LinearAlgebra:-MatrixInverseMatrix2, 2, 2,1,0,3

• 

Show Command is used to display the command used by a context panel operation while in Document mode. In Maple 2020, the arrow and description now turn grey if the underlying input is edited to indicate that the results may no longer be valid.

• 

It is now possible to launch the Calculus tutors from both the fully stated problem and from the integrand (when the Calculus package is loaded). For example, you can call the Integration Methods Tutor by clicking on xsinx ⅆx or xsinx and then selecting the tutor from the context panel.

View Menu

• 

All options from the Show/Hide Contents dialog are now more easily accessible, because they have been moved to a new Show/Hide Contents submenu.

• 

The Arrange Palettes item has been removed from the Palettes submenu.

New Shortcut Key

• 

Alt+S (Control+S, Mac)—Move the focus in the help browser to the search field (note that this is the same key combination used in the worksheet for moving focus to the search box).

Command Line Interface Updates

Paging of Output in Command Line Interface

• 

By setting interface(paging=true), Maple will print a "-- More --" prompt after every screenful (interface(screenheight) - 2 lines) of text.

• 

At this prompt, one can use single-key commands to show more lines or pages, skip lines or pages, search for a particular string, or skip the remainder of the output. The ? command displays a summary of these commands.

Improved Formatting of Help Output

• 

Maple's help in the Command Line Interface now makes use of color and highlighting when displaying help output on terminals that support this.