Contents

1 Introduction ................................................................................................................................. 1
   1.1 Maple Flow .......................................................................................................................... 1
   1.2 What Does This Manual Aim to Do? ................................................................................... 1
   1.3 What Is the Relationship between Maple and Maple Flow? ............................................... 2
   1.4 If You Are a Maple User .................................................................................................... 3
   1.5 Maple Flow Help System .................................................................................................... 3
       Additional Documentation ....................................................................................................... 4
   1.6 Interface ............................................................................................................................. 4
       Customizing the Interface ..................................................................................................... 5
       Working in Maple Flow ......................................................................................................... 6

2 Canvas ........................................................................................................................................ 8
   2.1 Grid ................................................................................................................................... 8
   2.2 Grid Cursor ....................................................................................................................... 8
   2.3 Math and Text Containers ................................................................................................. 8
   2.4 Moving Containers ............................................................................................................ 9
       Single Container .................................................................................................................. 9
       Group of Containers .......................................................................................................... 9
       Bringing Containers from Back to Front, and Vice Versa ..................................................... 10
   2.5 Editing an Existing Container ......................................................................................... 10
   2.6 Deleting a Container ........................................................................................................ 10
   2.7 Inserting or Removing White Space ................................................................................ 10
       Adding Blank Rows ............................................................................................................ 10
       Deleting Blank Rows ......................................................................................................... 10

3 Entering Math ........................................................................................................................... 11
   3.1 Creating a Math Container ............................................................................................... 11
   3.2 Deleting a Math Container .............................................................................................. 11
   3.3 Copying and Pasting Math ............................................................................................... 11
   3.4 Evaluating Math and Displaying Output .......................................................................... 11
       Definitions ........................................................................................................................... 11
       Expressing Equality ............................................................................................................ 12
   3.5 Creating Definitions and Expressing Equality .................................................................. 11
   3.6 Numeric and Symbolic Evaluation Modes ....................................................................... 12
   3.7 Numeric Formatting .......................................................................................................... 13
   3.8 Basic Arithmetic ............................................................................................................... 15
   3.9 Complex Numbers .......................................................................................................... 15
   3.10 Units ............................................................................................................................... 15
       Entering Units ..................................................................................................................... 15
       Editing Existing Units ....................................................................................................... 16
   3.11 Notes about Calculations ............................................................................................... 17
       Numerical Evaluation and Accuracy .................................................................................. 17
       Evaluation Order ................................................................................................................. 18
       Nonexecutable Math .......................................................................................................... 18
       Controlling Evaluation ..................................................................................................... 18
       Disabling Evaluation ......................................................................................................... 19

4 Creating a Polished Document ................................................................................................. 21
   4.1 Entering Text ..................................................................................................................... 21
       Entering Math in a Text Container ..................................................................................... 21
   4.2 Math and Text Styling ...................................................................................................... 21
       Formatting the Content of Single Containers .................................................................. 21
       Applying Background Color to a Math or Text Container ................................................ 21
       Formatting Text ............................................................................................................... 23
List of Figures

Figure 1.1: Overview of in-product tutorials ................................................................. 2
Figure 1.2: The Maple Flow interface ............................................................................. 2
Figure 1.3: Options dialog .............................................................................................. 5
Figure 2.1: Enable/Disable Grid button on toolbar ....................................................... 8
Figure 2.2: Grid cursor ................................................................................................... 8
Figure 2.3: Flip to Front and Flip to Back buttons ............................................................ 10
Figure 3.1: Numeric formatting ..................................................................................... 13
Figure 3.2: Setting default numeric formatting .............................................................. 14
Figure 3.3: Inserting a Unit with the Units Palette ........................................................ 16
Figure 3.4: Using the Unit() function to assign a unit .................................................... 16
Figure 3.5: Using keyboard shortcuts to insert a unit placeholder ................................ 16
Figure 3.6: Convert output units .................................................................................... 17
Figure 3.7: Numerical operations .................................................................................. 17
Figure 3.8: The effect of Digits on numerical accuracy ................................................ 17
Figure 3.9: Spatial evaluation ....................................................................................... 18
Figure 3.10: Setting for controlling evaluation ............................................................. 19
Figure 3.11: Worksheet evaluation disabled ................................................................. 20
Figure 3.12: Visual indicator for disabled evaluation ..................................................... 20
Figure 4.1: Entering and formatting text ...................................................................... 21
Figure 4.2: Apply background color to a container ...................................................... 21
Figure 4.3: Select background color ............................................................................. 22
Figure 4.4: A math container with background color .................................................... 22
Figure 4.5: The Styles drop-down list .......................................................................... 23
Figure 4.6: Sections in a worksheet ............................................................................. 24
Figure 4.7: Align Output Below := ............................................................................. 25
Figure 4.8: Hide commands ......................................................................................... 25
Figure 4.9: Marker indicates hidden command .............................................................. 26
Figure 4.10: Drawing Toolbar ...................................................................................... 26
Figure 4.11: Drawing on plots ...................................................................................... 27
Figure 4.12: Help Topic Hyperlink .............................................................................. 34
Figure 4.13: Link To Bookmark .................................................................................. 35
Figure 4.14: Shortcut ................................................................................................... 36
Figure 4.15: Shortcut Properties .................................................................................. 36
Figure 4.16: Using a Shortcut to execute code .............................................................. 37
Figure 5.1: Setting the default unit system .................................................................... 39
Figure 5.2: Change units in Context Panel .................................................................... 40
Figure 5.3: A simple plot using a Maple plot command .............................................. 42
Figure 5.4: A simple 3-D plot .................................................................................... 42
Figure 5.5: Resizing a plot .......................................................................................... 43
Figure 5.6: Matrix palette ........................................................................................... 43
Figure 5.7: Matrix from palette .................................................................................. 44
Figure 5.8: Matrix indexing ......................................................................................... 44
Figure 5.9: Inline Matrix Browsing .............................................................................. 45
Figure 5.10: Set matrix size ......................................................................................... 47
Figure 5.11: Import data .............................................................................................. 48
Figure 5.12: Command completion window .................................................................. 48
Figure 5.13: Code Editor button on main toolbar ....................................................... 50
Figure 6.1: Print extents .............................................................................................. 52
Figure 6.2: Inserting Headers and Footers .................................................................. 53
Figure 6.3: Page Setup ............................................................................................... 56
# List of Tables

Table 1.1: How Maple Flow differs from Maple ........................................................................................ 3  
Table 2.1: Container states ..................................................................................................................... 8  
Table 3.1: Difference between numeric and symbolic evaluation modes .................................................. 12  
Table 3.2: Using the Command Completion feature and Expression Palette to insert a square root .......... 15  
Table 7.1: Keyboard shortcuts for canvas operations ................................................................................. 58  
Table 7.2: Keyboard shortcuts for math entry ........................................................................................... 58  
Table 7.3: International keyboard shortcuts for evaluation .......................................................................... 59  
Table 7.4: Greek Keymap .................................................................................................................... 59  
Table 7.5: Keyboard shortcuts for text entry ............................................................................................ 60  
Table 7.6: Keyboard shortcuts for menu operations ................................................................................... 60  
Table 7.7: Mouse bindings ................................................................................................................... 61
1 Introduction

1.1 Maple Flow

Maple Flow is a new calculation tool from Maplesoft. Maple Flow offers a freeform user interface combined with a comprehensive math engine. Use Maple Flow for engineering, scientific, and technical calculations and documentation.

Maple Flow gives you

- A spatially aware mathematical canvas that replicates the design metaphor of a physical whiteboard
- Automatic recalculation to ensure that results are always up to date
- A broad, rich mathematical language with many functions
- Visually impactful, fully programmatic plots
- A coding region with full access to the Maple programming language

Note for non-Windows users: The keystrokes given in this document are for Windows. If you are using a different platform, see the keyboard shortcuts for your platform in Keyboard Shortcuts (page 58).

1.2 What Does This Manual Aim to Do?

This manual describes

- The Maple Flow interface
- Differences with the Maple user interface and programming language that an existing Maple user may experience.

This manual should be read in unison with the in-product tutorials and exercises; these are available from the Tutorial link on the Maple Flow Home page. If you've closed the Home page, you can access it again from the View menu:

- Select View > Home
This manual does not describe the math functionality of the Maple Flow in detail, but makes references to specific functions in context of a broader discussion. The detailed documentation for the math functionality resides in the Maple online help: http://www.maplesoft.com/support/help.

1.3 What Is the Relationship between Maple and Maple Flow?

First, some definitions:

- Maple refers to the (i) Maple programming language and (ii) Maple interface.
- Maple Flow refers to the new product whose manual you are reading.

Maple Flow

- Uses the powerful Maple math engine
- Borrows a few elements from the Maple interface

Maple Flow's "language" is the commands (and their syntax), data structures and programming language. These are based on the Maple programming language; you can use any of the math functions in Maple in your Maple Flow analyses.
1.4 If You Are a Maple User

If you already use Maple, you'll appreciate the unique twist that Maple Flow offers with its spatial evaluation model and automatic calculation updates. You will also get a head start because you'll be familiar with Maple's programming language, functions, and features.

Maple Flow differs from the Maple interface and programming language in a number of ways. Several important differences are listed in Table 1.1.

Table 1.1: How Maple Flow differs from Maple

<table>
<thead>
<tr>
<th>Maple Flow</th>
<th>Maple (\rightarrow)</th>
</tr>
</thead>
<tbody>
<tr>
<td>You enter math and text at any point, simply by clicking with your mouse, and typing. This is in much the same way that you can write math at any point on a whiteboard.</td>
<td>You can enter commands at execution prompts, which are largely aligned to the left (except when inserted into multicolumn tables), and linearly progress down the worksheet.</td>
</tr>
<tr>
<td>The evaluation model is forward in space. Any assignments are only valid at any point to the right or below where they are made.</td>
<td>The evaluation model is forward in time. You can use assignments above or below where they are made, at any time after the assignment is made. Most users progress linearly down a worksheet, but the apparently linear form of a worksheet is not always reflected in the displayed results.</td>
</tr>
<tr>
<td>Multiplication needs to be explicitly stated.</td>
<td>Multiplication can be implicit (i.e. entered with a space) or explicit.</td>
</tr>
<tr>
<td>More numeric evaluation by default (for example (\frac{5}{10}) evaluates to 0.5)</td>
<td>Results are kept symbolic except when requested to be numeric (for example, with the \texttt{evalf} command).</td>
</tr>
<tr>
<td>Units are automatically combined. That is, (\text{N/m}^2) is automatically reconciled to Pa.</td>
<td>Units are only reconciled if explicitly requested by the user (for example, by loading a Units package).</td>
</tr>
<tr>
<td>What you see in the Maple Flow canvas is always up to date and reflects the current state of all assignments. Any changes or additions to the canvas automatically cascade down the canvas. Automatic recalculation means the currently visible portion of the canvas updates as you work, and as you scroll through the document all the calculations are updated.</td>
<td>Individual commands, groups of commands, or entire worksheets are only updated if requested by the user. This means results may not reflect the current value of definitions.</td>
</tr>
<tr>
<td>Matrix, vector, and array indices are only entered with square brackets.</td>
<td>Matrix, vector, and array indices can be entered with square brackets or typeset subscripts (in 2-D input).</td>
</tr>
<tr>
<td>Math is entered into the canvas in mathematical notation, but programmatic content is entered in Maple notation.</td>
<td>Equations and programs can be entered in typeset mathematics notation (often called &quot;2-D math&quot;) or Maple notation (&quot;1-D math&quot;).</td>
</tr>
</tbody>
</table>

Maple worksheets cannot be loaded into the Maple Flow, or vice versa.

1.5 Maple Flow Help System

The in-product help system, accessed through the Help menu, provides information on key commands. Each help page gives details on the usage of a command, including the calling sequence, parameters, options, and examples.

Search: Search for a command name, keyword, or phrase.

Browse: Browse the table of contents to view a structured list of help topics.
To get help on a specific word:
1. In a worksheet, place the cursor in a word for which you want to obtain help.
2. Press F2 to access context-sensitive help.

**View Help Page as Worksheet:** You can open any help page as a worksheet to interact with the page and modify the examples.
- With the help page displayed in the right pane of the help system, from the View menu, select **Open Page as Worksheet**. A new worksheet window opens.
- Alternately, click **Open current page as worksheet** (�) in the help system toolbar.

**Additional Documentation**

Since Maple Flow uses the Maple programming language, you have the ability to use the vast math functionality that is part of the Maple programming language. When browsing the help system, some hyperlinks take you to additional detailed documentation for the math functionality that reside on the Maplesoft website, in the Maple online help: [http://www.maplesoft.com/support/help](http://www.maplesoft.com/support/help). Note that these pages are formatted as Maple pages, not Maple Flow pages, so the examples will look a little different.

### 1.6 Interface

The different parts of the Maple Flow interface, as seen in **Figure 1.2**, are:
- Canvas — the workspace
- Main toolbar — This toolbar is always at the top of the Maple Flow window.
- Context toolbar — This toolbar, located directly above the canvas, is relevant to the current selection.
- Palettes — In the left pane, these provide an easy way to enter a math expression, matrix, Greek letter, or units.
- Context panel — Some options relevant to the current selection appear here, such as numeric formatting and units formatting.
- Status Bar — Displays system information
Customizing the Interface

Customize your Maple Flow preferences using the Options Dialog.

To open the Options Dialog:

• From the toolbar, click the Options icon ( ).

There are six tabs.

Under the Units tab, you can specify the default unit system (SI, FPS, or IPS). For more information, see Setting the Default Unit System (page 38).

Under the Display tab, you can customize settings related to display of output. For more information, see Numeric Formatting (page 13) and Set Displayed Matrix Size (page 46).
Under the Interface tab, you can specify the following:

- Open worksheets in new tab or new window.
- Open hyperlinks in new tab or new window. This refers to hyperlinks to other Maple Flow worksheets.
- Default zoom.
- Open worksheet at startup. You can select the worksheet that Maple Flow displays as the Home page. See the next section for more information.
- Control the Automatic argument completion feature. For more information, see Argument Completion (page 49).

Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the setting to the current session an future sessions.

Under the Evaluation tab, you can customize settings related to evaluation. For more information, see Controlling Evaluation (page 18).

Under the General tab, you customize settings related to saving. You can set the matrix save limit and enable saving of debugging information to a log file. For more information, see Set Matrix Save Limit (page 47) and Logging Debugging Information (page 50).

Under the Template tab, you can customize settings related to default page layout. For more information, see Page Setup (page 55).

**Working in Maple Flow**

By default, Maple Flow opens to the Home page. From this page you can access the tutorials and many sample applications. If you close this page, you can always return to the home page using View > Home.

You can customize what worksheet Maple Flow displays as the home page, or have it simply display a new, blank worksheet on start up.

- From the toolbar, click the Options icon ( ).
- Under the Interface tab, select the desired home page: Default home page, Specified worksheet, or New, blank.
- If you select Specified worksheet, browse to the desired document. (Tip: You may want to make your custom home page noneditable, as described in Controlling the Editability of a Document (page 26).
• Click **Apply to Session** to apply for the current Maple Flow session only, or click **Apply Globally** to apply the setting to the current session and future sessions.

By default Maple Flow documents open in a new tab. (That setting can be changed in the Options > Interface tab as well.) You can always move a Maple Flow document from a tab to a new window.

To move a Maple Flow document to a new window:

• Grab the document tab, and drag it onto the canvas. The document opens in a new Maple Flow window.
2 Canvas

2.1 Grid

When you drag math and text containers, the positions of containers are snapped to a grid. By default, the grid is not displayed.

To display the grid, click the Enable/Disable Grid button on the main toolbar.

![Enable/Disable Grid button on toolbar](image)

Figure 2.1: Enable/Disable Grid button on toolbar

2.2 Grid Cursor

The grid cursor is illustrated in Figure 2.2 and by default appears in the top left corner of every new canvas.

![Grid cursor](image)

Figure 2.2: Grid cursor

The grid cursor can be moved by pointing and clicking with the mouse, or with the arrow keys.

Math and text containers are created at the location of the grid cursor.

2.3 Math and Text Containers

On the canvas, you can create math boxes or text boxes. Each box can be moved; the position of a math container determines the order in which it is evaluated (as illustrated in Figure 3.9).

A container can be in one of three states, as described in Table 2.1.

<table>
<thead>
<tr>
<th>Table 2.1: Container states</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Math</strong></td>
</tr>
<tr>
<td>Stationary with no focus. A math container in this mode is still &quot;live&quot;, and Maple Flow will update its result if an upstream parameter changes.</td>
</tr>
<tr>
<td>Editing</td>
</tr>
<tr>
<td>• Only one container can be in editing mode at any one time.</td>
</tr>
<tr>
<td>• A math container has a solid dark green border if numeric, or a dashed light green border if symbolic (see Numeric and Symbolic Evaluation Modes (page 12)).</td>
</tr>
<tr>
<td>• A text container has a blue border.</td>
</tr>
<tr>
<td>• You will see a flashing cursor, whose position can be changed with the arrow keys or mouse.</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Move</td>
</tr>
<tr>
<td>• Math and text containers that are selected have a light blue border. Such a container is in move mode.</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Math</td>
</tr>
<tr>
<td>------</td>
</tr>
<tr>
<td>$x^2 = 9$</td>
</tr>
</tbody>
</table>

### 2.4 Moving Containers

#### Single Container

**With the mouse**

To move a container with the mouse:

1. Move the mouse pointer over a container.
2. Move the container to another position by click and dragging.
3. Release the mouse button when the container is in the desired position.

**With the keyboard arrows**

To move a container with the keyboard:

1. Move the grid cursor into a container so that the container is in editing mode.
2. Do one of the following:
   - Press **Ctrl** and use the arrow keys to move the container one grid space at a time.
   - Press **Ctrl + Shift** and use the arrow keys to move the container a single pixel at a time.

Note that when you press **Ctrl**, the container border changes to royal blue to indicate **Ctrl** has been pressed.

#### Group of Containers

To move multiple containers:

1. Click in a blank part of the canvas.
2. Drag a selection box around a group of containers.
3. Release the mouse button.

   Alternatively, you can press and hold **Ctrl** while you select the containers.

4. Move the mouse pointer over one of the selected containers.
5. Drag the containers to another location.

To align containers:

1. Click in a blank part of the canvas.
2. Drag a selection box around a group of containers.
3. Release the mouse button.
4. Right-click and from the context-sensitive menu, select **Align Left**.
Bringing Containers from Back to Front, and Vice Versa

You can potentially have two containers at the same grid position. You can bring the lower container forward, or send the top container back, by using Flip to Front and Flip to Back buttons.

![Flip to Front and Flip to Back buttons](image)

**Figure 2.3: Flip to Front and Flip to Back buttons**

2.5 Editing an Existing Container

To enter editing mode on an existing container, do one of the following:

- With the mouse, click the container.
- With the arrow keys, move the grid cursor onto the container.

2.6 Deleting a Container

To remove a container, do one of the following:

- With the mouse, select the container (or containers) and from the toolbar, select Cut (Cut icon).
- Move the grid cursor into a container so that the container is in editing mode. Then press Ctrl + Delete to delete the in-focus container.
- Triple-click the container to select the entire container, then press Delete.

2.7 Inserting or Removing White Space

You can insert or remove space in the canvas (i.e. grid rows) by using the Enter, Backspace, and Delete keys.

**Adding Blank Rows**

To add blank rows, place the grid cursor on a blank part of the canvas and press Enter. This shifts all content on and below the same row as the grid cursor down.

**Deleting Blank Rows**

To delete blank rows, click on a blank row of the canvas and press one of the following:

- Backspace to remove that blank row and shift the grid cursor and all content below the grid cursor up.
- Delete to remove that blank row, and shift all content below that row up.
3 Entering Math

3.1 Creating a Math Container

A math container is a box in which you enter math that is to be evaluated.

To create a math container:
1. Click on a blank part of the canvas.
2. Begin typing your math. As soon as you enter the first character, a math container is created automatically.

3.2 Deleting a Math Container

To delete a math container, do one of the following:
• Drag-select the math container and press Delete.
• In editing mode, press Ctrl + Delete to delete the in-focus container.
• Triple-click the container to select the entire container, and then press Delete.

3.3 Copying and Pasting Math

When you are copying from outside of Maple Flow, for example from a text document, by default the content is pasted into your Maple Flow worksheet as text. If you are copying a math expression, there is an easy way to ensure it pastes as math.

To copy and paste as math:
• Select and copy the math.
• To paste as math, right-click on a location in the worksheet, and select Paste as Math.
  A new math container is created, and the selected math is copied into it.

3.4 Evaluating Math and Displaying Output

Anytime you leave a container by pressing Enter, or navigating away using Tab or the arrow keys, evaluation occurs.

All math is evaluated in the canvas, using a left-to-right, top-to-bottom order (see Evaluation Order (page 18)). When you need to display results, evaluate and display output.

To evaluate math and display results:
• Enter the expression, then press =. The evaluation occurs and the result displays. The focus remains in the math container.

If desired, press Enter or the arrow keys to leave the math container.

Typically all visible calculations that are dependent on a math container are updated when the focus leaves a math container.

You can change the behavior of = in a math container, if desired. See Controlling Evaluation (page 18).

3.5 Creating Definitions and Expressing Equality

Definitions

You can assign a numerical value or an expression to a name by using := (a colon, followed by an equal sign).
For example, entering \( a := 4 \) in a math container assigns the value 4 to the name \( a \).

You can then use this definition later.

**Expressing Equality**

As discussed in *Evaluating Math and Displaying Output (page 11)*, by default the equal sign is used to evaluate and display results. When you are entering an expression into a math container that involves an equation, use \( Ctrl + = \) to enter the equal sign. This allows entry of the = symbol without immediate evaluation of the math container.

Example 1.

**Solve this equation for** \( x \): \( x^2 - 2 \cdot x - 7 = 0 \).

A one-line solution is:

\[
solve(x^2 - 2 \cdot x - 7 = 0, x) \rightarrow 3.828, -1.828
\]

Notice there are two equal signs in this math container. The first one is part of the equation. The second one means evaluate and display results, and at the end you see the two solutions: 3.828 and -1.828.

An alternative approach is to first define the equation, then solve for the result.

\[
eqn := x^2 - 2 \cdot x - 7 = 0
\]

\[
solve(eqn, x) = 3.828, -1.828
\]

In both cases, use the following steps:

- To enter the equal sign between the left-hand side and right-hand side of the equation, use \( Ctrl + = \).
- To enter the equal sign that means evaluate and show results, use =.

Example 2.

When the calling sequence for a command includes an option of the form \( name=value \).

For example, on the CurveFitting:-LeastSquares help page, there is an example using the option \( weight \):

\[
\text{CurveFitting:-LeastSquares([0, 1, 2, 3], [1, 2, 3, 10], v, weight = [1, 1, 1, 10])} = -0.644 + 3.466 \cdot v
\]

In this example, use \( Ctrl + = \) to put the equal sign in \( weight=[1, 1, 1, 10] \).

When **View > Visual Indicators** is selected, the = for equality is displayed in bold. For more uses of the visual indicators setting, see *Hiding Commands (page 25)*.

You can change the behavior of = in a math container, if desired. See *Controlling Evaluation (page 18)*.

### 3.6 Numeric and Symbolic Evaluation Modes

Maple Flow offers two math evaluation modes—numeric and symbolic.

#### Table 3.1: Difference between numeric and symbolic evaluation modes

<table>
<thead>
<tr>
<th>Numeric evaluation mode</th>
<th>Symbolic evaluation mode</th>
</tr>
</thead>
</table>
The numeric evaluation mode performs as much numeric evaluation as possible. For example:

- Rational fractions (such as $\frac{1}{2}$) are converted to floating-point numbers
- $\pi$ and $\exp(1)$ evaluate to floating-point numbers

Symbolic evaluation mode prevents numeric evaluation (except when requested by the user). For example:

- Rational fractions are only converted to floating-point numbers if requested by the user (e.g., with the `evalf` command)
- $\pi$ evaluates to a symbolic name

In both modes, unassigned names are evaluated symbolically (i.e., in numeric mode, unassigned names do not give an error when evaluated).

The current mode of an existing math container is given by clicking inside it, and observing the state of the border or Numeric/Symbolic buttons in the Context toolbar, as illustrated in Table 3.1.

By default, new math containers are numeric. Clicking the Symbolic button in the Context toolbar switches the in-focus math container to symbolic mode. Alternatively, use the shortcut key Alt + S.

Holding down the Symbolic button for a second makes symbolic evaluation mode "sticky". This is indicated with a padlock by the Symbolic button (Symbolic). This means that all future math containers will be symbolic (until symbolic mode is toggled off, by toggling to Numeric, or with another long click on the Symbolic button).

### 3.7 Numeric Formatting

By default, Maple Flow displays numeric results with three decimal places. To customize the numeric formatting:

1. Place the editing cursor on a numeric result.
2. Use the Number Format options in the Context Panel.

![Figure 3.1: Numeric formatting](image)

Note that the number format options in the Context Panel only apply to a single math container.

To select a number format and apply it broadly, you can use the Options Dialog to set your desired number format and apply it either to the current session or globally:

1. From the toolbar, click the Options icon (Options).
2. Under the Display tab, select the desired number format.
3. Click **Apply to Session** to apply for the current Maple Flow session only, or click **Apply Globally** to apply the setting to the current session and future sessions.

![Options dialog box](image)

**Figure 3.2: Setting default numeric formatting**

Maple Flow supports the following standard number formats:

- Fixed
- Currency
- Scientific
- Engineering
- Percent

You can also create a Custom format.

**To apply a custom format to a single math container:**

1. Place the cursor in the numeric result to be formatted.
2. In the Context Panel, under **Number Format**, select **Custom**. In the custom string field you can enter a string that is specific to your formatting needs.

   Examples include the following:
   - `#.###` formats to 3.12
   - `00.000` formats to 03.120
   - `#.##` formats to 2,100,320.5
   - `$0.00` formats to $123.50
   - `??0.00;[Red](??0.00)` formats to blue for a positive number, and red for a negative number
   - `[<10]Low;[>=100]High;Medium` formats to "Low" for numbers less than 10,"High" for numbers less than or equal to 100, and "Medium" otherwise

**To apply a custom format to all numeric results in the current session or globally:**

1. From the toolbar, click the Options icon (\(\text{Options}\)).
2. Under the Display tab, for Number Format select **Custom** and enter your specification in the custom string field.
3. Click **Apply to Session** to apply for the current Maple Flow session only, or click **Apply Globally** to apply the setting to the current session and future sessions.

To remove a number format, return to the Number Format dialog and select **None**.
3.8 Basic Arithmetic

Equations are entered in typeset math notation, using standard keys such as /, *, + and -. Note that multiplication must always be explicitly stated. For example, you must enter 3*x, not 3x.

You can also use the Expression palette or Command Completion feature to enter typeset math, as illustrated in Table 3.2.

<table>
<thead>
<tr>
<th>Table 3.2: Using the Command Completion feature and Expression Palette to insert a square root</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Command Completion" /></td>
</tr>
</tbody>
</table>

For more information on command completion, see Command Completion (page 48).

When you select a template, you can then replace the placeholders in the template, using Tab to move between placeholders.

**Tips on piecewise functions:** You can enter a piecewise function using the Expression palette or command completion. To add an additional line to the piecewise function, place your cursor in the piecewise function and right-click. From the context menu, select either Insert Row Above or Insert Row Below. Similarly, you can remove a row using Delete Row in the same context menu. Triple-click to select the entire piecewise function.

3.9 Complex Numbers

Imaginary numbers are entered with a number followed by the suffix i, with no multiplication between the two. For example, 2+2i.

The unit complex number is created with 1i. You cannot just enter i for the unit complex number.

To create a symbolic multiplier on an imaginary number, you need to enter x*1i.

3.10 Units

**Entering Units**

You can enter units in several different ways.
Units Palette

You can enter units using the Units palette located in the Palettes pane on the left side of the Canvas. Click the desired unit (using the Dimensionality drop-down list to switch to different groups of units), or insert the unit placeholder (as illustrated in Figure 3.3) and overwrite the placeholder.

You may want to place a space between the number and the unit.

![Units Palette](image)

Figure 3.3: Inserting a Unit with the Units Palette

Unit function

You can use the Unit() function to assign a unit.

\[ x := 3.4 \text{Unit}\left(m^2\right) \]

Figure 3.4: Using the Unit() function to assign a unit

Keyboard shortcut

Press Ctrl + Shift + U to enter a unit placeholder. Then, replace the placeholder with the desired units.

![Keyboard Shortcut](image)

Figure 3.5: Using keyboard shortcuts to insert a unit placeholder

Editing Existing Units

Move the cursor onto the unit. When the unit has focus, it is highlighted by a light blue box. You can now change the unit.

Deleting all the characters in a unit placeholder will leave an empty placeholder one character in size. Deleting this empty placeholder will remove the unit placeholder entirely.

When the results of your calculations contains units, you can use the units formatting options in the Context Panel to rescale the units to units you'd prefer to see.
Further tools for working with units are described in *More Controls for Units* (page 38).

### 3.11 Notes about Calculations

#### Numerical Evaluation and Accuracy

Any purely numerical operations are evaluated to a floating-point approximation.

\[
\frac{1}{2} = 0.500
\]

\[
\sqrt{2} = 1.414
\]

\[
\sin\left(\sqrt{3} \times x\right) = \sin(1.732 \times x)
\]

**Figure 3.7: Numerical operations**

The Digits environment variable controls the number of digits that Maple uses when making calculations with software floating-point numbers.

The default value of Digits is 10. The value of Digits is changed with the assignment operator (e.g. `Digits:=15`).

**Figure 3.8** illustrates the effect of changing digits from its default value of 10 to 15 on the evaluation of \(2^{0.5}\). (Note that numeric formatting on the result of \(2^{0.5}\) has been set to Fixed with 20 decimal places.)

\[
\text{Digits} := 10
\]

\[
2^{0.5} = 1.41421356200000000000
\]

\[
\text{Digits} := 15
\]

\[
2^{0.5} = 1.41421356237310000000
\]

**Figure 3.8: The effect of Digits on numerical accuracy**
Evaluation Order

Maple Flow evaluates calculations from left-to-right, top-to-bottom (much like reading a page from a book). This means that downstream calculations only "see" assignments on the left or above. This is illustrated in Figure 3.9.

![Figure 3.9: Spatial evaluation](image)

You can change the evaluation order by moving math containers around.

Nonexecutable Math

You may want to enter nonexecuting math for documentation purposes. You can do this by entering math into a text container. For details, see Entering Math in a Text Container (page 21).

Controlling Evaluation

By default, Maple Flow recalculates all visible dependent containers when a math container is created, edited, or moved.

You can also force evaluation when your cursor is in a math container by using Ctrl + Enter.

When the calculations are in progress, the status bar at the bottom of the Maple Flow window displays a status message: Evaluating... m/n where n is the total number of math containers being evaluated.

To stop the current calculation:

• From the toolbar, click the Interrupt icon, ![Interrupt](image).

The Options dialog contains settings you can control related to evaluation.

If you want the entire worksheet to be updated when you make an edit, you can change the settings to recalculate all dependent containers in the entire document, rather than just visible containers.

1. From the toolbar, click the Options icon (🛠).
2. Click on the Evaluation tab.
3. Under Content to evaluate, select one of the following:
   • Evaluate only visible containers (the default)
   • Evaluate all dependent containers
4. Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the setting to the current session and future sessions.
Figure 3.10: Setting for controlling evaluation

Under the **Options > Evaluation** dialog, you can also change the meaning of = in a math container. Under Evaluation keys, select one of the following:

- **= to evaluate math and display results, and Ctrl + = for equality** (the default). When typing in a math container in this mode, at any location you can use the = key to have the math container evaluate and show results. Ctrl + = is used to type an equal sign without causing immediate evaluation.

- **= + Enter at the end of math to evaluate and display results, and = for equality**. The equal sign can be typed without causing an evaluation. To get a math container to display results, enter the expression, then with the cursor at the right end of the expression, press =, followed by Enter (or move the focus outside of the container).

After you make your selection, click **Apply to Session** or **Apply Globally**.

Under **Options > Evaluation**, you can control whether a worksheet is executed when it is opened. Under When loading a worksheet, select one of the following:

- **Don’t execute the worksheet** (the default)

- **Execute the worksheet**

If **Execute the worksheet** is selected, when a file is opened, for consistency between saved results and worksheet display settings, auto-evaluation on load happens if needed. For instance, this would ensure output units and matrices are displayed according to the current settings.

If **Don’t execute the worksheet** is selected, no auto-evaluation happens on load.

After you make your selection, click **Apply to Session** or **Apply Globally**.

**Disabling Evaluation**

If you want to author content without any math evaluating in the Maple Flow worksheet, but eventually the math will be executed, you can temporarily disable evaluation.

To disable evaluation:

- Click **Turn evaluation off** on the toolbar. An indicator appears at the top of the canvas indicating Evaluation Disabled.
To enable evaluation:

- Click the icon again.

To disable evaluation of a single math container:

- Right-click on the container and from the context menu, select **Disable Evaluation**.

There is an option to display a visual indicator for math containers that have evaluation disabled. To enable this setting, select **View > Visual Indicators**. When Visual Indicators is selected, a math container with evaluation disabled is drawn with a red circle at the top left corner.

\[
b := 15
\]
\[
a := \frac{b}{5} = 3
\]
\[
\text{sol} := \text{fsolve}\left(\log(a \cdot x) + a = x, x\right) = 0.017
\]

To show the command again, right-click and clear the **Disable Evaluation** check box from the context menu.
4 Creating a Polished Document

4.1 Entering Text

To enter text:
1. Click in a blank part of the canvas.
2. Press Space to create an empty text container. This will have a blue border.
3. Type your text.
4. Use the context toolbar to format your text.

![My first text](image)

Figure 4.1: Entering and formatting text

Spellcheck is available through the Tools menu.

**Entering Math in a Text Container**

You may want to enter nonexecuting math for documentation. You can do this by entering math into a text container.

To enter math in a text container:
1. Anywhere inside a text container, press Ctrl + R to switch into math mode.
2. Enter your math.
3. If required, press Ctrl + T to return to text mode.

4.2 Math and Text Styling

**Formatting the Content of Single Containers**

To change font, size, and font color, drag-select the content and use the context bar.

**Applying Background Color to a Math or Text Container**

Math and text containers can also have a background color. This can be useful, for instance, to highlight a math container that contains the assignments for the variables that are used in the later calculations.

To apply a background color, right click on a container.

![Background Color](image)

Figure 4.2: Apply background color to a container
The color selector dialog appears. Select a color.

Figure 4.3: Select background color

To apply a background color to multiple math containers, select the math containers, then right-click and from the context-sensitive menu, select **BackgroundColor**.

Figure 4.4 shows the result of using a background color on the math containers that define two assignments, and another color on the plot.

\[
\begin{align*}
a &\leftarrow 1.5 \\
b &\leftarrow 2 \pi \\
f &\leftarrow x \rightarrow a \sin(b \cdot x)
\end{align*}
\]

Figure 4.4: A math container with background color

For information on creating plots, see *Plots (page 41)*.
Formatting Text

In text containers, you can control the formatting of text.

In the **Format** menu, the Character submenu can be used to apply **bold**, **italic**, underline, or strikethrough to text, to make a subscript or superscript in the text, or to change the text color or highlight text.

Applying and Changing Styles

The style drop-down list contains several formatting styles for text and math.

![Figure 4.5: The Styles drop-down list](image)

By default:

- Text is given the **Text** style.
- Math input is given the **2D Math** style.
- Math output is given the **2D Output** style.

You can apply other styles with the other entries (such as the **Title** style for text). You will need to select the content and then pick the appropriate style. You can select text by clicking in the container and then using **Edit > Select All** or drag-select.

Use the **Format > Styles** menu to change the typeface of the pre-defined styles.

Use the **Format > Manage Style Sets** menu to:

- Export and save the active style set.
- Load and apply an existing style set.

4.3 Using Sections

You can use sections to organize your document.

To create a section:

1. Select **Insert > Section**.
   - If you select some content and then use **Insert > Section**, the selection will be enclosed in the section.
2. Enter a title for the section. You can modify the font/style for the title.

To change the size of the section, you can drag the bottom boundary line. If you drag the section boundary past additional content, the section now encloses that content.

To collapse a section:

- Click the collapse button (—).

To expand a section:

- Click the expand button (＋).
Figure 4.6 shows an example of a Maple Flow worksheet with sections. The first section is collapsed and the second section is expanded.

![Parameters](image1)

**Area Calculation**

\[
\text{Area} = d \times w \times h = 98304 \text{ cm}^3
\]

Figure 4.6: Sections in a worksheet

Evaluation order still applies as it normally does, and content in a section is evaluated even if a section is collapsed.

### Controlling the Display of Sections

You can edit a section title by clicking in the text box for the title, or by clicking on the top boundary line.

**Tip:** If a section does not have a title, click on the top boundary line. This opens the title text box for editing.

You can control the display of sections using **Format > Section Style**. From this dialog, you can:

- Control whether to display the top and bottom boundary lines.
- Control whether boundaries are displayed on only the left-most page.
- Specify margins.
- Specify boundary line thickness.
- Specify boundary line color.
- Specify boundary opacity.
- Control whether to display the expand button.

Note that if the section style is set up so the expand/collapse button is not displayed, you can expand or collapse a section by doing one of the following:

- Click the left most part of the top section boundary line
- Double-click anywhere along the top section boundary line.

For information on controlling the display of sections when printing or exporting to PDF, see *Printing a Worksheet with Sections* (page 57).

### Removing a Section

To remove a section:

- Use **Edit > Remove Section**. The content remains in the canvas, and the section boundaries are removed.
4.4 Controlling Display of Math

When creating a document, you can control some aspects of the display of the content of math containers. For instance, you can control numeric formatting, as described in Numeric Formatting (page 13). This section describes some further customizations.

Aligning Results under the Definition Operator

Typically, math output appears inline with the input. In the case that you are making a definition and displaying the output, you can choose instead to align the result on a new line, under the definition operator. This can help with readability. Figure 4.7 shows an example in which the output of the stress definition is displayed below.

\[
\text{force} := 4.5 \text{ N} \\
\text{area} := 3.4 \text{ cm}^2 \\
\text{stress} := \frac{\text{force}}{\text{area}} = 1.324 \times 10^4 \text{ Pa}
\]

Figure 4.7: Align Output Below :=

To align the result on the next line, below the := operator:

1. Enter the definition and press = to evaluate and display results.
2. With focus in the math container, click Align math output on newline (X:

Hiding Commands

When creating a document, you can hide the input expression and just show the resulting output.

To hide the input expression:

• Right-click on the math container and select Hide commands from the context menu.

In the case of an assignment, you can select either Hide commands or Hide commands and name.

\[
b := 15 \\
a := \frac{b}{5} = 3
\]

Figure 4.8: Hide commands

There is an option to display a visual indicator for math containers that have hidden commands. To enable this setting, select View > Visual Indicators. When Visual Indicators is selected, a math container with hidden commands is drawn with a gray circle at the top left corner.
Figure 4.9: Marker indicates hidden command

To show the command again:
• Right-click and select Show commands from the context menu.
  Similarly, you can select Show name if the name has been hidden.

You can also perform the hide commands action on multiple math containers.
1. Drag a selection box around a group of math containers.
2. Release the mouse button.
3. Right-click and from the context menu select Hide commands or Hide commands and name.

4.5 Controlling the Editability of a Document

You can protect the content in a document from changes by marking either the entire document as noneditable.

When a document is marked as noneditable, existing content in the document cannot be modified. For example, the Home page that appears when you first open Maple Flow is a noneditable document.

To prevent changes to a document, ensure the document is noneditable:
• In the status bar at the bottom of the Maple Flow window, clear the Editable check box.

When a document is noneditable, users can view the document, open and close sections, and click links, but cannot change content.

To change any part of a document, ensure the document is editable:
• In the status bar at the bottom of the Maple Flow window, select the Editable check box.

4.6 Including Images and Drawings

You can insert images and drawings into your worksheet using Insert > Image and Insert > Drawing.

When you insert a drawing, an empty grid appears. You can then use the drawing tools. You can also use the drawing tools on an image or a plot.

You can resize an image or drawing using the grab box around the image. Tip: To maintain the aspect ratio on an image, use the corner resizing handles. To maintain the aspect ratio on a drawing, hold the Shift key while resizing.

Drawing Tools

To view the drawing tools, select a drawing or an image in your Maple Flow worksheet. The Context toolbar displays the Drawing toolbar.

Figure 4.10: Drawing Toolbar

\[
\begin{align*}
  b &= 15 \\
  a &= \frac{b}{5} = 3 \\
  \text{sol} &= 0.017
\end{align*}
\]
Drawing on Plots

To view the drawing tools on a plot, select the plot in your Maple Flow worksheet. The Context toolbar displays the Plot toolbar by default. Use the drop-down list to switch to the Drawing toolbar, as shown in Figure 4.11.

Figure 4.11: Drawing on plots

Available Tools

The tools include the following: selection tool, pencil (free style drawing), eraser, text insert, straight line, rectangle, rounded rectangle, oval, diamond, arc, alignment tool, drawing outline tool, drawing fill tool, and line style tool.

Tip: For the text, line, rectangle, round rectangle, oval, diamond, and arc tools,
- Click once on the toolbar icon to insert that type of object into the drawing. The tool is activated. For example,
- Click twice on the toolbar icon to insert multiple objects of the same type without having to reselect the tool.
  The icon is highlighted yellow. For example, The tool remains activated until you select another toolbar icon.

Text

To insert text in the drawing canvas:
1. Click the text icon (T).
2. Click in the drawing canvas (on the image). A text box appears.
3. Enter text and modify font as necessary using the toolbar font and font size drop-down lists. Include math in the text box in the same way you include math in a text container. See Entering Math in a Text Container (page 21).
4. Optional. Select a fill color for a text box or select the line color for the border in the same way it is done for objects.
Lines - Straight, Resizing, Adding Arrows

Drawing Straight Lines

To draw a straight line:

1. Click the straight line icon (\). 

2. (Optional) From the menu, select the line style, thickness, and arrow points:

3. In the canvas, click and drag the mouse. A straight line is drawn.

4. To complete the line, click the mouse twice or press Enter. The drawing feature switches to the Selection tool.

5. You can draw more than one connected line; to complete your drawing, click the mouse twice, press Enter, or bring the end of the last line back to the start of the first line.

6. To remove the last point drawn, press Esc.

Drawing a Line that Snaps to Vertical, Horizontal, or a 45 Degree Angle

To draw a line that snaps to an orientation that is a multiple of 45 degrees:

1. Click the straight line icon.

2. In the canvas, click and drag the mouse.

3. Press and hold the Shift key to snap to a 45 degree increment.

4. To complete the line, click the mouse twice or press Enter.

Drawing a Line that is Attached to a Shape

To draw a line that is attached to a shape in the drawing canvas:

If you have inserted a shape in the canvas, you can draw a line that is automatically attached to that shape.

1. Click the straight line icon.

2. Press and hold the Ctrl key, and, in the canvas, hover your mouse cursor over the existing shape to which you want to attach the line. The shape is highlighted in green.

3. To draw the line, click and drag the mouse.

4. To complete the line, click the mouse twice or press Enter. The drawing feature switches to the Selection tool.
Resizing Lines

To resize objects drawn with straight lines:
1. Select the line to be resized using the selection tool.
2. With the mouse pointer over a grab box, click and drag the line to increase or decrease its size.
3. Release the mouse button.

To resize a shape and maintain the aspect ratio, hold the Shift key while resizing.

Changing Vertices of Lines

To change vertices of drawn lines in the canvas:
When an object is selected, grab boxes and nodes at the vertices are displayed.

1. Click a node and drag the mouse to the desired point, thereby changing the vertex position.
2. Release the mouse.

Changing the Line Style

To change the style of drawn lines:
You can change the line style, thickness, and arrow points of a line either when it is drawn or afterwards.
1. Select a line using the selection tool.
2. From the menu, select a line style, thickness, or arrow direction and shape.
The selected change is automatically applied to the straight line.

For example, a straight, thick line will have a solid arrow on the right end after clicking on the menu item displayed above.

Rotating Images or Rotating Objects in a Drawing

You can rotate an image, or an object in a drawing. The process is the same.

To rotate an object:

1. Select the object. The vertices of the object are designated by grab boxes.
2. Place the cursor at one of the vertices.
3. Press Ctrl. The rotate icon is displayed.
4. While pressing Ctrl, click the mouse and drag. The object rotates. Release the mouse once the object is positioned as you want.
Color Selection Dialog

The drawing outline tool, drawing fill tool, and canvas properties tool allow you to select colors for shapes, lines, and the canvas grid lines. Choose a color by using one of the following tools in the color selection dialog:

Color Palette

To select a color, click a color from a palette of pre-defined colors.

The last five colors that you select are displayed in the box below the color swatches. If you want to view the RGB values of a particular color, hover your mouse cursor over a color swatch.

Color Wheel

To select a color:

1. Move the slider beside the color wheel to display a range of colors.
2. To select a color, click a point in the color wheel.
Color Value Sliders

To select a color, specify the RGB values of the color by moving the sliders. Alternatively, you can use the spinners to scroll to certain values or type the values directly in the fields. For each RGB value, you can specify a number from 0 to 225.

Color Magnifying Glass

To select a color:

1. Select the eye dropper icon ( ).
2. Hover the color magnifying glass over an area on your screen that displays the color you want to select.
3. Using your mouse cursor, in the circle, click a point that displays the color.

To cancel your selection, right-click the circle.

Pencil Tool - Free Form drawing

To draw with the pencil tool in the canvas:

1. From the drawing icons, select the pencil tool icon ( ).
2. Click and drag your mouse in the canvas to draw lines. Release the mouse to complete the drawing.

Selection Tool - How and When to Use

To select items in the canvas use the selection tool ( ).

You can use the selection tool to select a single object or a group of objects. To select a group of objects:

Using the selection tool, click and drag the mouse around the items to be grouped. Release the mouse button. The items are temporarily grouped.

Apply formatting as desired, for example by using the alignment tools in the Drawing toolbar.
To temporarily switch to the selection tool (when using another tool), press and hold the Tab key (Command, Mac). You can move and resize objects. When you release the Tab key, the tool will revert to its previous setting. This allows you to tweak something you just drew.

**Filling Objects - Solid or Gradient Fill Colors**

**Filling an Object with a Solid Color**

To fill an object with a solid color:

1. Select the object in the canvas.
2. From the menu, select the solid fill style at the top (next to None).
3. From the same menu, click the left color bar at the bottom, and select a color from the color palette.
4. To change the line color, select a color from the menu.

**Filling an Object with a Gradient Color**

To fill an object with a gradient color:

1. Select the object in the canvas.
2. From the menu, select one of the gradient fill styles, the square icons.
3. From the same menu, click the left and right color bars at the bottom to select a color from the color palette for each part of the gradient.
4.7 Creating Hyperlinks

You can add a hyperlink to a worksheet that links to another Maple Flow worksheet, a webpage, and more.

To insert a hyperlink:
1. In a text container, select Insert>Hyperlink. The Hyperlink Properties dialog opens.
2. For the Link Text field, enter the text to be shown.
3. Select the link type.
4. For the Target field, enter the destination. Note that you have to save your document if you want to use a relative path.
5. Optionally, you can add a hyperlink tooltip.

You can also create a hyperlink by selecting some text and using the Format > Convert > Hyperlink menu item.

To edit the hyperlink properties, right-click on the hyperlink and select Hyperlink Properties.

You can create a hyperlink to a Maple Flow help page. For example, setting Type to Help Topic and Target to solve creates a link to the solve help page.

![Hyperlink Properties](image)

**Figure 4.12: Help Topic Hyperlink**

**Using Bookmarks**

Bookmarks allow you to mark a specific position in a worksheet. After you have created a bookmark, you can create a hyperlink to that bookmark.

You can create a bookmark for a section title, text container, math container, or image.
To create a bookmark:

1. Place the cursor at the location where you want the bookmark.
2. From the **Format** menu, select **Bookmarks**. The **Bookmarks** dialog opens.
3. Click **New**. The **Create Bookmark** dialog opens.
4. Enter a bookmark name and click **Create**. The new bookmark appears in the **Bookmark** dialog list. Click **OK** to accept this bookmark.

You can link to a bookmark using a hyperlink. You can link to a bookmark in the same worksheet or in another worksheet.

To create a link to a bookmark in the same worksheet:

1. In a text container, select **Insert** > **Hyperlink**. The Hyperlink Properties dialog opens.
2. For the **Link Text** field, enter the text to be shown.
3. Select Worksheet from the **Type** drop-down menu.
4. Leave the **Target** field blank to link to a bookmark in the current document.
5. From the **Bookmark** drop-down menu, select the desired bookmark. All bookmarks in the current worksheet are available.

![Hyperlink Properties](image)

**Figure 4.13: Link To Bookmark**

6. Optionally, you can add a hyperlink tooltip.
7. Click **OK**. The hyperlink is created.

You can also create a hyperlink to a bookmark by selecting some text and using the **Format** > **Convert To** > **Hyperlink** menu item.

To create a link to a bookmark in another worksheet, the steps are analogous, but for the **Target** field, enter or browse to the desired Maple Flow worksheet.
Additional Notes:

- The Edit > Go To menu item can be used to go to a bookmark in the current worksheet.
- You can rename or delete an existing bookmark from the Format > Bookmarks menu.
- There is an option to display a visual indicator for bookmarks. To enable this setting, select View > Visual Indicators. When Visual Indicators is selected, a container or other location in the document that has a bookmark is drawn with a dark gray square at the top left corner.

Using Shortcuts

In addition to hyperlinks, your worksheet can contain shortcut components, which are clickable image links. The default look of a shortcut is shown in Figure 4.14, but you can change the image used. The Application Gallery in Maple Flow uses shortcuts.

Figure 4.14: Shortcut

To insert a shortcut:

1. Click on the canvas.
2. Select Insert > Shortcut. A shortcut component is inserted at the cursor.
3. To edit the shortcut properties, select the shortcut component, and in the Context Panel the shortcut properties are available.

Figure 4.15: Shortcut Properties

4. Specify a caption, which appears below the image. Optionally, add a tooltip.
   Note: The Name field is used by Maple Flow to identify the component. The caption is what is visible.
5. Specify a link target. You can link to a Maple Flow worksheet or URL. You can also use the Shortcut to open a blank Maple Flow worksheet, execute one line of Maple code, or open a help topic.

![Link Target]

Figure 4.16: Using a Shortcut to execute code

6. If desired, change the image.
5 Further Tools

5.1 Introduction

This chapter provides further details on a range of tools available in Maple Flow, including mathematical functions, plots, using units in Maple flow, working with matrices, features that make authoring documents easier, and programming via the code editor.

5.2 Functions

Maple Functions

Maple Flow is built on top of the Maple programming language. You can use most Maple functions in Maple Flow. Maple package functions are used in the long form. For example, `SignalProcessing:-FFT()`. Note: Use of the `with()` command to load packages is not supported.

The Maple programming language is described in the Maple online help: [http://www.maplesoft.com/support/help](http://www.maplesoft.com/support/help).

Unsupported Maple Keywords, Commands, and Packages

As noted above, the `with()` command is not supported, and instead package commands should be called using the long form of their name. In addition, some Maple keywords, commands, and packages are not supported. The following are some examples, but not a complete list.

The `assume` command is not supported (use `assuming` instead). Some keywords, such as `read` and `save`, are not supported.

These Maple packages are not supported:

- Physics
- Tolerances
- DocumentTools
- Typesetting

Procedures can only be defined in the Code Editor. See *Code Editor (page 50)*.

5.3 More Controls for Units

In *Units (page 15)*, we describe how to add units to your computations. In this section we describe further tools for controlling units in your computations.

Setting the Default Unit System

By default, units in output are displayed using the SI system of units. You can change the default system of units.

To set the default system of units:

1. From the toolbar, click the Options icon (جيب).
2. Under the Units tab, select the desired output unit system, SI, FPS, or IPS.
3. Select `Apply even if no operations are performed` to force recalculation of the worksheet.
4. Click `Apply to Session` to apply for the current Maple Flow session only, or click `Apply Globally` to apply the setting to the current session and future sessions.
Changing the Units of a Result

Sometimes you want to control the units displayed in a result beyond setting the default system of units. There are two ways of changing the units of a result: inline or through the Context Panel.

To change the units of a result inline:
1. Move the cursor into the output of the math container.
2. Delete the existing unit, and type the desired unit.
3. Press Enter or use the arrow keys to leave the math container. The result is updated.

For example, in this example, suppose we want the elapsed time shown in minutes, not seconds.

\[
\text{pace} := \frac{11 \text{ minutes}}{\text{mi}} \\
\text{distance} := 2.5 \text{ mi} \\
\text{elapsed time} := \text{pace \ distance} = 1.650 \times 10^3 \text{ s}
\]

Edit the right-hand side by deleting the unit s and typing min. When you press enter the result is calculated in the desired units.

\[
\text{elapsed time} := \text{pace \ distance} = 27.500 \text{ min}
\]

To change the units using the Context Panel:
1. Move the cursor into the output of the math container.
2. In the Context Panel for the result, select the desired unit from the Choose Unit list, and press Enter. You can also type the desired unit in the Enter Unit field, for instance, if the Choose Unit list doesn't show the desired unit, as the list is not exhaustive.
Dimensional Balancing

If you change a unit of a result inline or via the Context Panel, and the unit is dimensionally inconsistent with the currently displayed unit, Maple Flow automatically performs dimensional balancing by inserting additional units to make the result dimensionally consistent.

Custom Units

You can define a custom unit, which will then be available for rescaling any result with units of equivalent dimension.

```
To define a unit:
1. Click a blank part of the canvas to create a math container, and then from the Units palette insert the units placeholder.
2. In the units placeholder, type the name of your custom unit.
3. Use the right arrow key to leave the units placeholder.
4. Type := (colon equals) to create a definition.
5. Insert another units placeholder from the Units palette.
6. Enter the unit definition.
```

fpd can now be used to rescale any result with a dimension equivalent to length/time.
5.4 Variables Manager

The Variables Manager in the palettes pane helps you keep track of the variables currently defined in your worksheet, including any defined custom units.

As you move your cursor through the worksheet, the Variables manager dynamically updates to show what variables are defined up to that point.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="View" /></td>
<td>View - Inspect the value assigned to a variable.</td>
</tr>
<tr>
<td><img src="image" alt="Hide" /></td>
<td>Hide - Hide a variable in the Variable Manager</td>
</tr>
<tr>
<td><img src="image" alt="Filter" /></td>
<td>Filter - Filter the variables list so the selected variables are shown. This can be used to unhide a variable you previously hid.</td>
</tr>
</tbody>
</table>

Inserting Variables into the Worksheet Using the Variables palette

Any variables that appear in the Variables palette can be inserted into the worksheet from the palette.

To insert a variable from the Variables palette into your worksheet, either:

- Right-click on a variable, then from the context menu, select Insert Into Worksheet.
- or
- Double-click on the variable name in the Variables palette.

Notes:

Insert Into Worksheet is enabled only when:

- The grid cursor is on the canvas. In this case, a new math container is created into which the variable being inserted is added.
- The cursor is currently in an active math container. In this case, the variable is inserted at the cursor location.

5.5 Plots

You can create a plot with the Maple language plot command. A simple example is given in Figure 5.3.
Maple Flow also supports 3-D plots. A simple example is given in Figure 5.4.

You can rotate a 3-D plot.

To rotate a plot:
1. Double-click the plot. The 3-D plotting toolbar is shown in the context menu. By default, the rotate tool ( ) is enabled.
2. Hold the left mouse button and drag the mouse to re-orient the plot.
3. Release the mouse button when the plot is oriented as desired.

The values of the angles theta, phi, and psi are displayed in the 3-D plotting toolbar to help you orient the plot. You can also interact directly with the values of these angles.

The orientation is determined by rotating the plot psi degrees around the x-axis, then phi about the (transformed) y-axis, and then theta about the (transformed) z-axis.

To reset the view, use the Reset view icon ( ). The rotation and zoom of the plot reset to the initial view.
You can resize the plot in the worksheet.
1. Select the plot, as shown in **Figure 5.5**.
2. Resize the plot. To maintain the aspect ratio, hold **Shift** while resizing.

![Figure 5.5: Resizing a plot](image)

Tip: When the plotting command is long, you may want to line break the command using **Shift + Enter**. This enters a soft new line, and can be useful for controlling the width of math containers. It also makes it possible for you to resize the plot narrower, since resizing is naturally limited by the width of the math container.

If you do not want to see the plot command at all, you can hide it as described in *Hiding Commands* (page 25).

### 5.6 Matrices

**Entering and Using Matrices**

**Matrix Entry**

There are a few ways to enter a Matrix.

The Matrix palette or Matrix command can be used to enter a matrix.

When you use the Matrix palette, shown in **Figure 5.6**, a template is inserted into the worksheet.

![Figure 5.6: Matrix palette](image)

You can then replace the placeholders in the matrix template, using **Tab** to move between placeholders.
To add an additional row or column to a matrix, place your cursor in the matrix and right-click. From the context menu, select one of:

- **Insert Row Above**
- **Insert Row Below**
- **Insert Column to the Left**
- **Insert Column to the Right**

Similarly, you can remove a row or column from the context menu.

**Tip:** Triple-click to select the entire matrix.

### Indexing into Matrices

If you’ve made a matrix definition, such as

\[
M := \begin{bmatrix}
2.2 & 3.1 \\
4.0 & 1.7
\end{bmatrix}
\]

you can index into the matrix using indexed notation.

For example, to extract the first entry, you enter `M[1,1]`. This can be entered by hand or selected from the Expression palette. To enter this from the Expression palette:

1. From the Expression palette, click `a[n]`. This template is inserted in the worksheet.
2. Replace the placeholders, using Tab to move between placeholders.

In **Figure 5.6**, further examples of matrix indexing are given.

\[
M := \begin{bmatrix}
2.2 & 3.1 \\
4.0 & 1.7
\end{bmatrix}
\]

\[
M[1,1] = 2.200 \quad \text{Select the (1,1) entry.}
\]

\[
M[1,2] := 1.2 \quad \text{Change the (1,2) entry.}
\]

\[
M[1] = \begin{bmatrix}
2.200 \\
1.200
\end{bmatrix} \quad \text{Select the first row.}
\]

\[
M[..,2] = \begin{bmatrix}
1.200 \\
1.700
\end{bmatrix} \quad \text{Select the second column.}
\]

### Basic Matrix Operations

<table>
<thead>
<tr>
<th>Operation</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Matrix multiplication</td>
<td><code>M \cdot N</code> (period)</td>
</tr>
<tr>
<td>Matrix inverse</td>
<td><code>M^{-1}</code> or <code>LinearAlgebra:-MatrixInverse(M)</code></td>
</tr>
<tr>
<td>Transpose</td>
<td><code>M^T</code> or <code>LinearAlgebra:-Transpose(M)</code></td>
</tr>
<tr>
<td>Elementwise operations</td>
<td><code>elementwise(expression)</code></td>
</tr>
</tbody>
</table>
The elementwise function allows you to apply operators and basic functions element-wise over data container(s) such as matrices, arrays, or lists. For example, if M and N are matrices of the same dimensions, \texttt{elementwise(3*log(M)*N)} applies this expression to the positional pairwise entries of these matrices.

More information can be found in the help system.

**Viewing Large Matrices and Vectors**

Matrices $10 \times 10$ and smaller, and vectors with 10 or fewer elements, display in the document. For larger matrices or vectors, a portion is shown inline.

**For example, insert a $30 \times 30$ matrix.**

1. In the Matrix palette, specify the dimensions: 30 rows and 30 columns.
2. In the **Type** drop-down list, select a matrix type, for example, **Random**.
3. Click **Insert Matrix**. The command is inserted; evaluate and display the result.

![Figure 5.9: Inline Matrix Browsing](image)

Note the output shows ellipses indicating the data continues and the output is scrollable meaning that you can explore the values directly within the worksheet, using your trackpad or mouse wheel. To view the entire matrix or vector, double-click the summary placeholder. This launches the Matrix Browser.

Back in the document, the context menu for the matrix has some controls.
• To remove the row and column headers, right-click on the matrix and clear the check boxes for **Row Header** and **Column Header**.

![Context menu showing options to clear headers](image)

Additionally, you can disable the scrollable functionality by selecting **Freeze Scrollable Output** from the context menu. This also freezes the Matrix in its current size and position.

**Set Displayed Matrix Size**

In **Figure 5.9**, for the matrix, a certain number of rows and columns are displayed. By default, 10 rows and 10 columns are displayed in output for any matrix. The same rules apply to one-dimensional and multidimensional data stored as arrays.

You can change this setting in the Options dialog.

To set the maximum number of rows and columns displayed:

1. From the toolbar, click the Options icon (тельные)
2. Under the Display tab, specify the desired values under Output matrix size for:
   - **Row limit**
   - **Column limit**
3. Click **Apply to Session** to apply for the current Maple Flow session only, or click **Apply Globally** to apply the setting to the current session and future sessions.
Set Matrix Save Limit

If a worksheet that contains a large matrix is saved and reopened, the data is saved and is scrollable as long as the matrix has 5000 or fewer entries. With larger matrices, you will need to re-execute or re-import the matrix before scrolling. This limit can be changed in the Options Dialog:

1. From the toolbar, click the Options icon (ulfilled).
2. Select the General tab.
3. Enter your value for RTable output save limit.
4. Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the setting to the current session and future sessions.

Data Import Assistant

The data import assistant makes it easy to import your data into a worksheet. Supported file types include CSV, delimited, and Excel files, as well as audio files, image files, and graph formats.

To import data:
1. Click on a blank part of the canvas to create a math container.
2. From the Tools menu, select Import Data. The Data Import Assistant opens.
3. Browse to select a file to import.
4. Follow the steps in the assistant. When prompted, specify a variable name to which to assign the imported data.
5. Click done when prompted. A command is inserted into the math container that will import the data.
5.7 Ease of Use Features

Command and argument completion offer an easy way to get your syntax right when working with commands in Maple Flow.

Command Completion

Maple Flow offers a dialog for command completion. When typing in a math container, Maple Flow suggests commands and templates that match what you have already entered.

The command completion dialog is initiated by pressing Esc or Ctrl + Space.

The command completion lists include command names and templates. If there are any placeholders in your selection, they appear in a colored font. Replace the placeholders in the template, using Tab to move to the next placeholder.

Automatic Command Completion

In addition, when typing in a math container, Maple Flow offers automatic completions for items that are unambiguous. When such a suggestion is available, it appears as a yellow annotation. Pressing the Esc or Tab key inserts the suggested item.
Argument Completion

Similar in concept and design to command completion, Maple Flow offers automatic completions for arguments in many useful cases. When such items are available, Maple Flow displays a popup list of suggested completions.

Example: plot(\(e^x, x = 0 .. 2\), color)

To use argument completion:
1. If only one item is suggested, press Tab to insert the suggested item into your expression.
2. If more than one item is listed, use the arrow keys to select an entry then press Tab. You can alternatively use your pointer to select an entry from the list.

The argument completion list can include examples for some suggested items. In such a case, if you select that entry, the example is inserted.

Example: plot(\(e^x, x = 0 .. 2\), color)

Note: Automatic argument completion is on by default.

To turn off argument completion:
1. From the toolbar, click the Options icon (⚙️).
2. Select the Interface tab.
3. Clear the **Automatic argument completion** check box.
4. Click either **Apply to Session** or **Apply Globally**.

**5.8 Code Editor**


To view the code editor, click the **Code Editor** button on the main toolbar, as illustrated in **Figure 5.13**. Alternatively, from the **Edit** menu, select **Code**.

![Figure 5.13: Code Editor button on main toolbar](image)

**Note:** You can only enter proc definitions in the code editor. That is, your code should be in the form:

```maple
FirstProc:=proc(...) ... end proc;
NextProc:=proc(...) ... end proc;
```

To define the procedure, enclose a sequence of statements between **proc(...)** and **end proc** statements, and specify the parameter name(s) in the parentheses after the proc statement. For example, a simple definition for a procedure that takes one parameter and returns the square of the parameter is:

```maple
MyProc:=proc(x) x^2; end proc;
```

**5.9 Logging Debugging Information**

Maple Flow uses a log file. It always includes some information on the startup routine.

If necessary, you can enable the logging of debugging information into the log file. This information may be needed if you contact Technical Support.
To enable logging of debugging information:

1. From the toolbar, click the Options icon (옵션).
2. Under the General tab, select **Include debugging information in log file**.
3. Click **Apply to Session** to apply for the current Maple Flow session only, or click **Apply Globally** to apply the setting to the current session and future sessions.
   
   Now, the log file will include information that can be used for troubleshooting.

Note: The log file is located here:

- On macOS: `~/.maplesoft/maplesoft.log`
- On Windows: `C:\Users\username\maplesoft\maplesoft.log`
6 Printing and Exporting to PDF

6.1 Printing a Maple Flow Document

The following sections describe settings you can control when printing or exporting to PDF.

Whenever you prepare a document for printing or export to PDF, the entire document re-evaluates if needed so everything reflects the current state.

6.2 Print Extents

Selecting **View > Print Extents** displays dashed horizontal and vertical lines. These indicate the extents of a printable page, taking into account the chosen page size, margins and headers/footers. Pages are printing column-by-column.

Figure 6.1: Print extents
The on-screen positioning and size of math, text, plots and images will be reflected in the printed page or exported PDF.

Note: If you only want to print the left-most page, under File > Print Settings, select Print single page width. This is useful, for example, if you write extra notes to the side of your work. By using print extents and this setting, you can ensure those notes do not end up in the printed version of your document.

6.3 Headers/Footers

The Insert > Header Footer menu permits you specify a header and/or footer. This will be seen in the printed page or exported PDF, but not in the working environment.

![Header and Footer window](image)

**Figure 6.2: Inserting Headers and Footers**

Headers and footers can be customized, making it easy to create standardized templates. A header or footer can include date, timestamp, image, document name, page number, and so on. You can draw borders around the header, footer, or the body of the document.

To create a multi-line header or footer, use a newline character.

- On Windows, use \n
- On Mac, use \r

For example, to create a multi-line header in Windows that contains the date and timestamp on different lines:

1. From the Insert menu, select Header Footer...
2. In the Header Footer window, select the Custom Header tab.
3. In the **Left** text field, click **Insert Date**.
4. Also, in the **Left** text field, after the newly inserted date, type "\n".
5. Click **Insert Timestamp**. The **Left** text field will look like this:

   ![Header and Footer dialog](image)

6. Click **OK**.
7. Finally, If you open Print Preview, your header should look like this:

   ![Example header](image)

**Note:** For headers or footers on the same line, use the spacebar to insert a space between header or footer elements.

**Apply a Header or Footer to All Your Documents**

To apply the header or footer to all documents:

- Select **Apply Globally**.

To remove the global definition, open the header/footer dialog and select None for both header and footer, and check **Apply Globally**.

To edit the global definition, open the header/footer dialog, made the desired edits, and then check **Apply Globally**.
Additional Options

To access additional formatting options, click **Options**

From the Options menu, you can adjust:

**Start headers on page.** Use the option arrow buttons to select on which page you want the headers to begin appearing.

**Start page numbers at.** Use the option arrow buttons to select the page you want numbering to begin appearing.

**Date Format:** You can adjust the date format in your header or footer by selecting one of the available options from the list.

<table>
<thead>
<tr>
<th>Date Format Choice</th>
<th>Displayed as</th>
</tr>
</thead>
<tbody>
<tr>
<td>Short</td>
<td>2023-04-04</td>
</tr>
<tr>
<td>Medium</td>
<td>Apr 4, 2023</td>
</tr>
<tr>
<td>Long</td>
<td>April 4, 2023</td>
</tr>
<tr>
<td>Full</td>
<td>Tuesday, April 4, 2023</td>
</tr>
</tbody>
</table>

**Scale Image.** Scale the size of the inserted image as a percentage of the original size.

**6.4 Page Setup**

The **Page Setup** menu lets you change the page size, orientation, and margins, for printing.
To specify the page setup for one document:

- Use **File > Page Setup** to specify the settings.

The page layout is saved with the document and remembered when it is reopened.

To set the default page layout:

1. From the toolbar, click the Options icon (•).
2. In the **Template** tab, click **Set default page layout**. The Page Setup dialog opens. Specify the settings and click **OK**.
3. Click **Apply to Session** to apply for the current Maple Flow session only, or click **Apply Globally** to apply the setting to the current session an future sessions.

### 6.5 Print Preview

The **File > Print Preview** menu lets you preview the printed page or exported PDF.

### 6.6 Export to PDF

On Windows:

To export the worksheet to PDF:

1. Select **File > Export As**.
2. Browse to the desired location and specify a filename. Click **Save**.
On Mac:

To create a PDF of the worksheet:
1. Select File > Print.
2. Select Save as PDF.
3. Specify a filename. Click Save.

### 6.7 Printing a Worksheet with Sections

Whether printing or exporting to PDF, if your Maple Flow worksheet has sections, you can select how it is printed.

Select File > Print Settings. Select one of the following:
- Print/export document with all sections expanded.
- Print/export document keeping sections exactly as shown on-screen.

If you selected the first option, in addition, specify whether to print the section boundary markers.

For more information on controlling the display of sections, see *Controlling the Display of Sections* (page 24).
# 7 Keyboard Shortcuts

Maple Flow provides many keyboard shortcuts for ease of use. These are given in the following tables.

## Table 7.1: Keyboard shortcuts for canvas operations

<table>
<thead>
<tr>
<th>Canvas operations</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>With the grid cursor on an empty row: move the grid cursor, and all content below the grid cursor, down</td>
<td>Enter</td>
<td>Return</td>
</tr>
<tr>
<td>With the grid cursor on an empty row: move the grid cursor, and all content below the grid cursor, up</td>
<td>Backspace</td>
<td>Backspace</td>
</tr>
<tr>
<td>With the grid cursor on an empty row: move all content below the grid cursor up</td>
<td>Delete</td>
<td>Delete</td>
</tr>
<tr>
<td>With the grid cursor on a container: move the container</td>
<td>Ctrl + arrow keys</td>
<td>Command + arrow keys</td>
</tr>
<tr>
<td></td>
<td>Ctrl + Shift + arrow keys</td>
<td>Command + Shift + arrow keys</td>
</tr>
<tr>
<td>With the cursor in a container: delete the container</td>
<td>Ctrl + Delete</td>
<td>Command + Delete</td>
</tr>
<tr>
<td>Move to next container</td>
<td>Tab</td>
<td>Tab</td>
</tr>
<tr>
<td>Move to previous container</td>
<td>Shift + Tab</td>
<td>Shift + Tab</td>
</tr>
<tr>
<td>Cursor to top of canvas (first container)</td>
<td>Ctrl + Home</td>
<td>Command + Home</td>
</tr>
<tr>
<td>Cursor to bottom of canvas (last container)</td>
<td>Ctrl + End</td>
<td>Command + End</td>
</tr>
</tbody>
</table>

## Table 7.2: Keyboard shortcuts for math entry

<table>
<thead>
<tr>
<th>Math</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evaluate math and display output*</td>
<td>=</td>
<td>=</td>
</tr>
<tr>
<td>Update math container, then continue editing</td>
<td>Ctrl + Enter</td>
<td>Command + Return</td>
</tr>
<tr>
<td>Entering an equal sign to mean equality*</td>
<td>Ctrl + =</td>
<td>Command + =</td>
</tr>
<tr>
<td>Add units to a value or expression</td>
<td>Ctrl + Shift + U</td>
<td>Command + Shift + U</td>
</tr>
<tr>
<td>Navigate through expression</td>
<td>[←][→][↑][↓]</td>
<td>[←][→][↑][↓]</td>
</tr>
<tr>
<td>Move cursor to different level in expression, e.g. out of exponent</td>
<td>[→]</td>
<td>[→]</td>
</tr>
<tr>
<td>Fraction $\frac{x}{y}$</td>
<td>x/y</td>
<td>x/y</td>
</tr>
<tr>
<td>Inline fraction $\frac{x}{y}$</td>
<td>x/y</td>
<td>x/y</td>
</tr>
<tr>
<td>Literal subscript $x_n$</td>
<td>$x_n$ (two underscores)</td>
<td>$x_n$</td>
</tr>
<tr>
<td>Exponent $x^n$</td>
<td>$x^n$</td>
<td>$x^n$</td>
</tr>
<tr>
<td>Command or symbol completion</td>
<td>Esc, or Ctrl + Space</td>
<td>Esc, or Command + Shift + Space</td>
</tr>
<tr>
<td>Enter a Greek character**</td>
<td>Ctrl + G</td>
<td>Command + G</td>
</tr>
<tr>
<td>Navigate between placeholders in a math expression</td>
<td>Tab, or Shift + Tab (navigate backwards)</td>
<td>Tab, or Shift + Tab (navigate backwards)</td>
</tr>
<tr>
<td>Toggle between numeric/symbolic mode for math container</td>
<td>Alt + S</td>
<td>Ctrl + S</td>
</tr>
<tr>
<td>Soft new line</td>
<td>Shift + Enter</td>
<td>Shift + Return</td>
</tr>
<tr>
<td>Disable/enable evaluation of the worksheet</td>
<td>Ctrl + E</td>
<td>Command + E</td>
</tr>
<tr>
<td>Interrupt evaluation</td>
<td>F6</td>
<td>F6 + Command + . (period)</td>
</tr>
</tbody>
</table>
You can change the behavior of the = key in a math container through the Options > Evaluation dialog. For details, see Controlling Evaluation (page 18).

Some notes on the evaluation shortcuts on international keyboards are found in the following table.

Table 7.3: International keyboard shortcuts for evaluation

<table>
<thead>
<tr>
<th></th>
<th>German keyboard</th>
<th>Japanese keyboard</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evaluate math and display output</td>
<td>Shift + 0, for Mac and Windows</td>
<td>Shift + -, for Mac and Windows</td>
</tr>
<tr>
<td>Entering an equal sign to mean equality</td>
<td>Shift + Alt + 0, for Windows</td>
<td>Ctrl + Shift + -, for Windows</td>
</tr>
<tr>
<td></td>
<td>Command + Shift + 0, for Mac</td>
<td>Command + Shift + -, for Mac</td>
</tr>
</tbody>
</table>

** To enter a Greek character, type the indicated Roman letter from the keymap in the following table, then type Ctrl + G (Command + G, for Mac) to get the corresponding Greek character.

Table 7.4: Greek Keymap

<table>
<thead>
<tr>
<th>Type</th>
<th>Lowercase Greek</th>
<th>Type</th>
<th>Uppercase Greek</th>
</tr>
</thead>
<tbody>
<tr>
<td>a</td>
<td>α</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>b</td>
<td>β</td>
<td>B</td>
<td>B</td>
</tr>
<tr>
<td>c</td>
<td>χ</td>
<td>C</td>
<td>X</td>
</tr>
<tr>
<td>d</td>
<td>δ</td>
<td>D</td>
<td>Δ</td>
</tr>
<tr>
<td>e</td>
<td>ε</td>
<td>E</td>
<td>E</td>
</tr>
<tr>
<td>f</td>
<td>φ</td>
<td>F</td>
<td>Φ</td>
</tr>
<tr>
<td>g</td>
<td>γ</td>
<td>G</td>
<td>Γ</td>
</tr>
<tr>
<td>h</td>
<td>η</td>
<td>H</td>
<td>H</td>
</tr>
<tr>
<td>i</td>
<td>τ</td>
<td>I</td>
<td>I</td>
</tr>
<tr>
<td>j</td>
<td>ι</td>
<td>J</td>
<td>ι</td>
</tr>
<tr>
<td>k</td>
<td>κ</td>
<td>K</td>
<td>K</td>
</tr>
<tr>
<td>l</td>
<td>λ</td>
<td>L</td>
<td>Λ</td>
</tr>
<tr>
<td>m</td>
<td>μ</td>
<td>M</td>
<td>M</td>
</tr>
<tr>
<td>n</td>
<td>ν</td>
<td>N</td>
<td>N</td>
</tr>
<tr>
<td>o</td>
<td>ο</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>p</td>
<td>π</td>
<td>P</td>
<td>Π</td>
</tr>
<tr>
<td>q</td>
<td>θ</td>
<td>Q</td>
<td>Θ</td>
</tr>
<tr>
<td>r</td>
<td>ρ</td>
<td>R</td>
<td>P</td>
</tr>
<tr>
<td>s</td>
<td>σ</td>
<td>S</td>
<td>Σ</td>
</tr>
<tr>
<td>t</td>
<td>τ</td>
<td>T</td>
<td>T</td>
</tr>
<tr>
<td>u</td>
<td>υ</td>
<td>U</td>
<td>Υ</td>
</tr>
<tr>
<td>v</td>
<td>ϖ</td>
<td>V</td>
<td>ζ</td>
</tr>
<tr>
<td>w</td>
<td>Ω</td>
<td>W</td>
<td>Ω</td>
</tr>
<tr>
<td>Type</td>
<td>Lowercase Greek</td>
<td>Type</td>
<td>Uppercase Greek</td>
</tr>
<tr>
<td>------</td>
<td>----------------</td>
<td>------</td>
<td>----------------</td>
</tr>
<tr>
<td>x</td>
<td>( \xi )</td>
<td>X</td>
<td>( \Xi )</td>
</tr>
<tr>
<td>y</td>
<td>( \psi )</td>
<td>Y</td>
<td>( \Psi )</td>
</tr>
<tr>
<td>z</td>
<td>( \zeta )</td>
<td>Z</td>
<td>Z</td>
</tr>
</tbody>
</table>

Table 7.5: Keyboard shortcuts for text entry

<table>
<thead>
<tr>
<th>Operation</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a text box</td>
<td>Space</td>
<td>Space</td>
</tr>
<tr>
<td>Switch to math entry in a text box</td>
<td>Ctrl + R</td>
<td>Command + R</td>
</tr>
<tr>
<td>Switch back to text entry</td>
<td>Ctrl + T</td>
<td>Command + T</td>
</tr>
</tbody>
</table>

Table 7.6: Keyboard shortcuts for menu operations

<table>
<thead>
<tr>
<th>Operation</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td></td>
<td></td>
</tr>
<tr>
<td>New</td>
<td>Ctrl + N</td>
<td>Command + N</td>
</tr>
<tr>
<td>Open</td>
<td>Ctrl + O</td>
<td>Command + O</td>
</tr>
<tr>
<td>Close worksheet</td>
<td>Ctrl + F4</td>
<td>Command + W</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl + S</td>
<td>Command + S</td>
</tr>
<tr>
<td>Save as ...</td>
<td>Ctrl + Shift + S</td>
<td>Command + Shift + S</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl + P</td>
<td>Command + P</td>
</tr>
<tr>
<td>Page setup</td>
<td>Ctrl + Shift + P</td>
<td>Command + Shift + P</td>
</tr>
<tr>
<td>Exit</td>
<td>Alt + F4</td>
<td>Command + Q</td>
</tr>
<tr>
<td>Edit</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl + Z</td>
<td>Command + Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl + Y</td>
<td>Command + Y</td>
</tr>
<tr>
<td>Find/Replace</td>
<td>Ctrl + F</td>
<td>Command + F</td>
</tr>
<tr>
<td>Select all</td>
<td>Ctrl + A</td>
<td>Command + A</td>
</tr>
<tr>
<td>Remove section</td>
<td>Ctrl + Comma</td>
<td>Command + Shift + Comma</td>
</tr>
<tr>
<td>Code editor</td>
<td>Ctrl + Shift + E</td>
<td>Command + Shift + E</td>
</tr>
<tr>
<td>View</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Zoom factor—default</td>
<td>Ctrl + 0</td>
<td>Command + 0</td>
</tr>
<tr>
<td>Zoom factor 75%</td>
<td>Ctrl + 1</td>
<td>Command + 1</td>
</tr>
<tr>
<td>Zoom factor 100%</td>
<td>Ctrl + 2</td>
<td>Command + 2</td>
</tr>
<tr>
<td>Zoom factor 125%</td>
<td>Ctrl + 3</td>
<td>Command + 3</td>
</tr>
<tr>
<td>Zoom factor 150%</td>
<td>Ctrl + 4</td>
<td>Command + 4</td>
</tr>
<tr>
<td>Zoom factor 200%</td>
<td>Ctrl + 5</td>
<td>Command + 5</td>
</tr>
<tr>
<td>Zoom factor 300%</td>
<td>Ctrl + 6</td>
<td>Command + 6</td>
</tr>
<tr>
<td>Zoom factor 400%</td>
<td>Ctrl + 7</td>
<td>Command + 7</td>
</tr>
<tr>
<td>Zoom in</td>
<td>Alt + Plus, or Control + Shift + =</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Alt + =</td>
<td></td>
</tr>
<tr>
<td>Zoom out</td>
<td>Alt + -</td>
<td>Control + Minus, or Control + Shift + Minus</td>
</tr>
<tr>
<td>Insert</td>
<td>Ctrl + Enter</td>
<td>Command + Return</td>
</tr>
<tr>
<td>Format</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Table 7.7: Keyboard shortcuts for formatting
<table>
<thead>
<tr>
<th></th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Ctrl + B</td>
<td>Command + B</td>
</tr>
<tr>
<td><strong>Italic</strong></td>
<td>Ctrl + I</td>
<td>Command + I</td>
</tr>
<tr>
<td><strong>Underline</strong></td>
<td>Ctrl + U</td>
<td>Command + U</td>
</tr>
</tbody>
</table>

**Tools**

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Spellcheck</td>
<td>F7</td>
<td>F7</td>
</tr>
</tbody>
</table>

**Help**

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Maple Flow Help</td>
<td>F1</td>
<td>F1</td>
</tr>
<tr>
<td>Help on Context</td>
<td>F2</td>
<td>F2</td>
</tr>
</tbody>
</table>

**Table 7.7: Mouse bindings**

<table>
<thead>
<tr>
<th></th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Locate cursor</td>
<td>Single-click</td>
<td>Single-click</td>
</tr>
<tr>
<td>Select current word, in text container</td>
<td>Double-click</td>
<td>Double-click</td>
</tr>
<tr>
<td>Select entire matrix, piecewise expression, or container</td>
<td>Triple-click</td>
<td>Triple-click</td>
</tr>
</tbody>
</table>
# Index

## Symbols
- `:=`, 11
  - align results under definition operator, 25
- `=`
  - for equality, 11
  - to display results, 11
  - international keyboard shortcuts, 59

## A
- accuracy, 17
- align
  - containers to the left, 9
  - result on new line, 25
- assigning
  - align results under `:=`, 25
  - hide commands and name, 25
  - value to a name, 11

## B
- background color
  - for container, 21
- bookmarks, 34
- bring
  - to front/back, 10

## C
- canvas, 4
- code editor, 50
- command completion, 48
- commands
  - getting help on, 3
  - complex numbers, 15
- context panel, 4, 13
- control display of math
  - hide commands, 25
  - numeric formatting of result, 13
  - symbolic or numeric result, 12
- control display of results
  - align under `:=`, 25
- control editability of document, 26

## D
- debugging
  - log file, 50
- defining procedures, 50
- definition
  - creating, 11
- Digits
  - for numerical evaluation, 17
- drawings
  - creating, 26

## E
- editable option, 26
- editing, 8
- editing units, 16
- elementwise, 44
- entering
  - math container, 8, 11
  - text container, 8, 21
- entering math
  - basics, 15
  - command completion, 15
  - complex numbers, 15
  - definition, 11
  - in a text paragraph, 21
  - nonexecuting, 18, 19, 21
  - using `:=`, 11
  - option to change evaluation keys, 18
  - using palettes, 15
- entering units, 15
- `evalf`, 12
- evaluation
  - disable temporarily, 19
  - interrupt, 18
  - only visible containers, 18
  - order of, 18
  - progress bar, 18
  - using `=`, 11
  - international keyboard shortcuts, 59
- evaluation modes
  - numeric and symbolic, 12

## F
- flip
  - to front/back, 10
- format
  - section style, 24
  - using character formatting, 23
  - using style sets, 23
- functions
  - Maple, 38

## G
- graphing, 41
- Greek characters
  - entering, 59
- grid, 8

## H
- help
on additional Maple commands, 3
help system, 3
hide commands, 25
home page, 1
customize, 6
hyperlinks
inserting, 34
I
i, 15
images
drawing on, 26
inserting, 26
import data
using assistant, 47
indexing
into matrices or lists, 44
insert
header or footer, 53
section, 23
K
keyboard shortcuts, 58
L
linking
to a bookmark, 34
to another worksheet, 34
location
grid cursor, 8
M
Maple Flow
versus Maple, 2
Maple Flow window, 4
math container
for display only, 18
set background color, 21
matrix
entering, 43
importing data for, 47
large, 45
operations, 44
random, 45
select entries, 44
set matrix save limit, 47
set visible matrix size, 46
view entries, 45
moving
math container, 8
changes evaluation order, 18
text container, 8
N
numeric evaluation, 12
numeric formatting options, 13
O
open
in new window, 6
Options
default zoom, 5
display
set number format, 13
evaluate
entire worksheet, 18
evaluation keys, 18
on loading worksheet, 18
only visible containers, 18
P
packages
using Maple, 38
palettes, 4, 15, 43
units, 16
variables, 41
pasting
in math container, 11
PDF
export to, 56
pi, 12
plotting, 41
print
set default page layout, 55
settings for sections, 57
single page width only, 52
print preview, 56
printing, 56
programming, 50
R
random
matrices, 45
rounding
specify decimal places, 13
rtablesize option, 47
S
scientific formatting, 13
section
expand or collapse, 23
sections, 23
display of, 24
shortcuts
inserting, 34
status bar, 18
symbolic evaluation, 12
syntax
  documentation, 38
  for commands, 48

T
text
  formatting, 21
  formatting using built-in styles, 23
  using character formatting, 23
text container, 21
  entering math in, 21
  set background color, 21
toolbars, 4
troubleshooting
  logging debugging information, 50
turning evaluation off, 19
tutorials, 1

U
units, 15, 38
  add custom unit, 40
  changing units of a result, 39
  default units system, 38
  dimensional balancing, 40
  rescaling, 16

V
variables
  manager, 41
vector
  large, 45
view
  print extents, 52
  visual indicators, 12, 19, 25, 36

Z
zoom
  set default, 5