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Introduction

Maple Flow is a new calculation tool from Maplesoft. Maple Flow offers a freeform user interface for
engineering, scientific, and technical calculations.
Maple Flow gives you






A spatially aware mathematical canvas that replicates the design metaphor of a physical
whiteboard
Automatic recalculation to ensure that results are always up to date
A broad, rich mathematical language with many functions
Visually impactful, fully programmatic plots
A coding region with full access to the Maple programming language

Note for non-Windows users: The keystrokes given in this document are for Windows. If you are using
a different platform, see the keyboard shortcuts guide on page 18.
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What Does this Manual Aim to Do?

This manual describes



The Maple Flow interface
Differences with the Maple user interface and programming language that an existing Maple
user may experience.

This manual should be read in unison with the in-product tutorials and exercises; these are available
from the “Tutorial” link on Maple Flow’s home page.

Figure 1. Overview of in-product tutorials
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This manual does not describe the math functionality of the Maple Flow in detail, but makes references
to specific functions in context of a broader discussion. The detailed documentation for the math
functionality resides in the Maple online help.
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What is the Relationship between Maple and Maple Flow?

First, some definitions:



Maple refers to the (i) Maple programming language and (ii) Maple interface.
Maple Flow refers to the new product whose manual you are reading.

Maple Flow



Is built on top of the Maple programming language
Borrows a few elements from the Maple interface

Maple Flow’s “language” is the commands (and their syntax), data structures and programming
language. These are based on the Maple programming language; you can use any of the math functions
in Maple in your Maple Flow analyses.
Maple is installed automatically when you install the Maple Flow.
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If You’re a Maple User

If you already use Maple, you’ll appreciate the unique twist that Maple Flow offers with its spatial
evaluation model and automatic calculation updates. You’ll also get a head start because you’ll be
familiar with Maple’s programming language, functions and features.
Maple Flow differs from the Maple interface and programming language in a number of ways. Several
important differences are listed in Table 1.

5

Maple Flow
You enter math and text at any point, simply by
clicking with your mouse, and typing.
This is in much the same way that you can write
math at any point on a whiteboard.
The evaluation model is forward in space. Any
assignments are only valid at any point to the right
or below where they are made.

Multiplication needs to be explicitly stated.
More numeric evaluation by default (for example
5/10 evaluates to 0.5)
Units are automatically combined. That is, N/m2 is
automatically reconciled to Pa.
Maple Flow canvases are always up to date and
reflect the current state of all assignments. Any
changes or additions to the canvas automatically
cascade down the canvas. Automatic recalculation
can, however, be disabled.
Matrix, vector, and array indices are only entered
with square brackets.
Math is entered into the canvas in mathematical
notation, but programmatic content is entered in
Maple notation.

Maple
You can enter commands at execution prompts,
which are largely aligned to the left (except when
inserted into multicolumn tables), and linearly
progress down the worksheet.
The evaluation model is forward in time. You can
use assignments above or below where they are
made, at any time after the assignment is made.
Most users progress linearly down a worksheet,
but the apparently linear form of a worksheet is
not always reflected in the displayed results.
Multiplication can be implicit (i.e. entered with a
space) or explicit.
Results are kept symbolic except when requested
to be numeric (for example, with the evalf
command).
Units are only reconciled if explicitly requested by
the user (for example, by loading a Units package).
Individual commands, groups of commands, or
entire worksheets are only updated if requested
by the user. This means results may not reflect the
current value of definitions.
Matrix, vector, and array indices can be entered
with square brackets or typeset subscripts (in 2-D
input).
Equations and programs can be entered in typeset
mathematics notation (often called “2-D math”) or
Maple notation (“1-D math”).

Table 1. How Maple Flow differs from Maple

Maple worksheets cannot be loaded into the Maple Flow, or vice versa.
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Interface

The different parts of the Maple Flow interface are illustrated in Figure 2.
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Figure 2. The Maple Flow interface
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Canvas

6.1 Grid
When you drag math and text containers, the positions of containers are snapped to a grid. By default,
the grid is not displayed.
To display the grid, click the Enable/Disable Grid button on the main toolbar.

Figure 3. Enable/Disable Grid button on toolbar

6.2 Grid Cursor
The grid cursor is illustrated in Figure 4 and by default appears in the top left corner of every new
canvas.

Figure 4. Grid cursor

The grid cursor can be moved by pointing and clicking with the mouse, or with the arrow keys.
Math and text containers are created at the location of the grid cursor.
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6.3 Math and Text Containers
On the canvas, you can create math boxes or text boxes. Each box can be moved; the position of a math
container determines the order in which it is evaluated (as illustrated in Figure 14).
A container can be in one of three states, as described in the following table.
Math

Text

Stationary with no focus. A math
container in this mode is still “live”,
and the Maple Flow will update its
result if an upstream parameter
changes.
Editing
Numeric:
 Only one container can be in
editing mode at any one time.
 A math container has a solid
dark green border if numeric, Symbolic:
or a dashed light green border
if symbolic (see Section 7.4)
 A text container has a blue
border.
 You will see a flashing cursor,
whose position can be
changed with the arrow keys
or mouse.
Move
 Math and text containers
have a light blue border in
move mode.
 One or several containers can
be in move mode.
 Move the containers with the
mouse or Ctrl + arrow keys.
Table 2. Container States

6.4 Moving Containers
6.4.1

Single container

6.4.1.1 With the mouse
To move a container with the mouse:
1. Move the mouse pointer over a container.
2. Move the container to another position by click and dragging.
3. Release the mouse button when the container is in the desired position.
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6.4.1.2 With the keyboard arrow keys
To move a container with the keyboard:
1. Move the grid cursor into a container so you see a green border. The container is now in
editing mode
2. Do one of the following:
o Press Ctrl and use the arrow keys to move the container one grid space at a time.
o Press Ctrl + Shift and use the arrow keys to move the container a single pixel at a time.
6.4.2 Group of containers
To move multiple containers:
1.
2.
3.
4.
5.

Click in a blank part of the canvas.
Drag a selection box around a group of containers.
Release the mouse button.
Move the mouse pointer over one of the selected containers.
Drag the containers to another location.

6.4.3 Bringing containers from back to front, and vice-versa
You can potentially have two containers at the same grid position. You can bring the lower container
forward, or send the top container back, by using Flip to Front and Flip to Back buttons.

Figure 5. Flip to Front and Flip to Back buttons

6.5 Editing an Existing Container
To enter editing mode on an existing container, either



With the mouse, click the container.
With the arrow keys, move the grid cursor onto the container.

6.6 Inserting or Removing White Space
You can insert or remove space in the canvas (i.e. grid rows) by using the Enter, Backspace, and Delete
keys.
6.6.1 Adding blank rows
To add blank rows, place the grid cursor on a blank part of the canvas press Enter. This shifts all content
on and below the same row as the grid cursor down.
6.6.2 Deleting blank rows
To delete blank rows, click on a blank row of the canvas and press one of the following:


9

Backspace to remove that blank row and shift the grid cursor and all content below the grid
cursor up
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Delete to remove that blank row, and shift all content below that row up.

Entering Math

7.1 Creating a Math Container
A math container is a box in which you enter math that is to be executed.
To create a math container:
1. Click on a blank part of the canvas.
2. Begin typing your math. As soon as you enter the first character, a math container is created
automatically.

7.2 Deleting a Math Container
Drag-select the math container and press Delete.

7.3 Evaluating Math and Displaying Output
All math is evaluated in the canvas, using a left-to-right, top-to-bottom order (see section 7.10.2.) When
you need to display results, evaluate and display output.
To evaluate math and display output:
1. Enter the expression, then with the cursor at the right end of the expression, press = .
2. Press Enter or the arrow keys. The result is displayed. After evaluation, the focus leaves the
math container.

7.4 Numeric and Symbolic Evaluation Modes
Maple Flow offers two math evaluation modes – numeric and symbolic.
Numeric evaluation mode

Symbolic evaluation mode

Figure 6. Difference between numeric and symbolic evaluation modes

The numeric evaluation mode performs as much numeric evaluation as possible. For example
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Rational fractions (such as ½) are converted to floating point numbers
Pi and exp(1) evaluate to floating point numbers

Symbolic evaluation mode prevents numeric evaluation (except when requested by the user). For
example



Rational fractions are only converted to floating point numbers if request by the user (e.g. with
the evalf command)
Pi evaluates to a symbolic name

In both modes, unassigned names are evaluated symbolically (i.e. in numeric mode, unassigned names
do not give an error when evaluated)
The current mode of an existing math container is given by clicking inside it, and observing the state of
the border or numeric/symbolic buttons in the Context toolbar, as illustrated in Figure 6.
By default, new math containers are numeric. Clicking the “symbolic” button in the Context toolbar
switches the in-focus math container to symbolic mode.
Holding down the symbolic button for a second makes symbolic evaluation mode “sticky” (this is
indicated with a padlock by the symbolic button). This means that all future math containers will be
symbolic (until symbolic mode is toggled off with another long click on the symbolic button)

7.5 Numeric Formatting
By default, Maple Flow displays numeric results with three decimal places. To customize the numeric
formatting,



place the editing cursor on a numeric result
use the Number Format options in the Context Panel

Figure 7. Numeric formatting

7.6 Creating a Definition
You can assign a numerical value or an expression to a name by using := (a colon, followed by an equal
sign).
For example, entering a:=4 in a math container assigns the value 4 to the name a.

7.7 Basic Arithmetic
Equations are entered in typeset math notation, using standard keys such as /, *, + and -.
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Note that multiplication must always be explicitly stated. For example, you must enter 3*x, not 3x.
You can also use the Expressions palette, or Command Completion window to enter typeset math, as
illustrated in Figure 8.

(a) Command completion

(b) Expressions palette

Figure 8. Using the Command Completion menu and Expressions Palette to insert a square root

7.8 Complex Numbers
Imaginary numbers are entered with a number followed by the suffix i, with no multiplication between
the two. For example, 2+2i.
The unit complex number is created with 1i. You cannot just enter i for the unit complex number.
To create a symbolic multiplier on an imaginary number, you need to enter x*1i.

7.9 Units
7.9.1 Entering Units
You can enter units in several different ways.
7.9.1.1 Units Palette
You can enter units using the Units palette located in the Palettes pane on the left side of the Canvas.
Click the desired unit (using the Dimensionality drop-down list to switch to different groups of units), or
insert the unit placeholder (as illustrated in Figure 9) and overwrite the placeholder.
You may want to place a space between the number and the unit.
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Figure 9. Inserting a Unit with the Units Palette

7.9.1.2 Unit function
You can use the Unit() function to assign a unit.

Figure 10. Using the Unit() function to assign a unit

7.9.1.3 Keyboard shortcut
Press Ctrl + Shift + U to enter a unit placeholder. Then, replace the placeholder with the desired units.

Figure 11. Using keyboard shortcuts to insert a units placeholder

7.9.2 Editing Existing Units
Move the cursor onto the unit. When the unit has focus, it is surrounded by a blue box. You can now
change the unit.
Deleting all the characters in a units placeholder will leave an empty placeholder one character in size.
Deleting this empty placeholder will remove the units placeholder entirely.

7.10 Notes about Math Input
7.10.1 Numerical evaluation and accuracy
Any purely numerical operations are evaluated to a floating-point approximation.
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Figure 12. Numerical operations

The Digits environment variable controls the number of digits that Maple uses when making calculations
with software floating-point numbers.
The default value of Digits is 10. The value of Digits is changed with the assignment operator (e.g.
Digits:=15).
Figure 13 illustrates the effect of changing digits from its default value of 10 to 15 on the evaluation of
20.5 (note that numeric formatting on the result of 20.5 has been set to Fixed with 20 decimal places).

Figure 13. The effect of digits on numerical accuracy

7.10.2 Evaluation order
Maple Flow evaluates calculations from left-to-right, top-to-bottom (much like reading a page from a
book). This means that downstream calculations only “see” assignments on the left or above. This is
illustrated in Figure 14.
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Figure 14. Spatial evaluation

You can change the evaluation order by moving math containers around.
7.10.3 Non-executable math
You may want to enter non-executing math for documentation. You can do this by entering math into a
text container. For more about text containers, see Entering Text.
To enter math in a text container:
1. Anywhere inside a text container, press Ctrl + R to switch into math mode.
2. Enter your math.
3. If required, press Ctrl + T to return to text mode.
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Mathematical Functions

8.1 Maple Functions
Maple Flow is built on top of the Maple programming language. You can use most Maple functions in
Maple Flow.
Maple package functions are used in the long form. For example, SignalProcessing:-FFT(). Note: Use of
the with() command to load packages is not supported.
The Maple programming language is described in the Maple online help.

8.2 Unsupported Maple Keywords, Commands, and Packages
As noted above, the with() command is not supported, and instead package commands should be called
using the long form of their name. In addition, some maple keywords, commands, and packages are not
supported. The following are some examples, but not a complete list.
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The assume command is not supported (use assuming instead). Some keywords, such as read and save
are not supported.
These Maple packages are not supported:
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Physics
Tolerances
DocumentTools
Typesetting

Math and Text Styling

9.1 Formatting the Content of Single Containers
To change font, size, and color, drag-select the content and use the context bar.

9.2 Applying and Changing Styles
The style drop-down list contains several formatting styles for text and math.

Figure 15. The Styles drop-down list

By default,




text is given the Text style
math input is given the 2D Math style
math output is given the 2D Output style

You can apply other styles with the other entries (just as the Title style for text). You will need to dragselect the content of the container, and picking the appropriate style.
The Format > Styles menu lets you change the typeface of the pre-defined styles.
The Format > Manage Style Sets… menu lets you
16




Export and save the active style set
Load and apply an existing style set

10 Plots
You can create a plot with the Maple language plot command. A simple example is given in Figure 16.

Figure 16. A simple Maple Flow plot using a Maple plot command

11 Command Completion
Maple Flow offers a dialog for command completion. Maple Flow suggests commands and parameters
that complete what you have already entered.
The command completion dialog is initiated by pressing Esc or Ctrl + Space.

Figure 17. Command completion window

12 Code Editor
The Code Editor lets you write Maple procedures to use in a Maple Flow canvas. To learn how to write a
Maple procedure, read the online Maple Programming Guide.
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To view the code editor, click the Code Editor button on the main toolbar, as illustrated in Figure 18.
Alternatively, from the Edit menu, select Code.

Figure 18. Code Editor button on toolbar

Note: You can only enter proc definitions in the code edit region. That is, your code should be in the
form:
FirstProc:=proc …. end proc;
NextProc:=proc … end proc;

13 Entering Text
To enter text:
1.
2.
3.
4.

Click in a blank part of the canvas.
Press the space bar to create an empty text container. This will have a blue border.
Type your text.
Use the context toolbar to format your text.

Figure 19. Entering and formatting text

14 Printing and Export to PDF
14.1 Print Extents
Selecting View>Print Extents displays dashed horizontal and vertical lines. These indicate the extents of
a printable page, taking into account the chosen page size, margins and headers/footers. Pages are
printing column-by-column.
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Figure 20. Print Extents

The on-screen positioning and size of math, text, plots and images will be reflected in the printed page
or exported PDF.

14.2 Headers/Footers
The View > Header Footer menu lets you specify a header and/or footer. This will be seen in the printed
page or exported PDF, but not in the working environment.

Figure 21. Inserting Headers and Footers

14.3 Page Setup and Print Preview
The File>Page Setup menu lets you change the page size, orientation, and margins, for printing.
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Figure 22. Page Setup

The File > Print Preview menu lets you preview the printed page or exported PDF.

14.4 Export to PDF
To export the canvas to a PDF, click Print > Export.
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15 Keyboard Shortcuts
Canvas operations
Windows
Enter

Linux
Enter

Mac
Return

With the grid cursor on an
empty row: moves the grid
cursor and all content
below the grid cursor, up

Backspace

Backspace

Backspace

With the grid cursor on an
empty row: move all
content below the grid
cursor up

Delete

Delete

Delete

With the grid cursor on a
container: move the
container
Math
Add units to a value or
expression
Navigate through
expression
Move cursor to different
level in expression, e.g. out
of exponent
𝑥
Fraction

Ctrl + arrow keys
Ctrl + Shift + arrow
keys

Ctrl + arrow keys
Ctrl + Shift + arrow
keys

Command + arrow keys
Command + Shift + arrow
keys

Ctrl + Shift + U

Alt + Shift + U

Command + Shift + U

[←][→][↑][↓]

[←][→][↑][↓]

[←][→][↑][↓]

[→]

[→]

[→]

x/n

x/n

x/n

Inline fraction 𝑥 ⁄𝑦
Literal subscript 𝑥𝑛
Exponent 𝑥 𝑛
Command or symbol
completion
Text
Create a text box
Switch to math entry in a
text box
Switch back to text entry

x\/y
x_ _n
x^n
Esc, or
Ctrl + Space

x\/y
x_ _n
x^n
Esc, or
Ctrl + Shift + Space

x\/y
x_ _n
x^n
Esc, or
Command + Shift + Space

Space
Ctrl + R

Space
Ctrl + R

Space
Command + R

Ctrl + T

Ctrl + T

Command + T

With the grid cursor on an
empty row: move the grid
cursor and all content
below the grid cursor,
down

𝑦

Table 3. Keyboard shortcuts
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