# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preface</td>
<td>xiii</td>
</tr>
<tr>
<td>1 Getting Started</td>
<td>1</td>
</tr>
<tr>
<td>1.1 In This Chapter</td>
<td>1</td>
</tr>
<tr>
<td>1.2 Introduction to Maple</td>
<td>1</td>
</tr>
<tr>
<td>Working in Maple</td>
<td>1</td>
</tr>
<tr>
<td>Starting the Standard Document Interface</td>
<td>2</td>
</tr>
<tr>
<td>Entering 2-D Math</td>
<td>4</td>
</tr>
<tr>
<td>Toolbar Options</td>
<td>7</td>
</tr>
<tr>
<td>The Context Panel and Copy &amp; Drag</td>
<td>10</td>
</tr>
<tr>
<td>Saving a Maple Document</td>
<td>13</td>
</tr>
<tr>
<td>Saving a Maple Document as a Workbook</td>
<td>13</td>
</tr>
<tr>
<td>1.3 Entering Expressions</td>
<td>14</td>
</tr>
<tr>
<td>Execution Groups</td>
<td>14</td>
</tr>
<tr>
<td>Math Mode vs. Text Mode</td>
<td>14</td>
</tr>
<tr>
<td>Palettes</td>
<td>15</td>
</tr>
<tr>
<td>Symbol Names</td>
<td>21</td>
</tr>
<tr>
<td>Toolbar Icons</td>
<td>22</td>
</tr>
<tr>
<td>1.4 Point-and-Click Interaction</td>
<td>24</td>
</tr>
<tr>
<td>Assistants</td>
<td>24</td>
</tr>
<tr>
<td>Tutors</td>
<td>25</td>
</tr>
<tr>
<td>Math Apps</td>
<td>26</td>
</tr>
<tr>
<td>The Context Panel</td>
<td>27</td>
</tr>
<tr>
<td>Task Templates</td>
<td>27</td>
</tr>
<tr>
<td>Exploration Assistant</td>
<td>29</td>
</tr>
<tr>
<td>1.5 Commands</td>
<td>31</td>
</tr>
<tr>
<td>The Maple Library</td>
<td>31</td>
</tr>
<tr>
<td>Entering Commands</td>
<td>32</td>
</tr>
<tr>
<td>Document Blocks</td>
<td>35</td>
</tr>
<tr>
<td>1.6 The Maple Help System</td>
<td>37</td>
</tr>
<tr>
<td>Accessing the Help System</td>
<td>37</td>
</tr>
<tr>
<td>Using the Help Navigator</td>
<td>38</td>
</tr>
<tr>
<td>Viewing Help Pages as Documents</td>
<td>39</td>
</tr>
<tr>
<td>Viewing Examples in 2-D Math</td>
<td>39</td>
</tr>
<tr>
<td>Copying Examples</td>
<td>39</td>
</tr>
<tr>
<td>1.7 Available Resources</td>
<td>40</td>
</tr>
<tr>
<td>Resources Available through the Maple Help System</td>
<td>40</td>
</tr>
<tr>
<td>Quick Reference Card</td>
<td>41</td>
</tr>
<tr>
<td>Website Resources</td>
<td>41</td>
</tr>
<tr>
<td>2 Document Mode</td>
<td>43</td>
</tr>
<tr>
<td>2.1 In This Chapter</td>
<td>43</td>
</tr>
<tr>
<td>2.2 Introduction</td>
<td>43</td>
</tr>
<tr>
<td>2.3 Entering Expressions</td>
<td>44</td>
</tr>
<tr>
<td>Example 1 - Enter a Partial Derivative</td>
<td>44</td>
</tr>
<tr>
<td>Example 2 - Define a Mathematical Function</td>
<td>46</td>
</tr>
<tr>
<td>2.4 Evaluating Expressions</td>
<td>46</td>
</tr>
<tr>
<td>2.5 Editing Expressions and Updating Output</td>
<td>47</td>
</tr>
<tr>
<td>2.6 Performing Computations</td>
<td>48</td>
</tr>
<tr>
<td>Computing with Palettes</td>
<td>48</td>
</tr>
<tr>
<td>Computing with the Context Panel</td>
<td>48</td>
</tr>
<tr>
<td>Assistants and Tutors</td>
<td>53</td>
</tr>
<tr>
<td>3 Worksheet Mode</td>
<td>55</td>
</tr>
</tbody>
</table>
5.4 Calculus ................................................................. 128
   Limits ........................................................................ 128
   Differentiation ...................................................... 130
   Series ...................................................................... 133
   Integration .............................................................. 134
   Calculus Packages ............................................... 136
   Differential Equations ............................................. 137
5.5 Optimization .......................................................... 137
   Point-and-Click Interface ....................................... 138
   Large Optimization Problems ............................... 139
   MPS(X) File Support .............................................. 140
   Optimization Package Commands ......................... 140
5.6 Statistics ............................................................... 141
   Probability Distributions and Random Variables ....... 141
   Statistical Computations ....................................... 142
   Plotting ................................................................. 143
   Student Statistics Package .................................... 145
   Additional Information ........................................... 145
5.7 Teaching and Learning with Maple ......................... 145
   Student Packages and Tutors ............................... 147
   Calculus Problem Solving Examples ...................... 151
5.8 Clickable Math™ ..................................................... 157
   Smart Popups ......................................................... 157
   Drag-to-Solve ......................................................... 157
   Examples ............................................................... 158
6 Plots and Animations .................................................. 183
6.1 In This Chapter ...................................................... 183
6.2 Creating Plots ........................................................ 183
   Interactive Plot Builder ....................................... 184
   Context Panel ........................................................ 189
   The plot and plot3d Commands ............................ 189
   The plots Package ................................................ 197
   Multiple Plots in the Same Plot Region ..................... 201
6.3 Customizing Plots ................................................. 204
   Interactive Plot Builder Options ........................... 204
   Context Panel Options .......................................... 205
   The plot and plot3d Options .................................... 208
6.4 Analyzing Plots ....................................................... 210
   Point Probe, Rotate, Pan, and Zoom Tools ............... 210
6.5 Representing Data .................................................. 211
6.6 Creating Animations .............................................. 211
   Interactive Plot Builder ....................................... 211
   The plots[animate] Command .............................. 212
   The plot3d(...,viewpoint) Option ......................... 214
6.7 Playing Animations ................................................ 216
   Animation Context Bar ......................................... 216
6.8 Customizing Animations ....................................... 217
   Interactive Plot Builder Animation Options .......... 217
   Context Panel Options .......................................... 217
   The animate Command Options ............................ 218
6.9 Exporting ............................................................. 219
7 Creating Mathematical Documents ......................... 221
7.1 In This Chapter ..................................................... 221
7.2 Document Formatting ............................................ 222
Copy and Paste ........................................................................................................................ 222
Quick Character Formatting ..................................................................................................... 223
Quick Paragraph Formatting ................................................................................................. 225
Character and Paragraph Styles ............................................................................................ 226
Sections ................................................................................................................................. 231
Headers and Footers ............................................................................................................. 233
Show or Hide Worksheet Content ....................................................................................... 233
Indentation and the Tab Key .............................................................................................. 234

7.3 Commands in Documents .............................................................................................. 235
Document Blocks .................................................................................................................. 235
Typesetting .......................................................................................................................... 237
Auto-Execute ....................................................................................................................... 237

7.4 Tables ............................................................................................................................. 239
Creating a Table .................................................................................................................... 239
Cell Contents ........................................................................................................................ 239
Navigating Table Cells ......................................................................................................... 239
Modifying the Structural Layout of a Table ........................................................................ 240
Modifying the Physical Dimensions of a Table ................................................................. 242
Modifying the Appearance of a Table ................................................................................ 242
Printing Options ................................................................................................................. 245
Execution Order Dependency ............................................................................................. 245
Editable Tables .................................................................................................................... 246
Additional Examples ............................................................................................................. 246

7.5 Canvas ............................................................................................................................ 248
Insert a Canvas ..................................................................................................................... 249
Drawing ................................................................................................................................. 249
Canvas Style ........................................................................................................................ 250
Inserting Images .................................................................................................................. 251

7.6 Hyperlinks ...................................................................................................................... 252
Inserting a Hyperlink in a Document .................................................................................. 252
Bookmarks ............................................................................................................................ 255

7.7 Embedded Components ................................................................................................. 257
Adding Graphical Interface Components ........................................................................... 257
Task Template with Embedded Components ....................................................................... 258

7.8 Spell Checking ................................................................................................................ 259
How to Use the Spellcheck Utility ...................................................................................... 260
Selecting a Suggestion .......................................................................................................... 260
User Dictionary ..................................................................................................................... 260

8 Maple Expressions ............................................................................................................ 263
8.1 In This Chapter ................................................................................................................ 263
8.2 Creating and Using Data Structures .............................................................................. 263
Expression Sequences ......................................................................................................... 263
Sets ...................................................................................................................................... 264
Lists ..................................................................................................................................... 264
Arrays ................................................................................................................................. 265
Tables ................................................................................................................................. 267
Matrices and Vectors .......................................................................................................... 267
Functional Operators ........................................................................................................ 268
Strings ................................................................................................................................. 271

8.3 Working with Maple Expressions ................................................................................... 272
Low-Level Operations ......................................................................................................... 272
Manipulating Expressions ................................................................................................. 276
Evaluating Expressions ....................................................................................................... 279

9 Basic Programming .......................................................................................................... 289
### 9.1 In This Chapter

- Flow Control ........................................................................................................... 289

### 9.2 Flow Control

- Conditional Execution (if Statement) ................................................................. 289
- Repetition (for Statement) .................................................................................. 292

### 9.3 Iterative Commands

- Creating a Sequence ......................................................................................... 297
- Adding and Multiplying Expressions ............................................................... 297
- Selecting Expression Operands ....................................................................... 298
- Mapping a Command over a Set or List ............................................................ 299
- Mapping a Binary Command over Two Lists or Vectors ................................. 299
- Additional Information ...................................................................................... 299

### 9.4 Procedures

- Defining and Running Simple Procedures ..................................................... 300
- Procedures with Inputs .................................................................................... 300
- Procedure Return Values ................................................................................ 300
- Displaying Procedure Definitions .................................................................. 301
- Displaying Maple Library Procedure Definitions ........................................... 301
- Modules ........................................................................................................... 302
- Objects ............................................................................................................ 302

### 9.5 Programming in Documents

- Code Edit Region .............................................................................................. 302
- Startup Code ..................................................................................................... 303

### 9.6 Additional Information

- Additional Information ...................................................................................... 299

### 10 Embedded Components and Maplets

- In This Chapter .................................................................................................. 305

### 10.1 In This Chapter

- Using Embedded Components ......................................................................... 305
  - Interacting ....................................................................................................... 305
  - Printing and Exporting a Document with Embedded Components .............. 308

### 10.3 Creating Embedded Components

- Inserting Components ...................................................................................... 308
  - Editing Component Properties: General Process ......................................... 309
  - Removing Graphical Interface Components .................................................. 309
  - Integrating Components into a Document ....................................................... 309
  - Example 2 - Creating Embedded Components ............................................. 311

### 10.4 Using Maplets

- Maplet File ....................................................................................................... 314
- Maple Document ............................................................................................... 315

### 10.5 Authoring Maplets

- Simple Maplet .................................................................................................. 315
- Maplet Builder .................................................................................................. 316
- Maplets Package .............................................................................................. 319
- Saving ............................................................................................................... 320

### 11 Input, Output, and Interacting with Other Products

- In This Chapter .................................................................................................. 321

### 11.1 In This Chapter

- Writing to Files ................................................................................................. 321
  - Saving Data to a File ...................................................................................... 321
  - Saving Expressions to a File ......................................................................... 322
  - Saving Data as Part of a Workbook ............................................................... 323

### 11.3 Reading from Files

- Reading Data from a File ................................................................................ 323
- Reading Expressions from a File ..................................................................... 324
- Reading Data From Workbook Attachments .................................................. 325

### 11.4 Exporting to Other Formats

- Exporting Documents ....................................................................................... 325
MapleNet ........................................................................................................................................ 327
11.5 Connectivity ......................................................................................................................... 327
   Translating Maple Code To Other Programming Languages ............................................... 327
   Accessing External Products from Maple .............................................................................. 327
   Accessing Maple from External Products ............................................................................. 328
   Sharing and Storing Maple Content ...................................................................................... 329
Index ............................................................................................................................................. 331
List of Figures

Figure 1.1: The Maple Environment ................................................................. 2
Figure 1.2: Text and Math Buttons on the Toolbar ................................................ 14
Figure 1.3: Accessing the Assistants from the Tools Menu ..................................... 24
Figure 1.4: Accessing Tutors from the Tools Menu ............................................... 25
Figure 1.5: Calculus - Single Variable → Differentiation Methods Tutor .................. 26
Figure 1.6: Click the expression to see applicable operations in the context panel ............ 27
Figure 1.7: Click the plot to see plot options in the context panel ............................... 27
Figure 1.8: Browse Tasks Dialog ........................................................................ 28
Figure 1.9: Equation Label ................................................................................. 34
Figure 1.10: Inserting an Equation Label .............................................................. 35
Figure 1.11: Controlling Equation Label Format .................................................... 35
Figure 1.12: Label Reference ............................................................................... 35
Figure 1.13: Document Block Markers ................................................................. 36
Figure 1.14: Expanded Document Block ............................................................... 36
Figure 1.15: Sample Help Page ............................................................................. 38
Figure 2.1: Context Panel .................................................................................... 49
Figure 2.2: Approximating the Value of a Fraction ................................................. 51
Figure 2.3: Finding the Approximate Solution to an Equation ................................. 52
Figure 2.4: Units Palette ...................................................................................... 52
Figure 3.1: Calculus Palette ................................................................................ 62
Figure 3.2: Integer Context Panel ........................................................................ 63
Figure 3.3: ODE Analyzer Assistant ..................................................................... 64
Figure 3.4: Task Browser .................................................................................... 65
Figure 3.5: Insert Label Dialog ............................................................................ 70
Figure 3.6: Format Labels Dialog: Adding a Prefix ............................................... 71
Figure 4.1: Context Panel for an Integer ............................................................... 77
Figure 4.2: Context Panel for an Equation ............................................................ 81
Figure 4.3: ODE Analyzer Assistant ................................................................. 88
Figure 4.4: ODE Analyzer Assistant: Solve Numerically Dialog .......................... 89
Figure 4.5: ODE Analyzer Assistant: Solve Symbolically Dialog ......................... 90
Figure 4.6: Units Converter Assistant ................................................................. 94
Figure 4.7: Units Palette ..................................................................................... 95
Figure 5.1: Sorting a Polynomial Using the Context Panel ..................................... 113
Figure 5.2: Matrix Palette .................................................................................. 117
Figure 5.3: Matrix Palette: Choosing the Size ...................................................... 117
Figure 5.4: Insert Matrix or Insert Vector ............................................................ 118
Figure 5.5: Matrix Browser ............................................................................... 120
Figure 5.6: Computing the Infinity Norm of a Matrix ........................................... 126
Figure 5.7: Directional Derivative Tutor .............................................................. 132
Figure 5.8: Optimization Assistant ................................................................. 138
Figure 5.9: Optimization Assistant Plotter Window ............................................. 139
Figure 5.10: Calculus 1 Derivatives Tutor ......................................................... 147
Figure 5.11: Calculus 1 Differentiation Methods Tutor ........................................ 148
Figure 5.12: Multivariate Calculus Gradient Tutor .............................................. 149
Figure 5.13: Multivariate Calculus Gradient Tutor Showing x-y Plane .................. 149
Figure 5.14: Flowchart of solving a problem ...................................................... 152
Figure 5.15: Volume of Revolution Tutor .......................................................... 154
Figure 5.16: Inserted Task Template ................................................................. 155
Figure 5.17: Example Worksheet ....................................................................... 156
Figure 6.1: Plot an Expression Using the Context Panel ....................................... 189
Figure 7.1: Select Color Dialog ......................................................................... 223
Figure 7.2: Character Style Dialog ................................................................. 224
Figure 7.3: Paragraph Style Dialog ............................................................... 225
Figure 7.4: Style Management Dialog ............................................................ 226
Figure 7.5: Defining a Character Style ......................................................... 228
Figure 7.6: Defining a Paragraph Style ....................................................... 231
Figure 7.7: Style Set Management Dialog ................................................... 231
Figure 7.8: Header and Footer Dialog - Custom Header ............................... 233
Figure 7.9: Show Contents Dialog ............................................................... 234
Figure 7.10: Working with Document Blocks .............................................. 235
Figure 7.11: Delete Table Contents Verification Dialog ................................ 241
Figure 7.12: Table Paste Mode Selection Dialog ........................................ 241
Figure 7.13: Two Cells .................................................................................. 242
Figure 7.14: Merged Cells ............................................................................ 242
Figure 7.15: Drawing Tools and Canvas ...................................................... 249
Figure 7.16: Drawing Outline Color Icon .................................................... 250
Figure 7.17: Drawing Properties Canvas Icon - Change the Gridline Color 251
Figure 7.18: Hyperlink Properties Dialog ................................................... 252
Figure 7.19: Bookmark Indicator ................................................................. 255
Figure 7.20: Create Bookmark Dialog ......................................................... 256
Figure 7.21: Components Palette ............................................................... 258
Figure 7.22: Interactive Application Task Template ..................................... 259
Figure 7.23: Spellcheck Dialog ................................................................. 260
Figure 8.1: Function Definition Palette Items ............................................. 268
Figure 8.2: Evaluate at a Point ................................................................. 280
Figure 9.1: Code Edit Region ...................................................................... 302
Figure 9.2: Collapsed Code Edit Region .................................................... 303
Figure 9.3: Startup Code Editor ................................................................. 303
Figure 10.1: Components Palette ............................................................. 309
Figure 10.2: Label Properties Dialog ......................................................... 310
Figure 10.3: Slider Properties Dialog ......................................................... 310
Figure 10.4: The Inserted Components ....................................................... 312
Figure 10.5: DialComponent Action Code Editor ...................................... 313
Figure 10.6: A Simple Maplet ................................................................. 315
Figure 10.7: Maplet Builder Interface ......................................................... 316
Figure 10.8: Image of the Maplet ............................................................... 317
Figure 10.9: Body Elements Used to Define This Maplet ......................... 317
Figure 11.1: Import Data Assistant ............................................................ 323
List of Tables

Table 1.1: Common Keystrokes for Entering Symbols and Formats .......................................................... 5
Table 1.2: Maple Toolbar Options ............................................................................................................. 7
Table 1.3: Context Bar Tools .................................................................................................................... 9
Table 1.4: Context Selector Options ........................................................................................................ 9
Table 1.5: Text Mode vs. Math Mode ....................................................................................................... 14
Table 1.6: Palette Categories ................................................................................................................... 16
Table 1.7: Managing Palettes .................................................................................................................. 18
Table 1.8: Complex Numbers using I ...................................................................................................... 22
Table 1.9: Complex Numbers using i ...................................................................................................... 22
Table 1.10: Help Page Icons .................................................................................................................. 39
Table 3.1: Top Commands ...................................................................................................................... 59
Table 3.2: Top Packages .......................................................................................................................... 60
Table 4.1: Select Integer Commands ..................................................................................................... 77
Table 4.2: Modular Arithmetic Operators ............................................................................................... 79
Table 4.3: Overview of Solution Methods for Important Equation Types ............................................... 80
Table 4.4: Sample Dimensions .............................................................................................................. 93
Table 4.5: Scientific Constants .............................................................................................................. 98
Table 4.6: Restricting to Real Numbers ................................................................................................. 104
Table 5.1: Polynomial Arithmetic Operators ......................................................................................... 110
Table 5.2: Polynomial Coefficient and Degree Commands ................................................................... 114
Table 5.3: Select Other Polynomial Commands .................................................................................... 115
Table 5.4: Additional Polynomial Help ................................................................................................. 115
Table 5.5: Matrix and Vector Arithmetic Operators ............................................................................... 124
Table 5.6: Select Matrix and Vector Operators ..................................................................................... 125
Table 5.7: Select LinearAlgebra Package Commands ............................................................................ 127
Table 5.8: Limits ..................................................................................................................................... 129
Table 5.9: Optimization Package Commands ........................................................................................ 140
Table 5.10: Student and Instructor Resources ....................................................................................... 146
Table 6.1: The plot and plot3d Commands ............................................................................................. 190
Table 6.2: Common Plot Options ......................................................................................................... 208
Table 6.3: Plot Context Bar Analysis Options ....................................................................................... 210
Table 6.4: The animate Command ........................................................................................................ 212
Table 6.5: Animation Options ............................................................................................................... 216
Table 9.1: Default Clause Values .......................................................................................................... 292
Table 9.2: Iterative Commands .............................................................................................................. 297
Table 9.3: The seq Command ................................................................................................................ 297
Table 9.4: The add and mul Commands ............................................................................................... 298
Table 9.5: The select, remove, and selectremove Commands ............................................................... 298
Table 9.6: The map Command ............................................................................................................... 299
Table 9.7: The zip Command ............................................................................................................... 299
Table 10.1: Embedded Component Descriptions .................................................................................... 305
Table 11.1: Summary of Content Translation When Exporting to Different Formats .......................... 326
Preface

Maple Software

Maple™ software is a powerful system that you can use to solve mathematical problems from simple to complex. You can also create professional quality documents, presentations, and custom interactive computational tools in the Maple environment.

You can access the power of the Maple computational engine through a variety of interfaces.

<table>
<thead>
<tr>
<th>Interface</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard (default)</td>
<td>A full-featured graphical user interface that helps you create electronic documents to show all your calculations, assumptions, and any margin of error in your results. You can also hide the computations to allow your reader to focus on the problem setup and final results. The advanced formatting features let you create the customized document you need. Because the documents are live, you can edit the parameters and, with the click of a button, compute the new results. The Standard interface has two modes: Document mode and Worksheet mode.</td>
</tr>
<tr>
<td>Command-line version</td>
<td>A command-line interface for solving very large complex problems or batch processing with scripts. No graphical user interface features are available.</td>
</tr>
<tr>
<td>Maplet™ Applications</td>
<td>Graphical user interfaces containing windows, textbox regions, and other visual interfaces, which gives you point-and-click access to the power of Maple. You can perform calculations and plot functions without using the worksheet.</td>
</tr>
</tbody>
</table>

This manual describes how to use the Standard interface. As mentioned, the Standard interface offers two modes: Document mode and Worksheet mode. Using either mode, you can create high quality interactive mathematical documents. Each mode offers the same features and functionality, the only difference is the default input region of each mode.

Shortcut Keys by Platform

This manual will frequently refer to shortcut keys and command completion when entering expressions. The keyboard keys used to invoke these features differ based on your operating system.

The keystrokes given in this document are for Windows. There will be differences for other platforms. If you are using a different platform, see Shortcut Keys.

Command Completion

- Esc, Macintosh, Windows, and Linux
- Ctrl + Space, Windows
- Ctrl + Shift + Space, Linux

Begin entering a command in a Maple document. Press the Esc key. Alternatively, use the platform-specific keys. For Windows, press and hold the Ctrl key and then press the Space bar.

For more information on Command Completion, see Command Completion (page 33).

In This Manual

This manual provides an introduction to the following Maple features:

- Ease-of-use when entering and solving problems
- Point-and-click interaction with various interfaces to help you solve problems quickly
- Maple commands and standard math notation
• Clickable Math™
• The help system
• Online resources
• Performing computations
• Creating plots and animations
• The Maple programming language
• Using and creating custom Maplet applications
• File input and output, and using Maple with third party products
• Data structures

For a complete list of manuals, study guides, toolboxes, and other resources, visit the Maplesoft website at http://www.maplesoft.com

**Audience**

The information in this manual is intended for first-time Maple users and users looking for a little more information.

**Conventions**

This manual uses the following typographical conventions.

• **bold** font - Maple command, package name, option name, dialog, menu, or text field
• *italics* - new or important concept
• **Note** - additional information relevant to the section
• **Important** - information that must be read and followed

**Customer Feedback**

Maplesoft welcomes your feedback. For suggestions and comments related to this and other manuals, contact support@maplesoft.com.
1 Getting Started

Don't worry about your difficulties in Mathematics. I can assure you mine are still greater.

~Albert Einstein

Mathematics touches us every day—from the simple chore of calculating the total cost of our purchases to the complex calculations used to construct the bridges we travel.

To harness the power of mathematics, Maplesoft provides a tool in an accessible and complete form. That tool is Maple.

1.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Introduction to Maple (page 1)</strong> - The main features of Maple's Standard Interface</td>
<td>- Starting the Standard Document Interface</td>
</tr>
<tr>
<td></td>
<td>- Entering commands and mathematical expressions</td>
</tr>
<tr>
<td></td>
<td>- Toolbars</td>
</tr>
<tr>
<td></td>
<td>- Context Panel</td>
</tr>
<tr>
<td></td>
<td>- Copy and drag keys</td>
</tr>
<tr>
<td></td>
<td>- Saving Maple documents</td>
</tr>
<tr>
<td><strong>Entering Expressions (page 14)</strong> - Methods of entering expressions in 1-D and 2-D Math</td>
<td>- Execution groups</td>
</tr>
<tr>
<td></td>
<td>- Math Mode and Text Mode</td>
</tr>
<tr>
<td></td>
<td>- Palettes</td>
</tr>
<tr>
<td></td>
<td>- Symbol names</td>
</tr>
<tr>
<td></td>
<td>- Toolbar icons</td>
</tr>
<tr>
<td><strong>Point-and-Click Interaction (page 24)</strong> - An introduction to the point-and-click features in Maple</td>
<td>- Assistants</td>
</tr>
<tr>
<td></td>
<td>- Tutors</td>
</tr>
<tr>
<td></td>
<td>- Context Panel</td>
</tr>
<tr>
<td></td>
<td>- Task Templates</td>
</tr>
<tr>
<td></td>
<td>- Exploration Assistant</td>
</tr>
<tr>
<td><strong>Commands (page 31)</strong> - An introduction to the commands of the Maple language</td>
<td>- Using commands from the Maple library</td>
</tr>
<tr>
<td></td>
<td>- Entering commands</td>
</tr>
<tr>
<td></td>
<td>- Document blocks</td>
</tr>
<tr>
<td><strong>The Maple Help System (page 37)</strong> - Accessing help on commands, packages, point-and-click features, and more</td>
<td>- How to access help for Maple features</td>
</tr>
<tr>
<td></td>
<td>- Interacting with help pages</td>
</tr>
<tr>
<td></td>
<td>- Viewing and interacting with examples</td>
</tr>
<tr>
<td><strong>Available Resources (page 40)</strong> - Both online and from within Maple</td>
<td>- New user resources, including tutorials and the Maple Portal</td>
</tr>
<tr>
<td></td>
<td>- Examples</td>
</tr>
<tr>
<td></td>
<td>- Maple website resources</td>
</tr>
</tbody>
</table>

1.2 Introduction to Maple

Working in Maple

With Maple, you can create powerful interactive documents. The Maple environment lets you start solving problems right away by entering expressions in 2-D Math and solving these expressions using point-and-click interfaces. You can combine text and math in the same line, add tables to organize the content of your work, or insert images and sketch
regions. You can visualize and animate problems in two and three dimensions, format text for academic papers or books, and insert hyperlinks to other Maple files, websites, or email addresses. You can embed and program graphical user interface components, as well as devise custom solutions using the Maple programming language.

Starting the Standard Document Interface

To start Maple on:

<table>
<thead>
<tr>
<th>Windows</th>
<th>From the Start menu, select All Programs → Maple 2023 → Maple 2023. Alternatively: Double-click the Maple 2023 desktop icon.</th>
</tr>
</thead>
</table>

Figure 1.1: The Maple Environment
1. From the Finder, select **Applications** and **Maple 2023**.
2. Double-click **Maple 2023**.

**Linux**

Enter the full path, for example, `/usr/local/maple/bin/xmaple`  
Alternatively:  
1. Add the Maple directory (for example, `/usr/local/maple/bin`) to your command search path.  
2. Enter `xmaple`.

When the first Maple session opens, a **Start Page** displays shortcuts to useful tasks and topics.

**To start a Maple session:**

- In the **Start Page**, select **New Document** or **New Worksheet**. A blank document displays.

  or

- From the **File** menu, select **New**, and then either **Document Mode** or **Worksheet Mode**. A blank document displays.

You can opt to start Maple with a blank document instead of the start page. You can also replace the default start page with a custom start page. For instructions, refer to the **startpage** help page.

To invoke the Start Page at any time, click the home button (/swagger) on the worksheet toolbar.

**Document and Worksheet Modes**

Maple offers two modes, **Document Mode** and **Worksheet Mode**. Using either mode, you can create high quality interactive mathematical documents. Each mode offers the same features and functionality; the only difference is the default input region of each mode.

**Document Mode**

Document mode uses **Document Blocks** as the default input region to hide Maple syntax. A Document Block region is indicated by two triangles located in the vertical Markers column along the left pane of the Maple Document. If the Markers column is not visible, open the **View** menu and select **Markers**. This allows you to focus on the problem instead of the commands used to solve the problem. For example, when using the context-sensitive operations from the Context Panel on Maple input in Document mode (invoked by moving your mouse cursor over your input expression, then selecting the appropriate operation from the displayed context panel), input and output are connected using an arrow or equal sign with self-documenting text indicating the calculation that had taken place. The command used to solve this expression is hidden.

\[ x^2 + 7x + 10 \rightarrow \text{solve} \rightarrow \{x = -2\}, \{x = -5\} \]

To create a new document, select **File** → **New** → **Document Mode**.

**Worksheet Mode**

Worksheet mode uses a Maple prompt as the default input region. The Maple input prompt is a red angle bracket, `>`.

When using context-sensitive operations on input in Worksheet mode, all commands are displayed.

\[ > \text{solve}(x^2 + 7x + 10 = 0) \]

\[-2, -5\]
To create a new worksheet, select File → New → Worksheet Mode.

**Full Flexibility in Either Mode**

Regardless of which mode you begin working in, you have the opportunity to use both document blocks and command prompts.

For example, you can hide commands in Worksheet Mode by adding a document block from the Edit menu, Edit → Document Blocks → Create Document Block (see Document Blocks (page 35)), or you can show commands in Document mode by adding a Maple prompt from the Insert menu, Insert → Execution Group → Before / After Cursor (see Input Prompt (page 56)).

This chapter discusses features common to both modes. Specific aspects of Document mode are explained in Document Mode (page 43), and aspects of Worksheet mode are explained in Worksheet Mode (page 55).

**The Maple Workbook**

The Maple Workbook acts as a container that lets you collect Maple worksheets, library archives and language files, data (such as images or spreadsheets), and other items into a single file, stored in the .maple file format. This lets you better organize your Maple-based projects. For more information, refer to the WorkbookOverview help page.

Navigation of Workbook files is accomplished through the workbook Navigator palette, available in the Workbook tab. For more information, refer to The Workbook Navigator help page.

**Entering 2-D Math**

In documents, the default format for entering mathematical expressions is 2-D Math. This results in mathematical expressions that are equivalent to the quality of math found in textbooks. Entering 2-D Math in Maple is done using common key strokes or palette items. For more information on palettes, see Palettes (page 15). An example of entering an expression using common key strokes is presented in the following section. An example of entering an expression using palette items is presented in Example 3 - Enter an Expression Using Palettes (page 20).

**Common Operations**

Entering mathematical expressions, such as \[ \frac{35}{99} + \frac{1}{9} \cdot x^2 + x \], and \[ x \cdot y \] is natural in 2-D Math.

**To enter a fraction starting with the numerator:**

1. Enter the numerator.
2. Press the forward slash (/) key.
3. Enter the denominator.
4. To leave the denominator, press the right arrow key.

**To enter a fraction starting with the denominator:**

1. Enter the denominator.
2. Press // (two forward slashes).
3. Enter the numerator.
4. To leave the numerator, press the right arrow key.
To enter a power:
1. Enter the base.
2. Press the caret (^) key.
3. Enter the exponent, which displays in math as a superscript.
4. To leave the exponent, press the right arrow key.

To enter a product:
1. Enter the first factor.
2. Press the asterisk (*) key, which displays in 2-D Math as a dot, ·.
3. Enter the second factor.

Implied Multiplication:
In general, the best practice is to enter a multiplication symbol (*) for multiplication in any calculation. In some cases, you can instead insert a space character between two quantities to multiply them. This is called implicit multiplication.

For example, in the expression \(-\frac{b + \sqrt{b^2 - 4ac}}{2a}\) a space is used for the multiplication 4*a*c and 2*a.

In the case of a number followed by a variable, Maple interprets the expression as meaning multiplication even without the presence of * or a space character.

However, it's easier to identify and correct mistakes in your formulas if you use the multiplication symbol (*) regularly.

Important: Maple interprets a sequence of letters, for example, \(xy\), as a single variable. To specify the product of two variables, you must insert a space character (or multiplication operator), for example, \(x \cdot y\) or \(x \cdot y\). For more information, refer to the 2DMathDetails help page.

Shortcuts for Entering Mathematical Expressions

Table 1.1: Common Keystrokes for Entering Symbols and Formats

<table>
<thead>
<tr>
<th>Symbol/Formats</th>
<th>Key</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>implicit multiplication</td>
<td>Space key</td>
<td>((x^2 - 7xy + 3y^2)xy)</td>
</tr>
<tr>
<td>explicit multiplication</td>
<td>Shift + *</td>
<td>2.3</td>
</tr>
<tr>
<td>fraction</td>
<td>(/) (forward slash)</td>
<td>(\frac{1}{4})</td>
</tr>
<tr>
<td>exponent (superscript)</td>
<td>Shift + ^</td>
<td>(x^2)</td>
</tr>
<tr>
<td>indexed subscript</td>
<td>Ctrl + Shift + _ (Command + Shift + _ in Mac)</td>
<td>(x_a)</td>
</tr>
<tr>
<td>literal subscript (subscripted variable name)</td>
<td>__ (two underscores)</td>
<td>(x_{\text{max}})</td>
</tr>
<tr>
<td>navigating expressions</td>
<td>Arrow keys</td>
<td></td>
</tr>
<tr>
<td>Symbol/Formats</td>
<td>Key</td>
<td>Example</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>----------------------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>command / symbol completion</td>
<td>Esc in Mac, Windows, and Linux</td>
<td>( a b )</td>
</tr>
<tr>
<td></td>
<td>Ctrl + Space in Windows</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ctrl + Shift + Space in Linux</td>
<td></td>
</tr>
<tr>
<td>square root</td>
<td>sqrt and then command completion</td>
<td>( \sqrt{25} )</td>
</tr>
<tr>
<td>exponential function</td>
<td>exp and then command completion</td>
<td>( e^x )</td>
</tr>
<tr>
<td>enter / exit 2-D Math</td>
<td>F5 key</td>
<td>( \frac{1}{4} ) versus ( 1/4 )</td>
</tr>
</tbody>
</table>

1 required for products of numbers

2 use the right arrow key to leave a denominator, numerator, superscript, or subscript region

3 for more information, see Command Completion (page 33).

For a complete list of shortcut keys, refer to the 2-D Math Shortcut Keys and Hints help page. To access this help page in the Maple software, in Math mode enter ?MathShortcuts and then press Enter. For information on the Maple Help System, see The Maple Help System (page 37).

Example 1 - Enter and Evaluate an Expression Using Keystrokes

Review the following example:

\[ \frac{x^2 + y^2}{2} \]

In this example, you will enter \( \frac{x^2 + y^2}{2} \) and evaluate the expression.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>To enter the expression:</strong></td>
<td></td>
</tr>
<tr>
<td>1. Enter ( x ).</td>
<td>( x )</td>
</tr>
<tr>
<td>2. Press Shift + ^. The cursor moves to the superscript position.</td>
<td>( x^2 )</td>
</tr>
<tr>
<td>3. Enter 2.</td>
<td>( x^2 )</td>
</tr>
<tr>
<td>4. Press the right arrow key. The cursor moves right and out of the superscript position.</td>
<td>( x^2 )</td>
</tr>
<tr>
<td>5. Enter the + symbol.</td>
<td>( \frac{x^2 + y^2}{2} )</td>
</tr>
<tr>
<td>6. Enter ( y ).</td>
<td>( x^2 + y^2 )</td>
</tr>
<tr>
<td>7. Press Shift + ^ to move to the superscript position.</td>
<td>( x^2 + y^2 )</td>
</tr>
<tr>
<td>8. Enter 2 and press the right arrow key.</td>
<td>( x^2 + y^2 )</td>
</tr>
<tr>
<td>9. With the mouse, select the expression that will be the numerator of the fraction.</td>
<td>( \frac{x^2 + y^2}{2} )</td>
</tr>
</tbody>
</table>
10. Enter the / symbol. The cursor moves to the denominator, with the entire expression in the numerator.

\[
\frac{x^2 + y^2}{1}
\]

11. Enter 2.

\[
\frac{x^2 + y^2}{2}
\]

12. Press the right arrow key to move right and out of the denominator position.

\[
\frac{x^2 + y^2}{2}
\]

To evaluate the expression and display the result inline:

13. Press Ctrl + = (Command + = in Mac).

\[
\frac{x^2 + y^2}{2} = \frac{x^2}{2} + \frac{y^2}{2}
\]

To execute 2-D Math, you can use any of the following methods.

- Pressing Ctrl + = (Command + = in Mac). That is, press and hold the Ctrl (or Command) key and then press the equal sign (=) key. This evaluates and displays results inline.
- Pressing the Enter key. This evaluates and displays results on the next line and centered.
- Select the input and from the context panel, select Evaluate and Display Inline. See The Context Panel (page 27) for more details.
- Using the Evaluate menu items Evaluate and Evaluate and Display Inline.

**Toolbar Options**

The Maple toolbar offers easy access to a number of actions. See Table 1.2.

### Table 1.2: Maple Toolbar Options

<table>
<thead>
<tr>
<th>Basic Usage</th>
<th>Icon</th>
<th>Equivalent Menu Option or Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a new Maple document</td>
<td>![Icon]</td>
<td>From the File menu, select New and then Document Mode</td>
</tr>
<tr>
<td>Open an existing document or worksheet</td>
<td>![Icon]</td>
<td>From the File menu, select Open...</td>
</tr>
<tr>
<td>Save the active document or worksheet</td>
<td>![Icon]</td>
<td>From the File menu, select Save...</td>
</tr>
<tr>
<td>Print the active document or worksheet</td>
<td>![Icon]</td>
<td>From the File menu, select Print...</td>
</tr>
<tr>
<td>Print preview the active document or worksheet</td>
<td>![Icon]</td>
<td>From the File menu, select Print Preview...</td>
</tr>
<tr>
<td>Toggle the Print Layout Mode</td>
<td>![Icon]</td>
<td>From the File menu, select Print Layout Mode.</td>
</tr>
<tr>
<td>Cut the selection to the clipboard</td>
<td>![Icon]</td>
<td>From the Edit menu, select Cut</td>
</tr>
<tr>
<td>Copy the selection to the clipboard</td>
<td>![Icon]</td>
<td>From the Edit menu, select Copy</td>
</tr>
<tr>
<td>Paste the clipboard contents into the current document or worksheet</td>
<td>![Icon]</td>
<td>From the Edit menu, select Paste</td>
</tr>
<tr>
<td>Undo the last operation</td>
<td>![Icon]</td>
<td>From the Edit menu, select Undo</td>
</tr>
<tr>
<td>Redo the last operation</td>
<td>![Icon]</td>
<td>From the Edit menu, select Redo</td>
</tr>
<tr>
<td>Basic Usage</td>
<td>Icon</td>
<td>Equivalent Menu Option or Command</td>
</tr>
<tr>
<td>---------------------------------------------------------------------------</td>
<td>------</td>
<td>---------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Insert the Code Edit Region</td>
<td><img src="image1.png" alt="Icon" /></td>
<td>From the Insert menu, select <strong>Code Edit Region</strong></td>
</tr>
<tr>
<td>Inserts plain text after the current execution group.</td>
<td><img src="image2.png" alt="Icon" /></td>
<td>From the Insert menu, select <strong>Text</strong></td>
</tr>
<tr>
<td>Inserts Maple Input after the current execution group.</td>
<td><img src="image3.png" alt="Icon" /></td>
<td>From the Insert menu, select <strong>Execution Group</strong> and then <strong>After Cursor</strong></td>
</tr>
<tr>
<td>Encloses the selection in a document block. If nothing is selected, it</td>
<td><img src="image4.png" alt="Icon" /></td>
<td>From the Edit menu, select <strong>Document Blocks</strong> and then <strong>Create Document Block</strong></td>
</tr>
<tr>
<td>Encloses the selection in a subsection. For details, refer to <strong>Sections</strong></td>
<td><img src="image5.png" alt="Icon" /></td>
<td>From the Format menu, select <strong>Insert Section</strong></td>
</tr>
<tr>
<td>Remove one level of indentation enclosing the selection.</td>
<td><img src="image6.png" alt="Icon" /></td>
<td>From the Format menu, select <strong>Remove Section</strong></td>
</tr>
<tr>
<td>Move backward to previous document in the hyperlink history</td>
<td><img src="image7.png" alt="Icon" /></td>
<td></td>
</tr>
<tr>
<td>Open the start page</td>
<td><img src="image8.png" alt="Icon" /></td>
<td></td>
</tr>
<tr>
<td>Move forward to next document in the hyperlink history.</td>
<td><img src="image9.png" alt="Icon" /></td>
<td></td>
</tr>
<tr>
<td>Executes all commands in the worksheet or document</td>
<td><img src="image10.png" alt="Icon" /></td>
<td>From the Execute menu, select <strong>Execute Worksheet</strong></td>
</tr>
<tr>
<td>Executes a selected area.</td>
<td><img src="image11.png" alt="Icon" /></td>
<td>From the Evaluate menu, select <strong>Execute Selection</strong></td>
</tr>
<tr>
<td>Interrupt the current operation.</td>
<td><img src="image12.png" alt="Icon" /></td>
<td></td>
</tr>
<tr>
<td>Debug the current operation.</td>
<td><img src="image13.png" alt="Icon" /></td>
<td>Enter <strong>restart</strong></td>
</tr>
<tr>
<td>Clears Maple's internal memory. For details, refer to the <strong>restart</strong></td>
<td><img src="image14.png" alt="Icon" /></td>
<td>Enter <strong>restart</strong></td>
</tr>
<tr>
<td>Add and edit Maple code that is executed each time the worksheet is</td>
<td><img src="image15.png" alt="Icon" /></td>
<td>From the Edit menu, select <strong>Startup Code</strong></td>
</tr>
<tr>
<td>Adjusts the display size of document content. <strong>Note:</strong> Plots, images,</td>
<td><img src="image16.png" alt="Icon" /></td>
<td>From the View menu, select <strong>Zoom Factor</strong> and then a zoom size.</td>
</tr>
<tr>
<td>Reset zoom level.</td>
<td><img src="image17.png" alt="Icon" /></td>
<td>From the View menu, select <strong>Zoom Factor → Default</strong></td>
</tr>
<tr>
<td>Opens the Maple help system in a new window. For details, refer to</td>
<td><img src="image18.png" alt="Icon" /></td>
<td>From the Help menu, select <strong>Maple Help</strong></td>
</tr>
<tr>
<td>Search box provides quick access to the help system.</td>
<td><img src="image19.png" alt="Icon" /></td>
<td></td>
</tr>
<tr>
<td>Access to the MapleCloud on the web.</td>
<td><img src="image20.png" alt="Icon" /></td>
<td></td>
</tr>
</tbody>
</table>

The Context Bar shows icons that are relevant to the location of the cursor in the document. For example, place the cursor at an input region and the Text and Math tools are accessible. See Table 1.3 for a list of the tools available in each icon.
Table 1.3: Context Bar Tools

<table>
<thead>
<tr>
<th>Context Bar Tools</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Nonexecutable Math</td>
</tr>
<tr>
<td></td>
<td>Text</td>
</tr>
<tr>
<td>Math</td>
<td>Nonexecutable Math</td>
</tr>
<tr>
<td></td>
<td>Text</td>
</tr>
</tbody>
</table>

**Drawing tools**

**2-D Plot tools**

**3-D Plot tools**

**Animation tools**

Table 1.4: Context Selector Options

<table>
<thead>
<tr>
<th>Region</th>
<th>Available Tools</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input region</td>
<td>Text and Math icons</td>
</tr>
<tr>
<td>Plot region</td>
<td>Drawing and Plot icons</td>
</tr>
<tr>
<td>Animation region</td>
<td>Drawing, Plot, and Animation icons</td>
</tr>
<tr>
<td>Drawing Canvas and Image regions</td>
<td>Drawing icon</td>
</tr>
</tbody>
</table>

The Text and Math icons allow you to enter text and math in the same line by choosing the appropriate input style at each stage when entering the sentence, such as the following sentence:

The graph of $y = (x - 2)^2 - 1$ is a parabola that opens up with vertex at $(2, 1)$.

For a step-by-step example of creating a sentence with text and math, see Example 6 - Enter Text and 2-D Math in the Same Line Using Toolbar Icons (page 22).

The meaning of the Text and Math icons differs while at a Maple input prompt. The Math icon displays input as 2-D Math, whereas the Text icon displays Maple input. For details, refer to Math Mode vs. Text Mode (page 14).

```maple
> x^2/2;
> x^2/2;
```

To access the tools available in the Plot and Drawing icons, click a plot region. These tools allow you to manipulate the plot or draw shapes and enter text on the plot region. By clicking an animation region, you have the same features available for a plot region, in addition to tools for playing the animation in the Animation icon. For details on plots and animations, refer to Plots and Animations (page 183).

For the description of any icon, hover the mouse over the icon to display at tooltip.
The Context Panel and Copy & Drag

Context Panel

Maple dynamically generates a collection of applicable options when you select or hover your mouse over an object, expression, or region. The options are organized and collectively displayed in the context panel to the right-hand side of the Maple user interface. The options available in the context panel depend on the selected input region. For example, you can manipulate and graph expressions, enhance plots, format text, manage palettes, structure tables, and more. When using menu items from the context panel to perform an action on an expression, the input and output are connected with a self-documenting arrow or equal sign indicating the action that had taken place. For more information, see The Context Panel (page 27).

Copy & Drag

With Maple, you can drag input, output, or curves in a plot region into a new input region. This is done by highlighting the input or selecting the curve and dragging it with your mouse into a new input region. Dragging the highlighted region will cut or delete the original input. To prevent this, use the copy and drag feature.

- Ctrl + drag, Windows and Linux
- Command + drag, Mac

That is, highlight the region you want to copy. Press and hold the Ctrl key while you drag the input to the new region using the mouse. The analogous operation on Mac uses the Command key.

Example 2 - Solve and Plot an Equation Using Context Panel Options and Copy & Drag

Review the following example:

\[ 5x - 7 = 3x + 2 \]

In this example, you will enter the equation and then solve and plot the equation using the context panel and the copy & drag feature. This example will only refer to the keystrokes needed on a Windows operating system to invoke the context panel and the copy & drag feature. For your operating system, refer to section Shortcut Keys by Platform (page xiii) for the equivalent keystrokes.
To solve the equation:
1. Enter the equation.
2. Click the equation and select **Move to Left**.

**Input:**

```
5x - 7 = 3x + 2
```

**Result:**

```
5x - 7 = 3x + 2 \xrightarrow{\text{move to left}} 2x - 9 = 0
```

A brief description, "move to left" is displayed above the arrow that connects the input and output.

3. Right-click the output from the previous action, \(2x - 9 = 0\), and select **Solve → Isolate Expression for → x**.
Now that we have solved the equation, we can plot it. To do this, we will copy the equation $2x - 9 = 0$ to a new document block and use the context panel again.

4. From the **Edit** menu, select **Document Blocks** → **Create Document Block**.

5. To copy the expression $5x - 7 = 3x + 2$, highlight this expression from the previous line. Press and hold the **Ctrl** key and drag the expression to the new document block region.
To plot the expression:

6. From the context panel, select **Plot both sides**.

**Input:**

![Plot both sides](image)

**Result:**

\[ 5x - 7 = 3x + 2 \]

![Graph of the equation](image)

---

**Saving a Maple Document**

To save these examples you created, from the **File** menu, select **Save**. Maple documents are saved as `.mw` files.

**Saving a Maple Document as a Workbook**

To save these examples you created as part of a new Maple workbook, from the **Workbook** tab, click **Save As Workbook**. For more information about saving Maple content refer to the **worksheet, managing, saving** help page.
1.3 Entering Expressions

Execution Groups

An execution group is a grouping of Maple input with its corresponding Maple output. It is distinguished by a large square bracket, called a group boundary, at the left. An execution group may also contain any or all of the following: a plot, text, embedded components, and a drawing canvas.

Execution groups are the fundamental computation and documentation elements in the document. If you place the cursor in an input command and press the Enter or Return key, Maple executes all of the input commands in the current execution group.

Math Mode vs. Text Mode

The default mode of entry in Document or Worksheet mode is Math Mode, which displays input in 2-D Math. In Worksheet Mode or at a prompt, you can opt to use Maple Input (1-D Math). This is 1-D math input:

\[
\begin{align*}
> & \text{simplify(cos(alpha)^2+sin(alpha)^2);} \\
& 1 \\
> & a*\text{int(exp(sqrt(2)*x)),x}; \\
& \frac{a\sqrt{2}}{2} e^{\frac{\sqrt{2}}{2} x} \\
> & \text{limit(f(x),x=\text{infinity});} \\
& \lim_{x \to \infty} f(x) \\
> & \text{sum(a[k]*x^k, k=0..m)=product(b[j]*x^j, j=0..n);} \\
& \sum_{k=0}^{m} a_k x^k = \prod_{j=0}^{n} b_j x^j
\end{align*}
\]

In Document Mode, to enter input using Maple Input mode, insert a Maple prompt by clicking in the toolbar, and then click the Text button in the context bar. In Worksheet Mode, simply click the Text button. See Figure 1.2.

![Text and Math Buttons on the Toolbar](image)

Figure 1.2: Text and Math Buttons on the Toolbar

<table>
<thead>
<tr>
<th>Math Mode</th>
<th>Text Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maple's default setting. Executable standard math notation. This is also referred to as 2-D Math Input.</td>
<td>Executable Maple notation. This is referred to as 1-D Math Input or Maple Input.</td>
</tr>
<tr>
<td>[ \int x^2 + 2 x + 6 , dx ]</td>
<td>[ \text{int}(x^2+2*x+6, , x); ]</td>
</tr>
<tr>
<td>Access from the Insert → 2-D Math menu.</td>
<td>Access from the Insert → Maple Input menu.</td>
</tr>
<tr>
<td>When using 2-D Math, the Math mode icon is highlighted in the toolbar, Text None-executable Math Math.</td>
<td>When entering Maple Input or text in a text region, the Text mode icon is highlighted in the toolbar, Text None-executable Math Math.</td>
</tr>
</tbody>
</table>
### Math Mode

- In Document Mode (or a document block), input is entered in a document block with a slanted cursor, $\int f \, dx$.
- In Worksheet Mode, input is made at an input prompt with a slanted cursor, $\int f \, dx$.

### Text Mode

- In Document Mode (or a document block), text is entered with a vertical cursor, as plain text, `Enter some text`.
- In Worksheet Mode, input is made at an input prompt with a vertical cursor, $\int f \, dx$.

<table>
<thead>
<tr>
<th>Math Mode</th>
<th>Text Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>In Document Mode (or a document block), input is entered in a document block with a slanted cursor, $\int f , dx$.</td>
<td>In Document Mode (or a document block), text is entered with a vertical cursor, as plain text, <code>Enter some text</code>.</td>
</tr>
<tr>
<td>In Worksheet Mode, input is made at an input prompt with a slanted cursor, $\int f , dx$.</td>
<td>In Worksheet Mode, input is made at an input prompt with a vertical cursor, $\int f , dx$.</td>
</tr>
</tbody>
</table>

| To convert a 2-D Math expression to 1-D Math, click the expression, then from the context panel select Convert To → 1-D Math Input. | To convert a 1-D Math expression to 2-D Math, click the expression, then from the context panel select Convert To → 2-D Math Input. |

Palettes make entering expressions in familiar notation easier than entering foreign syntax and reduces the possibility of introducing typing errors.

Using palettes while in 1-D Math teaches you the related Maple command syntax.

---

If you prefer 1-D Math input in Worksheet mode, you can change the default math input notation.

**To change math input notation for a session or globally across all documents:**

1. From the **Tools** menu, select **Options**. The **Options Dialog** opens.
2. Click the **Display** tab.
3. In the **Input Display** drop-down list, select **Maple Notation**.
4. Click the **Apply to Session** or **Apply Globally** button.

This changes the default input math notation at the prompt ($\int$).

**Important:** The new input display becomes the default setting after pressing the **Enter** key.

### Palettes

Palettes are collections of related items that you can insert into a document by clicking or drag-and-dropping. The Maple environment provides access to over 30 palettes containing items such as symbols, layouts ($A^b$), mathematical operations ($\int_a^b f \, dx$), and much more.

By default, palettes are displayed in the left pane of the Maple environment when you launch Maple. If the palettes are not displayed,

1. From the **View** menu, select **Palettes**.
2. Select **Expand Dock**.
3. Right-click (Control-click, Mac) the palette dock. From the context menu, select **Show Palette**. Alternatively, from the main menu, select **View → Palettes → Show Palette**.

A list of potential palettes is displayed, with currently displayed palettes dimmed.

4. Select a palette.

Alternatively, select **View → Palettes → Show All Palettes**.

You can create a **Favorites** palette of the expressions and entities you use often by right-clicking (Control-click, Mac) the palette template you want to add and selecting **Add To Favorites Palette** from the context menu.
Table 1.6: Palette Categories

<table>
<thead>
<tr>
<th>Palette Category</th>
<th>Palette Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Alphabetical Palettes</strong></td>
<td>Greek $\beta$, Script $\mathcal{A}$, Fraktur $\mathfrak{U}$, Open Face $\mathbb{C}$, Cyrillic $\mathfrak{C}$, Diacritical Marks $\acute{\alpha}$, RomanExtended Upper Case $\AE$, RomanExtended Lower Case $\ae$.</td>
</tr>
<tr>
<td><strong>Mathematical Palettes</strong></td>
<td>Palettes for constructing expressions: Common Symbols, Relational $\geq$, Relational Round $\geq$, Operators $\div$, Large Operators $\int$, Negated $\neq$, Fenced $\langle$, Arrows $\downarrow$, Constants and Symbols $\infty$.</td>
</tr>
</tbody>
</table>

**Punctuation** - insert punctuation symbols, such as inserting the registered trademark and copyright symbols $\text{®}$ into text regions. **Miscellaneous** - insert miscellaneous math and other symbols outside the above categories. |
## 1.3 Entering Expressions

<table>
<thead>
<tr>
<th>Palette Category</th>
<th>Palette Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Expression Palettes</strong></td>
<td></td>
</tr>
<tr>
<td>Expression</td>
<td>construct expressions such as logarithms $\log(u)$</td>
</tr>
<tr>
<td>Matrix</td>
<td>enter the number of rows and columns required, designate type, such as zero-filled,</td>
</tr>
<tr>
<td></td>
<td>and designate shape, such as diagonal.</td>
</tr>
<tr>
<td>Layout</td>
<td>add math content that has specific layout, such as expressions with one or more</td>
</tr>
<tr>
<td></td>
<td>superscripts and subscripts $A^b$.</td>
</tr>
<tr>
<td>Calculus</td>
<td>construct expressions such as integrals $\int_a^b dx$.</td>
</tr>
<tr>
<td>Handwriting</td>
<td>an easy way to find a desired symbol.</td>
</tr>
<tr>
<td>Units</td>
<td>select a unit and insert into document, such as $[A]$ or $[kg]$.</td>
</tr>
<tr>
<td>Accents</td>
<td>insert decorated names, such as an $X$ with an arrow over it to denote a vector $\vec{A}$.</td>
</tr>
<tr>
<td>Trigonometric &amp; Hyperbolic</td>
<td>a palette for constructing expressions containing trigonometric and hyperbolic functions</td>
</tr>
<tr>
<td>Student Random Variables</td>
<td>a palette for constructing random variables based on distributions in the Student Statistics package</td>
</tr>
<tr>
<td>Group Constructors</td>
<td>a palette for constructing groups based on the Group Theory package</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Other Palettes</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Components</td>
<td>embed graphical interface components such as a button into your document or worksheet. Components can be programmed to perform an action when selected such as executing a command when a button is clicked.</td>
</tr>
<tr>
<td>Favorites</td>
<td>add templates that you use most often from other palettes. Variables - manage all of your assigned variables in your current Maple session.</td>
</tr>
</tbody>
</table>
### Palette Description

<table>
<thead>
<tr>
<th>Palette Category</th>
<th>Palette Description</th>
</tr>
</thead>
</table>
| Task Palettes    | Live Data Plots - templates for visual representation of your data.  
                  | eBook Metadata - markup tags for use when creating eBooks from Maple worksheets  
                  | Tasks - a palette where you can store tasks that you have created |

### Viewing and Arranging Palettes

By default, palettes display in palette dock in the left pane of the Maple window. To view and manage palettes and palette docks, see Table 1.7.

**Table 1.7: Managing Palettes**

**To view the palette dock:**
- From the View menu, select **Palettes**, and then **Expand Dock**. The dock is in the left pant of the window.
To add a palette:
1. Right-click the palette dock. Maple displays a context menu near the palette.
2. From the context menu, select Show Palette and then select the palette.

To expand or collapse a palette in the palette dock:
• Click the triangle at the left of the palette title.

To move a palette in the palette dock:
• Move the palette by clicking the title and dragging the palette to the new location.
Example 3 - Enter an Expression Using Palettes

Review the following example:

\[ \sum_{i=1}^{10} (7i^2 - 5i) = 2420 \]

In this example, we will enter \( \sum_{i=0}^{10} (7i^2 - 5i) \) and evaluate the expression.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Place the cursor in a new document block. In the Expression palette, click the summation template ( \sum_{i=k}^{n} ). Maple inserts the summation symbol with the range variable placeholder highlighted.</td>
<td>( \sum_{i=k}^{n} )</td>
</tr>
<tr>
<td>2. Enter ( i ) and then press Tab. The left endpoint placeholder is selected. Notice that the color of the range placeholder has changed to black. Each placeholder must have an assigned value before you execute the expression. The Tab key advances you through the placeholders of an inserted palette item.</td>
<td>( \sum_{i=k}^{n} )</td>
</tr>
<tr>
<td>3. Enter ( 1 ) and then press Tab. The right endpoint placeholder is selected.</td>
<td>( \sum_{i=1}^{10} )</td>
</tr>
<tr>
<td>4. Enter ( 10 ) and then press Tab. The expression placeholder is selected.</td>
<td>( \sum_{i=1}^{10} )</td>
</tr>
<tr>
<td>5. Enter ( (7i^2 - 5i) ). For instructions on entering this type of expression, see Example 1 - Enter and Evaluate an Expression Using Keystrokes (page 6).</td>
<td>( \sum_{i=1}^{10} (7i^2 - 5i) )</td>
</tr>
<tr>
<td>6. Press Ctrl+ (Command + for Mac) to evaluate the summation.</td>
<td>( \sum_{i=1}^{10} (7i^2 - 5i) = 2420 )</td>
</tr>
</tbody>
</table>

Favorites Palette

You can add to the Favorites palette any expressions that you use most often.

- To add an entry from another palette to the Favorites palette, simply drag the entry to the Favorites palette.
To add a custom expression, select the expression in the worksheet and select **Add Selection to Favorites Palette** from the Context Panel.

### Symbol Names

Each symbol has a name and some have aliases. By entering its name (or an alias) in Math mode, you can insert the symbol in your document. All common mathematical symbols, including all Greek characters, \( \pi \), and the square root symbol (\( \sqrt{\ } \)), are recognized by Maple.

**Note:** If you hover the mouse pointer over a palette item, a tooltip displays the symbol's name.

To insert a symbol, enter the first few characters of a symbol name using a keyword that is familiar to you and then press the completion shortcut key, **Esc** (see *Shortcut Keys by Platform* (page xiii)). Symbol completion works in the same way as command completion (see *Command Completion* (page 33)).

- If a unique symbol name matches the characters entered, Maple inserts the corresponding symbol.
- If multiple symbol names match the characters entered, Maple displays the completion list, which lists all matches, including commands. To select an item, click its name or symbol.

#### Example 4 - Square Root

To find the square root of 603729:

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In a new document block, enter ( \text{sqrt} ).</td>
<td>( \sqrt{\ } )</td>
</tr>
<tr>
<td>2. Press the symbol completion shortcut key, <strong>Esc</strong>. Maple displays a popup list of exact matches.</td>
<td>( \sqrt{\ } )</td>
</tr>
<tr>
<td>3. In the completion list, select ( \sqrt{\ } ). Maple inserts the symbol with the ( \times ) placeholder selected.</td>
<td>( \sqrt{603729} )</td>
</tr>
<tr>
<td>4. Enter 603729 into the placeholder.</td>
<td>( \sqrt{603729} = 777 )</td>
</tr>
<tr>
<td>5. Press <strong>Ctrl + =</strong> (<strong>Command + =</strong>, Mac).</td>
<td>( \sqrt{603729} = 777 )</td>
</tr>
</tbody>
</table>

#### Example 5 - Complex Numbers

In Maple, the default display for imaginary \( i \) is a capital \( I \). When you simply type the letter \( j \) in Math mode, it is in italics. This letter is just a variable, and is not the same as the imaginary unit \( \sqrt{-1} \), denoted by \( I \) or \( \mathbf{i} \) in Maple.

\[ \text{sum}(i, i = 1 .. 4) = 10 \]

Multiply two complex numbers, \(-0.123 + 0.745 \mathbf{i}\) and \(4.2 - \mathbf{i}\):

We will compute the result two ways, using \( I \) and then using \( \mathbf{i} \). The first way is the quickest to enter.
Table 1.8: Complex Numbers using I

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In a new document block, enter</td>
<td>$( -0.123 + 0.745 I ) \cdot (4.2 - I)$</td>
</tr>
<tr>
<td>Use * to enter multiplication between the two complex numbers.</td>
<td></td>
</tr>
<tr>
<td>2. Press Ctrl + = (Command + =, Mac) to evaluate the product.</td>
<td>$( -0.123 + 0.745 I ) \cdot (4.2 - I) = 0.2284 + 3.2520 I$</td>
</tr>
</tbody>
</table>

The next method, while not as quick to enter, displays the computation using lowercase i.

Table 1.9: Complex Numbers using i

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In a new document block, enter</td>
<td>$( -0.123 + 0.745 i )$</td>
</tr>
<tr>
<td>2. Press the symbol completion shortcut key, Esc.</td>
<td>$( -0.123 + 0.745 i )$</td>
</tr>
<tr>
<td>Maple displays a popup list of partial and exact matches, including symbols and commands.</td>
<td></td>
</tr>
<tr>
<td>3. Select the imaginary unit, [i] (imaginary)</td>
<td>$( -0.123 + 0.745 i )$</td>
</tr>
<tr>
<td>4. Close the parentheses, enter * (for multiplication),</td>
<td>$( -0.123 + 0.745 i ) \cdot (4.2 - i)$</td>
</tr>
<tr>
<td>and type the second expression in parentheses, using symbol completion for the second imaginary number.</td>
<td></td>
</tr>
<tr>
<td>5. Press Ctrl + = (Command + =, Mac) to evaluate the product.</td>
<td>$( -0.123 + 0.745 i ) \cdot (4.2 - i) = 0.2284 + 3.2520 I$</td>
</tr>
</tbody>
</table>

For more information on entering complex numbers, refer to the HowDoI/EnterAComplexNumber help page.

**Toolbar Icons**

In the introduction section, you learned about the toolbar icons and context toolbars available in Maple (see Toolbar Options (page 7)). The toolbar can be used to format your document, alter plots and animations, draw in a canvas, write in both Math and Text modes in one line and much more. The last of these is demonstrated in the next example.

**Example 6 - Enter Text and 2-D Math in the Same Line Using Toolbar Icons**

Enter the following sentence:

Evaluate

\[ \int_{1}^{5} \left( 3x^2 + 2\sqrt{x} + 3\sqrt[3]{x} \right) \, dx \] and write in simplest terms.
<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>To enter this sentence:</td>
<td></td>
</tr>
<tr>
<td>1. Select the Text icon and enter &quot;Evaluate &quot;.</td>
<td></td>
</tr>
<tr>
<td>2. Select the Nonexecutable Math icon.</td>
<td></td>
</tr>
<tr>
<td>3. From the Calculus palette, select the definite integration</td>
<td></td>
</tr>
<tr>
<td>template, $\int_{1}^{2} f , dx$. The expression is displayed with</td>
<td></td>
</tr>
<tr>
<td>the first placeholder highlighted.</td>
<td></td>
</tr>
<tr>
<td>4. With the first placeholder highlighted, enter 1, then press</td>
<td></td>
</tr>
<tr>
<td>Tab.</td>
<td></td>
</tr>
<tr>
<td>5. Enter 5 and press Tab to highlight the integrand region.</td>
<td></td>
</tr>
<tr>
<td>6. Enter $(3x^2$ and press the right arrow to leave the superscript</td>
<td></td>
</tr>
<tr>
<td>position.</td>
<td></td>
</tr>
<tr>
<td>7. Enter $+2$.</td>
<td></td>
</tr>
<tr>
<td>8. Press the Space bar for implicit multiplication. Enter sqrt and</td>
<td></td>
</tr>
<tr>
<td>press Esc to show the command completion options. Maple displays a</td>
<td></td>
</tr>
<tr>
<td>popup list of exact matches. Select the square root symbol, $\sqrt{x}$</td>
<td></td>
</tr>
<tr>
<td>Maple inserts the symbol with the x placeholder selected. (Alternatively, select the square root symbol from the Expression palette.)</td>
<td></td>
</tr>
<tr>
<td>9. Enter $x$, then press the right arrow to leave the square root</td>
<td></td>
</tr>
<tr>
<td>region.</td>
<td></td>
</tr>
<tr>
<td>10. Enter $+3$, and then press the Space bar.</td>
<td></td>
</tr>
<tr>
<td>11. Select the n-th root symbol from the Expression palette, $\sqrt[n]{x}$.</td>
<td></td>
</tr>
<tr>
<td>12. Enter 3, then press Tab.</td>
<td></td>
</tr>
<tr>
<td>13. Enter $x$, then press the right arrow to leave the root region.</td>
<td></td>
</tr>
<tr>
<td>14. Enter $)$, then press Tab.</td>
<td></td>
</tr>
<tr>
<td>15. Enter $x$ for the integration variable.</td>
<td></td>
</tr>
<tr>
<td>16. Put the cursor after the expression and click the Text icon in</td>
<td></td>
</tr>
<tr>
<td>the toolbar, then enter the rest of the sentence: &quot; and write in</td>
<td></td>
</tr>
<tr>
<td>simplest terms.&quot;</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** When an expression is intended for display purposes only, as in this example, it can be displayed in nonexecutable math. This is indicated by the gray background. For more information on executable and nonexecutable math, refer to the 2DMathDetails help page.
1.4 Point-and-Click Interaction

Maple contains many built-in features that allow you to solve problems quickly without having to know any commands.

**Assistants**

Maple offers a set of assistants in the form of graphical user interfaces to perform many tasks without the need to use any syntax.

Using the Tools → Assistants menu, you can access tools to help you accomplish various tasks. See Figure 1.3. In some cases, you can launch an assistant by entering an expression and selecting the assistant from the options in the Context Panel.

![Figure 1.3: Accessing the Assistants from the Tools Menu](image)

**Descriptions of Assistants**

The available assistants are described below. Some of the assistants are interfaces to package commands. For more information on package commands, see *Package Commands* (page 33).

- **CAD Link** - an interface to explore the properties of models from supported CAD applications (available on Microsoft Windows only).

- **Code Generation** - an interface to automatically transform Maple expressions and programs to other languages.

- **Data Set Search** - an interface for searching built-in and online data sources.

- **eBook Publisher** - an interface to the eBook Publisher tools.

- **Import Data** - an interface to read data from an external file into Maple.

- **Installer Builder** - an interface to the *InstallerBuilder* package in which you can create installers for your Maple toolboxes.

- **Library Browser** - an interface to manipulate the libraries in a specified directory.

- **Maplet Builder** - an interface to the *Maplets* package. The *Maplets* package contains commands for creating and displaying Maplet applications (point-and-click interfaces). Using the Maplet Builder, you can define the layout of a Maplet, drag-and-drop elements (visual and functional components of Maplets), set actions associated with elements, and directly run a Maplet application. The Maplet Builder is available in the Standard interface only.

- **Plot Builder** - an interface for creating two and three-dimensional plots, animations, and interactive plots.

- **Scientific Constants** - an interface to over 20 000 values of physical constants and properties of chemical elements. All of these constants come with the corresponding unit and, if applicable, with the uncertainty or error, that is, how precisely the value of this constant is known.
• **Special Functions** - an interface to the properties of over 200 special functions, including the Hypergeometric, Bessel, Mathieu, Heun and Legendre families of functions.

• **Thermophysical Properties Calculator** - Calculate state-dependent and independent thermophysical properties.

• **Units Converter** - an interface to convert between 500 units of measurement.

• **Worksheet Migration** - an interface to convert worksheets from Classic Maple (.mws files) to Standard Maple (.mw files).

**Tutors**

Maple provides over 50 interactive tutors and assistants to aid in the learning of:

- Basics
- Precalculus
- Calculus
- Multivariate Calculus
- Vector Calculus
- Complex Variables
- Differential Equations
- Linear Algebra
- Numerical Analysis
- Optimization
- Statistics

These tutors are easily accessible in the **Tools** menu by selecting **Tutors**. See Figure 1.4.

Figure 1.4: Accessing Tutors from the Tools Menu
Some of the tutors can also be accessed through the **Student** package. The Differential Equations tutor, **DE Plots**, is accessible through the **DEtools** package. For a definition of the term **package**, see **Package Commands** (page 33).

The **Student** package is a collection of subpackages designed to assist with the teaching and learning of standard undergraduate mathematics. The subpackages contain many commands for displaying functions, computations, and theorems in various ways, and include support for stepping through important computations.

The **interactive** commands help you explore concepts and solve problems using a point-and-click interface. These commands launch tutors that provide a graphical interface to some of the visualization and computation commands described above. See **Figure 1.5** for an example of one of the tutors.

![Figure 1.5: Calculus - Single Variable → Differentiation Methods Tutor](image)

The Practice Sheets Assistant, found under **Tools → Tutors → Basics**, lets you construct a practice sheet of math problems. It’s easy to interactively construct a randomized set of problems arithmetic, algebra, calculus, factorization and more. Students can then do the problems, check their solutions, and even generate another set of problems.

For more information on the tutors and related resources for mathematics education, see **Teaching and Learning with Maple** (page 145).

**Math Apps**

Maple provides Math Apps that offer interactive, entertaining ways to explore mathematical concepts, ranging from Precalculus to Physics to Economics. A guide to these demonstrations is accessible in the **Tools** menu by selecting **Math Apps**.
The Context Panel

The context panel is a dynamically generated list of tools and actions that are applicable for the region on which it is invoked. These tools and actions are further organized into menus. Use the context panel to perform calculations and manipulations on expressions without using Maple syntax. To display the context panel, select an object, expression, or region. Context panel options are available for many input regions, including:

- **expressions** to perform calculations, manipulations, or plotting
- **plot regions** to apply plot options and manipulate the plot
- **tables** to modify the table properties
- **text regions** to add annotations and format text

When performing calculations or manipulations on an expression, a self-documenting arrow or equal sign connects the input and output, indicating the action that took place. See Figures 1.8 and 1.9 for two examples of context-sensitive operations.

![Figure 1.7: Click the plot to see plot options in the context panel](image)

![Figure 1.6: Click the expression to see applicable operations in the context panel](image)

Task Templates

Task templates help you perform specific tasks in Maple, such as:

- performing a mathematical computation such as solving an equation symbolically or numerically, or determining the Taylor approximation of a function of one variable
- constructing a Maple object such as a function
- creating a document such as an application

Each task contains a description along with a collection of content that you can insert directly into your document. Content consists of 2-D mathematics, commands, embedded components (for example, buttons), and plots. You specify the parameters of your problem and then execute the commands in the document. See Figure 1.8 for an example of a Task Template.
To preview Maple tasks,

- From the **Tools** menu, select **Tasks**, and then **Browse**. The **Browse Tasks** dialog opens and displays the list of tasks.

The tasks are sorted by subject to help you quickly find the desired task. In the **Browse Tasks** dialog, you can view tasks without inserting them into your document.

### Inserting a Task into the Document

To insert a task into your document,

1. Select the **Insert into New Worksheet** check box to insert the task into a new document.
2. Click one of the insert buttons.
   - Click the **Insert Default Content** button. Maple inserts the default content. The default content level is set using the **Options** dialog. For instructions, refer to the **usingtasks** help page.
   - Click the **Insert Minimal Content** button. Maple inserts only the commands and embedded components, for example, a button to launch the related assistant or tutor.
   - Click the **Copy Task to Clipboard** button. Place the cursor where you want to insert the task, and then paste the task. Maple inserts the default content. Use this method to quickly insert a task multiple times.
**Note**: You can view the history of previously inserted tasks. From the **Tools** menu, select **Tasks**. Previously selected task names are displayed below the **Browse** menu item.

Before inserting a task, Maple checks whether the task variables have assigned values in your document. If any task variable is assigned, the **Task Variables** dialog opens to allow you to modify the names. Maple uses the edited variable names for all variable instances in the inserted task.

By default, the **Task Variables** dialog is displayed only if there is a naming conflict. You can set it to display every time you insert a task.

**To specify that the Task Variables dialog be displayed every time you insert a task:**
1. From the **Tools** menu, select **Options**.
2. Click the **Display** tab.
3. In the **Show task variables on insert** drop-down list, select **Always**.
4. Click **Apply to Session** or **Apply Globally**, as necessary.

**Updating Parameters and Executing the Commands**

In inserted Task Templates, parameters are marked as placeholders (in purple text) or specified using sliders or other embedded components.

1. Specify values for the parameters in placeholders or using graphical interface components. You can move to the next placeholder by pressing **Tab**.
2. Execute all commands in the task by:
   - Placing the cursor in the first task command, and then pressing **Enter** repeatedly to execute each command.
   - Selecting all the template commands, and then clicking the execute toolbar icon 🔄.
3. If the template contains a button that computes the result, click it.

For more information on task templates, refer to the **tasks** help page.

**Exploration Assistant**

The Exploration Assistant allows you to interactively make parameter changes to expressions and view the result. The assistant can be used with almost any Maple expression or command that has at least one variable or parameter.

**To launch the Exploration Assistant:**
1. Enter an expression or command.
2. Click the expression or command. From the context panel, select **Explore**.
3. The **Explore** parameter selection dialog appears, where you can select the parameters to explore and the range for each parameter.

If you enter integer ranges, only integer values are allowed for parameters. To allow floating-point values, enter floating-point ranges.

Select **skip** for any of the parameters to leave that parameter as a variable.

4. Click **Explore** to continue to the **Exploration Assistant**. The assistant creates a table in the document. You can use the slider or sliders to vary the parameters and see your changes as the expression output is updated.
5. Once you are finished interacting with the assistant, you can copy and paste the results into your document, or save the interactive document for later use.
Example 7 - Use the Exploration Assistant to Explore a Plot

In this example, we will explore how the plot of \( \frac{\sin(ax) - b \cos(x)}{x} \) changes as we vary the parameters \( a \) and \( b \).

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Enter the plot command shown.</td>
<td>( \text{plot}\left( \frac{\sin(ax) - b \cos(x)}{x}, x = 1..10 \right) )</td>
</tr>
<tr>
<td>2. Click the expression and select Explore from the context panel.</td>
<td>![Image of Explore dialog]</td>
</tr>
<tr>
<td>3. In the Explore parameter selection dialog, set the ranges ( a = 0..10.0 ) and ( b = -5..5.0 ).</td>
<td>![Image of Explore parameter selection dialog]</td>
</tr>
</tbody>
</table>
### 1.5 Commands

Even though Maple comes with many features to solve problems and manipulate results without entering any commands, you may find that you prefer greater control and flexibility by using the set of commands and programming language that Maple offers.

**The Maple Library**

Commands are contained in the Maple library, which is divided into two groups: the main library and packages.

The main library contains the most frequently used Maple commands.

Packages contain related commands for performing tasks from disciplines such as Student Calculus, Statistics, or Differential Geometry. For example, the Optimization package contains commands for numerically solving optimization problems.

For details on top-level and package commands, see *Commands (page 57)*.

---

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>4. Click <strong>Explore</strong>. The Exploration Assistant creates a table in the document. Move the sliders to see the plot as the parameters change.</td>
<td>![Plot with sliders for a and b]</td>
</tr>
<tr>
<td><strong>Tip:</strong> Since decimal numbers were used for the ranges in step 3, the slider uses decimal numbers. If you use integers for the ranges, the slider uses integer numbers.</td>
<td>![Slider with decimal and integer options]</td>
</tr>
</tbody>
</table>
Entering Commands

If you want to interact with Maple using commands, simply enter the command using 2-D math. Notice that commands and variable names display in italics. Maple commands are constructed in a format similar to `command(arguments)`, based on the command you are using.

For example, to factor an expression, enter:

```
factor(x^2 + 2 x + 1)
```

\[(x + 1)^2\]

To differentiate an expression, enter:

```
diff(sin(x), x)
```

\[\cos(x)\]

To integrate an expression on the interval \([0, 2 \pi]\), enter:

```
int(2 x + cos(x), x = 0 .. 2 \pi)
```

\[4 \pi^2\]

To plot an expression, enter:

```
plot(sin(x) x^2, x = -10 .. 10)
```

For a list of the top commands in Maple, see *Top Commands* (page 59).
Package Commands

There are two ways to access commands within a package, using the long form of the package command or the short form.

Long Form of Accessing Package Commands:
The long form specifies both the package and command names using the syntax `package[command](arguments).

```
LinearAlgebra[RandomMatrix](2)
```

<table>
<thead>
<tr>
<th>44</th>
<th>-31</th>
</tr>
</thead>
<tbody>
<tr>
<td>92</td>
<td>67</td>
</tr>
</tbody>
</table>

Short Form of Accessing Package Commands:
The short form makes all of the commands in the package available using the `with` command, `with(package)`. If you are using a number of commands in a package, loading the entire package is recommended. When you execute the `with` command, a list of all commands in the package displays. To suppress the display of all command names, end the `with(package)` command with a colon. Alternatively, you can load packages through the Tools menu, by selecting Load Package, and then the package name.

```
with(Optimization)
```

```
[ImportMPS, Interactive, LPSolve, LSSolve, Maximize, Minimize, NLPsolve, QPSolve]
```

After loading a package, you can use the short-form names, that is, the command names, without the package name.

```
LSSolve([x - 2, x - 6, x - 9])
```

```
[12.333333333333321, [x = 5.666666666666667]]
```

For a list of the top packages in Maple, see Top Packages (page 60).

Command Completion

To help with syntax and reduce the amount of typing when entering Maple commands, you can use command completion. Command completion displays a list of all Maple packages, commands, and functions that match the entered text. If there are multiple ways to call a command, then the command completion list contains each one, with appropriate placeholders.

To use command completion:

1. Begin entering a command or package name.
2. Select Tools → Complete Command or use the shortcut key Esc (see Shortcut Keys by Platform (page xiii)). If there is a unique completion, it is inserted. Otherwise, a list of possible matches is displayed.
3. Select the correct completion from the list.
4. Some inserted commands have placeholders, denoted by purple text. The first placeholder is highlighted after you insert it into the document. Replace it with your parameter, then move to the next placeholder by pressing the Tab key.

**Equation Labels**

Equation labels help to save time entering expressions by referencing Maple output. See Figure 1.9.

By default, equation labels are displayed. If equation labels are not displayed,

1. From the Tools menu, select Options, and click the Display tab. Ensure that the Show equation labels check box is selected.

2. From the Format menu, select Equation Labels. Ensure that both Execution Group and Worksheet are selected.

![Figure 1.9: Equation Label](image)

**To apply equation labels:**

1. Enter an expression and press Enter. Note that the equation label is displayed to the right of the answer in the document.

2. In a new execution group, enter another expression that will reference the output of the previous execution group.

3. From the Insert menu, select Label. Alternatively, press Ctrl+L (Command+L, for Mac) to open the Insert Label dialog. Enter the label number in the Insert Label dialog and click OK. The item is now a label. See Figure 1.10.
4. Press **Enter** to obtain the result.

**To change the format of equation labels:**

- Select **Format → Equation Labels → Label Display**. In the **Format Labels** dialog, select one of the numbering schemes. Numbering can be flat numbers for the entire worksheet, or by section, so that equations in section 1 are labeled (1.1), (1.2), and so on.

- Optionally, enter an appropriate numbering prefix.

**The Label Reference menu item allows you to switch between the label name and its reference content. Place the cursor on the referenced equation label and select **Format → Equation Labels → Label Reference**.**

The label is associated with the last output within an execution group.

You cannot apply equation labels to the following:

- Error, warning, and information messages
- Tables, images, plots, or sketches

**Document Blocks**

In Document mode, content is created as a series of document blocks. Document blocks allow you to hide the syntax used to perform calculations, which in turn lets you focus on the concept presented instead of the command used to manipulate or solve the problem. You can also create document blocks in Worksheet mode to perform the same function.
Document blocks are typically collapsed to hide the Maple code, but these regions can also be expanded to reveal this code.

To create a document block:

From the **Edit** menu, select **Document Blocks → Create Document Block**. If text or math in one or more execution groups is selected, then a document block is created that contains those execution groups. If not, a new document block is created after the current execution group. For more information, see the next example.

Document block regions are identified using markers that are located in a vertical bar along the left pane of the document. See Figure 1.13. In addition to document block boundaries, these markers (icons) indicate the presence of hidden attributes in the document such as annotations, bookmarks, and numeric formatting.

To activate markers:

From the **View** menu, select **Markers**. See Figure 1.13.

![Figure 1.13: Document Block Markers](image)

To view code in a document block:

1. Place the cursor in a document block to be expanded.
2. From the **Edit → Document Blocks** menu, select **Show Command**.

![Figure 1.14: Expanded Document Block](image)

With the Document Block expanded, you can see the Maple command that was used to perform this calculation. In Figure 1.14, the `solve` command was used.

Also notice a red prompt (>) before the original expression and the `solve` command. Entering commands outside of a document block region is done at this input region. To insert an input region, click the `>` button in the toolbar menu.

In Figure 1.14, an equation label was used to refer to the expression. For more information, see *Equation Labels (page 34)*.

To collapse a Document Block:

- With your cursor inside the document block, from the **Edit → Document Blocks** menu, clear the check box for **Show Command**.

You can use this process of expanding document blocks to view and edit Maple commands within a document block.
**Changing the Display:**

You can specify which parts of the input and output are displayed when the document block is collapsed. For each execution group in the block, you can choose to display either the input or the output.

- Place the cursor in the execution group.
- From the **Edit → Document Blocks** menu, select **Toggle Input/Output Display**.

Also, you can choose to display output either inline or centered on a new line.

- From the **Edit → Document Blocks** menu, select **Inline Document Output**.

---

**1.6 The Maple Help System**

The Maple program provides a custom help system consisting of almost 5000 reference pages. The help system is a convenient resource for determining the syntax of Maple commands and for learning about Maple features.

### Accessing the Help System

There are several ways to access the Maple help system:

- From the **Help** menu, select **Maple Help**.
- Enter a search term in the search box in the worksheet toolbar.
- Click 🔄 in the toolbar.

**To get help on a specific word:**

- In a document, place the insertion point in a word for which you want to obtain help. From the **Help** menu, select **Help on ...**. Alternatively, press F2 (Control + ?, for Mac) to access context-sensitive help.
- In a document, execute the command `?topic`, for example, enter `?LinearAlgebra` and press **Enter**.

The Maple help system opens in a separate window with two panes. The left pane contains the Help Navigator where you initiate searches and browse the table of contents, and the right pane displays the final search result, such as a specific help page.
Every help page in Maple lists the command's calling sequence, parameters, and a description, with examples of the command at the end of the page. Some help pages also contain hyperlinks to related help pages and hyperlinks to dictionary definitions. Hyperlinks to dictionary definitions display in red to distinguish them from hyperlinks to help pages.

Using the Help Navigator

Use the search field in the Help Navigator to find information on Maple commands and features.

- **Search** for a known help topic, a command name, or a keyword or phrase.
- If you have any add-on products, you can restrict the search to Maple, MapleSim, or any combination of those products and their add-ons.
You can search all of the help system or specific Resources such as Help Pages, Tasks, Math Apps, and Manuals by selecting the Page Types drop-down menu.

Search results are displayed as a list in the Search Results tab of the left pane. Click the Table of Contents tab to view a structured list of all topics in the help system.

Note that some tutorials open in a Maple window instead of in the Help window.

In the left pane, the type of resource is indicated by an icon. Table 1.10 describes the icons.

### Table 1.10: Help Page Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📏</td>
<td>A folder icon in the Table of Contents tab indicates that a topic can be expanded into subtopics.</td>
</tr>
<tr>
<td>❓</td>
<td>Question mark icon indicates a help page and displays the associated help page in the right pane when selected.</td>
</tr>
<tr>
<td>_WS</td>
<td>WS icon indicates an example worksheet or tutorial. These worksheets open in a new tab in the Maple document.</td>
</tr>
<tr>
<td>𝐷</td>
<td>D icon indicates a definition and displays the associated dictionary definition in the right pane when selected.</td>
</tr>
<tr>
<td>𝑇</td>
<td>T icon indicates a Task template and displays the associated Task Template in the right pane when selected.</td>
</tr>
</tbody>
</table>

**Viewing Help Pages as Documents**

In the help system, examples are not executable.

The Maple help system allows you to open help pages as documents that you can execute.

**To open a help page as a worksheet:**

- With the help page displayed in the right pane of the help system, from the View menu, select Open Page as Worksheet. A new worksheet tab opens and displays the help page as an executable document.

Alternatively, in the help system toolbar, click the open current help page in a worksheet window icon.

**Viewing Examples in 2-D Math**

You can choose to view the examples in most help pages in either 2-D math or 1-D Math (Maple input) mode. The default is 2-D Math.

**To change the math mode:**

In the Maple help system:

- From the View menu, select or clear the Display Examples with 2D math input check box.

- Click the 2-D Math icon, $x^2$.

Note: Some input in help pages displays as 1-D Math, no matter which option you have chosen. This is for Maple procedures and other code that is best input in 1-D Math. For more information, refer to the helpnavigator help page.

**Copying Examples**

Instead of opening the entire page as a document, you can copy the Examples section only.

**To copy examples:**

1. With the help page displayed in the right pane of the help system, from the Edit menu, select Copy Examples.
2. Close or minimize the Help Navigator and return to your document.
3. In your document, place the cursor at the location where you want to paste the examples.
4. From the Edit menu, select Paste. The Examples section of the help page is inserted as executable content in your document.

1.7 Available Resources

Your work with Maple is supported by numerous resources.

Resources Available through the Maple Help System

Help Pages

Use the help system to find information about a specific topic, command, package, or feature. For more information, see The Maple Help System (page 37).

Dictionary

More than 5000 mathematical and engineering terms with over 300 figures and plots.

1. From the Help menu, select Maple Help.
2. Enter a search term. Dictionary entries that match your query are displayed in the left pane with a icon.

Tutorials and the Maple Portal

The Maple Portal includes material designed for all Maple users, from new users to users who want more advanced tutorials. The Maple Portal also includes specific sections for students and engineers. The Maple Portal includes:

• How Do I... topics that give quick answers to essential questions.
• Tutorials that provide an overview of topics from getting started to plotting, data manipulation, and interactive application development.
• Navigation to portals with specialized information for students and engineers.

Access the portal in the Table of Contents under Getting Started.

Applications and Example Worksheets

Applications

Sample applications demonstrate how Maple can be used to find and document a solution to a specific problem. Some applications allow for input or contain animations that you can run; however, their primary use is for demonstrations. Topics include Bouncing Ball, Digital Filter Design, Frequency Domain System Identification, Harmonic Oscillator, Image Processing, Radiator Design with CAD Systems, and Sunspot Periodicity.

Examples

Example worksheets are executable documents covering topics that demonstrate syntax or invoke a user interface to make complex problems easy to solve and visualize. You can copy and modify the examples as needed. Topics include Algebra, Calculus, Connectivity, Discrete Mathematics, General Numerics and Symbolics, and Integral Transforms.

• Explore the available topics in the Table of Contents under Applications and Example Worksheets.

Manuals

You can access all of Maple's manuals from within Maple, including the Maple Programming Guide and this manual. You can execute examples, copy content into other documents, and search the contents using the Maple Help System.

• Access the manuals in the Table of Contents under Manuals.

Maple's manuals are also available as PDFs on the Maplesoft website.
Task Templates
Set of commands with placeholders that you can use to quickly perform a task. For details, see Task Templates (page 27).
• From the Tools menu, select Tasks, and then Browse.

Quick Reference Card
The Quick Reference Card is a table of commands and information for new users that opens in a new window. It contains hyperlinks to help pages for more information.
• From the Help menu, select Quick Reference. Alternatively, press Ctrl + F2 (Command + F2, for Mac).

Website Resources

Student Help Center
The Student Help Center offers a Maple student forum, online math Oracles, training videos, and a math homework resource guide.
http://www.maplesoft.com/studentcenter

Teacher Resource Center
The Teacher Resource Center is designed to ensure you get the most out of your Maple teaching experience. It provides sample applications, course material, training videos, white papers, and tips.
http://www.maplesoft.com/TeacherResource

Application Center
Maple website resource for free applications related to mathematics, education, science, engineering, computer science, statistics and data analysis, finance, communications, and graphics. Many applications are available in translations (French, Spanish, and German).
http://www.maplesoft.com/applications

Training
Maplesoft offers a comprehensive set of complementary training materials. From complete training videos to recorded training seminars to downloadable documentation, you have many options to get familiar with Maplesoft products. In addition, custom training sessions can be created to meet your needs.
http://www.maplesoft.com/support/training

MaplePrimes
A web community dedicated to sharing experiences, techniques, and opinions about Maple and related products, as well as general interest topics in math and computing.
http://www.mapleprimes.com

Online Help
All of Maple's help pages are available online.
http://www.maplesoft.com/support/help
Technical Support

A Maple website containing FAQs, downloads and service packs, links to discussion groups, and a form for requesting technical support.

http://www.maplesoft.com/support

For a complete list of resources, refer to the MapleResources help page.
2 Document Mode

Using the Maple software, you can create powerful interactive documents. You can visualize and animate problems in two and three dimensions. You can solve complex problems with simple point-and-click interfaces or easy-to-modify interactive documents. You can also devise custom solutions using the Maple programming language. While you work, you can document your process, providing text descriptions.

2.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction (page 43)</td>
<td>• Comparison of Document and Worksheet Modes</td>
</tr>
<tr>
<td>Entering Expressions (page 44)</td>
<td>• Palettes</td>
</tr>
<tr>
<td></td>
<td>• Symbol Names</td>
</tr>
<tr>
<td></td>
<td>• Mathematical Functions</td>
</tr>
<tr>
<td>Evaluating Expressions (page 46)</td>
<td>• Displaying the Value Inline</td>
</tr>
<tr>
<td></td>
<td>• Displaying the Value on the Following Line</td>
</tr>
<tr>
<td>Editing Expressions and Updating Output (page 47)</td>
<td>• Updating a Single Computation</td>
</tr>
<tr>
<td></td>
<td>• Updating a Group of Computations</td>
</tr>
<tr>
<td></td>
<td>• Updating All Computations in a Document</td>
</tr>
<tr>
<td>Performing Computations (page 48)</td>
<td>• Computing with Palettes</td>
</tr>
<tr>
<td></td>
<td>• Context Panel</td>
</tr>
<tr>
<td></td>
<td>• Assistants and Tutors</td>
</tr>
</tbody>
</table>

2.2 Introduction

Maple has two modes: Document mode and Worksheet mode.

Document mode is designed for quickly performing calculations. You can enter a mathematical expression, and then evaluate, manipulate, solve, or plot it with a few keystrokes or mouse clicks. This chapter provides an overview of Document mode.

Document mode sample:

Find the value of the derivative of $\ln(x^2 + 1)$ at $x = 4$.

$$\ln(x^2 + 1) \xrightarrow{\text{differentiate w.r.t. } x} \frac{2x}{x^2 + 1} \xrightarrow{\text{evaluate at point}} \frac{8}{17}$$

Integrate $\sin\left(\frac{1}{x}\right)$ over the interval $[0, \pi]$.

$$\int_0^\pi \sin\left(\frac{1}{x}\right) \, dx = \sin\left(\frac{1}{\pi}\right) \pi - \text{Ci}\left(\frac{1}{\pi}\right)$$

Worksheet mode is designed for interactive use through commands and programming using the Maple language. The Worksheet mode supports the features available in Document mode described in this chapter. For information on using Worksheet mode, see Chapter 3, Worksheet Mode (page 55). Note: To enter a Maple input prompt while in Document mode, click $\cdot$ in the Maple toolbar.

Important: In any Maple document, you can use Document mode and Worksheet mode.
Interactive document features include:

- Embedded graphical interface components, like buttons, sliders, and check boxes
- Automatic execution of marked regions when a file is opened
- Tables
- Character and paragraph formatting styles
- Hyperlinks

These features are described in Chapter 7, *Creating Mathematical Documents* (page 221).

**Note:** This chapter and Chapter 1 were created using Document mode. All of the other chapters were created using Worksheet mode.

## 2.3 Entering Expressions

Chapter 1 provided an introduction to entering simple expressions in 2-D Math (see *Entering Expressions* (page 14)). It is also easy to enter mathematical expressions, such as:

- Piecewise-continuous functions: $|x| = \begin{cases} -x & \text{if } x < 0 \\ 0 & \text{if } x = 0 \\ x & \text{if } 0 < x \end{cases}$
- Limits: $\delta(x) = \lim_{t \to 0} |x|^{-1}$
- Continued fractions: $\sqrt{2} = 1 + \cfrac{1}{2 + \cfrac{1}{2 + \cfrac{1}{2 + \cdots}}}$

and more complex expressions.

Mathematical expressions can contain the following objects.

- Numbers: integers, rational numbers, complex numbers, floating-point values, finite field elements, 1, $\infty$, ...
- Operators: $+,-,!,/,,\int, \lim_{x \to a}, \frac{\partial}{\partial x}$, ...
- Constants: $\pi, e, ...$
- Mathematical functions: $\sin(x), \cos\left(\frac{\pi}{3}\right), \Gamma(2), ...$
- Names (variables): $x, y, z, \alpha, \beta, ...$
- Data structures: sets, lists, Arrays, Vectors, Matrices, ...

Maple contains over a thousand symbols. For some numbers, operators, and names, you can press the corresponding key, for example, 9, =, >, or x. Most symbols are not available on the keyboard, but you can insert them easily using two methods, palettes and symbol names.

### Example 1 - Enter a Partial Derivative

To insert a symbol, you can use palettes or symbol names.
Enter the partial derivative \( \frac{\partial}{\partial t} e^{-t^2} \) using palettes.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the <strong>Calculus</strong> palette, click the partial differentiation item ( \partial_{x} f ). Maple inserts the partial derivative. The variable placeholder is selected.</td>
<td>( \frac{\partial}{\partial x} f )</td>
</tr>
<tr>
<td>2. Enter ( t ), and then press Tab. The expression placeholder is selected.</td>
<td>( \frac{\partial}{\partial t} f )</td>
</tr>
<tr>
<td>3. Enter ( e^{-t^2} ). <strong>Note:</strong> To enter the exponential ( e ), use the <strong>Expression</strong> palette or the <strong>Common Symbols</strong> palette. Here, we use the ( e^a ) template from the <strong>Expression</strong> palette.</td>
<td>( \frac{\partial}{\partial t} e^{-t^2} )</td>
</tr>
</tbody>
</table>

Click the template. The exponent placeholder is selected. Enter the exponent.

To evaluate the derivative and display the result inline, press **Ctrl+=** (Command+=, for Macintosh) or **Enter**. For more information, see *Computing with Palettes* (page 48).
You can enter any expression using symbol names and the symbol completion list.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Begin typing the name of the symbol, <code>diff</code>, and press the symbol completion key (see Shortcut Keys by Platform (page xiii)).</td>
<td><img src="image" alt="diff" /></td>
</tr>
<tr>
<td>2. Select the partial differentiation item, <code>diff (right partial)</code></td>
<td>( \frac{d}{dx} x )</td>
</tr>
<tr>
<td>3. Replace the placeholder with ( t ). Use the right arrow to move out of the denominator. Enter ( e^{-t^2} ) as in the previous example.</td>
<td>( \frac{\partial}{\partial t} e^{-t^2} )</td>
</tr>
</tbody>
</table>

**Example 2 - Define a Mathematical Function**

Define the function *twice*, which doubles its input.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the Expression palette, click the single variable function definition item, ( f = a \rightarrow y ).</td>
<td>( f = a \rightarrow y )</td>
</tr>
<tr>
<td>2. Replace the placeholder ( f ) with the function name, <em>twice</em>. Press Tab to move to the next placeholder.</td>
<td>twice ( = a \rightarrow y )</td>
</tr>
<tr>
<td>3. Replace the parameter placeholder, ( a ), with the independent variable ( x ). Press Tab.</td>
<td>twice ( = x \rightarrow y )</td>
</tr>
<tr>
<td>4. Replace the output placeholder, ( y ), with the desired output, 2 ( x ).</td>
<td>twice ( = x \rightarrow 2 x )</td>
</tr>
</tbody>
</table>

\[
twice(1342) = 2684
\]

\[
twice(y - z) = 2 \, y - 2 \, z
\]

**Note:** To insert the right arrow symbol \( \rightarrow \), you can also enter the characters `->` in Math mode. In this case, symbol completion is automatic.

**Important:** The expression 2 \( x \) is different from the function \( x \rightarrow 2 \, x \).

For more information on functions, see Functional Operators (page 268).

**2.4 Evaluating Expressions**

To evaluate a mathematical expression, place the cursor in the expression and press Ctrl + = (Command + =, for Macintosh). That is, *press and hold* the Ctrl (or Command) key, and then press the equal sign (=) key.

To the right of the expression, Maple inserts an equal sign and then the value of the expression.
In mathematical content, pressing Enter evaluates the expression and displays it centered on the following line. The cursor moves to a new line below the output.

\[
\frac{2}{9} + \frac{7}{11} = \frac{85}{99}
\]

By default, Maple labels output that is generated by pressing Enter. For information on equation labels, see Equation Labels (page 68). In this manual, labels are generally not displayed.

You can use the basic algebraic operators, such as + and −, with most expressions, including polynomials—see Polynomial Algebra (page 110) and matrices and vectors—see Matrix Arithmetic (page 124).

\[
(2x^2 - x + 1) - (x^2 + 2x + 12) = x^2 - 3x - 11
\]

\[
\begin{bmatrix}
-4 & 8 & 99 \\
27 & 69 & 29
\end{bmatrix}
= 
\begin{bmatrix}
-12 & 24 & 297 \\
81 & 207 & 87
\end{bmatrix}
\]

Tip: The Enter key has a number of uses.

- Pressing Enter with your cursor in a math expression executes it and evaluates it on a new line.
- Pressing Enter in text inserts a line break.
- Pressing Enter when at the beginning of a line (the Home position) inserts a new line above the current line.

For more information on these concepts, refer to the Using Document Blocks help page.

Tip: If you want to change an input/output expression from evaluate and display inline to evaluate and display on a new line, with your cursor in the input expression, from the Evaluate menu or the Context Panel, clear the check box beside Evaluate and Display Inline.

2.5 Editing Expressions and Updating Output

One important feature of Maple is that your documents are live. That is, you can edit expressions and quickly recalculate results.

To update one computation:
1. Edit the expression.
2. Press Ctrl + = (Command + =, for Macintosh) or Enter.

The result is updated.

To update a group of computations:
1. Edit the expressions.
2. Select all edited expressions and the results to recalculate.
3. Click the Execute toolbar icon !.

All selected results are updated.
To update all output in a Maple document:

- Click the Execute All toolbar icon 

All results in the document are updated.

Note: Be careful when you revisit a document and make changes, as it's possible to produce a document with worksheet commands out of order (i.e. where a certain command won't work properly without a later one).

### 2.6 Performing Computations

Using the Document mode, you can access the power of the advanced Maple mathematical engine without learning Maple syntax. In addition to solving problems, you can also easily plot expressions.

The primary tools for syntax-free computation are:

- Palettes
- The Context Panel
- Assistants and tutors

Note: The Document mode is designed for quick calculations, but it also supports Maple commands. For information on commands, see Commands (page 57) in Chapter 3, Worksheet Mode (page 55).

Important: In Document mode, you can execute a statement only if you enter it in Math mode. To use a Maple command, you must enter it in Math mode.

**Computing with Palettes**

As discussed in Entering Expressions (page 44), some palettes contain mathematical operations.

To perform a computation using a palette mathematical operation:

1. In a palette that contains operators, such as the Expression or Calculus palettes, click an operator item.
2. In the inserted item, specify values in the placeholders.
3. To execute the operation and display the result, press Ctrl+= (Command+=, for Macintosh) or Enter.

For example, to evaluate \( \frac{\partial}{\partial t} e^{-t^2} \) inline:

1. Using the Calculus palette, enter the partial derivative. See Example 1 - Enter a Partial Derivative (page 44).
2. Press Ctrl+= (Command+=, for Macintosh).

\[
\frac{\partial}{\partial t} e^{-t^2} = -2 t e^{-t^2}
\]

**Computing with the Context Panel**

The context panel is a collection of tools and operations that are appropriate for a particular expression. The context panel changes according to the expression, table, or region that you click on. See Figure 2.1.
To display the context panel:

1. Click the expression.

2. Move your mouse cursor over Pin Open Context Panel (∇), or click it to fix the context panel in place.

The context panel is displayed.

You can evaluate expressions using context panel options. The Evaluate and Display Inline operation (see Figure 2.1) is equivalent to pressing Ctrl+= (Command++, for Macintosh). That is, it inserts an equal sign (=) and then the value of the expression.

Alternatively, press Enter to evaluate the expression and display the result centered on the following line.

For more information on evaluation, see Evaluating Expressions (page 46).
From the context panel, you can also select operations different from evaluation. To the right of the expression, Maple inserts a right arrow symbol (→) and then the result.

For example, use the Approximate operation to approximate a fraction: \( \frac{2}{3} \) at 10 digits \( \rightarrow 0.666666667 \)

You can perform a sequence of operations by repeatedly using context panel options. For example, to compute the derivative of \( \cos(x^2) \), use the Differentiate operation on the expression, and then to evaluate the result at a point, use the Evaluate at a Point operation on the output and enter 10:

\[ \cos(x^2) \xrightarrow{\text{differentiate w.r.t. } x} -2 \sin(x^2) \xrightarrow{\text{evaluate at point}} -20 \sin(100) \]

Note: For the sequence of operations to make sense when being read from left to right, stale results are deleted before new operations are performed.

For example:

<table>
<thead>
<tr>
<th>Enter the expression ( x^2 ).</th>
<th>( x^2 )</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click on the expression and use the Differentiate option from the context panel to differentiate with respect to ( x ).</td>
<td>( x^2 \xrightarrow{\text{differentiate w.r.t. } x} 2x )</td>
</tr>
<tr>
<td>Click on ( 2x ) and use the Integrate option from the context panel to integrate with respect to ( x ).</td>
<td>( x^2 \xrightarrow{\text{differentiate w.r.t. } x} 2x \xrightarrow{\text{integrate w.r.t. } x} x^2 )</td>
</tr>
<tr>
<td>Click on ( 2x ) again and use the Differentiate option to differentiate with respect to ( x ).</td>
<td>( x^2 \xrightarrow{\text{differentiate w.r.t. } x} 2x \xrightarrow{\text{differentiate w.r.t. } x} 2 )</td>
</tr>
<tr>
<td>Notice how the result of integration with respect to ( x ) has been replaced with the result of differentiation with respect to ( x ) so that the sequence of operations makes sense.</td>
<td></td>
</tr>
</tbody>
</table>

The following subsections provide detailed instructions on performing a few of the numerous operations available using context-sensitive operations in the context panel.

**Approximating the Value of an Expression**

To approximate a fraction numerically:

1. Enter a fraction.
2. Click the fraction to display the context panel. See Figure 2.2.
3. From the context panel, select Approximate, and then the number of significant digits to use: 5, 10, 20, 50, or 100.
Figure 2.2: Approximating the Value of a Fraction

\[
\frac{2}{3} \quad \text{at 10 digits} \quad 0.666666667
\]

You can replace the inserted right arrow with text or mathematical content.

To replace the right arrow (→):
1. Select the arrow and text. Press Delete.
2. Enter the replacement text or mathematical content.

Note: To replace the right arrow with text, you must first press F5 to switch to Text mode.

For example, you can replace the arrow with the text "is approximately equal to" or the symbol ≈.

\[
\frac{2}{3} \quad \text{is approximately equal to} \quad 0.666666667
\]

\[
\frac{2}{3} \approx 0.666666667
\]

Solving an Equation

You can find an exact (symbolic) solution or an approximate (numeric) solution of an equation. For more information on symbolic and numeric computations, see Symbolic and Numeric Computation (page 74).

To solve an equation:
1. Enter an equation.
2. Display the context panel. See Figure 2.3.
3. From the context panel, select Solve or Numerically Solve in the Solve menu item.
Figure 2.3: Finding the Approximate Solution to an Equation

\[
\frac{7x^2}{3} - \frac{x}{\pi} = 12 \quad \text{solve} \quad \left\{ x = \frac{3}{14} - 1 + \sqrt{112 \pi^2 + 1} \pi \right\}, \left\{ x = \frac{3}{14} - 1 - \sqrt{112 \pi^2 + 1} \pi \right\}
\]

\[
\frac{7x^2}{3} - \frac{x}{\pi} = 12 \quad \text{solve} \quad -2.200603126, 2.337021648
\]

For more information on solving equations, including solving inequations, differential equations, and other types of equations, see Solving Equations (page 80).

Using Units

You can create expressions with units. To specify a unit for an expression, use the Units palette. See Figure 2.4.

Figure 2.4: Units Palette

To insert an expression with a unit:

1. Enter the expression.
2. In a unit palette, click a unit symbol.

Note: To include a reciprocal unit, divide by the unit.
To evaluate an expression that contains units:

1. Enter the expression using the units palettes to insert units.
2. Click the expression.
3. From the context panel, select the **Simplify** menu and then **Simplify**.

For example, compute the electric current passing through a wire that conducts 590 coulombs in 2.9 seconds.

\[
\frac{590 \text{ C}}{2.9 \text{ s}} \xrightarrow{\text{simplify units}} 203.4482759 \text{ A}
\]

For more information on using units, see *Units (page 93)*.

**Assistants and Tutors**

Assistants and tutors provide point-and-click interfaces with buttons, text input regions, and sliders. For details on assistants and tutors, see *Point-and-Click Interaction (page 24)*.

Assistants and tutors can be launched from the *Tools* menu or the Context Panel for an expression. For example, you can use the **Linear System Solving** tutor to solve a linear system, specified by a matrix or a set of equations.

**Example 3 - Using the Context Panel to Open the Linear System Solving Tutor**

Use the **Linear System Solving** tutor to solve the following system of linear equations, written in matrix form:

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
</table>
| 1. In a new document block, create the matrix or set of linear equations to be solved. | \[
\begin{bmatrix}
1 & 3 & 0 & -2 & -1 \\
4 & 2 & -1 & 5 & 7 \\
0 & -3 & 5 & 4 & -7 \\
1 & -1 & 3 & 6 & 5
\end{bmatrix}
\]
| 2. Load the **Student[LinearAlgebra]** package. From the *Tools* menu, select *Load Package* → **Student Linear Algebra**. This makes the tutors in that package available. For details, see *Package Commands (page 33)*. | Loading **Student:-LinearAlgebra**
| 3. Click the matrix and from the context panel select **Student Linear Algebra → Tutors → Linear System Solving**... The Linear System Solving dialog appears, where you can choose the solving method. **Gaussian Elimination** reduces the matrix to row-echelon form, then performs back-substitution to solve the system. **Gauss Jordan Elimination** reduces the matrix to reduced row-echelon form, where the equations are already solved. For this example, choose **Gaussian Elimination**. | ![Linear Algebra - Linear System Solving](image)
4. The Gaussian Elimination dialog opens. You can specify the Gaussian elimination step-by-step, or you can use the Next Step or All Steps buttons to have Maple perform the steps for you.

5. Once the matrix is in row-echelon (upper-triangular) form, click the Solve System button to move to the next step.

6. The Solve the system of equations in Row-Echelon Form dialog appears. Click the buttons on the right to calculate the solution: first find the Equations, then solve for each variable. Click the Solution button to display the solution in the tutor.

7. Click the Close button to return the solution to your document.

For more information on linear systems and matrices, see Linear Algebra (page 116).
3 Worksheet Mode

The Worksheet mode of the Standard Worksheet interface is designed for:

• Interactive use through Maple commands, which offers advanced functionality and customized control not available using the context panel or other syntax-free methods
• Programming using the powerful Maple language

Using Worksheet mode, you have access to all of the Maple features described in Chapter 1, and most of those described in Chapter 2, including:

• Math and Text modes
• Palettes
• The context panel
• Assistants and tutors

For information on these features, see Chapter 1, Getting Started (page 1) and Chapter 2, Document Mode (page 43).

Note: Using a document block, you can use all Document mode features in Worksheet mode. For information on document blocks, see Document Blocks (page 35).

Note: This chapter and the following chapters except Chapter 7 were created using Worksheet mode.

3.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Input Prompt (page 56) - Where you enter input | • The Input Prompt (>)
• Suppressing Output
• 2-D and 1-D Math Input
• Input Separators |
| Commands (page 57) - Thousands of routines for performing computations and other operations | • The Maple Library
• Top-Level Commands
• Mathematical Functions
• Package Commands
• Lists of Common Commands and Packages |
| Palettes (page 61) - Items that you can insert by clicking or dragging | • Using Palettes |
| The Context Panel (page 63) - Clickable access to common operations | • Using the Context Panel |
| Assistants and Tutors (page 64) - Graphical interfaces with buttons and sliders | • Launching Assistants and Tutors |
| Task Templates (page 64) - Sets of commands with placeholders that you can insert and use to perform a task | • Viewing Task Templates
• Inserting a Task Template
• Performing the Task |
| Text Regions (page 65) - Areas in the document in which you can enter text | • Inserting a Text Region
• Formatting Text |
### 3.2 Input Prompt

In Worksheet mode, you enter input at the Maple *input prompt* (>). The default mode for input is Math mode (2-D Math).

To evaluate input:

- Press **Enter**.

Maple displays the result (output) below the input.

For example, to find the value of \( \sin^3\left(\frac{\pi}{3}\right) \), enter the expression, and then press **Enter**.

\[
> \sin^3\left(\frac{\pi}{3}\right) \\
\quad = \frac{3 \sqrt{3}}{8} \quad (3.1)
\]

For example, compute the sum of two fractions.

\[
> \frac{2}{9} + \frac{7}{11} \\
\quad = \frac{85}{99} \quad (3.2)
\]

A set of Maple input and its output are referred to as an *execution group*.

In the worksheet, the semicolon as a statement terminator is optional.

**Suppressing Output**

To suppress the output, enter a colon (:) at the end of the input.

\[
> a := \frac{2}{9} + \frac{7}{11} :
\]
To enter input using 1-D Math:

- At the input prompt, press F5 or click the Text button in the context bar, to switch from 2-D Math to 1-D Math.

\[123^2 - \frac{29857}{120};\]

1785623
\[120\]

As with 2-D math, in 1-D math, if you use a colon, Maple suppresses the output.

\[123^2 - \frac{29857}{120};\]

To set the default input mode at a prompt to 1-D Math:

1. From the Tools menu, select Options. The Options dialog is displayed.
2. On the Display tab, in the Input display drop-down list, select Maple Notation.
3. Click Apply to Session (to set for only the current session) or Apply Globally (to set for all Maple sessions).

To convert between 2-D Math input and 1-D Math input:

1. Select the 2-D (or 1-D) Math input.
2. From the Format menu, select Convert To, and then 1-D Math Input (or 2-D Math Input).

Input Separators

In 1-D and 2-D Math input, you can use a semicolon or colon to separate multiple inputs in the same input line.

\[\sqrt{4.4}; \tan(3.2);\]

\[2.097617696\]
\[0.05847385446\]

If you do not specify a semicolon or colon, Maple interprets it as a single input. This can either give unexpected results or an error. Notice that the following example gives an error in 1-D math but in 2-D math this is interpreted as multiplication.

\[\sqrt{4.4} \tan(3.2)\]

Error, missing operator or `;`

\[\sqrt{4.4} \tan(3.2)\]

0.1226557919

3.3 Commands

Maple contains a large set of commands and a powerful programming language. Most Maple commands are written using the Maple programming language.

You can enter commands using 1-D or 2-D Math. 1-D Math input is recommended when programming in Maple. Basic Programming (page 289) provides an introduction to Maple programming.

To learn how to use Maple commands, see the appropriate help page, or use task templates. For more information, see The Maple Help System (page 37) and Task Templates (page 64).
The Maple Library

Maple’s commands are contained in the Maple library. There are two types of commands: top-level commands and package commands.

• The top-level commands include many of the most frequently used Maple commands, as well as an extensive list of mathematical functions.
• Packages contain related specialized commands in areas such as calculus, linear algebra, vector calculus, and code generation.

For a complete list of packages and commands, refer to the index/help help pages. For information on the Maple Help System, see The Maple Help System (page 37).

Top-Level Commands

To use a top-level command, enter its name followed by parentheses (()) containing any parameters. This is referred to as a calling sequence for the command. 

\[ \text{command(arguments)} \]

Note: In 1-D Math input, include a semicolon or colon at the end of the calling sequence.

For example, to differentiate an expression, use the diff command. The required parameters are the expression to differentiate, which must be specified first, and the independent variable.

\[ \text{diff}(\tan(x) \sin(x), x) \]
\[ (1 + \tan(x)^2) \sin(x) + \tan(x) \cos(x) \]

Mathematical Functions

For a complete list of commands that implement mathematical functions, such as Bessel and AiryAi, available in the library, refer to the initialfunctions help page.

\[ \frac{\text{BesselI}(0.1, 1)}{\text{AiryAi}(2.2)} \]
\[ 47.53037086 \]

For detailed information on the properties of a function, use the FunctionAdvisor command.

\[ \text{FunctionAdvisor}'definition', \text{BesselI} \]

\[ I_0(z) = \frac{z^a \text{hypergeom}(a; a+1; \frac{z^2}{4})}{\Gamma(a+1) 2^a}, \text{with no restrictions on } (a, z) \]

This definition is displayed using the typeset form of the Bessel function, the hypergeometric function (hypergeom) and the Gamma function (GAMMA). To see the function names rather than the typeset form, use lprint:

\[ \text{lprint}() \]

\[ \{\text{BesselI}(a, z) = z^a \text{hypergeom}([], [a+1], (1/4)*z^2)/(\text{GAMMA}(a+1)*2^a), '\text{with no restrictions on } '(a, z)\} \]

For detailed information on how to use a function in Maple, refer to its help page.
For example:

> ?Bessel

Another way to access help is to select the word for which you want help and use the shortcut key for context help, F2 (Control + Shift + ?, for Mac).

**Top Commands**

Here are a few of the most frequently used Maple commands. A complete list of top-level commands is available on the index/function help page.

**Table 3.1: Top Commands**

<table>
<thead>
<tr>
<th>Command Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>plot and plot3d</td>
<td>Create a two-dimensional and three-dimensional plot of functions.</td>
</tr>
<tr>
<td>solve</td>
<td>Solve one or more equations or inequalities for their unknowns.</td>
</tr>
<tr>
<td>fsolve</td>
<td>Solve one or more equations using floating-point arithmetic.</td>
</tr>
<tr>
<td>eval</td>
<td>Evaluate an expression at a given point.</td>
</tr>
<tr>
<td>evalf</td>
<td>Numerically evaluate expressions.</td>
</tr>
<tr>
<td>dsolve</td>
<td>Solve ordinary differential equations (ODEs).</td>
</tr>
<tr>
<td>int</td>
<td>Compute an indefinite or definite integral.</td>
</tr>
<tr>
<td>diff</td>
<td>Compute an ordinary or partial derivative, as the context dictates.</td>
</tr>
<tr>
<td>limit</td>
<td>Calculate the limiting value of a function.</td>
</tr>
<tr>
<td>sum</td>
<td>For symbolic summation. It is used to compute a closed form for an indefinite or definite sum.</td>
</tr>
<tr>
<td>assume/is</td>
<td>Set variable properties and relationships between variables. Similar functionality is provided by the assuming command.</td>
</tr>
<tr>
<td>assuming</td>
<td>Compute the value of an expression under assumptions.</td>
</tr>
<tr>
<td>simplify</td>
<td>Apply simplification rules to an expression.</td>
</tr>
<tr>
<td>factor</td>
<td>Factor a polynomial.</td>
</tr>
<tr>
<td>expand</td>
<td>Distribute products over sums.</td>
</tr>
<tr>
<td>normal</td>
<td>Normalize a rational expression.</td>
</tr>
<tr>
<td>convert</td>
<td>Convert an expression to a different type or form.</td>
</tr>
<tr>
<td>type</td>
<td>Type-checking command. In many contexts, it is not necessary to know the exact value of an expression; it suffices to know that an expression belongs to a broad class, or group, of expressions that share some common properties. These classes or groups are known as types.</td>
</tr>
<tr>
<td>series</td>
<td>Generalized series expansion.</td>
</tr>
<tr>
<td>map</td>
<td>Apply a procedure to each operand of an expression.</td>
</tr>
</tbody>
</table>

**Package Commands**

To use a package command, the calling sequence must include the package name, and the command name enclosed in square brackets ([ ]).

```maple
package[command](arguments)
```

If you are frequently using the commands in a package, load the package.

**To load a package:**

- Use the `with` command, specifying the package as an argument.

The `with` command displays a list of the package commands loaded (unless you suppress the output by entering a colon at the end of the calling sequence).
After loading a package, you can use the short form names of its commands. That is, you can enter the commands without specifying the package name.

For example, use the `NLPSolve` command from the `Optimization` package to find a local minimum of an expression and the value of the independent variable at which the minimum occurs.

```plaintext
> Optimization[NLPSolve](\frac{\sin(x)}{x}, x = 1..15)

[-0.0913252028230577, [x = 10.9041216489198]]
> with(Optimization);

[ImportMPS, Interactive, LPSolve, LSSolve, Maximize, Minimize, NLPSolve, QPSolve]

> NLPSolve(\frac{\sin(x)}{x}, x = 1..15)

[-0.0913252028230576718, [x = 10.9041216700744900]]
```

For more information on optimization, see `Optimization` (page 137).

To unload a package:

- Use the `unwith` command, specifying the package as an argument.

```plaintext
> unwith(Optimization)
```

Alternatively, use the `restart` command. The restart command clears Maple's internal memory. The effects include unassigning all names and unloading all packages. For more information, refer to the `restart` help page.

Note: To execute the examples in this manual, you may be required to use the unassign or restart command between examples.

Some packages contain commands that have the same name as a top-level command. For example, the `plots` package contains a `changecoords` command. Maple also contains a top-level `changecoords` command.

```plaintext
> with(plots):
```

After the plots package is loaded, the name `changecoords` refers to the `plots[changecoords]` command. To use the top-level `changecoords` command, unload the package or use the restart command. (For alternative methods of accessing the top-level command, see the `rebound` help page.)

**Top Packages**

Here are a few of the most frequently used Maple packages. A complete list of packages is available on the `index/package` help page.

**Table 3.2: Top Packages**

<table>
<thead>
<tr>
<th>Package Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CodeGeneration</td>
<td>The <code>CodeGeneration</code> package is a collection of commands and subpackages that enable the translation of Maple code to other programming languages, such as C, C#, Fortran, MATLAB®, Visual Basic®, Java™, Julia, Perl, and Python®.</td>
</tr>
<tr>
<td>LinearAlgebra</td>
<td>The <code>LinearAlgebra</code> package contains commands to construct and manipulate Matrices and Vectors, and solve linear algebra problems. <code>LinearAlgebra</code> routines operate on three principal data structures: Matrices, Vectors, and scalars.</td>
</tr>
<tr>
<td>Package Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Optimization</td>
<td>The <strong>Optimization</strong> package is a collection of commands for numerically solving optimization problems, which involve finding the minimum or maximum of an objective function possibly subject to constraints.</td>
</tr>
<tr>
<td>Physics</td>
<td>The <strong>Physics</strong> package implements computational representations and related operations for most of the objects used in mathematical physics computations.</td>
</tr>
<tr>
<td>RealDomain</td>
<td>The <strong>Real Domain</strong> package provides an environment in which Maple assumes that the basic underlying number system is the field of real numbers instead of the complex number field.</td>
</tr>
<tr>
<td>ScientificConstants</td>
<td>The <strong>Scientific Constants</strong> package provides access to the values of various physical constants, for example, the velocity of light and the atomic weight of sodium. This package provides the units for each of the constant values, allowing for greater understanding of an equation. The package also provides units-matching for error checking of the solution.</td>
</tr>
<tr>
<td>ScientificErrorAnalysis</td>
<td>The <strong>Scientific Error Analysis</strong> package provides representation and construction of numerical quantities that have a central value and an associated uncertainty (or error), which is a measure of the degree of precision to which the quantity's value is known. Various first-order calculations of error analysis can be performed with these quantities.</td>
</tr>
<tr>
<td>Statistics</td>
<td>The <strong>Statistics</strong> package is a collection of tools for mathematical statistics and data analysis. The package supports a wide range of common statistical tasks such as quantitative and graphical data analysis, simulation, and curve fitting.</td>
</tr>
<tr>
<td>Student</td>
<td>The <strong>Student</strong> package is a collection of subpackages designed to assist with teaching and learning standard undergraduate mathematics. The many commands display functions, computations, and theorems in various ways, including stepping through important computations.</td>
</tr>
<tr>
<td></td>
<td>The <strong>Student</strong> package contains the following subpackages:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Basics</strong> - fundamental math concepts</td>
</tr>
<tr>
<td></td>
<td>• <strong>Calculus1</strong> - single-variable calculus</td>
</tr>
<tr>
<td></td>
<td>• <strong>LinearAlgebra</strong> - linear algebra</td>
</tr>
<tr>
<td></td>
<td>• <strong>MultivariateCalculus</strong> - multivariate calculus</td>
</tr>
<tr>
<td></td>
<td>• <strong>NumericalAnalysis</strong> - numerical analysis</td>
</tr>
<tr>
<td></td>
<td>• <strong>Precalculus</strong> - precalculus</td>
</tr>
<tr>
<td></td>
<td>• <strong>Statistics</strong> - statistics</td>
</tr>
<tr>
<td></td>
<td>• <strong>VectorCalculus</strong> - multivariate vector calculus</td>
</tr>
<tr>
<td>Units</td>
<td>The <strong>Units</strong> package contains commands for unit conversion and provides environments for performing calculations with units. It accepts approximately 300 distinct unit names (for example, meters and grams) and over 550 units with various contexts (for example, standard miles and U.S. survey miles). Maple also contains two <strong>Units</strong> palettes that allow you to enter the unit for an expression quickly.</td>
</tr>
<tr>
<td>VectorCalculus</td>
<td>The <strong>Vector Calculus</strong> package is a collection of commands that perform multivariate and vector calculus operations. A large set of predefined orthogonal coordinate systems is available. All computations in the package can be performed in any of these coordinate systems. It contains a facility for adding a custom but orthogonal coordinate system and using that new coordinate system for your computations.</td>
</tr>
</tbody>
</table>

### 3.4 Palettes

Palettes are collections of related items that you can insert by clicking or dragging. For example, see **Figure 3.1**.
You can use palettes to enter input.

For example, evaluate a definite integral using the definite integration item in the Calculus palette.

In 2-D Math, clicking the definite integration item inserts:

```
> \int_{x_1}^{x_2} f \, dx
```

1. Enter values in the placeholders. To move to the next placeholder, press Tab.
2. To evaluate the integral, press Enter.

```
> \int_{0}^{1} \tanh(x) \, dx
```

\[-\ln(2) + \ln(e^{-1} + e)\]

In 1-D Math, clicking the definite integration item inserts the corresponding command calling sequence.

```
> \text{int}(f, x = x[1]..x[2]);
```

Specify the problem values (using the Tab to move to the next placeholder), and then press Enter. Note: If pressing the Tab key inserts a tab, under the Format menu, toggle Tab Navigation. Then the Tab key will move the cursor to the next placeholder.

```
> \text{int}(\tanh(x), x = 0..1);
```

\[-\ln(2) + \ln(e^{-1} + e)\]

Note: Some palette items cannot be inserted into 1-D Math because they are not defined in the Maple language. When the cursor is in 1-D Math input, unavailable palette items are dimmed.

For more information on viewing and using palettes, see Palettes (page 15) in Chapter 1.
3.5 The Context Panel

The context panel is a collection of tools and operations that are appropriate for a particular expression. The context panel changes according to the expression, table, or region that you click on. See Figure 3.2.

![Figure 3.2: Integer Context Panel](image)

You can use the context panel to perform operations on 2-D Math, including output.

To use the context panel:
1. Click the expression.
2. Move your mouse cursor over Pin Open Context Panel ( ), or click it to fix the context panel in place.
3. From the context panel, select a tool or operation.

Maple inserts a new execution group containing:
- The calling sequence that performs the operation
- The result of the operation

Example - Using the Context Panel

Determine the rational expression (fraction) that approximates the floating-point number 0.3463678 + 1.7643.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
</table>
| 1. Enter and execute the expression. | \[ > 0.3463678 + 1.7643 \]
| 2. Click the output floating-point number. | \[ > 0.3463678 + 1.7643 \]
| 3. From the context panel, select Conversions \rightarrow\text{Rational}. The inserted calling sequence includes an equation label reference to the number you are converting. | convert\((3.3)\), 'rational' \\ \[ \begin{array}{c} 32270 \\ 15289 \end{array} \] |

Notice that an equation label reference has been used. For information on equation labels and equation label references, see Equation Labels (page 68).
For more information on the Context Panel, see *Computing with the Context Panel* (page 48) in Chapter 2.

### 3.6 Assistants and Tutors

Assistants and tutors provide point-and-click interfaces with buttons, text input regions, and sliders. See Figure 3.3.

![Figure 3.3: ODE Analyzer Assistant](image)

**Launching an Assistant or Tutor**

**To launch an assistant or tutor:**

1. Open the *Tools* menu.
2. Select *Assistants* or *Tutors*.
3. Navigate to and select one of the assistants or tutors.

For more information on assistants and tutors, see *Assistants* (page 24) in Chapter 1.

### 3.7 Task Templates

Maple can solve a diverse set of problems. The task template facility helps you quickly find and use the commands required to perform common tasks.

After inserting a task template, specify the parameters of your problem in the placeholders, and then execute the commands, or click a button.

The *Task Browser* (Figure 3.4) organizes task templates by subject.

**To launch the Task Browser:**

- From the *Tools* menu, select *Tasks*, and then *Browse*.

You can also browse the task templates in the Table of Contents of the Maple Help System.
For details on inserting and using task templates, see Task Templates (page 27). You can also create your own task templates for performing common tasks. For details, refer to the creatingtasks help page.

3.8 Text Regions

To add descriptive text in Worksheet mode, use a text region.

To insert a text region:

- In the toolbar, click the Text region icon $T$.

The default mode in a text region is Text mode.
In a text region, you can:

- Enter text with inline mathematical content by switching between Text and Math modes. To toggle between Text mode and Math mode, press F5 or click the Math and Text toolbar icons.

  **Note:** To change a math region to nonexecutable mathematical content, use Shift + F5.

- Insert any palette item. Palette items are inserted in Math mode (2-D Math). **Note:** After you insert a palette item, you must press F5 or click the toolbar icon to return to Text mode.

You can format text in a text region. Features include:

- Character styles
- Paragraph styles
- Sections and subsections
- Tables

For more information on formatting documents, see *Creating Mathematical Documents* (page 221).

### 3.9 Names

Instead of re-entering an expression every time you need it, you can assign it to a name or add an equation label to it. Then you can quickly refer to the expression using the name or an equation label reference. For information on labels, see the following section, *Equation Labels* (page 68).

**Note:** Through the Variable Manager you can manage the top-level assigned variables currently active in your Maple Session. For more information about the Variable Manager, see the Variable Manager help page. For Maple workbooks, you can use the Variable Manager palette to return to the saved state of your variables.

**Assigning to Names**

You can assign any Maple expression to a name: numeric values, data structures, procedures (a type of Maple program), and other Maple objects.

Initially, the value of a name is itself.

```maple
> a

a
```

The assignment operator := associates an expression with a name.

```maple
> a := π

a := π
```

Recall that you can enter $\pi$ using the following two methods.

- Use the Common Symbols palette.
- In 2-D Math enter $\pi$, and then press the symbol completion shortcut key. See *Shortcuts for Entering Mathematical Expressions* (page 5).
When Maple evaluates an expression that contains a name, it replaces the name with its value. For example:

```plaintext
> cos(a)
-1
```

For information on Maple evaluation rules, see Evaluating Expressions (page 279).

**Mathematical Functions**

To define a function, assign it to a name.

For example, define a function that computes the cube of its argument.

```plaintext
> cube := x -> x^3:
```

For information on creating functions, see Example 2 - Define a Mathematical Function (page 46).

```plaintext
> cube(3); cube(1.666)
27
4.624076296
```

**Note:** To insert the right arrow, enter the characters \texttt{->}. In 2-D Math, Maple replaces \texttt{->} with the right arrow symbol \texttt{→}. In 1-D Math, the characters are not replaced.

For example, define a function that squares its argument.

```plaintext
> square := x -> x^2:
> square(32);
1024
```

For more information on functions, see Functional Operators (page 268).

**Protected Names**

Protected names are valid names that are predefined or reserved.

If you attempt to assign to a protected name, Maple returns an error.

```plaintext
> sin := 2
```

Error, attempting to assign to `sin` which is protected. Try declaring `local sin`; see ?protect for details.

For more information, refer to the type/protected and protect help pages.

**Unassigning Names right single**

To unassign a name, reset the value of a name to itself. Right single quotes (unevaluation quotes) prevent Maple from evaluating the name.

```plaintext
> a := 'a'
> a
```

You can also use the unassign command. You must enclose the name in right single quotes (`'`).
> unassign( ' a' )

> a

a

For more information on the uses of unevaluation quotes, see Delaying Evaluation (page 285) or refer to the uneval help page.

**Unassigning all names:**

The **restart** command clears Maple's internal memory. The effects include unassigning all names. For more information, refer to the **restart** help page.

Note: To execute the examples in this manual, you may be required to use the unassign or restart command between examples.

**Valid Names**

A Maple name must be one of the following.

- A sequence of alphanumeric and underscore (_) characters that begins with an alphabetical character.
- A sequence of characters enclosed in left single quotes (' ').

**Important:** Do not begin a name with an underscore character. Maple reserves names that begin with an underscore for use by the Maple library.

Examples of valid names:

- a
- a1
- polynomial
- polynomial1_divided_by_polynomial2
- `2a`
- `x y`

**3.10 Equation Labels**

Maple marks the output of each execution group with a unique equation label.

**Note:** The equation label is displayed to the right of the output.

> \[ \int \sin(x) \, dx \]

\[ -\cos(x) \quad (3.4) \]

Using equation labels, you can refer to the result in other computations.

> \[ \int (3.4) \, dx \]

\[ -\sin(x) \quad (3.5) \]
Displaying Equation Labels

Important: By default, equation labels are displayed. If equation label display is turned off, complete both of the following operations.

- From the Format menu, select Equation Labels, and then ensure that Worksheet is selected.
- In the Options dialog (Tools→Options), on the Display tab, ensure that Show equation labels is selected.

Inserting Equation Labels

Instead of re-entering previous results in computations, you can use equation label references. Each time you need to refer to a previous result, insert an equation label reference.

You can insert equation labels by:

- Positioning your cursor where you want to insert the equation label, then double-click on the equation label you want to insert.
- Using the Label option from the Insert menu (or using the CTRL+L shortcut keys).

Insert an equation label reference using the double-click method:

1. Position your cursor where you want to insert the equation label.

   \[
   \int \sin(x) \, dx - \cos(x) \quad (1)
   \]

2. Double-click on the equation label you want to insert into your expression.

   \[
   \int \sin(x) \, dx - \cos(y) \quad (1)
   \]

3. The equation label is inserted into the expression at the location you selected.

   \[
   \int \sin(x) \, dx - \cos(x) \quad (1)
   \]

Insert an equation label reference using the Insert menu:

1. From the Insert menu, select Label. Alternatively, double-click on the equation label (to the far right side of the output) or press Ctrl+L, Command+L, Macintosh.
2. In the **Insert Label** dialog (see **Figure 3.5**), enter the label value, and then click **OK**.

![Figure 3.5: Insert Label Dialog](image)

Maple inserts the reference.

\[
> \int \sin(x) \, dx - \cos(x) \\
= \int (1) \, dx
\]

To integrate the product of \((3.4)\) and \((3.5)\):

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the <strong>Expression</strong> palette, click the indefinite integration item (\int f , dx). The item is inserted and the integrand placeholder is highlighted.</td>
<td>(&gt; \int f , dx)</td>
</tr>
</tbody>
</table>
| 2. Press Ctrl+L (Command+L, for Macintosh).  
3. In the **Insert Label** dialog, enter **3.4**. Click **OK**. | \(\int f \, dx\) |
| 4. Press *.  
5. Press Ctrl+L (Command+L, for Macintosh).  
6. In the **Insert Label** dialog, enter **3.5**. Click **OK**. | \(> \int (3.4) (3.5) \, dx\) |
7. To move to the variable of integration placeholder, press Tab.
8. Enter x.
9. To evaluate the integral, press Enter.

\[ > \int (3.4) \cdot (3.5) \, dx \]
\[ \frac{\sin(x)^2}{2} \]

**Execution Groups with Multiple Outputs**

An equation label is associated with the last output within an execution group.

\[ > \left( \frac{2}{3.5} \right)^2 \cos\left( \frac{\pi}{6} \right) \]
\[ 0.3265306122 \]
\[ \frac{1}{2} \sqrt{3} \]  

\[ > (3.7)^2 \]
\[ \frac{3}{4} \]

**Label Numbering Schemes**

You can number equation labels in two ways:

- **Flat** - Each label is a single number, for example, 1, 2, or 3.
- **Sections** - Each label is numbered according to the section in which it occurs. For example, 2.1 is the first equation in the second section, and 1.3.2 is the second equation in the third subsection of the first section.

To change the equation label numbering scheme:

- From the Format menu, select **Equation Labels → Label Display**. In the **Format Labels** dialog (Figure 3.6), select one of the formats.
- Optionally, enter a prefix.

[Figure 3.6: Format Labels Dialog: Adding a Prefix]

**Features of Equation Labels**

Although equation labels are not descriptive names, labels offer other important features.
• Each label is unique, whereas a name may be inadvertently assigned more than once for different purposes.

• Maple labels the output values sequentially. If you remove or insert an output, Maple automatically re-numbers all equation labels and updates the label references.

• If you change the equation label format (see Label Numbering Schemes (page 71)), Maple automatically updates all equation labels and label references.

For information on assigning to, using, and unassigning names, see Names (page 66).

For more information on equation labels, refer to the equationlabels help page.

The following chapters describe how to use Maple to perform tasks such as solving equations, producing plots and animations, and creating mathematical documents. The chapters were created using Worksheet mode. Except where noted, all features are available in both Worksheet mode and Document mode.
4 Basic Computations

This chapter discusses key concepts related to performing basic computations with Maple. It discusses important features that are relevant to all Maple users. After learning about these concepts, you will learn how to use Maple to solve problems in specific mathematical disciplines in the following chapter.

4.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Symbolic and Numeric Computation (page 74)</strong> - An overview of exact and floating-point computation</td>
<td>• Exact Computations</td>
</tr>
<tr>
<td></td>
<td>• Floating-Point Computations</td>
</tr>
<tr>
<td></td>
<td>• Converting Exact Quantities to Floating-Point Values</td>
</tr>
<tr>
<td></td>
<td>• Sources of Error</td>
</tr>
<tr>
<td><strong>Integer Operations (page 76)</strong> - How to perform integer computations</td>
<td>• Important Integer Commands</td>
</tr>
<tr>
<td></td>
<td>• Non-Base 10 Numbers</td>
</tr>
<tr>
<td></td>
<td>• Finite Rings and Fields</td>
</tr>
<tr>
<td></td>
<td>• Gaussian Integers</td>
</tr>
<tr>
<td><strong>Solving Equations (page 80)</strong> - How to solve standard mathematical equations</td>
<td>• Equations and Inequations</td>
</tr>
<tr>
<td></td>
<td>• Ordinary Differential Equations</td>
</tr>
<tr>
<td></td>
<td>• Partial Differential Equations</td>
</tr>
<tr>
<td></td>
<td>• Integer Equations</td>
</tr>
<tr>
<td></td>
<td>• Integer Equations in a Finite Field</td>
</tr>
<tr>
<td></td>
<td>• Linear Systems</td>
</tr>
<tr>
<td></td>
<td>• Recurrence Relations</td>
</tr>
<tr>
<td><strong>Units, Scientific Constants, and Uncertainty (page 93)</strong> - How to construct and compute with expressions that have units, scientific constants, or uncertainty</td>
<td><strong>Units</strong></td>
</tr>
<tr>
<td></td>
<td>• Conversions</td>
</tr>
<tr>
<td></td>
<td>• Applying Units to an Expression</td>
</tr>
<tr>
<td></td>
<td>• Performing Computations with Units</td>
</tr>
<tr>
<td></td>
<td>• Changing the Current System of Units</td>
</tr>
<tr>
<td></td>
<td>• Extensibility</td>
</tr>
<tr>
<td></td>
<td><strong>Scientific Constants</strong></td>
</tr>
<tr>
<td></td>
<td>• Scientific Constants</td>
</tr>
<tr>
<td></td>
<td>• Element and Isotope Properties</td>
</tr>
<tr>
<td></td>
<td>• Value, Units, and Uncertainty</td>
</tr>
<tr>
<td></td>
<td>• Performing Computations</td>
</tr>
<tr>
<td></td>
<td>• Modification and Extensibility</td>
</tr>
<tr>
<td></td>
<td><strong>Uncertainty Propagation</strong></td>
</tr>
<tr>
<td></td>
<td>• Quantities with Uncertainty</td>
</tr>
<tr>
<td></td>
<td>• Performing Computations with Quantities with Uncertainty</td>
</tr>
</tbody>
</table>
### 4.2 Symbolic and Numeric Computation

**Symbolic computation** is the mathematical manipulation of expressions involving symbolic or abstract quantities, such as variables, functions, and operators; and exact numbers, such as integers, rationals, π, and e^2. The goal of such manipulations may be to transform an expression to a simpler form or to relate the expression to other, better understood formulas.

**Numeric computation** is the manipulation of expressions in the context of finite-precision arithmetic. Expressions involving exact numbers, for example, \( \sqrt{2} \), are replaced by close approximations using floating-point numbers, for example 1.41421. These computations generally involve some error. Understanding and controlling this error is often of as much importance as the computed result.

In Maple, numeric computation is normally performed if you use floating-point numbers (numbers containing a decimal point) or the `evalf` command. The `plot` command (see *Plots and Animations (page 183)*) uses numeric computation, while commands such as `int`, `limit`, and `gcd` (see *Integer Operations (page 76) and Mathematical Problem Solving (page 109)*) generally use only symbolic computation to achieve their results.

### Exact Computations

In Maple, integers, rational numbers, mathematical constants such as π and ∞, and mathematical structures such as matrices with these as entries are treated as exact quantities. Names, such as `x`, `y`, `my_variable`, and mathematical functions, such as `sin(x)` and `LambertW(k, z)`, are *symbolic* objects. Names can be assigned exact quantities as their values, and functions can be evaluated at symbolic or exact arguments.

\[
> \frac{3}{2} + \frac{1}{3}, 1 + \frac{\pi}{2}
\]

\[
\frac{11}{6}, 1 + \frac{\pi}{2}
\]

**Important:** Unless requested to do otherwise (see the following section), Maple evaluates expressions containing exact quantities to exact results, as you would do if you were performing the calculation by hand, and not to numeric approximations, as you normally obtain from a standard hand-held calculator.

\[
> \sin(1), \sin(\pi), \sin(x)
\]

\[
\sin(1), 0, \sin(x)
\]

\[
> \int \tan(t) \ dt
\]

\[
-\ln(\cos(t))
\]

\[
> \sqrt{32}
\]

\[
4 \sqrt{2}
\]
Floating-Point Computations

In some situations, a numeric approximation of an exact quantity is required. For example, the `plot` command requires the expression it is plotting to evaluate to numeric values that can be rendered on the screen: \( \pi \) cannot be so rendered, but 3.14159 can be. Maple distinguishes *approximate* from *exact* quantities by the presence or absence of a decimal point: 1.9 is approximate, while \( \frac{19}{10} \) is exact.

**Note:** An alternative representation of floating-point numbers, called *e-notation*, may not include an explicit decimal point: \( 1e5 = 100000 \), \( 3e-2 = .03 \).

In the presence of a floating-point (approximate) quantity in an expression, Maple generally computes using numeric approximations. Arithmetic involving mixed exact and floating-point quantities results in a floating-point result.

\[
> 1.5 + \frac{2}{3}, 1 + 0.5 \cdot \pi
\]

\[
2.16666666, 2.570796327
\]

If a mathematical function is passed a floating-point argument, it normally attempts to produce a floating-point approximation of the result.

\[
> \sin(1.5), \int_{0}^{1.0} e^{x} \, dx
\]

\[
0.997494986, 1.718281828
\]

Converting Exact Quantities to Floating-Point Values

To convert an exact quantity to a numeric approximation of that quantity, use the `evalf` command or the `Approximate` context panel operation (see *Approximating the Value of an Expression* (page 50)).

\[
> \text{evalf}(\pi), \text{evalf}(\sin(3)), \text{evalf}\left(\frac{3}{2} + \frac{1}{3}\right)
\]

\[
3.141592654, 0.1411200081, 1.833333333
\]

By default, Maple computes such approximations using 10 digit arithmetic. You can modify this in one of two ways:

- **Locally,** you can pass the precision as an index to the `evalf` call.

\[
> \text{evalf}[20](\exp(2)), \text{evalf}\left(\Gamma\left(\frac{2}{3}\right)\right)
\]

\[
7.3890560989306502272, 1.354117939
\]

- **Globally,** you can set the value of the `Digits` environment variable.

\[
> \text{Digits} := 25 ;
\]

\[
> \text{evalf}\left(\tan\left(\frac{\pi}{3}\right)\right)
\]

\[
1.732050807568877293527446
\]

- Set the value back to the default Digits level:
> Digits := 10:

For more information, see the evalf and Digits help pages.

**Note:** When appropriate, Maple performs floating-point computations directly using your computer’s underlying hardware.

**Sources of Error**

By its nature, floating-point computation normally involves some error. Controlling the effect of this error is the subject of active research in *Numerical Analysis*. Some sources of error are:

- An exact quantity may not be exactly representable in decimal form: $\frac{1}{3}$ and $\pi$ are examples.
- Small errors can accumulate after many arithmetic operations.
- Subtraction of nearly equal quantities can result in essentially no useful information. For example, consider the computation $x - \sin(x)$ for $x \approx 0$.

> (x - sin(x)) | x = .00001

0.

No correct digits remain. If, however, you use Maple to analyze this expression, and replace this form with a representation that is more accurate for small values of $x$, a fully accurate 10-digit result can be obtained.

> t := taylor(x - sin(x), x)

\[
t := \frac{1}{6} x^3 - \frac{1}{120} x^5 + O(x^7)
\]

> t | x = 0.00001

1.666666667 \times 10^{-16}

For information on evaluating an expression at a point, see *Substituting a Value for a Subexpression* (page 279). For information on creating a series approximation, see *Series* (page 133). For more information on floating-point numbers, refer to the *float* and *type/float* help pages.

**4.3 Integer Operations**

In addition to the basic arithmetic operators, Maple has many specialized commands for performing more complicated integer computations, such as factoring an integer, testing whether an integer is a prime number, and determining the greatest common divisor (GCD) of a pair of integers.

**Note:** Many integer operations are available as task templates (Tools→Tasks→Browse, under *Integers*).

You can quickly perform many integer operations using the context panel. Clicking on an integer displays the context panel with integer commands. For example, the context-sensitive operation *Integer Factors* applies the *ifactor* command to compute the prime factorization of the given integer. See *Figure 4.1*. 
The result of applying \textbf{Integer Factors} is shown:

\begin{verbatim}
> 9469629

9469629
\end{verbatim}  

(4.1)

> \texttt{ifactor(4.1)}

\begin{verbatim}
(3)^4 (13) (17) (23)^2
\end{verbatim}  

(4.2)

Maple inserts the command \texttt{ifactor}, using an equation label reference to the integer 946929. For more information on equation labels, see \textit{Equation Labels (page 68)}.

For more information on using context-sensitive operations in Worksheet mode, see \textit{The Context Panel (page 63)}. For information on using context-sensitive operations in Document mode, see \textit{Computing with the Context Panel (page 48)}.

Maple has many other integer commands, including those listed in \textbf{Table 4.1}.

\begin{table}[h]
\centering
\begin{tabular}{|l|l|}
\hline
\textbf{Command} & \textbf{Description} \\
\hline
abs & absolute value (displays in 2-D math as $|a|$) \\
\hline
factorial & factorial (displays in 2-D math as $a!$) \\
\hline
ifactor & prime factorization \\
\hline
igcd & greatest common divisor \\
\hline
iquo & quotient of integer division \\
\hline
irem & remainder of integer division \\
\hline
iroot & integer approximation of nth root \\
\hline
isprime & test primality \\
\hline
isqrt & integer approximation of square root \\
\hline
max, min & maximum and minimum of a set \\
\hline
mod & modular arithmetic (See \textit{Finite Rings and Fields (page 78)}) \\
\hline
NumberTheory[Divisors] & set of positive divisors \\
\hline
\end{tabular}
\caption{Select Integer Commands}
\end{table}
For information on finding integer solutions to equations, see Integer Equations (page 92).

Non-Base 10 Numbers and Other Number Systems

Maple supports:

• Non-base 10 numbers
• Finite ring and field arithmetic
• Gaussian integers

Non-Base 10 Numbers

To represent an expression in another base, use the convert command.

> convert(6000, 'binary')

\[1011101110000\]

> convert(34271, 'hex')

\[85DF\]

For information on enclosing keywords in right single quotes ('), see Delaying Evaluation (page 285).

You can also use the convert/base command.

> convert(34271, 'base', 16)

\[15, 13, 5, 8\]

Note: The convert/base command returns a list of digit values in order of increasing significance.

Finite Rings and Fields

Maple supports computations over the integers modulo m.

The mod operator evaluates an expression over the integers modulo m.
> 27 \textbf{mod} 4

\[
3
\]

By default, the \texttt{mod} operator uses positive representation (\texttt{modp} command). Symmetric representation is available using the \texttt{mods} command.

> \texttt{modp}(27, 4)

\[
3
\]

> \texttt{mods}(27, 4)

\[
-1
\]

For information on setting symmetric representation as the default, refer to the \texttt{mod} help page.

The modular arithmetic operators are listed in Table 4.2.

\textbf{Table 4.2: Modular Arithmetic Operators}

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>\texttt{+}</td>
<td>( &gt; 7 \ + \ 6 \texttt{ mod} 5 )</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[ 3 ]</td>
</tr>
<tr>
<td>Subtraction</td>
<td>\texttt{-}</td>
<td>( &gt; \texttt{mods}(3 - 16, 11) )</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[ -2 ]</td>
</tr>
<tr>
<td>Multiplication (displays in 2-D Math as ( \cdot ))</td>
<td>\texttt{^(-1)}</td>
<td>( &gt; 13 \cdot 5 \texttt{ mod} 3 )</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[ 2 ]</td>
</tr>
<tr>
<td>Multiplicative inverse (displays in 2-D Math as a superscript)</td>
<td>\texttt{^(-1)}</td>
<td>( &gt; 3^{(-1)} \texttt{ mod} 5 )</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[ 2 ]</td>
</tr>
<tr>
<td>Division (displays in 2-D Math as ( \frac{a}{b} ))</td>
<td>\texttt{/}</td>
<td>( &gt; \frac{2}{3} \texttt{ mod} 5 )</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[ 4 ]</td>
</tr>
<tr>
<td>Exponentiation(^1)</td>
<td>\texttt{&amp;^}</td>
<td>( &gt; (100&amp;^100) \texttt{ mod} 7 )</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[ 2 ]</td>
</tr>
</tbody>
</table>

\(^1\)To enter a caret (\( ^{\wedge} \)) in 2-D Math, enter a backslash character followed by a caret, that is, \texttt{^}. For information on solving an equation modulo an integer, see \textit{Integer Equations in a Finite Field} (page 92).

The \texttt{mod} operator also supports polynomial and matrix arithmetic over finite rings and fields. For more information, refer to the \texttt{mod} help page.

\textbf{Gaussian Integers}

Gaussian integers are complex numbers in which the real and imaginary parts are integers.

The \texttt{GaussInt} package contains commands that perform Gaussian integer operations.

The \texttt{GIfactor} command returns the Gaussian integer factorization.
In Maple, complex numbers are represented as \( a + bI \), where the uppercase \( I \) represents the imaginary unit \( \sqrt{-1} \).

You can also enter the imaginary unit using the following two methods.

- In the Common Symbols palette, click the \( \Im \), \( \imath \), or \( j \) item. See Palettes (page 15).
- Enter \( i \) or \( j \), and then press the symbol completion key. See Symbol Names (page 21).

Note that the output will still be displayed with \( I \), no matter what symbol was used for input. You can customize Maple's settings to use a different symbol for \( \sqrt{-1} \). For more information on entering complex numbers, including how to customize this setting, refer to the HowDoI/EnterAComplexNumber help page.

The \texttt{GIsqrt} command approximates the square root in the Gaussian integers.

\[
> \text{GaussInt}[\text{GIsqrt}](173 + 16 \, I)
\]

\[
(1 + 2 \, I) (41 - 66 \, I)
\]

For more information on Gaussian integers including a list of \texttt{GaussInt} package commands, refer to the \texttt{GaussInt} help page.

### 4.4 Solving Equations

You can solve a variety of equation types, including those described in Table 4.3.

<table>
<thead>
<tr>
<th>Equation Type</th>
<th>Solution Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equations and inequations</td>
<td>\texttt{solve} and \texttt{fsolve} commands</td>
</tr>
<tr>
<td>Ordinary differential equations</td>
<td>\texttt{ODE Analyzer Assistant} (and \texttt{dsolve} command)</td>
</tr>
<tr>
<td>Partial differential equations</td>
<td>\texttt{pdsolve} command</td>
</tr>
<tr>
<td>Integer equations</td>
<td>\texttt{isolve} command</td>
</tr>
<tr>
<td>Integer equations in a finite field</td>
<td>\texttt{msolve} command</td>
</tr>
<tr>
<td>Linear integral equations</td>
<td>\texttt{intsolve} command</td>
</tr>
<tr>
<td>Linear systems</td>
<td>\texttt{LinearAlgebra[LinearSolve]} command</td>
</tr>
<tr>
<td>Recurrence relations</td>
<td>\texttt{rsolve} command</td>
</tr>
</tbody>
</table>

**Note:** Many solve operations are available in the context panel and as task templates (Tools→Tasks→Browse). Most of this section focuses on other methods.

**Solving Equations and Inequations**

Using Maple, you can symbolically solve equations and inequations. You can also solve equations numerically.

**To solve an equation or set of equations using the context panel:**

1. Click the equation.
2. From the context panel, select \texttt{Solve} (or \texttt{Solve Numerically}). See Figure 4.2.
In Worksheet mode, Maple inserts a calling sequence that solves the equation followed by the solutions.

If you select \texttt{Solve}, Maple computes exact solutions.

\[
> \quad \frac{7}{3} x^2 - x = 12
\]

\[
\frac{7}{3} x^2 - x = 12
\]  

\[
> \quad \texttt{solve( (4.3) )}
\]

\[
\left\{ x = \frac{3}{14} + \frac{3\sqrt{113}}{14}, \quad x = \frac{3}{14} - \frac{3\sqrt{113}}{14} \right\}
\]  

If you select \texttt{Solve Numerically}, Maple computes floating-point solutions.

\[
> \quad \frac{7}{3} x^2 - x = 12
\]

\[
\frac{7}{3} x^2 - x = 12
\]  

\[
> \quad \texttt{fsolve( (4.5) )}
\]

\[
\{ x = -2.063602674 \}, \quad \{ x = 2.492174103 \}
\]
For information on solving equations and inequations symbolically using the `solve` command, see the following section. For information on solving equations numerically using the `fsolve` command, see Numerically Solving Equations (page 84).

**Symbolically Solving Equations and Inequations**

The `solve` command is a general solver that determines exact symbolic solutions to equations or inequations. The solutions to a single equation or inequation are returned as an expression sequence. For details, see Creating and Using Data Structures (page 263). If Maple does not find any solutions, the `solve` command returns the empty expression sequence.

```maple
> solve(x^2 + 3*x + 14 = 0)

\[-\frac{3}{2} + \frac{1}{2}\sqrt{47}, \ -\frac{3}{2} - \frac{1}{2}\sqrt{47}\]
```

In general, `solve` computes solutions in the field of complex numbers. To restrict the problem to only real solutions, see Restricting the Domain (page 103).

It is recommended that you verify the solutions returned by the `solve` command. For details, see Working with Solutions (page 85).

To return the solutions as a list, enclose the calling sequence in brackets ([ ]).

```maple
> [solve(x^2 + x = 256, y, x)]

\[-\frac{1}{2} + \frac{\sqrt{1 + 1024y}}{2}, \ -\frac{1}{2} - \frac{\sqrt{1 + 1024y}}{2}\]
```

**Expressions:** You can specify expressions instead of equations. The `solve` command automatically equates them to zero.

```maple
> solve(e^x + z)

\[-\text{LambertW}(1)\]
```

(In this case, the solution involves the LambertW function.)

**Multiple Equations:** To solve multiple equations or inequations, specify them as a list or set. For an introduction to both lists and sets, see Creating and Using Data Structures (page 263).

```maple
> solve([x*y^2 - y = 5, x > 0])

\[\{x = \frac{y + 5}{y^2}, \ -5 < y, y < 0\}, \ \{x = \frac{y + 5}{y^2}, 0 < y\}\]
```

```maple
> solve({x*y^2 - y = 5, x < 0})

\[\{x = \frac{y + 5}{y^2}, y < -5\}\]
```

**Solving for Specific Unknowns:** By default, the `solve` command returns solutions for all unknowns. You can specify the unknowns for which to solve.
To solve for multiple unknowns, specify them as a list.

\[ s = \frac{\sqrt{4r^3s + 20r^2 + 1} - 1}{2r} \]

Transcendental Equations: In general, the `solve` command returns one solution to transcendental equations.

\[ \text{equation1} := \sin(x) = \cos(x) \]

\[ \text{solve(equation1)} \]

\[ \frac{\pi}{4} \]

To produce all solutions, use the `allsolutions` option.

\[ \text{solve(equation1, allsolutions = true)} \]

\[ \frac{1}{4} \pi + \pi \_Z1\]
that you use the Maple numerical solver, \texttt{fsolve}. For information, see the following section, \textit{Numerically Solving Equations}.

For more information on the \texttt{solve} command, including how to solve equations defined as procedures and how to find parametric solutions, refer to the \texttt{solve/details} help page.

For information on verifying and using solutions returned by the \texttt{solve} command, see \textit{Working with Solutions (page 85)}.

\textbf{Numerically Solving Equations}

The \texttt{fsolve} command solves equations numerically. The behavior of the \texttt{fsolve} command is similar to that of the \texttt{solve} command.

\begin{verbatim}
> equation2 := z\cos(z) = 2:
> fsolve(equation2)

\end{verbatim}

\begin{verbatim}
\texttt{23.64662473} \hfill (4.8)
\end{verbatim}

\textbf{Note}: You can also numerically solve equations using the context panel. See \textit{Solving Equations and Inequations (page 80)}.

It is recommended that you verify the solutions returned by the \texttt{fsolve} command. For details, see \textit{Working with Solutions (page 85)}.

\textbf{Multiple Equations}: To solve multiple equations, specify them as a set. For more information, see \textit{Creating and Using Data Structures (page 263)}. The \texttt{fsolve} command solves for all unknowns.

\begin{verbatim}
> fsolve( \{ln(x) = y^2 + 1, x y = e^y\} )

\end{verbatim}

\begin{verbatim}
\texttt{\{x = 3.396618823, y = 0.4719962637\}}
\end{verbatim}

\textbf{Univariate Polynomial Equations}: In general, the \texttt{fsolve} command finds one real solution. However, for a univariate polynomial equation, the \texttt{fsolve} command returns all real roots.

\begin{verbatim}
> equation3 := y^4 - 3 y^2 - 2 y + 1:
> fsolve(equation3, y)

\end{verbatim}

\begin{verbatim}
\texttt{0.3365322739, 1.940392664}
\end{verbatim}

\textbf{Controlling the Number of Solutions}: To limit the number of roots returned, specify the \texttt{maxsols} option.

\begin{verbatim}
> fsolve(equation3, y,'maxsols'= 1)

\end{verbatim}

\begin{verbatim}
\texttt{0.3365322739}
\end{verbatim}

To find additional solutions to a general equation, use the \texttt{avoid} option to ignore known solutions.

\begin{verbatim}
> fsolve(equation2, z, 'avoid' = \{z = (4.8)\})

\end{verbatim}

\begin{verbatim}
\texttt{\{-2.498755763\}}
\end{verbatim}

\textbf{Complex Solutions}: To search for a complex solution or find all complex and real roots for a univariate polynomial, specify the \texttt{complex} option for the \texttt{fsolve} command.
If the \texttt{fsolve} command does not find any solutions, it is recommended that you specify a range in which to search for solutions, or specify an initial value.

\textbf{Range:} To search for a solution in a range, specify the range in the calling sequence. The range can be real or complex.

\begin{verbatim}
> fsolve(equation2, z, \{z = 100 .. 200\})
199.5011587
\end{verbatim}

The syntax for specifying a region in the complex plane is \texttt{lower-left point..upper-right point}.

\begin{verbatim}
> fsolve(equation3, y, \{y = -2 - I .. 0\}, 'complex');
-1.13846246879373 - 0.485062494059435 I
\end{verbatim}

\textbf{Initial Values:} You can specify a value for each unknown. The \texttt{fsolve} command uses these as initial values for the unknowns in the numerical method.

\begin{verbatim}
> fsolve(equation2, \{z = 100\})
\{z = 98.98037599\}
\end{verbatim}

For more information and examples, refer to the \texttt{fsolve/details} help page.

For information on verifying and using solutions returned by the \texttt{fsolve} command, see the following section, \textit{Working with Solutions}.

\section*{Working with Solutions}

\textbf{Verifying:} It is recommended that you always verify solutions (that the \texttt{solve} and \texttt{fsolve} commands return) using the \texttt{eval} command.

\begin{verbatim}
> equation4 := \sin(x) = -\cos(x):
> solve(equation4)
-\pi/4
\end{verbatim}

\begin{verbatim}
> eval(equation4, x = (4.10))
-\sqrt{2}/2 = -\sqrt{2}/2
\end{verbatim}

\begin{verbatim}
> equation5 := \cos(z) = 2/z:
\end{verbatim}
> \texttt{Isolve(equation5)}

\begin{equation}
-2.498755763 \\
\end{equation}

> \texttt{eval(equation5, \{z = (4.12)\})}

\begin{equation}
-0.8003983544 = -0.8003983540 \\
\end{equation}

For more information, see \textit{Substituting a Value for a Subexpression (page 279)}.

**Assigning the Value of a Solution to a Variable:** To assign the value of a solution to the corresponding variable as an \textit{expression}, you can use the \texttt{assign} command, which can turn an equation such as the numeric solution in (4.9), \{z = 98.98037599\}, into an assignment.

> \texttt{assign( (4.9) )}

> \texttt{z}

\begin{equation}
98.98037599 \\
\end{equation}

A word of caution, if you do this, \texttt{z} now has a value so you cannot afterwards treat it as an unknown unless you unassign it. The way to do that is

> \texttt{z := 'z';}

For more information on unassigning names, see \textit{Unassigning Names right single (page 67)}.

**Creating a Function from a Solution:** The \texttt{assign} command assigns a value as an expression to a name. It does \textbf{not} define a function. To convert a solution to a function, use the \texttt{unapply} command.

Consider one of the solutions for \texttt{q} to the equation \(q^2 - rs + \frac{q}{r} = 5\).

> \texttt{solutions := [solve(}q^2 - rs + \frac{q}{r} = 5, q\texttt{)]}

\begin{equation}
\texttt{solutions :=} \left[ \frac{-1 + \sqrt{4 r^3 s + 20 r^2 + 1}}{2 r}, \frac{-1 + \sqrt{4 r^3 s + 20 r^2 + 1}}{2 r} \right] \\
\end{equation}

> \texttt{f := unapply(solutions[1], r, s)}

\begin{equation}
f := (r, s) \mapsto \frac{-1 + \sqrt{4 r^3 s + 20 r^2 + 1}}{2 r} \\
\end{equation}

Here, \texttt{solutions[1]} selects the first element of the list of solutions. For more information on selecting elements, see \textit{Accessing Elements (page 263)}.

You can evaluate this function at symbolic or numeric values.
> f(x, y)

\[-1 + \sqrt{4 \, x^3 \, y + 20 \, x^2 + 1} \over 2 \, x\]

> f\left(\frac{1}{\sqrt{2}}, 1\right)

\[\sqrt{2} \, \left(-1 + \sqrt{2 + 11}\right) \over 2\]

> f(5.7, 2.1)

4.032680521587978641060188

For more information on defining and using functions, see *Functional Operators* (page 268).

**Other Specialized Solvers**

In addition to equations and inequations, Maple can solve other equations including:

- Ordinary differential equations (ODEs)
- Partial differential equations (PDEs)
- Integer equations
- Integer equations in a finite field
- Linear systems
- Recurrence relations

**Ordinary Differential Equations (ODEs)**

Maple can solve ODEs and ODE systems, including initial value and boundary value problems, symbolically and numerically.

**ODE Analyzer Assistant** The ODE Analyzer Assistant is a point-and-click interface to the Maple ODE solving routines.

**To open the ODE Analyzer:**

- From the Tools menu, select Tutors, Differential Equations, and then ODE Analyzer.

Maple inserts the `dsolve[interactive]()` calling sequence in the document. The ODE Analyzer Assistant (Figure 4.3) is displayed.
In the main ODE Analyzer Assistant window, you can define ODEs, initial or boundary value conditions, and parameters. To define derivatives, use the \texttt{diff} command. For example, \texttt{diff(x(t), t)} corresponds to $\frac{df}{dx}$, and \\
\texttt{diff(x(t), t, t)} corresponds to $\frac{d^2f}{dx^2}$. For more information on the \texttt{diff} command, see \textit{The diff Command (page 130)}.  

After defining an ODE, you can solve it numerically or symbolically.

To solve a system numerically using the ODE Analyzer Assistant:

1. Ensure that the conditions guarantee uniqueness of the solution.
2. Ensure that all parameters have fixed values.
3. Click the \textbf{Solve Numerically} button.
4. In the \textbf{Solve Numerically} window (Figure 4.4), you can specify the numeric method and relevant parameters and error tolerances to use for solving the problem.
5. To compute solution values at a point, click the \textbf{Solve} button.
To solve a system symbolically using the ODE Analyzer Assistant:

1. Click the **Solve Symbolically** button.
2. In the **Solve Symbolically** window (Figure 4.5), you can specify the method and relevant method-specific options to use for solving the problem.
3. To compute the solution, click the **Solve** button.
When solving numerically or symbolically, you can view a plot of the solution by clicking the **Plot** button.

- To plot the solution to a symbolic problem, all conditions and parameters must be set.
- To customize the plot, click the **Plot Options** button to open the **Plot Options** window.

To view the corresponding Maple commands as you solve the problem or plot the solution, select the **Show Maple commands** check box.

You can control the return value of the ODE Analyzer using the **On Quit, Return** drop-down list. You can select to return nothing, the displayed plot, the computed numeric procedure (for numeric solutions), the solution (for symbolic solutions), or the Maple commands needed to produce the solution values and the displayed plot.

For more information, refer to the **ODEAnalyzer** help page.

**The dsolve Command**

The ODE Analyzer provides a point-and-click interface to the Maple **dsolve** command.

For ODEs or systems of ODEs, the **dsolve** command can find:

- Closed form solutions
- Numerical solutions
• Series solutions
In addition, the \texttt{dsolve} command can find:
• Formal power series solutions to linear ODEs with polynomial coefficients
• Formal solutions to linear ODEs with polynomial coefficients
To access all available functionality, use the \texttt{dsolve} command directly. For more information, refer to the \texttt{dsolve} help page.

**Partial Differential Equations (PDEs)**
To solve a PDE or PDE system symbolically or numerically, use the \texttt{pdsolve} command. PDE systems can contain ODEs, algebraic equations, and inequations.

For example, solve the following PDE symbolically. For help entering a partial derivative, see \textit{Example 1 - Enter a Partial Derivative (page 44)}.

> \texttt{restart:}

> \texttt{x \left( \frac{\partial}{\partial y} f(x, y) \right) - y \left( \frac{\partial}{\partial x} f(x, y) \right) = 0}

\[ x \left( \frac{\partial}{\partial y} f(x, y) \right) - y \left( \frac{\partial}{\partial x} f(x, y) \right) = 0 \]  
(4.14)

> \texttt{pdsolve(4.14)}

\[ f(x, y) = f_1(x^2 + y^2) \]

The solution is an arbitrary univariate function applied to \( x^2 + y^2 \).

Maple generally prints only the return value, errors, and warnings during a computation. To print information about the techniques Maple uses, increase the \texttt{infolevel} setting for the command.

To return all information, set \texttt{infolevel} to 5.

> \texttt{infolevel[pdsolve] := 5:}

> \texttt{pdsolve(4.14)}

Checking arguments ... 
First set of solution methods (general or quasi general solution) 
- \texttt{trying characteristic strip method for first order PDEs}
  \texttt{characteristic strip method for first order PDEs successful}
- \texttt{First set of solution methods successful}
- \texttt{Returning a *general* solution}

\[ f(x, y) = f_1(x^2 + y^2) \]

For more information on solving PDEs, including numeric solutions and solving PDE systems, refer to the \texttt{pdsolve} help page.
Integer Equations

To find only integer solutions to an equation, use the \texttt{isolve} command. The \texttt{isolve} command finds solutions for all variables. For more information, refer to the \texttt{isolve} help page.

\begin{verbatim}
> isolve({x^2 + y = 13})
\end{verbatim}

\begin{verbatim}
{x = \_Z1, y = -\_Z1^2 + 13}
\end{verbatim}

Integer Equations in a Finite Field

To solve an equation modulo an integer, use the \texttt{msolve} command. The \texttt{msolve} command finds solutions for all variables. For more information, refer to the \texttt{msolve} help page.

\begin{verbatim}
> msolve({x^2 = 1}, 13)
\end{verbatim}

\begin{verbatim}
{x = 1}, {x = 12}
\end{verbatim}

Solving Linear Systems

To solve a linear system, use the \texttt{LinearAlgebra[LinearSolve]} command. The \texttt{LinearSolve} command returns the vector \texttt{x} that satisfies \(A \cdot x = B\). For more information, refer to the \texttt{LinearAlgebra[LinearSolve]} help page.

For example, construct an augmented matrix using the \texttt{Matrix} palette (see Creating Matrices and Vectors (page 116)) in which the first four columns contain the entries of \(A\) and the final column contains the entries of \(B\).

\begin{verbatim}
> linearystem :=
\end{verbatim}

\begin{verbatim}
\begin{bmatrix}
59 & 44 & 17 & 1 & 1 \\
10 & 25 & 2 & 100 & 2 \\
1 & 0 & 7 & 533 & 61 \\
98 & 21 & 3 & 100 & 50 \\
23 & 9 & 12 & 7 & 2178 \\
\end{bmatrix}
\end{verbatim}

\begin{verbatim}
> LinearAlgebra[LinearSolve](linearystem)
\end{verbatim}

\begin{verbatim}
\begin{bmatrix}
31753441047 \\
41858667400 \\
16991806239 \\
8371733480 \\
1489266217 \\
1674346696 \\
262603866 \\
209293337
\end{bmatrix}
\end{verbatim}

For more information on using Maple to solve linear algebra problems, see \textit{Linear Algebra} (page 116).

Solving Recurrence Relations

To solve a recurrence relation, use the \texttt{rsolve} command. The \texttt{rsolve} command finds the general term of the function. For more information, refer to the \texttt{rsolve} help page.
In addition to manipulating exact symbolic and numeric quantities, Maple can perform computations with units and uncertainties.

Maple supports hundreds of units, for example, miles, coulombs, and bars, and provides facilities for adding custom units.

Maple has a library of hundreds of scientific constants with units, including element and isotope properties.

To support computations with uncertainties, Maple propagates errors through computations.

**Units**

The **Units** package in Maple provides a library of units, and facilities for using units in computations. It is fully extensible so that you can add units and unit systems as required.

**Note:** Some unit operations are available as task templates (see Tools→Tasks→Browse) and through the context panel.

**Overview of Units**

A **dimension** is a measurable quantity, for example, length or force. The set of dimensions that are fundamental and independent are known as **base dimensions**.

In Maple, the base dimensions include length, mass, time, electric current, thermodynamic temperature, amount of substance, luminous intensity, information, and currency. For a complete list, enter and execute `Units[GetDimensions]()`.

Complex dimensions (or composite dimensions) measure other quantities in terms of a combination of base dimensions.

For example, the complex dimension force is a measurement of \( \frac{\text{mass} \cdot \text{length}}{\text{time}^2} \).

Each dimension, base or complex, has associated units. (Base units measure a base dimension. Complex units measure a complex dimension.) Maple supports over 40 units of length, including feet, miles, meters, angstroms, microns, and astronomical units. A length must be measured in terms of a unit, for example, a length of 2 parsecs.

**Table 4.4** lists some dimensions, their corresponding base dimensions, and example units.

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Base Dimensions</th>
<th>Example Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>time</td>
<td>second, minute, hour, day, week, month, year, millennium, blink, lune</td>
</tr>
<tr>
<td>Energy</td>
<td>( \frac{\text{length}^2 \cdot \text{mass}}{\text{time}^2} )</td>
<td>joule, electron volt, erg, watt hour, calorie, Calorie, British thermal unit</td>
</tr>
<tr>
<td>Electric potential</td>
<td>( \frac{\text{length}^2 \cdot \text{mass}}{\text{time}^2 \cdot \text{electric current}} )</td>
<td>volt, abvolt, statvolt</td>
</tr>
</tbody>
</table>

For the complete list of units (and their contexts and symbols) available for a dimension, refer to the corresponding help page, for example, the **Units/length** help page for the units of length.
Each unit has a *context*. The context differentiates between different definitions of the unit. For example, the standard and US survey miles are different units of length, and the second is a unit of time and of angle. You can specify the context for a unit by appending the context as an index to the unit, for example, \texttt{mile[US_survey]}. If you do not specify a context, Maple uses the default context.

Units are collected into systems, for example, the foot-pound-second (FPS) system and international system, or \textit{système international}, (SI). Each system has a default set of units used for measurements. In the FPS system, the foot, pound, and second are used to measure the dimensions of length, mass, and time. The unit of speed is the foot/second. In SI, the meter, kilogram, and second are used to measure the dimensions of length, mass, and time. The units of speed, magnetic flux, and power are the meter/second, weber, and watt, respectively.

**Unit Conversions**

To convert a value measured in a unit to the corresponding value in a different unit, use the \texttt{Units Converter}.

- From the Tools→Assistants menu, select \texttt{Units Converter}.

The \texttt{Units Converter} application (Figure 4.6) opens.

![Units Converter](Image)

**Figure 4.6: Units Converter Assistant**

To perform a conversion:

1. In the **Convert** text field, enter the numeric value to convert.
2. In the **Dimension** drop-down list, select the dimensions of the unit.
3. In the **From** and **To** drop-down lists, select the original unit and the unit to which to convert.
4. Click **Perform Unit Conversion**.

The same conversion can be done with the \texttt{convert/units} command.

> \texttt{convert(1.0, 'units', 'lbf ft(radius)', 'N m(radius)')}

\begin{align*}
\text{1.355817948}
\end{align*}

Using the \texttt{Units Converter}, you can convert temperatures and temperature changes.

- To perform a *temperature* conversion, in the **Dimension** drop-down list, select \texttt{temperature(absolute)}.
- To perform a *temperature change* conversion, in the **Dimension** drop-down list, select \texttt{temperature(relative)}.

To convert temperature changes, the \texttt{Units Converter} uses the \texttt{convert/units} command. For example, an increase of 32 degrees Fahrenheit corresponds to an increase of almost 18 degrees Celsius.
To convert absolute temperatures, the Unit Converter uses the convert/temperature command. For example, 32 degrees Fahrenheit corresponds to 0 degrees Celsius.

```plaintext
> convert(32.0, 'units', 'degF', 'degC')
17.77777778
```

Applying Units to an Expression

To insert a unit, use the Units palette. See Figure 4.7.

![Figure 4.7: Units Palette](image)

To insert a unit:
- In the Units palette, select a unit dimension, then click the desired unit symbol.

```plaintext
> 3ft
3 ft
```

To insert a unit that is unavailable in the palettes:
1. In the Units palette, click the unit symbol. Maple inserts a Unit object with the placeholder selected.
2. In the placeholder, enter the unit name (or symbol). Note that you see double brackets around the unit when you are editing it.

For example, to enter 0.01 standard (the default context) miles, you can specify the unit name, mile, or symbol, mi.

As you edit, the unit is enclosed in double brackets: 0.01[mile]

```plaintext
> 0.01mile
0.01 mi
```

The context of a unit is displayed only if it is not the default context.

Alternative ways to enter units:
- Enter Unit, and then press the symbol completion key (see Symbol Names (page 21)) and then enter the unit.
- Use the shortcut key Ctrl + Shift + U (Command + Shift + U, on Mac) and then enter the unit.
• Use the `Unit` command. Note that to write a quantity with a unit using this command, write multiplication between them; this is especially evident in 1-D math:

**Important:** In 1-D Math input, the quantity and unit (entered using the top-level `Unit` command) are a product, not a single entity. The following calling sequences define different expressions.

\[
> 1 \ Unit(m)/(2 \ Unit(s)); \\
\frac{1}{2} \text{ m s}
\]

Some units support prefixes. For example, SI units support prefixes to names and symbols. You can specify 1000 meters using kilometer or km. For more information, refer to the Units/prefixes help page.

\[
> 1.5 \ [\text{km}]_S\ \\
1.5 \text{ km}
\]

**Performing Computations with Units**

In the default Maple environment, you cannot perform computations with quantities that have units. You can perform only unit conversions. For more information about the default environment, refer to the Units/Default help page.

To compute with expressions that have units, you must load a Units environment: Simple, Standard, or Natural. It is recommended that you use the Simple environment, and that environment is loaded by default when you load the Units package:

\[
> \text{with(Units)}:
\]

Automatically loading the Units[Simple] subpackage

In the Simple Units environment, commands that support expressions with units return results with the correct units.

\[
> \text{area} := 3\text{ft} \cdot \frac{1}{8} \text{mile}
\]

\[
\text{area} := \frac{3}{8} \text{ ft mi}
\]

\[
> (\ -12 \sin(x) + x^2) \frac{\text{m}}{\text{s}}
\]

\[
(-12 \sin(x) + x^2) \frac{\text{m}}{\text{s}}
\]

(4.15)

\[
> \text{int}(4.15, x)
\]

\[
\left(\frac{x^3}{3} + 12 \cos(x)\right) \frac{\text{m}}{\text{s}}
\]

(4.16)

\[
> \text{diff}(4.16, xs)
\]

\[
(-12 \sin(x) + x^2) \frac{\text{m}}{\text{s}^2}
\]

For information on differentiation and integration, see Calculus (page 128).
Changing the Current System of Units

If a computation includes multiple units, all units are expressed using units from the current system of units.

\[
> 132.25 \text{mile} \\
132.25 \text{ mi}
\]

(4.17)

By default, Maple uses the SI system of units, in which length is measured in meters and time is measured in seconds.

\[
> \frac{\text{(4.17)}}{3 \text{hour}}
\]

\[
19.70701333 \frac{\text{m}}{\text{s}}
\]

To view the name of the default system of units, use the \texttt{Units[UsingSystem]} command or view the current selection for \texttt{Choose System}, under the \texttt{Convert Output Units} section of the context panel.

\[
> \text{with(Units)}:
\]

\texttt{Automatically loading the Units[Simple] subpackage}

\[
> \text{UsingSystem(} \)
\]

\texttt{SI}

To change the system of units, use the \texttt{Units[UseSystem]} command or click the output and then select the desired system of units in the \texttt{Choose System} list, under the \texttt{Convert Output Units} section of the context panel.

\[
> \text{UseSystem(FPS)}:
\]

\[
> (4.17) \cdot 3 \text{m} \cdot 1.1\text{kg}
\]

\[
1.666720741 \times 10^7 \text{ ft}^2 \text{ lb}
\]

Extensibility

You can extend the set of:
- Base dimensions and units
- Complex dimensions
- Complex units
- Systems of units

For more information, refer to the \texttt{Units[AddBaseUnit], Units[AddDimension], Units[AddUnit], and Units[AddSystem]} help pages.

For more information about units, refer to the \texttt{Units} help page.

Scientific Constants and Element Properties

Computations often require not only units (see \textit{Units (page 93)}), but also the values of scientific constants, including properties of elements and their isotopes. Maple supports computations with scientific constants. You can use the built-in constants and add custom constants.
Overview of Scientific Constants and Element Properties

The ScientificConstants package provides the values of constant physical quantities, for example, the velocity of light and the atomic weight of sodium. The ScientificConstants package also provides the units for the constant values, allowing for greater understanding of the equation as well as unit-matching for error checking of the solution.

The quantities available in the ScientificConstants package are divided into two distinct categories.

- Physical constants
- Chemical element (and isotope) properties

Scientific Constants

List of Scientific Constants

You have access to scientific constants important in engineering, physics, chemistry, and other fields. Table 4.5 lists some of the supported constants. For a complete list of scientific constants, refer to the ScientificConstants/Physical-Constants help page.

Table 4.5: Scientific Constants

<table>
<thead>
<tr>
<th>Name</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Newtonian constant of gravitation</td>
<td>G</td>
</tr>
<tr>
<td>Planck constant</td>
<td>h</td>
</tr>
<tr>
<td>elementary_charge</td>
<td>e</td>
</tr>
<tr>
<td>Bohr radius</td>
<td>a[0]</td>
</tr>
<tr>
<td>deuteron magnetic moment</td>
<td>mu[d]</td>
</tr>
<tr>
<td>Avogadro constant</td>
<td>N[A]</td>
</tr>
<tr>
<td>Faraday constant</td>
<td>F</td>
</tr>
</tbody>
</table>

You can specify a constant using either its name or symbol.

Accessing Constant Definition

The GetConstant command in the ScientificConstants package returns the complete definition of a constant.

To view the definition of the Newtonian gravitational constant, specify the symbol G (or its name) in a call to the GetConstant command.

> with(ScientificConstants):

> GetConstant('G')

Newtonian constant of gravitation, symbol = G, value = 6.67408 \times 10^{-11}, uncertainty = 3.1 \times 10^{-15}, units = \frac{m^3}{kg \cdot s^2}

For information on accessing a constant's value, units, or uncertainty, see Value, Units, and Uncertainty (page 99).

Element Properties

Maple also contains element properties and isotope properties.
Elements

Maple supports all 117 elements of the periodic table. Each element has a unique name, atomic number, and chemical symbol. You can specify an element using any of these labels. For a complete list of supported elements, refer to the `ScientificConstants/elements` help page.

Maple supports key element properties, including atomic weight (`atomicweight`), electron affinity (`electronaffinity`), and density. For a complete list of element properties, refer to the `ScientificConstants/properties` help page.

Isotopes

Isotopes, variant forms of an element that contain the same number of protons but a different number of neutrons, exist for many elements.

To see the list of supported isotopes for an element, use the `GetIsotopes` command.

```plaintext
> GetIsotopes('element' = 'Li')

Li[4], Li[5], Li[6], Li[7], Li[8], Li[9], Li[10], Li[11], Li[12]
```

Maple supports isotopes and has a distinct set of properties for isotopes, including abundance, binding energy (`bindingenergy`), and mass excess (`massexcess`). For a complete list of isotope properties, refer to the `ScientificConstants/properties` help page.

Accessing an Element or Isotope Property Definition

The `GetElement` command in the `ScientificConstants` package returns the complete definition of an element or isotope.

```plaintext
> GetElement('Li')

3, symbol = Li, name = lithium, names = {lithium}, density = [value = 0.534, uncertainty

= undefined, units = \(\text{g cm}^{-3}\) ], electronaffinity = [value = 0.6180, uncertainty = 0.0005, units

= eV], boilingpoint = [value = 1615., uncertainty = undefined, units = K], electronegativity

= [value = 0.98, uncertainty = undefined, units = 1], ionizationenergy = [value = 5.3917,

uncertainty = undefined, units = eV], atomicweight = [value = 6.941, uncertainty = 0.002,

units = amu], meltingpoint = [value = 453.65, uncertainty = undefined, units = K]
```

```plaintext
> GetElement('Li[4]')

Li[4], massexcess = [value = 25320.173, uncertainty = 212.132, units = keV], bindingenergy

= [value = 4618.058, uncertainty = 212.132, units = keV], atomicmass = [value

= 4.027182329 \times 10^{6}, uncertainty = 227.733, units = \mu\text{amu}]
```

Value, Units, and Uncertainty

To use constants or element properties, you must first construct a `ScientificConstants` object.

To construct a scientific constant, use the `Constant` command.

```plaintext
> G := Constant('G') :
```

To construct an element (or isotope) property, use the `Element` command.
Value

To obtain the value of a `ScientificConstants` object, use the `evalf` command.

```maple
> evalf(G)
1.069085060 \times 10^{-9}
```

```maple
> evalf(LiAtomicWeight)
2.541006042 \times 10^{-26}
```

**Note:** The value returned depends on the current system of units.

Units

To obtain the units for a `ScientificConstants` object, use the `GetUnit` command.

```maple
> GetUnit(G)
\frac{\text{ft}^3}{\text{lb s}^2}
```

```maple
> GetUnit(LiAtomicWeight)
\text{lb}
```

For information on changing the default system of units, for example, from SI to foot-pound-second, see *Changing the Current System of Units* (page 97).

Value and Units

If you are performing computations with units, you can access the value and units for a `ScientificConstants` object by specifying the `units` option when constructing the object, and then evaluating the object.

```maple
> evalf(Constant('G', units))
1.069085060 \times 10^{-9} \frac{\text{ft}^3}{\text{lb s}^2}
```

```maple
> evalf(Element('Li[5]', atomicmass, units))
1.835022162 \times 10^{-26} \text{lb}
```

Uncertainty

The value of a constant is often determined by direct measurement or derived from measured values. Hence, it has an associated uncertainty. To obtain the uncertainty in the value of a `ScientificConstants` object, use the `GetError` command.

```maple
> GetError(G)
```

```maple
> GetError(LiAtomicWeight)
```

```maple
> GetError(Element('Li[5]', atomicmass))
```
Performing Computations

You can use constant values in any computation. To use constant values with units, use a Units environment as described in Performing Computations with Units (page 96). For information on computing with quantities that have an uncertainty, see the following section.

Modification and Extensibility

You can change the definition of a scientific constant or element (or isotope) property.

For more information, refer to the ScientificConstants[ModifyConstant] and ScientificConstants[ModifyElement] help pages.

You can extend the set of:
- Constants
- Elements (and isotopes)
- Element (or isotope) properties

For more information, refer to the ScientificConstants[AddConstant], ScientificConstants[AddElement], and ScientificConstants[AddProperty] help pages.

For more information about constants, refer to the ScientificConstants help page.

Uncertainty Propagation

Some computations involve uncertainties (or errors). Using the ScientificErrorAnalysis package, you can propagate the uncertainty in these values through the computation to indicate the possible error in the final result.

The ScientificErrorAnalysis package does not perform interval arithmetic. That is, the error of an object does not represent an interval in which possible values must be contained. (To perform interval arithmetic, use the Tolerances package. For more information, refer to the Tolerances help page.) The quantities represent unknown values with a central tendency. For more information on central tendency, refer to any text on error analysis for the physical sciences or engineering.

Quantities with Uncertainty

Creating: To construct quantities with uncertainty, use the Quantity command. You must specify the value and uncertainty. The uncertainty can be defined absolutely, relatively, or in units of the last digit. For more information on uncertainty specification, refer to the ScientificErrorAnalysis[Quantity] help page.

The output displays the value and uncertainty of the quantity.

> restart:

> with(ScientificConstants): with(ScientificErrorAnalysis):
To specify the error in units of the last digit, the value must be of floating-point type.

To access the value and uncertainty of a quantity with uncertainty, use the `evalf` and `ScientificErrorAnalysis[GetError]` commands.

```
> evalf(Quantity(105.0, 12, 'uld'))
105.

> GetError(Quantity(105.0, 12, 'uld'))
3.15
```

**Rounding:** To round the error of a quantity with uncertainty, use the `ApplyRule` command. For a description of the predefined rounding rules, refer to the `ScientificErrorAnalysis/rules` help page.

```
> GetError(ApplyRule(Quantity(105.0, 12, 'uld'), 'round[2]'))
3.2
```

**Units:** Quantities with errors can have units. For example, the scientific constants and element (and isotope) properties in the `ScientificConstants` packages are quantities with errors and units.

To construct a new quantity with units and an uncertainty, include units in the `Quantity` calling sequence.

For an absolute error, you must specify the units in both the value and error.

```
> with(ScientificErrorAnalysis): with(Units[Standard]):
> Quantity(3.5 m, 0.1 m)
Quantity(3.5 m, 0.1 m)
```

For a relative error, you can specify the units in only the value.

```
> Quantity(3.5 m, 0.1, 'relative')
Quantity(3.5 m, 0.35 m)
```

For information on the correlation between, variance of, and covariance between quantities with uncertainty, refer to the `ScientificErrorAnalysis` help page.

**Performing Computations with Quantities with Uncertainty**

Many Maple commands support quantities with uncertainty.

```
> q1 := Quantity(31., 2.):
```
Compute the value of the derivative of $q1 \cdot x^2 + \sin(q2 \cdot x)$ at $x = \sin(\pi/4)$.

$$d1 := \text{diff}(q1 \cdot x^2 + \sin(q2 \cdot x), x)$$

$$d1 := 2 \cdot x \cdot \text{Quantity}(31., 2.) + \text{Quantity}(20., 1.) \cdot \cos(x \cdot \text{Quantity}(20., 1.))$$

$$d2 := \text{eval}(d1, x = \sin\left(\frac{\pi}{4}\right))$$

To convert the solution to a single quantity with uncertainty, use the `combine/errors` command.

$$\text{result} := \text{combine}(d2, 'errors')$$

The value of the result is:

$$\text{evalf}(\text{result})$$

43.74124725

The uncertainty of the result is:

$$\text{GetError}(\text{result})$$

14.42690612

Additional Information

For information on topics including:

• Creating new rounding rules,
• Setting the default rounding rule, and
• Creating a new interface to quantities with uncertainty,

refer to the ScientificErrorAnalysis help page.

4.6 Restricting the Domain

By default, Maple computes in the complex number system. Most computations are performed without any restrictions or assumptions on the variables. Maple often returns results that are extraneous or unsimplified when computing in the field of complex numbers. Using restrictions, you can more easily and efficiently perform computations in a smaller domain.

Maple has facilities for performing computations in the real number system and for applying assumptions to variables.

Real Number Domain

To force Maple to perform computations in the field of real numbers, use the RealDomain package.

The RealDomain package contains a small subset of Maple commands related to basic precalculus and calculus mathematics, for example, arccos, limit, and log, and the symbolic manipulation of expressions and formulae, for example, expand, eval, and solve. For a complete list of commands, refer to the RealDomain help page.

After you load the RealDomain package, Maple assumes that all variables are real. Commands return simplified results appropriate to the field of real numbers.
<table>
<thead>
<tr>
<th>Without Loading <strong>RealDomain</strong></th>
<th>After Loading <strong>RealDomain</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>In Maple's default environment, without loading <strong>RealDomain</strong>, the answers are correct for the entire complex field.</td>
<td>After loading <strong>RealDomain</strong>, the answers are simplified.</td>
</tr>
<tr>
<td>&gt; <code>simplify(\sqrt{x^2})</code></td>
<td>&gt; <code>simplify(\sqrt{x^2})</code></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>&gt; <code>\text{csgn}(x) \cdot x</code></td>
</tr>
<tr>
<td>&gt; <code>\ln(e^x)</code></td>
<td>&gt; <code>\ln(e^x)</code></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>&gt; <code>(1/5)</code></td>
<td>&gt; <code>(1/5)</code></td>
</tr>
<tr>
<td></td>
<td>&gt; <code>(-32)^{1/5}</code></td>
</tr>
<tr>
<td></td>
<td>&gt; <code>(-32)^{1/5}</code></td>
</tr>
<tr>
<td></td>
<td>&gt; <code>(-32)^{1/5}</code></td>
</tr>
<tr>
<td>&gt; <code>\text{arcsin}(e^x)</code></td>
<td>&gt; <code>\text{arcsin}(e^x)</code></td>
</tr>
<tr>
<td></td>
<td>&gt; <code>\text{arcsin}(e^x)</code></td>
</tr>
<tr>
<td></td>
<td>&gt; <code>\text{arcsin}(e^x)</code></td>
</tr>
</tbody>
</table>

Complex return values are excluded or replaced by **undefined**.

> `\text{simplify}(x^2 = -1)`                                                                      > `\text{simplify}(x^2 = -1)`
> `L, -L`                                                                                         > `\text{arcsin}(e^x)`

### Assumptions on Variables

To simplify problem solving, it is recommended that you always apply any known assumptions to variables. You can impose assumptions using the **assume** command. To apply assumptions for a single computation, use the **assuming** command.

**Note:** The **assume** and **assuming** commands are not supported by the **RealDomain** package.

### The assume Command

You can use the **assume** command to set variable properties, for example, `x::real`, and relationships between variables, for example, `x < 0` or `x < y`. For information on valid properties, refer to the **assume** help page. For information on the double colon (`::`) operator, refer to the **type** help page.

The **assume** command allows improved simplification of symbolic expressions, especially multiple-valued functions, for example, computing the square root.

To assume that `x` is a positive real number, use the following calling sequence. Then compute the square root of `x^2`.

\[ \sqrt{x^2} \rightarrow |x| \]
The trailing tilde (~) on the name \( x \) indicates that it carries assumptions.

When you use the `assume` command to place another assumption on \( x \), all previous assumptions are removed.

\[
> \text{assume}(x < 0): \sqrt{x^2} \\
\sqrt{x~^2}
\]

**Displaying Assumptions:** To view the assumptions on an expression, use the `about` command.

\[
> \text{about}(x)
\]

Originally \( x \), renamed \( x~: \)

is assumed to be: \( \text{RealRange}(-\infty, \text{Open}(0)) \)

**Imposing Multiple Assumptions:** To simultaneously impose multiple conditions on an expression, specify multiple arguments in the `assume` calling sequence.

\[
> \text{assume}(0 < x, x < 2)
\]

To specify additional assumptions without replacing previous assumptions, use the `additionally` command. The syntax of the `additionally` calling sequence is the same as that of the `assume` command.

\[
> \text{additionally}(x :: \text{integer}): \text{about}(x)
\]

Originally \( x \), renamed \( x~: \)

is assumed to be: \( 1 \)

The only integer in the open interval \( (0, 2) \) is \( 1 \).

**Testing Properties:** To test whether an expression always satisfies a condition, use the `is` command.

\[
> \text{assume}(15 < x, 7 < y): \text{is}(100 < x \cdot y)
\]

\[
\text{true}
\]

The following test returns \text{false} because there are values of \( x \) and \( y \) (\( x = 0 \), \( y = 10 \)) that satisfy the assumptions, but do not satisfy the relation in the `is` calling sequence.

\[
> \text{assume}(x :: \text{nonnegint}, 10 \leq y): \text{is}(10 < x + y)
\]

\[
\text{false}
\]

To test whether an expression can satisfy a condition, use the `coulditbe` command.

\[
> \text{coulditbe}(10 < x + y)
\]

\[
\text{true}
\]

**Removing Assumptions:** To remove all assumptions on a variable, unassign its name.

\[
> x := 'x': y := 'y':
\]
For more information, see Unassigning Names right single (page 67).

For more information on the assume command, refer to the assume help page.

**The assuming Command**

To perform a single evaluation under assumptions on the names in an expression, use the assuming command.

The syntax of the assuming command is `<expression> assuming <property or relation>`. Properties and relations are introduced in The assume Command (page 104).

The frac command returns the fractional part of an expression.

> frac(x) assuming x :: integer

0

Using the assuming command is equivalent to imposing assumptions with the assume command, evaluating the expression, and then removing the assumptions.

> about(x)

x:

nothing known about this object

If you do not specify the names to which to apply a property, it is applied to all names.

> \( \sqrt{\left( \frac{a}{b} \right)^2} \) assuming positive

\[ \sqrt{\frac{a^2}{b^2}} \]

Assumptions placed on names using the assume command are ignored by the assuming command, unless you include the additionally option.

> assume(x < 1)

> is(1 - x^2 > 0) assuming x > -1

false

> is(1 - x^2 > 0) assuming additionally, x > -1

true

The assuming command does not affect variables inside procedures. (For information on procedures, see Procedures (page 299).) You must use the assume command.
\[ f := \text{proc}(x) \sqrt{a^2} + x \text{ end proc}; \]

\[ f := \text{proc}(x) \text{ Units:-Standard:-} \text{ + `(RealDomain:-}\sqrt{\text{RealDomain:-}\text{ `^`}(a, 2)), x) \text{ end proc} \]

\[ > f(1) \text{ assuming } a > 0 \]

\[ \sqrt{a^2} + 1 \]

\[ > \text{assume}(a > 0): f(1) \]

\[ \sqrt{a^2} + 1 \]

For more information on the \texttt{assuming} command, refer to the \texttt{assuming} help page.
5 Mathematical Problem Solving

This chapter focuses on solving problems in specific mathematical disciplines. The areas described below are not all that Maple provides, but represent the most commonly used packages. Examples are provided to teach you how to use the different methods of calculation available in Maple, including tutors, assistants, commands, task templates, plotting, and context-sensitive operations.

The examples in this chapter assume knowledge of entering commands and mathematical symbols. For information, see Entering Expressions (page 14). For information on basic computations, including integer operations and solving equations, see Basic Computations (page 73).

5.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Algebra (page 109) - Performing algebra computations</td>
<td>• Polynomial Algebra</td>
</tr>
<tr>
<td>Linear Algebra (page 116) - Performing linear algebra computations</td>
<td>• Creating Matrices and Vectors</td>
</tr>
<tr>
<td></td>
<td>• Accessing Entries in Matrices and Vectors</td>
</tr>
<tr>
<td></td>
<td>• Linear Algebra Computations</td>
</tr>
<tr>
<td></td>
<td>• Student LinearAlgebra Package</td>
</tr>
<tr>
<td>Calculus (page 128) - Performing calculus computations</td>
<td>• Limits</td>
</tr>
<tr>
<td></td>
<td>• Differentiation</td>
</tr>
<tr>
<td></td>
<td>• Series</td>
</tr>
<tr>
<td></td>
<td>• Integration</td>
</tr>
<tr>
<td></td>
<td>• Differential Equations</td>
</tr>
<tr>
<td></td>
<td>• Calculus Packages</td>
</tr>
<tr>
<td>Optimization (page 137) - Performing optimization computations using the Optimization package</td>
<td>• Point-and-Click Interface</td>
</tr>
<tr>
<td></td>
<td>• Efficient Computation</td>
</tr>
<tr>
<td></td>
<td>• MPS(X) File Support</td>
</tr>
<tr>
<td>Statistics (page 141) - Performing statistics computations using the Statistics package</td>
<td>• Probability Distributions and Random Variables</td>
</tr>
<tr>
<td></td>
<td>• Statistical Computations</td>
</tr>
<tr>
<td></td>
<td>• Plotting</td>
</tr>
<tr>
<td>Teaching and Learning with Maple (page 145) - Student and Instructor resources for using Maple in an academic setting</td>
<td>• Student Packages and Tutors</td>
</tr>
<tr>
<td></td>
<td>• Study Guides</td>
</tr>
<tr>
<td></td>
<td>• Step by Step Solutions</td>
</tr>
<tr>
<td></td>
<td>• More Student and Instructor Resources</td>
</tr>
<tr>
<td>Clickable MathTM (page 157) - Solve math problems using some of the interactive methods available in Maple</td>
<td>• Step-by-Step examples</td>
</tr>
</tbody>
</table>

5.2 Algebra

Maple contains a variety of commands that perform integer operations, such as factoring and modular arithmetic, as described in Integer Operations (page 76). The following section describes Maple's support of polynomial algebra.

For information on matrix and vector algebra, see Linear Algebra (page 116).

For information directed to students of algebra or precalculus, see Teaching and Learning with Maple (page 145).
Polynomial Algebra

A Maple polynomial is an expression in powers of an unknown. Univariate polynomials are polynomials in one unknown, for example, \( x^3 - 2x + 13 \). Multivariate polynomials are polynomials in multiple unknowns, such as \( x^3 y - \frac{3}{2} x y^2 + 7x \).

The coefficients can be integers, rational numbers, irrational numbers, floating-point numbers, complex numbers, variables, or a combination of these types.

\[
> a x^2 + 7x - \frac{b}{2}
\]

\[
a x^2 + 7x - \frac{1}{2} b
\]

Arithmetic

The polynomial arithmetic operators are the standard Maple arithmetic operators excluding the division operator (/). (The division operator accepts polynomial arguments, but does not perform polynomial division.)

Polynomial division is an important operation. The quo and rem commands find the quotient and remainder of a polynomial division. See Table 5.1. (The quo and irem commands find the quotient and remainder of an integer division. For more information, see Integer Operations (page 76).)

### Table 5.1: Polynomial Arithmetic Operators

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>+</td>
<td>&gt; ((x^2 + 1)) + (3 (x^3 - 5x + 2))</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(3x^3 + x^2 - 5x + 3)</td>
</tr>
<tr>
<td>Subtraction</td>
<td>-</td>
<td>&gt; ((x^2 + 1)) - (3 (x^3 - 5x + 2))</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(-3x^3 + x^2 + 5x - 1)</td>
</tr>
<tr>
<td>Multiplication</td>
<td>*</td>
<td>&gt; ((x^2 + 1)) \cdot (3 (x^3 - 5x + 2))</td>
</tr>
<tr>
<td></td>
<td></td>
<td>((x^2 + 1) (3x^3 - 5x + 2))</td>
</tr>
<tr>
<td>Division: Quotient and Remainder</td>
<td>quo</td>
<td>&gt; (\text{quo}(2x^2 + x - 3, 3x + 5, x))</td>
</tr>
<tr>
<td></td>
<td>rem</td>
<td>(\frac{2x}{3} - \frac{7}{9})</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&gt; (\text{rem}(2x^2 + x - 3, 3x + 5, x))</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(\frac{8}{9})</td>
</tr>
<tr>
<td>Exponentiation</td>
<td>^</td>
<td>&gt; ((x^2 + 1))^3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>((x^2 + 1)^3)</td>
</tr>
</tbody>
</table>
You can specify multiplication explicitly by entering *, which displays in 2-D Math as \( \cdot \). In 2-D Math, you can also implicitly multiply by placing a space character between two expressions. In some cases, the space character is optional. For example, Maple interprets a number followed by a name as an implicit multiplication.

In 2-D Math, exponents display as superscripts.

To expand a polynomial, use the `expand` command.

\[
> \text{expand}(3 \, x^2 \cdot (3 \, x + 5) - (x^2 - 2))
\]

\[
9 \, x^3 + 14 \, x^2 + 2
\]

If you need to determine whether one polynomial divides another, but do not need the quotient, use the `divide` command. The `divide` command tests for exact polynomial division.

\[
> \text{divide}(x^4 y^2 + x^3 y^2 - x^2 y^2 + 13 \, x^2 + 13 \, x - 13 + y \cdot x^2 + x \cdot y - y, x^2 + x - 1)
\]

\[
\text{true}
\]

**Important:** You must insert a space character or a multiplication operator (\( \cdot \)) between adjacent variables names. Otherwise, they are interpreted as a single variable.

For example, without a space, \( x y \) is considered a single variable, and \( x \) does not divide the single variable \( x y \).

\[
> \text{divide}(x y, x)
\]

\[
\text{false}
\]

But, \( x \) divides the product of \( x \) and \( y \).

\[
> \text{divide}(x \, y, x); \text{divide}(x \, y, x)
\]

\[
\text{true}
\]

\[
\text{true}
\]

For information on polynomial arithmetic over finite rings and fields, refer to the `mod` help page.

**Sorting Terms**

To sort the terms of a polynomial, use the `sort` command.

\[
> p1 := x^2 + x^4 + x^3 - x:
\]

\[
> \text{sort}(p1)
\]

\[
x^4 + x^3 + x^2 - x
\]

**Note:** The `sort` command returns the sorted polynomial, and updates the order of the terms in the polynomial.

The terms of \( p1 \) are sorted.
To specify the unknowns of the polynomial and their ordering, include a list of names.

> \(p1\)

\[ x^4 + x^3 + x^2 - x \]

By default, the \texttt{sort} command sorts a polynomial by decreasing total degree of the terms.

> \(\text{sort}(a^2 x^3 + x^2 + x a + a + b, [a])\)

\[ x^3 a^2 + x a + a + x^2 + b \]

By default, the \texttt{sort} command sorts a polynomial by decreasing total degree of the terms.

> \(\text{sort}(a^2 x^3 + x^2 + x a + a + b, [x, b])\)

\[ a^2 x^3 + x^3 + a x + b + a \]

To sort the terms by pure lexicographic order, that is, first by decreasing order of the first unknown in the list option, and then by decreasing order of the next unknown in the list option, specify the \texttt{'plex'} option.

> \(\text{sort}(p2, [x, y], 'plex')\)

\[ x^3 + x^2 y + y^3 \]

For information on enclosing keywords in right single quotes ('), see \textit{Delaying Evaluation (page 285)}.

The first term contains \(x\) to the power 3; the second, \(x\) to the power 2; and the third, \(x\) to the power 0.

Using context-sensitive operations, you can perform operations, such as sorting, for polynomials and many other Maple objects.

\textbf{To sort a polynomial:}

1. Select the polynomial.
2. From the Context Panel, under the \texttt{Sorts} menu, select:
   - \texttt{Single-variable}, and then the unknown, or,
   - \texttt{Two-variable} (or \texttt{Three-variable}), \texttt{Pure Lexical} or \texttt{Total Degree}, and then the sort priority of the unknowns.

See \textit{Figure 5.1}. 

---

\( > p1 \)

\[ x^4 + x^3 + x^2 - x \]

To specify the unknowns of the polynomial and their ordering, include a list of names.

\( > \text{sort}(a^2 x^3 + x^2 + x a + a + b, [a]) \)

\[ x^3 a^2 + x a + a + x^2 + b \]

\( > \text{sort}(a^2 x^3 + x^2 + x a + a + b, [x, b]) \)

\[ a^2 x^3 + x^3 + a x + b + a \]

By default, the \texttt{sort} command sorts a polynomial by decreasing total degree of the terms.

\( > p2:=x^3 + y^3 + x^2 y^2: \)

\( > \text{sort}(p2, [x, y]) \)

\[ x^2 y^2 + x^3 + y^3 \]

The first term has total degree 4. The other two terms have total degree 3. The order of the final two terms is determined by the order of their names in the list.

To sort the terms by pure lexicographic order, that is, first by decreasing order of the first unknown in the list option, and then by decreasing order of the next unknown in the list option, specify the \texttt{'plex'} option.

\( > \text{sort}(p2, [x, y], 'plex') \)

\[ x^3 + x^2 y + y^3 \]

For information on enclosing keywords in right single quotes ('), see \textit{Delaying Evaluation (page 285)}.

The first term contains \(x\) to the power 3; the second, \(x\) to the power 2; and the third, \(x\) to the power 0.

Using context-sensitive operations, you can perform operations, such as sorting, for polynomials and many other Maple objects.

\textbf{To sort a polynomial:}

1. Select the polynomial.
2. From the Context Panel, under the \texttt{Sorts} menu, select:
   - \texttt{Single-variable}, and then the unknown, or,
   - \texttt{Two-variable} (or \texttt{Three-variable}), \texttt{Pure Lexical} or \texttt{Total Degree}, and then the sort priority of the unknowns.

See \textit{Figure 5.1}. 

Maple sorts the polynomial.

In Worksheet mode, Maple inserts the calling sequence that performs the sort followed by the sorted polynomial. For this example, choose **Sorts > Two-variable > Pure Lexical > y, x.**

\[
> x^3 + y^3 + x^2 y^2 \\
\rightarrow x^3 + x^2 y^2 + y^3 \quad (5.1)
\]

\[
> \text{sort}( y^3 + y^2 x^2 + x^3, [y, x], 'plex' ) \\
\rightarrow y^3 + x^2 y^2 + x^3 \quad (5.2)
\]
You can use the Context Panel to perform context-sensitive operations on 2-D Math content including output. For more information, see *Computing with the Context Panel (page 48)* (for Document mode) or *The Context Panel (page 63)* (for Worksheet mode).

**Collecting Terms**

To collect the terms of polynomial, use the `collect` command.

\[
> \text{collect} \left( 2\ a\ y + c\ x^2\ y - z\ y^2 + a\ z - 13\ b\ y + \frac{3\ y^2}{x}, y \right) \\
\left( -z + \frac{3}{x} \right) y^2 + (c\ x^2 + 2\ a\ x - 13\ b)\ y + a\ z
\]

**Coefficients and Degrees**

Maple has several commands that return coefficient and degree values for a polynomial. See Table 5.2.

**Table 5.2: Polynomial Coefficient and Degree Commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>coeff</code></td>
<td>Coefficient of specified degree term</td>
<td>( \text{coeff} \left( \frac{1}{2} x^3 - 2\ x + 5, x^2 \right) )</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1/2</td>
</tr>
<tr>
<td><code>lcoeff</code></td>
<td>Leading coefficient</td>
<td>( \text{lcoeff} \left( \frac{1}{2} x^3 - 2\ x + 5 \right) )</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1/2</td>
</tr>
<tr>
<td><code>tcoeff</code></td>
<td>Trailing coefficient</td>
<td>( \text{tcoeff} \left( \frac{1}{2} x^3 - 2\ x + 5 \right) )</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td><code>coeffs</code></td>
<td>Sequence of all coefficients, in one-to-one correspondence with the terms</td>
<td>( \text{coeffs} \left( \frac{1}{2} x^3 - 2\ x + 5 \right) )</td>
</tr>
<tr>
<td></td>
<td>Note: It does not return zero coefficients</td>
<td>5, -2, 1/2</td>
</tr>
<tr>
<td><code>degree</code></td>
<td>(Highest) degree</td>
<td>( \text{degree} \left( \frac{1}{2} x^3 - 2\ x + 5 \right) )</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3</td>
</tr>
<tr>
<td><code>ldegree</code></td>
<td>Lowest degree term with a non-zero coefficient</td>
<td>( \text{ldegree} \left( \frac{1}{2} x^3 - 2\ x \right) )</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1</td>
</tr>
</tbody>
</table>

**Factorization**

To express a polynomial in fully factored form, use the `factor` command.
> factor(x^4 - 1)

\[(x - 1) (x + 1) (x^2 + 1)\]

The `factor` command factors the polynomial over the ring implied by the coefficients, for example, integers. You can specify an algebraic number field over which to factor the polynomial. For more information, refer to the `factor` help page. (The `ifactor` command factors an integer. For more information, see `Integer Operations` (page 76).)

To solve for the roots of a polynomial, use the `solve` command. For information on the `solve` command, see `Solving Equations and Inequations` (page 80). (The `isolve` command solves an equation for integer solutions. For more information, see `Integer Equations` (page 92).)

**Other Commands**

Table 5.3 lists other commands available for polynomial operations.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>content</td>
<td>Content (multivariate polynomial)</td>
</tr>
<tr>
<td>compoly</td>
<td>Decomposition</td>
</tr>
<tr>
<td>discrim</td>
<td>Discriminant</td>
</tr>
<tr>
<td>gcd</td>
<td>Greatest common divisor (of two polynomials)</td>
</tr>
<tr>
<td>gcdex</td>
<td>Extended Euclidean algorithm (for two polynomials)</td>
</tr>
<tr>
<td>CurveFitting[PolynomialInterpolation]</td>
<td>Interpolating polynomial (for list of points)</td>
</tr>
<tr>
<td>lcm</td>
<td>Least common multiple (of two polynomials)</td>
</tr>
<tr>
<td>norm</td>
<td>Norm</td>
</tr>
<tr>
<td>prem</td>
<td>Pseudo-remainder (of two multivariate polynomials)</td>
</tr>
<tr>
<td>primpart</td>
<td>Primitive part (multivariate polynomial)</td>
</tr>
<tr>
<td>randpoly</td>
<td>Random polynomial</td>
</tr>
<tr>
<td>PolynomialTools[IsSelfReciprocal]</td>
<td>Determine whether self-reciprocal</td>
</tr>
<tr>
<td>resultant</td>
<td>Resultant (of two polynomials)</td>
</tr>
<tr>
<td>roots</td>
<td>Exact roots (over algebraic number field)</td>
</tr>
<tr>
<td>sqrfree</td>
<td>Square-free factorization (multivariate polynomial)</td>
</tr>
</tbody>
</table>

**Additional Information**

Table 5.4: Additional Polynomial Help

<table>
<thead>
<tr>
<th>Topic</th>
<th>Resource</th>
</tr>
</thead>
<tbody>
<tr>
<td>General polynomial information</td>
<td>polynom help page</td>
</tr>
<tr>
<td>PolynomialTools package</td>
<td>PolynomialTools package overview help page</td>
</tr>
<tr>
<td>Algebraic manipulation of numeric polynomials</td>
<td>SNAP (Symbolic-Numeric Algorithms for Polynomials) package overview help page</td>
</tr>
<tr>
<td>Polynomial information and commands</td>
<td>Maple Help System Table of Contents: Mathematics→Algebra→Polynomials section</td>
</tr>
</tbody>
</table>
5.3 Linear Algebra

Linear algebra operations act on Matrix and Vector data structures.

You can perform many linear algebra operations using task templates. In the Task Browser (Tools → Tasks → Browse), expand the Linear Algebra folder.

Creating Matrices and Vectors

Creating Matrices

You can create a Matrix using

• The Matrix command
• The angle bracket shortcut notation
• The Matrix palette (see Figure 5.2).

When creating a Matrix using the Matrix command, there are several input formats available. For example, enter a list of lists. The dimensions of the matrix are inferred from the number of entries given.

\[
\text{Matrix}\left(\begin{bmatrix} 1, \pi, 0, \frac{e^2 \sin(t) + \frac{87}{2}}{2}, 0, 0, 5e \end{bmatrix}\right)
\]

\[
\begin{bmatrix}
1 & \pi & 0 \\
e^2 & \sin(t) & \frac{87}{2} \\
0 & 0 & 5e
\end{bmatrix}
\]

Alternatively, use the angle bracket shortcut, <>. Separate items in a column with commas, and separate columns with vertical bars, |.

\[
\begin{bmatrix} 1, \pi, 0 | e^2, \sin(t), \frac{87}{2} | 0, 0, 5e \end{bmatrix}
\]

\[
\begin{bmatrix}
1 & e^2 & 0 \\
\pi & \sin(t) & 0 \\
0 & \frac{87}{2} & 5e
\end{bmatrix}
\]

For information on the Matrix command options, see Creating Matrices and Vectors with Specific Properties (page 120).
Use the Matrix palette to interactively create a matrix without commands:

**Figure 5.2: Matrix Palette**

In the Matrix palette, you can specify the matrix size (see Figure 5.3) and properties. To insert a matrix, click the Insert Matrix button.

**Figure 5.3: Matrix Palette: Choosing the Size**

**After inserting the matrix:**

1. Enter the values of the entries. To move to the next entry placeholder, press Tab.
2. After specifying all entries, press Enter.
Creating Vectors

You can create a Vector using angle brackets (< >).

To create a column vector, specify a comma-delimited sequence, \(<a, b, c>\). The number of elements is inferred from the number of expressions.

\[
> (1, 2, 3)
\]

\[
\begin{bmatrix}
1 \\
2 \\
3
\end{bmatrix}
\]

To create a row vector, specify a vertical-bar-delimited (|) sequence, \(<a | b | c>\). The number of elements is inferred from the number of expressions.

\[
> (1 | 2 | 3)
\]

\[
\begin{bmatrix}
1 & 2 & 3
\end{bmatrix}
\]

For information on the Vector command options, refer to the Vector help page.

You can also create vectors using the Matrix palette. If either the number of rows or number of columns specified is 1, then you have the option of inserting a matrix, or inserting a vector of the appropriate type. See Figure 5.4.

Figure 5.4: Insert Matrix or Insert Vector

Viewing Large Matrices and Vectors

Matrices \(10 \times 10\) and smaller, and vectors with 10 or fewer elements, display in the document. For larger matrices or vectors, a portion is shown inline.
For example, insert a $15 \times 15$ matrix.

**In the Matrix palette:**

1. Specify the dimensions: 15 rows and 15 columns.
2. In the *Type* drop-down list, select a matrix type, for example, *Random*.
3. Click *Insert Matrix*. The command is inserted; execute it to see the result.

\[
\begin{bmatrix}
19 & 67 & 60 & -60 & -60 & -13 & -33 & 54 & -1 & 41 & \ldots \\
87 & -55 & 79 & -24 & 77 & -35 & 79 & 31 & 21 & 18 & \ldots \\
33 & 14 & -26 & 37 & -65 & 88 & 93 & 32 & -10 & -9 & \ldots \\
79 & 5 & 1 & 28 & -84 & -72 & 40 & -31 & -82 & -92 & \ldots \\
-43 & -32 & -16 & -35 & 4 & -7 & 75 & -19 & 23 & -24 & \ldots \\
36 & 79 & -33 & 51 & 10 & -20 & 72 & -84 & 82 & -62 & \ldots \\
6 & 40 & -36 & 51 & -54 & -74 & 48 & -48 & 42 & -95 & \ldots \\
38 & 42 & -27 & -89 & 52 & 0 & -44 & -81 & -25 & 79 & \ldots \\
-55 & -38 & -17 & -23 & -94 & -19 & -46 & 93 & 16 & 72 & \ldots \\
41 & 25 & 9 & 21 & 43 & -43 & 80 & -28 & 73 & -60 & \ldots \\
\vdots & \vdots & \vdots & \vdots & \vdots & \vdots & \vdots & \vdots & \vdots & \vdots & \vdots
\end{bmatrix}
\]

$15 \times 15$ Matrix

To view the entire matrix or vector, double-click the summary placeholder. This launches the **Matrix Browser**. See Figure 5.5.
To modify the entries using the Matrix Browser:
1. Select the Table tab.
2. Double-click an entry, and then edit its value. Press Enter.
3. Repeat for each entry to edit.
4. When you have finished updating entries, click Done.

You can view the matrix or vector as a table or as an image, which can be inserted into the document. For more information, refer to the MatrixBrowser help page.

To set the maximum dimension of matrices and vectors displayed inline:
- Use the interface command with the rtablesize option.

For example, interface(rtablesize = 15).

For more information, refer to the interface help page.

Creating Matrices and Vectors with Specific Properties

By default, matrices and vectors can store any values. To increase the efficiency of linear algebra computations, create matrices and vectors with properties. You must specify the properties, for example, the matrix shape or data type, when defining the object.

The Matrix palette (Figure 5.2) supports several properties.

To specify the matrix type:
- Use the Shape and Type drop-down lists.
To specify the data type:

- Use the **Datatype** drop-down list.

For example, define a diagonal matrix with small integer coefficients.

**In the Matrix palette:**

1. Specify the size of the matrix, for example, $3 \times 3$.
2. In the **Shapes** drop-down list, select **Diagonal**.
3. In the **Datatype** drop-down list, select `integer[1]`.
4. Click the **Insert Matrix** button.
5. Enter the values in the diagonal entries.

$$
\begin{bmatrix}
-23 & 0 & 0 \\
0 & 17 & 0 \\
0 & 0 & 32
\end{bmatrix}
$$

You cannot specify properties when defining vectors using the angle-bracket notation. You must use the **Vector** constructor.

**To define a column vector using the Vector constructor, specify:**

- The number of elements. If you explicitly specify all element values, this argument is not required.
- A list of expressions that define the element values.
- Parameters such as `shape`, `datatype`, and `fill` that set properties of the vector.

The following two calling sequences are equivalent.

```maple
> Vector([0, 0, 0])

\begin{bmatrix}
0 \\
0 \\
0
\end{bmatrix}
```

```maple
> Vector(3, 'shape' = 'zero')

\begin{bmatrix}
0 \\
0 \\
0
\end{bmatrix}
```

To create a row vector using the **Vector** constructor, include `row` as an index.

```maple
> Vector[row](3,'fill'=1)

\begin{bmatrix}
1 & 1 & 1
\end{bmatrix}
```

```maple
> Vector[row]([127, 0, 34], 'datatype' = 'integer[1]')

\begin{bmatrix}
127 & 0 & 34
\end{bmatrix}
```

The **Matrix** palette does not support some properties. To set all properties, use the **Matrix** constructor.
To define a matrix using the Matrix constructor, specify:

- The number of rows and columns. If you explicitly specify all element values, these arguments are not required.
- A list of lists that define the element values row-wise.
- Parameters such as shape, datatype, and fill that set properties of the matrix.

For example:

\[
\text{Matrix}([[1, 2, 3], [4, 5, 6]])
\]

\[
\begin{bmatrix}
1 & 2 & 3 \\
4 & 5 & 6
\end{bmatrix}
\]

The Matrix palette cannot fill the matrix with an arbitrary value. Use the fill parameter.

\[
\text{Matrix}(3, 4, [[1, 2, 3], [4, 5, 6]], \text{`fill`} = 2 + \text{I})
\]

\[
\begin{bmatrix}
1 & 2 & 3 & 2 + \text{I} \\
4 & 5 & 6 & 2 + \text{I} \\
2 + \text{I} & 2 + \text{I} & 2 + \text{I} & 2 + \text{I}
\end{bmatrix}
\]

For more information on the constructors, including other calling sequence syntaxes and parameters, refer to the storage, Matrix, and Vector help pages.

See also Numeric Computations (page 128).

**Accessing Entries in Matrices and Vectors**

**Matrices**

To select an entry in a Matrix, enter the matrix name with a sequence of two non-zero integer indices, row first.

\[
\text{M} := \langle -4.3, -6.7, 1.9, 2.9, -1.2, 9.6, 9.3, -8.0, -9.2 \rangle
\]

\[
\begin{bmatrix}
-4.3 & 2.9 & 9.3 \\
-6.7 & -1.2 & -8.0 \\
1.9 & 9.6 & -9.2
\end{bmatrix}
\]

\[
\text{M}[1, 3] = 9.3
\]

To select an entire row, enter a single index; to select an entire column, enter first the entire range of rows, \(1..1\), then the column index.
Similarly, you can access submatrices. Enter the indices as a list or range.

```latex
> M[2]

\begin{bmatrix}
  -6.7 & -1.2 & -8.0 \\
\end{bmatrix}
```

```latex
> M[1..-1, 1]

\begin{bmatrix}
  -4.3 \\
  -6.7 \\
  1.9 \\
\end{bmatrix}
```

Similarly, you can access submatrices. Enter the indices as a list or range.

```latex
> M[2..3, 1..2]

\begin{bmatrix}
  -6.7 & -1.2 \\
  1.9 & 9.6 \\
\end{bmatrix}
```

**Vectors**

To select an entry in a vector, enter the vector name with a non-zero integer index.

```latex
> a := <85.3, 47.1, 59.9, 38.1>

\begin{bmatrix}
  85.3 \\
  47.1 \\
  59.9 \\
  38.1 \\
\end{bmatrix}
```

```latex
> a[1]

85.3
```

Negative integers select entries from the end of the vector.

```latex
> a[-1]

38.1
```

To create a Vector consisting of multiple entries, specify a list or range of integers in the index. For more information, refer to the set and range help pages.

```latex
> a[[1, 2]]

\begin{bmatrix}
  85.3 \\
  47.1 \\
\end{bmatrix}
```

```latex
> a[2..4]

\begin{bmatrix}
  47.1 \\
  59.9 \\
  38.1 \\
\end{bmatrix}
```
Linear Algebra Computations

Maple has extensive support for linear algebra. You can perform many matrix and vector computations using context-sensitive operations. Matrix operations such as multiplication and inverses can be done with the basic matrix arithmetic operators. The **LinearAlgebra** package provides the full range of Maple commands for linear algebra and vector space computations, queries, and linear system solving.

**Matrix Arithmetic**

The matrix and vector arithmetic operators are the standard Maple arithmetic operators up to the following two differences.

- The scalar multiplication operator is the asterisk (*), which displays in 2-D Math as $\cdot$. The noncommutative matrix and vector multiplication operator is the period (.)
- There is no division operator (/) for matrix algebra. (You can construct the inverse of a matrix using the exponent $-1$.)

Table 5.5 lists the basic matrix operators.

> $A := \begin{pmatrix} 93 & 43 \\ 19 & 37 \end{pmatrix}$ ; $B := \begin{pmatrix} 48 & 20 \\ 19 & 37 \end{pmatrix}$ ; $C := (23, 6)$ ;

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>+</td>
<td>$&gt; A + B$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{pmatrix} 141 &amp; 63 \ 38 &amp; 74 \end{pmatrix}$</td>
</tr>
<tr>
<td>Subtraction</td>
<td>$-$</td>
<td>$&gt; A - B$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{pmatrix} 45 &amp; 23 \ 0 &amp; 0 \end{pmatrix}$</td>
</tr>
<tr>
<td>Multiplication</td>
<td>$\cdot$</td>
<td>$&gt; A \cdot C$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{pmatrix} 2397 \ 659 \end{pmatrix}$</td>
</tr>
<tr>
<td>Scalar Multiplication</td>
<td>*</td>
<td>$&gt; 12 \times A$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{pmatrix} 1116 &amp; 516 \ 228 &amp; 444 \end{pmatrix}$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$&gt; 4 \cdot C$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{pmatrix} 92 \ 24 \end{pmatrix}$</td>
</tr>
</tbody>
</table>
You can specify scalar multiplication explicitly by entering *, which displays in 2-D Math as \( \cdot \). In 2-D Math, you can also implicitly multiply a scalar and a matrix or vector by placing a space character between them. In some cases, the space character is optional. For example, Maple interprets a number followed by a name as an implicit multiplication.

In 2-D Math, exponents display as superscripts.

A few additional matrix and vector operators are listed in Table 5.6.

Define two column vectors.

\[ d := <1, 2, 3> : e := <4, 5, 6> : \]

Table 5.6: Select Matrix and Vector Operators

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exponentiation(^2)</td>
<td>^</td>
<td>( A^3 )</td>
</tr>
</tbody>
</table>
|                   |          | \[
|                   |          | 986548 613868            |
|                   |          | 271244 187092            |
|                   |          | \[ 37 \]                 |
|                   |          | \[ 1396 \]              |
|                   |          | \[ 19 \]                 |
|                   |          | \[ 349 \]               |
|                   |          | \[ 19 \]                 |
|                   |          | \[ 1396 \]              |
|                   |          | \[ 349 \]               |

1You can specify scalar multiplication explicitly by entering *, which displays in 2-D Math as \( \cdot \). In 2-D Math, you can also implicitly multiply a scalar and a matrix or vector by placing a space character between them. In some cases, the space character is optional. For example, Maple interprets a number followed by a name as an implicit multiplication.

2In 2-D Math, exponents display as superscripts.

For information on matrix arithmetic over finite rings and fields, refer to the mod help page.
Point-and-Click Interaction

Using the Context Panel, you can perform many matrix and vector operations.

Matrix operations available in the Context Panel include the following.

- Perform standard operations: determinant, inverse, norm (1, Euclidean, infinity, or Frobenius), transpose, and trace
- Compute eigenvalues, eigenvectors, and singular values
- Compute the dimension or rank
- Convert to the Jordan form, or other forms
- Perform Cholesky decomposition and other decompositions

For example, compute the infinity norm of a matrix. See Figure 5.6.

![Figure 5.6: Computing the Infinity Norm of a Matrix](image)

In Document mode, Maple inserts a right arrow and the name of the computation performed, followed by the norm.

\[
\begin{bmatrix}
18735.6985 & 349723.234987 \\
9859.459 & 798124.14089
\end{bmatrix}
\text{infinity-norm} \rightarrow 807983.5999
\]

Vector operations available in the Context Panel include the following.

- Compute the dimension
- Compute the norm (1, Euclidean, and infinity)
- Compute the transpose
- Select an element
For more information on context-sensitive operations, see *Computing with the Context Panel* (page 48) (for Document mode) or *The Context Panel* (page 63) (for Worksheet mode).

**LinearAlgebra Package Commands**

The **LinearAlgebra** package contains commands that construct and manipulate matrices and vectors, compute standard operations, perform queries, and solve linear algebra problems.

Table 5.7 lists some **LinearAlgebra** package commands. For a complete list, refer to the **LinearAlgebra/Details** help page.

**Table 5.7: Select LinearAlgebra Package Commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basis</td>
<td>Return a basis for a vector space</td>
</tr>
<tr>
<td>CrossProduct</td>
<td>Compute the cross product of two vectors</td>
</tr>
<tr>
<td>DeleteRow</td>
<td>Delete a row or rows of a matrix</td>
</tr>
<tr>
<td>Dimension</td>
<td>Determine the dimension of a matrix or a vector</td>
</tr>
<tr>
<td>Eigenvalues</td>
<td>Compute the eigenvalues of a matrix</td>
</tr>
<tr>
<td>Eigenvectors</td>
<td>Compute the eigenvectors of a matrix</td>
</tr>
<tr>
<td>FrobeniusForm</td>
<td>Reduce a matrix to Frobenius form</td>
</tr>
<tr>
<td>GaussianElimination</td>
<td>Perform Gaussian elimination on a matrix</td>
</tr>
<tr>
<td>HessenbergForm</td>
<td>Reduce a square matrix to Hessenberg form</td>
</tr>
<tr>
<td>HilbertMatrix</td>
<td>Construct a generalized Hilbert matrix</td>
</tr>
<tr>
<td>IsOrthogonal</td>
<td>Test if a matrix is orthogonal</td>
</tr>
<tr>
<td>LeastSquares</td>
<td>Compute the least-squares approximation to A . x = b</td>
</tr>
<tr>
<td>LinearSolve</td>
<td>Solve the linear system A . x = b</td>
</tr>
<tr>
<td>MatrixInverse</td>
<td>Compute the inverse of a square matrix or pseudo-inverse of a non-square matrix</td>
</tr>
<tr>
<td>QRDecomposition</td>
<td>Compute the QR factorization of a matrix</td>
</tr>
<tr>
<td>RandomMatrix</td>
<td>Construct a random matrix</td>
</tr>
<tr>
<td>SylvesterMatrix</td>
<td>Construct the Sylvester matrix of two polynomials</td>
</tr>
</tbody>
</table>

For information on arithmetic operations, see *Matrix Arithmetic* (page 124).

For information on selecting entries, subvectors, and submatrices, see *Accessing Entries in Matrices and Vectors* (page 122).

**Example:** Determine a basis for the space spanned by the set of vectors \{(2, 13, -15), (7, -2, 13), (5, -4, 9)\}. Express the vector \((25, -4, 9)\) with respect to this basis.

\[
> \text{with(LinearAlgebra):}
\]

\[
> v1 := \langle 2, 13, -15 \rangle; v2 := \langle 7, -2, 13 \rangle; v3 := \langle 5, -4, 9 \rangle;
\]

Find a basis for the vector space spanned by these vectors, and then construct a matrix from the basis vectors.

\[
> \text{basis} := \text{Matrix} (\text{Basis} ([v1, v2, v3]));
\]

\[
\text{basis} := \begin{bmatrix}
2 & 7 & 5 \\
13 & -2 & -4 \\
-15 & 13 & 9
\end{bmatrix}
\]

To express \((25, -4, 9)\) in this basis, use the **LinearSolve** command.
Numeric Computations
You can very efficiently perform computations on large matrices and vectors that contain floating-point data using the built-in library of numeric linear algebra routines. Some of these routines are provided by the Numerical Algorithms Group (NAG®). Maple also contains portions of the CLAPACK and optimized ATLAS libraries.

For information on performing efficient numeric computations using the **LinearAlgebra** package, refer to the **EfficientLinearAlgebra** help page.

See also *Creating Matrices and Vectors with Specific Properties (page 120)* and *Reading from Files (page 323)*.

**Student LinearAlgebra Package**
The **Student** package contains subpackages that help instructors teach concepts and allow students to visualize and explore ideas. These subpackages also contain computational commands.

In the **Student[LinearAlgebra]** subpackage, the environment differs from that of the **LinearAlgebra** package in that floating-point computations are generally performed using software precision, instead of hardware precision, and symbols are generally assumed to represent real, rather than complex, quantities. These defaults, and others, can be controlled using the **SetDefault** command. For more information, refer to the **Student[SetDefault]** help page.

For information on using Maple as a teaching and learning tool, see *Teaching and Learning with Maple (page 145)*.

**5.4 Calculus**
This section describes the key Maple calculus commands. Many of these commands are also available in the Context Panel for an expression.

For a complete list of calculus commands, refer to the Mathematics (including Calculus, Differential Equations, Power Series, and Vector Calculus subfolders) and Education > **Student Package** sections of the Maple Help System Table of Contents.

The **Task Browser** (Tools→Tasks→Browse) contains numerous calculus task templates.

For more about resources for teaching or learning calculus, see *Teaching and Learning with Maple (page 145)*.

**Limits**
To compute the limit of an expression as the independent variable approaches a value:

1. In the **Calculus** palette, click the limit item \( \lim_{x \to a} f \).
2. Specify the independent variable, limit point, and expression, and then evaluate it. Press Tab to move to the next placeholder.
For example:

\[
> \lim_{x \to 0} \left( \frac{x}{\sin(x)} \right)
\]

1

**The limit Command**

By default, Maple searches for the real bidirectional limit (unless the limit point is \(\infty\) or \(-\infty\)). To specify a direction, include one of the options `left`, `right`, `real`, or `complex` in a call to the `limit` command. See Table 5.8.

Table 5.8: Limits

<table>
<thead>
<tr>
<th>Limit</th>
<th>Command Syntax</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>[\lim_{x \to 0} \left( \frac{1}{x} \right)]</td>
<td>&gt; limit(\frac{1}{x}, x = 0)</td>
<td>undefined</td>
</tr>
<tr>
<td>[\lim_{x \to 0^+} \left( \frac{1}{x} \right)]</td>
<td>&gt; limit(\frac{1}{x}, x = 0, 'right')</td>
<td>(\infty)</td>
</tr>
<tr>
<td>[\lim_{x \to 0^-} \left( \frac{1}{x} \right)]</td>
<td>&gt; limit(\frac{1}{x}, x = 0, 'left')</td>
<td>(-\infty)</td>
</tr>
</tbody>
</table>

Using the `limit` command, you can also compute multidimensional limits.

\[
> \lim_{x \to 0, y \to \infty} \left( \frac{x^2}{y} \right), (x = 1, y = \infty)
\]

0

For more information on multidimensional limits, refer to the `limit/multi` help page.

**Numerically Computing a Limit**

To numerically compute a limit:

- Use the `evalf(Limit(arguments))` calling sequence.

**Important:** Use the inert `Limit` command, not the `limit` command. For more information, refer to the `limit` help page.

The `Limit` command accepts the same arguments as the `limit` command.

For example:

\[
> \text{evalf}\left( \text{Limit}\left( \frac{\sin(x)}{\cos(x) + \tan(x)}, x = 1.225 \right) \right)
\]

0.3020605357

For information on the `evalf` command, see *Numerical Approximation* (page 281).

The `Limit` command does not compute the limit. It returns an unevaluated limit.
For more information on the Limit command, refer to the Limit help page.

**Differentiation**

Maple can perform symbolic and numeric differentiation.

To differentiate an expression:

1. In the Calculus palette, click the differentiation item \( \frac{d}{dx} \) or the partial differentiation item \( \frac{\partial}{\partial x} \).
2. Specify the expression and independent variable, and then evaluate it.

For example, to differentiate \( x \sin(a \, x) \) with respect to \( x \):

\[
\text{unassign('a') :}
\]
\[
\frac{d}{dx} (x \sin(a \, x)) = \sin(a \, x) + x \, a \cos(a \, x)
\]

You can also differentiate using the Context Panel. For more information, see The Context Panel (page 27).

To calculate a higher order or partial derivative, edit the derivative symbol inserted. For example, to calculate the second derivative of \( x \sin(a \, x) + x^2 \) with respect to \( x \):

\[
\frac{d^2}{dx^2} (x \sin(a \, x) + x^2) = 2 \, a \cos(a \, x) - x \, a^2 \sin(a \, x) + 2
\]

To calculate the mixed partial derivative of \( x \sin(3 \, y) + y \, x^5 \):

\[
\frac{\partial^2}{\partial y \partial x} (x \sin(3 \, y) + y \, x^5) = 3 \cos(3 \, y) + 5 \, x^4
\]

**Note:** To enter another \( \partial \) symbol, you can copy and paste the existing symbol, or enter \( d \) and use symbol completion.

**The diff Command**

Maple computes derivatives using the diff command. To directly use the diff command, specify the expression to differentiate and the variable.

\[
x \sin(a \, x) + x^2
\]

\[
x \sin(a \, x) + x^2
\]  

(5.3)

\[
diff(5.3, x)
\]

\[
sin(a \, x) + x \, a \cos(a \, x) + 2 \, x
\]  

(5.4)

For information on equation labels such as \( 5.3 \), see Equation Labels (page 68).

You can calculate a higher order derivative by specifying a sequence of differentiation variables. Maple recursively calls the diff command.
To calculate a partial derivative, use the same syntax. Maple assumes that the derivatives commute.

\[
\text{diff}\left(\frac{\partial f}{\partial x}, x, x\right)
\]

To enter higher order derivatives, it is convenient to use the syntax \(\text{diff}(f, x^n)\). This syntax can also be used to compute the symbolic \(n\)th order derivative.

For example:

\[
\text{diff}(\cos(t), t^n)
\]

Differentiating an Operator

You can also specify a mathematical function as a functional operator (a mapping). For a comparison of operators and other expressions, see Distinction between Functional Operators and Other Expressions (page 269).

To find the derivative of a functional operator:

- Use the \(D\) operator.

The \(D\) operator returns a functional operator.

For example, find the derivative of an operator that represents the mathematical function \(F: x \mapsto x \cos(x)\).

First, define the operator \(F\).

1. In the Expression palette, click the single-variable function definition item \(f = a \mapsto y\).

2. Enter placeholder values.
   - To move to the next placeholder, press the Tab key. Note: If pressing the Tab key inserts a tab, click the Tab icon in the toolbar.

\(\text{diff}(\cos(t), t^n)\):

Now, define the operator, \(G\), that maps \(x\) to the derivative of \(x \cos(x)\).

\(\text{diff}(\cos(t), t^n)\):

\(G := x \mapsto \cos(x) - x \sin(x)\)

\(F\) and \(G\) evaluated at \(\frac{\pi}{2}\) return the expected values.
> F(\frac{\pi}{2}); G(\frac{\pi}{2})

\[0\]
\[-\frac{\pi}{2}\]

For more information on the \texttt{D} operator, refer to the \texttt{D} help page. For a comparison of the \texttt{diff} command and \texttt{D} operator, refer to the \texttt{diffVersusD} help page.

\textbf{Directional Derivative}

To compute and plot a directional derivative, use the \textbf{Directional Derivative Tutor}. The tutor computes a floating-point value for the directional derivative.

\textbf{To launch the tutor:}

- From the \texttt{Tools} menu, select \texttt{Tutors, Calculus - Multivariate}, and then \texttt{Directional Derivatives}. Maple launches the \textbf{Directional Derivative Tutor}. See \textbf{Figure 5.7}.

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{figure5.7}
\caption{Directional Derivative Tutor}
\end{figure}

To compute a symbolic value for the directional derivative, use the \texttt{Student[MultivariateCalculus][DirectionalDerivative]} command. The first list of numbers specifies the point at which to compute the derivative. The second list of numbers specifies the direction in which to compute the derivative.
For example, at the point \([1, 2]\), the gradient of \(x^2 + y^2\) points in the direction \([2, 4]\), which is the direction of greatest increase. The directional derivative in the orthogonal direction \([-2, 1]\) is zero.

\[
> \text{with(Student[MultivariateCalculus])}:
\]
\[
> \text{DirectionalDerivative}(x^2+y^2, [x, y] = [1, 2], [1, 2]);
2 \sqrt{5}
\]
\[
> \text{DirectionalDerivative}(x^2+y^2, [x, y] = [1, 2], [-2, 1]);
0
\]

**Series**

To generate the **Taylor series** expansion of a function about a point, use the `taylor` command.

\[
> \text{taylor(sin(4 \cdot x) \cdot \cos(x), x=0)}
\]
\[
4 \cdot x - \frac{38}{3} \cdot x^3 + \frac{421}{30} \cdot x^5 + O(x^7)
\]

**Note:** If a Taylor series does not exist, use the `series` command to find a general series expansion.

For example, the **cosine integral function** does not have a taylor series expansion about 0. For more information, refer to the `Ci` help page.

\[
> \text{taylor(Ci(x), x = 0)}
\]

Error, does not have a taylor expansion, try series()

To generate a truncated series expansion of a function about a point, use the `series` command.

\[
> \text{series(Ci(x), x = 0)}
\]
\[
\gamma + \ln(x) - \frac{1}{4} \cdot x^2 + \frac{1}{96} \cdot x^4 + O(x^6)
\]

By default, Maple performs series calculations up to order 6. To use a different order, specify a non-negative integer third argument.

\[
> \text{expansion} := \text{series(Ci(t), t = 0, 4)}
\]
\[
\text{expansion} := \gamma + \ln(t) - \frac{1}{4} \cdot t^2 + O(t^4)
\]

To set the order for all computations, use the `Order` environment variable. For information about the `Order` variable and the \(O(t^4)\) term, refer to the `Order` help page.

The expansion is of type `series`. Some commands do not accept arguments of type `series`. To use the expansion, you must convert it to a polynomial using the `convert/polynom` command.
> plot\left\{Ci(t), \text{convert}(\text{expansion}, \text{polynom})\right\}, t = \frac{1}{100} \ldots .2\right\)

For information on Maple types and type conversions, see *Maple Expressions* (page 263).

For information on plotting, see *Plots and Animations* (page 183).

**Integration**

Maple can perform symbolic and numeric integration.

**To compute the indefinite integral of an expression:**

1. In the Calculus palette, click the indefinite integration item $\int f(x) \, dx$.
2. Specify the integrand and variable of integration, and then evaluate it.

For example, to integrate $x \sin(ax)$ with respect to $x$:

> $\int x \sin(ax) \, dx$

\[ \frac{\sin(ax) - x a \cos(ax)}{a^2} \]

Recall that you can also enter symbols, including $\int$ and $d$, using symbol completion.

- Enter the symbol name (or part of the name), for example, int or d, and then press the completion shortcut key.

For more information, see *Symbol Names* (page 21).
You can also compute an indefinite integral using the Context Panel. For more information, see *The Context Panel (page 27)*.

**To compute the definite integral of an expression:**

1. In the **Calculus** palette, click the definite integration item \( \int_a^b f(x) \, dx \).
2. Specify the endpoints of the interval of integration, integrand expression, and variable of integration, and then evaluate it.

For example, to integrate \( e^{-at} \ln(t) \) over the interval \((0, \infty)\):

\[
> \int_0^\infty e^{-at} \ln(t) \, dt
\]

\[
\lim_{a \to \infty} \left( -\frac{e^{-at} \ln(t) + \text{Ei}(at) + \gamma + \ln(a)}{a} \right)
\]

Maple treats the parameter \( a \) as a complex number. As described in *Assumptions on Variables (page 104)*, you can compute under the assumption that \( a \) is a positive, real number using the **assuming** command.

\[
> \int_0^\infty e^{-at} \ln(t) \, dt \text{ assuming } a > 0
\]

\[
-\frac{\gamma + \ln(a)}{a}
\]

To compute iterated integrals, line integrals, and surface integrals, use the task templates (**Tools** → **Tasks** → **Browse**) in the **Multivariate** and **Vector Calculus** folders.

**The int Command**

\( \int_a^b f(x) \, dx \) and \( \int_a^b f(x) \, dx \) use the **int** command. To use the **int** command directly, specify the following arguments.

- Expression to integrate
- Variable of integration

\[
> x \sin(a \, x)
\]

\[
x \sin(a \, x)
\]  

(5.6)

\[
> \text{int}(5.6, x)
\]

\[
\frac{\sin(a \, x) - x \, a \, \cos(a \, x)}{a^2}
\]

(5.7)

For a definite integration, set the variable of integration equal to the interval of integration.

\[
> \text{int}(5.6, x = 0 .. \frac{\pi}{a})
\]

\[
\frac{\pi}{a^2}
\]

(5.8)
Numeric Integration

To perform numeric integration:

- Use the `evalf(Int(arguments))` calling sequence.

**Important:** Use the inert `Int` command, not the `int` command. For more information, refer to the `int` help page.

In addition to the arguments accepted by the `int` command, you can include optional arguments such as `method`, which specifies the numeric integration method.

```
> evalf(Int(1/Γ(x), x = 0 .. 2, 'method' = 'Dexp'))

1.626378399
```

For information on the `evalf` command, see *Numerical Approximation (page 281)*.

For information on numeric integration, including iterated integration and controlling the algorithm, refer to the `evalf/Int` help page.

**Calculus Packages**

In addition to top-level calculus commands, Maple contains calculus packages.

**VectorCalculus Package**

The `VectorCalculus` package contains commands that perform multivariate and vector calculus operations on `VectorCalculus` vectors (vectors with an additional coordinate system attribute) and vector fields (vectors with additional coordinate system and vector field attributes), for example, Curl, Flux, and Torsion.

```
> with(VectorCalculus):

> BasisFormat(false):

> SetCoordinates('cartesian'[x, y, z])

> VectorField1 := VectorField(-y, x, z)

VectorField1 := [ -y ]
[  x ]
[  z ]

Note: For information on changing the display format in the VectorCalculus package, see the `VectorCalculus[BasisFormat]` help page.

Find the curl of VectorField1.

```
> Curl(VectorField1);

[ 0 ]
[ 0 ]
[ 2 ]
```

Find the flux of `VectorField1` through a sphere of radius `r` at the origin.
Compute the torsion of a space curve. The curve must be a vector with parametric function components.

> 

\[ \text{Flux( VectorField1, Sphere((0, 0, 0), r) )} \]

\[ \frac{4}{3} \pi r^3 \]

> 

\[ \text{simplify(Torsion((t, t^2, t^3), t)) assuming t::real} \]

\[ \frac{3}{9t^4 + 9t^2 + 1} \]

For information on the assuming command, see The assuming Command (page 106).

For more information on the VectorCalculus package, including a complete list of commands, refer to the VectorCalculus help page.

To find other calculus packages, such as VariationalCalculus, refer to the index/package help page.

**Student Calculus Packages**

The Student package contains subpackages that help instructors teach concepts and allow students to visualize and explore ideas. These subpackages also contain computational commands. The Student calculus subpackages include Calculus1, MultivariateCalculus, and VectorCalculus. The Student[VectorCalculus] package provides a simple interface to a subset of the functionality available in the VectorCalculus package.

For information on using Maple as a teaching and learning tool, including the comprehensive interactive Study Guides, see Teaching and Learning with Maple (page 145).

**Differential Equations**

Maple has a powerful set of solvers for ordinary differential equations (ODEs) and partial differential equations (PDEs), and systems of ODEs and PDEs.

For information on solving ODEs and PDEs, see Other Specialized Solvers (page 87).

**Student ODEs Package**

The Student subpackage for ODEs has commands for computation, visualization, and step-by-step solutions, designed to support a first year course in ordinary differential equations.

---

**5.5 Optimization**

Using the Optimization package, you can numerically solve optimization problems. The package uses fast Numerical Algorithms Group (NAG) algorithms to minimize or maximize an objective function.

The Optimization package solves constrained and unconstrained problems.

- Linear programs
- Quadratic programs
- Nonlinear programs
- Linear and nonlinear least-squares problems

The Optimization package contains local solvers. In addition, for univariate finitely-bounded nonlinear programs with no other constraints, you can compute global solutions using the NLPsolve command. To find global solutions generally,
purchase the Global Optimization Toolbox. For more information, visit http://www.maplesoft.com/products/toolboxes.

**Point-and-Click Interface**

The primary method for solving optimization problems is the Optimization Assistant.

**To launch the Optimization Assistant:**

- From the Tools menu, select Tutors, Optimization, and then Optimization.

Maple launches the Optimization Assistant. See Figure 5.8.

![Optimization Assistant](image)

*Figure 5.8: Optimization Assistant*

To solve a problem:

1. Enter the objective function, constraints, and bounds.
2. Select the Minimize or Maximize radio button.
3. Click the Solve button. The solution is displayed in the Solution text box.

You can also enter the problem (objective function, constraints, and bounds) in the calling sequence of the Optimization[Interactive] command.

For example, find the maximum value of $x^2y - y^2$ subject to the constraints $x + y \leq 6$, $x \in [0,5]$, $y \in [0,5]$.

```maple
> Optimization[Interactive](x^2*y - y^2, {x + y <= 6, x = 0..5, y = 0..5})
```

[134.491161539748163, [x = 4.53559292539129, y = 1.46440707460871]]

- When the Optimization Assistant opens, select Maximize, then Solve.
After finding a solution, you can plot it. To plot a solution:

- In the **Optimization Assistant** window, click the **Plot** button. The **Optimization Plotter** window is displayed. See Figure 5.9.

**Note:** When you close the **Optimization Assistant**, you can choose to return the solution, problem, command used, plot, or nothing, using the drop-down in the bottom right corner of the assistant window.

---

**Figure 5.9: Optimization Assistant Plotter Window**

For information on the algorithms used to solve optimization problems, refer to the **Optimization/Methods** help page.

**Large Optimization Problems**

The **Optimization Assistant** accepts input in an algebraic form. You can specify input in other forms, described in the **Optimization/InputForms** help page, in command calling sequences.

The Matrix form, described in the **Optimization/MatrixForm** help page, is more complex but offers greater flexibility and efficiency.

For example, solve the linear program:

\[
\text{Maximize } c^T x \text{ subject to } Ax \leq b, \text{ where } x \text{ is the vector of problem variables.}
\]

1. Define the column vector, \(c\), of the linear objective function.
> restart;

> with(LinearAlgebra):

> c := RandomVector[column](20, outputoptions = ['datatype'='float']):

2. Define the matrix \( A \), the coefficient matrix for the linear inequality constraints.

> A := RandomMatrix(19, 20, outputoptions = ['datatype'='float']):

3. Define the column vector \( b \), the linear inequality constraints.

> b := RandomVector[column](19, outputoptions = ['datatype'= 'float']):

4. The QPSolve command solves quadratic programs.

> Optimization[LPSolve](c, [A, b], maximize, assume = nonnegative)

This example uses a random data set to demonstrate the problem. You could also read data from an external file as Matrices, and use that data. For details and an example, see Reading from Files (page 323).

**Note:** For information on creating matrices and vectors (including how to use the Matrix palette to easily create matrices), see Linear Algebra (page 116).

For additional information on performing efficient computations, refer to the Optimization/Computation help page.

**MPS(X) File Support**

To import linear programs from a standard MPS(X) data file, use the ImportMPS command.

**Optimization Package Commands**

Each Optimization package command solves the problem using a different optimization method. These are described in Table 5.9, along with the general input form for each command.

Table 5.9: Optimization Package Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LPSolve</td>
<td>Solve a linear program (LP), which involves computing the minimum (or maximum) of a linear objective function subject to linear constraints; input is in equation or Matrix form</td>
</tr>
</tbody>
</table>
Solve a least-squares (LS) problem, which involves computing the minimum of a real-valued objective function having the form \( \frac{1}{2} \left( f_1(x)^2 + f_2(x)^2 + \ldots + f_n(x)^2 \right) \), where \( x \) is a vector of problem variables, possibly subject to constraints; input is in equation or Matrix form.

Maximize

Compute a local maximum of an objective function, possibly subject to constraints.

Minimize

Compute a local minimum of an objective function, possibly subject to constraints.

NLPSolve

Solve a non-linear program (NLP), which involves computing the minimum (or maximum) of a real-valued objective function, possibly subject to constraints; input is in equation or Matrix form.

QPSolve

Solve a quadratic program (QP), which involves computing the minimum (or maximum) of a quadratic objective function, possibly subject to linear constraints; input is in equation or Matrix form.

For a complete list of commands and other Optimization package information, refer to the Optimization help page.

### 5.6 Statistics

The Statistics package provides tools for mathematical statistics and data analysis. The package supports a wide range of common statistical tasks including quantitative and graphical data analysis, simulation, and curve fitting.

In addition to standard data analysis tools, the Statistics package provides a wide range of symbolic and numeric tools for computing with random variables. The package supports over 35 major probability distributions and can be extended to include new distributions.

#### Probability Distributions and Random Variables

The Statistics package supports:

- Continuous distributions, which are defined along the real line by probability density functions. Maple supports many continuous distributions, including the normal, Student-t, Laplace, and logistic distributions.

- Discrete distributions, which have nonzero probability only at discrete points. A discrete distribution is defined by a probability function. Maple supports many discrete distributions, including the Bernoulli, geometric, and Poisson distributions.

For a complete list of distributions, refer to the Statistics/Distributions help page.

You can define random variables by specifying a distribution in a call to the RandomVariable command.

> \texttt{with(Statistics) :}

> \texttt{X := RandomVariable(Poisson(\lambda)) :}

Find the probability distribution function for \( X \). (For information on statistics computations, see Statistical Computations (page 142).)

> \texttt{PDF(X, t)}

\[
\sum_{k=0}^{\infty} \frac{\lambda^k e^{-\lambda}}{k!} \operatorname{Dirac}(t-k)
\]

#### Adding Custom Distributions

To add a new distribution, specify a probability distribution in a call to the Distribution command.
To construct a piecewise-continuous function in 1-D Math, use the `piecewise` command, for example,
\[
t \rightarrow \\text{piecewise}(t < 0, 0, t < 3, \frac{1}{3}, 0).
\]

Define a new random variable with this distribution.

\[
> Z := \text{RandomVariable}(U): PDF(Z, t)
\]

\[
\begin{align*}
0 & \quad t < 0 \\
\frac{1}{3} & \quad t < 3 \\
0 & \quad \text{otherwise}
\end{align*}
\]

Calculate the mean value of the random variable.

\[
> \text{Mean}(Z)
\]

\[
\frac{3}{2}
\]

**Statistical Computations**

In addition to basic functions, like mean, median, standard deviation, and percentile, the `Statistics` package contains commands that compute, for example, the interquartile range and hazard rate.

**Example 1 - Interquartile Range**

Compute the average absolute range from the interquartile of the Rayleigh distribution with scale parameter 3.

\[
> \text{InterquartileRange}(\text{Rayleigh}(3))
\]

\[
\sqrt{36 \ln(2)} - \sqrt{-18 \ln\left(\frac{3}{4}\right)}
\]

To compute the result numerically:

- Specify the 'numeric' option.

\[
> \text{InterquartileRange}(\text{Rayleigh}(3), \text{'numeric'})
\]

\[
2.71974481762339
\]

**Example 2 - Hazard Rate**

Compute the hazard rate of the Cauchy distribution with location and scale parameters \(a\) and \(b\) at an arbitrary point \(t\).

\[
> \text{unassign('b') :}
\]
\[ \text{HazardRate}(\text{Cauchy}(a, b), t) \]
\[ \frac{1}{\pi b \left(1 + \frac{(t - a)^2}{b^2}\right) \left(\frac{1}{2} - \frac{\arctan \left(\frac{t - a}{b}\right)}{\pi}\right)} \]

You can specify a value for the point \( t \).

\[ \text{HazardRate}(\text{Cauchy}(a, b), \frac{1}{2}) \]
\[ \frac{1}{\pi b \left(1 + \frac{\left(\frac{1}{2} - a\right)^2}{b^2}\right) \left(\frac{1}{2} - \frac{\arctan \left(\frac{\frac{1}{2} - a}{b}\right)}{\pi}\right)} \]

You can also specify that Maple compute the result numerically.

\[ \text{HazardRate}(\text{Cauchy}(10, 1), \frac{1}{2}, \text{"numeric"}) \]
\[ 0.003608801461 \]

For more information, refer to the \texttt{Statistics/DescriptiveStatistics} help page.

\textbf{Plotting}

You can generate statistical plots using the visualization commands in the \texttt{Statistics} package. Available plots include:

- Bar chart
- Frequency plot
- Histogram
- Pie chart
- Scatter plot

For example, create a scatter plot for a distribution of points that vary from \( \sin \left(\frac{2\pi x}{200}\right) \) by a small value determined by a normally distributed sample.

\[ \text{restart;} \]
\[ \text{with(Statistics);} : \]
\[ N := 200; \]
\[ U := \text{Sample}(\text{Normal}(0, 1), N); \]
\[ X := \langle \text{seq}(x, x = 1 .. N) \rangle ; \]
\[ Y := < \text{seq}\left(\sin \left(\frac{2\pi x}{N}\right) + \frac{U[x]}{5}, x = 1 .. N\right)> ; \]
To fit a curve to the data points, include the optional fit equation parameter.

Using the `plots[display]` command, create a plot that contains:

- a scatter plot of the data points
- a quartic polynomial fitted to the data points: \( f(x) = a x^4 + b x^3 + c x^2 + d x + e \)
- the function \( \sin \left( \frac{2 \pi x}{N} \right) \)

\[
> P := \text{ScatterPlot}(X, Y, \text{fit} = [a x^4 + b x^3 + c x^2 + d x + e, x, x], \text{thickness} = 2);
\]

\[
> Q := \text{plot}\left( \sin \left( \frac{2 \pi x}{N} \right), x = 1..N, \text{thickness} = 2, \text{color} = "\text{Niagara 3}" \right);
\]
> plots[display]([P, Q, 'title' = "Scatter Plot with Fitted Quartic Polynomial"])

Scatter Plot with Fitted Quartic Polynomial

For more information on statistical plots, refer to the Statistics/Visualization help page.

For an overview of plotting, see Plots and Animations (page 183).

**Student Statistics Package**

The Student[Statistics] package helps instructors teach concepts and allows students to understand and explore concepts in an introductory statistics course. The Student[Statistics] package provides a simple interface to a limited subset of the functionality available in the Statistics package, as well as some additional resources. You can create and explore random distributions, perform hypothesis testing, and more.

The Student Statistics Example worksheet provides some starting examples.

**Additional Information**

For more information on the Statistics package, including regression analysis, estimation, data manipulation, and data smoothing, refer to the Statistics help page.

**5.7 Teaching and Learning with Maple**

Table 5.10 lists the available resources for instructors and students. For additional resources, see Available Resources (page 40).
Table 5.10: Student and Instructor Resources

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Student Packages and Tutors</strong></td>
<td>The <strong>Student</strong> package contains computational and visualization (plotting and animation) functionality, and point-and-click interfaces for explaining and exploring concepts (Tools→Tutors). For more information, refer to the <strong>Student</strong> help page.</td>
</tr>
</tbody>
</table>
| **Study Guides**                 | Study guides - Complete lessons with interactive examples for academic courses. Maple includes these study guides:  
  - **Precalculus Study Guide** contains worked problems, each solved as in a standard textbook, using Maple commands and custom Maplet graphical interfaces.  
  - **Calculus Study Guide** contains worked problems, each solved as in a standard textbook, using Maple commands and custom Maplet graphical interfaces.  
  - **Multivariate Calculus Study Guide** contains worked problems, each solved as in a standard textbook, using Maple commands and custom Maplet graphical interfaces. |
| **Teacher Resource Center**      | The Maple Teacher Resource Center contains resources and tips for teachers using Maplesoft products to help in the classroom. Available resources include:  
  - Classroom content for subjects including Precalculus, Calculus, and Engineering  
  - Training videos  
  - E-books (http://www.maplesoft.com/TeacherResource) |
| **Maple Portal**                 | The Maple Portal includes material designed for all Maple users as well as a specific portal for students. The Maple Portal includes:  
  - How Do I... topics that give quick answers to essential questions  
  - Tutorials that provide an overview of topics from getting started to plotting and working with matrices  
  - Navigation to portals with specialized information for students and engineers  
  Access the portal the table of contents in the Maple Help System, under **Getting Started**. |
| **Mathematics and Engineering Dictionary** | The Maple Help System has an integrated dictionary of over 5000 mathematics and engineering terms. You can search the dictionary by entering a term in the Help System search field. |
| **Maple Application Center**     | The Maple Application Center contains tutorials and applications that help instructors begin using Maple and use Maple in the classroom. Browse the many resources by category or search for a topic. (http://www.maplesoft.com/applications) |
| **Student Help Center**          | The Maple Student Help Center contains tutorials and applications that help students learn how to use Maple, explore mathematical concepts, and solve problems. Available resources include:  
  - Free course lessons for many subjects including precalculus to vector calculus; high school, abstract, and linear algebra; engineering; physics; differential equations; cryptography; and classical mechanics.  
  - Applications for students, written by students, providing examples in many subject areas.  
  - Student FAQs with answers from experts. (https://www.maplesoft.com/studentcenter/index.aspx) |
Student Packages and Tutors

The Student package is a collection of subpackages for teaching and learning mathematics and related subjects. The Student package contains packages for a variety of subjects, including precalculus, calculus, and linear algebra.

Instructors can:

- Teach concepts without being distracted by the mechanics of the computations.
- Create examples and quickly update them during a lesson to demonstrate different cases or show the effect of the variation of a parameter.
- Create plots and animations to visually explain concepts, for example, the geometric relationship between a mathematical function and its derivatives (Tools→Tutors→Calculus - Single Variable→Derivatives). See Figure 5.10.

Students can:

- Perform step-by-step computations, for example, compute a derivative by applying differentiation rules using commands or a tutor (Tools→Tutors→Calculus - Single Variable→Differentiation Methods). See Figure 5.11.
- Perform computations.
- Visually explore concepts.
Figure 5.11: Calculus 1 Differentiation Methods Tutor

Tutors provide point-and-click interfaces to the Student package functionality.

**To launch a tutor:**

1. From the Tools menu, select Tutors.
2. Select a subject, for example, Calculus - Multivariate.
3. Select a tutor, for example, Gradients.

Maple inserts the Student[MultivariateCalculus][GradientTutor]() calling sequence (in Worksheet mode), and launches the Multivariate Calculus Gradient Tutor.

By rotating the three-dimensional plot, you can show that the gradient points in the direction of greatest increase of the surface (see Figure 5.12) and show the direction of the gradient vector in the x-y plane by rotating the plot (see Figure 5.13).
Figure 5.12: Multivariate Calculus Gradient Tutor

Figure 5.13: Multivariate Calculus Gradient Tutor Showing x-y Plane
When you close the tutor, Maple inserts the 3-D plot.

> Student[MultivariateCalculus][GradientTutor]();

Many Student package commands can return a value, mathematical expression, plot, or animation. This allows you to compute the final answer, see the general formula applied to a specific problem, or visualize the underlying concepts.

For example, the Student[VectorCalculus][LineInt] (line integral) command can return the following.

- Plot that visually indicates the vector field, path of integration, and tangent vectors to the path
- Unevaluated line integral
- Numeric value of the line integral

> with(Student[VectorCalculus]):
To evaluate the integral returned by the `output = integral` calling sequence, use the `value` command.

\[ \int_0^{2\pi} (\sin(t)^2 - \cos(t)^2) \, dt \]  
(5.9)

To evaluate the integral returned by the `output = integral` calling sequence, use the `value` command.

\( \text{value}(5.9) \)  

\[ -2\pi \]  
(5.10)

By default, the `LineInt` command returns the value of the integral.

\( \text{LineInt}(\text{VectorField}(<y, -x>), \text{Circle}(<0, 0>, r)) \)

\[ -2\pi r^2 \]

For more information on the `Student` package, refer to the `Student` help page.

**Calculus Problem Solving Examples**

Maple is a powerful application with many resources to guide you. The following examples provide you with scenarios to learn about using Maple resources and the Maple program.

When using Maple to solve a problem, consider the following process.

1. Formulate your problem.
2. Obtain Maple resources that allow you to solve it.
Problem

Scenario A:

Your company is designing a bottle for its new spring water product. The bottle must contain 18 ounces of water and the height is fixed. The design includes an undulating curved surface. You know the amplitude and equation of the curve, but you must find the radius. You require the Volume of Revolution.

Scenario B:

You want to teach your students the concept of a Volume of Revolution. Specifically, you want to plot and compute the volume of a solid generated by rotating \( f(x), a \leq x \leq b \), about an axis or a line parallel to an axis.

Figure 5.14: Flowchart of solving a problem

Check for Existing Tools: Tutor

Begin by examining the Tools menu for a Tutor to a Volume of Revolution problem.

To access a Tutor for the Volume of Revolution:

1. From the Tools menu, select Tutors, and then Calculus-Single Variable. Notice that a Volume of Revolution tutor exists.
2. Click the Volume of Revolution menu item. The following Maple command is entered in your document.
The **Volume of Revolution Tutor** is displayed. See **Figure 5.15**. Use this tutor to enter a function and an interval, view and manipulate the corresponding plot, and view the full Maple command associated with your entries and selections.
After you Close the tutor, the plot is inserted into your worksheet.

**Check for Existing Tools: Task Template**

1. From the Tools menu, select Tasks, and then Browse. The Browse Tasks dialog opens, displaying a list of tasks in the left pane. The tasks are sorted by subject to help you quickly find the desired task.

2. Expand the Calculus - Integral→ Applications → Solids of Revolution folder.

3. From the displayed list, select Volume. The Volume of Revolution task is displayed in the right pane of the Browse Tasks dialog.

4. Select the Insert into New Worksheet check box.

Click Insert Default Content. Before inserting a task, Maple checks whether the task variables have assigned values in your worksheet. If any task variable is assigned, the Task Variables dialog opens allowing you to modify the names. Maple uses the edited variable names for all variable instances in the inserted task. The content is inserted into your document. See Figure 5.16.
Volume of Revolution

Calculate the volume of revolution for a solid of revolution when a function is rotated about the horizontal or vertical axis.

Enter the function as an expression and specify the range:

\[
> \sin(x) \cos(x) + 1, 0 .. \frac{\pi}{2}
\]

\[
\sin(x) \cos(x) + 1, 0 .. \frac{1}{2} \pi
\]  
(1.1)

Calculate the volume of revolution:

\[
> \text{Student}[	ext{Calculus1}][\text{VolumeOfRevolution}](1.1)
\]

\[
\pi + \frac{9 \pi^2}{16}
\]  
(1.2)

Display the floating-point value using the evalf command:

\[
> \text{evalf}(1.2)
\]

\[
8.693245131
\]  
(1.3)

Figure 5.16: Inserted Task Template

6. When a Task Template is inserted, parameters are marked as placeholders, denoted by purple font. To navigate between placeholders, press the Tab key. After updating any parameters, execute the command by pressing Enter.

Check for Instructions: Help Page and Example Worksheet

The help system provides command syntax information.

To access a help page:
1. From the Help menu, select Maple Help.
2. In the search field, enter volume of revolution and click Search. The search results include the command help page, the dictionary definition, and the associated tutor help page.
3. Review the calling sequence, parameters, and description in the Student[Calculus1][VolumeOfRevolution] help page.
4. Copy the examples into your worksheet: from the help system Edit menu, select Copy Examples.
5. Close the Help Navigator.
6. In your document, from the Edit menu, select Paste. The examples are pasted into your document.
7. Execute the examples and examine the results.

To access an example worksheet:
1. In the worksheet, enter examples/index. The Examples and Applications Index opens.
2. Expand the Calculus topic.
3. Click the examples/Calculus1IntApps link. The Calculus1: Applications of Integration worksheet opens. See Figure 5.17.
4. Expand the Volume of Revolution topic.
5. Examine and execute the examples.
Calculus 1: Applications of Integration

The Student[Calculus1] package contains four routines that can be used to both work with and visualize the concepts of function averages, arc lengths, and volumes and surfaces of revolution. This worksheet demonstrates this functionality.

For further information about any command in the Calculus1 package, see the corresponding help page. For a general overview, see Calculus1.

Getting Started

While any command in the package can be referred to using the long form, for example, Student[Calculus1][DerivativePlot], it is easier, and often clearer, to load the package, and then use the short form command names.

```maple
restart
with(Student[Calculus1]):
```

The following sections show how the routines work. In some cases, examples show to use these visualization routines in conjunction with the single-stepping Calculus1 routines.

- Function Average
- Volume of Revolution
- Arc Length
- Surface of Revolution

Figure 5.17: Example Worksheet

Check for Other Ready-To-Use Resources: Application Center

The Maple Application Center contains free user-contributed applications related to mathematics, education, science, engineering, computer science, statistics and data analysis, finance, communications, graphics, and more.

To access a free application for volume of revolution:

2. In the menu of the main webpage, click Support & Resources, and then Maple Application Center.
3. In the Application Search section, enter Volume of Revolution in the Keyword or phrase field.
4. Click Search.
5. From the search results page, under Displaying applications, click the Click here link.
6. From the list of archived applications, select any of the Maple document you want to view.
7. Click on the Download Maple Document link to download the .mw file.
8. Execute the worksheet and examine the results.

5.8 Clickable Math™

For years, Maple has led the way in making math software easy to use. With its collection of Clickable Math™ tools, including palettes, interactive assistants, context-sensitive operations, tutors, and more, Maple has set the standard for making it easy to learn, teach, and do mathematics.

The Study Guides are a core feature of our Clickable Math resources. These are described in *Teaching and Learning with Maple* (page 145).

In addition, two key features of the Clickable Math tool collection are Smart Popups and Drag-to-Solve™.

**Smart Popups**

Smart Popups are interactive popup options that are invoked when you select certain types of equations, expressions or subexpressions.

**With Smart Popups you can:**

- Select operations to apply to just one part of your equation or mathematical expression, leaving the rest unchanged.
- Preview the result of the operation before going ahead.
- Explore your expression to deepen your understanding of the problem.
- Easily determine if your subexpression can be factored, what its plot looks like, what mathematical identities could be applied, and more.

Smart popups, if any, are shown at the top of the Context Panel. For more information on Smart Popups, as well as examples, see the Clickable Math: Smart Popups help page.

**Drag-to-Solve**

The Drag-to-Solve feature enables you to solve your equations step-by-step by dragging terms to where you want them to be.

**With Drag-to-Solve you can:**

- Easily take complete control over each individual step of your calculation.
- Let Maple apply the appropriate addition, subtraction, division, or multiplication operation to both sides of your equation, to avoid mechanical errors.
- Keep the full record of steps produced by Maple to document your work.

For more information on Drag-to-Solve, as well as examples, see the Clickable Math: Drag-to-Solve help page.
Examples

This chapter is designed to show several ways to solve the same problem in Maple. Throughout these examples, you will need to insert new document block regions. This is done using the Create document block icon (\(\frac{\text{Create Document Block}}{\text{Create Document Block}}\)) on the toolbar or through the Edit menu, by selecting Document Blocks>Create Document Block. Also, these examples only give the keyboard keys needed for a Windows operating system. Refer to Shortcut Keys by Platform (page xiii) for the keys needed for your operating system.

Example 1 - Graph a Function and its Derivatives

On the interval \([-\pi, \pi]\), graph \(f\), \(f'\), and \(f''\) for \(f(x) = x \cos(x)\).

We solve this problem using the following methods:

- Solution by Context-Sensitive Operations (page 158)
- Solution by Tutor (page 160)
- Access the Tutor from a Task Template (page 162)

Solution by Context-Sensitive Operations

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Enter the expression (x \cos(x)).</td>
<td>(x \cos(x))</td>
</tr>
<tr>
<td>Make a copy of the expression and calculate the derivative:</td>
<td>(x \cos(x)) (\xrightarrow{\text{differentiate w.r.t. } x}) (\cos(x) - x \sin(x))</td>
</tr>
<tr>
<td>2. Insert a new document block region by selecting from the Format menu Create Document Block.</td>
<td></td>
</tr>
<tr>
<td>3. Highlight the original expression. Ctrl + drag the expression to the new document block.</td>
<td></td>
</tr>
<tr>
<td>4. Select the expression and, from the Context Panel select Differentiate (\rightarrow) With Respect To (\rightarrow) (x).</td>
<td></td>
</tr>
<tr>
<td>Make a copy of the derivative and calculate the second derivative:</td>
<td>(\cos(x) - x \sin(x)) (\xrightarrow{\text{differentiate w.r.t. } x}) (-2 \sin(x) - x \cos(x))</td>
</tr>
<tr>
<td>5. Insert a new document block, and Ctrl + drag the derivative to the document block.</td>
<td></td>
</tr>
<tr>
<td>6. From the Context Panel for the derivative, select Differentiate (\rightarrow) With Respect To (\rightarrow) (x).</td>
<td></td>
</tr>
<tr>
<td>Action</td>
<td>Result in Document</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>--------------------</td>
</tr>
<tr>
<td><strong>Plot the original expression:</strong></td>
<td>$x \cos(x)$</td>
</tr>
<tr>
<td>7. Insert a new document block, and Ctrl + drag the original expression to the new block.</td>
<td></td>
</tr>
<tr>
<td>8. From the Context Panel for the expression, select <strong>Plots</strong> $\rightarrow$ <strong>2-D Plot</strong>.</td>
<td></td>
</tr>
<tr>
<td>9. Modify the plot through the Context Panel: select <strong>Axes</strong> $\rightarrow$ <strong>Properties</strong>.</td>
<td></td>
</tr>
<tr>
<td>10. In the <strong>Axis Properties</strong> dialog, de-select <strong>Use data extents</strong> and change the range to -3.14 to 3.14. Click <strong>OK</strong>.</td>
<td></td>
</tr>
</tbody>
</table>

**Add the first and second derivatives to the plot:**

11. Select and then Ctrl + drag the derivative of the expression onto the plot region. Do the same for the second derivative.
### Enhance the plot by adding a legend:

12. From the Context Panel for the plot region, select **Legend → Show Legend**.

13. In the legend, double-click **Curve 1**. Notice that the **Text** icon is selected in the toolbar. Delete the text and select the **Math** icon in the toolbar. This allows you to enter 2-D Math in a text region. Enter the original expression, \( x \cos(x) \).


### Add a title:

15. From the Context Panel, select **Title → Add Title**. Replace the text **New title** with the text "Plot the expression".

16. Click the **Math** icon, and enter the expression \( x \cos(x) \). Click the **Text** icon once again and enter "and its derivatives".

### Solution by Tutor

The **Student Calculus 1** package contains a tutor called **Derivatives**, which displays a plot of the expression along with its derivatives. In this example, we solve the same problem as previously, using this tutor.

### Action

<table>
<thead>
<tr>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Load the <strong>Student Calculus 1</strong> package. From the <strong>Tools</strong> menu, select <strong>Load Package → Student Calculus 1</strong>.</td>
</tr>
<tr>
<td>2. <strong>Ctrl + drag</strong> the expression ( x \cos(x) ) to a blank document block region.</td>
</tr>
</tbody>
</table>

### Result in Document

| Loading **Student:-Calculus1** |

---

**Diagram:**

- **X \( \cos(x) \)**
- **Plot the expression \( x \cos(x) \) and its derivatives**
- **\( x \cos(x) \)**
- **\( \cos(x) - x \sin(x) \)**
- **\( -2 \sin(x) - x \cos(x) \)**
3. From the Context Panel for the expression, select **Student Calculus 1 → Tutors → Derivatives**. **Note:** The **Student Calculus 1** menu is now available in the Context Panel because we loaded the package in step 1.

In the **Derivative Tutor**, the color swatch shown beside the original expression is the color used for the curve in the plot region. Similarly for \( f'(x) \) and \( f''(x) \).

4. Change the lower endpoint to \(-\pi\). Select the check box to display \( f''(x) \) in the plot. Click **Display** to make these changes take effect.

5. You can change the expression and modify plot options from within this tutor. For each change made, click **Display** to view the altered plot. When complete, click **Close** to display the resulting plot in the document.
### Access the Tutor from a Task Template

Maple also comes with a Task Template to solve this problem without using any commands.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Launch the Task Template Browser by selecting <strong>Tools → Tasks → Browse.</strong></td>
<td><img src="https://via.placeholder.com/150" alt="Task Template Browser" /></td>
</tr>
<tr>
<td>2. In the table of contents of the <strong>Task Browser</strong> dialog, select <strong>Calculus-Differential → Derivatives → Graph f(x) and its Derivatives.</strong></td>
<td><img src="https://via.placeholder.com/150" alt="Task Template Browser" /></td>
</tr>
<tr>
<td>3. Click <strong>Insert Minimal Content</strong> at the top of the dialog to insert the task template into the current document.</td>
<td><img src="https://via.placeholder.com/150" alt="Task Template Browser" /></td>
</tr>
<tr>
<td>4. Enter the new expression $x^2 \cos(x)$ in the f(x) region.</td>
<td><img src="https://via.placeholder.com/150" alt="Task Template Browser" /></td>
</tr>
<tr>
<td>5. Enter the interval $[-\pi, \pi]$. To insert the symbol for pi, you can use command completion or select $\pi$ from the <strong>Common Symbols</strong> palette.</td>
<td><img src="https://via.placeholder.com/150" alt="Task Template Browser" /></td>
</tr>
</tbody>
</table>
6. Click **Launch Differentiation Tutor** to launch the same tutor as in the previous solution.

7. When complete, click **Close**. A plot of the expression and its derivatives displays in the plot region of the inserted task template.

---

### Example 2 - Solve for x in a Quadratic Equation

Solve for $x$ in the equation $(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)$.

We solve this problem using the following methods:

- **Solution through Equation Manipulator** (page 163)
- **Instant Solution** (page 165)
- **Step-by-step Interactive Solution** (page 165)
- **Graphical Solution** (page 166)
- **Graphical Solution Using Smart Popups** (page 168)

#### Solution through Equation Manipulator

Maple provides a dialog that allows you to single-step through the process of manipulating an expression. This manipulator is available from the Context Panel.
<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Enter the equation ((x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)) in a new document block region.</td>
<td>((x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2))</td>
</tr>
<tr>
<td>2. From the Context Panel for this equation, select <strong>Manipulate Equation</strong>. The <strong>Manipulate Equation</strong> dialog displays.</td>
<td><img src="image" alt="Manipulate Equation dialog" /></td>
</tr>
<tr>
<td><strong>Group all of the terms to the left:</strong></td>
<td></td>
</tr>
<tr>
<td>3. In the <strong>Addition</strong> region, the <strong>Group terms</strong> row allows you to group terms on a specified side. With the <strong>left</strong> side already selected, click <strong>Do</strong>.</td>
<td><img src="image" alt="Group terms" /></td>
</tr>
<tr>
<td><strong>Expand the left side of the equation:</strong></td>
<td></td>
</tr>
<tr>
<td>4. In the <strong>Miscellaneous Operations</strong> region, we can manipulate the equation by applying a command from the drop-down menus. Since we want to expand the left side of the equation only, click the first drop-down menu in the second row and select <strong>expand</strong>. Click <strong>Do</strong>. <strong>Note:</strong> This example is carried out with no assumptions. You can assume the solution to be real, positive, nonnegative or integer from the drop-down menu.</td>
<td><img src="image" alt="Expand left side" /></td>
</tr>
</tbody>
</table>
### Factor the equation:

5. From the same drop-down menu, select **factor** and click **Do**.

6. Click **Return Steps** to close the dialog and return all of the steps to the Maple document.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>Factor the equation:</td>
<td><img src="image" alt="Factor the equation" /></td>
</tr>
<tr>
<td>5. From the same drop-down menu, select <strong>factor</strong> and click <strong>Do</strong>.</td>
<td>$(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)$ manipulate equation $(x - 7)^2 + (x - 1)^2 = 4(x - 1)^2 + 4(x - 4)^2$ $$(x - 7)^2 - 3(x - 1)^2 - 4(x - 4)^2 = 0$$ $$-6x^2 + 24x - 18 = 0$$ $$-6(x - 1)(x - 3) = 0$$</td>
</tr>
<tr>
<td>6. Click <strong>Return Steps</strong> to close the dialog and return all of the steps to the Maple document.</td>
<td>$(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)$</td>
</tr>
</tbody>
</table>

---

### Instant Solution

To apply an instant solution to this problem, use the Context Panel.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + drag the equation $(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)$ to a new document block region.</td>
<td>$(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)$</td>
</tr>
<tr>
<td>2. From the Context Panel for this expression, select <strong>Solve</strong> → <strong>Obtain Solutions for</strong> → $x$.</td>
<td>$(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)$ solutions for $x$ → $1, 3$</td>
</tr>
</tbody>
</table>

### Step-by-step Interactive Solution

This equation can also be solved interactively in the document, by applying context-sensitive operations or commands one step at a time.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + drag the equation $(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)$ to a blank document block region.</td>
<td>$(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)$</td>
</tr>
<tr>
<td>Group all terms on the right:</td>
<td>$(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)$ move to right $0 = 3(x - 1)^2 + 4(x - 4)^2 - (x - 7)^2$ (5.11)</td>
</tr>
<tr>
<td>2. From the Context Panel for this equation, select <strong>Move to Right</strong>.</td>
<td>$0 = 3(x - 1)^2 + 4(x - 4)^2 - (x - 7)^2$ right-hand side $3(x - 1)^2 + 4(x - 4)^2 - (x - 7)^2$ expand $6x^2 - 24x + 18$</td>
</tr>
<tr>
<td>Expand the expression on the right-hand side:</td>
<td></td>
</tr>
<tr>
<td>3. From the Context Panel for this output (or Ctrl + drag the equation to a blank document block region), select <strong>Right-hand side</strong>.</td>
<td></td>
</tr>
<tr>
<td>4. From the Context Panel for this result, select <strong>Expand</strong>.</td>
<td></td>
</tr>
</tbody>
</table>
Use Maple's factor command on the resulting right-hand side:
5. From the Context Panel for the result, select Right-hand Side.
6. From the Context Panel for the result, select Factor.

Solve for x:
7. From the Context Panel for the result, select Solve → Obtain Solutions for → x.

Graphical Solution
Now that we have seen several methods to solve this problem, we can check the answer by plotting the expression.
### 3. Select the output and from the Context Panel select **Left-hand Side.**

\[(x - 7)^2 - 3 (x - 1)^2 - 4 (x - 4)^2 = 0\]

### 4. Select the output and from the Context Panel select **Expand.**

\[(x - 7)^2 - 3 (x - 1)^2 - 4 (x - 4)^2 \Rightarrow -6x^2 + 24x - 18\]

---

Now that the equation is in its simplest form, plot the result:

5. **Ctrl +** drag the output to a new document block.

6. From the Context Panel for thee expression select **Plots → 2-D Plot.**

Or,

Right-click the output from step 4 and select **Plots → 2-D Plot.**
Result in Document

7. By default, the plot uses a range chosen to fit the key features of the graph. To better see the \( x \)-intercepts, change the range: from the Context Panel, select Axes → Properties. In the Horizontal tab of the Axes Properties dialog, clear the Use data extents check box and change the Range min and Range max to 0 and 5, respectively.

Click the Vertical tab and clear the Use data extents check box. Change the Range min and Range max to -5 and 10, respectively.

8. Click OK to apply the changes and return to the plot.

The interception points of this graph with the \( x \)-axis are 1 and 3, the same solutions that we found previously.

Graphical Solution Using Smart Popups

Use Smart Popup menu options to find a graphical solution.

Copy the equation
\[
(x - 7)^2 + (x - 1)^2 = 4\left( (x - 1)^2 + (x - 4)^2 \right)
\]
to a new document block region and press Enter.

Highlight the right-hand side of the output expression. Smart popups are shown in the top of the Context Panel.

Select the Subtract menu option.

The results of the calculation are displayed in the document.

Select the left side of the equation. A smart popup window is displayed.
Select normal. The results of the calculation are displayed in the document.

\[(x - 7)^2 + (x - 1)^2 = 4( (x - 1)^2 + (x - 4)^2)\]

\[(x - 7)^2 + (x - 1)^2 = 4( (x - 1)^2 + 4(x - 4)^2)\] (5.15)

subtract $4(x-1)^2+4(x-4)^2$ from both sides

\[(x - 7)^2 - 3(x - 1)^2 - 4(x - 4)^2 = 0\] (5.16)

normal $x-7=2-3P(x-1)^2-4(x-4)^2$

\[-6x^2 + 24x - 18 = 0\] (5.17)

Once again, select the left side of the equation. A smart popup window is displayed. Select 2D plot.

The resulting plot is displayed in the document.

\[(x - 7)^2 + (x - 1)^2 = 4( (x - 1)^2 + (x - 4)^2)\]

\[(x - 7)^2 + (x - 1)^2 = 4( (x - 1)^2 + 4(x - 4)^2)\] (5.18)

subtract $4(x-1)^2+4(x-4)^2$ from both sides

\[(x - 7)^2 - 3(x - 1)^2 - 4(x - 4)^2 = 0\] (5.19)

normal $x-7=2-3P(x-1)^2-4(x-4)^2$

\[-6x^2 + 24x - 18 = 0\] (5.20)

You can also solve the equation using smart popups. Highlight the simplified equation and from the Smart Popup menu, select solve.
The solution to the equation is displayed.  

Example 3 - Solve a Quadratic Trig Equation

Find all of the solutions to the equation $6 \cos^2(x) - \cos(x) - 2 = 0$ in the interval $[0, 2\pi]$.  

We solve this problem using the following methods:

- **Graphical Solution** (page 170)
- **Solution by Task Template** (page 172)
- **Analytic Solution** (page 172)

### Graphical Solution

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
</table>
| 1. Ctrl + drag the equation $6 \cos^2(x) - \cos(x) - 2 = 0$ to a blank document block.  
2. From the Context Panel for the equation, select **Left-hand Side**.  
3. Click the output and select **Plot Builder** in the Context Panel. A plot appears. In the Plot Builder panel, in the plot type list, the initially selected plot type is **2-D plot**.  
4. Modify the plot range to $x = 0$ to $2\pi$.  |
| $6 \cos(x)^2 - \cos(x) - 2 = 0$  
$6 \cos(x)^2 - \cos(x) - 2$  
$2$  

[[x = 1], [x = 3]]
5. Click **Plot** to display the plot in the document.

6. From the graph, we can see all of the solutions within the interval \([0, 2\pi]\). To approximate the values, click the plot, select the type of coordinates that you want to view from the selection menu (\(\mathbf{\text{•••}}\)) in the toolbar, and then use the point probe tool to view the coordinates of the mouse pointer.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>5. Click <strong>Plot</strong> to display the plot in the document.</td>
<td></td>
</tr>
<tr>
<td>6. From the graph, we can see all of the solutions within the interval</td>
<td></td>
</tr>
<tr>
<td>([0, 2\pi]). To approximate the values, click the plot, select the</td>
<td></td>
</tr>
<tr>
<td>type of coordinates that you want to view from the selection menu</td>
<td></td>
</tr>
<tr>
<td>((\mathbf{\text{•••}})) in the toolbar, and then use the point</td>
<td></td>
</tr>
<tr>
<td>probe tool to view the coordinates of the mouse pointer.</td>
<td></td>
</tr>
</tbody>
</table>
### Solution by Task Template

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. From the <strong>Tools</strong> menu, select <strong>Tasks</strong> → <strong>Browse</strong>. Expand the <strong>Algebra</strong> folder and select <strong>Solve Analytically in a Specified Interval.</strong></td>
<td><img src="image1.png" alt="Image" /></td>
</tr>
<tr>
<td>2. Click <strong>Insert Minimal Content.</strong></td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
<tr>
<td>3. Replace the current equation with the one from this example, $6 \cos^2(x) - \cos(x) - 2 = 0$, and then execute the commands. Notice that equation labels are used to reference the results.</td>
<td><img src="image3.png" alt="Image" /></td>
</tr>
</tbody>
</table>

### Analytic Solution

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. <strong>Ctrl</strong> + drag the equation $6 \cos^2(x) - \cos(x) - 2 = 0$ to a blank document block region.</td>
<td>$6 \cos^2(x) - \cos(x) - 2 = 0$</td>
</tr>
<tr>
<td>2. From the Context Panel, select <strong>Left-hand Side.</strong></td>
<td>$6 \cos^2(x) - \cos(x) - 2 = 0$ <strong>left hand side</strong></td>
</tr>
<tr>
<td>3. From the Context Panel, select <strong>Factor.</strong></td>
<td>$6 \cos(x)^2 - \cos(x) - 2$</td>
</tr>
<tr>
<td>4. Click the new factored output and select <strong>Solve</strong> → <strong>Solve</strong> in the Context Panel.</td>
<td>$6 \cos(x)^2 - \cos(x) - 2 = 0$ <strong>factor</strong> $(2 \cos(x) + 1)(3 \cos(x) - 2)$ <strong>solve</strong>, ${x = \frac{2\pi}{3}, x = \arccos\left(\frac{2}{3}\right)}$</td>
</tr>
</tbody>
</table>

Alternatively, you can select each factor, **Ctrl** + drag the expressions to separate document block regions and for each one select **Solve** → **Solve.**
Example 4 - Find the Inverse Function

If \( f(x) = x^2 + 1, x \geq 0 \), find and graph the rule for \( f^{-1}(x) \), its functional inverse.

We solve this problem using the following methods:

- Implement the Definition Graphically (page 173)
- Solution by Tutor (page 176)

Implement the Definition Graphically

The graph of the inverse function is the set of ordered pairs formed by interchanging the ordinates and abscissas.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In a blank document block, enter ([x^2 + 1, x]) and press Enter.</td>
<td>([x^2 + 1, x])</td>
</tr>
<tr>
<td>2. Click the output and select Plot Builder in the Context Panel. In the Plot Builder panel select 2-D plot (parametric) for the plot type. The plot appears.</td>
<td>([x^2 + 1, x])</td>
</tr>
<tr>
<td>3. Adjust the domain for (x) to the interval.</td>
<td><img src="image" alt="Graph" /></td>
</tr>
</tbody>
</table>
4. Copy and paste the expression $x^2 + 1$ onto this graph. Notice that the axis ranges alter.

5. Copy and paste the expression $x$ onto this graph. The resulting graph shows $\hat{f}(x)$, $\hat{f}(x)$, and the line $y = x$. 
Adjust the $x$ and $y$ axis ranges:

6. Select the plot and from the Plot menu, select Axes $\rightarrow$ Properties.

7. In the Axis Properties dialog, de-select Use data extents and change the range to 0 to 2.

8. Click the Vertical tab and repeat step 9. Click OK to apply these settings and close the dialog.
1. Load the **Student Calculus 1** package. From the **Tools** menu, select **Load Package** → **Student Calculus 1**.

2. Enter the expression $x^2 + 1$ in a blank document block.

3. From the Context Panel, select **Student Calculus 1** → **Tutors** → **Function Inverse**. The **Function Inverse Tutor** displays.

4. Adjust the domain to $\text{Domain}$. 

---

**Solution by Tutor**

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Load the <strong>Student Calculus 1</strong> package. From the <strong>Tools</strong> menu,</td>
<td>Loading <strong>Student:-Calculus1</strong></td>
</tr>
<tr>
<td>select <strong>Load Package</strong> → <strong>Student Calculus 1</strong>.</td>
<td></td>
</tr>
<tr>
<td>2. Enter the expression $x^2 + 1$ in a blank document block.</td>
<td>$x^2 + 1$</td>
</tr>
<tr>
<td>3. From the Context Panel, select <strong>Student Calculus 1</strong> → <strong>Tutors</strong></td>
<td></td>
</tr>
<tr>
<td>→ <strong>Function Inverse</strong>. The <strong>Function Inverse Tutor</strong> displays.</td>
<td></td>
</tr>
<tr>
<td>4. Adjust the domain to $\text{Domain}$</td>
<td></td>
</tr>
</tbody>
</table>
Example 5 - Methods of Integration - Trig Substitution

Evaluate the integral \[ \int \frac{1}{\sqrt{4 - x^2}} \, dx \] by making the substitution \( x = 2 \sin(u) \).

We solve this problem using the following methods:

- **Immediate Evaluation of the Integral** (page 177)
- **Solution by Integration Methods Tutor** (page 178)
- **Solution by First Principles** (page 179)

**Immediate Evaluation of the Integral**

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Enter the integral ( \int \frac{1}{\sqrt{4 - x^2}} , dx ) in a blank document block region.</td>
<td>( \int \frac{1}{\sqrt{4 - x^2}} , dx )</td>
</tr>
<tr>
<td>2. From the Context Panel for the expression and select Evaluate and Display Inline.</td>
<td>( \int \frac{1}{\sqrt{4 - x^2}} , dx = \arcsin\left( \frac{x}{2} \right) )</td>
</tr>
</tbody>
</table>
**Solution by Integration Methods Tutor**

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Load the Student Calculus 1 package. From the Tools menu, select Load Package → Student Calculus 1.</td>
<td>Loading Student::Calculus1</td>
</tr>
<tr>
<td>2. Ctrl + drag the integrand ( \frac{1}{\sqrt{4 - x^2}} ) to a blank document block region.</td>
<td>( \frac{1}{\sqrt{4 - x^2}} )</td>
</tr>
<tr>
<td>3. From the Context Panel, select Student Calculus 1 → Tutors → Integration Methods. The Integration Methods Tutor displays.</td>
<td><img src="image" alt="Integration Methods Tutor" /></td>
</tr>
<tr>
<td>4. Perform a change of variables by selecting Change and entering ( x = 2 \sin(u) ).</td>
<td>( \int \left( \frac{1}{\sqrt{4 - x^2}} \right)^{\frac{1}{2}} , dx )</td>
</tr>
</tbody>
</table>
5. Apply the constant rule by clicking **Constant**.
6. To revert back to the original variable, click **Revert**.

\[
\int \left(\frac{1}{2} - x^2\right)^{\frac{1}{2}} \, dx
= \int 1 \, du
= u
= \arcsin\left(\frac{1}{2} \cdot x\right)
\]

7. Now that the integral has been evaluated, click **Close** to close the tutor and return the evaluated integral to the document.

\[
\int \frac{1}{\sqrt{4 - x^2}} \, dx
= \int 1 \, du \quad [\text{change, } x = 2 \sin(u), u]
= u \quad [\text{constant}]
= \arcsin\left(\frac{1}{2} \cdot x\right) \quad [\text{revert}]
\]

\[
\int \frac{1}{\sqrt{-x^2 + 4}} \, dx = \arcsin\left(\frac{1}{2} \cdot x\right)
\]

**Solution by First Principles**

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
</table>
| 1. Ctrl + drag the integrand \(\frac{1}{\sqrt{4 - x^2}}\) to a blank document block region and press **Enter**. | \[
\frac{1}{\sqrt{4 - x^2}}
\]
| 2. From the Context Panel for the output, select **Evaluate at a point**. In the dialog that displays, enter \(2 \cdot \sin(u)\). | \[
\frac{1}{\sqrt{-x^2 + 4}}
\]
| 3. From the Context Panel for the output, select **Simplify \rightarrow Symbolic**. | \[
\frac{1}{2 \cos(u)}
\]

(5.22)

(5.23)
### Example 6 - Initial Value Problem

Solve and plot the solution of the initial value problem

\[
\begin{align*}
y''(t) + 4y'(t) + 13y(t) &= \cos(2t) \\
y(0) &= 2 \\
y'(0) &= -1
\end{align*}
\]

#### Calculations

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
</table>
| Calculate \( \frac{du}{dx} \): | \[
x = 2 \sin(u)
\]
| 4. In a blank document block, enter the substitution equation: \( x = 2 \sin(u) \) and press **Enter**. | \[
\text{implicit differentiation} \\
2 \cos(u)
\] \( (5.24) \)
| 5. From the Context Panel for the output, select **Differentiate** \( \rightarrow \) **Implicitly**. In the dialog that displays, change the **Dependent Variable** to \( x \) and change **Differentiate with respect to** to \( u \). | \[
(5.23) \cdot (5.24)
\]
| Calculate the integral in terms of \( u \): | \[
\int (5.25) \, du \\
1
\] \( (5.25) \)
| 6. Referencing the results by their equation labels, multiply the original simplified expression by this derivative. | \[
(5.26)
\]
| 7. Integrate the resulting expression. | \[
x = 2 \sin(u)
\]
| Revert the substitution: | \[
x = 2 \sin(u)
\]
| 8. Place the equation \( x = 2 \sin(u) \) in a blank document block. Delete \( u \) and insert the equation label for the previous result, the value of the integral in terms of \( u \). Press **Enter**. | \[
\left[ u = \arcsin\left(\frac{x}{2}\right) \right]
\]
| 9. From the Context Panel for the output, select **Solve** \( \rightarrow \) **Solve for Variable** \( \rightarrow u \). | \[
\text{solve for } u
\]
| The solution is \( \arcsin\left(\frac{1}{2}x\right) \). |
Solution by ODE Analyzer Assistant

The ODE Analyzer Assistant lets you solve ODEs numerically or symbolically and displays a plot of the solution.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Enter the ODE in a blank document block region.</td>
<td>$y''(t) + 4, y'(t) + 13, y(t) = \cos(2, t)$</td>
</tr>
<tr>
<td>2. Select the equation and from the Context Panel, select <strong>Solve DE</strong> Interactively. The ODE Analyzer Assistant displays with the ODE automatically inserted.</td>
<td><img src="image" alt="ODE Analyzer Assistant" /></td>
</tr>
<tr>
<td>To insert the initial conditions:</td>
<td></td>
</tr>
<tr>
<td>3. In the <strong>Conditions</strong> region, click <strong>Edit</strong>. The <strong>Edit Conditions</strong> dialog opens.</td>
<td><img src="image" alt="Edit Conditions" /></td>
</tr>
<tr>
<td>4. In the <strong>Add Condition</strong> region, with $y$ selected in the drop-down menu, enter 0 in the first text field to the right and 2 in the second text field. Click <strong>Add</strong>. Your entry should match the one shown to the right.</td>
<td><img src="image" alt="Add Condition" /></td>
</tr>
</tbody>
</table>

5.8 Clickable Math™ • 181
5. To enter the initial condition for $y'$, select $y'$ from the drop-down menu. In the text fields, enter 0 and -1. Click Add.

Click Done to close this dialog and return to the main dialog. Notice that the initial conditions are in the Conditions section.


7. Click Solve to solve the initial value problem.

8. Click Plot to plot the solution of the DE.

9. Click the Plot Options button to modify the default graph, if desired.

10. Click Quit to close the ODE Analyzer and return a plot of the solution to the document.

$$y''(t) + 4y'(t) + 13y(t) = \cos(2t)$$

$$y(0) = 2$$

$$y'(0) = -1$$

$$y(t) = e^{-2t}\sin(3t)\_C2 + e^{-2t}\cos(3t)\_C1 + \frac{9\cos(2t)}{145} + \frac{8\sin(2t)}{145}$$
6 Plots and Animations

Maple can generate many forms of plots, allowing you to visualize a problem and further understand concepts.

• Maple accepts explicit, implicit, and parametric forms to display 2-D and 3-D plots and animations.
• Maple recognizes many coordinate systems.
• All plot regions in Maple are active; therefore, you can drag expressions to and from a plot region.
• Maple offers numerous plot options, such as axis styles, title, colors, shading options, surface styles, and axis ranges, which give you complete control to customize your plots.

For a reference to the types of plots available in Maple, see the Plotting Guide.

6.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Creating Plots (page 183) - Interactive and command-driven methods to display 2-D and 3-D plots | • Interactive Plot Builder  
• Context Panel  
• The `plot` and `plot3d` Commands  
• The `plots` Package  
• Multiple Plots in the Same Plot Region |
| Customizing Plots (page 204) - Methods for applying plot options before and after a plot displays | • Interactive Plot Builder Options  
• Context Panel Options  
• The `plot` and `plot3d` Command Options |
| Analyzing Plots (page 210) - Plot analyzing tools | • Point Probe  
• Rotate  
• Pan  
• Zoom |
| Representing Data (page 211) - Templates for visual representation of your data | • The Live Data Plots Palette |
| Creating Animations (page 211) - Interactive and command-driven methods to display animations | • Interactive Plot Builder  
• The `plots[animate]` Command  
• The `plot3d[viewpoint]` Command |
| Playing Animations (page 216) - Tools to run animations | • Animation Context Bar |
| Customizing Animations (page 217) - Methods for applying plot options before and after an animation displays | • Interactive Plot Builder Animation Options  
• Context Menu Options  
• The `animate` Command Options |
| Exporting (page 219) - Methods for exporting plots | • Saving Plots to File Formats |

6.2 Creating Plots

Maple offers several methods to easily plot an expression. These methods include:

• The Interactive Plot Builder  
• The context panel  
• Commands
Each method offers a unique set of advantages. The method you use depends on the type of plot to display, as well as your personal preferences.

**Interactive Plot Builder**

The Interactive Plot Builder is a point-and-click interface to Maple plotting functionality. The interface displays plot types based on the expression you specify. Depending on the plot type you select, you can create a:

- 2-D / 3-D plot
- 2-D polar plot
- 2-D / 3-D contour plot
- 2-D / 3-D conformal plot of a complex-valued function
- 2-D / 3-D complex plot
- 2-D / 3-D parametric plot
- 2-D density plot
- 2-D / 3-D implicit plot
- 2-D inequality plot
- 3-D spacecurve
- 2-D animated curve
- 2-D / 3-D plot of multiple expressions
- 2-D / 3-D exploration of a plot with one interactive parameter (slider)
Launching the PlotBuilder

Context Panel Access

The Plot Builder can be launched using the context panel for an expression.

Click on the expression you'd like to plot and from the context panel select Plot Builder. In this case, the Plot Builder Panel opens.

This is equivalent to calling the PlotBuilder command on the expression.

Assistants Access

The Plot Builder can also be accessed from the Standard Menu Bar, under Tools -> Assistants.

When launched in this way, an interactive dialog is displayed where you can enter the expression to be plotted. This is equivalent to calling the PlotBuilder command with no arguments.

Note: The Tools menu also offers tutors to easily generate plots in several academic subjects. For more information, see Teaching and Learning with Maple (page 145).
Example 1 - Display a plot of a single variable expression

Maple can display two-dimensional graphs and offers numerous plot options such as color, title, and axis styles to customize the plot.

Enter an expression:
1. Type the expression $\sin(x)/x$.

From the Context Panel, select the Plot Builder:
2. From the Context Panel for the expression, select Plot Builder. The Plot Builder inserts plot component, with a plot of the expression, into the worksheet, and the Context Panel shows the Plot Builder options.

3. The automatically selected plot type for this expression is 2-D plot, and the panel is now populated with the available plotting options for a 2-D plot.

4. Ensure that the x-axis range is from $-2\pi$ to $2\pi$.

When you return focus to your worksheet, you'll no longer see the Plot Builder controls. To make further modifications, click the output region of the displayed plot in the worksheet to again view the plot builder controls on the right.

Note: You can toggle the show command option to view the Maple syntax used to generate this plot.
Example 2 - Display a plot of multiple expressions in 1 variable

Maple can display multiple expressions in the same plot region to compare and contrast. The Interactive Plot Builder accepts multiple expressions.

Launch the Interactive Plot Builder and enter the expressions:

If the PlotBuilder is passed a list, set, or sequence containing multiple expressions then the context panel becomes automatically populated with a thumbnail view. The common plot type for expressions in a single unknown is a 2-D curve, and for expressions in two unknowns it is a 3-D surface plot.

As an example, use the PlotBuilder to plot $\sin(x^2)$, $\frac{d}{dx} \sin(x^2)$ and $\int \sin(x^2) \, dx$.

$$> \text{PlotBuilder}\left(\sin(x^2), \frac{d}{dx} \sin(x^2), \int \sin(x^2) \, dx\right)$$

Notice in the PlotBuilder window, from the thumbnail view you can change the common plot type for all expressions using the ListBox menu. You can select any individual thumbnail plot to change its associated properties or its own plot type in the PlotBuilder's usual individual plot view.

By default, Maple displays each plot in a plot region using a different color. You can also apply a line style such as solid, dashed, or dotted for each expression in the graph. For more information, refer to the plot/options help page. To see the Maple syntax used to generate this plot, see Maple commands from Creating Plots: Interactive Plot Builder (page 190)

Example 3 - Display a plot of a multivariate expression

Maple can display three-dimensional plots and offers numerous plot options such as light models, surface styles, and shadings to allow you to customize the plot.

Enter an expression, then launch the Interactive Plot Builder from the context panel:

1. Enter the expression $\frac{1+\sin(x*y)}{(x^2+y^2)}$.
2. Launch the Plot Builder from the context panel.

In the Select Plot Type list:

3. Notice the available plot types for an expression with 2 variables, as well as the plot objects for each type. For this example, select 3-D plot.
4. Select Basic Options from the list of option types.

Restricting how much of the plot axes to display:

5. For the view option, select axis[3] to adjust how much of the z-axis to display. Enter the range values in the two boxes. You can repeat this for the y-axis (axis[2]) and x-axis (axis[1]) as well.

Style and color changes:

6. From the Style combo box, select surface.
7. From the shading and color list box select shading, then select z (grayscale) from the color list box.
8. Select the Axes and Text menu.
9. In the text box next to label, enter z.
10. Select the 3-D Options menu
11. In the text box beside grid size, enter 40,40.

Note: You can toggle the show command option to view the Maple syntax used to generate this plot.
Example 4 - Display a conformal plot

Maple can display a conformal plot of a complex expression mapped onto a two-dimensional grid or plotted on the Riemann sphere in 3-D.

Enter an expression, then launch the Interactive Plot Builder from the context panel:

1. Enter the expression \( z^3 \).
2. Launch the Plot Builder from the context panel.
3. Select 2-D conformal plot as the plot type.
4. Change the range of the \( z \) parameter to \( 0 .. 2+2*I \).
5. From the axes style box, ensure normal is selected.
6. Select 2-D Options from the plot options list box, then enter [30,30] as the grid size.

Example 5 - Display a plot in polar coordinates

Cartesian (ordinary) coordinates is the Maple default. Maple also supports numerous other coordinate systems, including hyperbolic, inverse elliptic, logarithmic, parabolic, polar, and rose in two-dimensions, and bipolar cylindrical, bispherical, cylindrical, inverse elliptical cylindrical, logarithmic cosh cylindrical, Maxwell cylindrical, tangent sphere, and toroidal in three-dimensional plots. For a complete list of supported coordinate systems, refer to the coords help page.

Enter an expression, then launch the Interactive Plot Builder from the context panel:

1. Enter the expression \( 1+4*\cos(4*\theta) \).
2. Launch the Plot Builder from the context panel.
3. Select the plot type and change the x-axis range:
4. Select 2-D polar plot as the plot type.
5. Change the angle of \( \theta \) to \( 0 .. 8*\pi \).
6. Change the plot color:
7. From the color group box, select magenta.

Note: You can toggle the show command option to view the Maple syntax used to generate this plot.

Example 6 - Interactive plotting

In this example, we'll make an animation of \( x + 3 \sin(x*t) \), as \( t \) goes from 1 to 10.

Enter an expression, then launch the Interactive Plot Builder from the context panel:

1. Enter the expression \( x+3*\sin(x*t) \).
2. Launch the Plot Builder from the context panel.
3. Select animation.
4. The animation parameter is given under the animation toggle button. By default, this will animate as \( t \) goes from 1 to 10. (Note, if you wanted to animate over another variable, use this to specify that.
5. Set the \( x \) range to 0 to 5.
6. Click Build Animation.
Play the animation.

7. To play the animation, click the plot and then from the Animation Toolbar, select Play (►). For information on playing the animation, see Playing Animations (page 216).

Alternatively, you can use the exploration option in the Plot Builder to build an interactive plot with one parameter that you operate with a slider. For more about explorations, see Exploration Assistant (page 29).

**Context Panel**

The context panel is a collection of tools and operations that are appropriate for a particular expression. The plotting options in the context panel change according to the expression, table, or region that you click on.

One advantage of using the context panel is the simplicity of creating an expression using the tools and operations in the panel. By using this method, you do not need any knowledge of plot command syntax.

1. Enter and evaluate an expression, for example, \( \frac{xy}{x^2 + y^2} \).
2. Click the expression.
3. From the context panel, select Plots → 3-D Plot → xy.

\[
\frac{xy}{x^2 + y^2} \quad (6.1)
\]

Figure 6.1: Plot an Expression Using the Context Panel

For information on customizing plots using the context menu, see Context Panel Options (page 205).

**The plot and plot3d Commands**

The final method for creating plots is entering plotting commands.

The main advantages of using plotting commands are the availability of all Maple plot structures and the greater control over the plot output. Plot options are discussed in Customizing Plots (page 204).
Table 6.1: The plot and plot3d Commands

plot(plotexpression, x=a..b, ...)
plot3d(plotexpression, x=a..b, y=a..b, ...)

- plotexpression - expression to be plotted
- x=a..b - name and horizontal range
- y=a..b - name and vertical range

Note: It's possible to not specify the ranges for the variables, in which case Maple determines a reasonable domain.

Maple commands from Creating Plots: Interactive Plot Builder

Example 1 - Display a plot of a single variable expression

> plot(\( \frac{\sin(x)}{x} \), x = -2 \pi .. 2 \pi)

Example 2 - Display a plot of multiple expressions in 1 variable

To display multiple expressions in a plot, include the expressions in a list. To enter \( \frac{d}{dx} \sin(x^2) \) and \( \int \sin(x^2) \, dx \), use the Expression palette. For more information, see Palettes (page 15).
> plot([sin(x^2), diff(x^2, x), int(x^2) dx], x = -pi..pi)
Example 3 - Display a plot of a multivariable expression

```latex
> plot3d\left(\frac{1 + \sin(x-y)}{x^2 + y^2}, x = -2 \pi..2 \pi, y = -2 \pi..2 \pi, \text{view} = 0..0.5, \text{lightmodel} = \text{light1}, \text{shading} = \text{zgrayscale}, \text{style} = \text{patchnogrid}, \text{grid} = [40, 40]\right)
```

Example 4 - Display a conformal plot

A collection of specialized plotting routines is available in the plots package. For access to a single command in a package, use the long form of the command.
> plots[conformal](z^3, z = 0..2 + 2 I, axes=normal, grid = [20, 20])
Example 5 - Display a plot in polar coordinates

> `plots[polarplot](1 + 4 \cos(4 \theta), \theta = 0 .. 8 \pi, color = magenta)`
Example 6 - Interactive Plotting

```plaintext
> plots[animate](plot, [x + 3 sin(x·t), x = 0 .. 0.5, t = 0 .. 10])

\[ t = 0. \]
```

To play the animation, click the plot and the from the Animation Toolbar, select Play ( ). For information on playing the animation, see Playing Animations (page 216).

For more information on the plot options used in this section, refer to the plot/options and plot3d/options help pages.

**Display a Parametric Plot**

Some graphs cannot be specified explicitly. In other words, you cannot write the dependent variable as a function of the independent variable, \( y = f(x) \). One solution is to make both the x-coordinate and the y-coordinate depend on a parameter.
Display a 3-D Plot

Maple can plot an expression of two variables as a surface in three-dimensional space. To customize the plot, include `plot3d` options in the calling sequence. For a list of plot options, see *The plot and plot3d Options (page 208).*
The plots Package

The plots package contains numerous plot commands for specialized plotting. This package includes: animate, contourplot, densityplot, fieldplot, odeplot, matrixplot, spacecurve, textplot, tubeplot, and more. For details about this package, refer to the plots help page.

> with(plots) :

The pointplot Command

To plot numeric data, use the pointplot command in the plots package with the data organized in a list of lists structure of the form \([ [x_1, y_1], [x_2, y_2], \ldots, [x_n, y_n]]\). By default, Maple does not connect the points. To draw a line through the points, use the style = line option. For further analysis of data points, use the Curve Fitting Assistant (Tools→Assistants→CurveFitting), which fits and plots a curve through the points. For more information, refer to the CurveFitting[Interactive] help page.
The `matrixplot` Command

The `matrixplot` command plots the values of a plot object of type `Matrix`. The `matrixplot` command accepts options such as `heights` and `gap` to control the appearance of the plot. For more information on Matrices, see *Linear Algebra (page 116).*

```plaintext
> with(LinearAlgebra)
```

> `pointplot([[0, 1], [1, -1], [3, 0], [4, -3], [2, 0], [4, 1], [3, -2], [4, 1]], axes = boxed, symbolsize = 25, symbol = circle)`
> A := HilbertMatrix(6)

\[
A := \begin{bmatrix}
1 & 1 & 1 & 1 & 1 & 1 \\
\frac{1}{2} & 3 & 4 & 5 & 6 & 7 \\
2 & 3 & 4 & 5 & 6 & 8 \\
\frac{1}{3} & \frac{1}{4} & \frac{1}{5} & \frac{1}{6} & \frac{1}{7} & \frac{1}{8} \\
\frac{1}{4} & \frac{1}{5} & \frac{1}{6} & \frac{1}{7} & \frac{1}{8} & \frac{1}{9} \\
\frac{1}{5} & \frac{1}{6} & \frac{1}{7} & \frac{1}{8} & \frac{1}{9} & \frac{1}{10} \\
\frac{1}{6} & \frac{1}{7} & \frac{1}{8} & \frac{1}{9} & \frac{1}{10} & \frac{1}{11}
\end{bmatrix}
\]

> B := ToeplitzMatrix([1, 2, 3, 4, 5, 6], symmetric)

\[
B := \begin{bmatrix}
1 & 2 & 3 & 4 & 5 & 6 \\
2 & 1 & 2 & 3 & 4 & 5 \\
3 & 2 & 1 & 2 & 3 & 4 \\
4 & 3 & 2 & 1 & 2 & 3 \\
5 & 4 & 3 & 2 & 1 & 2 \\
6 & 5 & 4 & 3 & 2 & 1
\end{bmatrix}
\]

> matrixplot(A + B, heights = histogram, axes = normal, gap = 0.25, style = patch)
The contourplot Command

The `contourplot` command generates a topographical map for an expression or function. To create a smoother and more precise plot, increase the number of points using the `numpoints` option.
Drag the expression onto the plot of \( \sin(x) \). When dragging an expression to a plot region, you can either make a copy of the expression from the input region or you can cut the expression, thereby removing it from the input region. To make a copy of the expression, select the full expression in the input region and press \( \text{Ctrl} \) (Command, Macintosh) while you drag the expression to the plot region. To cut the expression and paste it in the plot region, highlight the expression and drag it to the plot region.

4. Repeat steps 3 and 4 using the following expressions: \( \sin(x + 2) \) and \( \sin(x)^2 \).
**Tip:** To remove an expression from the plot region, drag-and-drop the expression plot from the plot region to a Maple input region.

**List of Expressions**

To display multiple expressions in the same plot region, enter the expressions in a list data structure. To distinguish the surfaces, apply different shading options, styles, or colors to each surface.
The display Command

To display different types of plots in the same plot region, use the display command in the plots package.

This example plots a curve over a hill with the shadow of the curve projected onto the hill.

```maple
> plot3d([cos(5*x) + cos(5*y), x^2 + 3*y^2 - 4], x = -2..2, y = -1..1, shading=[zgrayscale, none], color=[default,grey], style=[patchnogrid, patch], lightmodel=light3, transparency=0.1)
```

> z := 10 \left( x^2 + y^5 + \frac{x}{5} \right) e^{-x^2-y^2}:

> hill := plot3d(z, x = -2..2, y = -2.5..2.5, shading = hue, style = patchnogrid, lightmodel = light3, orientation = [125, 60]) :

> xt := cos(t) :

> yt := 2 sin(t) :

Maple can draw curves in three-dimensional space.

> curve := spacecurve([xt, yt, 10], t = 0..10, color = red, thickness = 2) :

> zt := subs({x = xt, y = yt}, z) :

> shadow := spacecurve([xt, yt, zt], t = -\pi..\pi, color = black, thickness = 2):
```
6.3 Customizing Plots

Maple provides many plot options to display the most aesthetically pleasing, illustrative results. Plot options include line styles, colors, shadings, axis styles, and titles where applicable. Plot options are applied using the Interactive Plot Builder, the context menus, or as options in the command syntax.

Interactive Plot Builder Options

The Interactive Plot Builder offers most of the plot options available in Maple in an easy-to-use interface.

Example:

Enter the expression, then launch the Plot Builder from the context panel:

1. Enter the expression \(2x^5 - 10x^3 + 6x - 1\).

2. Launch the Plot Builder from the context panel. For information on interacting with the Interactive Plot Builder, see Example 1 - Display a plot of a single variable expression (page 186).

Set the x-axis range:

3. Select 2-D Plot as the plot type.

4. Change the x-axis range to \(-2 \ldots 2\).
In the Basic Options window:
5. From the *line style* list box, select *dot*.
6. From the *color* list box, select *blue*.
7. From the *axes style* list box, select *frame*.

In the Axes and Text window:
8. In the text field beside *title*, enter *My Plot*.

### Context Panel Options

Using the options in the context panel, you can alter a plot by clicking the plot output. You can also access a large subset of plot options using the *Plot* toolbar and *Plot* menu options. These menus display when a plot region is selected. Regardless of the method used to insert a plot into Maple, you can use the context menu to apply different plot options. For a list of options available when plotting in two and three dimensions, see *The plot and plot3d Options* (page 208).

### 2-D Plot Options

Consider this example:

\[
> \text{plot}\left(\frac{x + 2}{(x - 1)^2}, x = -5..5\right)
\]

There is a singularity at \(x = 1\). What are the \(x\) and \(y\)-intercepts? It's hard to see in the current view. If you change the range, the locations of the intercepts are easier to see.
Alter the y-axis range:
1. Click the plot region. From the context panel, select Axes, and then Properties.
2. In the Axes Properties dialog, click the Vertical tab.
3. Clear the Use data extents check box and enter -2 and 5 in the Range min and Range max text regions, respectively.
4. Click Apply to view the changes, or OK to return to the document.

Change the color:
5. Click on the curve. Note: The curve is selected when it becomes highlighted.
6. Select Color, and then Green.

Note: The Niagara colors listed form the default color palette in Maple.

Change the line style:
7. Select Line, and then Dash.

The x-intercept is at x=-2, and the y-intercept is at y=2. This can be verified using the equation \( y = \frac{x + 2}{(x - 1)^2} \).

3-D Plot Options

By default, Maple displays the graph as a shaded surface with a wireframe and scales the plot to fit the window. To change these options, use the context menu.
Maple has many preselected light source configurations.

**Change the style:**
1. Click the plot region. From the context panel select Style → Surface. The wireframe is removed.

**Apply a light scheme:**
2. Select Lighting → Light 1.

**Change the axes style:**
3. Select Axes → Boxed.
Alter the glossiness:
4. Select Glossiness and then select Set.... Using the slider, adjust the level of glossiness.

The plot and plot3d Options

If you are using commands to insert a plot, you can specify plot options as arguments at the end of the calling sequence. You can specify the options in any order. Applying plot options in the command syntax offers a few more options and greater control than what is available in the Interactive Plot Builder and the context panel.

Table 6.2: Common Plot Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>axes</td>
<td>Defines the type of axes, one of: boxed, frame, none, or normal</td>
</tr>
<tr>
<td>caption</td>
<td>Defines the caption for the plot</td>
</tr>
<tr>
<td>color</td>
<td>Defines a color for the curves to be plotted</td>
</tr>
<tr>
<td>font</td>
<td>Defines the font for text objects in the plot</td>
</tr>
<tr>
<td>glossiness (3-D)</td>
<td>Controls the amount of light reflected from the surface</td>
</tr>
<tr>
<td>gridlines (2-D)</td>
<td>Defines gridlines in the plot</td>
</tr>
<tr>
<td>lightmodel (3-D)</td>
<td>Controls the light model to illuminate the plot, one of: none, light1, light2, light3, or light4</td>
</tr>
<tr>
<td>linestyle</td>
<td>Defines the dash pattern used to render lines in the plot, one of: dot, dash, dashdot, longdash, solid, spacedash, and spacedot</td>
</tr>
<tr>
<td>legend (2-D)</td>
<td>Defines a legend for the plot</td>
</tr>
<tr>
<td>numpoints</td>
<td>Controls the minimum total number of points generated</td>
</tr>
<tr>
<td>scaling</td>
<td>Controls the scaling of the graph, one of: constrained or unconstrained</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td>shading (3-D)</td>
<td>Defines how the surface is colored, one of: xyz, xy, z, zgrayscale, zhue, or none</td>
</tr>
<tr>
<td>size (2-D)</td>
<td>Specifies the size (or ratio) of the plot window</td>
</tr>
<tr>
<td>style</td>
<td>Defines how the surface is to be drawn, one of: line, point, pointline, polygon, or polygonoutline for 2-D plots; contour, point, pointline, surface, surfacecontour, surfacewireframe, wireframe, or wireframeopaque for 3-D plots</td>
</tr>
<tr>
<td>symbol</td>
<td>Defines the symbol for points in the plot, one of: asterisk, box, circle, cross, diagonalcross, diamond, point, solidbox, solidcircle, or soliddiamond for 2-D plots; asterisk, box, circle, cross, diagonalcross, diamond, point, solidsphere, or sphere for 3-D plots</td>
</tr>
<tr>
<td>title</td>
<td>Defines a title for the plot</td>
</tr>
<tr>
<td>thickness</td>
<td>Defines the thickness of lines in the plot</td>
</tr>
<tr>
<td>transparency (3-D)</td>
<td>Controls the transparency of the plot surface</td>
</tr>
<tr>
<td>view</td>
<td>Defines the minimum and maximum coordinate values of the axes displayed on the screen</td>
</tr>
</tbody>
</table>

For a complete list of plot options, refer to the `plot/options` and `plot3d/options` help pages.

```maple
> plot(Si(x), x = -20 .. .20, title = "Plot of the Sine Integral", titlefont = [HELVETICA, 12], color = "Niagara 2", style = point)
```

To create a smoother or more precise plot, calculate more points using the `numpoints` option.
6.4 Analyzing Plots

Point Probe, Rotate, Pan, and Zoom Tools

To gain further insight into a plot, Maple offers various tools to analyze plot regions. These tools are available in the Plot menu, Context Bar, and in the context menu (under Manipulator and Probe Info) when the plot region is selected.

Table 6.3: Plot Context Bar Analysis Options

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point probe</td>
<td></td>
<td>Select a curve. For 2-D plots, select a coordinate type from the Selection Tool menu to display coordinates.</td>
</tr>
<tr>
<td>Selection Tool</td>
<td></td>
<td>Use the Selection Tool to select the information displayed in the point probe tool tooltip. You can choose to display coordinates derived from converted pixel coordinates or data points derived from the original data points.</td>
</tr>
<tr>
<td>Rotate (3-D)</td>
<td></td>
<td>Rotate a three-dimensional plot to see it from a different point of view.</td>
</tr>
<tr>
<td>Pan</td>
<td></td>
<td>Pan the plot by changing the view ranges for 2-D plots; plots are redrawn to reflect the new view. Change the position of the plot in the plot region for 3-D plots.</td>
</tr>
</tbody>
</table>

> plot3d(\frac{x^2 + y^4}{x^2 + y^4}, x = -10 .. 10, y = -10 .. 10, axes=boxed, numpoints = 1500, lightmodel = light3, shading = zgrayscale, orientation = [160, 20], style = patchnogrid)
### 6.5 Representing Data

The **LiveDataPlots** palette has templates that allow you to represent your data in many different ways including:

- Area chart
- Bar chart
- Box plot
- Bubble plot
- Histogram
- Line chart
- Pie chart
- Scatter plot

After you select a type of plot, an interactive environment allows you to change a number of options to refine the look of your plot. As you refine your plot, Maple automatically updates the plot command with your options.

If the **LiveDataPlots** palette is not displayed in the palette dock, right-click on the palette pane, and select **Show Palette**, and then **LiveDataPlots**.

### 6.6 Creating Animations

Animations allow you to emphasize certain graphical behavior, such as the deformation of a bouncing ball, more clearly than in a static plot. A Maple animation is a number of plot frames displayed in sequence, similar to the action of movie frames. To create an animation, use the **Interactive Plot Builder** or commands.

**Interactive Plot Builder**

**Creating Animations Using the Interactive Plot Builder:**

Enter the expression, then launch the Plot Builder from the context panel:

1. Enter the expression \( \sin(i*\sqrt{x^2+y^2}/10) \).
2. Select **Plot Builder** from the context panel.

**In the Basic Options window:**

3. Select the **Animation** radio button.
4. The default **x Axis** range is \(-2*\pi .. 2*\pi\). Change the **x Axis** range to \(-6 .. 6\).
5. The default **y Axis** range is \(-2*\pi .. 2*\pi\). Change the **y Axis** range to \(-6 .. 6\).
6. Select \( i \) as the animation parameter from the drop-down list and the range to \( 1 .. 30 \).
7. From the **Style** group box, select **surface**.
8. From the **Color** group box, in the **Shading** drop-down menu, select **z (grayscale)**.
In the 3-D Options window:

9. In the Scaling drop-down list, select constrained.

Build the Animation:

10. Click Build Animation

11. Click on the plot in the worksheet.

12. From the animation toolbar, click Start/Resume playing the animation.

For information on playing the animation, see Playing Animations (page 216). To see the Maple syntax used to generate this plot, see Maple Syntax for Creating Animations: Interactive Plot Builder Example (page 212).

The plots[animate] Command

You can also use the animate command, in the plots package, to generate animations.

Table 6.4: The animate Command

| animate(plotcommand, plotarguments, t=a..b, ...) |
| animate(plotcommand, plotarguments, t=L, ...) |
| • plotcommand - Maple procedure that generates a 2-D or 3-D plot |
| • plotarguments - arguments to the plot command |
| • t=a..b - name and range of the animation parameter |
| • t=L - name and list of real or complex constants |

To access the command, use the short form name after invoking the with(plots) command.

> with(plots):

Maple Syntax for Creating Animations: Interactive Plot Builder Example

The following example shows the plotting command returned by the example in Interactive Plot Builder (page 211).
\[
\texttt{animate(} \texttt{plot3d, [}\sin\left( \frac{i \sqrt{x^2 + y^2}}{10} \right), x = -6..6, y = -6..6, \text{ style = patchnogrid, lightmodel = light3, shading = zgrayscale, scaling = constrained]} \texttt{, i = 1..30)}
\]

\[i = 1.\]
Animate a 2-D plot

> animate(polarplot, [5 cos(2 θ), θ = 0..t], t = π/4..2π, frames = 50)

For more information on the `animate` command, refer to the `plots[animate]` help page.

The `plot3d(...,viewpoint)` Option

You can use the `viewpoint` option to create an animation in which the position from which you view a 3-D plot moves in all directions and in various angles around the plot surface based on coordinates and parameters you specify. This type of animation creates the effect of flying through, around, beside, towards, and away from a plot surface in three-dimensional space.

The moveable position from which you view the surface is called the camera. You can specify the orientation of the camera to view different sides of a surface, the path along which the camera moves throughout and around a surface, and the location of the camera in 3-D space in each animation frame. For example, you can specify coordinates to move the camera to specific points beside a surface; a pre-defined camera path to move the camera in a circle around the surface; and the range of view to move the camera close to or away from the surface. Refer to the `viewpoint` help page for more information.

To animate the following examples, click the plot object and then click the play button (►) in the Animation context bar.

Example 1: Moving the Camera Around a 3-D Plot

In the following example, a pre-defined path `circleleft` moves the camera in a counter-clockwise circle around the plot surface.
Example 2: Specifying a Path to Move the Camera Towards and Around a 3-D Plot

In the following example, a camera path is specified to zoom into and view different sides of the plot surface.

```r
> plot3d(1.3^x * sin(y), x = -1 .. 2 * pi, y = 0 .. pi, coords = spherical, style = patch, viewpoint = ["circleleft"])
```
> plot3d(sin(x + y), x = -1..1, y = -1..1, shading = xyz, viewpoint = [path = [[50 x, 90 cos(x), 100 sin(x)], x = -2*Pi..Pi]])

### 6.7 Playing Animations

#### Animation Context Bar

To run the animation, click the plot to display the **Animate** context bar.

**Table 6.5: Animation Options**

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous Frame</td>
<td><img src="previous_frame.png" alt="Icon" /></td>
<td>View the previous frame in the animation.</td>
</tr>
<tr>
<td>Stop</td>
<td><img src="stop.png" alt="Icon" /></td>
<td>Stop the animation.</td>
</tr>
<tr>
<td>Play</td>
<td><img src="play.png" alt="Icon" /></td>
<td>Play the selected animation.</td>
</tr>
<tr>
<td>Next Frame</td>
<td><img src="next_frame.png" alt="Icon" /></td>
<td>View the next frame in the animation.</td>
</tr>
<tr>
<td>Current Frame</td>
<td><img src="current_frame.png" alt="Icon" /></td>
<td>Slider control for viewing individual frames of an animated plot.</td>
</tr>
<tr>
<td>Forward</td>
<td><img src="forward.png" alt="Icon" /></td>
<td>Forward - Play the animation forward.</td>
</tr>
<tr>
<td>Oscillate</td>
<td><img src="oscillate.png" alt="Icon" /></td>
<td>Oscillate - Play the animation forward and backward.</td>
</tr>
<tr>
<td>Backward</td>
<td><img src="backward.png" alt="Icon" /></td>
<td>Backward - Play the animation backward.</td>
</tr>
</tbody>
</table>
### 6.8 Customizing Animations

The display options that are available for static plots are also available for Maple animations.

#### Interactive Plot Builder Animation Options

Using the **Interactive Plot Builder**, you can apply various plot options within the **Plot Options** window. See *Interactive Plot Builder* (page 211).

#### Context Panel Options

As with static plots, you can apply plot options to the animation by clicking the animation output.

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single</td>
<td><img src="image" alt="Single Icon" /></td>
<td>Single - Run the animation in single cycle mode. The animation is displayed only once.</td>
</tr>
<tr>
<td>Continuous</td>
<td><img src="image" alt="Continuous Icon" /></td>
<td>Continuous - Run the animation in continuous mode. The animation repeats until you stop it.</td>
</tr>
<tr>
<td>Frames per second</td>
<td><img src="image" alt="FPS Icon" /></td>
<td>Set the animation to play at a faster or slower speed.</td>
</tr>
<tr>
<td>Point probe</td>
<td><img src="image" alt="Point Probe Icon" /></td>
<td>Select a curve. For 2-D plots, select a coordinate type from the Selection Tool menu to display coordinates.</td>
</tr>
<tr>
<td>Execute click and drag code (2-D)</td>
<td><img src="image" alt="Click and Drag Icon" /></td>
<td>In an embedded plot window, use this probe to execute the specified click and drag code, if any.</td>
</tr>
<tr>
<td>Pan</td>
<td><img src="image" alt="Pan Icon" /></td>
<td>Pan the plot by changing the view ranges.</td>
</tr>
<tr>
<td>Zoom in</td>
<td><img src="image" alt="Zoom In Icon" /></td>
<td>Zoom into the plot. Also, scale the plot by placing the pointer over the plot and then rotating the wheel button.</td>
</tr>
<tr>
<td>Zoom out</td>
<td><img src="image" alt="Zoom Out Icon" /></td>
<td>Zoom out of the plot. Also, scale the plot by placing the pointer over the plot and then rotating the wheel button.</td>
</tr>
<tr>
<td>Reset view</td>
<td><img src="image" alt="Reset Icon" /></td>
<td>Reset the view to the default view of the 2-D plot.</td>
</tr>
<tr>
<td>Selection Tool (2-D)</td>
<td><img src="image" alt="Selection Tool Icon" /></td>
<td>Use the Selection Tool to select the information displayed in the point probe tool tip. You can choose to display coordinates derived from converted pixel coordinates or data points derived from the original data points. To copy the coordinate data into the clipboard, from the context panel select <strong>Probe Info → Copy data</strong>.</td>
</tr>
<tr>
<td>Rotate (3-D)</td>
<td><img src="image" alt="Rotate Icon" /></td>
<td>Rotate a three-dimensional plot to see it from a different point of view.</td>
</tr>
</tbody>
</table>
Customize the animation using the context panel:

1. To change the line style, click the plot region. Select Style \rightarrow \text{Point}.

2. To remove the axes, select \text{Axes} \rightarrow \text{None}.

The animate Command Options

The \texttt{animate} command offers a few options that are not available for static plots. Refer to the \texttt{animate} help page for information on these additional options. By default, a two-dimensional animation consists of sixteen plots (frames) and a three-dimensional animation consists of eight plots (frames). To create a smoother animation, increase the number of frames using the \texttt{frames} option.

\textbf{Note:} Computing more frames increases time and memory requirements.

\begin{verbatim}
> sinewave := plot( \sin(x) \exp(-x/5), x = 0..20 ) :
> ball := proc(x, y) plots[pointplot]([[x, y]], symbol = circle, symbolsize = 20) end proc:
\end{verbatim}
6.9 Exporting

You can export a generated plot or animation to an image in various file formats, including DXF and X3D (for 3-D plots), EPS, GIF, JPEG/JPG, POV, and Windows BMP. Exporting an animation to GIF produces an animated image file. The exported images can be included in presentations, web pages, Microsoft Word, or other software.
To export an image:

1. Click the plot region.
2. From the context panel, select Export and the file format.

Alternatively:

1. Click the plot.
2. From the Plot menu, select Export, and then the file format.

Maple has various plot drivers. By setting the plotdevice, a file can be automatically created without returning the image to the document. For more information, refer to the plot,device help page.
7 Creating Mathematical Documents

Maple allows you to create powerful documents as business and education tools, technical reports, presentations, assignments, and handouts.

You can:
- Copy, cut, and paste information
- Format text for reports or course material
- Add headers and footers
- Insert images, tables, and symbols
- Generate 2-D and 3-D plots and animations
- Sketch in the document or on a plot
- Insert hyperlinks to other Maple files, websites, or email addresses
- Place instructions and equations side by side
- Bookmark specific areas
- Easily update, revise, and distribute your documents

In this chapter, we will create a document that demonstrates many of Maple's documentation features. For further examples, note that this guide was written using Maple.

7.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Document Formatting (page 222) - Add various text formatting elements | • Copy and Paste  
• Quick Character Formatting  
• Quick Paragraph Formatting  
• Character and Paragraph Styles  
• Sections  
• Headers and Footers  
• Show or Hide Worksheet Content  
• Indentation and the Tab Key |
| Commands in Documents (page 235) - Format and display or hide commands in a document | • Document Blocks  
• Typesetting  
• Auto-Execute |
| Tables (page 239) - Create tables and modify their attributes | • Creating a table  
• Cell contents  
• Navigating table cells  
• Modifying Structural Layout  
• Modifying Physical Dimensions  
• Modifying Appearance  
• Printing Options  
• Execution Order |
7.2 Document Formatting

To begin, create a new Maple document. From the File menu, select New → Document Mode. For this example, you can copy and paste text from any file. The example text below is from a Maple help page, plot, but the formatting has been removed for demonstration purposes.

**Copy and Paste**

You can cut, copy, and paste content within Maple documents, and from other sources.

**To copy an expression, or part of an expression, to another location on the document:**

1. Select the expression, or part of the expression, to copy. Alternatively, right-click and select Copy.
2. From the Edit menu, select Copy.
3. Place the cursor at the insertion point.
4. From the Edit menu, select Paste. Alternatively, right-click and select Paste.

**Result:**

```
plot: create a two-dimensional plot

Calling Sequence
plot(f, x)
plot(f, x=x0..x1)
plot(x1, y2)

Parameters
f - expression in independent variable x
x - independent variable
x0, x1 - left and right endpoints of horizontal range
x1, y2 - x-coordinates and y-coordinates
```
If you paste into a math input region, Maple interprets all the pasted content as input. If you paste into a text region, Maple interprets all the pasted content as text. However, note that 2-D Math retains its format in both input and text regions.

When you copy and paste to another application, in general, Maple retains the original structure.

**Quick Character Formatting**

The **Format→Character** menu provides access to the following quick formatting features: **Bold**, **Italic**, **Underline**, **Superscript**, **Subscript**, **Font Color**, and **Highlight Color**.

**To modify text:**

1. In the document, select the text to modify.

2. From the **Format** menu, select **Character**, and then the appropriate feature. Alternatively, select **Format→Character** from the context panel.

3. Select the quick formatting feature you want to apply (for example, bold or italic font).

Alternatively, use the context bar icons. For example, to apply a color to the parameters "f, x=x0..x1":

- Font Color Context Bar Icon

- Highlight Color Context Icon

For font and highlight colors, you can select from Swatches, a color wheel, RGB values, or choose a color using the eye dropper tool. See **Figure 7.1**.

**Figure 7.1: Select Color Dialog**

In this example, choose a dark purple color, as in the help pages.

To format this text as bold, click the **Bold** toolbar icon. Also, select the text "Calling Sequence" and format as bold.
Result:

plot - create a two-dimensional plot

Calling Sequence

\[ \text{plot}(f, x) \]
\[ \text{plot}(f, x=x_0..x_1) \]
\[ \text{plot}(v_1, v_2) \]

Parameters:

- \( f \) - expression in independent variable \( x \)
- \( x \) - independent variable
- \( x_0, x_1 \) - left and right endpoints of horizontal range
- \( v_1, v_2 \) - \( x \)-coordinates and \( y \)-coordinates

Attributes Submenu: Setting Fonts, Character Size, and Attributes

You can also change various character attributes such as font, character size, style, and color in one dialog.

To modify text:

1. In the document, select text to modify.
2. From the Format menu, select Character, and then Attributes. The Character Style dialog opens. See Figure 7.2.

![Figure 7.2: Character Style Dialog](image-url)
Quick Paragraph Formatting

The Format→Paragraph menu provides access to the following quick alignment features: Align Left, Center, and Align Right.

To modify a paragraph:

1. In the document, select the paragraph to modify.
2. From the Format menu, select Paragraph, and then the appropriate feature.

Attributes Submenu: Spacing, Indent, Alignment, Bullets, Line Break, and Page Break

You can change various paragraph attributes in one dialog.

• From the Format menu, select Paragraph, and then Attributes. The Paragraph Style dialog opens. See Figure 7.3.
• When changing spacing, you must indicate units (inches, centimeters, or points) in the Units drop-down list.

![Paragraph Style Dialog]

Figure 7.3: Paragraph Style Dialog

For example, in the pasted text, select all of the items under "Parameters", then open the Paragraph Style dialog. Notice that the spacing has already been set.

In the Indent section, change the Left Margin indent to 10.0 pt.

In the Bullets and Numbering section, click the Style drop-down and select Dash. Click OK to close the dialog and apply the styles.

Result:
plot - create a two-dimensional plot

**Calling Sequence**
plot(f, x)
plot(f, x=a..b)
plot(g, v1, v2)

**Parameters**
- `f` - expression in independent variable `x`
- `x` - independent variable
- `a..b` - left and right endpoints of horizontal range
- `v1, v2` - x-coordinates and y-coordinates

For more information, refer to the paragraph menu help page.

**Character and Paragraph Styles**

Maple has predefined styles for characters and paragraphs. A style is a set of formatting characteristics that you can apply to text in your document to change the appearance of that text. When you apply a style, you apply a group of formats in one action.

- A **character style** controls text font, size, color, and attributes such as bold and italic. To override the character style within a paragraph style, you must apply a character style or character formatting.
- A **paragraph style** controls all aspects of a paragraph's appearance, such as text alignment, line spacing, and indentation. In Maple, each paragraph style includes a character style.

![Style Management Dialog](image)

**Figure 7.4: Style Management Dialog**

**Applying Character Styles**

By using the drop-down list in the document context bar, you can apply:
- Existing Maple character styles.
- New styles that you have created through the **Style Management** (Figure 7.4) and **Character Style** (Figure 7.5) dialogs.
To apply a character style to text in your document:

1. Select the text to modify.
2. In the styles drop-down list in the context bar of your document, select an appropriate character style. All character styles are preceded by the letter C. The selected text now reflects the attributes of the character style you have chosen.

3. (Optional) If necessary, you can remove this style. From the Edit menu, select Undo.

Creating and Modifying Character Styles

You can create custom character styles to apply to text, or change existing character styles. New styles are automatically added to the styles drop-down list in the context bar of your document.

1. From the Format menu, select Styles. The Style Management dialog opens. See Figure 7.4.

To create a character style:

• Click Create Character Style. The Character Style dialog opens. See Figure 7.5.
• In the first row of the dialog, enter a style name in the blank text region.

To modify a character style:

• From the style list, select the character style to modify. Recall that all character styles are preceded by the letter C, while paragraph styles are preceded by the letter P.
• Click Modify. The Character Style dialog opens with the current attributes displayed. See Figure 7.5.

For either action, continue:

2. Select the properties for the new character style, such as font, size, attributes, and color. In the font attributes, the Superscript and Subscript check boxes are mutually exclusive. When you select one of the two check boxes, the other is disabled. You must clear one before selecting the other.

Note: A preview of the style is displayed in the last row of the Character Style dialog.

3. To save the style, click OK or to abandon, click Cancel. If you have modified a style, all text in your document that uses the altered style is updated to reflect the changes.
For example, in the pasted text, suppose we want to create a character style for the bold, purple parameter.

- From the Format menu, select Styles, then click Create Character Style.
- Enter the style name, "Placeholder", and then select the character attributes. In this case, click the Bold check box. Then click the Color button and choose a dark purple. Click OK to create the character style.

Now you can apply the style to any text. Under Calling Sequences, select each list of parameters inside the command. To apply the style, from the Styles drop-down menu in the toolbar, select Parameter.

Result:
Calling Sequence

\begin{equation}
\text{plot}(f, x) \\
\text{plot}(f, x=a..b) \\
\text{plot}(v1, v2)
\end{equation}

Parameters

- \( f \) - expression in independent variable \( x \)
- \( x \) - independent variable
- \( x0, x1 \) - left and right endpoints of horizontal range
- \( v1, v2 \) - \( x \)-coordinates and \( y \)-coordinates

Applying Paragraph Styles

By using the drop-down list in the document context bar, you can apply:

- Existing Maple paragraph styles.
- New styles that you have created through the Style Management (Figure 7.4) and Defining a Paragraph Style (Figure 7.6) dialogs.

To apply a Maple paragraph style to text in your document:

1. Select the text to modify.
2. In the styles drop-down list in the context bar of your document, select an appropriate paragraph style. All Maple paragraph styles are preceded by the letter \( P \). The selected text now reflects the attributes of the paragraph style you have chosen.

For example, to format the title of the pasted text as a title, first select the line: "plot - create a two-dimensional plot". In the Styles drop-down, select \textbf{Title}.

Result:
plot - create a two-dimensional plot

Calling Sequence
plot(f, x)
plot(f, x=x0..x1)
plot(v1, v2)

Parameters
f - expression in independent variable x
x - independent variable
x0, x1 - left and right endpoints of horizontal range
v1, v2 - x-coordinates and y-coordinates

3. (Optional) If necessary, you can remove this style. From the Edit menu, select Undo.

Creating and Modifying Paragraph Styles

You can create custom paragraph styles to apply to text, or change existing paragraph styles. New styles are automatically added to the styles drop-down list in the context bar of your document.

1. From the Format menu, select Styles. The Style Management dialog opens. See Figure 7.4.

To create a paragraph style:
- Click Create Paragraph Style. The Paragraph Style dialog opens. See Figure 7.6.
- In the first row of the dialog, enter a style name in the blank text field.

To modify a paragraph style:
- Select a paragraph style to modify. Recall that all paragraph styles are preceded by the letter P.
- Click Modify. The Paragraph Style dialog opens with the current attributes displayed.

For either action, continue:
4. In the Units drop-down menu, select the units used to determine spacing and indentation. Select from inches (in), centimeters (cm), or points (pt).
5. Select the properties to use for this paragraph style, such as Spacing, Indent, Alignment, Bullets and Numbering, Page Break Before, and Linebreak.
6. To add or modify a font style, click Font. The Character Style dialog opens. For detailed instructions, see Creating and Modifying Character Styles (page 227).
7. To save the style, click OK, or to abandon, click Cancel. If you are modifying an existing style, all text in your document that uses the altered style is updated to reflect the changes.
Figure 7.6: Defining a Paragraph Style

**Style Set Management: Saving Styles for Future Use**

You can use the style set of a particular document as the default style for all documents.

For information on creating and managing style sets, see the `worksheet/documenting/styles` help page.

**Sections**

You can organize your document into sections, either before or after the text has been entered.
Using the Insert Menu to Add Sections

1. Place the cursor in the paragraph or execution group above the location at which you want to insert a new section.
   - If the cursor is inside a section, Maple inserts the new section after the current section.
   - If the cursor is in an execution group, Maple inserts the new section after the execution group.
2. From the Insert menu, select Section. An arrow marks the start of the section.
3. Move the cursor to the text area beside the arrow. Enter the section heading.
4. Move the cursor to the body of the section. Enter the content.

Tips for Adding Sections and Subsections

- If you are in a section and select Insert→Section, a subsection is created.
- To insert a subsection immediately after the current subsection, use Edit→Split or Join→Split Section. The newly created section is at the same indentation level as the existing section.
- To outdent, use Edit→Remove Section. This decreases the indentation of a worksheet element by one level by removing one subsection that encloses the worksheet element.

Using the Indent and Outdent Toolbar Icons

You can shift sections to create or remove subsections.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Indent" /></td>
<td>Enclose the selection in a section or subsection</td>
</tr>
<tr>
<td><img src="image" alt="Outdent" /></td>
<td>Outdent the selection to the next section level, if possible.</td>
</tr>
</tbody>
</table>

For example, to create two sections containing the two categories of information in the pasted text:

1. Select "Parameters" and all of the items under it.
2. Click the Indent toolbar item.
3. Cut and paste "Parameters" from inside the section to its title.
4. Similarly, create a section with the title "Calling Sequence", containing the items under that heading.
Result:

plot - create a two-dimensional plot

**Calling Sequence**

plot(f, x)
plot(f, x=x0..x1)
plot(x1, y2)

**Parameters**

- \( f \) - expression in independent variable \( x \)
- \( x \) - independent variable
- \( x0, x1 \) - left and right endpoints of horizontal range
- \( v1, v2 \) - \( x \)-coordinates and \( y \)-coordinates

Note: The section titles are automatically formatted as section titles, but you can change the formatting through the Paragraph Style dialog.

**Headers and Footers**

You can add headers and footers to your document that will appear at the top and bottom of each page when you print the document.

To add or edit headers and footers:

From the **Insert** menu, select **Header Footer**. The **Header Footer** dialog appears. See **Figure 7.8**.

![Figure 7.8: Header and Footer Dialog - Custom Header](image)

The available elements include the current date, page number, number of pages, an image, the filename, or any plain text. These elements can be placed in the left or right corner or the center of the page.

You can choose one of the predefined header or footer styles in the **Predefined Header and Footer** tab, or create your own by clicking the **Custom Header** or **Custom Footer** tab.

For more information on header and footer options, refer to the **headerfooter** help page.

**Show or Hide Worksheet Content**

You can hide document elements of a specific type so that they are not visible. This does not delete them, but hides them from view. Hidden elements are not printed or exported, but they can be copied and pasted.

In a document, use the **Show Contents** dialog to hide all spreadsheets, input, output, or graphics, plus markers for section boundaries, execution group boundaries, hidden table borders on mouse pointer roll over, and annotations. The dialog is accessed from the **View**→**Show/Hide Contents** menu.
Using the Show Contents Dialog

A check mark beside the item indicates that all document elements of that type are displayed for the current document. See Figure 7.9.

![Show Contents Dialog](image)

Figure 7.9: Show Contents Dialog

1. From the View menu, select Show/Hide Contents. The Show Contents dialog opens with all items selected for display.

2. Clear the check box associated with the document components or markers to hide them.

Note: By clearing the Input check box, Maple Input (1-D Math) and 2-D Math input are hidden. However, this will not hide Text input in Document mode. Clearing the Graphics check box ensures that a plot, an image, or the Canvas inserted in the document by using the Insert menu option is also hidden.

Command Output Versus Inserted Content

Output is considered an element that results from executing a command. Inserted components are not considered output. Consider the following examples.

The plot resulting from executing the `plot(sin)` command is considered output.

- To show a plot from the `plot(sin)` command, select both the Output and Graphics check boxes in the Show Contents dialog.

Inserted images and the Canvas are not considered output. As such, they are not hidden if you clear the Output check box.

- To hide an inserted image or canvas, clear the Graphics check box in the Show Contents dialog.

Indentation and the Tab Key

The Tab key has a few different uses:

- Indentation
- Navigation through a document or between table cells
• Navigation between placeholders within a math expression

Control the behavior of the Tab key using the Tab Navigation feature in the Format menu. For more information, refer to the tabkey help page.

7.3 Commands in Documents

Document Blocks

With document blocks, you can create documents that present text and math in formats similar to those found in business and education documents.

In a document block, an input prompt or execution group is not displayed.

By hiding Maple input such that only text and results are visible, you create a document with better presentation flow. Before using document blocks, it is recommended that you display Markers. A vertical bar is displayed along the left pane of the document. Icons representing document blocks are displayed in this vertical bar next to associated content.

To activate Markers:

• From the View menu, select Markers.

For further details on document blocks, see Document Blocks (page 35) in Chapter 1.

Working with Document Blocks

In document mode, each time you press Enter, a new document block appears. Documents consist of a series of document blocks.

1. Create a new document block after the last section of the pasted example, either by pressing Enter, or by selecting, from the Edit→Document Blocks menu, Create Document Block.

2. Enter text and an expression to evaluate. For example, enter "Plot the expression \( \sin(x) \) and its derivative, \( \frac{d}{dx} \sin(x) \)." For detailed instructions on entering this phrase, see Example 6 - Enter Text and 2-D Math in the Same Line Using Toolbar Icons (page 22) in Chapter 1.

3. Select the expression to display the context panel.

4. From the context panel, click Evaluate and Display Inline. The expression is evaluated.

5. Check that the input mode is Text, then enter the rest of the sentence: ", in the same plot." See Figure 7.10.

Before

After

Figure 7.10: Working with Document Blocks
plot - create a two-dimensional plot

\section*{Calling Sequence}
\begin{itemize}
\item \texttt{plot(f, x)}
\item \texttt{plot(f, x=x0..x1)}
\item \texttt{plot(v1, v2)}
\end{itemize}

\section*{Parameters}
\begin{itemize}
\item \texttt{f} - expression in independent variable \texttt{x}
\item \texttt{x} - independent variable
\item \texttt{x0, x1} - left and right endpoints of horizontal range
\item \texttt{v1, v2} - \texttt{x} coordinates and \texttt{y} coordinates
\end{itemize}

Plot the expression \(\sin(x)\) and its derivative, \(\frac{d}{dx}\sin(x) = \cos(x)\), in the same plot.

\section*{Inline Document Output}
Document blocks can display content inline, that is, text, input, and output in one line as presented in business and education documents.

To display content inline:
1. Place the cursor in the document block.
2. From the \textit{Edit}→\textit{Document Blocks} menu, select \textcolor{red}{Inline Document Output}.

\section*{View Document Code}
To view the contents, that is, all code and expanded execution groups within a document block, you must expand the document block.

1. Place the cursor in the document block region.
2. From the \textit{Edit}→\textit{Document Blocks} menu, select \textcolor{red}{Show Command}.

\begin{verbatim}
> int(\sin(x), x)
\end{verbatim}

output redirected...

\begin{verbatim}
> print(1); \# input placeholder
\end{verbatim}

\hspace{1cm} -\cos(x)

3. To hide code again, clear the check box beside \textcolor{red}{Show Command}.

\section*{Expand an Execution Group within a Document Block}
An execution group is a grouping of Maple input with its corresponding Maple output. It is distinguished by a large square bracket at the left called a group boundary.

As document blocks can contain many execution groups, you can select to expand an execution group within a document block.

1. Place the cursor near the end of the document block region.
2. From the \textit{Edit}→\textit{Document Blocks} menu, select \textcolor{red}{Show Execution Group}. 
3. To hide the group, clear the check box beside Show Execution Group.

**Switch between Input and Output**

1. Place the cursor in the document block region.
2. From the *Edit→Document Blocks* menu, select *Toggle Input/Output Display*.

Input from any executable math or commands is displayed in one instance, or only output is displayed.

**Typesetting**

You can control typesetting and 2-D Math equation parsing options in the Standard Worksheet interface. Extended typesetting uses a customizable set of rules for displaying expressions.

The rule-based typesetting functionality is available when the Typesetting level is set to Extended (the default). You can set the typesetting level under *Tools→Options→Display* tab. This parsing functionality applies to 2-D Math editing (Math mode) and output.

For example, you can change the display of derivatives to suit the content and audience of your document.

\[
\frac{d}{dx} f(x)
\]

Tools→Options→Display tab: Typesetting level = Extended.

\[
f'(x)
\]

Tools→Options→Display tab: Typesetting level = Maple Standard.

\[
\frac{d}{dx} f(x)
\]

To specify rules, use the Typesetting Rule Assistant.

- From the *View* menu, select Typesetting Rules. The Typesetting Rule Assistant dialog opens.

For more information, see the Typesetting, TypesettingRuleAssist, and OptionsDialogDisplay help pages.

**Auto-Execute**

The Autoexecute feature allows you to designate regions of a document for automatic execution. These regions are executed when the document opens or when the restart command is executed. This is useful when sharing documents. Important commands can be executed as soon as the user opens your document. The user is not required to execute all commands.

**Setting the Auto-Execute Feature**

1. Select the region to be automatically executed when the document opens.
2. From the *Evaluate* menu, select Set Selection to Autoexecute.

Regions set to Autoexecute are denoted by exclamation mark symbols in the Markers region (*View → Markers*),
For example, to display a plot in your document without saving the plot, making your document use less memory, you can set a plot command to autoexecute.

1. After the plot instruction, enter a Maple prompt (Insert → Execution Group → After Cursor).

2. Enter the plot command: \texttt{plot(\left[ \sin(x), \int \sin(x) \, dx \right])} and press Enter to execute.

3. Select the plot, then select Evaluate → Remove Output from Selection.

4. Place the cursor in the plot command, then select Evaluate → Set Selection to Autoexecute.

5. Save and close the document; on reopening, the command is re-executed.

Result:

\[
\text{plot - create a two-dimensional plot}
\]

\textbf{Calling Sequence}

\begin{itemize}
\item plot(f, x)
\item plot(f, x=x0..x1)
\item plot(v1, v2)
\end{itemize}

\textbf{Parameters}

\begin{itemize}
\item \texttt{f} - expression in independent variable \texttt{x}
\item \texttt{x} - independent variable
\item \texttt{x0, x1} - left and right endpoints of horizontal range
\item \texttt{v1, v2} - x-coordinates and y-coordinates
\end{itemize}

Plot the expression \( \sin(x) \) and its derivative, \( \frac{d}{dx} \sin(x) = \cos(x) \), in the same plot.

\begin{itemize}
\item \texttt{plot(\left[ \sin(x), \frac{d}{dx} \sin(x) \right])}
\end{itemize}

Removing the Auto-Execute Setting

To remove the setting in a region:

1. Select the region.

2. From the Evaluate menu, select Clear Selection from Autoexecute.

To remove all autoexecuted regions from a document:

- From the Evaluate menu, select Clear All Autoexecute.

Repeating Auto-Execution

To execute all marked groups:

- From the Evaluate menu, select Repeat Autoexecute.

Security Levels

By default, Maple prompts the user before automatically executing the document.

To set security levels for the autoexecute feature, use the Security tab in the Options dialog. For details, refer to the OptionsDialogSecurity help page.
7.4 Tables

Tables allow you to organize content in a document.

Creating a Table

To create a table:
1. From the Insert menu, select Table.
2. Specify the number of rows and columns in the table creation dialog.
3. Click OK.

The default properties for the table include visible borders and auto-adjustment to 100% of the document width. These options, as well as the table dimensions, can be modified after table creation.

Create a table with 4 rows and 2 columns at the end of your document. In document mode, the input mode is set to Math by default; in worksheet mode, the default is Text mode.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Cell Contents

Any content that can be placed into a document can also be placed into a table cell, including other sections and tables. Table cells can contain a mix of:

- Input commands
- 2-D Math
- Embedded components: buttons, sliders, check boxes, and more
- Plots
- Images

Enter a heading in both columns of the first row, in 2-D Math. You can use any text formatting features within each cell; for example, bold and center the headings.

<table>
<thead>
<tr>
<th>f(x)</th>
<th>[ \frac{d}{dx} f(x) ]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Navigating Table Cells

Use the Tab key to move to the next cell. Ensure that Format → Tab Navigation is selected.

<table>
<thead>
<tr>
<th>Tab Navigation selected</th>
<th>Allows you to move between cells using the Tab key.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab Navigation not selected</td>
<td>Allows you to indent in the table using the Tab key.</td>
</tr>
</tbody>
</table>

Tab between the cells of the table and enter the following expressions in the first column. For each function, from the context panel, select Differentiate → With respect to → x. Cut and paste the resulting expression into the second column.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Modifying the Structural Layout of a Table

The number of rows and columns in a table are modified using the Insert and Delete submenus in the Table menu or by using the Cut and Copy/Paste tools. The Table menu is found under the Format menu. The same table menu options are available in the Context Panel when the cursor resides in a table.

Inserting Rows and Columns

Row and column insertion is relative to the table cell that currently contains the cursor. If the document has an active selection, insertion is relative to the selection boundaries.

- Column insertion can be to the left or right of the document position marker or selection.
- Row insertion can be above or below the marker or selection.

In your table, add a third column on the right to display the plots of these expressions. Add the heading, and insert a blank plot region in each cell below it, by selecting Insert → Plot → 2-D (or 3-D for the second expression). Then Ctrl-drag (Control-drag for Macintosh) each expression in the row into its plot region to display it. For details on this procedure, see Plots and Animations (page 183).

Resize the plots and table as desired.

<table>
<thead>
<tr>
<th>$f(x)$</th>
<th>$\frac{d}{dx}f(x)$</th>
</tr>
</thead>
<tbody>
<tr>
<td>$1 + \frac{1}{1 + \frac{1}{x}}$</td>
<td>$\frac{1}{\left(1 + \frac{1}{1 + \frac{1}{x}}\right)^2 \left(1 + \frac{1}{x}\right)^2 x^2}$</td>
</tr>
<tr>
<td>$\sin(\omega x) e^{-5 x}$</td>
<td>$\cos(\omega x) \omega e^{-5 x} - 5 \sin(\omega x) e^{-5 x}$</td>
</tr>
<tr>
<td>$\frac{d^2}{dx^2} \sin^2(x)$</td>
<td>$-8 \sin(x) \cos(x)$</td>
</tr>
</tbody>
</table>
### Table

<table>
<thead>
<tr>
<th>( f(x) )</th>
<th>( \frac{d}{dx} f(x) )</th>
<th>Plot of ( f(x) ) and ( \frac{d}{dx} f(x) )</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \frac{1}{1 + \frac{1}{x}} )</td>
<td>( \frac{1}{\left(1 + \frac{1}{1 + \frac{1}{x}}\right)^2 \left(1 + \frac{1}{x} \right)^2 x^2} )</td>
<td><img src="image" alt="Plot of ( f(x) ) and ( \frac{d}{dx} f(x) )" /></td>
</tr>
<tr>
<td>( \sin(\omega x) e^{(-5x)} )</td>
<td>( \cos(\omega x) \omega e^{-5x} - 5 \sin(\omega x) e^{-5x} )</td>
<td><img src="image" alt="Plot of ( f(x) ) and ( \frac{d}{dx} f(x) )" /></td>
</tr>
<tr>
<td>( -\frac{d^2}{dx^2} \sin^2(x) )</td>
<td>( -8 \sin(x) \cos(x) )</td>
<td><img src="image" alt="Plot of ( f(x) ) and ( \frac{d}{dx} f(x) )" /></td>
</tr>
</tbody>
</table>

#### Deleting Rows and Columns

With deleting operations using the **Delete** key, the **Delete Table Contents** dialog opens allowing you to specify the desired behavior. For example, you can delete the selected rows, or delete the contents of the selected cells. See **Figure 7.11**.

![Delete Table Contents Verification Dialog](image)

**Figure 7.11: Delete Table Contents Verification Dialog**

#### Pasting

Pasting a table subselection into a table may result in the creation of additional rows or columns, overwriting existing cell content, or the insertion of a subtable within the active table cell. When there is a choice, the **Table Paste Mode** dialog opens, allowing you to choose. See **Figure 7.12**.

![Table Paste Mode Selection Dialog](image)

**Figure 7.12: Table Paste Mode Selection Dialog**
Merging Cells

To merge adjacent cells in a table, select the cells you would like to merge. From the Table menu, select Merge Cells. You can merge cells across row or column borders. See Figure 7.13. The resulting cell must be rectangular. The contents of the individual cells in the merge operation are concatenated in execution order. See Figure 7.14. For details on cell execution order, see Execution Order Dependency (page 245).

![Figure 7.13: Two Cells](image)

![Figure 7.14: Merged Cells](image)

Modifying the Physical Dimensions of a Table

The overall width of the table can be controlled in several ways.

The most direct way is to press the left mouse button (press mouse button, for Macintosh) while hovering over the left or right table boundary and dragging the mouse left or right. Upon release of the mouse button, the table boundary is updated. This approach can also be used to resize the relative width of table columns.

Alternatively, the size of the table can be controlled from the Table Properties dialog. The Table Properties dialog is found in the Context Panel or through the Format menu under Table and then Properties. Two sizing modes are supported.

1. **Fixed percentage of page width.** Using this option, the table width adjusts whenever the width of the document changes. This option is useful for ensuring that the entire content of the table fits in the screen or printed page.

2. **Scale with zoom factor.** This option is used to preserve the size and layout of the table regardless of the size of the document window or the zoom factor. If the table exceeds the width of the document window, the horizontal scroll bar can be used to view the rightmost columns. **Note:** Using this option, tables may be incomplete when printed.

Modifying the Appearance of a Table

**Table Borders**

The style of exterior and interior borders is set using the Table Properties dialog.

- You can set all, none, or only some of the borders to be visible in a table. Exterior borders are controlled separately.
- You can control the visibility of interior borders by using the Group submenu of the Table menu; grouping rows or columns suppresses interior borders, provided that the interior border style is set by row and column group.
For example, group the columns together, and group rows 2 to 4 together. Then in the **Table Properties** dialog, select \textbf{Exterior Borders: Top and bottom}, and \textbf{Interior Borders: By row and column group}.

\[
\begin{array}{ccc}
   f(x) & \frac{d}{dx} f(x) & \text{Plot of } f(x) \text{ and } \frac{d}{dx} f(x) \\
   \frac{1}{1 + \frac{1}{x}} & 1 & \\
   \left(1 + \frac{1}{x}\right)^2 & \frac{\left(1 + \frac{1}{x}\right)^2}{x^2} & \\
   \sin(\omega x) e^{-5x} & \cos(\omega x) e^{-5x} - 5 \sin(\omega x) e^{-5x} & \\
\end{array}
\]

\[
\begin{align*}
   \frac{d^2}{dx^2} \sin^2(x) & \quad -8 \sin(x) \cos(x) \\
\end{align*}
\]

- Hidden borders are visible when the mouse hovers over a table. **Note**: You can hide the visibility of lines on mouse pointer roll over by using the **View→Show/Hide Contents** dialog, and clearing the **Hidden Table Borders** check box. This setting applies to all tables in the worksheet. You can also set controls for an individual table from the **Table Properties→Show hidden borders** option. Using this option, borders can be hidden in a table even if they are set to visible on roll over in the **Show/Hide Contents** dialog.

**Alignment Options**

The table alignment tools control the horizontal alignment of columns and vertical alignment of rows.

For column alignment, the current selection is expanded to encompass all rows in the selected columns. The alignment choice applies to all cells within the expanded selection. If the document does not contain a selection, the cursor position is used to identify the column.

Similarly, the selection is expanded to include all columns in the selected rows for vertical alignment options. The following table illustrates the vertical alignment options. The baseline option is useful for aligning equations across multiple cells within a row of a table.
For example, set the Row alignment to Baseline for all rows, and set the Column alignment to Center for all columns.

<table>
<thead>
<tr>
<th>Top</th>
<th></th>
</tr>
</thead>
</table>
| \[
\frac{1}{x^y}
\]          | \[
\frac{1}{x^y}
\]                                                     |
| Center       |                                                                 |
| \[
\frac{1}{x^y}
\]          | \[
\frac{1}{x^y}
\]                                                     |
| Bottom       |                                                                 |
| \[
\frac{1}{x^y}
\]          | \[
\frac{1}{x^y}
\]                                                     |
| Baseline     |                                                                 |
| \[
\frac{1}{x^y}
\]          | \[
\frac{1}{x^y}
\]                                                     |

For example, set the Row alignment to **Baseline** for all rows, and set the Column alignment to **Center** for all columns.

\[
f(x) = \frac{1}{1 + \frac{1}{1 + \frac{1}{x}}} - \left( \frac{1}{1 + \frac{1}{1 + \frac{1}{x}}} \right)^2 \left( \frac{1}{1 + \frac{1}{x}} \right)^2 x^2
\]

\[
\frac{df}{dx} = \sin(\omega x)e^{-5x} - \cos(\omega x)e^{-5x} - 5\sin(\omega x)e^{-5x}
\]

\[
\frac{d^2}{dx^2} \sin^2(x) = -8\sin(x)\cos(x)
\]

**Cell Color**

You can set the background color of any cell or collection of cells to be any color. This coloring is independent of any highlighting or text color that may also be applied.

To change the color of a cell, place the cursor in the cell, then from the Table menu, select **Cell Color**. In the Select A Color dialog, choose a color from the swatches, the color wheel, or RGB. See the Drawing Tools help page for details on color selection.
For example, select the first row of the table and apply a light blue color. This sets the header off from the content below.

\[
\begin{array}{ccc}
  f(x) & \frac{d}{dx}f(x) & \text{Plot of } f(x) \text{ and } \frac{d}{dx}f(x) \\
  \frac{1}{1 + \frac{1}{1 + \frac{1}{x}}} & - \left(1 + \frac{1}{1 + \frac{1}{x}}\right)^2 \left(1 + \frac{1}{x}\right)^2 x^2 & \text{Graph}
\end{array}
\]

\[
\begin{align*}
\sin(\omega x) e^{-\omega x} & \quad \cos(\omega x) e^{5x} - 5 \sin(\omega x) e^{5x} \\
\frac{d^2}{dx^2} \sin(\omega x) & \quad -8 \sin(x) \cos(x)
\end{align*}
\]

Controlling the Visibility of Cell Content

The Table Properties dialog includes two options to control the visibility of cell content. These options allow control over the visibility of Maple input and execution group boundaries. Thus, these elements can be hidden in a table even if they are set to visible for the document in the View→Show/Hide Contents dialog.

Printing Options

The Table Properties dialog contains options to control the placement of page breaks when printing. You can fit a table on a single page, allow page breaks between rows, or allow page breaks within a row.

Execution Order Dependency

The order in which cells are executed is set in the Table Properties dialog. The following tables illustrate the effect of execution order.

<table>
<thead>
<tr>
<th>Row-wise execution order</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt; x := 1;</td>
</tr>
<tr>
<td>x := 1</td>
</tr>
<tr>
<td>&gt; x := x + 1;</td>
</tr>
<tr>
<td>x := 2</td>
</tr>
<tr>
<td>&gt; x := x + 1;</td>
</tr>
<tr>
<td>x := 3</td>
</tr>
<tr>
<td>&gt; x := x + 1;</td>
</tr>
<tr>
<td>x := 4</td>
</tr>
</tbody>
</table>
### Editable Tables

Tables can be marked as editable or non-editable. The editable property for tables is independent of the document editability, though if a document is marked as non-editable, tables cannot be edited. After a table has been marked as non-editable, any content stored in the table cannot be modified. It is not possible to add any new content such as embedded components or to run computations in execution groups or document blocks. Existing interactive embedded components inside of a table will continue to work.

A table can be marked as editable or non-editable in its **Table Properties** using either the `DocumentTools:-SetProperty` command or the Context Panel. To make a table editable or non-editable using the Context Panel, in the Table properties, select or clear the **Editable** check box.

### Additional Examples

For more practice creating and manipulating tables, try creating the following tables at the end of your document.

#### Table of Values

This example illustrates how to set the visibility options for cell contents to display a table of values.

> \( y := t \rightarrow \frac{1}{2} t^2 \)

Create a table with 2 rows and 7 columns. Enter the values as below, and then select all table cells. In the Table→Alignment menu, select **Columns**, and then **Center**.

<table>
<thead>
<tr>
<th>( t ) seconds</th>
<th>0</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>( y(t) ) meters</td>
<td>0</td>
<td>&gt; ( y(1) )</td>
<td>&gt; ( y(2) )</td>
<td>&gt; ( y(3) )</td>
<td>&gt; ( y(4) )</td>
<td>&gt; ( y(5) )</td>
<td>&gt; ( y(6) )</td>
</tr>
<tr>
<td></td>
<td>0</td>
<td>1/2</td>
<td>2</td>
<td>9/2</td>
<td>8</td>
<td>25/2</td>
<td>18</td>
</tr>
</tbody>
</table>

**Table settings:**

1. Set **Table Size Mode** to **Scale with zoom factor**.
2. Hide Maple input and execution group boundaries: Clear the **Show input** and **Show execution group boundaries** check boxes.
## Formatting Table Headers

The following table uses cell merging for formatting row and column headers, and row and column grouping to control the visibility of cell boundaries.

By default, invisible cell boundaries are visible on mouse pointer roll over. You can hide the visibility of lines on mouse pointer roll over by using the **View→Show/Hide Contents** dialog, and clearing the **Hidden Table Borders** check box.

<table>
<thead>
<tr>
<th>Parameter 1</th>
<th>Parameter 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Low</td>
<td>13</td>
</tr>
<tr>
<td>High</td>
<td>18</td>
</tr>
</tbody>
</table>

**Table settings:**

1. Insert a table with 4 rows and 4 columns and enter the information shown above.

Using the **Table** menu:

2. **Merge** the following sets of (Row,Column) cells: (R1,C1) to (R2,C2), (R1,C3) to (R1,C4), and (R3,C1) to (R4,C1).

3. **Group** columns 1 and 2, and columns 3 and 4.

4. **Group** rows 1 and 2, and rows 3 and 4.

In the **Properties** dialog:

5. Set **Exterior Borders** to **None**.

6. (Optional) Change **Table Size Mode** size option to **Scale with zoom factor**.

Using the **Table** menu:

7. Set **Alignment** of columns 3 and 4 to **Center**.

### 2-D Math and Plots

The following example illustrates the use of tables to display 2-D Math and plots side by side.

\[
\begin{array}{c|cccccc}
 t \text{ seconds} & 0 & 1 & 2 & 3 & 4 & 5 & 6 \\
 y(t) \text{ meter} & 0 & 1/2 & 2 & 9/2 & 8 & 25/2 & 18 \\
\end{array}
\]
Approximating $\exp(-x)$ as a rational polynomial using a $3^{rd}$ order Padé approximation.

\[
e^{-x} \approx \frac{1 - \frac{1}{2} x + \frac{1}{10} x^2 - \frac{1}{120} x^3}{1 + \frac{1}{2} x + \frac{1}{10} x^2 + \frac{1}{120} x^3}
\]

Insert a table with 1 row and 2 columns. Enter the information in text and executable 2-D Math to create the calculation and plot, as shown.

**Table Settings:**

In the **Properties** dialog:

1. Set **Exterior** and **Interior Borders** to **None**.
2. Hide Maple input and execution group boundaries: Clear the **Show input** and **Show execution group boundaries** check boxes.

Using the **Table** menu:

3. Change row **Alignment** to **Center**.

**7.5 Canvas**

Using the drawing tools, you can sketch an idea in a canvas, draw on plots, and draw on images. See **Figure 7.15**. For details about the drawing feature, refer to the **DrawingTools** help page.
Insert a Canvas

To insert a canvas:
1. Place the cursor where the canvas is to be inserted.
2. From the Insert menu, select Canvas. A canvas with grid lines appears in the document at the insertion point. The Drawing icon is available and associated context bar icons are displayed.

The tools include the following: selection tool, pencil (free style drawing), eraser, text insert, straight line, rectangle, rounded rectangle, oval, diamond, alignment, drawing outline, drawing fill, drawing linestyle, and drawing canvas properties.

Drawing

To draw with the pencil tool in the canvas:
1. From the Drawing icons, select the pencil icon.
2. Click and drag your mouse in the canvas to draw lines. Release the mouse to complete the drawing.

To adjust the color of drawing tools:
1. From the Drawing icons, select the Drawing Outline icon. See Figure 7.16.
2. Select one of the color swatches available or select the color wheel, RGB ranges, or eye dropper icon at the bottom of the dialog and customize the color to your preference.
3. After selecting a new color, draw on the canvas using the pencil icon and notice the new color.

![Figure 7.16: Drawing Outline Color Icon](image)

In your document, there are three plots, two of which are 2-D plots that can be drawn on. All of the information in the table you made in the previous section could be drawn onto the plot, putting the information in a more concise layout.

Consider one of the plots from the table:

\[
f(x) = \frac{1}{1 + \frac{1}{1 + \frac{1}{x}}}
\]

\[
\frac{d}{dx} f(x) = -\frac{1}{\left(1 + \frac{1}{1 + \frac{1}{x}}\right)^2 \left(1 + \frac{1}{x}\right)^2 x^2}
\]

Click on the plot, and notice that the **Plot** toolbar is open. However, the **Drawing** toolbar is also available. Click on **Drawing** to see the toolbar.

Select the **Text** icon, and click on the plot. Enter the expression \( f(x) \) in one text area, and its derivative in another, as shown. You can move the text areas around on the plot so that they indicate the correct lines.

For details on the rest of the drawing features, refer to the **Drawing Tools** help page.

**Canvas Style**

You can alter the **Canvas** in the following ways:

- Add a grid of horizontal and/or vertical lines. By default, the canvas opens with a grid of horizontal and vertical lines.
• Change the grid line color.
• Change the spacing between grid lines.
• Change the background color.

These options can be changed in the **Drawing Properties Canvas Icon**. See Figure 7.17.

![Drawing Properties Canvas Icon](image)

Figure 7.17: Drawing Properties Canvas Icon - Change the Gridline Color

### Inserting Images

You can insert images in these file formats into your document.

- Graphics Interchange Format - gif
- Joint Photographic Experts Group - jpe, jpeg, jpg
- Portable Network Graphics - png
- Bitmap Graphics - bmp
- Tagged Image File Format - tif, tiff, jfx
- Portable aNyMap - pnm
- Kodak FlashPix - fpx

**To insert an image into the document at the cursor location:**

1. From the **Insert** menu, select **Image**. The **Load Image** dialog opens.
2. Specify a path or folder name.
3. Select a filename.
4. Click **Open**. The image is displayed in the document.

If the source file is altered, the embedded image does not change because the original object is pasted into the document.

**To resize an inserted image:**

1. Click the image. Resizing anchors appear at the sides and corners of the image.
2. Move the mouse over the resize anchor. Resizing arrows appear.
3. Click and drag the image to the desired size.

**Note:** To constrain the proportions of the image as it is resized, press and hold the **Shift** key as you drag.
You can also draw on images in the same way as the drawing canvas. For more information, refer to the worksheet/documenting/drawingtools help page.

**ImageTools Package**

You can manipulate image data using the ImageTools package. This package is a collection of utilities for reading and writing common image file formats, and for performing basic image processing operations within Maple.

Within Maple, images are represented as dense, rectangular Arrays of 64-bit hardware floating-point numbers. Grayscale images are 2-D, whereas color images are 3-D (the third dimension representing the color channels).

In addition to the commands in the ImageTools package, many ordinary Array and Matrix operations are useful for image processing.

For details about this feature, refer to the ImageTools help page.

### 7.6 Hyperlinks

Use a hyperlink in your document to access any of the following.

- Webpage (URL)
- Email
- Worksheet
- Help Topic
- Task
- Dictionary Topic
- Maplet

![Hyperlink Properties Dialog](image)

**Figure 7.18: Hyperlink Properties Dialog**

**Inserting a Hyperlink in a Document**

To create a hyperlink from existing text in the document:

1. Highlight the text that you want to make a hyperlink.
2. From the Insert menu, select Hyperlink. Alternatively, from the Context Panel for the highlighted text, select Convert To—Hyperlink.
3. In the **Hyperlink Properties** dialog box, the **Link Text** field is dimmed since the text region you highlighted is used as the link text. This is demonstrated in **Figure 7.18**. The highlighted text region, Diff is dimmed.

4. Specify the hyperlink **Type** and **Target** as described in the appropriate following section.

**To insert a text or image hyperlink into the document:**

1. From the **Insert** menu, select **Hyperlink**.
2. In the **Hyperlink Properties** dialog box, enter the **Link Text**.

   Optionally, use an image as the link. Select the **Image** check box and click **Choose Image** for the file. In .mw files, the image appears as the link. You can resize the image as necessary. Click and drag from the corners of the image to resize.

3. Specify the hyperlink **Type** and **Target** as described in the appropriate following section.

**Linking to a Webpage**

**To link to a webpage:**

1. In the **Type** drop-down list, select **URL**.
2. In the **Target** field, enter the full URL, for example, `http://www.maplesoft.com`.
3. Click **OK**.

**Linking to an Email Address**

**To link to an email address:**

1. In the **Type** drop-down list, select **Email**.
2. In the **Target** field, enter the email address.
3. Click **OK**.

**Linking to a Worksheet**

**To link to a Maple worksheet or document:**

1. In the **Type** drop-down list, select **Worksheet**.
2. In the **Target** field, enter the path and filename of the document or click **Browse** to locate the file. (Optional) In the **Bookmark** drop-down list, enter or select a bookmark.

**Note:** To link within a single Maple document, leave the **Target** field blank and choose the bookmark from the **Bookmark** drop-down list.

**Tip:** When linking to another document, the default is to use a relative path. When sharing documents that contain hyperlinks, ensure that target documents are in the same directory, or use a ZIP file to preserve the directory structure if you are sharing a large collection of interlinking documents.

3. Click **OK**.

**Linking to a Help Page**

**To link to a help page:**

1. In the **Type** drop-down list, select **Help Topic**.
2. In the **Target** field, enter the topic of the help page. (Optional) In the **Bookmark** drop-down list, enter or select a bookmark.
3. Click **OK**.
Linking to a Task

To link to a task:
1. In the Type drop-down list, select Task.
2. In the Target field, enter the topic name of the task template (see the status bar at the bottom of the Task Browser window).
3. Click OK.

Linking to a Dictionary Topic

To link to a Dictionary topic:
1. In the Type drop-down list, select Dictionary Topic.
2. In the Target field, enter a topic name. Dictionary topics begin with the prefix Definition/, for example, Definition/dimension.
3. Click OK.

Linking to a Maplet Application

To link to a Maplet application:
1. In the Type drop-down list, select Maplet.
2. In the Target field, enter the local path to a file with the .maplet extension. Optionally, click Browse to locate the file.

If the Maplet application exists, clicking the link launches the Maplet application. If the Maplet application contains syntax errors, then error messages are displayed in a popup window.

When sharing documents that contain links to Maplet applications, ensure that target Maplet applications are in the same directory, or use a ZIP file to preserve the directory structure if you are sharing a large collection.

3. Click OK.

Note: To link to a Maplet application available on a MapleNet™ webpage, use the URL hyperlink type to link to the webpage. For information on MapleNet, see Embedded Components and Maplets (page 305).

Linking to a Workbook Attachment

Similar to attaching to a worksheet, you can link to workbook content by directly entering the workbook file URI, or by browsing to the target workbook file.

If you want to enter the URI directly into Target field, you should copy the URI first.

To copy the URI of the content you want to link to:
1. In the Workbook Navigator palette, right-click on the file you want to link to.
2. From the context menu, select Copy Path.
3. The URI of the target file is now copied to the clipboard.

To link to a workbook attachment:
4. Select Workbook Attachment from the Type drop-down list.
5. In the Target field, enter the URI of the worksheet, obtained in the above instructions, or click Browse to locate the workbook file.
6. Click OK.
Linking to a Workbook File

You can link to a workbook file (instead of an attachment inside the workbook) using the hyperlink properties dialog.

1. Select Worksheet from the Type drop-down list.
2. In the Target field, enter the path and filename of the workbook (.maple) file or click Browse to locate the file.
3. Click OK.

Example

For this example, link the text "horizontal range" to the dictionary page for domain. As indicated in the section for Linking to a Dictionary Topic, select Dictionary Topic in the Type drop-down list, and then enter Definition/domain in the Target field.

Links to dictionary topics appear underlined and in red.

Result:

```
plot - create a two-dimensional plot
```

Calling Sequence

```
plot(f, x)
plot(f, x=x0..x1)
plot(v1, v2)
```

Parameters

- `f` - expression in independent variable `x`
- `x` - independent variable
- `x0, x1` - left and right endpoints of horizontal range
- `v1, v2` - x-coordinates and y-coordinates

Bookmarks

Use a bookmark to designate a location in an active document. This bookmark can then be accessed from other regions in your document or by using hyperlinks in other documents.

To display bookmark formatting icons, activate the Marker feature.

- From the View menu, select Markers.

![Section 1.1 Bookmark Indicator](Figure7.19: Bookmark Indicator)

Note: You can display bookmark properties by holding the pointer over a bookmark indicator. See Figure 7.19.

Inserting, Renaming, and Deleting a Bookmark

To insert a bookmark:

1. Place the cursor at the location at which to place the bookmark. For example, place the cursor in the Parameters section title.
2. From the Format menu, select Bookmarks. The Bookmark dialog opens, listing existing bookmarks in the document.
3. Click **New**. The **Create Bookmark** dialog opens. See **Figure 7.20**. Enter a bookmark name, "parameters", and click **Create**.

![Create Bookmark Dialog](image)

**Figure 7.20: Create Bookmark Dialog**

4. The new bookmark appears in the **Bookmark** dialog list. Click **OK**.

**Note**: You can also rename and delete bookmarks using the **Bookmark** dialog. Alternatively, right-click on a particular bookmark to rename or delete it.

**Result:**

```
plot - create a two-dimensional plot
```

\[ \text{\bf Calling Sequence} \]

\[
\begin{align*}
\text{plot}(f, x) \\
\text{plot}(f, x=x_0..x_1) \\
\text{plot}(v_1, v_2)
\end{align*}
\]

\[ \text{\bf Parameters} \]

- \( f \) - expression in independent variable \( x \)
- \( x \) - independent variable
- \( x_0, x_1 \) - left and right endpoints of horizontal range
- \( v_1, v_2 \) - \( x \)-coordinates and \( y \)-coordinates

**Go to a Bookmark**

You can automatically move the cursor to the location of the bookmark in the active document.

1. From the **Edit** menu, select **Go To Bookmark**. The **Go To Bookmark** dialog opens with the current bookmarks listed.

2. Select the bookmark "parameters" and click **OK**. The cursor moves to the bookmark, at the beginning of the **Parameters** section.

For more information, refer to the **bookmarks** help page.
7.7 Embedded Components

You can embed simple graphical interface components, such as a button, in your document. These components can then be associated with actions that are to be executed. For example, the value of a slider component can be assigned to a document variable, or a text field can be used to input an equation.

Adding Graphical Interface Components

The graphical interface components can be inserted by using the Components palette (Figure 7.21) or by cutting/copying and pasting existing components to another area of the document. Although copied components have most of the same characteristics, they are distinct.

By default, palettes are displayed when you launch Maple. If palettes are not visible, use the following procedure:

1. From the View menu, select Palettes.
2. Select Expand Dock.
3. If the Components palette is not displayed, right-click (Control-click, for Macintosh) the palette dock. From the context menu, select Show Palette, and then Components.

For more information, see Palettes (page 15).

You can embed the following items:

- Button, Toggle Button
- Combo Box, Check Box, List Box, Radio Button
- Text Area, Label
- Slider, Plot, Mathematical Expression
- Dial, Meter, Rotary Gauge, Volume Gauge
- Data Table
- Video Player
- Shortcut Component
Task Template with Embedded Components

In your document, you can add components that have already been configured to work together, by using a task template. Here, we use the Interactive Application template. For details on how to create and modify components, see *Creating Embedded Components* (page 308).

To insert the task template, from the **Tools** menu, select **Tasks → Browse**. In the table of contents, expand **Document Templates**, and select **Interactive Application**. Click **Insert Minimal Content**. The following is inserted into your document.
The Spellcheck utility examines all designated text regions of your document for potential spelling mistakes, including regions that are in collapsed sections. It does not check input, output, text in execution groups, or math in text regions. See Figure 7.23.

Note: The Spellcheck utility uses American spelling.
How to Use the Spellcheck Utility


2. If the Spellcheck utility finds a word that it does not recognize, that word is displayed in the Not Found text box. You have six choices:
   - To ignore the word, click Ignore.
   - To ignore all instances of the word, click Ignore All.
   - To change the word, that is, accept the suggested spelling that is in the Change To text box, click Change.
   - To change all instances of the word, that is, accept the suggested spelling to replace all instances of the word, click Change All.
   - To add the word to your dictionary, click Add. For details, see the following User Dictionary section.
   - To close the Spellcheck dialog and stop the spelling check, click Cancel.

3. When the Spellcheck is complete, a dialog containing the message "The spelling check is complete" appears. Click OK to close this dialog.

Note: when using the Spellcheck utility, you can fix spelling errors in the dialog, but you cannot change the text in document. The Spellcheck utility does not check grammar.

Selecting a Suggestion

To select one of the suggestions as the correct spelling, click the appropriate word from the list in the Suggestions text box.

If none of the suggestions are correct, highlight the word in the Change To text box and enter the correct spelling. Click Change to accept this new spelling.

User Dictionary

You can create and maintain a custom dictionary that works with the Maple Spellcheck utility.
Properties of the Custom Dictionary File

- It must be a text file, that is, have the file extension `.txt`. For example, `mydictionary.txt`.
- It is a list of words, one word per line.
- It is case sensitive. This means that `integer` and `Integer` require individual entries in the dictionary file.
- It does not require manual maintenance. You build your dictionary file by using the Add functionality of the Spellcheck. However, you can manually edit the file.

To specify a custom dictionary to be used with the Maple Spellcheck utility:
1. Create a `.txt` file in a directory/folder of your choice.
2. In Maple, open the Options dialog, Tools → Options, and select the General tab.
3. In the User Dictionary field, enter the path and name of the `.txt` file you created, or click Browse to select the location and filename.
4. To ignore Maple words that are command and function names, clear the Use Maple words in spellchecker check box.
5. Click Apply to Session or Apply Globally to save the settings, or Cancel to discard.

Adding a Word to Your Dictionary

When running the spellcheck, if the word in the Not Found text box is correct, you can add the word to your dictionary.
1. Click the Add button. If this is the first time you are adding a word, the Select User Dictionary dialog opens.
2. Enter or select the custom dictionary (.txt file) you created. See User Dictionary (page 260).
3. Click Select. The word is automatically added to your custom dictionary file.

Note: Specifications in the Options dialog determine whether this word is recognized in your next Maple session. If you set your custom dictionary and clicked Apply to Session, then this word will not be recognized in a new Maple session. If you set your custom dictionary and clicked Apply Globally, then this new word will be recognized.
8 Maple Expressions

This chapter provides basic information on using Maple expressions, including an overview of the basic data structures. Many of the commands described in this chapter are useful for programming. For information on additional Maple programming concepts, such as looping, conditional execution, and procedures, see Basic Programming (page 289).

8.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Creating and Using Data Structures (page 263) - How to define and use basic data structures | • Expression Sequences  
• Sets  
• Lists  
• Tables  
• Arrays  
• Matrices and Vectors  
• Functional Operators  
• Strings |
| Working with Maple Expressions (page 272) - Tools for manipulating and controlling the evaluation of expressions | • Low-Level Operations  
• Manipulating Expressions  
• Evaluating Expressions |

8.2 Creating and Using Data Structures

Constants, data structures, mathematical expressions, and other objects are Maple expressions. For more information on expressions, refer to the Maple Help System.

This section describes the key data structures:

• Expression sequences
• Sets
• Lists
• Tables
• Arrays
• Matrices and Vectors
• Functional operators
• Strings

Expression Sequences

The fundamental Maple data structure is the expression sequence. It is a group of expressions separated by commas.

\[ S := 2, y, \sin(x^2), I : \]

Accessing Elements

To access one of the expressions:

• Enter the sequence name followed by the position of the expression enclosed in brackets( ).
For example:

\[ S[2] \]

\[ 5 \]

Using negative integers, you can select an expression from the end of a sequence.

\[ S[-2] \]

\[ \sin(x^2) \]

You can select multiple expressions by specifying a range using the range operator (..).

\[ S[2..-2] \]

\[ 5, \sin(x^2) \]

Note: This syntax is valid for most data structures.

Sets

A set is an expression sequence enclosed in curly braces ({}).

\[ \{4, 12, i, \sin\left(\frac{2}{3}\right)\} \]

A Maple set has the basic properties of a mathematical set.

- Each element is unique. Repeated elements are stored only once.
- The order of elements is not stored.

For example:

\[ \{c, a, a, a, b, c, a\} \]

\[ \{a, b, c\} \]

Using Sets

To perform mathematical set operations, use the set data structure.

\[ \{2, 6, 5, 1\} \cup \{2, 8, 6, 7\} \]

\[ \{1, 2, 5, 6, 7, 8\} \]

Note: The union operator is available in 1-D Math input as union. For more information, refer to the union help page.

For more information on sets, refer to the set help page.

Lists

A list is an expression sequence enclosed in brackets ([ ]).

\[ L := [2, 3, 3, 1, 0] \]

\[ L := [2, 3, 3, 1, 0] \]

Note: Lists preserve both the order and repetition of elements.
**Accessing Entries**

To refer to an element in a list:
- Use square brackets.

For example:

```plaintext
> L[−2 .. −1]  
```

[1, 0]

For more information, see *Accessing Elements (page 263).*

**Using Lists**

Some commands accept a list (or set) of expressions.

For example, you can solve a list (or set) of equations using the context panel or the `solve` command.

```plaintext
> solve([x − y^2 = −2, x + y = 0])
```

For more information, see *Solving Equations and Inequations (page 80).*

For more information on sets and lists, refer to the `set` help page.

**Arrays**

Conceptually, the `Array` data structure is a generalized list. Each element has an index that you can use to access it.

The two important differences are:
- The indices can be any integers.
- The dimension can be greater than one.

**Creating and Using Arrays**

To define an Array, use the `Array` constructor.

Standard `Array` constructor arguments are:
- Expression sequences of ranges - Specify the indices for each dimension
- Nested lists - Specify the contents
For example:

> \( a := \text{Array}(1..3, 1..3, [[1, 2, 3], [4, 5, 6], [7, 8, 9]]) \)

\[
\begin{bmatrix}
1 & 2 & 3 \\
4 & 5 & 6 \\
7 & 8 & 9
\end{bmatrix}
\]

> \( b := \text{Array}(1..2, 2..5, [[1.2, 4.9, 6.3, 7.1], [9.2, 5.5, 2.4, 1.7]]) \)

\[
\begin{bmatrix}
1.2 & 4.9 & 6.3 & 7.1 \\
9.2 & 5.5 & 2.4 & 1.7
\end{bmatrix}
\]

To access entries in an Array, use either square bracket or round bracket notation.

Square bracket notation respects the actual index of an Array, even when the index does not start at 1.

> \( a[1, 1] \)

\[
1
\]

> \( a[2, 3] \)

\[
6
\]

> \( b[2, 3] \)

\[
5.5
\]

> \( b[1, 1] \)

Error, Array index out of range

Round bracket indexing normalizes the dimensions to begin at 1. Since this method is relative, you can access the end of the array by entering \(-1\).

> \( a(-1, 2) \)

\[
8
\]

> \( b(1, 1) \)

\[
1.2
\]

Arrays can have more than one or two dimensions. For example, the following is a simple three-dimensional Array.

> \( A := \text{Array}(1..2, 1..2, 1..2, \text{fill} = 3) \)

\[
\begin{bmatrix}
3 & 3 \\
3 & 3
\end{bmatrix}
\]

slice of \( 2 \times 2 \times 2 \) Array
The `Array` constructor supports other syntaxes. It also supports many options. For more information on the `Array` constructor and the Array data structure, refer to the `Array` help page. For more information on indexing methods, refer to the `table_indexing` help page.

Large Arrays

Larger Arrays than can be practically displayed in the document display with a summary format. For example, the multidimensional Array in (8.1) is displayed in summary format. The following 100-entry Array is as well. In both cases, double-clicking on the placeholder output opens a browser for the entire data structure.

```plaintext
> Array(0 .. 100)

[0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, ]
```

To view large Arrays:
- Double-click the placeholder output.

The `Matrix Browser` displays the Array.

In the case of a multidimensional array, you can change what slice you are viewing in the Options tab.

For more information, see Viewing Large Matrices and Vectors (page 118).

Tables

Tables are conceptually an extension of the Array data structure, but the table data structure is implemented using hash tables. Tables can be indexed by any values, not only integers.

Defining Tables and Accessing Entries

```plaintext
> Greek := table([ a = α, b = β, c = γ ]):
> Greek[b]

β
```

You can also assign anything, for example, a list, to each element.

```plaintext
> Translation := table([ one = [ un, uno], two = [ deux, dos], three = [ trois, tres] ]):
> Translation[two]

[deux, dos]
```

For more information on tables, refer to the `table` help page.

Matrices and Vectors

Matrices and Vectors are specialized data structures used in linear algebra and vector calculus computations.

```plaintext
> M := [12, 33; 83, 12]: v := <2, 14>:
```

For information on defining Matrices and Vectors, see Creating Matrices and Vectors (page 116).
For more information on these data structures, including how to access entries and perform linear algebra computations, see Linear Algebra (page 116).

**Functional Operators**

A functional operator is a mapping \( f : x \rightarrow y(x) \). The value of \( f(x) \) is the result of evaluating \( y(x) \).

Using functional operators, you can define mathematical functions.

**Defining a Function**

To define a function of one or two variables:

1. In the Expression palette, click one of the function definition items. See Figure 8.1. Maple inserts the function definition.
2. Replace the placeholders, using Tab to move to the next placeholder. **Note:** If pressing the Tab key indents the text, click the Tab icon in the toolbar. This allows you to move between placeholders.
3. Press Enter.

![Figure 8.1: Function Definition Palette Items](image)

For example, define a function that adds 1 to its input.

\[
> \text{add1} := x \rightarrow x + 1:
\]

**Note:** Instead of using the palettes, you can type the definition. To insert the right arrow, you can enter the characters ->. In 2-D Math, Maple replaces -> with the right arrow symbol \( \rightarrow \). In 1-D Math, the characters are not replaced.

You can evaluate the function **add1** with symbolic or numeric arguments.
Distinction between Functional Operators and Other Expressions

Note: The expression $x + 1$ is different from the functional operator $x \rightarrow x + 1$.

Assign the functional operator $x \rightarrow x + 1$ to $f$.

```plaintext
> f := x \rightarrow x + 1;
```

Assign the expression $x + 1$ to $g$.

```plaintext
> g := x + 1;
```

To evaluate the functional operator $f$ at a value of $x$:

- Specify the value as an argument to $f$.

```plaintext
> f(22)
```

To evaluate the expression $g$ at a value of $x$:

- You **must** use the **eval** command.

The following is not meaningful:

```plaintext
> g(22)
```

Evaluating $g$ at $x = 22$ gives the desired result.

```plaintext
> eval(g, x = 22)
```

For more information on the **eval** command, and on using palettes and the context panel to evaluate an expression at a point, see *Substituting a Value for a Subexpression* (page 279).

Multivariate and Vector Functions

To define a multivariate or vector function:

- Enclose coordinates or coordinate functions in parentheses (()).

For example, a multivariate function:

```plaintext
> f := (x, y) \rightarrow \frac{x^3}{y^2 + 1};
```
A vector function:

\[ f(0, 0); f(-2.1, 1.9) \]

\[ \begin{align*}
0 \\
-2.008893709
\end{align*} \]

Using Operators

To perform an operation on a functional operator, specify arguments to the operator. For example, for the operator \( f \), specify \( f(x) \), which Maple evaluates as an expression. See the following examples.

Plotting:

Plot a three-dimensional operator as an expression using the `plot3d` command.

\[ \text{> unassign('y') :} \]
\[ \text{> h := (x, y) \rightarrow x^2 \cos(y):} \]
> plot3d(h(x, y), x = -2 .. 2, y = -2 .. 2 pi)

For information on plotting, see *Plots and Animations* (page 183).

**Integration:**

Integrate a function using the `int` command.

> k := x -> sin(cos(x)*pi):

> int(k(t), t = 0 .. pi/2)

\[
\frac{\pi \text{StruveH}(0, \pi)}{2}
\]

The result uses the *Struve* function \( \text{StruveH}(v, x) \).

For information on integration and other calculus operations, see *Calculus* (page 128). For information on mathematical functions, including accessing detailed information on the properties of a function, see *Mathematical Functions* (page 58) and the `FunctionAdvisor` help page.

**Strings**

A string is a sequence of characters enclosed in double quotes (" ").
Accessing Characters

You can access characters in a string using brackets.

\[ S := \text{"This is a sequence of characters."} \]

\[ S[11..-2] \]

"sequence of characters"

Using Strings

The `StringTools` package is an advanced set of tools for manipulating and using strings.

\[ \text{with(StringTools):} \]

\[ \text{Random(9, 'alnum')} \]

"MJoY2Qs0F"

\[ \text{Stem("impressive")} \]

"impress"

\[ \text{Split("Create a list of strings from the words in a string")} \]

["Create", "a", "list", "of", "strings", "from", "the", "words", "in", "a", "string"]

8.3 Working with Maple Expressions

This section describes how to manipulate expressions using commands. Topics covered include testing the expression type, accessing operands of an expression, and evaluating an expression.

Low-Level Operations

Expression Types

A Maple type is a broad class of expressions that share common properties. Maple contains over 200 types, including:

- `+`
- `boolean`
- `constant`
- `integer`
- `Matrix`
- `trig`
- `truefalse`

For more information and a complete list of Maple types, refer to the `type` help page.

The type commands return true if the expression satisfies the type check. Otherwise, they return false.
Testing the Type of an Expression

To test whether an expression is of a specified type:

• Use the `type` command.

  > type(sin(x), 'trig')

      true

  > type(sin(x) + cos(x), 'trig')

      false

For information on enclosing keywords in right single quotes ('), see Delaying Evaluation (page 285).

Maple types are not mutually exclusive. An expression can be of more than one type.

  > type(3, 'constant')

      true

  > type(3, 'integer')

      true

For information on converting an expression to a different type, see Converting (page 278).

Testing the Type of Subexpressions

To test whether an expression has a subexpression of a specified type:

• Use the `hastype` command.

  > hastype(sin(x) + cos(x), 'trig')

      true

Testing for a Subexpression

To test whether an expression contains an instance of a specified subexpression:

• Use the `has` command.

  > has(sin(x + y), x)

      true

  > has(sin(x + y), x + y)

      true

  > has(sin(x + y), sin(x))

      false

The `has` command searches the structure of the expression for an exactly matching subexpression.
For example, the following calling sequence returns false.

\[
> \text{has}(x + y + z, x + z)
\]

\[
false
\]

To return all subexpressions of a particular type, use the \texttt{indets} command. For more information, see \textit{Indeterminates (page 275)}.

\textbf{Accessing Expression Components}

\textbf{Left and Right-Hand Side}

To extract the left-hand side of an equation, inequality, or range:

- Use the \texttt{lhs} command.

To extract the right-hand side of an equation, inequality, or range:

- Use the \texttt{rhs} command.

For example:

\[
> y = x + 1
\]

\[
y = x + 1
\]  

\[\text{(8.2)}\]

\[
> \text{lhs}(\text{(8.2)})
\]

\[
y
\]  

\[\text{(8.3)}\]

\[
> \text{rhs}(\text{(8.2)})
\]

\[
x + 1
\]  

\[\text{(8.4)}\]

For the following equation, the left endpoint of the range is the left-hand side of the right-hand side of the equation.

\[
> x = 3..5
\]

\[
x = 3..5
\]  

\[\text{(8.5)}\]

\[
> \text{lhs(rhs(\text{(8.5)})})
\]

\[
3
\]  

\[\text{(8.6)}\]

\textbf{Numerator and Denominator}

To extract the numerator of an expression:

- Use the \texttt{numer} command.

To extract the denominator of an expression:

- Use the \texttt{denom} command.

\[
> \theta := \frac{1 + \sin(x)^3 - \frac{y}{x}}{y^2 - 1 + x}:
\]

If the expression is not in normal form, Maple normalizes the expression before selecting the numerator or denominator. (For more information on normal form, refer to the \texttt{normal} help page.)
The expression can be any algebraic expression. For information on the behavior for non-rational expressions, refer to the `numer` help page.

**Components of an Expression**

The components of an expression are called its *operands*.

**To count the number of operands in an expression:**

- Use the `nops` command.

For example, construct a list of solutions to an equation.

```maple
> solutions := [solve(6*x^3 - x^2 + 7, x)]

solutions := [-1, 7/12 - 1*sqrt(119)/12, 7/12 + 1*sqrt(119)/12]
```

Using the `nops` command, count the number of solutions.

```maple
> nops(solutions)

3
```

For more information on the `nops` command and operands, refer to the `nops` help page.

**Indeterminates**

**To find the indeterminates of an expression:**

- Use the `indets` command.

The `indets` command returns the indeterminates as a set. Because the expression is expected to be rational, functions such as `sin(x)`, `f(x)`, and `sqrt(x)` are considered to be indeterminate.

```maple
> indets((3 + π) * x^2 * sin(1 + y))

{x, y, 1 + y, sin(1 + y)}
```

To return all subexpressions of a particular type, specify the type as the second argument. For information on types, see `Testing the Type of an Expression` (page 273).

```maple
> indets((3 + π) * x^2 * sin(1 + y), 'radical')

{1 + y}
```
To test whether an expression has subexpressions of a specific type (without returning them), use the `has` command. For more information, see Testing for a Subexpression (page 273).

## Manipulating Expressions

This section introduces the most commonly used manipulation commands. For additional manipulation commands, see Iterative Commands (page 297).

### Simplifying

To simplify an expression:

- Use the `simplify` command.

The `simplify` command applies simplification rules to an expression. Maple has simplification rules for various types of expressions and forms, including trigonometric functions, radicals, logarithmic functions, exponential functions, powers, and various special functions. You can also specify custom simplification rules using a set of side relations.

```maple
> simplify(5 + 32 - 8*(1/3))
35
```

```maple
> simplify(sin(x)^2 + ln(2*y) + cos(x)^2)
1 + ln(2) + ln(y)
```

To limit the simplification, specify the type of simplification to be performed.

```maple
> simplify(sin(x)^2 + ln(2*y) + cos(x)^2, 'trig')
1 + ln(2*y)
```

```maple
> simplify(sin(x)^2 + ln(2*y) + cos(x)^2, 'ln')
sin(x)^2 + ln(2) + ln(y) + cos(x)^2
```

You can also use the `simplify` command with side relations. See Substituting a Value for a Subexpression (page 279).

### Factoring

To factor a polynomial:

- Use the `factor` command.

```maple
> factor(x^6-x^5-9*x^4+x^3+20*x^2+12*x)
x(x-2)(x-3)(x+2)(x+1)^2
```

```maple
> factor(x^3*y+x^2*y^2-3*x^2-x^2*y+2*x*y^2-6*x^2-5*x*y+y^2-3*x-3*y)
(y-3)(x+1)^2(x+y)
```

Maple can factor polynomials over the domain specified by the coefficients. You can also factor polynomials over algebraic extensions. For details, refer to the `factor` help page.

For more information on polynomials, see Polynomial Algebra (page 110).
To factor an integer:
• Use the \texttt{ifactor} command.

\begin{verbatim}
> ifactor(196911)
\end{verbatim}

(3)^4 (11) (13) (17)

For more information on integers, see \textit{Integer Operations} (page 76).

\textbf{Expanding}

To expand an expression:
• Use the \texttt{expand} command.

The \texttt{expand} command distributes products over sums and expands expressions within functions.

\begin{verbatim}
> expand((y-3) (x + 1)^2 (x + y))
\end{verbatim}

\begin{verbatim}
x^3 y + x^2 y^2 - 3 x^3 - x^2 y - 2 x y^2 - 6 x^2 - 5 x y + y^2 - 3 x - 3 y
\end{verbatim}

\begin{verbatim}
> expand(sin(x + y))
\end{verbatim}

\begin{verbatim}
sin(x) \cos(y) + \cos(x) \sin(y)
\end{verbatim}

\textbf{Combining}

To combine subexpressions in an expression:
• Use the \texttt{combine} command.

The \texttt{combine} command applies transformations that combine terms in sums, products, and powers into a single term.

\begin{verbatim}
> combine(sin(x) \cos(y) + \cos(x) \sin(y))
\end{verbatim}

\begin{verbatim}
sin(x + y)
\end{verbatim}

Recall that \(a\) was previously assigned to represent a two-dimensional array (see \textit{Creating and Using Arrays} (page 265)).

\begin{verbatim}
> combine((x^a)^2 x)
\end{verbatim}

\begin{verbatim}
\begin{bmatrix}
x^3 & x^5 & x^7 \\
x^9 & x^{11} & x^{13} \\
x^{15} & x^{17} & x^{19}
\end{bmatrix}
\end{verbatim}

The \texttt{combine} command applies only transformations that are valid for all possible values of names in the expression.

\begin{verbatim}
> combine(4 \ln(x) - \ln(y))
\end{verbatim}

\begin{verbatim}
4 \ln(x) - \ln(y)
\end{verbatim}

To perform the operation under assumptions on the names, use the \texttt{assuming} command. For more information about assumptions, see \textit{Assumptions on Variables} (page 104).
Converting

To convert an expression:

• Use the `convert` command.

The `convert` command converts expressions to a new form, type (see Expression Types (page 272)), or in terms of a function. For a complete list of conversions, refer to the `convert` help page.

Convert a measurement in radians to degrees:

```maple
> convert(π, 'degrees')
180 degrees
```

To convert measurements that use units, use the Unit Converter or the `convert/units` command.

```maple
> convert(450.2kg, 'units', lb)
992.5211043 lb
```

For information on the Unit Converter and using units, see Units (page 93).

Convert a list to a set:

```maple
> convert([b, c, d], 'set')
{c, d, Array(1 .. 2, 2 .. 5, (1, 2) = 1.2, (1, 3) = 4.9, (1, 4) = 6.3, (1, 5) = 7.1, (2, 2) = 9.2, (2, 3) = 5.5, (2, 4) = 2.4, (2, 5) = 1.7))}
```

Maple has extensive support for converting mathematical expressions to a new function or function class.

```maple
> convert(cos(x), exp)
(1/2) e^1x + (1/2) e^-1x
```

Find an expression equivalent to the inverse hyperbolic cotangent function in terms of Legendre functions.

```maple
> convert(arccoth(z), Legendre)
LegendreQ(0, 1/5) + π/8 + π √−16/8
```

For more information on converting to a class of functions, refer to the `convert/to_special_function` help page.

Normalizing

To normalize an expression:

• Use the `normal` command.

The `normal` command converts expressions into factored normal form.
To expand the numerator and denominator, use the \texttt{expanded} option.

\begin{equation*}
\text{normal}\left( \frac{x^2-y^2}{(x-y)^3}, \text{expanded} \right)
\end{equation*}

\begin{equation*}
\frac{x + y}{x^2 - 2xy + y^2}
\end{equation*}

\begin{equation*}
\text{normal}\left( \sin\left(1 + \frac{1}{x}\right)\right)
\end{equation*}

\begin{equation*}
\sin\left(\frac{x+1}{x}\right)
\end{equation*}

\textbf{Sorting}

To sort the elements of an expression:

\begin{itemize}
  \item Use the \texttt{sort} command.
\end{itemize}

The \texttt{sort} command orders a list of values or terms of a polynomial.

\begin{equation*}
\text{sort}([4, 3, 2.1, -4, 43, 0])
\end{equation*}

\begin{equation*}
[-4, 0, 2.1, 3, 4, 43]
\end{equation*}

\begin{equation*}
\text{sort}(x + 4x^5 - 7x^2 + 1 + 9x^4 - 5x^3)
\end{equation*}

\begin{equation*}
4x^5 + 9x^4 - 5x^3 - 7x^2 + x + 1
\end{equation*}

\begin{equation*}
\text{sort}(xy - 6y^2x + 2y^3 + 5x - 1)
\end{equation*}

\begin{equation*}
-6xy^2 + 2y^3 + xy + 5x - 1
\end{equation*}

For information on sorting polynomials, see \textit{Sorting Terms (page 111)}.

For more information on sorting, refer to the \texttt{sort} help page.

\textbf{Evaluating Expressions}

\textbf{Substituting a Value for a Subexpression}

To evaluate an expression at a point, you must substitute a value for a variable.
To substitute a value for a variable using the context panel:
1. Select the expression.
2. From the context panel, select Evaluate at a Point. The Evaluate at a Point dialog is displayed. See Figure 8.2.

![Evaluate at a Point](image)

Figure 8.2: Evaluate at a Point
3. In the drop-down list, select the variable to substitute.
4. In the text field, enter the value to substitute for the variable. Click OK.

In Worksheet mode, Maple inserts the eval command calling sequence that performs the substitution. This is the most common use of the eval command.

For example, substitute \( x = 3 \) in the following polynomial.

\[
> x^3 + 4 x^2 - 7 x + 2
\]

\[
> \frac{d}{dx} (x^3 + 4 x^2 - 7 x + 2)
\]

\[
> \text{eval}((x^3 + 4 x^2 - 7 x + 2), [x = 3])
\]

44

To substitute a value for a variable using palettes:
1. In the Expression palette, click the evaluation at a point item \( f(x) \bigg|_{x = a} \).
2. Specify the expression, variable, and value to be substituted.

For example:

\[
> \sqrt{x^2 - x - 3} \bigg|_{x = 5}
\]

\[
= \sqrt{17}
\]

Substitutions performed by the eval function are syntactical, not the more powerful algebraic form of substitution. If the left-hand side of the substitution is a name, Maple performs the substitution.

\[
> \text{unassign('a')} : \text{unassign('b')} :
\]
If the left-hand side of the substitution is not a name, Maple performs the substitution only if the left-hand side of the substitution is an operand of the expression.

\[ \texttt{eval\left(\cos(a\ b\ c),\ a = \frac{\pi}{6}\right)} \]

\[ \cos\left(\frac{\pi\ b\ c}{6}\right) \]

If the left-hand side of the substitution is not a name, Maple performs the substitution only if the left-hand side of the substitution is an operand of the expression.

\[ \texttt{eval\left(\cos(a\ b),\ a\ b = \frac{\pi}{6}\right)} \]

\[ \frac{\sqrt{3}}{2} \]

\[ \texttt{eval\left(\cos(a\ b\ c),\ a\ b = \frac{\pi}{6}\right)} \]

\[ \cos(a\ b\ c) \]

Maple did not perform the evaluation because \( a\ b \) is not an operand of \( \cos(a\ b\ c) \). For information on operands, refer to the \texttt{op} help page.

For algebraic substitution, use the \texttt{algsubs} command, or the \texttt{simplify} command with side relations.

\[ \texttt{algsubs\left(a\ b = \frac{\pi}{6},\ \cos(a\ b\ c)\right)} \]

\[ \cos\left(\frac{c\ \pi}{6}\right) \]

\[ \texttt{simplify\left(\cos(a\ b\ c),\ \left[a\ b = \frac{\pi}{6}\right]\right)} \]

\[ \cos\left(\frac{c\ \pi}{6}\right) \]

**Numerical Approximation**

To compute an approximate numerical value of an expression:

- Use the \texttt{evalf} command.

The \texttt{evalf} command returns a floating-point (or complex floating-point) number or expression.
By default, Maple calculates the result to ten digits of accuracy, but you can specify any number of digits as an index, that is, in brackets ([ ]).

For more information, refer to the evalf help page.

See also Numerically Computing a Limit (page 129) and Numeric Integration (page 136).

**Evaluating Complex Expressions**

To evaluate a complex expression:

- Use the evalc command.

If possible, the evalc command returns the output in the canonical form expr1 + i expr2.

In 2-D Math input, you can enter the imaginary unit using the following two methods.
- In the Common Symbols palette, click the i or j item. See Palettes (page 15).
- Enter i or j, and then press the symbol completion key. See Symbol Names (page 21).

```plaintext
> evalc(2^(1 + I));

\sqrt{2 + \sqrt{2}} \frac{2}{2} + I \sqrt{2 - 2 \sqrt{2}} \frac{2}{2}
```

```plaintext
> evalc(sin(3 + 5 j));

\sin(3) \cosh(5) + I \cos(3) \sinh(5)
```

In 1-D Math input, enter the imaginary unit as an uppercase i (I).

```plaintext
> evalc(2^(1 + I));

2 \cos(\ln(2)) + 2 I \sin(\ln(2))
```

**Evaluating Boolean Expressions**

To evaluate an expression involving relational operators ( =, ≠, >, <, ≤, and ≥):

- Use the evalb command.
Note: In 1-D Math input, enter ≠, ≤, and ≥ using the <>, <=, and >= operators.

The evalb command uses a three-valued logic system. The return values are true, false, and FAIL. If evaluation is not possible, an unevaluated expression is returned.

> evalb(x = x)

true

> evalb(x = y)

false

> evalb(3 + 2 I < 2 + 3 I)

FAIL

Important: The evalb command does not perform arithmetic for inequalities involving <, ≤, >, or ≥, and does not simplify expressions. Ensure that you perform these operations before using the evalb command.

> evalb(ℜ(x) < ℜ(x + 1))

ℜ(x) < 1 + ℜ(x)

> evalb(ℜ(x) - ℜ(x + 1) < 0)

true

Applying an Operation or Function to All Elements in a List, Set, Table, Array, Matrix, or Vector

You can use the tilde character (~) to apply an operation or function to all of the elements in a list, set, table, Array, Matrix, or Vector.

In the following example, each element in the Matrix M is multiplied by 2 by adding a tilde character after the multiplication operator(·).

> M := [1 2 3
       4 5 6
       7 8 9]

M := [1 2 3
       4 5 6
       7 8 9]  

> M~*2

[2 4 6
 8 10 12
14 16 18]

In the following example, the function sin is applied to each element in the Matrix M.
The tilde character can also be used to apply a function to multiple data sets, for example,

\[
\text{diff}(z \cdot x^2 + x \cdot y^2, [x, x, y, y, z, z], [y, z, z, x, x, y]);
\]

\[
[2 \cdot y, 2 \cdot x, 2 \cdot y, 0, 2 \cdot x, 0]
\]  

(8.10)

You can use values in one data structure type to compute values in another data structure type, as long as both data structures are dimensional and contain the same number of elements. In the following example, the values in an Array are compared to the values in a Matrix that contains the same number of elements.

\[
> [12, 88, 20] \sim (3, 100, 25)
\]

\[
\begin{bmatrix}
3 < 12 \\
100 < 88 \\
25 < 20
\end{bmatrix}
\]  

(8.11)

For more information, refer to the elementwise help page.

**Levels of Evaluation**

In a symbolic mathematics program such as Maple, you encounter the issue of *levels of evaluation*. If you assign `y` to `x`, `z` to `y`, and then 5 to `z`, what is the value of `x`?

At the top-level, Maple *fully evaluates* names. That is, Maple checks if the name or symbol has an assigned value. If it has a value, Maple substitutes the value for the name. If this value has an assigned value, Maple performs a substitution, recursively, until no more substitutions are possible.

For example:

\[
> x := y;
\]

\[
> y := z;
\]

\[
> z := 5;
\]

Maple fully evaluates the name `x`, and returns the value 5.

\[
> x
\]

5

To control the level of evaluation of an expression:

- Use the `eval` command with an integer second argument.

If passed a single argument, the `eval` command fully evaluates that expression. If you specify an integer second argument, Maple evaluates the expression to that level.
> eval(x) 5

> eval(x, 1) y

> eval(x, 2) z

> eval(x, 3) 5

For more details on levels of evaluation, refer to the lastnameevaluation, assigned, and evaln help pages.

**Delaying Evaluation**

To prevent Maple from immediately evaluating an expression:

• Enclose the expression in right single quotes (').

Because right single quotes delay evaluation, they are referred to as unevaluation quotes.

> i := 4:

> i 4

> 'i'
i

**Using an Assigned Name as a Variable or Keyword**

If you use an assigned name as a variable, Maple evaluates the name to its value, and passes the value to the command. In this example, that causes Maple to return an error message.

> \( \sum_{i=1}^{n} i^2 \)

Error, (in sum) summation variable previously assigned, second argument evaluates to 4 = 1 .. n

**Note:** In general, it is recommended that you unassign a name to use it as a variable. See *Unassigning a Name Using Unevaluation Quotes* (page 286).

**To use an assigned name as a variable:**

• Enclose the name in unevaluation quotes. Maple passes the name to the command.
Important: It is recommended that you enclose keywords in unevaluation quotes.

For example, if you enclose the keyword \texttt{left} in unevaluation quotes, Maple uses the name, not its assigned value. We can also unassign the definition of 'x' with unevaluation quotes.

\begin{verbatim}
> x := 'x';
> left := 3;
> limit(1/x, x = 0, 'left')
\end{verbatim}

\[-\infty\]

Full Evaluation of an Expression in Quotes

Full evaluation of a quoted expression removes one set of right single quotes.

\begin{verbatim}
> i := 4;
> ' ' i + 1'
> (8.12)

\texttt{i + 1} \hspace{2cm} \texttt{4 \ q - \ i} \hspace{2cm} (8.15)
\end{verbatim}

For information on equation labels and equation label references, see \textit{Equation Labels} (page 68).

Enclosing an expression in unevaluation quotes delays evaluation, but does not prevent automatic simplification.

\begin{verbatim}
> ' q - i + 3 q'
> (8.13)

\texttt{5} \hspace{2cm} (8.14)
\end{verbatim}

Unassigning a Name Using Unevaluation Quotes

To unassign a name:

\begin{itemize}
  \item Assign the name enclosed in unevaluation quotes to itself.
\end{itemize}

\begin{verbatim}
> i := 'i';
> i
\end{verbatim}

\begin{verbatim}
\texttt{i}
\end{verbatim}
You can also unassign a name using the \texttt{unassign} command. For more information, see \textit{Unassigning Names right single (page 67)}. 
9 Basic Programming

You have used Maple interactively in the previous chapters, sequentially performing operations such as executing a single command. Because Maple has a complete programming language, you can also use sophisticated programming constructs.

In Maple, you can write programs called procedures, and save them in modules. These modules can be used and distributed in the same way as Maple packages.

**Important:** It is strongly recommended that you use the Worksheet mode and 1-D Math input when programming or using programming commands. Hence, all input in this chapter is entered as 1-D Math.

### 9.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Flow Control (page 289)</em> - Basic programming constructs: if-then statements and loops</td>
<td>- Conditional Execution <em>(if Statement)</em>&lt;br&gt;- Repetition <em>(for Statement)</em></td>
</tr>
<tr>
<td><em>Iterative Commands (page 297)</em> - Specialized, efficient iterative commands</td>
<td>- Creating a sequence&lt;br&gt;- Adding and Multiplying Expressions&lt;br&gt;- Selecting Expression Operands&lt;br&gt;- Mapping a Command over a Set or List&lt;br&gt;- Mapping a Binary Command over Two Lists or Vectors</td>
</tr>
<tr>
<td><em>Procedures (page 299)</em> - Maple programs</td>
<td>- Defining and Running Simple Procedures&lt;br&gt;- Procedures with Inputs&lt;br&gt;- Procedure Return Values&lt;br&gt;- Displaying Procedure Definitions&lt;br&gt;- Displaying Maple Library Procedure Definitions&lt;br&gt;- Modules</td>
</tr>
<tr>
<td><em>Programming in Documents (page 302)</em> - Display methods for Maple code</td>
<td>- Code Edit Region&lt;br&gt;- Startup Code&lt;br&gt;- Document Blocks</td>
</tr>
</tbody>
</table>

### 9.2 Flow Control

Two basic programming constructs in Maple are the *if* statement, which controls the conditional execution of statement sequences, and the *for* statement, which controls the repeated execution of a statement sequence (a loop).

**Conditional Execution (if Statement)**

You can specify that Maple perform an action only if a condition holds. You can also perform an action, from a set of many, depending on which conditions hold.

Using the *if* statement, you can execute one statement from a series of statements based on a boolean (*true*, *false*, or *FAIL*) condition. Maple tests each condition in order. When a condition is satisfied, Maple executes the corresponding statement, and then exits the *if* statement.

**Syntax**

The *if* statement has the following syntax.
The conditional expressions \( (\text{conditional_expression}_1, \text{conditional_expression}_2, \ldots) \) can be any boolean expression. You can construct boolean expressions using:

- Relational operators - \(<\), \(\leq\), \(=\), \(\geq\), \(>\), \(<>\)
- Logical operators - \(\text{and}\), \(\text{or}\), \(\text{xor}\), \(\text{implies}\), \(\text{not}\)
- Logical names - \(\text{true}\), \(\text{false}\), \(\text{FAIL}\)

The statement sequences \( (\text{statement_sequence}_1, \text{statement_sequence}_2, \ldots, \text{statement_sequence}_N) \) can be any sequence of Maple statements, including if statements.

The elif clauses are optional. You can specify any number of elif clauses.

The else clause is optional.

**Simple if Statements**

The simplest if statement has only one conditional expression.

\[
> \text{if conditional_expression} \text{ then}
\]
\[
\text{statement_sequence}
\]
\[
\text{end if;}
\]

If the conditional expression evaluates to \(\text{true}\), the sequence of statements is executed. Otherwise, Maple immediately exits the if statement.

For example:

\[
> x := 1173:
\]
\[
> \text{if not isprime}(x) \text{ then}
\]
\[
\text{ifactor}(x);
\]
\[
\text{end if;}
\]

\((3) (17) (23)\)

**else Clause**

In a simple if statement with an else clause, if the evaluation of the conditional expressions returns \(\text{false}\) or \(\text{FAIL}\), Maple executes the statement sequence in the else clause.

For example:

\[
> \text{if false then}
\]
\[
"\text{if statement}";
\]
\[
\text{else}
\]
\[
"\text{else statement}";
\]
\[
\text{end if;}
\]
"else statement"

**elif Clauses**

In an *if* statement with *elif* clauses, Maple evaluates the conditional expressions in order until one returns *true*. Maple executes the corresponding statement sequence, and then exits the *if* statement. If no evaluation returns *true*, Maple exits the *if* statement.

The keyword *elif* stands for *else if*.

```maple
> x := 11:
> if not(type(x, integer)) then
    printf("%a is not an integer.", x);
    elif x >= 10 then
        printf("%a is an integer with more than one digit.", x);
    elif x >= 0 then
        printf("%a is an integer with one digit.", x);
    end if;
11 is an integer with more than one digit.
```

**Order of elif Clauses:** An *elif* clause's statement sequence is executed only if the evaluation of all previous conditional expressions returns *false* or *FAIL*, and the evaluation of its conditional expression returns *true*. This means that changing the order of *elif* clauses may change the behavior of the *if* statement.

In the following *if* statement, the *elif* clauses are in the **wrong order**.

```maple
> if not(type(x, integer)) then
    printf("%a is not an integer.", x);
    elif x >= 10 then
        printf("%a is an integer with more than one digit.", x);
    elif x >= 0 then
        printf("%a is an integer with one digit.", x);
    else
        printf("%a is a negative integer.", x);
    end if;
11 is an integer with one digit.
```

**elif and else Clauses**

In an *if* statement with *elif* and *else* clauses, Maple evaluates the conditional expressions in order until one returns *true*. Maple executes the corresponding statement sequence, and then exits the *if* statement. If no evaluation returns *true*, Maple executes the statement sequence in the *else* clause.

```maple
> x := -12:
> if not(type(x, integer)) then
    printf("%a is not an integer.", x);
    elif x >= 10 then
        printf("%a is an integer with more than one digit.", x);
    elif x >= 0 then
        printf("%a is an integer with one digit.", x);
    else
        printf("%a is a negative integer.", x);
    end if;
-12 is a negative integer.
```

For more information on the *if* statement, refer to the *if* help page.
Repetition (for Statement)

Using repetition statements, you can repeatedly execute a statement sequence. You can repeat the statements in three ways.

- Until a counter variable value exceeds a limit (for/from loop)
- For each operand of an expression (for/in loop)
- Until a boolean condition does not hold (while loop or until loop)

**for/from Loop**

The for/from loop statement repeats a statement sequence until a counter variable value exceeds a limit.

**Syntax**

The for/from loop has the following syntax.

```maple
> for counter from initial by increment to final do
    statement_sequence
end do;
```

The behavior of the for/from loop is:

1. Assign the `initial` value to the name `counter`.
2. Compare the value of `counter` to the value of `final`. If the `counter` value exceeds the `final` value, exit the loop. (This is the loop bound test.)
3. Execute the `statement_sequence`.
4. Increment the `counter` value by the value of `increment`.
5. Repeat steps 2 to 4, until Maple exits the loop.

The from, by, and to clauses are optional and can be in any order between the for clause and the do keyword. Table 9.1 lists the default clause values.

**Table 9.1: Default Clause Values**

<table>
<thead>
<tr>
<th>Clause</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>from initial</td>
<td>1</td>
</tr>
<tr>
<td>by increment</td>
<td>1</td>
</tr>
<tr>
<td>to final</td>
<td>infinity (∞)</td>
</tr>
</tbody>
</table>

**Examples**

The following loop returns the square root of the integers 1 to 5 (inclusive).
for n to 5 do
    evalf(sqrt(n));
end do;

1.
1.414213562
1.732050808
2.
2.236067977

When the value of the counter variable \( n \) is strictly greater than 5, Maple exits the loop.

> n;

6

The previous loop is equivalent to the following for/from statement.

> for n from 1 by 1 to 5 do
    evalf(sqrt(n));
end do;

1.
1.414213562
1.732050808
2.
2.236067977

The by value can be negative. The loop repeats until the value of the counter variable is strictly less than the final value.

> for n from 10 by -1 to 3 do
    if isprime(n) then
        print(n);
    end if;
end do;

7
5
3

> n;

2

for/in Loop

The for/in loop statement repeats a statement sequence for each component (operand) of an expression, for example, the elements of a list.
Syntax

The for/in loop has the following syntax.

```plaintext
> for variable in expression do
    statement_sequence
    end do;
```

The for clause must appear first.

The behavior of the for/in loop is:

1. Assign the first operand of expression to the name variable.
2. Execute the statement_sequence.
3. Assign the next operand of expression to variable.
4. Repeat steps 2 and 3 for each operand in expression. If there are no more operands, exit the loop. (This is the loop bound test.)

Example

The following loop returns a floating-point approximation to the sin function at the angles (measured in degree) in the list L.

```plaintext
> L := [23.4, 87.2, 43.0, 99.7]:
> for i in L do
    evalf(sin(i*Pi/180));
    end do;
```

0.3971478907
0.9988061374
0.6819983602
0.9857034690

while Loop and until Loop

The while loop repeats a statement sequence until a boolean expression does not hold.

The until loop also repeats a statement sequence until a boolean expression does not hold, but it tests the terminating condition at the end of each iteration of the loop, instead of the beginning.

Syntax

The while loop has the following syntax.

```plaintext
> while conditional_expression do
    statement_sequence
    end do;
```

A while loop repeats until its boolean expression conditional_expression evaluates to false or FAIL. For more information on boolean expressions, see Conditional Execution (if Statement) (page 289).

The until loop has the following syntax.

```plaintext
> do
    statement_sequence
    until conditional_expression;
```
Note the difference in syntax: the until clause appears in place of end do

**Example**

Compare the following loops. In the first one, the terminating condition is met the first time it is tested, and the loop terminates immediately. In the second one, which uses the *until* clause, the body of the loop is performed before the condition is tested, and the loop is used.

\[
\begin{align*}
\text{a} & := 1; \\
\text{a} & := a+1; \\
\text{a} & := a+1; \\
\text{a} & := a+1;
\end{align*}
\]

\[
\begin{align*}
\text{while a mod 7 <>1 do} & \\
\text{end do:} & \\
\text{do} & \\
\text{until a mod 7=1:} & \\
\text{a} & ;
\end{align*}
\]

The following loop computes the digits of 87,234,9 in base 7 (in order of *increasing* significance).

\[
\begin{align*}
\text{x} & := 872349; \\
\text{irem(x, 7)}; & \\
\text{iquo(x, 7)}; & \\
\text{end do;}
\end{align*}
\]
To perform such conversions efficiently, use the `convert/base` command.

```maple
> convert(872349, base, 7);

[ 2, 0, 2, 6, 2, 0, 1 ]
```

For information on non-base 10 numbers, see Non-Base 10 Numbers (page 78).

**General Loop Statements**

You can include a `while` statement in a `for/from` or `for/in` loop.

The general `for/from` loop has the following syntax.

```maple
> for counter from initial by increment to final
   while conditional_expression do
     statement_sequence
   end do;
```

The general `for/in` loop has the following syntax.

```maple
> for variable in expression
   while conditional_expression do
     statement_sequence
   end do;
```

After testing the loop bound condition at the beginning of each iteration of the `for` loop, Maple evaluates `conditional_expression`.
• If \texttt{conditional_expression} evaluates to \texttt{false} or \texttt{FAIL}, Maple exits the loop.
• If \texttt{conditional_expression} evaluates to \texttt{true}, Maple executes \texttt{statement_sequence}.

The equivalent general until loops have the same form but with \texttt{end do} replaced with \texttt{until conditional_expression}.

\textbf{Infinite Loops}

You can construct a loop for which there is no exit condition, for example, a \texttt{while} loop in which the \texttt{conditional_expression} always evaluates to \texttt{true}. This is called an \textit{infinite loop}. Maple indefinitely executes an infinite loop unless it executes a \texttt{break}, \texttt{quit}, or \texttt{return} statement or you interrupt the computation using the interrupt icon in the toolbar (in worksheet versions). For more information, refer to the \texttt{break}, \texttt{quit}, \texttt{return}, and \texttt{interrupt} help pages.

\textbf{Additional Information}

For more information on the \texttt{for} statement and looping, refer to the \texttt{do} help page and the Loops section of the \textit{Maple Statements} chapter of the \textit{Maple Programming Guide}.

\section*{9.3 Iterative Commands}

Maple has commands that perform common selection and repetition operations. These commands are more efficient than similar algorithms implemented using library commands. \textbf{Table 9.2} lists the iterative commands.

\begin{table}[h]
\centering
\begin{tabular}{|l|l|}
\hline
\textbf{Command} & \textbf{Description} \\
\hline
\texttt{seq} & Create sequence \\
\texttt{add} & Compute numeric sum \\
\texttt{mul} & Compute numeric product \\
\texttt{select} & Return operands that satisfy a condition \\
\texttt{remove} & Return operands that do not satisfy a condition \\
\texttt{selectremove} & Return operands that satisfy a condition and separately return operands that do not satisfy a condition \\
\texttt{map} & Apply command to the operands of an expression \\
\texttt{zip} & Apply binary command to the operands of two lists or vectors \\
\hline
\end{tabular}
\end{table}

\textbf{Creating a Sequence}

The \texttt{seq} command creates a sequence of values by evaluating a specified expression over a range of index values or the operands of an expression. See \textbf{Table 9.3}.

\begin{table}[h]
\centering
\begin{tabular}{|l|l|}
\hline
\textbf{Calling Sequence Syntax} & \textbf{Examples} \\
\hline
\texttt{seq(expression, name = initial .. final);} & \texttt{\textgreater{} seq(exp(x), x=-2..0);} \\
& \texttt{\textgreater{} e\textsuperscript{2}, e\textsuperscript{-1}, 1} \\
\texttt{seq(expression, name in expression);} & \texttt{\textgreater{} seq(u, u in [Pi/4, Pi\textsuperscript{2}/2, 1/Pi]);} \\
& \texttt{\textgreater{} Pi/4, Pi\textsuperscript{2}/2, 1/Pi} \\
\hline
\end{tabular}
\end{table}

\textbf{Adding and Multiplying Expressions}

The \texttt{add} and \texttt{mul} commands add and multiply sequences of expressions over a range of index values or the operands of an expression. See \textbf{Table 9.4}.
Table 9.4: The add and mul Commands

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>add(expression, name = initial .. final);</td>
<td>&gt; add(exp(x), x = 2..4); [ e^2 + e^3 + e^4 ]</td>
</tr>
<tr>
<td>mul(expression, name = initial .. final);</td>
<td>&gt; mul(2*x, x = 1 .. 10); [ 3715891200 ]</td>
</tr>
<tr>
<td>add(expression, name in expression);</td>
<td>&gt; add(u, u in [Pi/4, Pi/2, Pi]); [ \frac{7}{4} \pi ]</td>
</tr>
<tr>
<td>mul(expression, name in expression);</td>
<td>&gt; mul(u, u in [Pi/4, Pi/2, Pi]); [ \frac{1}{8} \pi^3 ]</td>
</tr>
</tbody>
</table>

The endpoints of the index range (initial and final) in the add and mul calling sequence must evaluate to numeric constants. For information on symbolic sums and products, refer to the sum and product help pages.

### Selecting Expression Operands

The select, remove, and selectremove commands apply a boolean-valued procedure or command to the operands of an expression. For information on operands, refer to the op help page.

- The select command returns the operands for which the procedure or command returns true.
- The remove command returns the operands for which the procedure or command returns false or FAIL.
- The selectremove command returns two expressions of the same type as the input expression.
  - The first consists of the operands for which the procedure or command returns true.
  - The second consists of the operands for which the procedure or command returns false or FAIL.

The structure of the output is the same as the structure of the input. See Table 9.5.

For information on Maple procedures, see Procedures (page 299).

Table 9.5: The select, remove, and selectremove Commands

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>select(proc_cmd, expression);</td>
<td>&gt; select(issqr, {198331, 889249, 11751184, 9857934}); [ (889249, 11751184) ]</td>
</tr>
<tr>
<td>remove(proc_cmd, expression);</td>
<td>&gt; remove(var -&gt; degree(var) &gt; 3, 2<em>x^3</em>y - y^3*x + z); [ z ]</td>
</tr>
<tr>
<td>selectremove(proc_cmd, expression);</td>
<td>&gt; selectremove(x -&gt; evalb(x &gt; round(x)), [sin(0.), sin(1.), sin(3.)]); [ [0.141120081], [0., 0.8414709848] ]</td>
</tr>
</tbody>
</table>

For information on optional arguments to the selection commands, refer to the select help page.
Mapping a Command over a Set or List

The `map` command applies a name, procedure, or command to each element in a set or list. See Table 9.6.

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>map(name_proc_cmd, expression);</code></td>
<td><code>&gt; map(f, {a, b, c});</code></td>
</tr>
<tr>
<td></td>
<td><code>{f(a), f(b), f(c)}</code></td>
</tr>
<tr>
<td></td>
<td><code>&gt; map(u -&gt; int(cos(x), x = 0 .. u), [Pi/4, Pi/7, Pi/3.0]);</code></td>
</tr>
<tr>
<td></td>
<td>[ \frac{\sqrt{2}}{2}, \cos\left(\frac{5\pi}{14}\right), 0.8660254037 ]</td>
</tr>
</tbody>
</table>

An alternative to the `map` command is to apply a function elementwise, using ~. For more information ~, see Applying an Operation or Function to All Elements in a List, Set, Table, Array, Matrix, or Vector (page 283). For information on mapping over the operands of other expressions, optional arguments to the `map` command, and other mapping commands, refer to the `map` help page.

Mapping a Binary Command over Two Lists or Vectors

The `zip` command applies a name or binary procedure or command component-wise to two lists or vectors.

By default, the length of the returned object is that of the shorter list or vector. If you specify a value as the (optional) fourth argument, it is used as the value of the missing elements of the shorter list or vector. In this case, the length of the return value is that of the longer list or vector. See Table 9.7.

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>zip(proc_cmd, a, b);</code></td>
<td><code>&gt; zip(f, [i, j], [k, l]);</code></td>
</tr>
<tr>
<td><code>zip(proc_cmd, a, b, fill);</code></td>
<td><code>&gt; zip(AiryAi, [1, 2], [0], 1);</code></td>
</tr>
<tr>
<td></td>
<td>[ -\frac{3^{1/6} \Gamma\left(\frac{2}{3}\right)}{2 \pi}, Ai(1) ]</td>
</tr>
<tr>
<td></td>
<td>This is equivalent to [ \text{[AiryAi}(1, 0), \text{AiryAi}(2, 1)] ]</td>
</tr>
</tbody>
</table>

For more information on the `zip` command, refer to the `zip` help page.

Additional Information

For more information on looping commands, refer to the corresponding command help page.

9.4 Procedures

A Maple procedure is a program consisting of Maple statements. Using procedures, you can quickly execute the contained sequence of statements.
Defining and Running Simple Procedures

To define a procedure, enclose a sequence of statements between proc(...) and end proc statements. In general, you assign a procedure definition to a name.

The following procedure returns the square root of 2.

```maple
p := proc() sqrt(2); end proc;
```

Note: Maple returns the procedure definition.

To improve readability of procedures, it is recommended that you define a procedure using multiple lines, and indent the lines using space characters. To begin a new line (without evaluating the incomplete procedure definition), press Shift+Enter. When you have finished entering the procedure, press Enter to create the procedure.

For example:

```maple
p := proc()
    sqrt(2);
end proc:
```

To run the procedure p, enter its name followed by parentheses (( )).

```maple
p();
```

\[ \sqrt{2} \]

Procedures with Inputs

You can define a procedure that accepts user input. In the parentheses of the proc statement, specify the parameter names. For multiple parameters, separate the names with commas.

```maple
geometric_mean := proc(x, y)
    sqrt(x*y);
end proc:
```

When the user runs the procedure, the parameter names are replaced by the argument values.

```maple
geometric_mean(13, 17);
```

\[ \sqrt{221} \]

```maple
geometric_mean(13.5, 17.1);
```

15.19374871

For more information on writing procedures, including options and local and global variables, refer to the procedure help page.

Procedure Return Values

When you run a procedure, Maple returns only the last statement result value computed. Maple does not return the output for each statement in the procedure. It is irrelevant whether you use semicolons or colons as statement separators.

```maple
p := proc(a, b)
a + b;
a - b:
end proc:
```
Displaying Procedure Definitions

Unlike simple Maple objects, you cannot display the value of a procedure by entering its name.

> geometric_mean;

geometric_mean

You must evaluate the name of the procedure using the print (or eval) command.

> print(geometric_mean);

proc(x, y) sqrt(y*x) end proc

Displaying Maple Library Procedure Definitions

Maple procedure definitions are a valuable learning tool. To learn how to program in Maple, it is recommended that you examine the procedures available in the Maple library.

By default, the print command returns only the proc and end proc statements and (if present) the description fields of a Maple procedure.

> print(lcm);

proc(a, b) ... end proc

To display a Maple library procedure definition, first set the value of the interface verboseproc option to 2. Then re-execute the print calling sequence.

> interface('verboseproc' = 2):
> print(lcm);

proc(a, b)

    option remember, Copyright (c) 1990 by the University of Waterloo. All rights reserved;

    local q, t;

    if nargs = 0 then
        1
    elif nargs = 1 then
        t := expand(a); sign(t)*t
    elif 2 < nargs then
        foldl(procname, args)
    elif type(a, 'integer') and type(b, 'integer') then
        ilcm(a, b)
    else
        gcd(a, b, 'q'); q*b
    end if
end proc
Modules

Maple procedures associate a sequence of commands with a single command. The module, a more complex programming structure, allows you to associate related procedures and data.

A key feature of modules is that they export variables. This means that the variables are available outside the module in which they are created. Most Maple packages are implemented as modules. The package commands are exports of the module.

For more information on modules, refer to the module help page.

Objects

Objects take the idea of associating data and procedures beyond what modules provide. With objects, multiple instances of a class of objects can be created. Each individual object can have its own data, yet share other values and procedures with the entire class objects. A well implemented class of objects can be used in Maple as naturally as a built-in Maple type.

For more information on objects, refer to the object help page.

9.5 Programming in Documents

To write Maple code, you could simply open a Maple worksheet and start typing. However, if you want to create a readable document with the code interspersed or hidden, there are several options available: code edit regions and start up code. Both these features use a code editor which has features such as syntax highlighting and line numbers.

Code Edit Region

The code edit region allows you to program in one contained region, in a natural way. Features include the ability to press Enter for line breaking and indentation preservation. Figure 9.1 shows the expanded code edit region.

To insert a new code edit region into your worksheet:

• From the Insert menu, select Code Edit Region.

![Figure 9.1: Code Edit Region](image)

To execute the code within this region, click anywhere in this region, then click the Execute Selection icon (1) on the toolbar. (Alternatively, from the Evaluate menu, select Execute Code.)

You can hide the code in a code edit region by minimizing the region. To minimize, select View → Collapse Code Edit Region. When the region is minimized, an icon appears with the first line of the code written next to it. It is recommended that you make the first line a comment describing the program or programs contained in the region. See Figure 9.2.
Figure 9.2: Collapsed Code Edit Region

To re-execute the code in the region while it is collapsed, click this icon.

For more information, refer to the CodeEditRegion help page.

Startup Code

Startup code allows you to define commands and procedures that are executed each time the document is opened and after restart is called. This code is completely hidden to others reading the document. For example, use this region to define procedures that will be used throughout the document code but that would take up space and distract readers from the message of the document.

To enter startup code for a document:

1. From the Edit menu, select Startup Code. Alternatively, click the startup code icon in the toolbar.
2. Enter commands to be run each time the worksheet is opened or restart is called.
3. To check the syntax of the entered code while entering your Maple commands or before closing the editor, from the Edit menu, select Check Syntax Now.

Note: You can also check the Check Syntax Automatically option to enable continuous syntax checking. It is recommended that you check the syntax before saving so that your startup code does not prevent Maple from opening successfully.

4. To save the contents, from the File menu, select Save Code. Alternatively, click the save icon.

Figure 9.3: Startup Code Editor

For more information, refer to the startupcode help page.
9.6 Additional Information

The *Maple Programming Guide* provides an in-depth reference for programming in Maple. Topics include statements, data structures, procedures, packages, and debugging your code.

• Access via the help system. From the Table of Contents, select **Manuals>Programming Guide**.

The Programming Guide is also available as a PDF on the Maplesoft website.

[http://www.maplesoft.com/documentation_center](http://www.maplesoft.com/documentation_center)
10 Embedded Components and Maplets

These graphical components help you to create documents to use and share with colleagues or students, that interact with Maple code within the document without needing the reader to understand that Maple code. Other methods of interaction with Maple are described throughout this guide.

10.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Using Embedded Components (page 305) - Basic interacting with Maple documents containing embedded components | • Interacting with Components  
• Printing and Exporting |
| Creating Embedded Components (page 308) - Methods for creating embedded components that work together and with your document | • Inserting Components  
• Editing Components  
• Removing Components  
• Integrating into a Document |
| Using Maplets (page 314) - Methods for launching a Maplet | • Maplet File  
• Maple Document |
| Authoring Maplets (page 315) - Methods for authoring and saving a Maplet | • Simple Maplet  
• Maplet Builder  
• Maplets Package  
• Saving |

10.2 Using Embedded Components

Interacting

Embedded components allow readers to interact with Maple code through graphical components, rather than commands. They can be used alone, as with a button that you click to execute code, or together, such as a drop-down menu where you select an item, and a change takes place in a plot component.

Component Descriptions

Table 10.1: Embedded Component Descriptions

<table>
<thead>
<tr>
<th>Component Name and Description</th>
<th>Inserted Image</th>
</tr>
</thead>
<tbody>
<tr>
<td>Button - Click to perform an action; that is, execute code.</td>
<td><img src="image" alt="Button" /></td>
</tr>
<tr>
<td>Check Box - Select or de-select. Change the caption, and enter code to execute when the value changes.</td>
<td><img src="image" alt="CheckBox" /></td>
</tr>
<tr>
<td>Combo Box - Select one of the listed options from the drop-down menu. Change the items listed, and enter code to execute when the value changes.</td>
<td><img src="image" alt="ComboBox" /></td>
</tr>
<tr>
<td>Data Table - Link this embedded component to a Matrix, Vector, or Array in your worksheet.</td>
<td><img src="image" alt="DataTable" /></td>
</tr>
<tr>
<td>Component Name and Description</td>
<td>Inserted Image</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Dial - Select or display an integer or floating-point value. Change the display, and enter code to execute when the value changes.</td>
<td>![Dial Image]</td>
</tr>
<tr>
<td>Label - Display a label. The value can be updated based on code in the document or another embedded component.</td>
<td>![Label Image]</td>
</tr>
<tr>
<td>ListBox - Display a list of items. Change the items listed, and enter code to execute when an item is selected.</td>
<td>![ListBox Image]</td>
</tr>
<tr>
<td>Math Expression - Enter or display a mathematical expression. The value can be updated based on code in the document or another embedded component.</td>
<td>![Math Expression Image]</td>
</tr>
<tr>
<td>Meter - Select or display an integer or floating-point value. Change the display, and enter code to execute when the value changes.</td>
<td>![Meter Image]</td>
</tr>
<tr>
<td>Microphone Component - Capture sound from a recording device. Change setting options from properties, and enter code for start and stop recording actions.</td>
<td>![Microphone Image]</td>
</tr>
<tr>
<td>Plot - Display a 2-D or 3-D plot or animation. This plot or animation can be interacted with in the same way as other plots (see Plots and Animations (page 183)). The value can be updated based on code in the document or another embedded component. You can also enter code to be executed when the Click and Drag pointer is used to click or drag in the plot region.</td>
<td>![Plot Image]</td>
</tr>
<tr>
<td>RadioButton - Use with other radio buttons to select one in a group. Enter code to execute when the value changes.</td>
<td>![RadioButton Image]</td>
</tr>
<tr>
<td>Rotary Gauge - Select or display an integer or floating-point value. Change the display, and enter code to execute when the value changes.</td>
<td>![Rotary Gauge Image]</td>
</tr>
<tr>
<td>Slider - Select or display an integer or floating-point value. Change the display, and enter code to execute when the value changes.</td>
<td>![Slider Image]</td>
</tr>
<tr>
<td>TextArea - Enter or display plain text. The value can be updated based on code in the document or another embedded component, and you can enter code to execute when the value changes.</td>
<td>![TextArea Image]</td>
</tr>
<tr>
<td>Toggle Button - Select or display one of two options. Change the images displayed, and enter to code to execute when the value changes.</td>
<td>![Toggle Button Image]</td>
</tr>
</tbody>
</table>
### Component Name and Description

**Video Player** - Play a video. Enter code that specifies an action to perform when the video player reaches a marker during playback.

**Volume Gauge** - Select or display an integer or floating-point value. Change the display, and enter code to execute when the value changes.

**Shortcut Component** - Use to hyperlink various types of content, including help pages, MapleCloud documents, and URLs.

**Speaker Component** - Play a sound. Customize component by modifying setting options under properties.

### Example 1 - Using Embedded Components

This example demonstrates several components working together to perform a task. The user inputs an expression, which is plotted when the button is clicked. Plot options are controlled by text areas, a combo box, a math expression, and radio buttons.
Printing and Exporting a Document with Embedded Components

Printing: When printing a document, embedded components are rendered as they appear on screen.

Exporting: Exporting a document with embedded components to other formats produces the following results.
- HTML format - components are exported as .gif files.
- RTF format - components are rendered as bitmap images in the .rtf document.
- LaTeX - components are exported as .eps files.
- PDF - components are rendered as static images.

10.3 Creating Embedded Components

Embedded Components are graphical components that you can add to your document. They provide interactive access to Maple code without requiring the user to know Maple commands, and include buttons, sliders, math and text input areas, plot display, and shortcut components.

Inserting Components

The graphical interface components can be inserted by using the Components palette (Figure 10.1) or by cutting/copying and pasting existing components to another area of the document. Although copied components have most of the same characteristics, they are distinct.

If the Components palette is not visible, see Palettes (page 15) for instructions on viewing palettes.
Editing Component Properties: General Process

To edit properties of components embedded in the document:

1. Click the component to display the context panel.
2. In the context panel, enter values and contents in the fields as necessary.
3. To define an action, such as an action to perform when the slider is moved, click the component, and then select EditValueChangedCode... from the Context Panel. A Code Edit Region opens allowing you to enter Maple code that is executed when the event occurs. For details, refer to the DocumentTools help page.

Note: You can also edit embedded component properties and actions that are performed when a value changes by using Maple worksheet Edit menu options, Edit > Component Properties, and Edit > Component Code, respectively. For more information on options available in the Edit menu, see Edit menu options.

Removing Graphical Interface Components

You can remove an embedded component by:

- Using the Delete key
- Using the Backspace key
- Placing the cursor at the component and selecting from the document menu, Edit→Delete Element

Integrating Components into a Document

Use embedded components to display information from calculations, obtain input from a reader, or perform calculations at the click of a button, all without your readers having an understanding of Maple commands. They can be entered in any part of a Maple document, including a document block or table. For details on each component, see its help page.
This simple example inserts a slider with a label that indicates the current value of the slider.

1. Place the cursor in the location where the embedded component is to be inserted.
2. In the **Components** palette, click the **Slider** item. A slider is inserted into the document.
3. In the **Components** palette, click the **Label** item. A label is inserted next to the slider.

4. Click the label component. The **Label** context panel opens. See **Figure 10.2**.

5. Name the component **SliderLabel** and click **OK**.
6. Click the slider component. The **Slider** context panel opens. See **Figure 10.3**.
7. Name the component **Slider1**.

8. Enter the value at the lowest position as 0 and the highest as 100.

9. Enter major tick marks at 20 and minor tick marks at 10.

10. Make sure that the **Continuous Update On Drag** check box is selected.

11. Click **OK**.

12. To define an action, click the slider component, and then select **Edit Value Changed Code...** from the context panel. This launches a dialog that allows you to program the action of displaying the slider value in the label component. The **use...in/end use;** statement allows you to specify routines using the short form of accessing a package command without invoking the package. For details on this command, refer to the **use** help page.

13. Before the **end use;** statement at the bottom of the dialog, enter the following command.

   ```plaintext
   Do(%SliderLabel(caption)=%Slider0(value));
   ```

14. Save the code, and exit the code editor.

As you move the arrow indicator, the value from the slider populates the **Label** caption field.

For details on this command, refer to the **DocumentTools[Do]** help page.

**Example 2 - Creating Embedded Components**

In chapter 7 (see **Embedded Components (page 257)**), you created a document that included embedded components, imported from a task template. Here, we re-create that configuration of components. This example takes two parameters, \( a \) and \( b \), as inputs, then plots the function \( y = b x + a \) and calculates \( \frac{a}{b} \).

1. **Create the components.**

   The table layout is best done after the components are finished, in case the configuration of the components changes as you are working.

   Create two **DialComponents** to set the parameters, \( a \) and \( b \), one **RotaryGaugeComponent** to display the result, \( \frac{a}{b} \), one **PlotComponent** to display the plot, and one **MathContainerComponent** to display the function. Note that you do not have to use the dial and rotary gauge components here, you can also use the slider instead.
2. **Edit the display of the components.**

Open the context panel for the first **DialComponent**, and notice that it already has a name. This name is used to reference the component from other components, and is unique. Change the display of each of the components as follows:

- **Dial0**: no changes.
- **Dial1**: change the **Value at Lowest Position** to 1, the **Value at Highest Position** to 10, the **Spacing of Major Tick Marks** to 1, and the **Spacing of Minor Tick Marks** to 1.
- **RotaryGauge0**: change the **Value at Highest Position** to 40, the **Spacing of Major Tick Marks** to 5, and the **Spacing of Minor Tick Marks** to 1.
- **Plot0**: no changes.
- **MathContainer0**: change the **Width in Pixels** to 200, and the **Height in Pixels** to 45.

Note the names of all of the components, and close each dialog before moving on.

3. **Create actions for the components.**

Components can perform actions when their values are changed, so the code to execute needs to be in the dials. That way, whenever one of them is changed, the other components are updated to reflect that change.

The following Maple commands retrieve the values of the parameters and display them in the other three components:

```
> parameter1:=Do(%Dial0):
> parameter2:=Do(%Dial1):
```
4. Test the actions.

To test these commands, first load the DocumentTools package with the following command.

```maple
> with(DocumentTools):
```

After loading the package, execute the commands in the document, and verify that the components you inserted are updated: the gauge should change to the computed value, a plot should appear in the plot component, and the function should display in the math container.

5. Troubleshooting.

The first Do command gives an error, because the second parameter is 0. One way to avoid this problem is to change the range of the second dial. In the Component Properties dialog for the second DialComponent, change the Value at Lowest Position from 0 to 1. Alternatively, you could change the code to compensate, with an if statement.

6. Copy the actions to the components.

After the commands work as expected, you can copy them into the components.

- Click the first DialComponent and select Edit Value Changed Code from the context panel. Copy and paste the commands into the space between the use statements.

![DialComponent Action Code Editor](image)

Figure 10.5: DialComponent Action Code Editor

- Save the code, and exit the code editor.

- Do the same for the second DialComponent. Now, moving either dial will update the rotary gauge, plot, and formula displayed in the math component.
7. Create the layout for the components.

Create a table, and then cut and paste the components into it, along with explanatory text. Important: you must cut, not copy, the components, or their names will be changed to avoid duplication. For information on creating and modifying tables, refer to Tables (page 239).

<table>
<thead>
<tr>
<th>Parameters: $a$ and $b$</th>
<th>Plot Window</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the Dials to set parameters</td>
<td>$y$</td>
</tr>
<tr>
<td>Parameter 1: $a$</td>
<td>Parameter 2: $b$</td>
</tr>
<tr>
<td><img src="image1.png" alt="Dial 1" /></td>
<td><img src="image2.png" alt="Dial 2" /></td>
</tr>
<tr>
<td><img src="image3.png" alt="Result: $\frac{a}{b}$" /></td>
<td>Plot of $y = 7x + 89$</td>
</tr>
</tbody>
</table>

### 10.4 Using Maplets

A Maplet is a popup graphical user interface that provides interactive access to the Maple engine through buttons, text regions, slider bars, and other visual interfaces. You can create your own Maplets, and you can take advantage of the built-in Maplets that cover numerous academic and specialized topics. Built-in Maplets include some assistants and tutors, such as the ODE Analyzer. For more information on this assistant, see Ordinary Differential Equations (ODEs) (page 87).

Maplet applications are launched by executing Maplet code. Maplet code can be saved in a Maplet (.maplet) file or Maple document (.mw).

**Maplet File**

**To launch a Maplet application saved as a Maplet file:**

- In Windows, double-click the file from a Windows file browser.
- In UNIX and on Macintosh, use the command-line interface. At the command-line, enter `maple -q <maplet_filename>`.

**To view and edit the Maplet code contained within the .maplet file:**

1. Start Maple.
2. From the **File** menu, select **Open**. Maple displays the **Open** dialog.
3. In the **Files of Type** drop-down list, select **.maplet**.
4. Navigate to the location of the **.maplet** file and select the file.
5. Click **Open**.

**Maple Document**

To launch a Maplet application for which the Maple code is contained in a Maple document, you need to execute the Maplet code. To display the Maplet application, you must use the `Maplets[Display]` command. **Note:** The Maplet code may be quite large if the Maplet application is complex. In this case, execute the document to ensure user-defined procedures that are referenced in the Maplet application are also defined.

**Typical procedure:**
1. If present, evaluate user-defined procedures.

   \[
   \text{Myproc} := \text{proc}\ldots
   \]


   ```maple
   with( Maplets[Elements] );
   ```

3. Evaluate the Maplet definition.

   ```maple
   \text{Maplet}\_\text{name} := \text{Maplet}(\text{Maplet}\_\text{definition});
   ```

4. Display the Maplet application.

   ```maple
   Maplets[Display](\text{Maplet}\_\text{name});
   ```

**Important:** When a Maplet application is running, you cannot interact with the Maple document.

### 10.5 Authoring Maplets

To author Maplets, you can use the **Maplet Builder** (GUI-based) or the **Maplets** package (syntax-based). The **Maplet Builder** allows you to drag and drop buttons, sliders, text regions, and other elements to define the Maplet application and set the element properties to perform an action on selection or update of the element. The **Maplet Builder** is designed to create simple Maplets. The **Maplets** package offers more capabilities, control, and options when designing complicated Maplet applications.

Designing a Maplet application is similar to constructing a house. When building a house, you first construct the skeletal structure (that is, foundation, floors, and walls) and then proceed to add the windows and doors. Constructing a Maplet is no different. First define the rows and columns of the Maplet application and then proceed to add the body elements (such as buttons, text fields, and plot regions).

### Simple Maplet

A Maplet application can be defined using the commands in the `Maplets[Elements]` package and then launched using the `Maplets[Display]` command. The following commands define and run a very simple Maplet application that contains the text string "Hello World".

```maple
> with(Maplets[Elements]):
> MySimpleMaplet := Maplet(["Hello World"]) :
> Maplets[Display](MySimpleMaplet):
```

![Maplet](image)

**Figure 10.6: A Simple Maplet**
Maplet Builder

To start the Maplet Builder:

- From the Tools menu, select Assistants → Maplet Builder.

![Maplet Builder Interface](image)

Figure 10.7: Maplet Builder Interface

The Maplet Builder is divided into four different panes.

- The Palette pane displays palettes, which contain Maplet elements, organized by category. For a description of the elements, see the MapletBuilder/Palette help page. The Body palette contains the most popular elements.
  
- The Layout pane displays the visual elements of the Maplet.
  
- The Command pane displays the commands and corresponding actions defined in the Maplet.
  
- The Properties pane displays the properties of an instance of a defined element in the Maplet.

Example 3 - Design a Maplet Using the Maplet Builder

In this example, shown in Figure 10.8, the Maplet user enters a function and plots the result.
Define the number of rows in the Maplet:
1. In the Properties pane:
   a. In the drop-down list, select BoxColumn1.
   b. Change the numrows field to 2.

Add a plot region to row 1:
2. From the Body palette, drag the Plotter element to the first row in the Layout pane.
<table>
<thead>
<tr>
<th>Action</th>
<th>Result in MapletBuilder</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Add columns to row 2:</strong></td>
<td><img src="image" alt="Result in MapletBuilder" /></td>
</tr>
<tr>
<td>3. In the <strong>Properties</strong> pane:</td>
<td></td>
</tr>
<tr>
<td>a. In the drop-down list, select <strong>BoxRow2</strong>.</td>
<td></td>
</tr>
<tr>
<td>b. Change the <strong>numcolumns</strong> field to 3.</td>
<td></td>
</tr>
<tr>
<td><strong>Add a label to row 2:</strong></td>
<td><img src="image" alt="Result in MapletBuilder" /></td>
</tr>
<tr>
<td>4. From the <strong>Body</strong> palette, drag the <strong>Label</strong> element to the left column in the <strong>Layout</strong> pane.</td>
<td></td>
</tr>
<tr>
<td>5. In the <strong>Properties</strong> pane:</td>
<td></td>
</tr>
<tr>
<td>a. In the drop-down list, select <strong>Label1</strong>.</td>
<td></td>
</tr>
<tr>
<td>b. Change the caption field to <strong>Enter a function of x</strong>.</td>
<td></td>
</tr>
<tr>
<td><strong>Add a text region to row 2:</strong></td>
<td><img src="image" alt="Result in MapletBuilder" /></td>
</tr>
<tr>
<td>6. From the <strong>Body</strong> palette, drag the <strong>TextField</strong> element to the middle column. The <strong>TextField</strong> element allows the Maplet user to enter input that can be retrieved in an action.</td>
<td></td>
</tr>
<tr>
<td>7. If necessary, resize the Maplet Builder to display the entire <strong>Layout</strong> pane.</td>
<td></td>
</tr>
<tr>
<td><strong>Add a button to row 2:</strong></td>
<td><img src="image" alt="Result in MapletBuilder" /></td>
</tr>
<tr>
<td>8. From the <strong>Body</strong> palette, drag the <strong>Button</strong> element to the right column in the <strong>Layout</strong> pane.</td>
<td></td>
</tr>
<tr>
<td>9. In the <strong>Properties</strong> pane:</td>
<td></td>
</tr>
<tr>
<td>a. In the drop-down list, select <strong>Button1</strong>.</td>
<td></td>
</tr>
<tr>
<td>b. Change the <strong>caption</strong> field to <strong>Plot</strong>.</td>
<td></td>
</tr>
<tr>
<td>c. In the <strong>onclick</strong> property drop-down list, select <strong>&lt;Evaluate&gt;</strong>.</td>
<td></td>
</tr>
</tbody>
</table>
10. In the Evaluate Expression dialog that displays, the Target drop-down list contains the defined elements to which you can send information, in this case, Plotter1 and TextField1. The List group box, located below the Expression group box, displays the defined elements to which you can retrieve information, in this case, TextField1.

   a. In the Target drop-down list, select Plotter1.

   b. In the Command Form tab, enter plot(TextField1, x=-10..10) in the Expression group box. (Note: Do not include a semicolon (;) at the end of the plot command.) You can also double-click TextField1 in the List group box to insert this element in the command syntax.

   c. Click Ok.

Run the Maplet:

11. From the File menu, select Run. You are prompted to save the Maplet. Maplets created with the Maplet Builder are saved as .maplet files.

12. Click Yes and navigate to a location to save this Maplet.

For further information on the Maplet Builder, see the MapletBuilder help page. For more examples of designing Maplets using the Maplet Builder, see examples/MapletBuilder.

Maplets Package

When designing a complicated Maplet, the Maplets package offers greater control. The Maplets[Elements] subpackage contains the elements available when designing a Maplet application. After you define the Maplet, use the Maplets[Display] command to launch the Maplet.

For more information on the Maplets package, refer to the MapletsPackage help page. For more examples of designing Maplets using the Maplets package, see the Maplets/Roadmap help page.

Example 4 - Design a Maplet Using the Maplets Package

To introduce the structure of designing Maplets using the Maplets package, this example illustrates the equivalent syntax for the Example 3 - Design a Maplet Using the Maplet Builder (page 316).  

Load the Maplets[Elements] package.

> with(Maplets[Elements]):

Define the Maplet application. To suppress the display of the data structure associated with the Maplet application, end the definition with a colon.

> PlottingMaplet := Maplet(
  BoxLayout(
    BoxColumn(
      # First Box Row
      BoxRow(
        # Define a Plot region
        Plotter('reference' = Plotter1)
      )
    )
  )
)
# Second Box Row
BoxRow(
    # Define a Label
    Label("Enter a function of x "),
    # Define a Text Field
    TextField('reference' = TextField1),
    # Define a Button
    Button(caption="Plot", Evaluate(value = 'plot(TextField1, x = -10..10)', 'target' = Plotter1))
    # End of second Box Row
)
# End of BoxColumn
)
# End of BoxLayout
)
# End of Maplet
):

Launch the Maplet.

> Maplets[Display](PlottingMaplet);

For further examples using both the MapletBuilder and Maplets package commands, see the Maplets example worksheets. For a listing, refer to the examples/index help page.

**Saving**

When saving a Maplet, you can save the document as an .mw file or you can export the document as a .maplet file.

**Maple Document**

To save the Maplet code as an .mw file:

1. From the File menu, select Save.
2. Navigate to the save location.
3. Enter a filename.
4. Click Save.

If the document contains only Maplet code, it is recommended that you export the document as a .maplet file.

**Maplet File**

To export the Maplet code as a .maplet file:

1. From the File menu, select Export As.
2. In the Files of Type drop-down list, select Maplet.
3. Navigate to the export location.
4. Enter the filename.
5. Click Save.
11 Input, Output, and Interacting with Other Products

11.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Writing to Files (page 321) - Saving to Maple file formats | • Saving Data to a File  
• Saving Expressions to a File |
| Reading from Files (page 323) - Opening Maple files | • Reading Data from a File  
• Reading Expressions from a File |
| Exporting to Other Formats (page 325) - Exporting documents in file formats supported by other software | • Exporting Documents  
• MapleNet |
| Connectivity (page 327) - Using Maple with other programming languages and software | • Translating Maple Code to Other Programming Languages  
• Accessing External Products from Maple  
• Accessing Maple from External Products  
• Sharing and Storing Maple Worksheet Content with the MapleCloudTM |

11.2 Writing to Files

Maple supports file formats in addition to the standard .mw file format.

After using Maple to perform a computation, you can save the results to a file for later processing with Maple or another program.

**Note:** Make sure you have right access to the directory in order to execute the example in the following subsections.

### Saving Data to a File

If the result of a Maple calculation is a long list or a large array of numbers, you can convert it to Matrix form and write the numbers to a file using the `ExportMatrix` command. This command writes columns of numerical data to a file, allowing you to import the numbers into another program. To convert a list or a list of lists to a Matrix, use the `Matrix` constructor. For more information, refer to the `Matrix` help page.

```maple
> L := [-81, -98, -76, -4, 29] 
  [-38, -77, -72, 27, 44] 
  [-18, 57, -2, 8, 92] 
  [87, 27, -32, 69, -31] 
  [33, -93, -74, 99, 67] 

> ExportMatrix("matrixdata.txt", L) : 
```

If the data is a Vector or any object that can be converted to type Vector, use the `ExportVector` command. To convert lists to Vectors, use the `Vector` constructor. For more information, refer to the `Vector` help page.
You can extend these routines to write more complicated data, such as complex numbers or symbolic expressions. For more information, refer to the \texttt{ExportMatrix} and \texttt{ExportVector} help pages.

For more information on matrices and vectors, see \textit{Linear Algebra} (page 116).

### Saving Expressions to a File

If you construct a complicated expression or procedure, you can save them for future use in Maple. If you save the expression or procedure in the Maple internal format, Maple can retrieve it more efficiently than from a document. Use the \texttt{save} command to write the expression to a .\texttt{m} file. For more information on Maple internal file formats, refer to the \texttt{file} help page.

In this example, small expressions are used. In practice, Maple supports expressions with thousands of terms.

\begin{align}
> \text{expr} & := \text{qbinomial}(10, 4) \\
\text{expr} & := \frac{(1 - q^7) (1 - q^6) (1 - q^5) (1 - q^4)}{(1 - q) (1 - q^2) (1 - q^3) (1 - q^5)} \quad (11.3)
\end{align}

\begin{align}
> \text{nexpr} & := \text{normal}(\text{expr}) \\
\text{nexpr} & := (q^6 + q^5 + q^4 + q^3 + q^2 + q + 1) (q^4 + 1) (q^6 + q^3 + 1) (q^6 + q^6 + q^4 + q^2 + 1) \quad (11.4)
\end{align}

You can save these expressions to the file \texttt{qbinom.m}.

\begin{align}
> \text{save} \text{qbinomial, expr, nexpr, "qbinom.m"}
\end{align}

Clear the memory using the \texttt{restart} command and retrieve the expressions using the \texttt{read} command.

\begin{align}
> \text{restart}
\end{align}

\begin{align}
> \text{read "qbinom.m"}
\end{align}
For more information on writing to files, refer to the save help page.

**Saving Data as Part of a Workbook**

You can save all files related to a common Maple project as a workbook (.maple) file. Saving your data files and worksheets (or documents) as a workbook allows you to use this saved data across all .mw file inside your workbook.

### 11.3 Reading from Files

The most common reason for reading files is to load data, for example, data generated in an experiment. You can store data in a text file, and then read it into Maple.

**Reading Data from a File**

**Import Data Assistant**

If you generate data outside Maple, you can read it into Maple for further manipulation. This data can be an image, a sound file, or columns of numbers in a text file. You can easily import this external data into Maple using the Import Data Assistant, where the supported file formats include files of type Excel®, MATLAB®, Image, Audio, Matrix Market, and Delimited.

**To launch the Import Data Assistant:**

1. From the Tools menu, select Assistants, and then Import Data.
2. A dialog window appears where you can navigate to your data file. Select the file that you want to import data from, and then select the file type before clicking Next.
3. From the main window, you can preview the selected file and choose from the applicable options based on the format of the file read in before importing the data into Maple. See Figure 11.1 for an example.

![Data Import Assistant](image)

**Figure 11.1: Import Data Assistant**

\[ expr \]

\[
\begin{align*}
(1 - q^7) (1 - q^6) (1 - q^5) (1 - q^{10}) \\
(1 - q) (1 - q^2) (1 - q^3) (1 - q^4)
\end{align*}
\]  

(11.5)
**ImportMatrix Command**

The **Import Data Assistant** provides a graphical interface to the **ImportMatrix** command. For more information, including options not available in the assistant, refer to the **ImportMatrix** help page.

**Reading Expressions from a File**

You can write Maple programs in a text file using a text editor, and then import the file into Maple. You can paste the commands from the text file into your document or you can use the **read** command.

When you read a file with the **read** command, Maple treats each line in the file as a command. Maple executes the commands and displays the results in your document but it does not, by default, insert the commands from the file in your document.

For example, the file **ks.txt** contains the following Maple commands.

\[
S:= n \rightarrow \sum_{\beta=1}^{n} \text{binomial}(n, \beta) \left( \frac{(2\beta)!}{2^\beta} - \beta! \beta \right)
\]

\[
S(19);
\]

Note that the file should not contain prompts (\texttt{>}) at the start of lines.

When you read the file, Maple displays the results but not the commands.

\[
S := n \rightarrow \sum_{\beta=1}^{n} \text{binomial}(n, \beta) \left( \frac{(2\beta)!}{2^\beta} - \beta! \beta \right)
\]

\[
102493736166664598071114328769317982974
\] (11.6)

\[
> \text{filename} := \text{cat}(\text{kernelopts(datadir)}, \text{kernelopts(dirsep)}, "ks", \text{kernelopts(dirsep)}, "ks.txt")
\]

\[
> \text{read} \ \text{filename}
\]

\[
S := n \rightarrow \sum_{\beta=1}^{n} \text{binomial}(n, \beta) \left( \frac{(2\beta)!}{2^\beta} - \beta! \beta \right)
\]

\[
102493736166664598071114328769317982974
\] (11.7)

If you set the **interface echo** option to 2, Maple inserts the commands from the file into your document.

\[
> \text{interface}(\text{echo} = 2) :
\]

\[
\text{read} \ \text{filename}
\]

\[
S := n \rightarrow \sum_{\beta=1}^{n} \text{binomial}(n, \beta) \left( \frac{(2\beta)!}{2^\beta} - \beta! \beta \right)
\]

\[
S(19);
\]

\[
102493736166664598071114328769317982974
\] (11.8)

For more information, refer to the **read** and **interface** help pages.
Reading Data From Workbook Attachments

Data stored in a workbook in the form of an attachment, can be accessed easily using the workbook URI. For information on workbook attachments, see worksheet,workbook,attachFiles. For information on the workbook URI format, see worksheet,workbook,uri.

11.4 Exporting to Other Formats

Exporting Documents

You can save your documents by selecting Save or Save As from the File menu. By selecting Export As from the File menu, you can also export a document in the following formats: HTML, LaTeX, Maple input, Maplet application, Maple text, plain text, PDF, and Rich Text Format. This allows you to access your work outside Maple.

HTML

The .html file that Maple generates can be loaded into any HTML browser. Exported mathematical content can be displayed in one of two formats, GIF or MathML 2.0, and is saved in a separate folder. MathML is the Internet standard, sanctioned by the World Wide Web Consortium (W3C), for the communication of structured mathematical formulae between applications. For more information about MathML, refer to the MathML help page.

Maple documents that are exported to HTML translate into multiple documents when using frames. If the frames feature is not selected, Maple creates only one page that contains the document contents.

LaTeX

The .tex file generated by Maple is ready for processing by LaTeX. All distributions of Maple include the necessary style files. By default, the LaTeX style files are set for printing the .tex file using the dvips printer driver. You can change this behavior by specifying an option to the \usepackage LaTeX command in the preamble of your .tex file. For more information, refer to the exporttoLaTeX help page.

Maple Input

You can export a Maple document as Maple input so that it can be loaded using the Maple Command-line version.

Important: When exporting a document as Maple input for use in Command-line Maple, your document must contain explicit semicolons in 1-D Math input. If not, the exported .mpl file does not contain semicolons, and Command-line Maple generates errors.

Maplet Application

The Export as Maplet facility saves a Maple document as a .maplet file, so that you can run it using the command-line interface or the MapletViewer. The MapletViewer is an executable program that can launch saved Maplet applications. It displays and runs Maplet applications independently of the Maple Worksheet interface.

Important: When exporting a document as a Maplet Application for use in Command-line Maple or the MapletViewer, your document must contain explicit semicolons. If not, the exported .maplet file does not contain semicolons, and Command-line Maple and the MapletViewer generates errors.

Maple Text

Maple text is marked text that retains the distinction between text, Maple input, and Maple output. Thus, you can export a document as Maple text, send the text file by email, and the recipient can import the Maple text into a Maple session and regenerate the computations in the original document.
PDF

Export a Maple document to a Portable Document Format (PDF) file so that you can open the file in a reader such as Adobe® Acrobat®. The PDF document is formatted as it would appear when the Maple worksheet is printed using the active printer settings.

**Note:** Images, plots, and embedded components may be resized in the PDF file.

Plain Text

Export a Maple document as plain text so that you can open the text file in a word processor.

Rich Text Format (RTF)

Export a Maple document to a rich text format file so that you can open and edit the file in a word processor.

**Note:** The generated .rtf format is compatible with Microsoft Word and Microsoft WordPad only.

Summary of Translation

Table 11.1: Summary of Content Translation When Exporting to Different Formats

<table>
<thead>
<tr>
<th>Content</th>
<th>HTML</th>
<th>LaTeX</th>
<th>Maple Input</th>
<th>Maple Application</th>
<th>Maple Text</th>
<th>Plain Text</th>
<th>RTF Format</th>
<th>PDF Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Preceded by #</td>
<td>Preceded by #</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Maintained</td>
</tr>
<tr>
<td>1-D Math</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Preceded by #</td>
<td>Preceded by #</td>
<td>Static image</td>
<td>Static image</td>
</tr>
<tr>
<td>2-D Math GIF or MathML</td>
<td>GIF or MathML</td>
<td>LaTeX</td>
<td>1-D Math (if possible)</td>
<td>1-D Math (if possible)</td>
<td>1-D Math or \texttt{character-based} typesetting</td>
<td>1-D Math or \texttt{character-based} typesetting</td>
<td>Static image</td>
<td>Either text or shapes depending on option selected</td>
</tr>
<tr>
<td>Plot</td>
<td>GIF</td>
<td>Postscript file</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Static image</td>
<td>Static image</td>
</tr>
<tr>
<td>Animation Animated GIF</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Static image</td>
</tr>
<tr>
<td>Hidden content</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
</tr>
<tr>
<td>Manually inserted page break</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>RTF page break object</td>
<td>Maintained</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>Links to help pages become plain text. Links to documents are renamed and converted to HTML links</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
</tr>
<tr>
<td>Embedded image or sketch output</td>
<td>GIF</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Static image</td>
<td>Static image</td>
<td>Static image</td>
</tr>
<tr>
<td>Spreadsheet</td>
<td>HTML table</td>
<td>LaTeX tables</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>RTF table</td>
<td>Static image</td>
</tr>
</tbody>
</table>
MapleNet

Overview of MapleNet

Using MapleNet, you can deploy Maple content on the web. Powered by the Maple computation engine, MapleNet allows you to embed dynamic formulas, models, and diagrams as live content in webpages. The MapleNet software is not included with the Maple software. For more information on MapleNet, visit [http://www.maplesoft.com/maplenet](http://www.maplesoft.com/maplenet).

MapleNet Documents and Maplets

After you upload your Maple document to the MapleNet server, it can be accessed by anyone in the world using a web browser. Even if viewers do not have a copy of Maple installed, they can view documents and Maplets, manipulate 3-D plots, and execute code at the click of a button.

Custom Java Applets and JavaServer Pages™ Technology

MapleNet provides a programming interface to the Maple math engine so commands can be executed from a Java applet or using JavaServer Pages™ technology. Embed MapleNet into your web application, and let Maple handle the math and visualization.

11.5 Connectivity

Translating Maple Code To Other Programming Languages

Code Generation

The CodeGeneration package is a collection of commands and subpackages that enable the translation of Maple code to other programming languages. Languages currently supported include: C, C#, Fortran 77, Java, MATLAB®, Visual Basic, Perl, and Python.

For details on Code Generation, refer to the CodeGeneration help page.

Accessing External Products from Maple

External Calling

External calling allows you to use compiled C, C#, Fortran 77, or Java code in Maple. Functions written in these languages can be linked and used as if they were Maple procedures. With external calling you can use pre-written optimized algorithms without the need to translate them into Maple commands. Access to the NAG library routines and other numerical algorithms is built into Maple using the external calling mechanism.

External calling can also be applied to functions other than numerical algorithms. Routines exist that accomplish a variety of non-mathematical tasks. You can use these routines in Maple to extend its functionality. For example, you can link to controlled hardware via a serial port or interface with another program. The Database package uses external calling to allow you to query, create, and update databases in Maple. For more information, refer to the Database help page.

For more information on using external calling, refer to the ExternalCalling help page.
Mathematica Translator

The MmaTranslator package provides translation tools for converting Mathematica® expressions, command operations, and notebooks to Maple. The package can translate Mathematica input to Maple input and Mathematica notebooks to Maple documents. The Mma subpackage contains commands that provide translation for Mathematica commands when no equivalent Maple command exists. In most cases, the command achieves the translation through minor manipulations of the input and output of similar Maple commands.

Note: The MmaTranslator package does not convert Mathematica programs.

There is a Maplet interface to the MmaTranslator package. For more information, refer to the MmaToMaple help page.

Matlab Package

The Matlab package enables you to translate MATLAB® code to Maple, as well as call selected MATLAB® functions from a Maple session, provided you have MATLAB® installed on your system.

For more information, refer to the Matlab help page.

Accessing Maple from External Products

Microsoft Excel Add-In

Maple is available as an add-in to Microsoft Excel. This add-in is supported for Excel 2019 and Excel 2016 for Windows, and provides the following features.

- Access to Maple commands from Excel
- Ability to copy and paste between Maple and Excel
- Access to a subset of the Maple help pages
- Maple Function Wizard to step you through the creation of a Maple function call

To enable the Maple Excel Add-in:

1. In Excel, click the File menu and select Options.
2. Click Add-ins.
3. In the Manage box select Excel Add-ins, and then Go.
4. Navigate to the Excel subdirectory of your Maple installation and select the file:
   - WMIMPLEX64.xla (that is, select $MAPLE/Excel/WMIMPLEX64.xla), and click OK.
5. Select the Maple Excel Add-in check box.
6. Click OK.

For further details on enabling the Maple Excel Add-in, refer to the Excel help page.

For information on using this add-in, refer to the Using Maple in Excel help file within Excel.

To view this help file:

1. Enable the add-in.
2. From the Add-ins tab, view the Maple toolbar.
3. On the Maple toolbar, click the Maple help icon.
OpenMaple

OpenMaple is a suite of functions that allows you to access Maple algorithms and data structures in your compiled C, C#, Java, or Visual Basic programs. (This is the reverse of external calling, which allows access to compiled C, C#, Fortran 77, and Java code from Maple.)

To run your application, Maple must be installed. You can distribute your application to any licensed Maple user. For additional terms and conditions on the use of OpenMaple, refer to the extern/OpenMapleLicensing.txt file in your Maple installation.

For more details on using OpenMaple functions, refer to the OpenMaple help page.

MapleSim

MapleSim™ is a complete environment for modeling and simulating multidomain engineering systems. During a simulation, MapleSim uses the symbolic Maple computation engine to generate the mathematical models that represent the system behavior.

Because both products are tightly integrated, you can use Maple commands and technical document features to edit, manipulate, and analyze a MapleSim model. For example, you can use Maple commands and tools to manipulate your model equations, develop custom components based on a mathematical model, and visualize simulation results.

MapleSim software is not included with the Maple software. For more information on MapleSim, visit http://www.maplesoft.com/maplesim.

MaplePlayer for iPad

The Maple Player is a free application for the iPad that uses the Maple computation engine to enable you to view and interact with documents created in desktop Maple.

For more information on the Maple Player for iPad, visit http://www.maplesoft.com/products/MaplePlayer.

Sharing and Storing Maple Content

The MapleCloud

You can use the MapleCloud to share or store your Maple documents and workbooks. Upload Maple documents or workbooks. Package workbooks offer a way to share a Maple package with other users, including source code, documentation and examples.

The MapleCloud has private and public sharing. You can share with all Maple users, share with a private group, or upload and store content in a user-specific area that only you can access.

Users need an internet connection to use the MapleCloud. Anyone can access publicly shared documents. To share content, create, manage and join user groups; and view group-specific content, you must log in to the MapleCloud using a Maplesoft.com, Gmail™, or Google Mail™ account name and password.

A Maplesoft.com membership account gives you access to thousands of free Maple resources and MaplePrimes, which is an active web community for sharing techniques and experiences with Maple and related products. To sign up for a free Maplesoft.com membership account, visit http://www.maplesoft.com/members/sign_up_form.aspx. The MapleCloud is integrated with several of these online features, so it is strongly recommended that you use a Maplesoft.com membership account.

For more information on the MapleCloud, refer to the MapleCloud help page.
Index

Symbols
! toolbar icon, 47
!!! toolbar icon, 48
"", 271
$, 131
%H, 125
%T, 125
&x, 125
', 67, 285
(), 300
->, 67
., 124
1-D Math, 56
2-D Math, 56
   converting to 1-D, 57
   entering, 4
   shortcuts, 6
   switching to 1-D, 57
:, 56, 57
::, 104
:=, 66
;., 56, 57
<>:, 116, 118
>, 56
?
[ ], 123, 263, 264
^, 5, 79
   entering, 79
_, 68
`_ZN~, 83
`, 68
{ }, 264
|, 118
~, 83, 105
   element-wise operations, 283

A
about command, 105
abs command, 77
absolute value, 77
add
   word to your dictionary, 261
add command, 297
additionally command, 105
algebra, 115
   linear, 127
   polynomial, 110
algsubs command, 281
alignment format, 225
American spelling
   spellcheck, 259
and operator, 290
angle brackets, 116, 118, 152
angles, 278
animations
   creating, 215
   customizing, 217
Application Center, 41
applications
   sample documents, 40
apply
   character styles, 226
   paragraph styles, 229
approximation, 75
   least-squares, 127
   numeric, 281
arguments, 300
arithmetic, 47
   finite-precision, 74
   interval, 101
   matrix and vector, 124
   modular, 77, 78
   polynomial, 110
Arrays, 265
   indexing, 266
   large, 267
arrow operator, 67
assign command, 86
assigned command, 285
assignment operator (:=), 66
Assistants
   CAD Link, 24
   Code Generation, 24
   Curve Fitting, 115
   Data Set Search, 24
   eBook Publisher, 24
   Import Data, 24, 323
   Installer Builder, 24
   Library Browser, 24
   Maplet Builder, 24
   ODE Analyzer, 87
   Optimization, 138
   overview, 24
   Plot Builder, 24, 184
   Scientific Constants, 24
   Special Functions, 25
   Student Practice Sheets, 26
   Thermophysical Properties Calculator, 25
   Tools menu, 24
   Unit Converter, 278
   Units Converter, 25, 94
   Worksheet Migration, 25
assume command, 104
  adding assumptions, 105
  and procedure variables, 106
  imposing multiple assumptions, 105
  removing assumptions, 105
  setting relationships between variables, 104
  setting variable properties, 104
  testing property, 105
  using with assuming command, 106
  viewing assumptions, 105
assuming command, 104, 106, 135, 277
  additionally option, 106
  and procedure variables, 106
  applying to all names, 106
  using with assume command, 106
Attributes submenu
  character, 224
  paragraph, 225
auto-execute, 237
  repeating, 238
  security levels, 238
Avogadro constant, 98

B
bar chart, 143
basis
  vector space, 127
binary numbers, 78
Bohr radius, 98
bold format, 223
bookmarks
  using, 255
boolean expressions, 282, 290, 294
brackets
  angle, 116, 118
break statement, 297
browser
  Matrix, 118, 267
  Task, 64
bullets
  format, 225
button
  embedding, 257
Button component, 305
by clause, 292
  excluding, 292
  negative, 293

C
CAD Link Assistant, 24
calculus, 135
  clickable problem solving, 181
  multivariate, 136
  Student package, 137
  of variations, 137
  packages, 136
  study guides, 146
  teaching, 137, 147
  vector, 136
  Student package, 137
calling sequence, 58
canvas
  inserting, 249
canvas style
  sketch pad, 250
caret
  entering, 79
central tendency, 101
character styles
  creating, 227
  description, 226
Check Box component, 305
Cholesky decomposition, 126
clickable math
  expressions, 27
  Clickable Math, 181
  Drag-to-Solve, 157
  Smart Popups, 157
Code Edit Region, 302
Code Generation, 24
CodeGen
  package description, 60
coeff command, 114
coefficients
  polynomials, 114
coeffs command, 114
collect command, 114
colon, 56, 57
color
  of plots, 208
combine command, 277
caret
  errors option, 103
Combo Box component, 305
command completion, 6, 33
Command-line Interface, xiii
commands, 59
  and task templates, 64
displaying procedures, 301
entering, 32
  help, 37
  hiding, 302, 303
  iterative, 297
  mapping over set or list, 299
package, 59
top, 59
top-level, 58
complex expressions, 282
complex numbers, 21
compoly command, 115
components
  adding GUI elements, 257
  palette, 257
computations
  assistants, 64
  commands, 59
  context panel, 63
  errors, 76
    avoiding, 76
  integers, 79
  interrupting, 297
  linear algebra, 124
  mathematics, 109
  numeric, 75
  palettes, 61
  performing, 73, 109
  Real number system, 103
  symbolic, 75
  syntax-free, 53
  task templates, 64
  tutors, 64
  under assumptions, 104
    single evaluation, 106
  updating, 47
  with uncertainty, 102
  with units, 96
conditional execution, 289
constants, 44
content command, 115
context
  of unit, 94
context panel, 63, 126
  access tutors, 53
  computing with, 48
  customizing animations, 217
  integer, 63, 88
  overview, 27
  Plot Builder access, 185
  using, 27
context-sensitive operation, 27
  customize text on arrow, 51
  equation, 80
  integer, 76
  using, 10
convert command, 278
  base option, 78, 296
  degrees option, 278
  mathematical functions, 278
  polynom option, 133
  set option, 278
  temperature option, 95
  units option, 94, 278
copy, 222
  and drag, 10
  examples, 39
copy expressions, 10
correlation, 102
coulditbe command, 105
covariance, 102
cross product, 125
Curl command, 136
Curve Fitting
  package
    PolynomialInterpolation command, 115
Curve Fitting Assistant, 115
cut and paste
  in tables, 241
D
D operator, 131
data structures, 44, 263
  creating, 271
Data Table component, 305
Database Integration, 327
datatype option, 121
degree
  command, 114
  polynomials, 114
denom command, 274
derivatives, 130
  directional, 132
  partial, 44, 130
  prime notation, 237
  Tutor, 147
Dial component, 306
dictionary, 40, 146
dictionary topic
  adding hyperlink to, 254
diff command, 88, 130
differential equations
  ordinary, 87
  partial, 91
  Student package, 137
differentiation, 130
  with uncertainty, 102
  with units, 96
Differentiation Methods Tutor, 147
Digits environment variable, 75
dimension, 93, 126
  base, 93
Directional Derivative Tutor, 132
discrim command, 115
display
  bookmark, 255
distribution
probability, 141
divide command, 111
divisors, 77
document blocks, 35, 235
Document mode, 43
documents
running, 8
DocumentTools, 312
double colon operator, 104
dsolve command, 90

E

e (exponential)
entering, 44
e-notation, 75
eBook Publisher Assistant, 24
Edit menu
in help system, 39
eigenvalues, 126
eigenvectors, 126
element-wise operators, 283
elementary charge, 98
elements, 97
definition, 99
isotopes, 99
definition, 99
properties, 99
list, 99
properties
list, 99
uncertainty, 100
units, 100
using, 98
value, 100
value and units, 100
eilf clauses, 291
order, 291
else clause, 290
email
adding hyperlink to, 253
embedded components, 257, 305
example, 309, 311
inserting, 308
properties, 309
end do keywords, 292, 294
end if keywords, 289
end proc keywords, 300
engineers
portal for, 40
Enter key, 46
environment variables
Digits, 75
Order, 133

equation
solving step-by-step, 163
equation labels, 71
displaying, 69
features, 71
formatting, 35
inserting, 34, 69
numbering schemes, 71
overview, 34
versus names, 71
with multiple outputs, 71
Equation Manipulator, 163
equations
solving, 80
for real solutions, 103
numerically, 84
symbolically, 82
transcendental, 83
errors
quantities with, 101
Euclidean algorithm, 115
eval command, 280, 301
evallb command, 282
evallc command, 282
evallf command, 75, 83, 100, 102, 281
with Int command, 136
with Limit command, 129
evalln command, 285
evaluate
and display inline, 46
evaluation
boolean expressions, 282
complex expressions, 282
delaying, 285
levels of, 284
Maple expressions, 279
of expression at a point, 279
output below, 47
output inline, 46, 49
updated computations, 47
exact
computation, 74
numbers, 74
quantities
converting to floating-point, 75
example worksheets
copy, 39
execute, 46
execution group, 56
execution groups, 14
expand
command, 277
document block, 236
execution group, 236
series, 133
Exploration Assistant, 29
exponents
entering, 5
export, 302
to HTML, 325
to LaTeX, 325
to Maple input, 325
to Maple text, 325
to Maplet application, 325
to other formats, 325
to PDF, 326
to plain text, 326
to Rich Text Format, 326
worksheets, 325
exporting
embedded components, 308
expression sequences, 82, 263
creating, 297
expressions, 44, 263
adding, 297
clickable math, 27
evaluating, 279
manipulating, 276
multiplying, 297
versus functional operators, 269

F
factor
integers, 76
polynomials, 114
QR factorization, 127
factor command, 114, 276
factored normal form, 278
factorial command, 77
FAIL, 290, 294
false, 290, 294
Faraday constant, 98
Favorites palette, 15, 20
files
image formats, 251
reading from, 323
writing to, 321
fill option, 121
finite fields, 78
solving equations, 92
finite rings, 78
floating-point
computation, 75
accuracy, 76
hardware, 76
significant digits, 75
numbers, 74
rational approximation, 63
Flux command, 136
font color, 223
foot-pound-second (FPS) system, 94
footers, 233
for/from loops, 292
for/in loops, 293
formal power series solutions, 91
format labels, 35
Format menu
bookmarks, 255
quick formatting, 223
frac command, 106
fractions
approximating, 50
entering, 4
frequency plot, 143
Frobenius form
matrix, 127
from clause, 292
excluding, 292
fsolve command, 84
full evaluation, 284, 286
function, 46
FunctionAdvisor command, 58
functional operators, 268
differentiating, 131
plotting, 270
versus expressions, 269
functions
converting between, 278
defining as functional operators, 268
how to define in Maple, 268

G
Gaussian elimination, 127
Gaussian integers, 79
GaussInt package, 79
gcd command, 115
gcdex command, 115
Global Optimization Toolbox, 137
global variables, 300
glossiness
of 3-D plots, 208
go to
bookmark, 256
gradient, 148
Gradient Tutor, 148
greatest common divisor, 77, 115

H
has command, 273
hastype command, 273
HazardRate command, 142
headers, 233
Help Navigator
   Using, 38
help page
   adding hyperlink to, 253
help system
   accessing, 37
   description, 40
   Edit menu, 39
   Help Navigator, 37
   manuals, 39
   search, 39
   table of contents, 39
   tasks, 39
   View menu, 39
Hermitian transpose
   matrix and vector, 125
Hessenberg form, 127
hexadecimal numbers, 78
hide
   worksheet content, 233
highlight color, 223
Hilbert Matrix, 127
histogram, 143
Homework practice sheet assistant, 26
How Do I ... topics, 40
hyperlinks
   in worksheet, 252
i
   entering, 21, 80
icons
   open as example worksheet, 39
if statement, 289
ifactor command, 76, 77, 277
igcd command, 77
images
   adding hyperlink to, 253
   file format, 251
   inserting, 251
imaginary unit
   entering, 21, 80
implied multiplication, 5
implies operator, 290
Import Data Assistant, 24, 323
indent
   format, 225
indeterminates, 275
indets command, 275
indices, 58, 123
inequalities
   solving, 80
      for real solutions, 103
      symbolically, 82
infinite loops, 297
infolevel command, 91
input
   2-D Math, 56
   2-D math notation, 56
   Maple notation, 56
   prompt, 56
   separating, 57
   setting default mode, 57
insert
   bookmark, 255
   hyperlink, 252
   images, 251
   section, 232
   sketch pad, 249
   table, 239
Installer Builder Assistant, 24
instructor resources, 155
int command, 135
Int command, 136
integers
   commands, 77
   computations, 79
   context panel, 63, 88
   factoring, 76
   Gaussian, 79
   modulo m, 78
   solving equations, 92
   solving modular equations, 92
integration, 48, 62, 134
   definite, 135
   functional operators, 271
   indefinite, 134
   iterated, 135
   line, 135, 150
   numeric, 136
   surface, 135
   with units, 96
interactive commands
   Student, 26
interactive document
   building, 305
Interactive Linear System Solving tutor, 53
Interactive Plot Builder Assistant
   creating animations, 211
   creating plots, 184
   customizing animations, 217
   customizing plots, 204
interface command
   rtablesize option, 120
   verboseproc option, 301
international system (SI), 94
InterquartileRange command, 142
interval arithmetic, 101
iquo command, 77
iroot command, 77
is command, 105
isprime command, 77
isqrt command, 77
italic format, 223
J
j
entering, 80
Jordan form, 126
K
keyboard keys
  Command Completion, xiii
  keystrokes, 5
L
Label component, 306
labels, 71
last name evaluation, 285
lcm command, 115
lcoeff command, 114
ldegree command, 114
least-squares, 127
left single quotes, 68
left-hand side, 274
levels of evaluation, 284
lexicographic order, 112
lhs command, 274
Library Browser
description, 24
limit command, 129
Limit command, 129
limits, 128
  multidimensional, 129
line break, 225
line integrals, 150
linear algebra, 127
  computations, 124
  efficiency, 120, 128
  LinearAlgebra package, 127
teaching, 128, 147
Linear System Solving tutor, 53
linear systems
  solving, 92, 127
  interactive, 53
LinearAlgebra
  package description, 60
  package, 125
  commands, 127
  numeric computations, 128
LinearSolve command, 92
Linux
  command complete, 6
List Box component, 306
lists, 123, 264
  returning solutions as, 82
local variables, 300
logical operators, 290
loops, 292
  general, 296
  infinite, 297
M
Mac
  command complete, 6
map
  equation, 163
map command, 299
Maple Application Center, 146
Maple library, 31
Maple Portal, 40, 146
Maple Student Help Center, 146
Maple Workbook, 4
MapleCloud, 329
MaplePrimes, 41
Maple Builder
description, 24
launching, 316
Maplet authoring, 316
Maplets
  adding hyperlink to, 254
  authoring, 319
    Maplet Builder, 316
    Maplets package, 319
launching
    Maple worksheet, 315
    Maplet file type, 314
Maplets package
  Display command, 319
  Elements subpackage, 319
  Maplet authoring, 319
saving
  Maple worksheet, 320
  maplet file, 320
using, 314
markers
  bookmarks, 255
  displaying, 36
  for document blocks, 235
Math Apps, 26
in help system, 39
math dictionary
description, 40
Math Expression component, 306
Math mode, 14
shortcuts, 6
mathematical functions
list, 58
mathematics
computations, 109
teaching and learning, 155
matrices, 267
arithmetic, 124
context panel, 126
data type, 121, 122
defining, 116
efficiency, 120
filling, 122
Hermitian transpose, 125
image, 120
large, 119
multiplication, 124
operations, 126
random, 119
scalar multiplication, 124
selecting submatrices, 123
shape, 120, 122
transpose, 125
type, 120
Matrix
Browser, 118, 267
constructor, 121
data structure, 116
palette, 92, 116, 120
Matrix command, 116
max command, 77
maximize, 137
maximum, 77
Mean command, 142
Meter component, 306
Microphone component, 306
min command, 77
minimize, 137
minimum, 77
mod command, 77
mod operator, 78
modes
Document, 43
Worksheet, 43
modify
table, 240
modp command, 79
mods command, 79
modular arithmetic, 77, 78
modules, 302
MPS(X) files, 140
msolve command, 92
mul command, 297
multiplication
implied, 5
N
names, 44, 67
adding assumptions, 104
and symbols, 21
assigned, 285
assigning values to, 66
logical, 290
previously assigned, 285
protected, 67
removing assumptions, 105
reserved, 67
unassigning, 67, 105, 286
valid, 68
versus equation labels, 71
with assumptions, 105
nops command, 275
norm command, 115, 126
normal command, 278
normal form, 278
not operator, 290
numbers, 44
exact, 74
floating-point, 74
non-base 10, 78
NumberTheory[Divisors] command, 77
numer command, 274
numeric
approximation, 281
computation, 74
O
objects, 302
ODE Analyzer Assistant, 87
ODEs
Student package, 137
online help, 41
operands, 275
selecting, 298
operators, 44
functional, 268
logical, 290
relational, 290
Optimization
package description, 61
optimization, 139
efficiency, 139
plotting, 139
point-and-click interface, 138
Optimization Assistant, 138
Plotter, 139
Options dialog, 15
or operator, 290
Order environment variable, 133
ordinary differential equations
plotting solution, 90
solving, 87
orthogonal matrix, 127
output
suppressing, 56

P
packages, 58
accessing commands, 33
definition, 31
help, 37
loading, 59
top, 61
unloading, 60
page break, 225
page headers and footers, 233
palettes, 44, 48, 61, 280
categories, 18
Components, 308
favorites, 15
Favorites, 20
managing, 18
Matrix, 116, 120
overview, 15
saving expressions for ease of reuse, 20
Units, 52, 95
paragraph styles
creating, 230
description, 226
parameters, 300
parametric solutions, 84
partial derivative
entering, 44
partial differential equations
solving, 91
paste, 222
examples, 40
PDEs, 91
pdsolve command, 91
pencil
sketch pad, 249
Physics
package description, 61
pie chart, 143
piecewise command, 142
Planck constant, 98
Plot Builder
description, 24
Plot component, 306
plot3d command, 270
plots
analyzing, 210
pan, 210
point probe, 210
rotate, 210
scale, 210
creating, 203
context panel, 189
displaying multiple plots, 201
Interactive Plot Builder, 184
plot command, 189
plot3d command, 189
plots package, 197
creating animations
animate command, 212
Interactive Plot Builder, 211
plot3d[viewpoint] command, 214
customizing, 209
context panel, 205
Interactive Plot Builder, 204
plot options, 208
plot3d options, 208
customizing animations, 217
command-line options, 218
context panel, 217
Interactive Plot Builder, 217
data, 211
dragging expression to add to a plot, 201
exporting, 219
functional operators, 270
gradient, 150
line integral, 150
Live Data Plots palette, 211
ODEs
symbolic solution, 89
optimization problem, 139
playing animations, 216
plots package
animate command, 212
contourplot command, 200
display command, 203
matrixplot command, 198
pointplot command, 197
statistics, 143
viewing animations
animate context bar, 216
plotting
using the context panel, 27
point-and-click, 24
polynomial equations
solving, 83
   numerically, 84
polynomials
   algebra, 110
   arithmetic, 110
   coefficients, 114
   collecting terms, 114
   degree, 114
   division, 110, 111
   expanding, 111
   factoring, 114
   implied multiplication, 111
numeric
   algebraic manipulation, 115
   operations, 115
   sorting, 111
   pure lexicographic, 112
   total degree, 112
PolynomialTools package, 115
   IsSelfReciprocal command, 115
powers
   entering, 5
precalculus
   study guides, 146
   teaching, 147
precision, 75
prem command, 115
previously assigned, 285
primality testing, 77
primpart command, 115
print
   command, 301
   table, 245
printing
   embedded components, 308
probability distribution, 141
proc key word, 300
procedures, 301
   and assumptions, 106
   calling, 300
   defining, 300
   displaying, 301
   inputs, 300
   multiple lines, 300
   output, 300
   using, 300
product command, 298
products
   entering, 5
   implied, 5
programming, 289
   access to the Maple Programming Guide, 40
programs, 289
   modules, 302
objects, 302
   procedures, 301
prompt
   input, 56
   properties
   testing, 105
protected names, 67
Q
   QPSolve command, 140
   QR factorization, 127
   quadratic programs, 140
   quantities with uncertainty, 101
   accessing error, 102
   accessing value, 102
   computing with, 102
   constructing, 101
   element properties, 102
   rounding the error, 102
   scientific constants, 102
   with units, 102
quick
   character formatting, 223
   paragraph formatting, 225
quit statement, 297
quo command, 110
quotes
   double, 271
   left single, 68
   right single, 67, 285
   unevaluation, 285
quotient
   integer, 77
R
   Radio Button component, 306
random
   matrices, 119
   variables, 141
randpoly command, 115
range
   in plots, 206
   operator, 123
rank, 126
rational expressions
   entering, 4
read
   from files, 323
RealDomain
   package description, 61
recurrence relation
   solving, 92
reference
<table>
<thead>
<tr>
<th>Term</th>
<th>Page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>equation labels</td>
<td>71</td>
</tr>
<tr>
<td>names</td>
<td>67</td>
</tr>
<tr>
<td>relational operators</td>
<td>290</td>
</tr>
<tr>
<td>rem command</td>
<td>110</td>
</tr>
<tr>
<td>remainder</td>
<td>298</td>
</tr>
<tr>
<td>integer</td>
<td>77</td>
</tr>
<tr>
<td>remove command</td>
<td>298</td>
</tr>
<tr>
<td>repetition statements</td>
<td>292</td>
</tr>
<tr>
<td>reserved names</td>
<td>67</td>
</tr>
<tr>
<td>resources</td>
<td>39</td>
</tr>
<tr>
<td>in help system</td>
<td>39</td>
</tr>
<tr>
<td>restart command</td>
<td>60, 68</td>
</tr>
<tr>
<td>resultant command</td>
<td>115</td>
</tr>
<tr>
<td>return statement</td>
<td>297</td>
</tr>
<tr>
<td>values</td>
<td>300</td>
</tr>
<tr>
<td>rhs command</td>
<td>274</td>
</tr>
<tr>
<td>right single quotes</td>
<td>67, 285</td>
</tr>
<tr>
<td>right-hand side</td>
<td>274</td>
</tr>
<tr>
<td>RootOf structure</td>
<td>83</td>
</tr>
<tr>
<td>roots</td>
<td>115</td>
</tr>
<tr>
<td>of equations</td>
<td>83</td>
</tr>
<tr>
<td>Rotary Gauge component</td>
<td>306</td>
</tr>
<tr>
<td>row vector</td>
<td>121</td>
</tr>
<tr>
<td>rhs command</td>
<td>92</td>
</tr>
<tr>
<td>running</td>
<td>8</td>
</tr>
<tr>
<td>documents</td>
<td>8</td>
</tr>
<tr>
<td>worksheets</td>
<td>8</td>
</tr>
</tbody>
</table>

### S

<table>
<thead>
<tr>
<th>Term</th>
<th>Page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>saving a Maple Document</td>
<td>13</td>
</tr>
<tr>
<td>as a Workbook</td>
<td>13</td>
</tr>
<tr>
<td>scatter plot</td>
<td>143</td>
</tr>
<tr>
<td>scientific constants</td>
<td>97</td>
</tr>
<tr>
<td>list</td>
<td>98</td>
</tr>
<tr>
<td>name</td>
<td>98</td>
</tr>
<tr>
<td>symbol</td>
<td>98</td>
</tr>
<tr>
<td>uncertainty</td>
<td>100</td>
</tr>
<tr>
<td>units</td>
<td>100</td>
</tr>
<tr>
<td>using</td>
<td>98</td>
</tr>
<tr>
<td>value</td>
<td>100</td>
</tr>
<tr>
<td>value and units</td>
<td>100</td>
</tr>
<tr>
<td>Scientific Constants Assistant</td>
<td>24</td>
</tr>
<tr>
<td>ScientificConstants package description</td>
<td>61</td>
</tr>
<tr>
<td>ScientificConstants package</td>
<td>98</td>
</tr>
<tr>
<td>extensibility</td>
<td>103</td>
</tr>
<tr>
<td>objects</td>
<td>101</td>
</tr>
<tr>
<td>search</td>
<td>101</td>
</tr>
<tr>
<td>help system</td>
<td>38</td>
</tr>
<tr>
<td>sections</td>
<td>231</td>
</tr>
<tr>
<td>in worksheet</td>
<td>39</td>
</tr>
<tr>
<td>security levels</td>
<td>238</td>
</tr>
<tr>
<td>auto-execute</td>
<td>238</td>
</tr>
<tr>
<td>security tab</td>
<td>238</td>
</tr>
<tr>
<td>options dialog</td>
<td>238</td>
</tr>
<tr>
<td>select command</td>
<td>298</td>
</tr>
<tr>
<td>selection</td>
<td>8</td>
</tr>
<tr>
<td>execute</td>
<td>298</td>
</tr>
<tr>
<td>selectremove command</td>
<td>298</td>
</tr>
<tr>
<td>semicolon</td>
<td>56, 57</td>
</tr>
<tr>
<td>seq command</td>
<td>297</td>
</tr>
<tr>
<td>series</td>
<td>133</td>
</tr>
<tr>
<td>command</td>
<td>133</td>
</tr>
<tr>
<td>Taylor</td>
<td>133</td>
</tr>
<tr>
<td>type</td>
<td>133</td>
</tr>
<tr>
<td>Set Search Assistant</td>
<td>24</td>
</tr>
<tr>
<td>sets</td>
<td>264</td>
</tr>
<tr>
<td>shape option</td>
<td>121</td>
</tr>
<tr>
<td>Shortcut component</td>
<td>307</td>
</tr>
<tr>
<td>show</td>
<td>233</td>
</tr>
<tr>
<td>worksheet content</td>
<td>233</td>
</tr>
<tr>
<td>show contents dialog</td>
<td>234</td>
</tr>
<tr>
<td>using</td>
<td>234</td>
</tr>
<tr>
<td>significant digits</td>
<td>75</td>
</tr>
<tr>
<td>simplify command</td>
<td>276, 281</td>
</tr>
<tr>
<td>slider</td>
<td>257</td>
</tr>
<tr>
<td>embedding</td>
<td>257</td>
</tr>
<tr>
<td>Slider component</td>
<td>306</td>
</tr>
<tr>
<td>solutions</td>
<td>80</td>
</tr>
<tr>
<td>assigning as expression</td>
<td>86</td>
</tr>
<tr>
<td>assigning as function</td>
<td>86</td>
</tr>
<tr>
<td>details</td>
<td>91</td>
</tr>
<tr>
<td>formal</td>
<td>91</td>
</tr>
<tr>
<td>formal power series</td>
<td>91</td>
</tr>
<tr>
<td>integers</td>
<td>92</td>
</tr>
<tr>
<td>real</td>
<td>103</td>
</tr>
<tr>
<td>series</td>
<td>91</td>
</tr>
<tr>
<td>verifying</td>
<td>85</td>
</tr>
<tr>
<td>solve</td>
<td>80</td>
</tr>
<tr>
<td>equations</td>
<td>80</td>
</tr>
<tr>
<td>for real solutions</td>
<td>103</td>
</tr>
<tr>
<td>numerically</td>
<td>84</td>
</tr>
<tr>
<td>symbolically</td>
<td>82</td>
</tr>
<tr>
<td>inequations</td>
<td>80</td>
</tr>
<tr>
<td>for real solutions</td>
<td>103</td>
</tr>
<tr>
<td>symbolically</td>
<td>82</td>
</tr>
<tr>
<td>integer equations</td>
<td>92</td>
</tr>
<tr>
<td>linear system</td>
<td>92, 127</td>
</tr>
<tr>
<td>modular integer equations</td>
<td>92</td>
</tr>
</tbody>
</table>
ODEs, 87
PDEs, 91
recurrence relation, 92
transcendental equations, 83
solve command, 82, 265
finding all solutions, 83
finding parametric solutions, 84
real solutions, 103
solving procedures, 84
sort
lists, 279
polynomials, 111, 279
sort command, 111, 279
plex option, 112
source code
displaying, 301
spacing format, 225
Speaker component, 307
Special Functions Assistant, 25
spellcheck, 259
American spelling, 259
dictionary, 261
sqrfree command, 115
Standard Document Interface, xiii
starting, 2
Standard Worksheet Interface, xiii
startup code, 8
Startup Code, 303
statements
multiple lines, 300
Statistics
Student package, 145
Statistics package, 143
continuous distributions, 141
description, 61
discrete distributions, 141
plots, 143
strings, 271
StringTools package, 272
Student
package description, 61
Student Help Center, 41
Student package, 132, 146, 147
calculus subpackages, 137
LinearAlgebra subpackage, 128
Maplets, 146
statistics, 145
Tutors, 146
Student Practice Sheets
Assistant, 26
student resources, 155
students
portal for, 146
study guides, 146
style set management, 231
subscripts
entering, 5
format, 223
substitute, 279
sum command, 298
superscript format, 223
Sylvester matrix, 127
symbol completion, 6
symbolic
computation, 74
objects, 74
symbols
entering, 21
names, 21
system of units, 94
controlling, 97
systeme international (SI), 94

T
Tab
inserting, 62
key, 62
Tab key, 234
table of contents
help system, 39
tables, 267
alignment, 243
appearance, 242
borders, 242
contents, 239
editable, 246
execution order, 245
physical dimensions, 242
printing, 245
using, 239
visibility of cell content, 245
Task Browser, 64
task template, 27
task templates, 64, 76, 93, 116, 128
taylor command, 133
Taylor series, 133
tcoeff command, 114
Teacher Resource Center, 41
teaching with Maple, 155
Technical Support
access, 42
temperature conversion, 94
Text Area component, 306
text field
embedding, 257
Text mode, 14
text regions, 65
Thermophysical Properties Calculator Assistant, 25
tilde, 83, 105, 283
to clause, 292
  excluding, 292
Toggle Button component, 306
Tolerances package, 101
toolboxes
  Global Optimization, 137
Tools menu
  assistants, 24
  Assistants and Tutors, 64
  Tasks, 64
Torsion command, 137
total degree, 112
transparency
  of 3-D plots, 209
transpose
  matrices and vectors, 125
true, 290
Tutorials, 40
Tutors, 146, 147
  Derivatives, 147
  Differentiation Methods, 147
  Directional Derivative, 132
  Gradient, 148
  Linear System Solving, 53
  using, 25
tutors
  accessing, 25
type command, 273
types, 104, 272
  converting, 278
  series, 133
  testing, 273
  subexpressions, 273
U
unapply command, 86
unassign command, 67
unassigning names, 67, 286
uncertainty, 101
  quantities with, 101
underline format, 223
unevaluation quotes, 67, 285
union
  of sets, 264
Unit Converter Assistant, 278
units, 52, 93, 278
  adding to expressions, 52
  applying to expression, 95
  computing with, 96
  context, 94
  converting between, 94
environment, 96
  evaluating with, 53
in 1-D Math, 96
inserting, 95
overview, 93
prefixes, 96
system of
  controlling, 97
  systems of, 94
Units
  package description, 61
Units Converter, 94
Units Converter Assistant, 25
Units package, 93
  environments, 96
  extensibility, 97
  UseSystem command, 97
  UsingSystem command, 97
Units palette, 52, 95
universal gravitational constant, 98
until loop, 294
until loops, 294
unwith command, 60
URL
  adding hyperlink to, 253

V
variables, 44
variance, 102
VariationalCalculus package, 137
Vector
  constructor
    vectorfield attribute, 136
  data structure, 116
  vector fields, 136
vector spaces
  basis, 127
  VectorCalculus
    package description, 61
  VectorCalculus package, 136
  Student version, 137
vectors, 267
  arithmetic, 124
  column, 118
  context panel, 126
  cross product, 125
  data type, 121
  defining, 118
  efficiency, 120
  filling, 121
  large, 119
  multiplication, 124
  row, 118, 121
scalar multiplication, 124
selecting entries, 122
shape, 121
transpose, 125
Video Player component, 307
View menu
    in help system, 39
    markers, 36
Volume Gauge component, 307

W
Webpage
    adding hyperlink to, 253
Website
    access to Maple help pages, 41
        Application Center, 41, 146
        MaplePrimes, 41
        Student Center, 146
        Student Help Center, 41
        Teacher Resource Center, 41
        Technical Support, 42
        Training, 41
while loops, 294
Windows
    command complete, 6
    with command, 59
Workbook Attachment
    adding hyperlink to, 254
Workbook File
    adding hyperlink to, 255
worksheet
    adding hyperlink to, 253
Worksheet Environment, 1
Worksheet Migration Assistant, 25
Worksheet mode, 43, 55
worksheets
    running, 8
write
    to files, 321

X
xor operator, 290

Z
zero recognition, 279
zip command, 299