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1  Introduction to Maple

Chapter 1: Introduction to MapleMaple™ is an analytic computation system. It performs mathematical 
computations and manipulations for solving problems from various technical 
disciplines. Most significantly, Maple computes both numerical as well as 
symbolic solutions to mathematical expressions. This means that Maple 
performs computations on expressions that contain symbols, such as π or x, 
without performing numerical approximations. For example, Maple 
determines that the derivative of sin(x) is cos(x), even when x has not been 
assigned a value. Maple provides exact solutions to many technical problems. 
In addition, Maple has visualization tools that contribute to the problem-
solving process. 

1.1 Installing Maple
For installation and licensing instructions, refer to the Install.htm file on 
your Maple CD.

1.2 Starting Maple
You can access the power of the Maple computation engine through a variety 
of user interfaces: the Standard Worksheet, the Command-line version, the 
Classic Worksheet, and custom-built Maplet™ applications. The full Maple 
system is available through all of these interfaces. In this manual, any 
references to the graphical Maple interface refer to the Standard Worksheet 
interface. For more information on the various interface options, refer to the 
?versions help page.
1
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To start the Standard Worksheet interface in Windows®:

• From the Start menu, select Programs, Maple 9.5, Maple 9.5. 
Alternatively, double-click the Maple 9.5 desktop icon.

To start the Standard Worksheet interface on a Macintosh® computer:

• Double-click the Maple 9.5 application icon in the Finder.

To start the Standard Worksheet interface in UNIX® or Linux®:

• Enter the full path, for example, 
/usr/local/maple/bin/xmaple 
Alternatively,

1. Add your Maple 9.5 directory (for example, /usr/local/maple/bin) to 
your command search path.

2. Enter xmaple.

On all operating systems, the first Maple worksheet session opens with the 
Tip of the Day, and the Introduction to Maple 9.5 page that points you to the 
New User’s Tour, updates, and other introductory help pages. Subsequent 
worksheet sessions start with a new, blank worksheet.

1.3 The Maple Worksheet Window
The Maple worksheet window resembles that of a typical program. The main 
features are shown in Figure 1-A on page 3. 
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Figure 1-A Maple window features

Table 1: Maple Worksheet Interface

A Toolbar 
A toolbar containing shortcut buttons.

B Context bar 
A toolbar containing context-sensitive shortcut buttons. (The buttons change 
based on the cursor location or selection.) It can also contain a field for editing 
and entering text.

C Section heading 
The name or title of a section.

D Maple input 
A mathematical expression or command that Maple evaluates. By default, input 
commands are entered at the prompt, “>”, and are displayed in red type. The 
resulting output is displayed beneath.

E Maple output 
The result of an executed Maple input command. By default, Maple output is 
displayed in blue type in Standard Math Notation.
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1.4 Accessing Help Pages
The commands and features in Maple are documented in help pages. To view 
help pages, at the prompt, enter a question mark (?) followed by the name of 
the command or subject on which you want help. Do not enter any spaces. For 
example, to refer to the help page on natural logarithms, enter ?ln. For 
information on different ways to access help, see The Help System on page 27.

F Execution group 
A set of Maple input with its corresponding output.

G Prompt 
By default, the Maple prompt is a greater-than ( > ) symbol that indicates where 
to enter Maple input.

H Section range bracket 
A line that encloses the elements of a section.

I Expression palette 
A collection of templates for entering mathematical expressions in Maple.

J Vector palette 
A collection of templates for entering vectors in Maple

K Matrix palette 
A collection of templates for entering matrices in Maple.

L Symbol palette 
A collection of buttons for entering mathematical symbols in Maple.

Table 1: Maple Worksheet Interface
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1.5 Entering Expressions in Maple
There are two types of input display. Use Maple Notation to display input as 
Maple syntax. Maple Notation is the default. Use Standard Math Notation 
to display input in typeset notation as it appears in a textbook.

Maple has four palettes (Expression, Matrix, Vector, and Symbol) for building 
or editing mathematical expressions without having to remember the Maple 
command syntax. In the Standard Worksheet, the palettes are automatically 
displayed in the left-hand side of the worksheet interface. You can position 
palettes using a context-sensitive menu, that is, you can dock a palette to the 
top, bottom, left, or right side of the worksheet.

To enter expressions at the prompt, use the keyboard, the palettes, or both. 
Using the keyboard is the most direct method, but the palettes enable you to 
enter a command without knowing its syntax.

The following examples step you through entering and  

evaluating  in various ways.

To enter and evaluate the integral in Standard Math Notation by using the 
palettes:

1. Display the palettes, if necessary. From the View menu, select Palette, 
then Show All. The Symbol, Expression, Matrix, and Vector palettes are 
displayed. 

2. If required, change the input to Standard Math Notation. (If there is a 
question mark (?) after the prompt, the input is already set to Standard 
Math Notation.) If there is no ?, at the prompt, right-click. (For Macintosh, 
if you are using a single-button mouse, CONTROL-click.) A context-sensitive 
menu is displayed. Select Insert>Standard Math Input.

3. On the Expression palette, click . The integral symbol appears, and 

the question mark placeholder is selected.
4. Enter 0 (zero), and press TAB. The TAB advances the cursor to the next 

placeholder region.

5. On the Symbol palette, click . It is located in the bottom row.

6. On the Expression palette, click . The function sin appears, with 
another placeholder. 

7. Enter x (on the keyboard), and press TAB to go to the next placeholder, 
and enter x again. Press ENTER.

x( )sin xd
0

π

∫
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8. Press ENTER. Maple inserts the integral in Standard Math Notation, and 
then evaluates the integral.

Your worksheet should resemble that shown in Figure 1-B on page 6. 

Figure 1-B Integral input in Standard Math Notation

The next example shows you how you can use the palettes to enter the 
expression and learn the Maple command syntax at the same time.

To enter and evaluate the integral in Maple Notation by using the palettes:

1. On the Expression palette, click . The integration command int 

appears, and the %f placeholder is selected.

2. On the Expression palette, click . The mathematical function sin 
appears, with another placeholder. 

3. Enter x (on the keyboard), and press TAB to go to the next placeholder.
4. Repeat step 3.
5. Enter 0 (zero), and press TAB.

6. On the Symbol palette, click . (It is in the bottom row.)

7. Press ENTER. Maple evaluates the integral.

Note: Maple appends a semicolon to the end of the command. This signifies the 
end of the statement.
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Your worksheet should resemble that shown in Figure 1-C.

Figure 1-C Integral input in Maple Notation

Now that you know the correct notation, you can enter the expression at the 
prompt. For more information on entering expressions, see the examples in 
the next chapter and refer to ?worksheet,expressions,entering (Enter 
Expressions in Maple). For more information on using palettes, refer to 
?worksheet,expressions,palettes (Overview of Palettes).

For the rest of this guide, it is assumed that you are entering expressions in 
Maple Notation.
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2  Solving a Problem

Chapter 2: Solving a ProblemThis chapter presents a mathematical problem with its solution. The 
discussion of the problem and its solution introduces you to key features of the 
Maple program.

Note: When entering Maple commands, keep in mind that they are case-
sensitive.

2.1 Scenario
A skier has made her way to the top of a mountain. She wants to take the 
steepest path down, which she can find by performing the calculations 
outlined in this chapter. Start by opening a new worksheet for this problem.

To open a new worksheet:

• From the File menu, select New.

2.2 Commands in Packages
Some of the commands used in the discussion are found in packages whereas 
the top-level commands are not. A package is a group of routines related to a 
particular area of mathematics. You can always access commands in packages 
by using the long form, that is, specifying both package and function name: 
package_name[function_name](...), but to be able to use the short form, 
that is, specify only the function name, use the with command first.
9
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To access commands in the plots package using short-form names:

• At the prompt, enter the following and press ENTER. 
with(plots);

After executing the command, Maple lists any warnings, followed by all of the 
commands that are included in the package. For the plots package, a 
warning indicates that the name of one of the commands in the package, 
changecoords, is the same as that of a top-level command. After executing the 
with command, the name changecoords refers to the package command 
plots[changecoords] instead of the top-level changecoords command. To use 
the top-level command1, you must first clear the Maple internal memory 
using the restart command. For more information, refer to the ?restart help 
page. 

For other methods of accessing commands in packages, refer to Chapter 4, 
“Maple Organization,” in the Maple Learning Guide. For a list of all the 
packages in Maple, refer to ?index,packages (Index of descriptions for 
packages of library functions).

Note: Automatic Command Completion (Standard Worksheet interface only2) 
When you begin entering a command in the worksheet, Maple compares your 
entry with all Maple commands. If there is unique completion, Maple displays a 
tool-tip containing the matching command name above the entry in the worksheet. 
You can continue typing the command or press ENTER to insert the displayed 
command. This feature can be deactivated through the Options dialog.

2.3 Math and Visualization
Use mathematical and visualization commands to determine basic properties 
of the hill. For more information on any of the commands used here, enter a 
question mark, followed by the name of the command. For example, to find 
help on the exponential command, enter ?exp (The Expontential Function).

Suppose that the height at a point (x,y) of the hill is given by f, in thousands 
of feet.

1. For more information about using a top-level command in this context, refer to the ?with (with) 
help page.

2.Manual command completion is available in all interfaces. For information, refer to the 
?worksheet/expressions/completecommand (Complete Command) help page.
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To enter the expression in Maple:

• At the prompt, enter the following and press ENTER: 
f := 3/(1+x^2+y^2)/(1/4+1/2*(x+1)^2+1/2*(y+2)^2);

The expression for the shape of the hill is assigned to the name f by means of 
the assignment operator “:=” so that it can be referred to in subsequent 
calculations. For more information about assignments, refer to ?assignment 
(The assignment statement). For more information about names, refer to 
?names (Names).

Plotting the Hill
Before solving the problem, it is helpful to get an idea of the appearance of the 
hill (and an idea of the answer). 

To plot the expression:

1. Right-click the output of the expression (for Macintosh, CONTROL-click). 
The context-sensitive menu is displayed.

2. Select Plots, 3-D Plot, then x,y. Maple inserts the plot into the 
worksheet.

Note: The content of context-sensitive menus varies depending on the cursor 
location or selected expression. For more information, refer to 
?worksheet,expressions,manipulatecsm (Use Context-Sensitive Menus 
to Manipulate Expressions).

To add axes:

1. Right-click the plot (for Macintosh, CONTROL-click).
2. Select Axes, then Boxed.

To modify the axis ranges:

1. Right-click the plot (for Macintosh, CONTROL-click), select Axes, then 
Range.

2. In the Axis Ranges dialog:
a) Under X axis, click the button beside the range boxes. Enter a range 

of −4 to 3.
b) Similarly, under the Y axis, enter a range of −4 to 3.

f
3

1 x2 y2+ +( ) 1
4
---

x 1+( )2

2
-------------------

y 2+( )2

2
-------------------+ + 

 
---------------------------------------------------------------------------------------------=
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c) Click OK.

The visualization tools in Maple enable you to see the surface from more than 
one angle.

To rotate the surface:

1. Click the plot to select it.
2. Place the pointer on the plot.
3. Drag the plot in any direction. The surface rotates.

Depending on how you rotated the plot, it may look similar to Figure 2-A.

Figure 2-A Plot of the hill

While you can look at the surface and guess what the highest point (peak) is, 
you can obtain a more precise answer by using calculus.

Finding the Maximum Point of the Surface
Determine the location of the top of the hill by taking partial derivatives, 
setting them to 0, and solving for x and y.
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To find the partial derivative of f with respect to x:

• At the prompt, enter the following and press ENTER.  
fx := diff(f,x);

To find the partial derivative of f with respect to y:

• At the prompt, enter the following and press ENTER. 
fy := diff(f,y);

Since you are interested in the real-valued solution, use the fsolve command 
instead of the more general solve command. For more information, refer to 
the ?fsolve (fsolve) and ?solve (solve) help pages.

To solve the system of equations {fx=0, fy=0}:

• At the prompt, enter the following and press ENTER. 
top_xy := fsolve({fx=0,fy=0},{x,y},{x=-3..0,y=-3..0});

The numerical result {x = −.9026100199, 
y = -1.805220040} is an approximation of the x- and y-values of the peak.

Note: The elements in sets do not have a fixed order, so you may instead obtain 
the equivalent set:  
{ y = −1.805220040, x = −.9026100199}.

Finding the Skier’s Starting Point
Assume that the skier does not start at the peak but slightly to the side. To 
approximate this location, add a small factor, say 0.05, to the x- and y-values 
of the highest point. Assign the peak values to the variables x and y and then 
add the small factor.

To assign the values to the variables:

• At the prompt, enter the following and press ENTER. 
assign(%);

The ditto operator (%) refers to the result of the previous computation. For 
more information, refer to ?% (The ditto operators).

To define the starting x- and y-values, x1 and y1, respectively:

• At the prompt, enter the following and press ENTER. 
x1:=x+0.05; 
y1:=y+0.05;

The names x and y have values assigned to them. To use x and y as variables 
in the following calculations, they must be first unassigned. For more 
information on unassigning, refer to the ?uneval (Unevaluated expressions) 
help page.
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To unassign x and y:

• At the prompt, enter the following and press ENTER. 
x:=’x’; 
y:=’y’;

To find the z-coordinate of the starting point:

• Evaluate the function representing the hill at the x- and y-values 
representing the starting point (x1,y1). At the prompt, enter the following 
and press ENTER. 
z1:=eval(f,{x=x1,y=y1});

The numerical result {x1 =-.8526100199 , y1 = -1.755220040, z1 = 
2.145631453} is an approximation of the skier’s starting point.

Finding the Path Down
Before you find the path, take a look at the level curves of the hill to get an 
idea of the skier’s path.

To plot the level curves:

• The contourplot command (in the plots package) with five contours 
suggests an interesting shape, as shown in Figure 2-B. At the prompt, 
enter the following command and press ENTER.

contourplot(f, x=−2..1, y=−3..1, contours=5, filled=true); 

Figure 2-B Level curves of the hill 
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2.4 Using a For Loop—Finding the Path
Next, construct and plot the path on the surface of the hill that the skier 
should take. The negative of the gradient (−∇f(x,y) or −grad(f(x,y)) in the 
Maple language), gives the x and y components of the direction of steepest 
descent. At each point (x,y,z) on the surface, the skier must travel in the 
direction of −∇f(x,y), while staying on the surface. Since −∇f(x,y) changes 
from point to point, you can break the process into steps, building an 
approximation of the path of steepest descent. If the step size is too large, the 
path may leave the surface of the hill. If the step size is too small, you derive 
no benefit from the increased number of calculations.

Performing the Initialization
Assume that the skier is currently at the starting point (x1,y1,z1). Use a 
timestep of 0.1 and find 25 points along the path. Use the arrays point3d and 
route3d to store the values of the computed points and the direction taken, 
respectively. To simplify the calculation of the points and route, define vector 
representations of the expressions for the hill and the derivatives with respect 
to both x and y.

To define vector representations of the expressions:

• At the prompt, enter the following and press ENTER. (You can press SHIFT + 
ENTER after the first and second expression to organize the following as a 
single execution group on three lines.) 
g:=eval(f,{x=P[1],y=P[2]}); 
gx:=eval(fx,{x=P[1],y=P[2]}); 
gy:=eval(fy,{x=P[1],y=P[2]});

To declare the arrays for storing the values at each timestep:

• At the prompt, enter the following and press ENTER. 
point3d:=Array(1..25); 
route3d:=Array(1..25);

To define the initialization:

• At the prompt, enter the following and press ENTER. 
timestep:=0.1; 
point3d[1]:=<x1,y1,z1>;

Note: The notation <x1,y1,z1> defines a Vector while P[i] accesses the ith 
element of the list P. For more information about Vectors, refer to ?Vector 
(Vector - construct a Vector). For more information about lists, refer to ?lists 
(Sets and Lists).
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Specifying the For Loop
To obtain the additional 24 points, use a for loop. A for loop repeatedly 
executes a sequence of Maple commands entered between the do and end do 
commands of the loop, that is, in the loop body. It executes the commands as 
the value of a numeric variable, called an index, varies from its specified 
initial value to its specified final value. The value of the index is incremented 
after each execution of the commands in the body of the loop. The iteration 
stops when the value of the index is greater than the specified final value. For 
information on other programming structures in Maple, refer to the Maple 
Introductory Programming Guide.

To start the for loop:

• At the prompt, enter the following and press SHIFT+ENTER. 
for i from 1 to 24 do

Note: If you press ENTER, Maple returns the message: “Warning, premature end 
of input, use <Shift> + <Enter> to avoid this message”. The for statement is not 
complete. You must use SHIFT+ENTER to go to the next line.

The body of the for loop comprises the next commands. These commands find 
the skier’s position at the end of each time step.

To construct the 3-D normalized negative of the gradient vectors:

• On the next line, enter the following and press SHIFT+ENTER. 
route3d[i] := LinearAlgebra[Normalize](eval(<-gx,-gy,0>, 

P=point3d[i]));

To find the next point in the skier’s path:

• On the next line, enter the following and press SHIFT+ENTER. 
point3d[i+1] := 
eval(<P[1],P[2],g>,P=point3d[i]+timestep*route3d[i]);

To complete the for loop:

• On the next line, enter the following and press ENTER. Remember to end 
the line with a colon to suppress the output. 
end do:

This command ends the for loop. After you press ENTER, the five commands in 
the loop body are repeated 24 times. At the end of each iteration, the value of i 
is increased by 1. That is, for the first iteration, the value of i is its initial 
value 1, for the second, 2, and so on. For the last iteration the value of i is 24. 
Maple exits at the end of the 24th iteration once i is set to 25 (since 25 is 
outside of the bounds of the loop).
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To graph the path, you must convert the points representing the path of the 
skier, which are stored in the point3d array, to a list.

To convert the point3d array to a list:

• At the prompt, enter the following and press ENTER. 
listpoints3d := [seq( convert( point3d[i], list ), i=1..25 )]: 

You will use these lists in the next section.

2.5 Visualization Revisited
The visualization tools in Maple enable you to create different kinds of two- 
and three-dimensional plots in a number of coordinate systems. In addition, 
you can plot more than one element on a single set of axes. First assign the 
individual plots to names, then plot them together by using the display 
command.

To plot the hill and assign it to the name mountain:

• At the prompt, enter the following and press ENTER. Remember to end the 
line with a colon to suppress the output. 
mountain := plot3d(f, x=−3..3, y=−4..4, axes=boxed):

To plot the set of points on the path as a straight line and assign it to 
path3d:

• At the prompt, enter the following and press ENTER. 
path3d := pointplot3d(listpoints3d, style=line, color=white):

To plot the starting point of the skier and assign it to skier:

• At the prompt, enter the following and press ENTER. 
skier := pointplot3d(convert(point3d[1],list), symbol=cross, 
symbolsize=50,color=orange): 

To view all three elements at once: 

• At the prompt, enter the following and press ENTER. 
display(mountain,path3d,skier);

To rotate the surface of the plot to see the path:

1. Click the plot to select it.
2. Place the pointer on the plot.
3. Drag the plot in any direction. The surface rotates.
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Your plot should look similar to that shown in Figure 2-C. For a list of all the 
different types of plots, refer to ?plots (Introduction to the plots package). For 
overview information on plots, refer to ?worksheet,plotinterface (Overview 
of Plotting). For information on different plot options, refer to ?plot,options 
(plot[options]) and ?plot3d,option (plot3d[option]).

Figure 2-C The skier’s starting position, the path, and the hill

Similarly, you can display a contour plot with the skier’s path.
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2.6 Documenting Your Work
You can document the steps you take to solve a problem by adding some text 
to your worksheet. You can then format the text by using predefined styles, or 
defining and using custom styles. In addition, you can insert formatted 
mathematics in your text.

Adding Text
Add a title and text to your worksheet to describe the problem that you are 
solving. You can also add text in other locations in the worksheet to describe 
how you are solving the problem. 

To add a title to your worksheet:

1. Insert a new execution group at the top of the worksheet: place the 
insertion point on the top line, and from the Insert menu, select 
Execution Group, then Before Cursor. 

2. From the Insert menu, select Text to add text rather than a Maple 
command.

3. From the styles drop-down box on the left side of the context bar, select 
Title.

4. Enter the following text as the title of the worksheet. 
The Skier’s Path

5. Insert another execution group after the title. From the Insert menu, 
select Execution Group, then After Cursor.

6. From the Insert menu, select Text.
7. From the styles drop-down box, select Author. Enter your name. Your 

worksheet should resemble that shown in Figure 2-D.
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Figure 2-D Worksheet with a title; context bar for text

It is possible to redefine the styles, for example, alignment, font, and 
underlining. For more information, refer to ?worksheet,documenting,styles 
(Overview of Maple Text Styles).

To add a text description to the worksheet:

1. Place the insertion point on the first input command (the with command).
2. From the Insert menu, select Execution Group, then Before Cursor. A 

new prompt appears.
3. From the Insert menu, select Text to add text.
4. Enter the following sentences. 

A skier has made her way to the top of a mountain. She wants to 
take the steepest path down, which she can find by performing 
the calculations outlined in this worksheet.

To add formatted math to the text:

1. To add another paragraph and a blank line to the worksheet, press ENTER 
twice. 

2. Enter the following text. 
Suppose that the height at a point (x,y) of the hill is given by 
f=3/(1+x^2+y^2)/(1/4+1/2*(x+1)^2+1/2*(y+2)^2), in thousands of 
feet.

3. Highlight the equation. 
4. From the Format menu, select Convert to, then Standard Math. The 

equation appears in standard math notation.
Your worksheet should resemble that shown in Figure 2-E.
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Figure 2-E Text description with formatted math

Structuring the Worksheet with Sections
You can add sections to your worksheet to group various elements. When you 
enclose elements in a section (or indent them), Maple automatically inserts a 
place for a section title. 

To add and title a section:

1. Select the first two paragraphs in the worksheet. (They begin with “A 
skier …” and end with “… in thousands of feet.”)

2. Click  (Indent) on the toolbar. A large range bracket topped by a little 
square appears to the left of the two paragraphs you selected.

3. Click to the right of the  box, and enter the title of the section. 
Problem Description

Compare your worksheet to Figure 2-F on page 22. You can continue to 
document each step in the problem. For more information about sections, refer 
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to ?worksheet,documenting,structuring2 (Structure Worksheets with 
Sections).

Figure 2-F Worksheet with a titled section

Adding Numbers
If you plan to print your worksheet, you may find it useful to add page 
numbers to the bottom of the page.

To add page numbers (centered at the bottom of the page):

1. From the Format menu, select Page Numbers.
2. In the Page Number dialog: 

a) Select the Show Page Numbers check box.
b) Under Vertical location, leave the default selection at Bottom.
c) Under Horizontal location, click Center.
d) Click OK.

For more information about the page number options, refer to 
?worksheet,documenting,pagenumbers (Page Numbers).
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To save your worksheet:

• From the File menu, select Save. If you have not saved it previously, you 
are prompted for a file location and name that ends with .mw (for Maple 
Worksheet). The Maple Classic Worksheet(.mws) option exists for 
cases where the worksheet also needs to be read by older releases of 
Maple; it creates a worksheet in the .mws format.

Note: Maple worksheets use an .mw file extension. Maple 8 and previous 
releases of Maple created worksheets as .mws files. The two formats are 
different, but Maple can open and run both file types. Older worksheets may not 
behave exactly as they do in the release in which they were created because 
improvements to the system sometimes result in different forms of responses.

2.7 Exporting to HTML
You can export your worksheet as an HTML file. (Maple worksheets can also 
be exported to HTML with MathML, LaTeX, Maple text, Plain text, Rich Text 
Format (RTF), Maplet applications, and Maple Input. For more information, 
refer to ?worksheet,managing,export (Export a Worksheet).)

To export a worksheet as HTML:

1. Open the worksheet to export.
2. From the File menu, select Export As. The Export As dialog opens.
3. Specify HTML as the file type.
4. Specify a path and folder for the file.
5. Enter a filename.
6. Click Save. The HTML Options dialog opens.
7. In the Image Subdirectory field, enter the pathname for the directory 

where the exported images are to be saved. Each image is saved in its own 
GIF file. All image directories are relative to the document. The default 
directory is images, and it is located under the same directory that was 
selected for the HTML document.

8. To export the worksheet as an HTML document with frames, select the 
Use Frames check box. If you prefer that the links be at the top of the 
page, separated by a horizontal rule, clear the Use Frames check box.

9. You can export mathematical expressions in various forms. Select GIF 
images, MathML 1.0, MathML 2.0, or MathML 2.0 with WebEQ™.

10.Click OK.

The HTML file is created. You can then open it in your Web browser.
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For more information on how to export worksheets to HTML, refer to 
?worksheet,managing,exportHTML (Export as HTML or HTML with 
MathML). For information on how Maple translates the worksheet to HTML, 
refer to ?worksheet,managing,exporttoHTML (Translation of Maple 
Worksheets to HTML or HTML with MathML).

2.8 Tutors and Assistants
The Maple Student package has a complete set of Tutors and interactive 
routines to assist students with their education demands. For example, the 
Precalculus, Calculus1, and LinearAlgebra subpackages contain Tutors to 
single step through the various concepts presented in these courses. Since 
these Tutors are presented using graphical interfaces, Maplet applications, 
you can single step through a derivative problem or reduce a Matrix by 
applying Gauss-Jordan Elimination rules without viewing or interacting with 
Maple code. Each of the single stepping Tutors come fully equipped with a 
problem status window, the ability to ask for a hint, rule definitions, and 
more. You can quickly analyze concepts in these courses because everything is 
conveniently displayed within one Tutor as opposed to executing numerous 
commands to retrieve the same information.

Figure 2-G Calculus Tangent Tutor
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As the name implies, Maple Assistants are tools designed to assist you with 
various routines. Maple provides graphical interfaces to assist you with unit 
conversion, building plots or matrices, analyzing ODEs, curve fitting, 
optimization, and browsing libraries. 

Figure 2-H Unit Converter Assistant

You can access both the Tutors and Assistants from the Tools menu in the 
Standard Worksheet interface.



26 • Chapter 2: Solving a Problem



3  Getting More Information

Chapter 3: Getting More InformationThis guide is a brief introduction to the Maple program. Maple has many 
other features, such as spreadsheets, a Microsoft® Excel link, and a 
MATLAB® link. To learn more, you can use the Maple help system, read the 
Maple manuals, and access other online resources.

3.1 The Help System1

The Maple program provides a custom help system consisting of almost 4000 
reference pages. The help system is a convenient resource for determining the 
syntax of Maple commands and for learning about the features of the Maple 
program.

Maple Help Pages
The Maple help system opens in a separate window. The window has two 
panes. The left pane contains the Help Navigator, while the right pane 
displays the help page. Most help pages in the Maple program are command 
reference pages, such as the one shown in Figure 3-A on page 28.

1.This manual describes the Standard Worksheet interface help system. For information about 
the Classic Worksheet interface help system, refer to the ?worksheet/reference/HelpGuide 
help page.
27
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Figure 3-A Sample Help page

Table 2: Help System

A Help Page Name
Help page name in square brackets.

B Toolbar 
A toolbar containing shortcut buttons: Print an active worksheet, copy selection 
to clipboard, go back or forward in hyperlink history, go to the parent help page, 
or view the introduction to Maple help page.

C Help Navigator Tabs 
Contents displays a structured list of all topics in the help system. 
Topic reveals a list of matching topics. 
Search reveals a list of topics based on keyword frequency. 
Dictionary Contents displays an alphabetical list of math entries. 
History reveals the last ten help pages visited.

D Topic folders 
A folder icon indicates that a topic can be expanded into subtopics.

E

G

H

B
C

D

I

A

F
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Getting Help
The Maple program provides many ways of accessing the information in the 
help system.

• The ?topic_name help command in a worksheet displays the help page of 
a specified command or topic in the Help system.

• Table of Contents in the worksheet Help menu opens the Help system 
with the Contents tab active in the Help Navigator. 

• Topic Index in the worksheet Help menu opens the Help system with 
the Topic tab active in the Help Navigator.

• Search in the worksheet Help menu opens the Help system with the 
Search tab active in the Help Navigator.

• The worksheet toolbar also contains a Help icon to activate the Help 

system.

Help command    If you know, or can guess, the name of a help page, you can 
access it by using the ?topic_name help command. It is the most direct 
method of obtaining help. To use the help command, at the prompt, enter a 
question mark followed by the command or topic for which you want help and 
press ENTER. Note that you are not required to terminate a help command 
with a semicolon or a colon. For more information, refer to ?help (help).

Help Navigator    The Help Navigator contains five tabs: Contents, Topic, 
Search, Dictionary Contents, and History. Intermediate search results 
are displayed in the Help Navigator pane.

• A folder icon indicates that a topic can be expanded into subtopics.
• Clicking a topic preceded by a bullet displays the associated help page.

E Bullet 
Click a topic preceded by a bullet to open the corresponding help page.

F Description
Brief description of help page.

G Help Page Title
Help page name and a brief description.

H Examples

Sample uses of the Maple command. To copy all the examples, from the Edit 
menu in the Help window, select Copy Examples. You can then paste the 
examples into a worksheet and execute them.

I See Also
Hyperlinks to related topics.

Table 2: Help System
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• Contents displays a structured list of all topics in the help system. For 
more information, refer to ?worksheet,reference,browse (Using the 
Table of Contents in the Help Navigator).

• Topic searches reveal a list of matching topics displayed alphabetically as 
you enter the letters of the search topic word. Topic searches are not case-
sensitive. To search on a topic name, click the Topic tab in the Help 
Navigator. Enter your Topic word. For more information, refer to 
?worksheet,help,topicsearch (Perform a Topic Search).

• Search reveals a list of topics based on keyword frequency. With this 
search, you can search on more than one word. Results include pages that 
contain all the words listed in the search. Searches are not case-sensitive. 
To display a list of topics based on keyword frequency, click the Search 
tab in the Help Navigator. Enter your word(s) and press ENTER. For more 
information, refer to ?worksheet,help,fulltextsearch (Perform a 
Search).

• History lists the last ten help pages visited, which can include pages from 
previous Maple sessions. Note that these pages are included only if 
available based on libname.

For additional information about the Help system, refer to 
?worksheet,reference,HelpGuide (Using Help). 

For information on the Dictionary Contents tab, see the following section.
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The Math Dictionary
You can find over 5000 mathematical entries in your Maple 9.5 Math 
Dictionary. The definitions can be accessed as general help pages, by viewing 
an alphabetical listing in the Dictionary Contents of the Maple help system, 
or through links in worksheets and help pages. Definitions in the Standard 
Worksheet interface include over 300 figures and equations are formatted 
using Standard Math or Maple output. Also, when you access a definition 
through a worksheet or help page link, short definitions are conveniently 
displayed as pop-ups (Standard Worksheet interface only).

Figure 3-B Math Dictionary Sample Page
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3.2 Manual Set
The Maple software comes with the following manuals.

3.3 Tutorials
Maple provides three tutorials that can be accessed from the New Users 
submenu of the Help menu: Full Tour, Quick Tour, and Basic How To. 
Each tutorial is an active worksheet and as such opens in a worksheet 
window.

Title Content

Maple Getting Started 
Guide

This guide contains an introduction to the 
graphical user interface and a tutorial that 
outlines using Maple to solve mathematical 
problems and create technical documents. It also 
contains additional information for new users 
about the help system, New User's Tour, example 
worksheets, and Maplesoft™ Web site.

Maple Learning Guide This guide explains how Maple and the Maple 
language work. It describes the most important 
commands and uses them to solve technical 
problems. User hints for Maplet applications are 
also described in this guide.

Maple Introductory 
Programming Guide1

1. The Student Edition does not include the Maple Introductory Programming Guide 
and the Maple Advanced Programming Guide. These programming guides can be 
purchased from school and specialty bookstores or directly from Maplesoft.

This guide introduces the basic Maple 
programming concepts, such as expressions, data 
structures, looping and decision mechanisms, 
procedures, input and output, debugging, and the 
Maplet User Interface Customization System.

Maple Advanced 
Programming Guide1

This guide extends the basic Maple programming 
concepts to more advanced topics, such as modules, 
input and output, numerical programming, 
graphics programming, and compiled code.



3.4  Example Worksheets • 33
• When you select the Full Tour menu item, the New User’s Tour opens. 
This tour is a set of interactive worksheets that you can use to learn about 
the Maple program. The worksheets present commands that every user 
should know. The tour covers many areas of the Maple program, such as 
the worksheet environment, numerical calculations, algebraic 
computations, graphics, calculus, differential equations, linear algebra, 
finance and statistics, programming, and the Maple help system. The 
New User’s Tour is easy to follow and a single topic takes approximately 
15 minutes to complete.

• When you select the Quick Tour menu item, the Quick New User’s 
Tour worksheet opens. This worksheet is a subset of the Full Tour. You 
can execute the worksheet or simply glance at the content. The tour takes 
approximately 10 minutes to complete.

• When you select the Basic How To menu item, the How to Perform 
Basic Tasks worksheet opens. This worksheet serves as a review of 
common commands and guidelines for using the Maple program. You may 
choose to return to this reference in future Maple program sessions.

3.4 Example Worksheets
The example worksheets (about 100) contain examples from the Maple 
programming language and from many different areas of mathematics, such 
as algebra, geometry, discrete mathematics, integration, integral transforms, 
differential equations, general symbolics, general numerics, and 
mathematical visualization.

To see the contents of the set of example worksheets:

• At the prompt, enter ?examples,index and press ENTER.

3.5 Web Sites
The Maplesoft Web site has information on products, support, and services. 

To visit the Maplesoft Web site:

• In your Web browser, enter this URL: 
www.maplesoft.com, or
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• From the Help menu in your Maple worksheet, select Maple on the 
Web, and Product & Company Info.

The Maple Application Center™ includes a forum for sharing solutions, 
complete course curricula, and online tutorials.

To visit the Maple Application Center Web site:

• In your Web browser, enter this URL: 
www.mapleapps.com, or

• From the Help menu in your Maple worksheet, select Maple on the 
Web, and Maple Application Center.

The Maple Student Center™ includes course help, Maple tutorials, and Maple 
graphics.

To visit the Maple Student Center Web site:

• In your Web browser, enter this URL: 
www.maple4students.com, or

• From the Help menu in your Maple worksheet, select Maple on the 
Web, and Student Center.
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formatted math, 20–21
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new worksheet, 9
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partial derivatives, 13
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adding axes, 11
contour, 14
entering, 11
name assignments, 17
options, 17–18
rotating, 12, 17

plots package, 10
positioning page numbers, 22
Programming Guides

Advanced, 32
Introductory, 32

prompt, 4, 19–20

Q
question mark (?) command, 4, 29
Quick New User’s Tour, 33

R
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range of plot axes, 11
reference pages, 27
right-click menus, 11
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RTF, 23
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saving worksheets, 23
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in a worksheet, 21–22
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semicolon (;) terminator, 6
sets, 13
shortcut buttons. See buttons
shortcut menus, 11
Standard

worksheet interface, 1
Standard Math Notation, 3–6
starting Maple, 1–2
Student Center, 34
symbolic solutions, 1
Symbol palette, 4–6
syntax of commands, 5
system of equations, solving, 13
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text entry, 19–21
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main window, 3, 20, 28

tutorials
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full tour, 33
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quick tour, 33

Tutors, 24
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Application Center Web site, 34
Maplesoft Web site, 33
Student Center Web site, 34

user interface elements, 2
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versions, 1

W
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with command, 9–10, 20
word processing. See text entry
worksheets

adding text, 19
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exporting to HTML, 23
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saving, 23
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