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1  Introduction to Maple

Chapter 1: Introduction to MapleMaple™ is an analytic computation system. It performs mathematical 
computations and manipulations for solving problems from various technical 
disciplines. Most significantly, Maple computes both numerical as well as 
symbolic solutions to mathematical expressions. This means that Maple 
performs computations on expressions that contain symbols, such as π or x, 
without performing numerical approximations. For example, Maple 
determines that the derivative of ������ is ������, even when � has not been 
assigned a value. Maple provides exact solutions to many technical problems. 
In addition, Maple has visualization tools that contribute to the problem-
solving process. 

1.1 Installing Maple
For installation and licensing instructions, refer to the 	��
���
�
� file on 
your Maple CD.

1.2 Starting Maple
You can access the power of the Maple computation engine through a variety 
of user interfaces: the standard worksheet, the command-line version, the 
classic worksheet (not available on Macintosh®), and custom-built Maplet™ 
applications. The full Maple system is available through all of these 
interfaces. In this manual, any references to the graphical Maple interface 
refer to the standard worksheet interface. For more information on the 
various interface options, refer to the ��������� help page.
1
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To start the standard worksheet interface in Windows®:

• From the Start menu, select Programs, Maple 9, Maple 9. 
Alternatively, double-click the Maple 9 desktop icon.

To start the standard worksheet interface on a Macintosh computer:

• Double-click the Maple 9 application icon in the Finder.

To start the standard worksheet interface in UNIX® or Linux®:

• Enter the full path, for example, 
��������������������������� 
Alternatively,

1. Add your Maple 9 directory (for example, ��������������������) to your 
command search path.

2. Enter ������.

On all operating systems, the first Maple worksheet session opens with the 
Introduction to Maple 9 page that points you to the New User’s Tour, updates, 
and other introductory help pages. Subsequent worksheet sessions start with 
a new, blank worksheet.

1.3 The Maple Worksheet Window
The Maple worksheet window resembles that of a typical program. The main 
features are shown in Figure 1-A on page 3. 
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Figure 1-A Maple window features

Table 1: Maple Worksheet Interface

A Toolbar 
A toolbar containing shortcut buttons.

B Context bar 
A toolbar containing context-sensitive shortcut buttons. (The buttons change 
based on the cursor location or selection.) It can also contain a field for editing 
and entering text.

C Section heading 
The name or title of a section.

D Maple input 
A mathematical expression or command that Maple evaluates. By default, input 
commands are entered at the prompt, “>”, and are displayed in red type. The 
resulting output is displayed beneath.

A
B

E

C
D

F

G

H

J

K

L

I
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1.4 Accessing Help Pages
The commands and features in Maple are documented in help pages. To view 
help pages, at the prompt, enter a question mark (�) followed by the name of 
the command or subject on which you want help. Do not enter any spaces. For 
example, to refer to the help page on natural logarithms, enter ���. For 
information on different ways to access help, see The Help System on page 25.

E Maple output 
The result of an executed Maple input command. By default, Maple output is 
displayed in blue type in Standard Math Notation.

F Execution group 
A set of Maple input with its corresponding output.

G Section range bracket 
A line that encloses the elements of a section.

H Prompt 
By default, the Maple prompt is a greater-than ( > ) symbol that indicates where 
to enter Maple input.

I Symbol palette 
A collection of buttons for entering mathematical symbols in Maple.

J Expression palette 
A collection of templates for entering mathematical expressions in Maple.

K Matrix palette 
A collection of templates for entering matrices in Maple.

L Vector palette 
A collection of templates for entering vectors in Maple.

Table 1: Maple Worksheet Interface
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1.5 Entering Expressions in Maple
To enter expressions at the prompt, use the keyboard, the palettes, or both. 
Using the keyboard is the most direct method, but the palettes enable you to 
enter a command without knowing its syntax.

There are two types of input display. Use Maple Notation to display input as 
Maple syntax. Maple Notation is the default. Use Standard Math Notation 
to display input in typeset notation as it appears in a textbook.

These examples step you through entering and evaluating  in 

various ways.

To enter and evaluate the integral in Standard Math Notation by using the 
palettes:

1. Display the palettes, if necessary. From the View menu, select Palette, 
then Show All. The Symbol, Expression, Matrix, and Vector palettes are 
displayed. 

2. If required, change the input to Standard Math Notation. (If there is a 
question mark (?) after the prompt, the input is already set to Standard 
Math Notation.) If there is no ?, at the prompt, right-click. (For Macintosh, 
if you are using a single-button mouse, command-click.) A context-
sensitive menu is displayed. Select Standard Math.

3. On the Expression palette, click . The integral symbol appears, and 

the question mark placeholder is selected.

4. On the Expression palette, click . The function sin appears, with 
another placeholder. 

5. Enter � (on the keyboard), and press TAB to go to the next placeholder.
6. Repeat step 5.
7. Enter � (zero), and press TAB.

8. On the Symbol palette, click . (It is in the bottom row.)

9. Press ENTER. Maple inserts the integral in Standard Math Notation, and 
then evaluates the integral.

Your worksheet should resemble that shown in Figure 1-B on page 6. 

x( )sin xd
0

π

∫
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Figure 1-B Integral input in Standard Math Notation

The next example shows you how you can use the palettes to enter the 
expression and learn the Maple command syntax at the same time.

To enter and evaluate the integral in Maple Notation by using the palettes:

1. On the Expression palette, click . The integration command ��
 

appears, and the %? placeholder is selected.

2. On the Expression palette, click . The mathematical function sin 

appears, with another placeholder. 
3. Enter � (on the keyboard), and press TAB to go to the next placeholder.
4. Repeat step 5.
5. Enter � (zero), and press TAB.

6. On the Symbol palette, click . (It is in the bottom row.)

7. Press ENTER. Maple inserts the integral in Maple Notation, and then 
evaluates the integral.

Note: Maple appends a semicolon to the end of the command. This signifies the 
end of the statement.
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Your worksheet should resemble that shown in Figure 1-C.

Figure 1-C Integral input in Maple Notation

Now that you know the correct notation, you can enter the expression at the 
prompt. For more information on entering expressions, see the examples in 
the next chapter and refer to ���������
���������������
����� (Enter 
Expressions in Maple). For more information on using palettes, refer to 
���������
�����������������

�� (Overview of Palettes).

For the rest of this guide, it is assumed that you are entering expressions in 
Maple Notation.
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2  Solving a Problem

Chapter 2: Solving a ProblemThis chapter presents a mathematical problem with its solution. The 
discussion of the problem and its solution introduces you to key features of the 
Maple program.

Note: When entering Maple commands, keep in mind that they are case-
sensitive.

2.1 Scenario
A skier has made her way to the top of a mountain. She wants to take the 
steepest path down, which she can find by performing the calculations 
outlined in this chapter. Start by opening a new worksheet for this problem.

To open a new worksheet:

• From the File menu, select New.

2.2 Commands in Packages
Some of the commands used in the discussion are found in packages whereas 
the top-level commands are not. A package is a group of routines related to a 
particular area of mathematics. You can always access commands in packages 
by using the long form, that is, specifying both package and function name: 
�����������������
�������� �


�, but to be able to use the short form, 
that is, specify only the function name, use the ��
� command first.
9
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To access commands in the ����� package:

• At the prompt, enter the following and press ENTER. 
��
�����
��!

After executing the command, Maple lists any warnings, followed by all of the 
commands that are included in the package. For the ���
� package, a 
warning indicates that the name of one of the commands in the package, 
����������"�, is the same as that of a top-level command. After executing the 
��
� command, the name ����������"� refers to the package command 
���
������������"�  instead of the top-level ����������"� command. To use 
the top-level command1, you must first clear the Maple internal memory 
using the ���
��
 command. For more information, refer to the ����
��
 help 
page. 

For other methods of accessing commands in packages, refer to Chapter 4, 
“Maple Structure and Packages,” in the Maple Learning Guide. For a list of all 
the packages in Maple, refer to ���"����������� (Index of descriptions for 
packages of library functions).

2.3 Math and Visualization
Use mathematical and visualization commands to determine basic properties 
of the hill. For more information on any of the commands used here, enter a 
question mark, followed by the name of the command. For example, to find 
help on the exponential command, enter ���� (The Expontential Function).

Suppose that the height at a point ���#� of the hill is given by �, in thousands 
of feet.

 
To enter the expression in Maple:

• At the prompt, enter the following and press ENTER: 
�$%&$'��()�*+)#*+���(�,)(�+-��)(�*+)(�+-�#)+�*+�!

1. For more information about using a top-level command in this context, refer to the ������(with) 
help page.

f
3

1 x2 y2+ +( ) 1
4
---

x 1+( )2

2
-------------------

y 2+( )2

2
-------------------+ + 

 
---------------------------------------------------------------------------------------------=



2.3  Math and Visualization • 11
The expression for the shape of the hill is assigned to the name � by means of 
the assignment operator “:=” so that it can be referred to in subsequent 
calculations. For more information about assignments, refer to ����������
 
(The assignment statement). For more information about names, refer to 
������ (Names).

Plotting the Hill
Before solving the problem, it is helpful to get an idea of the appearance of the 
hill (and an idea of the answer). 

To plot the expression:

1. Right-click the output of the expression (for Macintosh, command-click). 
The context-sensitive menu is displayed.

2. Select Plots, 3-D Plot, then x,y. Maple inserts the plot into the 
worksheet.

Note: The content of context-sensitive menus varies depending on the cursor 
location or selected expression. For more information, refer to 
���������
���������������������
���� (Use Context-Sensitive Menus 
to Manipulate Expressions).

To add axes:

1. Right-click the plot (for Macintosh, command-click).
2. Select Axes, then Boxed.

To modify the axis ranges:

1. Right-click the plot (for Macintosh, command-click), select Axes, then 
Range.

2. In the Axis Ranges dialog:
a) Under X axis, click the button beside the range boxes. Enter a range 

of −� to �.
b) Similarly, under the Y axis, enter a range of −� to �.
c) Click OK.

The visualization tools in Maple enable you to see the surface from more than 
one angle.

To rotate the surface:

1. Click the plot to select it.
2. Place the pointer on the plot.
3. Drag the plot in any direction. The surface rotates.
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Depending on how you rotated the plot, it may look similar to Figure 2-A.

Figure 2-A Plot of the hill

While you can look at the surface and guess what the highest point (peak) is, 
you can obtain a more precise answer by using calculus.

Finding the Maximum Point of the Surface
Determine the location of the top of the hill by taking partial derivatives, 
setting them to �, and solving for � and #.

To find the partial derivative of 	 with respect to 
:

• At the prompt, enter the following and press ENTER.  
��$%&$"��������!
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To find the partial derivative of 	 with respect to �:

• At the prompt, enter the following and press ENTER. 
�#$%&$"������#�!

Since you are interested in the real-valued solution, use the ������ command 
instead of the more general ����� command. For more information, refer to 
the ������� (fsolve) and ������ (solve) help pages.

To solve the system of equations �	

���	�
��:

• At the prompt, enter the following and press ENTER. 

����#$%&$�������.��&���#&�/�.��#/�.�&0'

��#&0'

�/�!

The numerical result .�$&$−
1�+2(��(11� 
#$&$0(
3�4++��,�/ is an approximation of the x- and y-values of the peak.

Note: Sets do not preserve order, so you may instead obtain the equivalent set:  
{ #$&$−(
3�4++��,��$�$& −
1�+2(��(11/.

Finding the Skier’s Starting Point
Assume that the skier does not start at the peak but slightly to the side. To 
approximate this location, add a small factor, say �
�4, to the �0 and #0values 
of the highest point. Assign the peak values to the variables � and # and then 
add the small factor.

To assign the values to the variables:

• At the prompt, enter the following and press ENTER. 
�������5�!

The ditto operator (%) refers to the result of the previous computation. For 
more information, refer to �5 (The ditto operators).

To define the starting �0 and #0values, �($and$#(,$respectively:

• At the prompt, enter the following and press ENTER. 
�(%&�)�
�4! 
#(%&#)�
�4!

The names � and # have values assigned to them. To use � and # as variables 
in the following calculations, they must be first unassigned. For more 
information on unassigning, refer to the ������� (Unevaluated expressions) 
help page.

To unassign � and #:

• At the prompt, enter the following and press ENTER. 
�%&6�6! 
#%&6#6!
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To find the �-coordinate of the starting point:

• Evaluate the function representing the hill at the �0 and #0values 
representing the starting point (�(�#(). At the prompt, enter the following 
and press ENTER. 
7(%&�������.�&�(�#&#(/�!

The numerical result {�($&0
34+2(��(11$�$#($&$0(
844++��,��$7($&$
+
(,42'(,4'/ is an approximation of the skier’s starting point.

Finding the Path Down
Before you find the path, take a look at the level curves of the hill to get an 
idea of the skier’s path.

To plot the level curves:

• The ���
������
 command (in the ���
� package) with five contours 
suggests an interesting shape, as shown in Figure 2-B. At the prompt, 
enter the following command and press ENTER. 
���
������
���$�&−+

(�$#&−'

(�$���
����&4�$�����"&
����! 

Figure 2-B Level curves of the hill 
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2.4 Using a For Loop—Finding the Path
Next, construct and plot the path on the surface of the hill that the skier 
should take. The negative of the gradient (−∇ ����#�$or$−���"�����#�� in the 
Maple language), gives the � and #$components of the direction of steepest 
descent. At each point ���#�7� on the surface, the skier must travel in the 
direction of −∇ ����#�, while staying on the surface. Since −∇ ����#� changes 
from point to point, you can break the process into steps, building an 
approximation of the path of steepest descent. If the step size is too large, the 
path may leave the surface of the hill. If the step size is too small, you derive 
no benefit from the increased number of calculations.

Performing the Initialization
Assume that the skier is currently at the starting point (�(�#(�7(). Use a 
timestep of 0.1 and find 25 points along the path. Use the arrays ����
'" and 
���
�'" to store the values of the computed points and the direction taken, 
respectively. To simplify the calculation of the points and route, define vector 
representations of the expressions for the hill and the derivatives with respect 
to both � and #.

To define vector representations of the expressions:

• At the prompt, enter the following and press ENTER. 
�%&�������.�&9�( �#&9�+ /�! 
��%&��������.�&9�( �#&9�+ /�! 
�#%&������#�.�&9�( �#&9�+ /�!

To declare the arrays for storing the values at each timestep:

• At the prompt, enter the following and press ENTER. 
����
'"%&:���#�(

+4�! 
���
�'"%&:���#�(

+4�!

To define the initialization:

• At the prompt, enter the following and press ENTER. 

����
��%&�
(! 
����
'"�( %&;�(�#(�7(<!

Note: The notation ;�(�#(�7(< defines a Vector while P[i] accesses the ith 
element of the list P. For more information about Vectors, refer to �=��
�� 
(Vector - construct a Vector). For more information about lists, refer to ����
� 
(Sets and Lists).
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Specifying the For Loop
To obtain the additional 24 points, use a ��� loop. A ��� loop repeatedly 
executes a sequence of Maple commands entered between the "� and ��"$"�$
commands of the loop, that is, in the loop body. It executes the commands as 
the value of a numeric variable, called an index, varies from its specified 
initial value to its specified final value. The value of the index is incremented 
after each execution of the commands in the body of the loop. The iteration 
stops when the value of the index is greater than the specified final value. For 
information on other programming structures in Maple, refer to the Maple 
Introductory Programming Guide.

To start the 	�� loop:

• At the prompt, enter the following and press SHIFT+ENTER. 
���$�$����$($
�$+,$"�

Note: If you press ENTER, Maple returns the message: “Warning, premature end 
of input, use <Shift> + <Enter> to avoid this message”. The ��� statement is not 
complete. You must use SHIFT+ENTER to go to the next line.

The body of the ��� loop comprises the next commands. These commands find 
the skier’s position at the end of each time step.

To construct the 3-D normalized negative of the gradient vectors:

• On the next line, enter the following and press SHIFT+ENTER. 
���
�'"�� $%&$>�����:�������?������7� ������;0���0�#��<�$
9&����
'"�� ��!

To find the next point in the skier’s path:

• On the next line, enter the following and press SHIFT+ENTER. 
����
'"��)( $%&$
�����;9�( �9�+ ��<�9&����
'"�� )
����
��-���
�'"�� �!

To complete the 	�� loop:

• On the next line, enter the following and press ENTER. Remember to end 
the line with a colon to suppress the output. 
��"$"�%

This command ends the ��� loop. After you press ENTER, the five commands in 
the loop body are repeated 24 times. At the end of each iteration, the value of � 
is increased by 1. That is, for the first iteration, the value of � is its initial 
value 1, for the second 2, and so on. For the last iteration the value of � is 24. 
Maple exits at the end of the 24th iteration once � is set to 25 (since 25 is 
outside of the bounds of the loop).
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To graph the path, you must convert the points representing the path of the 
skier, which are stored in the ����
'" array, to a list.

To convert the ������� array to a list:

• At the prompt, enter the following and press ENTER. 
���
����
�'"$%&$���@�$������
�$����
'"�� �$���
$��$�&(

+4$� % 

You will use these lists in the next section.

2.5 Visualization Revisited
The visualization tools in Maple enable you to create different kinds of two- 
and three-dimensional plots in a number of coordinate systems. In addition, 
you can plot more than one element on a single set of axes. First assign the 
individual plots to names, then plot them together by using the "�����# 
command.

To plot the hill and assign it to the name ��������:

• At the prompt, enter the following and press ENTER. Remember to end the 
line with a colon to suppress the output. 
����
���$%&$���
'"���$�&−'

'�$#&−,

,�$����&����"�%

To plot the set of points on the path as a straight line and assign it to 
������:

• At the prompt, enter the following and press ENTER. 
��
�'"$%&$����
���
'"����
����
�'"�$�
#��&�����$�����&��"�%

To plot the starting point of the skier and assign it to �����:

• At the prompt, enter the following and press ENTER. 
�����$%&$����
���
'"�������
�����
'"�( ����
��$�#����&������$
�#������7�&4�������&#������% 

To view all three elements at once: 

• At the prompt, enter the following and press ENTER. 
"�����#�����
����$������$��
�'"�!

To rotate the surface of the plot to see the path:

1. Click the plot to select it.
2. Place the pointer on the plot.
3. Drag the plot in any direction. The surface rotates.
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Your plot should look similar to that shown in Figure 2-C. For a list of all the 
different types of plots, refer to ����
�$(Introduction to the plots package). For 
overview information on plots, refer to ���������
����
��
������ (Overview 
of Plotting). For information on different plot options, refer to ����
���
����$
(plot[options]) and ����
'"���
��� (plot3d[option]).

Figure 2-C The skier’s starting position, the path, and the hill

Similarly, you can display a contour plot with the skier’s path.
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2.6 Documenting Your Work
You can document the steps you take to solve a problem by adding some text 
to your worksheet. You can then format the text by using predefined styles, or 
defining and using custom styles. In addition, you can insert formatted 
mathematics in your text.

Adding Text
Add a title and text to your worksheet to describe the problem that you are 
solving. You can also add text in other locations in the worksheet to describe 
how you are solving the problem. 

To add a title to your worksheet:

1. Insert a new execution group at the top of the worksheet: place the 
insertion point on the top line, and from the Insert menu, select 
Execution Group, then Before Cursor. 

2. Click  (or from the Insert menu, select Text) to add text rather than 
a Maple command.

3. From the styles drop-down box on the left side of the context bar, select 
Title.

4. Enter the following text as the title of the worksheet. 
A��$B����6�$9�
�

5. Insert another execution group after the title. From the Insert menu, 
select Text.

6. From the styles drop-down box, select Author. Enter your name.
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Figure 2-D Worksheet with a title; context bar for text

It is possible to redefine the styles (alignment, font, underlining, and so on). 
For more information, refer to ���������
�"������
�����
#��� (Overview of 
Maple Text Styles).

To add a text description to the worksheet:

1. Place the insertion point on the first input command (the ��
� command).
2. From the Insert menu, select Execution Group, then Before Cursor. A 

new prompt appears.

3. Click  (or from the Insert menu, select Text) to add text.

4. Enter the following sentences. 
:$�����$���$��"�$���$��#$
�$
��$
��$��$�$����
���
$B��$���
�$
�$

���$
��$�
�����
$��
�$"����$�����$���$���$���"$�#$����������$

��$�������
����$��
����"$��$
���$��������



To add formatted math to the text:

1. To add another paragraph and a blank line to the worksheet, press ENTER 
twice. 

2. Enter the following text. 
B������$
��
$
��$�����
$�
$�$����
$���#�$��$
��$����$��$�����$�#$
�&'��()�*+)#*+���(�,)(�+-��)(�*+)(�+-�#)+�*+��$��$
������"�$��$
���



3. Highlight the equation. 
4. From the Format menu, select Convert to, then Standard Math. The 

equation appears in standard math notation.
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Your worksheet should resemble that shown in Figure 2-E.

Figure 2-E Text description with formatted math

Structuring the Worksheet with Sections
You can add sections to your worksheet to group various elements. When you 
enclose elements in a section (or indent them), Maple automatically inserts a 
place for a section title. 

To add and title a section:

1. Select the first two paragraphs in the worksheet. (They begin with “A 
skier …” and end with “… in thousands of feet.”)

2. Click  (Indent) on the toolbar. A large range bracket topped by a little 
square appears to the left of the two paragraphs you selected.

3. Click to the right of the  box, and enter the title of the section. 
9������$C������
���

Compare your worksheet to Figure 2-F on page 22. You can continue to 
document each step in the problem. For more information about sections, refer 
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to ���������
�"������
�����
���
�����+ (Structure Worksheets with 
Sections).

Figure 2-F Worksheet with a titled section

Adding Numbers
If you plan to print your worksheet, you may find it useful to add page 
numbers to the bottom of the page.

To add page numbers (centered at the bottom of the page):

1. From the Format menu, select Page Numbers.
2. In the Page Number dialog: 

a) Select the Show Page Numbers check box.
b) Under Vertical location, leave the default selection at Bottom.
c) Under Horizontal location, click Center.
d) Click OK.

For more information about the page number options, refer to 
���������
�"������
���������������$(Page Numbers).
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To save your worksheet:

• From the File menu, select Save. If you have not saved it previously, you 
are prompted for a file location and name that ends with 
�� (for Maple 
worksheet). The Save As Maple 8 Worksheet(.mws) option exists for 
cases where the worksheet also needs to be read by older releases of 
Maple; it creates a worksheet in the 
���$format.

Note: Maple worksheets use an 
��$file extension. Previous releases of Maple 
created worksheets as 
��� files. The two formats are different, but Maple can 
open and run both file types. Older worksheets may not behave exactly as they do 
in the version in which they were created because improvements to the system 
sometimes result in different forms of responses.

2.7 Exporting to HTML
You can export your worksheet as an HTML file. (Maple worksheets can also 
be exported to HTML with MathML, LaTeX, Maple text, Plain text, Rich Text 
Format (RTF), Maplet applications, and Maple Input. For more information, 
refer to ���������
���������������
 (Export a Worksheet).)

To export a worksheet as HTML:

1. Open the worksheet to export.
2. From the File menu, select Export As. The Export As dialog opens.
3. Specify HTML as the file type.
4. Specify a path and folder for the file.
5. Enter a filename.
6. Click Export. The HTML Options dialog opens.
7. In the Image Subdirectory field, enter the pathname for the directory 

where the exported images are to be saved. Each image is saved in its own 
GIF file. All image directories are relative to the document. The default 
directory is images, and it is located under the same directory that was 
selected for the HTML document.

8. To export the worksheet as an HTML document with frames, select the 
Use Frames check box. If you prefer that the links be at the top of the 
page, separated by a horizontal rule, clear the Use Frames check box.

9. You can export mathematical expressions in various forms. Select GIF 
images, MathML1.0, MathML2.0, or MathML2.0 with WebEQ™.

10.Click OK.

The HTML file is created. You can then open it in your Web browser.
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For more information on how to export worksheets to HTML, refer to 
���������
���������������
DAE> (Export as HTML or HTML with 
MathML). For information on how Maple translates the worksheet to HTML, 
refer to ���������
���������������

�DAE> (Translation of Maple 
Worksheets to HTML or HTML with MathML).
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Chapter 3: Getting More InformationThis guide is a brief introduction to the Maple program. Maple has many 
other features, such as spreadsheets, a Microsoft® Excel link, and a 
MATLAB® link. To learn more, you can use the Maple help system, read the 
Maple manuals, and access other online resources.

3.1 The Help System1

The Maple program provides a custom help system consisting of almost 4000 
reference pages. The help system is a convenient resource for determining the 
syntax of Maple commands and for learning about the features of the Maple 
program.

Maple Help Pages
The Maple help system opens in a separate window. The window has two 
panes. The left pane contains the Help Navigator, while the right pane 
displays the help page. Most help pages in the Maple program are command 
reference pages, such as the one shown in Figure 3-A on page 26.

1.This manual describes the standard worksheet interface help system. For information about the 
classic worksheet interface help system, refer to the ����������	��
������	
�������� help 
page.
25
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Figure 3-A Sample Help page

Table 2: Help System

A Help Page Name
Help page name in square brackets.

B Toolbar 
A toolbar containing shortcut buttons: Print an active worksheet, copy selection 
to clipboard, go back or forward in hyperlink history, go to the parent help page, 
or view the introduction to Maple help page.

C Help Navigator Tabs 
Contents displays a structured list of all topics in the help system. 
Topic reveals a list of matching topics. 
Search reveals a list of topics based on keyword frequency. 
History reveals the last ten help pages visited.

D Topic folders 
A folder icon indicates that a topic can be expanded into subtopics.

E Bullet 
Click a topic preceded by a bullet to open the corresponding help page.

E

G

H

B
C

D

I

A

F
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Getting Help
The Maple program provides many ways of accessing the information in the 
help system.

• The �
��������� help command in a worksheet displays the help page of 
a specified command or topic in the Help system.

• Table of Contents in the worksheet Help menu opens the Help system 
with the Contents tab active in the Help Navigator. 

• Topic Index in the worksheet Help menu opens the Help system with 
the Topic tab active in the Help Navigator.

• Search in the worksheet Help menu opens the Help system with the 
Search tab active in the Help Navigator.

• The worksheet toolbar also contains a Help icon to activate the Help 

system.

Help command    If you know, or can guess, the name of a help page, you can 
access it by using the �
��������� help command. It is the most direct 
method of obtaining help. To use the help command, at the prompt, enter a 
question mark followed by the command or topic for which you want help and 
press ENTER. Note that you are not required to terminate a help command 
with a semicolon or a colon. For more information, refer to ����� (help).

Help Navigator    The Help Navigator contains four tabs: Contents, Topic, 
Search, and History. Intermediate search results are displayed in the Help 
Navigator pane.

• A folder icon indicates that a topic can be expanded into subtopics.
• Clicking a topic preceded by a bullet displays the associated help page.

F Description
Brief description of help page.

G Help Page Title
Help page name and a brief description.

H Examples

Sample uses of the Maple command. To copy all the examples, from the Edit 
menu in the Help window, select Copy Examples. You can then paste the 
examples into a worksheet and execute them.

I See Also
Hyperlinks to related topics.

Table 2: Help System
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• Contents displays a structured list of all topics in the help system. For 
more information, refer to ���������
����������������� (Using the 
Table of Contents in the Help Navigator).

• Topic searches reveal a list of matching topics displayed alphabetically as 
you enter the letters of the search topic word. Topic searches are not case-
sensitive. To search on a topic name, click the Topic tab in the Help 
Navigator. Enter your Topic word. For more information, refer to 
���������
������
���������� (Perform a Topic Search).

• Search reveals a list of topics based on keyword frequency. With this 
search, you can search on more than one word. However, the results may 
include pages that contain only one of the words listed in the search, and 
not all of them. Searches are not case-sensitive. To display a list of topics 
based on keyword frequency, click the Search tab in the Help Navigator. 
Enter your word(s) and press ENTER. For more information, refer to 
���������
����������
��
������ (Perform a Search).

• History lists the last ten help pages visited, which can include pages from 
previous Maple sessions. Note that these pages are included only if 
available based on libname.

For additional information about the Help system, refer to 
���������
�����������D���F��"� (Using Help).

3.2 Manual Set
The Maple software comes with the following manuals.

Title Content

Maple 9 Getting Started 
Guide

This guide contains an introduction to the 
graphical user interface and a tutorial that 
outlines using Maple to solve mathematical 
problems and create technical documents. It also 
contains additional information for new users 
about the help system, New User's Tour, example 
worksheets, and Maplesoft™ Web site.

Maple 9 Learning Guide This guide explains how Maple and the Maple 
language work. It describes the most important 
commands and uses them to solve technical 
problems. User hints for Maplet applications are 
also described in this guide.
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3.3 Tutorials
Maple provides three tutorials that can be accessed from the New User 
submenu of the Help menu: Full Tour, Quick Tour, and Basic How To. 

• When you select the Full Tour menu item, the New User’s Tour opens. 
This tour is a set of interactive worksheets that you can use to learn about 
the Maple program. The worksheets present commands that every user 
should know. The tour covers many areas of the Maple program, such as 
the worksheet environment, numerical calculations, algebraic 
computations, graphics, calculus, differential equations, linear algebra, 
finance and statistics, programming, and the Maple help system. The 
New User’s Tour is easy to follow and a single topic takes approximately 
15 minutes to complete.

• When you select the Quick Tour menu item, the Quick New User’s 
Tour worksheet opens. This worksheet is a subset of the Full Tour. You 
can execute the worksheet or simply glance at the content. The tour takes 
approximately 10 minutes to complete.

• When you select the Basic How To menu item, the How to Perform 
Basic Tasks worksheet opens. This worksheet serves as a review of 
common commands and guidelines for using the Maple program. You may 
choose to return to this reference in future Maple program sessions.

Maple 9 Introductory 
Programming Guide1

This guide introduces the basic Maple 
programming concepts, such as expressions, data 
structures, looping and decision mechanisms, 
procedures, input and output, debugging, and the 
Maplet User Interface Customization System.

Maple 9 Advanced 
Programming Guide1

This guide extends the basic Maple programming 
concepts to more advanced topics, such as modules, 
input and output, numerical programming, 
graphics programming, and compiled code.

1. The Student Edition does not include the Maple 9 Introductory Programming Guide 
and the Maple 9 Advanced Programming Guide. These programming guides can be 
purchased from school and specialty bookstores or directly from Maplesoft.

Title Content



30 • Chapter 3: Getting More Information
To access the tutorials:

• From the Help menu, select New User and then Full Tour, Quick 
Tour, or Basic How To. Each tutorial is an active worksheet and as such 
opens in a worksheet window.

3.4 Example Worksheets
The example worksheets (about 100) contain examples from the Maple 
programming language and from many different areas of mathematics, such 
as algebra, geometry, discrete mathematics, integration, integral transforms, 
differential equations, general symbolics, general numerics, and 
mathematical visualization.

To see the contents of the set of example worksheets:

• At the prompt, enter ������������"�� and press ENTER.

3.5 Web Sites
The Maplesoft Web site has, among other things, information on products, 
support, and services. 

To visit the Maplesoft Web site:

• In your Web browser, enter this URL: 
���
��������

���, or

• From the Help menu in your Maple 9 worksheet, select Maple on the 
Web, and Product and Company Info.

The Maple Application Center™ includes a forum for sharing solutions, 
demonstrations of Maple PowerTools, and an online tutorial.

To visit the Maple Application Center Web site:

• In your Web browser, enter this URL: 
���
���������
���, or

• From the Help menu in your Maple 9 worksheet, select Maple on the 
Web, and Maple Application Center.

The Student Center includes course help, Maple tutorials, and Maple 
graphics.
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To visit the Student Center Web site:

• In your Web browser, enter this URL: 
���
�����,�
�"��
�
���, or

• From the Help menu in your Maple 9 worksheet, select Maple on the 
Web, and Student Center.
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� operator, 13
:= operator, 11
; terminator, 6
� command, 4, 27

A
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Application Center Web site, 30
Maplesoft Web site, 30
Student Center Web site, 31

Advanced Programming Guide, 29
Application Center, 30
arrays

converting to a list, 17
�������command, 13
assigning names, 11
axes of plots, 11

B
bar. See toolbar or context bar
basic how to, 29
bracket, 4
buttons

Indent, 21
short cuts, 3, 26

C
case-sensitive commands, 9, 28
centering page numbers, 22
classic

worksheet interface, 1
command-line

interface, 1
commands

case-sensitivity, 9
help, 4, 27
how to enter, 5
in packages, 9
reference pages, 25–26

computations, numeric and symbolic, 1
contact Maplesoft, 30
context bar, 3, 20, 26
context-sensitive menus, 11
�	�
	��
�	
 command, 14
�	����
 command, 17

D
derivatives, partial, 12
���� command, 12
���
��� command, 17
ditto operator, 13

E
equations, solving, 13
�����command, 16
example worksheets, 30
execution group, 4, 19–20
exporting worksheets, 23
Expression palette, 4–6
expressions

entering, 5, 7
referring to, 11

F
file extension

mw, 23
mws, 23

floating toolbars. See palette
�	� loops, 16
formatted math, 20–21
Full New User’s Tour, 2, 29
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G
Getting Started Guide, 28
guides, 28–29

H
headings

sections, 21
worksheets, 19

help, 25–28
accessing, 27
command, 4, 27
contents tab, 28
history tab, 28
icon, 27
navigator, 27
pages, 4
sample page, 25–26
search tab, 28
topic tab, 28

How to Perform Basic Tasks, 29
HTML export, 23

I
indenting worksheet elements, 21
installing Maple, 1
integrals, entering, 5
interfaces

various, 1
versions, 1

Introduction page, 2
Introductory Programming Guide, 29

K
keyboard commands, 5

L
LaTeX, 23
launching Maple, 1–2
Learning Guide, 28
licensing Maple, 1
list, 17

M
manuals, 28–29
Maple Advanced Programming 

Guide, 29
Maple Application Center, 30
Maple Getting Started Guide, 28
Maple help, 25–28
Maple input, 3, 23, 26
Maple Learning Guide, 10, 28

Maple Notation, 6
Maple output, 4
Maplesoft

Application Center Web site, 30
contact, 30
Student Center Web site, 31
Web site, 30

Maplet
applications, 23, 28
user interface customization 

system, 29
Maple text, 23
Maple window, 2–3
mathematical expressions

entering, 5, 7
referring to, 11

mathematics in text regions, 20–21
MathML, 23
Matrix palette, 4
menus, context-sensitive, 11

N
names

assigning, 11
new execution group, 19–20
New User’s Tour, 2, 29
new worksheet, 9
numbering pages, 22
numerical solutions, 1

O
options

page numbers, 22
plot, 17–18

P
packages, 9
page numbers, 22
palette

Expression, 4–6
general information, 5–7
Matrix, 4
Symbol, 4–6
Vector, 4

partial derivatives, 12
plain text, 23
plots

adding axes, 11
contour, 14
entering, 11
name assignments, 17
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options, 17–18
rotating, 11, 17


�	
� package, 10
positioning page numbers, 22
Programming Guides

Advanced, 29
Introductory, 29

prompt, 4, 19–20

Q
question mark (�) command, 4, 27
Quick New User’s Tour, 29

R
range brackets, 4
range of plot axes, 11
reference pages, 25
right-click menus, 11
rotating plots, 11, 17
RTF, 23

S
saving worksheets, 23
section

heading, 3, 26
in a worksheet, 21–22
range bracket, 4

semicolon (�) terminator, 6
sets, 13
shortcut buttons. See buttons
shortcut menus, 11
standard

worksheet interface, 1
Standard Math Notation, 4–6
starting Maple, 1–2
Student Center, 30
symbolic solutions, 1
Symbol palette, 4–6
syntax of commands, 5
system of equations, solving, 13

T
text entry, 19–21

titles
sections, 21
worksheets, 19

toolbar
main window, 3, 20, 26

tutorials
accessing, 30
basic how to, 29
full tour, 29
help menu items, 29
quick tour, 29

U
URL of

Application Center Web site, 30
Maplesoft Web site, 30
Student Center Web site, 31

user interface elements, 2

V
Vector palette, 4
versions, 1

W
Web site addresses, 30–31
window features, 2–3
��
��command, 9–10, 20
word processing. See text entry
worksheets

adding text, 19
classic, 1
creating new, 9
example, 30
exporting to HTML, 23
numbering pages, 22
saving, 23
sections, 21–22
standard, 1
version, 1

X
x and y plot axes, 11
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