Calculus Study Guide Installation and Licensing Guide


Calculus Study Guide Installation Instructions
Pre-Installation Instructions
Calculus Study Guide 18 Installation Using a Single User License
Activating Single User Versions
Calculus Study Guide 18 Installation Using a Network License
Configure the License Manager
Named Network Licensing
Getting Started With Calculus Study Guide
System Requirements
Trademarks

Calculus Study Guide Installation Instructions

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Log on as an administrator or log on to an account, with appropriate read and write privileges, that will own the Calculus Study Guide files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. This product requires Maple 18 or later.

To identify your Maple release:

  1. Start Maple.
  1. From the Help menu, select About Maple. The About Maple 18 dialog indicates the release number.

To update to the latest Maple release:

From the Tools menu, select Check for Updates and follow the instructions. If that option is dimmed, obtain the update from the downloads section of the Maplesoft website.

  1. Close all programs.

Note: This product can only be used in the Standard Worksheet interface.

Return to the top of the Guide.

Calculus Study Guide 18 Installation Using a Single User License

Windows Installation Using a Single User License

For Windows® XP, Windows Server® 2008, Windows Server 2012, Windows Vista®, Windows 7, and Windows 8.1 single user installation, read this section.

During the installation, you will need your purchase code, generally sent to you in an email.

To install Calculus Study Guide 18 on your Windows operating system, read and complete the following tasks

Install Calculus Study Guide 18

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click CalculusStudyGuide18WindowsInstaller.exe from the install disc.
  • From download

Double-click CalculusStudyGuide18WindowsInstaller.exe from where you downloaded the file.

  1. Follow the on-screen instructions.

By default, Calculus Study Guide is installed to the following location:

C:\Program Files\Maple 18\toolbox\CalculusStudyGuide

  1. In the Choose The Type of Licensing screen, select Single User License .
  1. When prompted, enter the purchase code and the required information to complete activation.
  1. If you activated successfully, you are ready to use Calculus Study Guide 18. If you had problems activating or chose not to activate during the installation, see Activating Single User Versions.

Return to the top of the Guide.

Macintosh Installation Using a Single User License

For Macintosh® installation instructions, read this section.

During the installation, you will need your purchase code, generally sent to you in an email.

To install Calculus Study Guide 18 on your Macintosh operating system, read and complete the following tasks:

Install Calculus Study Guide 18

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click CalculusStudyGuide18MacInstaller.dmg from the install disc, then double-click CalculusStudyGuide18MacInstaller.app.
  • From download

Double-click CalculusStudyGuide18MacInstaller.dmg from where you downloaded the file, then double-click CalculusStudyGuide18MacInstaller.app.

  1. Follow the on-screen instructions.

By default, Calculus Study Guide is installed to the following location:

/Library/Frameworks/Maple.framework/Versions/18/toolbox/CalculusStudyGuide

  1. In the Choose The Type of Licensing screen, select Single User License .
  1. When prompted, enter the purchase code and the required information to complete activation.
  1. If you activated successfully, you are ready to use Calculus Study Guide 18. If you had problems activating or chose not to activate during the installation, see Activating Single User Versions.

Return to the top of the Guide.

32-bit Linux Installation Using a Single User License

During the installation, you will need your purchase code, generally sent to you in an email.

To install Calculus Study Guide 18 on your 32-bit Linux® operating system, read and complete the following tasks.

Install Calculus Study Guide 18

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and run CalculusStudyGuide18LinuxX86Installer.run from the install disc
  • From download

Run CalculusStudyGuide18LinuxX86Installer.run from where you downloaded the file.

  1. Follow the on-screen instructions.

By default, Calculus Study Guide is installed to the following location:

$HOME/maple18/toolbox/CalculusStudyGuide

  1. In the Choose The Type of Licensing screen, select Single User License .
  1. When prompted, enter the purchase code and the required information to complete activation.
  1. If you activated successfully, you are ready to use Calculus Study Guide 18. If you had problems activating or chose not to activate during the installation, see Activating Single User Versions.

Return to the top of the Guide.

64-bit Linux Single User Installation

During the installation, you will need your purchase code, generally sent to you in an email.

To install Calculus Study Guide 18 on your 64-bit Linux operating system, read and complete the following tasks.

Install Calculus Study Guide 18

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and run CalculusStudyGuide18LinuxX64Installer.run from the install disc.
  • From download

Run CalculusStudyGuide18LinuxX64Installer.run from where you downloaded the file.

  1. Follow the on-screen instructions.

By default, Calculus Study Guide is installed to the following location:

$HOME/maple18/toolbox/CalculusStudyGuide

  1. In the Choose The Type of Licensing screen, select Single User License .
  1. When prompted, enter the purchase code and the required information to complete activation.
  1. If you activated successfully, you are ready to use Calculus Study Guide 18. If you had problems activating or chose not to activate during the installation, see Activating Single User Versions.

Return to the top of the Guide.

Activating Single User Versions

Windows Single User Activation

  1. Activation requires an Internet connection. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Change directory to the location of your Calculus Study Guide installation. The default locations are:
  • Personal copy:

C:\Documents and Settings\%USERNAME%\maple\toolbox\18\CalculusStudyGuide (Windows XP) or C:\Users\%USERNAME%\maple\toolbox\18\CalculusStudyGuide (Windows Vista, Windows 7, or Windows 8.1)

  • Single machine multi-user copy:

C:\Program Files\Maple 18\toolbox\CalculusStudyGuide

  1. Go to the license folder and double-click the activation.exe file. Note: If you are using Windows Server 2008, Windows Server 2012, Windows Vista, Windows 7, or Windows 8.1, right-click activation.exe and select Run as administrator.
  1. You will be prompted to enter your purchase code. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information. Click Next when this is complete.

A license file (CSG.dat) will be saved in the license folder of your Calculus Study Guide 18 installation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Macintosh Single User Activation

  1. Activation requires an Internet connection. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Change directory to the location of your Calculus Study Guide installation. The default locations are:
  • Personal copy:

/Users/$USERNAME/maple/toolbox/18/CalculusStudyGuide

  • Single machine multi-user copy:

/Library/Frameworks/Maple.framework/Versions/18/toolbox/CalculusStudyGuide

  1. Run the activation script located in the license folder of your installation.
  1. You will be prompted to enter your purchase code. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information. Click Next when this is complete.

A license file (CSG.dat) will be saved in the license folder of your Calculus Study Guide 18 installation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Linux Single User Activation

  1. Activation requires an Internet connection. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Change directory to the location of your Calculus Study Guide installation. The default locations are:
  • Personal copy:

$HOME/maple/toolbox/18/CalculusStudyGuide

  • Single machine multi-user copy:

$HOME/maple18/toolbox/CalculusStudyGuide

  1. Run the activation script located in the license directory of your installation.
  1. You will be prompted to enter your purchase code. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information. Click Next when this is complete.

A license file (CSG.dat) will be saved in the license folder of your Calculus Study Guide 18 installation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Calculus Study Guide 18 Installation Using a Network License

Windows Installation Using a Network License

Install Calculus Study Guide 18 to the Client Machines

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click CalculusStudyGuide18WindowsInstaller.exe from the install disc.
  • From download

Double-click CalculusStudyGuide18WindowsInstaller.exe from where you downloaded the file.

  1. Follow the on-screen instructions.

By default, Calculus Study Guide is installed to the following location:

C:\Program Files\Maple 18\toolbox\CalculusStudyGuide

  1. In the Choose The Type of Licensing screen, select Network License .
  1. When prompted, enter the name or IP address of the license server.
  1. Calculus Study Guide 18 is now installed. Prior to using Calculus Study Guide 18, you need to Configure the License Manager.

Return to the top of the Guide.

Macintosh Installation Using a Network License

For Macintosh® installation instructions, read this section.

To install Calculus Study Guide 18 on your Macintosh operating system, read and complete the following tasks:

Install Calculus Study Guide 18 to the Client Machines

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click CalculusStudyGuide18MacInstaller.dmg from the install disc, then double-click CalculusStudyGuide18MacInstaller.app.
  • From download

Double-click CalculusStudyGuide18MacInstaller.dmg from where you downloaded the file, then double-click CalculusStudyGuide18MacInstaller.app.

  1. Follow the on-screen instructions.

By default, Calculus Study Guide is installed to the following location:

/Library/Frameworks/Maple.framework/Versions/18/toolbox/CalculusStudyGuide

  1. In the Choose The Type of Licensing screen, select Network License .
  1. When prompted, enter the name or IP address of the license server.
  1. Calculus Study Guide 18 is now installed. Prior to using Calculus Study Guide 18, you need to Configure the License Manager.

Return to the top of the Guide.

32-bit Linux Installation Using a Network License

To install Calculus Study Guide 18 on your 32-bit Linux operating system, read and complete the following tasks.

Install Calculus Study Guide 18 to the Client Machines

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and run CalculusStudyGuide18LinuxX86Installer.run from the install disc
  • From download

Run CalculusStudyGuide18LinuxX86Installer.run from where you downloaded the file.

  1. Follow the on-screen instructions.

By default, Calculus Study Guide is installed to the following location:

$HOME/maple18/toolbox/CalculusStudyGuide

  1. In the Choose The Type of Licensing screen, select Network License .
  1. When prompted, enter the name or IP address of the license server.
  1. Calculus Study Guide 18 is now installed. Prior to using Calculus Study Guide 18, you need to Configure the License Manager.

Return to the top of the Guide.

64-bit Linux Installation Using a Network License

To install Calculus Study Guide 18 on your 64-bit Linux operating system, read and complete the following tasks.

Install Calculus Study Guide 18 to the Client Machines

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and run CalculusStudyGuide18LinuxX64Installer.run from the install disc.
  • From download

Run CalculusStudyGuide18LinuxX64Installer.run from where you downloaded the file.

  1. Follow the on-screen instructions.

By default, Calculus Study Guide is installed to the following location:

$HOME/maple18/toolbox/CalculusStudyGuide

  1. In the Choose The Type of Licensing screen, select Network License .
  1. When prompted, enter the name or IP address of the license server.
  1. Calculus Study Guide 18 is now installed. Prior to using Calculus Study Guide 18, you need to Configure the License Manager.

Return to the top of the Guide.

Configure the License Manager

Configure the License Manager for Windows

Before starting the Windows Network version of Calculus Study Guide 18, you must obtain your license file and start the license manager by completing the following tasks.

  1. Choose one of the following:

Install FlexNet Publisher and Activation Utilities

  1. Choose one of the following:
  1. On Windows 32-bit, double-click the NetworkToolsWindowsX86Installer.exe file from the install disc or from where you downloaded the file.
  1. On Windows 64-bit, double-click the NetworkToolsWindowsX64Installer.exe file from the install disc or from where you downloaded the file.
  1. Close all programs, particularly Microsoft® Excel® and any previous release of Calculus Study Guide.
  1. Follow the on-screen instructions.

Activate a Network License

Calculus Study Guide 18 requires a Calculus Study Guide 18 license file to operate. License files for earlier versions of Calculus Study Guide do not work with Calculus Study Guide 18. To obtain your license file, you must use the Maple Network Tools activation program or activate off-line by following the instructions at http://www.maplesoft.com/contact/webforms/offlineactivation/. Ensure that you can connect to the Internet as activation requires an Internet connection. If your computer does not have an Internet connection, please contact Maplesoft customer service.

  1. Depending on your version of Windows, do one of the following:
  • If you are using Windows 8.1, from Start screen swipe up from the middle of the screen or alternatively, move the mouse to the bottom left of the screen and click the downward arrow that appears. Under the Maple Network Tools heading, right-click on the Activate Maple tile. Next, click the Run as administrator icon.
  • For all other supported versions of Windows, from the Start menu, select (All) Programs > Maple Network Tools > Activate Maple.

Note: If you are using Windows Vista or Windows 7, right-click Activate Maple and select Run as administrator.

  1. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is complete.
  1. A license file, CSG18.lic, will be saved to the C:\Program Files\Maple Network Tools\activate folder. You will need this license file in the next step.

Start the License Manager for Calculus Study Guide 18 Only

The C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows directory contains license manager daemons, lmgrd and maplelmg, as well as utilities to assist you in installing and configuring FlexNet Publisher for your system.

Start the License Manager Daemons

If you intend to use a Novell® server, see Novell Networks.

To set up and start the license manager daemons on a Windows Network Server:

  1. From the Start menu, select (All) Programs>Maple Network Tools>LMTools11.7. Note: If you are using Windows 8.1, from Start screen swipe up from the middle of the screen or alternatively, move the mouse to the bottom left of the screen and click the downward arrow that appears. Under the Maple Network Tools heading, click LMTools11.7
  1. Under the Service/License File tab, click Configuration using Services.
  1. Click the Config Services tab.
  1. In the Config Services property sheet, enter or browse to the following files:

Service Name

Enter a name for the service (optional)

Path to the lmgrd.exe file

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe

Path to the license file

C:\Program Files\Maple Network Tools\activate\CSG18.lic

Path to the debug log file Enter the path to the directory containing the debug log file. You must create this file manually (log.txt is the manually created file in the example below), as it is not automatically generated.

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt

  1. To set up the daemons as a service (recommended), select the Use Services check box. This is available for Windows XP, Windows Vista, Windows 7, and Windows 8.1.
  1. To start the daemons at boot time (recommended), select the Start Server at Power Up check box
  1. Click Save Service. When prompted to save the service, click Yes
  1. Click the Start/Stop/Reread tab. In that property sheet, click Start Server to start the license manager daemons

You can now use Calculus Study Guide 18.

Start the License Manager for Multiple Maplesoft Products

To run Maple and associated products, you must place all license files in the same directory. If you have other FlexNet Publisher license files stored in one central location, you can store Maple and associated product license files there as well.

Complete the following tasks:

Stop the License Manager
  1. Go to the directory of the FlexNet Publisher utilities that are currently being used and double-click lmtools.exe. Alternatively, in the Start menu, select (All) Programs>Maple Network Tools>LMTools11.7 Note: On Windows 8.1, from Start screen swipe up from the middle of the screen or alternatively, move the mouse to the bottom left of the screen and click the downward arrow that appears. Under the Maple Network Tools heading, click LMTools11.7
  1. Under the Service/License File tab, click Configuration using Services.
  1. Click the Config Services tab. From the Server Name list, select the service currently being used.
  1. Click the Start/Stop/Reread tab, then click Stop Server.
Move all Calculus Study Guide License Files to a Common Directory

Using Windows Explorer, move all of the license files to a common directory, for example, C:\Program Files\Maple Network Tools\activate.

Start the License Manager Daemons
  1. From the Start menu, select (All) Programs>Maple Network Tools >LMTools11.7. Note: On Windows 8.1, from Start screen swipe up from the middle of the screen or alternatively, move the mouse to the bottom left of the screen and click the downward arrow that appears. Under the Maple Network Tools heading, click LMTools11.7
  1. Under the Service/License File tab, click Configuration using Services.
  1. Click the Config Services tab.
  1. In the Config Services property sheet, enter or browse for the following:

Service Name

Enter a name for the service (optional)

Path to the lmgrd.exe file

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe

Path to the license file Note: The path to the license file should not contain a terminating backslash

C:\Program Files\Maple Network Tools\activate

Path to the debug log file Enter the path to the directory containing the debug log file. You must create this file manually (log.txt is the manually created file in the example below), as it is not automatically generated.

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt

  1. To set up the daemons as a service (recommended), select the Use Services check box. This is available for Windows XP, Windows Vista, Windows 7, and Windows 8.1.
  1. To start the daemons at boot time (recommended), select the Start Server at Power Up check box.
  1. Click Save Service. When prompted to save the service, click Yes.
  1. Click the Start/Stop/Reread tab. In that property sheet, click Start Server to start the license manager daemons.

You can now use your network licensed Maplesoft products.

Novell Networks

FlexNet Publisher does not run on Novell or IPX/SPX. Follow these instructions to install the license manager on any network that is exclusively a Novell environment.

  1. Install TCP/IP on all client machines.
  1. Select a Windows computer that has TCP/IP installed to act as a license server and run the license daemons using the Start License Manager for Calculus Study Guide 18 Only instructions.

Return to the top of the Guide.

Configure the License Manager for Mac OS X

Before starting the Mac OS® X Network version of Calculus Study Guide 18, you must obtain your license file and start the license manager by completing the following tasks.

  1. Choose one of the following:

Install FlexNet Publisher and the Activation Utilities

  1. To begin installing the FlexNet Publisher and Activation Utilities, choose one of the following:
  1. Place the Calculus Study Guide 18 DVD in the DVD-ROM drive.
  1. Double-click NetworkToolsMacInstaller.dmg from where you downloaded the file.
  1. Run the installer by double-clicking the NetworkToolsMacInstaller icon.
  1. Follow the on-screen instructions.

Activate a Network License

Calculus Study Guide 18 requires a Calculus Study Guide 18 license file to operate. License files for earlier versions of Calculus Study Guide do not work with Calculus Study Guide 18. To obtain your license file, you must use the Maple Network Tools activation program or activate off-line by following the instructions at http://www.maplesoft.com/contact/webforms/offlineactivation/. Ensure that you can connect to the Internet as activation requires an Internet connection. If your computer does not have an Internet connection, please contact Maplesoft customer service.

  1. From the Finder, open a terminal window from Applications -> Utilities.
  1. Change to the location of the activation utility directory. By default, /Users/<username>/Applications/Maple_Network_Tools/activate.
  1. Run the activation script by issuing the command ./activation. To launch activation in console mode, use the -console option.
  1. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is complete.
  1. When prompted, enter the name or IP address of the license server.
  1. A license file, CSG18.lic, will be saved to the /Users/<username>/Applications/Maple_Network_Tools/activate directory. You will need this license file for the next step.

Start the License Manager for Calculus Study Guide 18 Only

Start the License Manager Daemons

Before you can use Calculus Study Guide 18, you must start the license server. It is recommended that you do not run lmgrd as root because any process run by root is a potential security risk.

  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/.
  1. Start the license manager daemons
  1. To start the license manager daemon (lmgrd), enter the following command at the prompt:

./lmgrd -c license_file_path -l debug_log &

where license_file_path is the full path and filename of the network license file (by default, /Users/<username>/Applications/Maple_Network_Tools/activate/CSG18.lic), and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

Help for Starting the License Server

If you have any problems starting the license server in the system boot up files, refer to http://www.flexerasoftware.com.

You can now use Calculus Study Guide 18.

Start the License Manager for Multiple Maplesoft Products

To run Maple and associated products, you must place all license files in the same directory. If you have other FlexNet Publisher license files stored in one central location, you can store Maple and associated product license files there as well.

Complete the following tasks:

Stop the License Manager

Go to the location of the FlexNet Publisher utilities that are currently being used. For Calculus Study Guide 18, the default location is /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/. Enter the command:

./lmdown

Move all Calculus Study Guide License Files to a Common Directory

Copy all the Calculus Study Guide network license files to /Users/<username>/Applications/Maple_Network_Tools/activate.

Start the License Manager Daemons
  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/.
  1. When starting license manager daemons, you must enter the path to the directory containing all license files. By default, /Users/<username>/Applications/Maple_Network_Tools/activate.

Note: Point to the directory only, not an actual license file.

  1. To start the license manager, enter the following command:

./lmgrd -c license_file_path -l debug_log

where license_file_path is the full path to the directory containing the license files and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

You can now use your network licensed Maplesoft products.

Return to the top of the Guide.

Configure the License Manager for Linux

Before starting the Linux Network version of Calculus Study Guide 18, you must obtain your license file and start the license manager by completing the following tasks.

  1. Choose one of the following:

Install FlexNet Publisher and the Activation Utilities

  1. Choose one of the following:
  1. On Linux 32-bit, run the NetworkToolsLinuxX86Installer.run file from the install disc or from where you downloaded the file.
  1. On Linux 64-bit, run the NetworkToolsLinuxX64Installer.run file from the install disc or from where you downloaded the file.
  1. Follow the on-screen instructions.

Activate a Network License

Calculus Study Guide 18 requires a Calculus Study Guide 18 license file to operate. License files for earlier versions of Calculus Study Guide do not work with Calculus Study Guide 18. To obtain your license file, you must use the Maple Network Tools activation program or activate off-line by following the instructions at http://www.maplesoft.com/contact/webforms/offlineactivation/. Ensure that you can connect to the Internet as activation requires an Internet connection. If your computer does not have an Internet connection, please contact Maplesoft customer service.

  1. Change to the location of the activation utility directory. By default, $HOME/Maple_Network_Tools/activate.
  1. Run the activation command. To launch activation in console mode, use the -console option.
  1. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is completed.
  1. A license file, CSG18.lic, will be saved to the $HOME/Maple_Network_Tools/activate directory. You will need this license file for the next step.

Start the License Manager for Calculus Study Guide 18 Only

Start the License Manager Daemons

Before you can use Calculus Study Guide 18, you must start the license server. It is recommended that you do not run lmgrd as root because any process run by root is a potential security risk.

  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, $HOME/Maple_Network_Tools/FLEXlm/11.7/.
  1. Start the license manager daemons.

Using the C Shell

To start the license manager daemon (lmgrd), enter the following command at the prompt,

./lmgrd -c license_file_path -l debug_log &

where license_file_path is the full path and filename of the network license file (by default, $HOME/Maple_Network_Tools/activate/CSG18.lic) and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

Using the Korn or Bourne Shell

To start the license manager daemon (lmgrd), enter the following command at the prompt:

nohup lmgrd -c license_file_path -l debug_log 2>&1 &

Run Daemons on Startup

To have the daemons run on startup, edit the appropriate boot script (such as /etc/rc.boot, /etc/rc.local, or /etc/rc2.d/Sxxxx). For example, if you run lmgrd as a boot startup script, you can run it as a regular user by using the following su command at the prompt:

su username -c \'umask 022; lmgrd_path -c license_file_path -l log_path\'

where username is a non-privileged user; lmgrd_path is the correct path to the lmgrd file, license_file_path is the full path of the network license file (by default, $HOME/Maple_Network_Tools/activate/CSG18.lic), and log_path is the debug log file path. It is recommended that the network license file be called CSG18.lic.

Help for Starting the License Server

If you have any problems starting the license server in the UNIX system boot up files, refer to http://www.flexerasoftware.com/.

You can now use Calculus Study Guide 18.

Start the License Manager for Multiple Maplesoft Products

To run Maple and associated products, you must place all license files in the same directory. If you have other FlexNet Publisher license files stored in one central location, you can store Maple and associated product license files there as well.

Complete the following tasks:

Stop the License Manager

Go to the location of the FlexNet Publisher utilities that are currently being used. For Calculus Study Guide 18, the default location is /usr/local/Maple_Network_Tools/FLEXlm/11.7/. Enter the command:

./lmdown
Move all Calculus Study Guide License Files to a Common Directory

Copy all of the Calculus Study Guide network license files to one folder, for example, $HOME/Maple_Network_Tools/activate.

Start the License Manager Daemons
  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, $HOME/Maple_Network_Tools/FLEXlm/11.7/.
  1. When starting license manager daemons, you must enter the path to the directory containing all of your license files. By default, $HOME/Maple_Network_Tools/activate.

Note: Point to the directory only, not an actual license file.

  1. To start the license manager, enter the following command:

./lmgrd -c license_file_path -l debug_log

where license_file_path is the full path to the directory containing the license files and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

You can now use your network licensed Maplesoft products.

Return to the top of the Guide.

Named Network Licensing

Named Network Users run Calculus Study Guide on their own client machines. These client machines are connected to the license server over the network. The Network Named User licensing option allows system administrators to strictly enforce which users, or client machines, may run Calculus Study Guide.

When you install Maple Network Tools, an options file (.opt) is automatically created in the $Maple Network Tools/activate directory.

Note: By default, the vendor daemon looks for the options file (maplelmg.opt) in the same directory that contains the license file used by the license server manager.

Setting Up Named Network Licensing

To set up Named Network User licensing, perform the following steps:

Edit the Options File

To manually edit the options file, perform the following steps:

  • Go to the directory that contains the options file. By default, this is $Maple Network Tools/activate.
  • INCLUDE lines in an options file state which users can run the product. Add an INCLUDE line for each product. If there is more than one user per product, add an INCLUDE line for each user, as well. Alternatively, you can use the GROUP syntax to combine authorized Named Users for a specific product.
Example 1: Specifying which users can run Maple and Calculus Study Guide

INCLUDE Maple USER User1

INCLUDE Maple USER User2

INCLUDE Maple USER User3

INCLUDE Maple USER User4

INCLUDE CSG18 USER User4

Example 2: Using GROUP syntax to specify users that can run Maple and Calculus Study Guide

GROUP Maple_users User1 User2 User3 User4

INCLUDE Maple GROUP Maple_users

INCLUDE CSG18 USER User4

Restart the License Manager.

You must restart the license manager for the changes to the options file to take effect.

Return to the top of the Guide.

Getting Started With Calculus Study Guide

Getting Started

The Calculus Study Guide is a collection of Maple worksheets, grouped by topic and organized by chapter.

To get started with this study guide, open the file named Contents.mw in Maple. This opens the Table of Contents. Follow the hyperlinks to each of the chapters.

Note

  • This product can be used only in the Standard Worksheet interface.

System Requirements

32-bit Windows System Requirements

Version

CPU

Recommended RAM

Hard Disk

Windows XP

Intel Pentium III 650 MHz or higher or fully compatible

2 GB

2 GB

Windows Vista

Intel Pentium III 1 GHz

2 GB

2 GB

Windows Server 2008 R2

x86_64 1.4 GHz (single core) or x86_64 1.3 GHz (dual core) or equivalent

2 GB

2 GB

Windows 7

Intel Pentium III 1 GHz

2 GB

2 GB

Windows Server 2012

x86_64 1.4 GHz (single core) or x86_64 1.3 GHz (dual core) or equivalent

2 GB

2 GB

Windows 8.1

Intel Pentium III 1 GHz

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.

64-bit Windows System Requirements

Version

CPU

Recommended RAM

Hard Disk

Windows XP

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows Vista

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows Server 2008 R2

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows 7

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows Server 2012

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows 8.1

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform.

Macintosh System Requirements

Vendor

CPU

Operating System

Version

Recommended RAM

Hard Disk

Apple

64-bit Intel

OS X

10.7, 10.8, 10.9

2 GB

2 GB

  • Java™ Runtime Environment 1.6.0_18 or higher installed
  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform.

32-bit Linux System Requirements

Vendor

Operating System Version

CPU

Recommended RAM

Hard Disk

Red Hat Enterprise Linux

6 update 4

Intel Pentium III 650 MHz or equivalent

2 GB

2 GB

SUSE Linux Enterprise Desktop

11, 12

Intel Pentium III 650 MHz or equivalent

2 GB

2 GB

Ubuntu

12.04 LTS, 13.10

Intel Pentium III 650 MHz or equivalent

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • X11 R6.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.

64-bit Linux System Requirements

Vendor

Operating System Version

CPU

Recommended RAM

Hard Disk

Red Hat Enterprise Linux

6 update 4

Intel 64 or AMD X86_64

2 GB

2 GB

SUSE Linux Enterprise Desktop

11, 12

Intel 64 or AMD X86_64

2 GB

2 GB

Ubuntu

12.04 LTS, 13.10

Intel 64 or AMD X86_64

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • X11 R6.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform

Return to the top of the Guide.

Trademarks

Note: Maple uses the Flexera Software Corporation FlexNet Publisher as its license manager. This document contains all the information you require for a standard Maple installation. For more information, refer to the FlexNet Publisher documentation at http://www.flexerasoftware.com/.

Maple, Maplesoft, and Waterloo Maple are trademarks of Waterloo Maple Inc.

Intel is a registered trademark of Intel Corporation.

Microsoft, Windows, Windows Server, Windows Vista, Excel, and Internet Explorer are registered trademarks of Microsoft Corporation.

Macintosh and Mac OS are registered trademarks of Apple Computer, Inc.

NVIDIA is a registered trademark of NVIDIA Corporation.

Java and JRE are registered trademarks of Oracle and/or its affiliates.

FLEXlm and FlexNet are registered trademarks of Flexera Software Corporation.

Linux is a registered trademark of Linus Torvalds.

All other brand names or product names are trademarks or registered trademarks of their respective companies.

Return to the top of the Guide.