MapleSim 6 Installation and Licensing Guide


MapleSim 6 インストールとライセンシングの手引き
Maple の要件
シングルユーザライセンスの場合の MapleSim 6 のインストール
シングルユーザ・バージョンのアクティベーション
MapleSim 6 ネットワークライセンスを用いたインストール
Windows 上のサイレント・インストール
Microsoft Visual C++ コンパイラーのインストール・設定
ビデオカード・ドライバーの仕様の確認
ライセンスマネージャの設定
指名ネットワークライセンシング
MapleSim を起動する方法
グラフィックスの仕様
仮想マシン
動作環境
商標

MapleSim 6 インストールとライセンシングの手引き

Maple の要件

MapleSim 6 を使用するには、 Maple 16 がインストールされていることが必要となります。すでに Maple 16 をインストールしてある場合、MapleSim 6 をインストールすることで自動的に Maple バージョンが Maple 16 に更新されます。Maple 16 がインストールされていない場合、Maple 16 のインストールとアクティベーションの手順は Maple 16 インストールとライセンシングの手引き に記載されています。

シングルユーザライセンスの場合の MapleSim 6 のインストール

32-bit Windows におけるシングルユーザ用インストール

Windows® XP、2008 サーバー、Windows Vista®、Windows® 7 のシングルユーザ用インストールについては本セクションをお読みください。64 ビット Windows については 64 ビット Windows シングルユーザ用インストール をご覧ください。

インストールの途中でパーチェスコードが必要となります。これは通常メールで送られます。

MapleSim 6 を Windows オペレーティングシステム上にインストールするには、次の手順に従ってください。

インストール前の手順

  1. オペレーティングシステムの 動作環境 を確認してください。
  1. 適切な読み書きの権限を持ち、MapleSim の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

MapleSim 6 のインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. インストールディスク を DVD-ROM ドライブに入れてください。
  1. インストールディスク の MapleSim6WindowsInstaller_ja.exe をダブルクリックしてください。
  • ダウンロードによる方法

ダウンロード先より MapleSim6WindowsInstaller_ja.exe をダブルクリックしてください。

  1. 画面の指示に従ってください。
  1. ライセンスタイプを選択 の画面から、シングルユーザライセンス を選択します。
  1. プロンプトされたら、パーチェスコードと必要な情報を入力し、アクティベーションを終了してください。
  1. アクティベーションに成功すると MapleSim 6 を使用開始できます。アクティベーション中に問題が発生したり、インストール中にアクティベーションしないことを選択した場合は シングルユーザ・バージョンのアクティベーション をご覧ください。

最初に戻る.

64 ビット Windows シングルユーザ用インストール

注意: MapleSim を 64 ビット Microsoft® Windows 環境で使用する場合、MapleSim コンパイラーを使用するためには Microsoft® Visual C++ コンパイラーをインストール・設定する必要があります。Microsoft Visual C++ コンパイラーを MapleSim で使用するための設定方法については Microsoft Visual C++ コンパイラーのインストール・設定 をご覧ください。

インストールの途中でパーチェスコードが必要となります。これは通常メールで送られます。

MapleSim 6 を Windows オペレーティングシステム上にインストールするには、次の手順に従ってください。

Windows® XP、2008 サーバー、Windows Vista®、Windows® 7 のシングルユーザ用インストールについては本セクションをお読みください。64 ビット Windows については 64 ビット Windows シングルユーザ用インストール をご覧ください。

インストールの途中でパーチェスコードが必要となります。これは通常メールで送られます。

MapleSim 6 を Windows オペレーティングシステム上にインストールするには、次の手順に従ってください。

インストール前の手順

  1. オペレーティングシステムの 動作環境 を確認してください。
  1. 適切な読み書きの権限を持ち、MapleSim の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

MapleSim 6 のインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. インストールディスク を DVD-ROM ドライブに入れてください。
  1. インストールディスク から MapleSim6WindowsX86_64Installer_ja.exe を見つけてダブルクリックしてください。
  • ダウンロードによる方法

ファイルのダウンロード先で MapleSim6WindowsX86_64Installer_ja.exe をダブルクリックしてください。

  1. 画面の指示に従ってください。
  1. ライセンスタイプを選択 の画面から、シングルユーザライセンス を選択します。
  1. プロンプトされたら、パーチェスコードと必要な情報を入力し、アクティベーションを終了してください。
  1. アクティベーションに成功すると MapleSim 6 を使用開始できます。アクティベーション中に問題が発生したり、インストール中にアクティベーションしないことを選択した場合は シングルユーザ・バージョンのアクティベーション をご覧ください。

最初に戻る.

Macintosh シングルユーザ用インストール

Macintosh® Intel の、32 ビットおよび 64 ビットのシングルユーザ用インストール方法は、本セクションを参照してください。

インストールの途中でパーチェスコードが必要となります。これは通常メールで送られます。

MapleSim 6 を Macintosh オペレーティングシステムにインストールするには、次の手順に従ってください。

インストール前の手順

  1. オペレーティングシステムの 動作環境 を確認してください。
  1. 適切な読み書きの権限を持ち、MapleSim の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

MapleSim 6 のインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. インストールディスク を DVD-ROM ドライブに入れてください。
  1. インストールディスク から MapleSim6MacInstaller_ja.dmg を見つけてダブルクリックし、その次に MapleSim6MacInstaller をダブルクリックしてください。
  • ダウンロードによる方法

ファイルのダウンロード先で MapleSim6MacInstaller_ja.dmg をクリックし、その次に MapleSim6MacInstaller をダブルクリックしてください。

  1. 画面の指示に従ってください。
  1. ライセンスタイプを選択 の画面から、シングルユーザライセンス を選択します。
  1. プロンプトされたら、パーチェスコードと必要な情報を入力し、アクティベーションを終了してください。
  1. アクティベーションに成功すると MapleSim 6 を使用開始できます。アクティベーション中に問題が発生したり、インストール中にアクティベーションしないことを選択した場合は シングルユーザ・バージョンのアクティベーション をご覧ください。

最初に戻る.

32 ビット Linux のシングルユーザ用インストール

インストール中、パーチェスコードが必要となります。これは、通常 E メールでお送りします。

32 ビット Linux® オペレーティングシステムに MapleSim 6 をインストールするには、次の手順に従ってください。

インストール前の手順

  1. オペレーティングシステムの 動作環境 を確認してください。
  1. 適切な読み書きの権限を持ち、MapleSim の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

MapleSim 6 のインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. インストールディスク を DVD-ROM ドライブに入れてください。
  1. インストールディスク から MapleSim6Linux32Installer.bin を見つけて実行してください。
  • ダウンロードによる方法

ファイルのダウンロード先から MapleSim6Linux32Installer.bin を実行してください。

  1. 画面の指示に従ってください。
  1. ライセンスタイプを選択 の画面から、シングルユーザライセンス を選択します。
  1. プロンプトされたら、パーチェスコードと必要な情報を入力し、アクティベーションを終了してください。
  1. アクティベーションに成功すると MapleSim 6 を使用開始できます。アクティベーション中に問題が発生したり、インストール中にアクティベーションしないことを選択した場合は シングルユーザ・バージョンのアクティベーション をご覧ください。

デスクトップおよびアプリケーションメニュー用ショートカット

インストール中、MapleSim 6 のインストールの bin ディレクトリーに MapleSim6.desktop ファイルを作成します。デスクトップにショートカットを作成するようにインストーラーに要求すると、そのファイルを ~/Desktop ディレクトリーにも作成します。アプリケーションメニューにショートカットを作成したい場合は、MapleSim6.desktop ファイルを /usr/share/applications (これはルート権限が必要な可能性があります)または ~/.local/share/applications にコピーしてください。

最初に戻る.

64 ビット Linux のシングルユーザー用インストール

インストールの途中でパーチェスコードが必要となります。これは通常メールで送られます。

64 ビット Linux® オペレーティングシステム上に MapleSim 6 をインストールする際には、次の手順を読んで実行してください。

インストール前の手順

  1. オペレーティングシステムの 動作環境 を確認してください。
  1. 適切な読み書きの権限を持ち、MapleSim の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

MapleSim 6 のインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. インストールディスク を DVD-ROM ドライブに入れてください。
  1. インストールディスク から MapleSim6LinuxX86_64Installer.bin を見つけて実行してください。
  • ダウンロードによる方法

ファイルのダウンロード先から MapleSim6LinuxX86_64Installer.bin を実行してください。

  1. 画面の指示に従ってください。
  1. ライセンスタイプを選択 の画面から、シングルユーザライセンス を選択します。
  1. プロンプトされたら、パーチェスコードと必要な情報を入力し、アクティベーションを終了してください。
  1. アクティベーションに成功すると MapleSim 6 を使用開始できます。アクティベーション中に問題が発生したり、インストール中にアクティベーションしないことを選択した場合は シングルユーザ・バージョンのアクティベーション をご覧ください。

デスクトップおよびアプリケーションメニュー用ショートカット

インストール中、MapleSim 6 のインストールの bin ディレクトリーに MapleSim6.desktop ファイルを作成します。デスクトップにショートカットを作成するようにインストーラーに要求すると、そのファイルを ~/Desktop ディレクトリーにも作成します。アプリケーションメニューにショートカットを作成したい場合は、MapleSim6.desktop ファイルを /usr/share/applications (これはルート権限が必要な可能性があります)または ~/.local/share/applications にコピーしてください。

最初に戻る.

シングルユーザ・バージョンのアクティベーション

MapleSim 6 が動作するには MapleSim 6 ライセンスファイルが必要です。MapleSim 6 の旧バージョンのライセンスファイルは MapleSim 6 では使用できません。ライセンスファイルを取得するには MapleSim 6 のシングルユーザ・バージョンのアクティベーションを行わなければなりません。シングルユーザのインストーラー実行時は、インストール中にアクティベーションを行うことができます。インストール手続き中にアクティベーションを行わない場合は、以下の手順に従ってください。

  1. アクティベーションにはインターネット接続が必要です。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. MapleSim 6 を起動します。
  1. アクティベーションのプロンプトが出たら、アクティベーション をクリックしてください。
  1. パーチェスコード入力のプロンプトが表示されます。プロキシサーバーを介してアクティベーションを行う場合、次へ をクリックする前に情報を入力するように注意してください。
  1. その他の情報を入力するプロンプトが表示されます。入力が完了したら 次へ をクリックしてください。
  • Windows では、スタートメニューのショートカット (すべての)プログラム>MapleSim 6>Tools>Activate MapleSim 6 よりアクティベーションを行うこともできます。注意: Windows Vista または Windows 7 を使用している場合は、Activate MapleSim 6 を右クリックし、管理者として実行 を選択してください。
  • Linux では $HOME/Maple16/toolbox/MapleSim/license ディレクトリーにある activation スクリプトを実行することでアクティベーションを行うこともできます。
  • Macintosh では、16 のインストール先(デフォルトでは /Library/Frameworks/Maple.framework/Versions/16/toolbox/MapleSim/license)の toolbox/MapleSim/license フォルダー中にある activation スクリプトを実行することでアクティベーションを行うこともできます。

MapleSim 6 ライセンスファイル(MapleSim.dat)が MapleSim 6 のインストール先のライセンスフォルダ中に保存されます。アクティベーションが上手くいかない場合は、http://www.maplesoft.com/support/Faqs/Activation の FAQ ページをご覧ください。

最初に戻る.

MapleSim 6 ネットワークライセンスを用いたインストール

ネットワークライセンスを用いた 32 ビット Windows 上のインストール

Windows® XP、2008 Server、Windows Vista®、Windows® 7 でネットワークライセンスを用いてインストールする場合は、このセクションをお読みください。64 ビット Windows については 動作環境 をご覧ください。

ネットワークライセンスを用いて Windows オペレーティングシステム上に MapleSim 6 をインストールする場合は、次の手順を読んで実行してください。

インストール前の手順

  1. オペレーティングシステムの 動作環境 を確認してください。
  1. 適切な読み書きの権限を持ち、MapleSim の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

MapleSim 6 のインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. インストールディスク を DVD-ROM ドライブに入れてください。
  1. インストールディスク の MapleSim6WindowsInstaller_ja.exe をダブルクリックしてください。
  • ダウンロードによる方法

ダウンロード先より MapleSim6WindowsInstaller_ja.exe をダブルクリックしてください。

  1. 画面の指示に従ってください。
  1. ライセンスタイプを選択 の画面から、ネットワークライセンス を選んでください。
  1. プロンプトが出たら、ライセンスサーバーの名前または IP アドレスを入力してください。
  1. MapleSim 6 のインストールが完了しました。MapleSim 6 を使用する前に、インストール前の手順 が必要となります。

最初に戻る.

ネットワークライセンスを用いた 64 ビット Windows 上のインストール

注意: MapleSim を 64 ビット Microsoft® Windows 環境で使用する場合、MapleSim コンパイラーを使用するためには Microsoft® Visual C++ コンパイラーをインストール・設定する必要があります。Microsoft Visual C++ コンパイラーを MapleSim で使用するための設定方法については Microsoft Visual C++ コンパイラーのインストール・設定 をご覧ください。

ネットワークライセンスを用いて Windows オペレーティングシステム上に MapleSim 6 をインストールする場合は、次の手順を読んで実行してください。

Windows® XP、2008 Server、Windows Vista®、Windows® 7 でネットワークライセンスを用いてインストールする場合は、このセクションをお読みください。64 ビット Windows については 動作環境 をご覧ください。

ネットワークライセンスを用いて Windows オペレーティングシステム上に MapleSim 6 をインストールする場合は、次の手順を読んで実行してください。

インストール前の手順

  1. オペレーティングシステムの 動作環境 を確認してください。
  1. 適切な読み書きの権限を持ち、MapleSim の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

MapleSim 6 のインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. インストールディスク を DVD-ROM ドライブに入れてください。
  1. インストールディスク から MapleSim6WindowsX86_64Installer_ja.exe を見つけてダブルクリックしてください。
  • ダウンロードによる方法

ファイルのダウンロード先で MapleSim6WindowsX86_64Installer_ja.exe をダブルクリックしてください。

  1. 画面の指示に従ってください。
  1. ライセンスタイプを選択 の画面から、ネットワークライセンス を選んでください。
  1. プロンプトが出たら、ライセンスサーバーの名前または IP アドレスを入力してください。
  1. MapleSim 6 のインストールが完了しました。MapleSim 6 を使用する前に、インストール前の手順 が必要となります。

最初に戻る.

ネットワークライセンスを用いた Macintosh 上のインストール

Macintosh® Intel の、32 ビットおよび 64 ビットのシングルユーザ用インストール方法は、本セクションを参照してください。

MapleSim 6 を Macintosh オペレーティングシステムにインストールするには、次の手順に従ってください。

インストール前の手順

  1. オペレーティングシステムの 動作環境 を確認してください。
  1. 適切な読み書きの権限を持ち、MapleSim の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

MapleSim 6 のインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. インストールディスク を DVD-ROM ドライブに入れてください。
  1. インストールディスク から MapleSim6MacInstaller_ja.dmg を見つけてダブルクリックし、その次に MapleSim6MacInstaller をダブルクリックしてください。
  • ダウンロードによる方法

ファイルのダウンロード先で MapleSim6MacInstaller_ja.dmg をクリックし、その次に MapleSim6MacInstaller をダブルクリックしてください。

  1. 画面の指示に従ってください。
  1. ライセンスタイプを選択 の画面から、ネットワークライセンス を選んでください。
  1. プロンプトが出たら、ライセンスサーバーの名前または IP アドレスを入力してください。
  1. MapleSim 6 のインストールが完了しました。MapleSim 6 を使用する前に、インストール前の手順 が必要となります。

最初に戻る.

ネットワークライセンスを用いた 32 ビット Linux 上のインストール

32 ビット Linux® オペレーティングシステムに MapleSim 6 をインストールするには、次の手順に従ってください。

インストール前の手順

  1. オペレーティングシステムの 動作環境 を確認してください。
  1. 適切な読み書きの権限を持ち、MapleSim の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

MapleSim 6 のインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. インストールディスク を DVD-ROM ドライブに入れてください。
  1. インストールディスク から MapleSim6Linux32Installer.bin を見つけて実行してください。
  • ダウンロードによる方法

ファイルのダウンロード先から MapleSim6Linux32Installer.bin を実行してください。

  1. 画面の指示に従ってください。
  1. ライセンスタイプを選択 の画面から、ネットワークライセンス を選んでください。
  1. プロンプトが出たら、ライセンスサーバーの名前または IP アドレスを入力してください。
  1. MapleSim 6 のインストールが完了しました。MapleSim 6 を使用する前に、インストール前の手順 が必要となります。

デスクトップおよびアプリケーションメニュー用ショートカット

インストール中、MapleSim 6 のインストールの bin ディレクトリーに MapleSim6.desktop ファイルを作成します。デスクトップにショートカットを作成するようにインストーラーに要求すると、そのファイルを ~/Desktop ディレクトリーにも作成します。アプリケーションメニューにショートカットを作成したい場合は、MapleSim6.desktop ファイルを /usr/share/applications (これはルート権限が必要な可能性があります)または ~/.local/share/applications にコピーしてください。

最初に戻る.

ネットワークライセンスを用いた 64 ビット Linux 上のインストール

64 ビット Linux® オペレーティングシステム上に MapleSim 6 をインストールする際には、次の手順を読んで実行してください。

インストール前の手順

  1. オペレーティングシステムの 動作環境 を確認してください。
  1. 適切な読み書きの権限を持ち、MapleSim の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

MapleSim 6 のインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. インストールディスク を DVD-ROM ドライブに入れてください。
  1. インストールディスク から MapleSim6LinuxX86_64Installer.bin を見つけて実行してください。
  • ダウンロードによる方法

ファイルのダウンロード先から MapleSim6LinuxX86_64Installer.bin を実行してください。

  1. 画面の指示に従ってください。
  1. ライセンスタイプを選択 の画面から、ネットワークライセンス を選んでください。
  1. プロンプトが出たら、ライセンスサーバーの名前または IP アドレスを入力してください。
  1. MapleSim 6 のインストールが完了しました。MapleSim 6 を使用する前に、インストール前の手順 が必要となります。

デスクトップおよびアプリケーションメニュー用ショートカット

インストール中、MapleSim 6 のインストールの bin ディレクトリーに MapleSim6.desktop ファイルを作成します。デスクトップにショートカットを作成するようにインストーラーに要求すると、そのファイルを ~/Desktop ディレクトリーにも作成します。アプリケーションメニューにショートカットを作成したい場合は、MapleSim6.desktop ファイルを /usr/share/applications (これはルート権限が必要な可能性があります)または ~/.local/share/applications にコピーしてください。

最初に戻る.

Windows 上のサイレント・インストール

Windows では、MapleSim のネットワークバージョンをサイレント・モードでインストールすることができます。Windows XP、Windows Server 2008、Windows Vista、Windows 7 (32 ビットまたは 64 ビット)については、この手順に従ってください。リソースファイルの情報は必ず正確に入力してください。

インストール前の準備

  1. Windows の動作環境を確認してください。
  1. プログラムをすべて閉じてください。特に、Microsoft Excel や、MapleSim の旧バージョンは必ず閉じるよう注意してください。
  1. 管理者としてログオンしてください。管理者権限が必要となります。
  1. リソースファイルを作成します。

インストーラーを実行するとき、コマンド MapleSim6WindowsInstaller_ja.exe -r <PATH>\installer.properties (32 ビット Windows) または MapleSim6WindowsX86_64Installer_ja.exe -r <PATH>\installer.properties (64 ビット Windows) (ただし <PATH> は指定のディレクトリー)を用いると、自動的にリソースファイルを作成します。画面の指示に従ってインストールを完了してください。

-r フラグにより生成される installer.properties ファイルを用いるか、次の例をテンプレートとして自分のファイルを作成することもできます。

INSTALLER_UI=SILENT

# インストールフォルダの選択

#---------------------

USER_INSTALL_DIR=C:\Program Files\Maple 16\toolbox\MapleSim

# デスクトップのショートカットのインストール

#-------------------------

DESKTOP_SHORTCUTS="Yes",""

DESKTOP_SHORTCUTS_1=Yes

DESKTOP_SHORTCUTS_2=

DESKTOP_SHORTCUTS_BOOLEAN_1=1

DESKTOP_SHORTCUTS_BOOLEAN_2=0

# Watcom インストールフォルダの選択

#----------------------------

WATCOM_INSTALL_FOLDER=C:\watcom-1.3

#MapleSim ワークシートの関連付け

#----------------------------

WKS_ASSOC_RESULT="Yes",""

WKS_ASSOC_RESULT_1=Yes

WKS_ASSOC_RESULT_2=

WKS_ASSOC_RESULT_BOOLEAN_1=1

WKS_ASSOC_RESULT_BOOLEAN_2=0

# ライセンスタイプの選択

#----------------------------

LICENSE="","Network License"

LICENSE_1=

LICENSE_2=Network License

LICENSE_BOOLEAN_1=0

LICENSE_BOOLEAN_2=1

LICENSE server

#----------------------------

LICENSE_SERVER=myserver.mydomain.com

PORT_NUMBER=

  1. コマンド・プロンプト・ウィンドウを開きます。
  1. MapleSim6WindowsInstaller_ja.exe または MapleSim6WindowsX86_64Installer_ja.exe ファイルがあるディレクトリーまで移動してください。
  1. MapleSim6WindowsInstaller_ja.exe -f installer.properties (32 ビット Windows)または MapleSim6WindowsX86_64Installer_ja.exe -f installer.properties の何れかのコマンドによりサイレント・インストーラー・プロセスを実行します。

注意: installer.properties ファイルを、MapleSim6WindowsInstaller_ja.exe または MapleSim6WindowsX86_64Installer_ja.exe ファイルの場所以外のディレクトリーに作成した場合、このコマンドを実行するとき installer.properties ファイルのパスを指定する必要があります。

注意

  1. インストール中、installer.properties ファイルを -r フラグを用いて作成した場合は、INSTALLER_UI=SILENT の行は自動的には入りません。-r を用いて installer.properties ファイルを作成した場合はファイル中の最初に INSTALLER_UI=SILENT を挿入する必要があります。
  1. このテンプレートでは、MapleSim 6 が C:\Program Files\Maple 16\toolbox\MapleSim フォルダーにインストールされているものとします。インストール先が異なる場合は USER_INSTALL_DIR を適宜変更してください。
  1. テンプレートは、デスクトップに MapleSim 6 のテスクトップ・アイコンを表示することを前提としています。不要な場合は "Install Desktop Shortcuts" のセクションの各行を以下の行で置き換えてください。

DESKTOP_SHORTCUTS="","No"

DESKTOP_SHORTCUTS_1=

DESKTOP_SHORTCUTS_2=No

DESKTOP_SHORTCUTS_BOOLEAN_1=0

DESKTOP_SHORTCUTS_BOOLEAN_2=1

  1. 必要であれば、WATCOM コンパイラーの場所を変更できます。パス名に空白文字は使用できません。WATCOM_INSTALL_FOLDER フィールドを完全に削除すると、WATCOM コンパイラーはインストールされません。
  1. テンプレートは、デフォルトの MapleSim バージョンが MapleSim 6 であることを前提としています(システムには MapleSim の他のバージョンがインストールされていることを前提とします)。これを変更するには、"MapleSim Worksheet Association" セクションの各行を以下のものに置き換えてください。

WKS_ASSOC_RESULT="","No"

WKS_ASSOC_RESULT_1=

WKS_ASSOC_RESULT_2=No

WKS_ASSOC_RESULT_BOOLEAN_1=0

WKS_ASSOC_RESULT_BOOLEAN_2=1

  1. ライセンスサーバー名(必須)を変更し、ポート番号(オプション)を適宜追加します。

追加項目

  • このモードでインストーラーを実行すると、フィードバックは表示されません
  • MapleSim のシングルユーザ・バージョンをサイレントでインストールすることはできますが、その場合製品のアクティベーションは同時にできません。MapleSim 6 のシングルユーザ・バージョンのサイレント・インストールが完了したら、スタートメニューより すべてのプログラム を選択し、MapleSim 6ToolsActivate MapleSim 6 と選択してください。

Windows 上のサイレント・アンインストール

  1. MapleSim のサイレント・アンインストールを行うには、コマンドプロンプトに対して次のコマンドを実行してください。

"C:\Program Files\Maple 16\toolbox\MapleSim\Uninstall_MapleSim\Uninstall.exe" -i silent

最初に戻る.

Microsoft Visual C++ コンパイラーのインストール・設定

注意: Windows Vista または Windows 7 を使用する場合、Microsoft Visual C++ コンパイラーの設定・インストールを行うには管理者権限を持ったアカウントにログインする必要があります。

必要なソフトウェアのインストール・設定を行うには、次の手順に従ってください。

Microsoft Visual C++ Express Edition のダウンロードとインストール

Visual Studio C++ コンパイラの設定

Microsoft Visual C++ Express Edition のダウンロードとインストール

コンピューターに、以下のソフトウェアをダウンロードし、インストールしてください。

  • Microsoft Windows SDK for Windows 7 および .NET Framework 4 (http://msdn.microsoft.com/en-us/windowsserver/bb980924.aspx より無料ダウンロード)。注意: Visual C++ コンパイラー・コンポーネントを必ずインストールしてください。.NET Framework 4 はフル・インストールが必要です。
  • Microsoft Visual C++ 2010 Express Edition (無料ダウンロード)

注意: Microsoft Visual C++ 2010 Edition のダウンロード方法は次の通りです。

  1. Visual Studio 2010 Express タブを選択します。
  1. Visual C++ 2010 Express Edition リンクをクリックします。
  1. 言語を選択してください。
  1. Free Download ボタンをクリックしてください。

Visual Studio C++ コンパイラの設定

Maple のスタンダードワークシートを起動するたびに、コンピュータが自動的にスキャンされ、適切な Microsoft Visual Studio C++ コンパイラが検索されます。サポートされているコンパイラバージョンは 2010、2008、2005、および 2003 です。

サポートされているバージョンの Visual Studio C++ コンパイラが検出されない場合は、コンパイラが使用する %LIB%%INCLUDE%、および %PATH% 環境変数を手動で定義できます。または、Maple のインストールプロセスの実行中に作成される vcvars64.bat ファイルのパスを指定して、Microsoft Visual C++ コンパイラを Maple 用に設定できます。vcvars64.bat ファイルをパスに指定するには、次の手順を実行します。

  • Maple がすでにコンピューターにインストールされている場合は、Maple からコマンドを実行してファイルへのパスを指定することができます。以下の手順に従ってください。
  1. Maple を開きます。
  1. Maple プロンプトより、Compiler:-Setup() と入力し、Enter を押します。
  1. ダイアログボックスで、ファイル vcvars64.bat へのパスを指定します。
  1. Maple を閉じます。
  • 注 : Compiler:-Setup() コマンドは、Maple のスタンダードワークシートで使用できます。Maple のコマンドラインバージョンを使用している場合は、手動で %LIB%%INCLUDE%、および %PATH% 環境変数を定義する必要があります。

最初に戻る.

ビデオカード・ドライバーの仕様の確認

MapleSim 6 においてグラフィックスの性能を最適化するには、使用しているビデオカードの最新のドライバー・ソフトウェアをインストールすることを強く推奨します。MapleSim 6 を使用する前に、本セクションの手順に従いビデオカードのドライバー・ソフトウェアを確認し、必要であればアップグレードしてください。

ビデオカードの種類の特定

32 ビットおよび 64 ビット Windows

  1. 次の方法のうちのひとつにより、デバイスマネージャのウィンドウを開きます。
  • (Windows 2003 および XP) スタート から ファイル名を指定して実行 を選択します。名前 フィールドに devmgmt.msc を入力して OK をクリックします。
  • (Windows Vista および Windows 7) スタート メニューを開く。検索 フィールドに devmgmt.msc を入力し、検索を実行。検索結果から デバイスマネージャ をクリックします。
  1. デバイスマネージャ ウィンドウで ディスプレイ アダプタ のセクションを開きます。このセクションに、使用中のビデオカードの種類が表示されます(例、RADEON X600 Series など)。

32 ビット および 64 ビット の Linux と UNIX

注意: このステップは、ルート・ユーザとして、または sudo アクセスによりログインしていることが必要となります。ネットワーク・コンピューターまたはシェアド・コンピューターを使用している場合はシステム管理者に連絡してください。

  1. コマンドプロンプトが表示されたら、lspci コマンドを実行します(lspci コマンドは /sbin または /usr/sbin ディレクトリーにあるかもしれません)。
  1. 出力中、"VGA" または "Display controller" が入った行を探します。例えば、

01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)

01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)

Macintosh

  1. Apple メニューより、この Mac について を選択します。
  1. 詳しい情報...をクリックします。
  1. システムプロファイラー中、左枠の ハードウェア セクションを開き、グラフィックス/ディスプレイ をクリックしてください。ウィンドウの右側パネル中 チップセットのモデル の左にビデオカードが表示されます。(例、チップセットのモデル: ATI Radeon HD 2600Pro

最初に戻る.

ドライバー・ソフトウェアの確認・アップグレード

32 ビットおよび 64 ビット Windows

  1. デバイスマネージャ ウィンドウ内、ディスプレイ アダプタ のセクションで、インストール先コンピューターのビデオカード名を右クリックし、ドライバの更新...を選択してください。ハードウェアの更新ウィザード が表示されます。
  1. Windows Update 接続用のプロンプトが表示されたら、はい、今回のみ接続します をクリックして 次へ をクリックしてください。
  1. ソフトウェアを自動的にインストールする(推奨) を選択して 次へ をクリックしてください。ウィザードは、現在インストールされているドライバー・ソフトウェアよりも新しいバージョンが提供されているか調べます。

最新のドライバーがインストールされていることをウィザードが検知したら、完了 をクリックしてウィザードを閉じてください。これでコンピューターは MapleSim 6 のグラフィックスを表示できるように設定されました。

インストールされているドライバーよりも新しいものが提供されていることをウィザードが示したら、画面の指示に従ってアップデートをインストールしてください。

32 ビット および 64 ビット の Linux と UNIX

  1. ビデオカードが使用しているドライバーのバージョンを調べてください。調べ方は シングルユーザ・バージョンのアクティベーション をご覧ください。
  1. ビデオカード販売元のウェブサイトに行き、インストールされているものより新しいドライバーソフトウェアが提供されているか調べてください。「最新のドライバーソフトウェアの取得法」に記載されている手順をご覧ください。

販売元が提供する最新のドライバーソフトウェアのバージョンナンバーが、インストールされているもののバージョンナンバーと一致すれば、コンピューターが MapleSim 6 のグラフィックスを表示する設定が整っていることになります。より新しいバージョンがある場合は、ウェブサイトよりドライバーソフトウェアをダウンロードし、コンピューターにインストールしてください。

注意: Linux や UNIX のソフトウェア更新ユーティリティーにより自動的に検出されたソフトウェア・アップグレードの利用は推奨しません。

Macintosh

  • Apple メニューより、ソフトウェア・アップデート...を選択してください。

Software Update ウィンドウにビデオカードの更新用ドライバーソフトウェアが表示されていなければ、コンピューターに最新のバージョンがインストールされているということを意味します。このとき、コンピューターは、MapleSim 6 でグラフィックスを表示できる設定となっています。

更新用ドライバーソフトウェアが表示されているときは、それを選択し、インストール をクリックしてください。画面の指示に従い、インストールを完了してください。

最初に戻る.

販売元ウェブサイトからの、更新ドライバーのダウンロード・インストール

Linux または UNIX オペレーティングシステムを使用している場合、もしくは Windows または Macintosh オペレーティングシステムを使用していて自動的に検出されたソフトウェアが正常に動作しない場合は、ビデオカード販売元のウェブサイトから最新のドライバーをダウンロードし、インストールしてください。

ビデオカードで使われているドライバーの特定

32 ビットおよび 64 ビット Windows
  1. デバイスマネージャ ウィンドウで、ディスプレイ アダプタ セクションを開く。
  1. コンピューターのビデオカードの項目を右クリックし、プロパティ を選択します。ビデオカードに関する情報を含んだダイアログボックスが表示されます。
  1. ドライバ タブをクリックしてください。ビデオカードが使用しているドライバーのバージョンは、ウィンドウ上部の バージョン の隣に表示されています。
32 ビット および 64 ビット の Linux と UNIX

まず、グラフィックスのハードウェア・アクセラレータが有効になっているか調べてください。

  • Linux または UNIX インストール先のルートより、glxinfo | head というコマンドを実行してください。

グラフィックスのハードウェア・アクセラレータが有効になっていれば direct rendering: Yes という行が表示されます。この行が direct rendering: No であれば、ハードウェア・アクセラレータは無効になっています。

Linux または UNIX のインストールのパッケージ管理システムから、コンピュータにインストールされているドライバーを検索することができます。Linux および UNIX は、ディストリビューションにより異なるパッケージ管理システムを使用しています。以下、Linux の最も使われているディストリビューション 2 つについて手順を説明します。

dpkg ベースの Linux ディストリビューション(Ubuntu など)

システムにどのパッケージがインストールされているか調べるには、dpkg -l コマンドを実行してください(最終文字は L の小文字)。このコマンドは出力結果を数行表示するので、grep コマンドで出力量を制限すると便利です。上記の例に続き、次のコマンドで NVIDIA® ドライバーを探すことができます。

dpkg -1 | grep -i nvidia

ハードウェア・アクセラレータ対応のドライバーをインストールしてある場合、nvidia-glx-177 のような出力行が見られます。この例の場合、177 はドライバーの主要バージョンナンバーで、2 列目に完全なバージョンナンバーが表示されます。例えば、Ubuntu システムでは 177.82-0ubuntu0.1 という形式となります。

ハードウェア・アクセラレータ対応の ATI™ ドライバーは、Linux では fglrx と名付けられます。例えば、Ubuntu システムではパッケージ名は fglrx-amdcccle など、バージョンナンバーは 2:8.543-0ubuntu4.1 などとなります。

Intel® 統合グラフィックス・アクセラレータ・ハードウェアは、パッケージ名に intel という文字列か、i810 などのチップセット情報が含まれることがあります。

rpm ベースの Linux ディストリビューション(SuSE、Red Hat Enterprise Linux など)

rpm ベースの Linux システムにインストールされているパッケージを調べるには、rpm -qa コマンドを実行します。このコマンドは、コンピューターにインストールされているすべてのパッケージを列挙するので、grep コマンドを用いて検索結果を制限することを推奨します。例えば、

rpm -qa | grep nvidia

最新のドライバーソフトウェアの取得

ご使用のビデオカード用の最新のドライバーをダウンロードするには、ビデオカード販売元のウェブサイトをご覧ください。

ATI ビデオカード

http://support.amd.com/us/gpudownload/Pages/index.aspx に行き、ご使用のオペレーティングシステムとビデオカードの種類に対するドライバーソフトウェアを探してください。ビデオカード用のドライバーソフトウェアの最新のものをダウンロードし、インストールしてください。

注意: ATI Catalyst™ ビデオカードをご使用の場合は、Catalyst ソフトウェア・スイートをダウンロードしてください。

Intel ビデオカード

http://www.intel.com/support/graphics/ に行き、ご使用のチップセット・タイプに対するドライバーソフトウェアを探してください。ビデオカード用のドライバーソフトウェアの最新のものをダウンロードし、インストールしてください。

Windows でチップセット・タイプを調べる方法の詳細については、http://www.intel.com/support/chipsets/sb/cs-009245.htm をご覧ください。

Linux でドライバーソフトウェアを更新する方法の詳細については、http://www.intel.com/support/graphics/sb/cs-010512.htm をご覧ください。

NVIDIA ビデオカード

http://www.nvidia.com/Download/index.aspx に行き、ご使用のオペレーティングシステムとビデオカードの種類に対するドライバーソフトウェアを探してください。ビデオカード用のドライバーソフトウェアの最新のものをダウンロードし、インストールしてください。

最初に戻る.

ライセンスマネージャの設定

Windows でのライセンスマネージャの設定

MapleSim 6 の Windows Network バージョンを起動する前に、以下の手順に従いライセンスファイルを取得し、ライセンスマネージャを起動してください。

  1. 次のひとつを選択してください。

FlexNet Publisher と Activation Utilities をインストール

  1. DVD またはダウンロード先から NetworkToolsInstaller_Windows.exe をダブルクリックしてください。
  1. プログラムをすべて閉じてください。特に、Microsoft® Excel と MapleSim の古いリリースは必ず閉じてください。
  1. 画面の指示に従ってください。

ネットワークライセンスのアクティベーション

MapleSim 6 を操作するには、MapleSim 6 ライセンスファイルが必要です。それより前の MapleSim バージョンのライセンスファイルは MapleSim 6 では動作しません。ライセンスファイルを取得するには、MapleSim アクティベーションプログラムを使用するか、http://www.maplesoft.com/contact/webforms/offlineactivation/ に記載されている手順に従ってオフラインでアクティベーションを実行する必要があります。アクティベーション中にインターネット接続が必要になります。インターネットに接続できることを確認してください。ご使用のコンピュータがインターネットに接続していない場合は、Maplesoft 顧客サービスにお問い合わせください。

  1. スタート メニューから (すべての)プログラム>Maple Network Tools>Activate MapleSim を選択してください。注意: Windows Vista または Windows 7 を使用している場合は、Activate MapleSim を右クリックして 管理者として実行 を選択してください。
  1. ライセンスサーバーのパーチェスコード、ホスト名、ホスト ID を入力するためのプロンプトが表示されます。プロキシサーバーを介してアクティベーションを行う場合は、次へ をクリックする前に必ずこの情報を入力してください。
  1. アクティベーションを行うライセンス数など、その他の情報を入力するためのプロンプトも表示されます。入力したら 次へ をクリックしてください。
  1. ライセンスファイル MapleSim6.licC:\Program Files\Maple Network Tools\activate フォルダーに保存されます。次のステップでこのライセンスファイルが必要となります。

MapleSim 6 用のライセンスマネージャだけを起動

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows ディレクトリーには、MapleSim 実行時に必要なライセンスマネージャ・デーモン(lmgrd および MapleSimlmg)のほか、使用システムに対する FlexNet Publisher のインストール・設定を支援するユーティリティーが含まれています。

ライセンスマネージャ・デーモンの起動

Novell® サーバーを使用する場合は、ライセンスマネージャの設定 をご覧ください。

Windows ネットワークサーバー上でライセンスマネージャ・デーモンを設定・起動するには:

  1. スタートメニューから (すべての)プログラム>Maple Network Tools>LMTools11.7 を選択します。
  1. Service/License File タブ下で、Configuration using Services をクリックします。
  1. Config Services タブをクリックします。
  1. Config Services プロパティ・シートで、次のファイルまで移動するか、ファイル名を入力してください。

サービス名

サービスの名前を入力(オプション)

lmgrd.exe ファイルへのパス

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe

ライセンスファイルへのパス

C:\Program Files\Maple Network Tools\activate\MapleSim6.lic

デバッグログファイルへのパス デバッグログファイルを含むディレクトリーへのパスを入力してください。このファイルは、自動生成されないため、自分で作成しなければなりません(下記の例では log.txt が自作ファイルです)。

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt

  1. デーモンをサービスとして設定する場合、Use Services チェックボックスを選択してください(デーモンは、サービスとして設定することを推奨します)。これは Windows XP、Windows Vista、Windows 7 で利用可能です。
  1. デーモンをブート時に起動するには、Start Server at Power Up チェックボックスを選択してください(デーモンはブート時に起動することを推奨します)。
  1. Save Service をクリックします。サービスを保存するためのプロンプトが表示されたら、Yes をクリックしてください。
  1. Start/Stop/Reread タブをクリックします。プロパティシートで Start Server をクリックすると、ライセンスマネージャ・デーモンが起動します。

これで、MapleSim 6 を使う準備ができました。

複数の Maplesoft 製品用にライセンスサーバーを起動

Maple とその関連製品を実行するには、すべてのライセンスファイルを同一のディレクトリーに入れる必要があります。ほかの FlexNet Publisher ライセンスファイルがひとつの場所に保存されている場合、Maple および関連製品のライセンスファイルもそこに置くことができます。

注意: Maple 6 とそれに関連付けられているツールボックスのライセンシングは、Maple 14 以降のライセンシングと互換性があります。ただし、Maple 14 より前のバージョンのライセンシングとは互換性がありません。バージョン 14 より前の Maple およびツールボックスでは、Maple 13 の Maple Network Tools を実行できます。

次の手順に従ってください:

ライセンスマネージャの停止
  1. 現在使用している FlexNet Publisher ユーティリティーのディレクトリーまで移動して、lmtools.exe をダブルクリックしてください。あるいは、スタート メニューから (すべての)プログラム>Maple Network Tools>LMTools11.7 を選択してください。
  1. Service/License File タブ下で、Configuration using Services をクリックします。
  1. Config Services タブをクリックしてください。Server Name リストから現在使用されているサービスを選択してください。
  1. Start/Stop/Reread タブをクリックしてから Stop Server をクリックしてください。
MapleSim ライセンスファイルすべてを共通のディレクトリに移動

Windows Explorer を用いて、ライセンスファイルをすべて1つのディレクトリーに移動してください。例えば、C:\Program Files\Maple Network Tools\activate など。

ライセンスマネージャ・デーモンの起動
  1. スタートメニューから (すべての)プログラム>Maple Network Tools >LMTools11.7 を選択します。
  1. Service/License File タブ下で、Configuration using Services をクリックします。
  1. Config Services タブをクリックします。
  1. Config Services プロパティーシートで、次のファイルまで移動するか、そのファイル名を入力します:

サービス名

サービスの名前を入力(オプション)

lmgrd.exe ファイルへのパス

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe

ライセンスファイルへのパス 注意: ライセンスファイルへのパスには最後にバックスラッシュを付けないものとします。

C:\Program Files\Maple Network Tools\activate

デバッグログファイルへのパス デバッグログファイルを含むディレクトリーへのパスを入力してください。このファイルは、自動生成されないため、自分で作成しなければなりません(下記の例では log.txt が自作ファイルです)。

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt

  1. デーモンをサービスとして設定する場合、Use Services チェックボックスを選択してください(デーモンは、サービスとして設定することを推奨します)。これは Windows 2003、XP、Vista、7 で利用可能です。
  1. デーモンをブート時に起動するには、Start Server at Power Up チェックボックスを選択してください(デーモンはブート時に起動することを推奨します)。
  1. Save Service をクリックします。サービスを保存するためのプロンプトが表示されたら、Yes をクリックしてください。
  1. Start/Stop/Reread タブをクリックします。プロパティシートで Start Server をクリックすると、ライセンスマネージャ・デーモンが起動します。

これで、ネットワークライセンスの Maplesoft 製品が使用できます。

Novell ネットワーク

FlexNet Publisher は、Novell や IPX/SPX 上では実行できません。Novell のみの環境のネットワークでライセンスマネージャをインストールするには、次の手順に従ってください。

  1. すべてのクライアント・マシンに TCP/IP をインストールしてください。
  1. TCP/IP をインストールした Windows コンピュータをひとつ、ライセンスサーバーとして割り当て、「MapleSim 6 のみのためにライセンスサーバーを起動する」の手順に従いライセンスデーモンを実行してください。

最初に戻る.

Mac OS X 用にライセンスサーバーを設定

MapleSim 6 の Mac OS® X ネットワークバージョンを起動する前に、次の手順に従いライセンスファイルを取得し、ライセンスマネージャを起動します。

  1. 次のひとつを選択してください。

FlexNet Publisher と Activation Utilities のインストール

  1. FlexNet Publisher と Activation Utilities のインストールを開始するには、次のひとつを選んでください。
  1. MapleSim 6 DVD を DVD-ROM ドライブに入れてください。
  1. ファイルのダウンロード先から NetworkToolsInstaller_Mac.dmg をダブルクリックしてください。
  1. NetworkToolsInstaller_Mac アイコンをダブルクリックしてインストーラーを実行してください。
  1. 画面の指示に従ってください。

ネットワークライセンスのアクティベーション

MapleSim 6 を操作するには、MapleSim 6 ライセンスファイルが必要です。それより前の MapleSim バージョンのライセンスファイルは MapleSim 6 では動作しません。ライセンスファイルを取得するには、MapleSim アクティベーションプログラムを使用するか、http://www.maplesoft.com/contact/webforms/offlineactivation/ に記載されている手順に従ってオフラインでアクティベーションを実行する必要があります。アクティベーション中にインターネット接続が必要になります。インターネットに接続できることを確認してください。ご使用のコンピュータがインターネットに接続していない場合は、Maplesoft 顧客サービスにお問い合わせください。

  1. Finder から、アプリケーション -> ユーティリティターミナル ウィンドウを開いてください。
  1. アクティベーションユーティリティーのディレクトリーの場所を変えます。デフォルトは、 /Users/<username>/Applications/Maple_Network_Tools/activate
  1. コマンド ./activation を呼んでアクティベーションスクリプトを実行します。コンソールモードでアクティベーションを起動するには、-console オプションを使用してください。
  1. ライセンスサーバーのパーチェスコード、ホスト名、ホスト ID の入力プロンプトが表示されます。プロキシサーバーを介してアクティベーションを行っている場合は、必ずこれらの情報を入力してから 次へ をクリックしてください。
  1. アクティベーションを行うライセンス数を含めた追加情報の入力プロンプトが表示されます。情報をすべて入力したら 次へ をクリックしてください。
  1. プロンプトが出たら、ライセンスサーバーの名前または IP アドレスを入力してください。
  1. ライセンスファイル MapleSim6.lic が、ディレクトリー /Users/<username>/Applications/Maple_Network_Tools/activate に保存されます。次のステップでこのライセンスファイルが必要になります。

MapleSim 6 用のライセンスマネージャだけを起動

ライセンスマネージャ・デーモンの起動

MapleSim 6 を使えるようにするためには、ライセンスサーバーを起動しなければなりません。root によって実行されるプロセスはすべてセキュリティーリスクであるため、lmgrd を root として走らせることは推奨しません。

  1. 使用しているオペレーティングシステムの FlexNet Publisher ユーティリティーのインストール先まで移動します。デフォルトでは、 /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/
  1. ライセンスマネージャ・デーモンを起動
  1. ライセンスマネージャ・デーモン(lmgrd)を起動するには、プロンプトに対し次のコマンドを入力してください。

./lmgrd -c license_file_path -l debug_log &

ここで、license_file_path はネットワークライセンスファイルのフルパスとファイル名(デフォルトは /Users/<username>/Applications/Maple_Network_Tools/activate/MapleSim6.lic)で、debug_log は、デバッグ情報の書き込み先ファイル名。-l オプション(アルファベットの l で、数字の 1 ではない)を指定すると、ファイルを作成します。

ライセンスサーバーの起動に関するヘルプ

システムブートアップファイルでライセンスサーバーを起動する際に問題が発生する場合は、http://www.flexerasoftware.com を参照してください。

これで、MapleSim 6 を使う準備ができました。

複数の Maplesoft 製品用にライセンスサーバーを起動

Maple とその関連製品を実行するには、すべてのライセンスファイルを同一のディレクトリーに入れる必要があります。ほかの FlexNet Publisher ライセンスファイルがひとつの場所に保存されている場合、Maple および関連製品のライセンスファイルもそこに置くことができます。

注意: Maple 6 とそれに関連付けられているツールボックスのライセンシングは、Maple 14 以降のライセンシングと互換性があります。ただし、Maple 14 より前のバージョンのライセンシングとは互換性がありません。バージョン 14 より前の Maple およびツールボックスでは、Maple 13 の Maple Network Tools を実行できます。

次の手順に従ってください:

ライセンスマネージャの停止

現在使われている FlexNet Publisher ユーティリティーのインストール先に移動してください。MapleSim 6 の場合、デフォルトのインストール先は /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/ となります。次のコマンドを入力してください。

./lmdown

MapleSim ライセンスファイルすべてを共通のディレクトリに移動

MapleSim のネットワークライセンスファイルをすべて /Users/<username>/Applications/Maple_Network_Tools/activate にコピーしてください。

ライセンスマネージャ・デーモンの起動
  1. 使用しているオペレーティングシステムの FlexNet Publisher ユーティリティーのインストール先まで移動します。デフォルトでは、 /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/
  1. ライセンスマネージャ・デーモンを起動するとき、すべてのライセンスファイルを含むディレクトリーへのパスを入力する必要があります。デフォルトは /Users/<username>/Applications/Maple_Network_Tools/activate

注意: ディレクトリーのパスで、ライセンスファイルそのものを指すものではありません。

  1. ライセンスマネージャを起動するには、次のコマンドを入力します。

./lmgrd -c license_file_path -l debug_log

ここで、license_file_path はライセンスファイルがあるディレクトリーのフルパスで、debug_log はデバッグ情報の書き込み先ファイル名。-l オプション(アルファベットの l で、数字の 1 ではない)を指定すると、ファイルを作成します。

これで、ネットワークライセンスの Maplesoft 製品が使用できます。

最初に戻る.

UNIX および Linux のライセンスマネージャの設定

MapleSim 6 の UNIX ネットワーク・バージョンを起動する前に、ライセンスファイルを取得し、次の手順に従ってライセンスマネージャを起動する必要があります。

  1. 次のひとつを選択してください。

FlexNet Publisher と Activation Utilities のインストール

  1. 次のひとつを選択してください。
  1. Linux 32 ビットでは、DVD またはファイルのダウンロード先から NetworkToolsInstaller_Linux.bin ファイルを実行してください。
  1. Linux 64 ビットでは、DVD またはファイルのダウンロード先から NetworkToolsInstaller_LinuxX86_64.bin ファイルを実行してください。
  1. Solaris では、DVD またはファイルのダウンロード先から NetworkToolsInstaller_Sun.bin ファイルを実行してください。
  1. 画面の指示に従ってください。

ネットワークライセンスのアクティベーション

MapleSim 6 を操作するには、MapleSim 6 ライセンスファイルが必要です。それより前の MapleSim バージョンのライセンスファイルは MapleSim 6 では動作しません。ライセンスファイルを取得するには、MapleSim アクティベーションプログラムを使用するか、http://www.maplesoft.com/contact/webforms/offlineactivation/ に記載されている手順に従ってオフラインでアクティベーションを実行する必要があります。アクティベーション中にインターネット接続が必要になります。インターネットに接続できることを確認してください。ご使用のコンピュータがインターネットに接続していない場合は、Maplesoft 顧客サービスにお問い合わせください。

  1. アクティベーションユーティリティー・ディレクトリーに移動してください。デフォルトでは、$HOME/Maple_Network_Tools/activate となります。
  1. activation コマンドを実行してください。コンソールモードでアクティベーションを起動するには -console オプションを指定します。
  1. ライセンスサーバーのパーチェスコード、ホスト名、ホスト ID を入力するためのプロンプトが表示されます。プロキシサーバーを介してアクティベーションを行う場合は、次へ をクリックする前に必ずこの情報を入力してください。
  1. アクティベーションしたいライセンス数などの情報を入力するプロンプトが表示されます。これが完了したら Next をクリックしてください。
  1. $HOME/Maple_Network_Tools/activate ディレクトリーにライセンスファイル MapleSim6.lic が保存されます。次のステップでこのライセンスファイルが必要となります。

MapleSim 6 用のライセンスマネージャだけを起動

ライセンスマネージャ・デーモンの起動

MapleSim 6 を使えるようにするためには、ライセンスサーバーを起動しなければなりません。root によって実行されるプロセスはすべてセキュリティーリスクであるため、lmgrd を root として走らせることは推奨しません。

  1. 使用しているオペレーティングシステムの FlexNet Publisher ユーティリティーの場所に移動してください。これは、デフォルトとして $HOME/Maple_Network_Tools/FLEXlm/11.7/ となります。
  1. ライセンスマネージャ・デーモンを起動します。

C Shell の使用

プロンプトに対し次のコマンドを入力し、ライセンスマネージャ・デーモンを起動してください。

./lmgrd -c license_file_path -l debug_log &

ここで、license_file_path はネットワークライセンスファイルのフルパスとファイル名(デフォルトは $HOME/Maple_Network_Tools/activate/MapleSim6.lic)で、debug_log は、デバッグ情報の書き込み先ファイル名。-l オプション(アルファベットの l で、数字の 1 ではない)を指定すると、ファイルを作成します。

Korn Shell または Bourne Shell の使用

ライセンスマネージャ・デーモン(lmgrd)を起動するには、プロンプトに対し次のコマンドを入力してください。

nohup lmgrd -c license_file_path -l debug_log 2>&1 &

起動時のデーモンの実行

起動時にデーモンを実行するようにするには、適宜ブートスクリプト(例、/etc/rc.boot/etc/rc.local/etc/rc2.d/Sxxxx など)に変更を加えます。例えば、ブート起動スクリプトとして lmgrd を実行する場合、プロンプトに対し次の su コマンドを実行すれば、レギュラーユーザとして実行することができます。

su username -c \'umask 022; lmgrd_path -c license_file_path -l log_path\'

ここで、username は特権のないユーザ、lmgrd_path は lmgrd ファイルへの正しいパス、license_file_path はネットワークライセンスファイルへのフルパス(デフォルトでは $HOME/Maple_Network_Tools/activate/MapleSim6.lic)、log_path はデバッグログファイルのパスとします。ネットワーク・ライセンス・ファイルの名前は MapleSim6.lic とすることを推奨します。

ライセンスサーバー起動のヘルプ

UNIX のシステムブートアップ・ファイルからライセンスサーバーを起動する際に問題が発生する場合は、http://www.flexerasoftware.com/ を参照してください。

これで、MapleSim 6 を使用することができます。

複数の Maplesoft 製品用にライセンスサーバーを起動

Maple とその関連製品を実行するには、すべてのライセンスファイルを同一のディレクトリーに入れる必要があります。ほかの FlexNet Publisher ライセンスファイルがひとつの場所に保存されている場合、Maple および関連製品のライセンスファイルもそこに置くことができます。

注意: Maple 6 とそれに関連付けられているツールボックスのライセンシングは、Maple 14 以降のライセンシングと互換性があります。ただし、Maple 14 より前のバージョンのライセンシングとは互換性がありません。バージョン 14 より前の Maple およびツールボックスでは、Maple 13 の Maple Network Tools を実行できます。

次の手順に従ってください:

ライセンスマネージャの停止

現在使われている FlexNet Publisher ユーティリティーの場所に移動してください。MapleSim 6 では、デフォルトの場所は /usr/local/Maple_Network_Tools/FLEXlm/11.7/ となります。次のコマンドを入力してください。

./lmdown
MapleSim ライセンスファイルすべてを共通のディレクトリに移動

MapleSim ネットワークライセンスファイルをすべてひとつのフォルダー、例えば $HOME/Maple_Network_Tools/activate などにコピーしてください。

ライセンスマネージャ・デーモンの起動
  1. 使用しているオペレーティングシステムの FlexNet Publisher ユーティリティーの場所に移動してください。これは、デフォルトとして $HOME/Maple_Network_Tools/FLEXlm/11.7/ となります。
  1. ライセンスマネージャ・デーモンを起動するとき、すべてのライセンスファイルを含むディレクトリーのパスを入力する必要があります。デフォルトは $HOME/Maple_Network_Tools/activate となります。

注意: ディレクトリーのパスで、ライセンスファイルそのものを指すものではありません。

  1. ライセンスマネージャを起動するには、次のコマンドを入力します。

./lmgrd -c license_file_path -l debug_log

ここで、license_file_path はライセンスファイルがあるディレクトリーのフルパスで、debug_log はデバッグ情報の書き込み先ファイル名。-l オプション(アルファベットの l で、数字の 1 ではない)を指定すると、ファイルを作成します。

これで、ネットワークライセンスの Maplesoft 製品が使用できます。

最初に戻る.

指名ネットワークライセンシング

指名ネットワーク・ユーザは、各自のクライアント・マシン上で MapleSim を走らせます。クライアント・マシンはネットワークを介してライセンスサーバーに接続します。ネットワークの指名ユーザのライセンシング・オプションは、システム管理者が、MapleSim を走らせることができるユーザまたはクライアントマシンを厳格に管理することを可能にします。

Maple Network Tools をインストールすると、オプションズファイル(.opt)が $Maple Network Tools/activate ディレクトリーに自動的に生成されます。

注意: ベンダーデーモン maplelmg.opt は、デフォルトとしてライセンスサーバーマネージャが使うライセンスファイルと同じディレクトリー内でオプションズファイルを探します。

指名ネットワークライセンシングの設定

指名ネットワーク・ユーザ・ライセンシングを設定するには、次の手順に従ってください。

オプションファイルの変更

オプションファイルを自分で変更する場合は、次の手順に従ってください。

  • オプションズファイルのディレクトリーに移動します。デフォルトでは $Maple Network Tools/activate
  • オプションファイル中の INCLUDE 文は、製品を走らせる権限を持つユーザーを指定します。各製品につき INCLUDE 文が必要となります。製品に対し複数のユーザーを指定する場合も、各ユーザーにつき INCLUDE 文が必要となります。別の方法として、GROUP 文を用いて権限を持つ指名ユーザーのグループを作ることもできます。
例 1: Maple 15 および MapleSim 6 を走らせることができるユーザを指定

INCLUDE Maple USER User1

INCLUDE Maple USER User2

INCLUDE Maple USER User3

INCLUDE Maple USER User4

INCLUDE MapleSim USER User4

例 2: GROUP 文を用いて Maple 15 および MapleSim 6 を走らせることができるユーザを指定

GROUP Maple_users User1 User2 User3 User4

INCLUDE Maple GROUP Maple_users

INCLUDE MapleSim USER User4

ライセンスマネージャを再起動します。

ライセンスマネージャを再起動しないとオプションファイルの変更は有効になりません。

最初に戻る.

MapleSim を起動する方法

Windows

Windows で MapleSim 6 を起動するには:

  • デスクトップの MapleSim 6 ショートカットアイコンをダブルクリックします。

Macintosh

Macintosh で MapleSim 6 を起動するには:

  • Applications フォルダーの MapleSim 6 アイコンをダブルクリックします。

Linux

Linux で MapleSim 6 を起動するには:

  • デスクトップの MapleSim6 アイコンをダブルクリックします。

または

  1. コマンドプロンプトで、Maple 16 インストールの bin ディレクトリーに移動してください。デフォルトは $HOME/maple16/bin。
  1. コマンド ./maplesim を実行してください。

最初に戻る.

グラフィックスの仕様

MapleSim でグラフィックスの性能を最適化するため、ビデオカードの最新ドライバーソフトウェアを使用することを強く推奨します。ビデオカードドライバー・ソフトウェアの確認方法の詳細は、ライセンスマネージャの設定 をご覧ください。

仮想マシン

最適なパフォーマンスを得るためには、MapleSim 6 のインストール・実行は物理マシンで行うことを推奨します。MapleSim 6 を仮想マシン上で実行すると性能が悪化することがあります。

動作環境

32 ビット Windows 動作環境

バージョン

CPU

推奨 RAM

ハードディスク

Windows XP

Intel Pentium III 650 MHz 以上、または完全互換

2 GB

2 GB

Windows Vista

Intel Pentium III 1 GHz

2 GB

2 GB

Windows Server 2008

x86_64 1.4 GHz (シングルコア) または x86_64 1.3 GHz (デュアルコア)、または同等

2 GB

2 GB

Windows 7

Intel Pentium III 1 GHz

2 GB

2 GB

  • DVD-ROM ドライブ(DVD インストール用)。
  • 解像度 1024 x 768 で 16 ビット色を推奨(最低条件)。
  • 内部 TCP/IP 接続有効。
  • 推奨するメモリー仕様に達していない場合は、システムの性能に影響することがあります。

64 ビット Windows 動作環境

バージョン

CPU

推奨 RAM

ハードディスク

Windows XP

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows Vista

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows Server 2008

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows 7

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

  • DVD-ROM ドライブ(DVD インストール用)。
  • 解像度 1024 x 768 で 16 ビット色を推奨(最低条件)。
  • 内部 TCP/IP 接続有効。
  • 推奨するメモリー仕様に達していない場合は、システムの性能に影響することがあります。
  • このプラットフォームでは、クラシックワークシートは提供されていません。

Macintosh 動作環境

ベンダー

CPU

オペレーティングシステム

バージョン

推奨 RAM

ハードディスク

Apple

Intel

OS X

10.6

2 GB

2 GB

Apple

64 ビット Intel

OS X

10.6, 10.7

2 GB

2 GB

  • Java™ Runtime Environment 1.6.0_18 以上を実装
  • DVD-ROM ドライブ(DVD インストール用)。
  • 解像度 1024 x 768 で 16 ビット色を推奨(最低条件)。
  • 内部 TCP/IP 接続有効。
  • 推奨するメモリー仕様に達していない場合は、システムの性能に影響することがあります。
  • このプラットフォームでは、クラシックワークシートは提供されていません。

32 ビット Linux 動作環境

ベンダー

オペレーティングシステムバージョン

CPU

推奨 RAM

ハードディスク

Red Hat Enterprise Linux

5 update 5, 6

Intel Pentium III 650 MHz または同等

2 GB

2GB

SUSE Linux Enterprise Desktop

10 SP3, 11 SP1

Intel Pentium III 650 MHz または同等

2 GB

2 GB

Ubuntu

10.04 LTS, 11.10

Intel Pentium III 650 MHz または同等

2 GB

2 GB

  • DVD-ROM ドライブ(DVD インストール用)。
  • 解像度 1024 x 768 で 16 ビット色を推奨(最低条件)。
  • X11 R6.
  • 内部 TCP/IP 接続有効。
  • 推奨するメモリー仕様に達していない場合は、システムの性能に影響することがあります。

64 ビット Linux 動作環境

ベンダー

オペレーティングシステムバージョン

CPU

推奨 RAM

ハードディスク

Red Hat Enterprise Linux

5 update 5,6

Intel 64 または AMD X86_64

2 GB

2 GB

SUSE Linux Enterprise Desktop

10 SP 3, 11 SP 1

Intel 64 または AMD X86_64

2 GB

2 GB

Ubuntu

10.04 LTS, 11.10

Intel 64 または AMD X86_64

2 GB

2 GB

  • DVD-ROM ドライブ(DVD インストール用)。
  • 解像度 1024 x 768 で 16 ビット色を推奨(最低条件)。
  • X11 R6.
  • 内部 TCP/IP 接続有効。
  • 推奨するメモリー仕様に達していない場合は、システムの性能に影響することがあります。
  • このプラットフォームでは、クラシックワークシートは提供されていません。

最初に戻る.

商標

注意: Maple は、ライセンスマネージャとして Flexera Software Corporation の FLEXlm を使用しています。本ドキュメントは標準の Maple インストールで必要な情報がすべて記載されています。詳細は、http://www.flexerasoftware.com/ のFLEXlm の文書をご覧ください。

Maple、Maplesoft、Waterloo Maple は、Waterloo Maple Inc. の商標です。

Intel は、Intel Corporation の登録商標です。

Microsoft、Windows、Windows Vista、Windows 7、Excel、Internet Explorer は、Microsoft Corporation の登録商標です。

Macintosh と Mac OS は Apple Computer, Inc. の登録商標です。

NVIDIA は NVIDIA Corporation の登録商標です。

Java と JRE は、Oracle またはその関連会社の登録商標です。

OpenGL は Silicon Graphics Inc. の登録商標です。

MATLAB は The MathWorks, Inc. の登録商標です。

FLEXlm は Flexera Software Corporation の商標です。

その他あらゆるブランド名および製品名は、それぞれの会社の商標または登録商標です。

最初に戻る.