MapleSim 4 Installation Guide

Release 4.5

Maplesoft, a division of Waterloo Maple Inc.

Pre-installation Tasks

Single User Installation

Network License Installation

Getting Started

For installation and start-up issues, see Troubleshooting.


Verifying System Requirements

Maple Requirements
Graphics Requirements
Virtual Machines
32-bit and 64-bit Windows System Requirements
32-bit Linux System Requirements
64-bit Linux System Requirements
Macintosh System Requirements

Maple Requirements

MapleSim™ 4.5 requires that Maple™ 14.01 be installed. If you have Maple 14, installing MapleSim 4.5 will automatically upgrade your Maple version to Maple 14.01. If you do not have Maple 14 and require Maple 14.01 installation and activation instructions, see the Maple 14 Installation and Licensing Guide.

Graphics Requirements

To optimize the performance of graphics in MapleSim, it is strongly recommended that you use the latest driver software available for your video card. For more information on verifying and upgrading your video card driver software, see the Maple 14 Installation and Licensing Guide.

Virtual Machines

For optimal performance, you should install and run MapleSim 4.5 on a physical computer. If you run MapleSim 4.5 on a virtual machine, you may experience performance issues.

32-bit and 64-bit Windows System Requirements

Version
CPU

Recommended RAM

Hard Disk
Windows® XP Pro
Intel® Pentium III 650 MHz or higher or fully compatible
2 GB
2 GB
Windows XP Home
Intel Pentium III 650 MHz or higher or fully compatible
2 GB
2 GB
Windows Vista® Home Basic
Intel Pentium III
1 GHz
2 GB
2 GB
Vista
Home Premium
Business
Ultimate Edition
Intel Pentium III
1 GHz
2 GB
2 GB
Windows 2003 Server

Intel Pentium III 650 MHz or higher or fully compatible

2 GB

2 GB

Windows XP Japanese Intel Pentium III 650
MHz or higher or
fully compatible
2 GB 2 GB
Windows Vista Japanese Intel Pentium III
1 GHz
2 GB 2 GB
64-bit Windows 2008 Server®
Intel Pentium III 650 MHz or higher or fully compatible
2 GB
2 GB
64-bit Windows (XP, Vista or 7)
AMD X86_64
1 GHz
Intel Xeon
Intel 64
2 GB
2 GB
64-bit Windows (XP, Vista or 7)
Japanese
AMD X86_64
1 GHz
Intel Xeon
Intel 64
2 GB 2 GB
Windows 7 Intel Pentium III
1 GHz
2 GB 2 GB
Windows 7 Japanese Intel Pentium III
1 GHz
2 GB 2 GB

32-bit Linux System Requirements

Vendor
Operating System Version
CPU
Recommended RAM
Hard Disk
Red Hat®
Enterprise 5
Intel Pentium III 650 MHz or equivalent 2 GB 2 GB
SUSE®


10.3

11.1
11.2


Intel Pentium III 650 MHz or equivalent 2 GB 2 GB
Ubuntu®
8.04
10.04
Intel Pentium III 650 MHz or equivalent 2 GB 2 GB

64-bit Linux System Requirements

Hardware Vendor
Operating System Version
CPU
Recommended RAM
Hard Disk
AMD (X86_64)
SUSE Enterprise 10
SUSE Enterprise 11
Red Hat Enterprise 5
Intel 64 2 GB 2 GB
Ubuntu 8.04
Ubuntu 10.04
Intel 64 2 GB
2 GB

Macintosh System Requirements

Vendor

Processor

Operating System

Version

Recommended RAM

Hard Disk

Apple®

Intel

OS X

10.5, 10.6

2 GB

2 GB

Apple

G4, G5

OS X

10.5

2 GB

2 GB

Apple 64-bit Intel OS X 10.5, 10.6 2 GB 2 GB
Apple 64-bit G5 OS X 10.5 2 GB 2 GB
  • Java runtime environment™ 1.6.0_18 or higher installed.
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.

MapleSim Single User Installation

During the installation process, you will need the purchase code that was sent to you in an email.

32-bit and 64-bit Windows

Note: If you are using Maple and MapleSim in a 64-bit Microsoft® Windows environment, you must install and set up a Microsoft® Visual C++ compiler to use the compile option in the MapleSim interface. For instructions on setting up a Microsoft Visual C++ compiler to use with Maple and MapleSim, click here.

  1. Double-click the MapleSim4.5WindowsInstaller.exe file located on your installation disc or in the directory where you downloaded the file.
  2. Follow the on-screen instructions. MapleSim is installed in c:\Program Files\Maple 14\toolbox\MapleSim4.5.

32-bit and 64-bit Linux

  1. Run MapleSim4.5Linux32Installer.bin or MapleSim4.5LinuxX86_64Installer.bin located on the installation disc or in the directory where you downloaded the file.
  2. Follow the on-screen instructions. MapleSim is installed in $HOME/Maple 14/toolbox/MapleSim4.5, where $HOME is your home directory.

Macintosh

  1. Double-click the MapleSim4.5MacInstaller.dmg file located on your installation disc or in the directory where you downloaded the file and then double-click the MapleSim4.5MacInstaller.app file icon.
  2. Follow the on-screen instructions. MapleSim is installed in /Library/Frameworks/Maple.framework/Versions/14/toolbox/MapleSim4.5.

Activating Single User Versions

Starting MapleSim requires a MapleSim license file to operate. You must activate the single user version of MapleSim to obtain your license file. If you are running a single user installer, you can activate during the installation process. If you do not activate during the installation process, follow the steps below.
  1. Activation requires an Internet connection. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  2. Start MapleSim.
  3. When prompted to activate, click Activate.
  4. You will be prompted to enter your purchase code. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  5. You will be prompted to enter additional information. Click Next when this is complete.

*On Windows, you can also activate using the Start menu shortcut Programs>MapleSim 4.5>Tools>Activate MapleSim 4.5.
Note: If you are using Windows Vista or Windows 7, right-click Activate MapleSim 4.5 and select Run as administrator.
*On Linux, you can also activate by running the activation script located in the $HOME/Maple14/toolbox/MapleSim4.5/license directory.
*On Macintosh, you can also activate by running the activation script located in the toolbox/MapleSim4.5/license folder of your Maple 14.01 installation. By default, /Library/Frameworks/Maple.framework/Versions/14/toolbox/MapleSim4.5/license.

A MapleSim license file (MapleSim.dat) will be saved in the license folder of your MapleSim installation.

MapleSim Network License Installation

32-bit and 64-bit Windows

Note: If you are using Maple and MapleSim in a 64-bit Microsoft Windows environment, you must install and set up a Microsoft Visual C++ compiler to use the compile option in the MapleSim interface. For instructions on setting up a Microsoft Visual C++ compiler to use with Maple and MapleSim, click here.

  1. Double-click the MapleSim4.5WindowsInstaller.exe file located on your installation disc or in the directory where you downloaded the file.
  2. Follow the on-screen instructions
  3. In the Choose The Type of Licensing screen, select Network License
  4. When prompted, enter the name or IP address of the license server

MapleSim is now installed. Prior to using MapleSim, you need to configure the license manager.

32-bit Linux

  1. Log in to the account that will own the MapleSim files
  2. Run MapleSim4.5Linux32Installer.bin from wherever you downloaded the file.
  3. Follow the on-screen instructions
  4. In the Choose The Type of Licensing screen, select Network License
  5. When prompted, enter the name or IP address of the license server

MapleSim is now installed. Prior to using MapleSim, you need to configure the license manager.

64-bit Linux

  1. Log in to the account that will own the MapleSim files
  2. Run MapleSim4.5LinuxX86_64Installer.bin from wherever you downloaded the file.
  3. Follow the on-screen instructions
  4. In the Choose The Type of Licensing screen, select Network License
  5. When prompted, enter the name or IP address of the license server

MapleSim is now installed. Prior to using MapleSim, you need to configure the license manager.

 

Macintosh

  1. Double-click the MapleSim4.5MacInstaller.dmg file located on your installation disc or in the directory where you downloaded the file and then double-click the MapleSim4.5MacInstaller.app file icon.
  2. Follow the on-screen instructions.
  3. In the Choose The Type of Licensing screen, select Network License
  4. When prompted, enter the name or IP address of the license server

MapleSim is now installed. Prior to using MapleSim, you need to configure the license manager.


Configuring the License Manager

32-bit and 64-bit Windows Network Licensing
32-bit and 64-bit Mac OS X Network Licensing
32-bit and 64-bit UNIX/Linux Network Licensing

32-bit and 64-bit Windows Network Licensing

Install FLEXlm and Activation Utilities

  1. Double-click NetworkToolsInstaller_Windows.exe from the disc or from where you downloaded the file.
  2. Follow the on-screen instructions.

Activate a Network License

  1. Go to c:\Program Files\Maple Network Tools\activate
  2. Double-click the activation icon to run the activation script.
  3. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  4. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is complete.
  5. A license file, MapleSim4.lic, will be saved to the c:\Program Files\Maple Network Tools\activate folder. You will need this license file in the next step

Start the License Manager for MapleSim Only

The \FLEXlm\11.7\windows directory, installed in the c:\Program Files\Maple Network Tools directory, contains license manager daemons (lmgrd and maplelmg) required to run Maplesoft products, as well as utilities to assist you in installing and configuring FLEXlm for your system.

Start the License Manager Daemons

If you intend to use a Novell® server, see Novell Networks.

To set up and start the license manager daemons on a Windows Network Server:

    1. From the Start menu, select Programs >Maple Network Tools ->LMTools.
    2. Under the Service/License File tab, click Configuration using Services.
    3. Click the Config Services tab.
    4. In the Config Services property sheet, enter or browse to the following files:
Service Name Enter a name for the service (optional)
Path to the lmgrd.exe file C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe
Path to the license file

C:\Program Files\Maple Network Tools\activate\MapleSim4.lic
Path to the debug log file C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt
  1. To set up the daemons as a service (recommended), select the Use Services check box. This is available for Windows 2003, XP, Vista, and Windows 7.
  2. To start the daemons at boot time (recommended), select the Start Server at Power Up check box.
  3. Click Save Service. When prompted to save the service, click Yes.
  4. Click the Start/Stop/Reread tab. In that property sheet, click Start Server to start the license manager daemons.
You can now use MapleSim.

Return to the Top of the Document.

Start the License Manager for Multiple Maplesoft Products

To run MapleSim 4.5, Maple 14.01, and associated toolboxes, you must place all license files in the same directory. If you have other FLEXlm license files stored in one central location, you can store the MapleSim license file there as well.

Note: MapleSim 4.5, Maple 14.01, and associated toolbox licensing is not compatible with licensing for previous versions of Maple. You must install and run Maple Network Tools for MapleSim 4.5, Maple 14.01, and associated toolboxes on a different machine.

Complete the following tasks:

Task 1: Stop the License Manager

    1. Go to the directory of the FLEXlm utilities that are currently being used.
    2. Double-click lmtools.exe.
    3. Under the Service/License File tab, click Configuration using Services.
    4. Click the Config Services tab. From the Server Name list, select the service currently being used.
    5. Click the Start/Stop/Reread tab, then click Stop Server.

Task 2: Move all Maple License Files to a Common Directory

Using Windows Explorer, move all of the license files to a common directory, for example, C:\Program Files\Maple Network Tools\activate.

Task 3: Start the License Manager Daemons

    1. From the Start menu, select Programs >Maple Network Tools >LMTools.
    2. Under the Service/License File tab, click Configuration using Services.
    3. Click the Config Services tab.
    4. In the Config Services property sheet, enter or browse for the following:
Service Name Enter a name for the service (optional)
Path to the lmgrd.exe file C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe
Path to the license file

Enter the path to the directory containing all of the license files. Point to the directory only, not an actual license file.

C:\Program Files\Maple Network Tools\activate
Path to the debug log file C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt
  1. To set up the daemons as a service (recommended), select the Use Services check box. This is available for Windows 2003, XP, Vista, and Windows 7.
  2. To start the daemons at boot time (recommended), select the Start Server at Power Up check box.
  3. Enter a name for your service and click Save Service. When prompted to save the service, click Yes.
  4. Click the Start/Stop/Reread tab, click Start Server to start the license manager daemons.

You can now use your network licensed Maplesoft products.

Novell Networks

FLEXlm does not run on Novell or IPX/SPX. Follow these instructions to install the license manager on any network that is exclusively a Novell environment.
  1. Install TCP/IP on all client machines.
  2. Select a Windows computer that has TCP/IP installed to act as a license server and run the license daemons using the Start the License Manager for MapleSim Only instructions.

 

32-bit and 64-bit Mac OS X Network Licensing

Install FLEXlm and the Activation Utilities

  1. To begin installing the FLEXlm and Activation Utilities, choose one of the following:
    1. Place the Maple 14 Macintosh disc in the media drive.
    2. Double-click NetworkToolsInstaller_Mac.zip from where you downloaded the file.
  2. Run the installer by double-clicking the NetworkToolsInstaller icon.
  3. Follow the on-screen instructions

Activate a Network License

  1. From the Finder, open a terminal window from Applications -> Utilities.
  2. Go to/Users/username/Applications/Maple_Network_Tools/activate.
  3. Run the activation script by issuing the command ./activation. To launch activation in console mode, use the -console option.
  4. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  5. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is complete.
  6. A license file, MapleSim4.lic, will be saved to the /Users/username/Applications/Maple_Network_Tools/activate directory. You will need this license file for the next step.

Start the License Manager for MapleSim Only

Start the License Manager Daemons

Before you can use MapleSim, you must start the license server. It is recommended that you do not run lmgrd as root because any process run by root is a potential security risk.

  1. Navigate to the location of the FLEXlm utilities for your operating system. By default, /Users/username/Applications/Maple_Network_Tools/FLEXlm/11.7.
  2. Start the license manager daemons.
  3. To start the license manager daemon (lmgrd), enter the following command at the prompt:

./lmgrd -c license_file_path -l debug_log &

where license_file_path is the full path and filename of the network license file (by default, /Users/username/Applications/Maple_Network_Tools/activate/MapleSim4.lic), and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

Help for Starting the License Server

If you have any problems starting the license server in the system boot up files, refer to http://www.flexerasoftware.com.

You can now use MapleSim.

Return to the Top of the Document.

Start the License Manager for Multiple Maplesoft Products

To run MapleSim 4.5, Maple 14.01, and associated toolboxes, you must place all license files in the same directory. If you have other FLEXlm license files stored in one central location, you can store the MapleSim license file there as well.

Note: MapleSim 4.5, Maple 14.01, and associated toolbox licensing is not compatible with licensing for previous versions of Maple. You must install and run Maple Network Tools for MapleSim 4.5, Maple 14.01, and associated toolboxes on a different machine.

Complete the following tasks:

 

Task 1: Stop the License Manager

Go to the location of the FLEXlm utilities that are currently being used. For Maple 14.01, the default location is Users/username/Applications/Maple_Network_Tools /FLEXlm/11.7. Enter the command:

./lmdown -c license_file_path

Task 2: Move All License Files to a Common Directory

Copy all the network license files to /Users/username/Applications/Maple_Network_Tools/activate.

Task 3: Start the License Manager Daemons

    1. Navigate to the location of the FLEXlm utilities for your operating system. By default, /Users/username/Applications/Maple_Network_Tools/FLEXlm/11.7/.
    2. When starting license manager daemons, you must enter the path to the directory containing all license files. By default, /Users/username/Applications/Maple_Network_Tools/activate.

Note: Point to the directory only, not an actual license file.

  1. To start the license manager, enter the following command:

./lmgrd -c license_file_path -l debug_log

where license_file_path is the full path to the directory containing the license files and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

You can now use your network licensed Maplesoft products.

Return to Top of the Document.

32-bit and 64-bit UNIX/Linux Network Licensing

Install FLEXlm and the Activation Utilities

  1. On Linux 32-bit, run the NetworkToolsInstaller_Linux.bin file from the disc or from where you downloaded the file.
    On Linux 64-bit, run the NetworkToolsInstaller_LinuxX86_64.bin file from the disc or from where you downloaded the file.
    On Solaris, run the NetworkToolsInstaller_Sun.bin file from the disc or from where you downloaded the file.
  2. Follow the on-screen instructions.

Activate a Network License

  1. Go to the $HOME/Maple_Network_Tools/activate directory and run the activation command. To launch activation in console mode, use the -console option.
  2. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  3. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is completed.
  4. A license file, MapleSim4.lic, will be saved to the $HOME/Maple_Network_Tools/activate directory. You will need this license file for the next step

Start the License Manager for MapleSim Only

Start the License Manager Daemons

Before you can use MapleSim, you must start the license server. It is recommended that you do not run lmgrd as root because any process run by root is a potential security risk.

  1. Navigate to the location of the FLEXlm utilities for your operating system. By default, $HOME/Maple_Network_Tools/FLEXlm/11.7/
  2. Start the license manager daemons.

Using the C Shell

To start the license manager daemon (lmgrd), enter the following command at the prompt,

./lmgrd -c license_file_path -l debug_log &

where license_file_path is the full path and filename of the network license file (by default, $HOME/Maple_Network_Tools/activate/MapleSim4.lic) and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

Using the Korn or Bourne Shell

To start the license manager daemon (lmgrd), enter the following command at the prompt:

./lmgrd -c license_file_path -l debug_log 2>&1 &

where license_file_path is the full path and filename of the network license file (by default, $HOME/Maple_Network_Tools/activate/MapleSim4.lic) and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

Run Daemons on Startup

To have the daemons run on startup, edit the appropriate boot script (such as /etc/rc.boot, /etc/rc.local, or /etc/rc2.d/Sxxxx). For example, if you run lmgrd as a boot startup script, you can run it as a regular user by using the following su command at the prompt:

su username -c 'umask 022; lmgrd_path -c license_file_path -l log_path'

where username is a non-privileged user; lmgrd_path is the correct path to the lmgrd file, license_file_path is the network license file, and log_path is the debug log file. It is recommended that the network license file be called MapleSim4.lic.

Help for Starting the License Server

If you have any problems starting the license server in the UNIX system boot up files, refer to http://www.flexerasoftware.com.

You can now use MapleSim.

Return to the Top of the Document.

Start the License Manager for Multiple Maplesoft Products

To run MapleSim 4.5, Maple 14.01, and associated toolboxes, you must place all license files in the same directory. If you have other FLEXlm license files stored in one central location, you can store the MapleSim license file there as well.

Note: MapleSim 4.5, Maple 14.01, and associated toolbox licensing is not compatible with licensing for previous versions of Maple. You must install and run Maple Network Tools for MapleSim 4.5, Maple 14.01, and associated toolboxes on a different machine.

Complete the following tasks:

Task 1: Stop the License Manager

Go to the location of the FLEXlm utilities that are currently being used. For MapleSim 4.5, Maple 14.01, and associated toolboxes, the default location is $HOME/Maple_Network_Tools/FLEXlm/11.7 . Enter the command:

./lmdown -c license_file_path

 

Task 2: Start the License Manager Daemons

      1. Navigate to the location of the FLEXlm utilities for your operating system. By default, $HOME/Maple_Network_Tools/FLEXlm/11.7/.
      2. When starting license manager daemons, you must enter the path to the directory containing all of your license files. By default, $HOME/Maple_Network_Tools/activate.

        Note: Point to the directory only, not an actual license file.

      3. To start the license manager, enter the following command:

        ./lmgrd -c license_file_path -l debug_log

        where license_file_path is the full path to the directory containing the license files and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

You can now use your network licensed Maplesoft products.

Return to Top of the Document.


Named Network Licensing

Named Network Users run MapleSim on their own client machines. These client machines are connected to the license server over the network.
The Network Named User licensing option allows system administrators to strictly enforce which users, or client machines, may run MapleSim.


When you  install Maple Network Tools,  an options file (.opt) is automatically created  in the $MAPLE NETWORK TOOLS/activate directory.

Note: The vendor daemon, maplelmg.opt, by default, looks for the options file with in the same directory that contains the license file used by the license server manager.


To manually edit the options file, perform the following steps:

 

Example 1: Specifying which users can run MapleSim 4.5 and Maple 14.01

INCLUDE Maple14   USER  User1
INCLUDE Maple14   USER  User2
INCLUDE Maple14   USER  User3
INCLUDE Maple14   USER  User4
INCLUDE MapleSim4  USER   User4

Example 2: Using GROUP syntax to specify users that can run MapleSim 4.5 and Maple 14.01


GROUP Maple_users User1 User2 User3 User4
INCLUDE Maple14 GROUP Maple_users
INCLUDE MapleSim4 USER User4


 

 


Starting MapleSim

32-bit and 64-bit Windows

32-bit and 64-bit Linux

You can start MapleSim by:

or

  1. At the command prompt, switch to the bin directory of your Maple 14 installation. By default, $HOME/maple14/bin.
  2. Run the command ./maplesim4.5.

Macintosh


Installing and Setting Up A Microsoft Visual C++ Compiler (64-bit Windows)

To install and set up the required software on your computer, follow the steps below.

Microsoft Visual C++ 2008 Express Edition

  1. Download and install the following software on your computer:
  1. Set up the Microsoft Visual C++ compiler for Maple 14 by specifying the path of the vcvars64.bat file that is distributed with Microsoft Windows SDK for Windows Server 2008. To specify the path of the vcvars64.bat file do one of the following:

Microsoft Visual C++ 2010 Express Edition

  1. Download and install the following software on your computer
  1. You can manually define the %LIB%, %INCLUDE% and %PATH% environment variables used by the compiler or you can set up the Microsoft Visual C++ compiler for Maple 14 by specifying the path of the vcvars64.bat file created during the Maple installation process. To specify the path of the vcvars64.bat file do one of the following:

@set VSINSTALLDIR=<path to Visual Studio>

You can either copy this file to your Visual Studio installation (VC\bin) or use the edited template in the bin.x86_64_WINDOWS directory. If you use the edited template, you must include the absolute file path in the bin.x86_64_WINDOWS\launch.ini file.

compilersetup="<path to vcvars64.bat>\vcvars64.bat"

Note About Setting Up the Vcvars64.bat File

There are two possible issues you may encounter while setting you the vcvars64.bat file:

  1. You do not have sufficient permissions on your machine. If this is the case, the registry scan performed by the batch file may fail and the "WindowsSdkDir not found " message is displayed. The compiler link will not work.
  2. The registry value being scanned points to an older SDK.

Solution

Open the vcvars64.bat file and do the following:

  1. Add @rem before and after the command, @call :GetWindowsSdkDir to disable the command
  2. Remove the @rem command from @rem @set WindowsSdkDir=C:\Program Files\Microsoft SDKs\Windows\v7.1\ @rem
  3. Save the changes to the file.

Troubleshooting

Issue:

No 3-D model is displayed in the 3-D workspace after you simulate a multibody system. This issue has been known to occur on Microsoft Windows operating systems using an Intel® 9XX series chipset.

For more information about identifying your Intel chipset type, visit http://www.intel.com/support/chipsets/sb/cs-009245.htm.

Resolution:

Make sure that the latest driver software for your video card is installed on your computer. For more information about verifying and upgrading your video card driver software, see the Maple 14 Installation and Licensing Guide.


Trademarks

Maple, MapleSim, Maplesoft, and Waterloo Maple are trademarks of Waterloo Maple Inc.
Apple, Mac OS, and Macintosh are trademarks of Apple Inc., registered in the U.S. and other countries.
Microsoft, Windows, Windows Server and Windows Vista, are registered trademarks of Microsoft Corporation.
Intel and Pentium are registered trademarks of Intel Corporation.
Java and Java runtime environment are trademarks of Sun Microsystems, Inc. in the United States and other countries.
Linux is a registered trademark of Linus Torvalds.
SUSE is a registered trademark of Novell, Inc. in the United States and other countries.
Ubuntu is a registered trademark of Canonical Ltd.

All other brand names or product names are trademarks or registered trademarks of their respective companies.