Overview of Tables - Maple Programming Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : Create Maple Worksheets : Format Maple Worksheets : worksheet/documenting/table

Overview of Tables

  

Tables provide a convenient mechanism for organizing content in the standard worksheet interface.

 

Creating a Table

Cell Contents

Navigating Table Cells

Modifying the Structural Layout of a Table

Modifying the Physical Dimensions of a Table

Modifying the Appearance of a Table Programmatically

Modifying the Appearance of a Table

Working With Table Captions

Applying a Table Cross-Reference

Printing Options

Execution Order Dependency

Classic Worksheet

Examples

Creating a Table

  

To create a table:

1. 

From the Insert menu, select Table.

2. 

Specify the number of rows and columns in the Insert Table dialog.

• 

If the cursor resides in an execution group, you can insert the table before or after the group.

• 

If the cursor resides in a document block, you can insert the table before or after the document block.

• 

If the cursor resides within an existing table, the table will be inserted at the cursor location.

3. 

If you want to include a table caption, select the Show table caption check box and enter a title (optional).

4. 

Click OK.

  

The default properties for the table include visible borders and auto-adjustment to 100% of the document width. These options, as well as the table dimensions, may be modified after table creation. The following is an example table using the default settings:

Cell Contents

  

Any content that can be placed into a section can also be placed into a table cell including other sections and tables. Table cells may contain a mix of:

• 

Input commands

• 

2-D math

• 

Embedded Components

• 

Plots

• 

Images

Navigating Table Cells

  

Use the Tab key to move between cells.

Modifying the Structural Layout of a Table

  

The number of rows and columns in a table may be modified using the Insert and Delete submenus in the Table menu or using the Cut and Paste tools.

Inserting Rows and Columns

  

Row and column insertion is relative to the table cell that currently contains the text input cursor. If the worksheet has an active selection, insertion is relative to the selection boundaries.

• 

Column insertion may be to the left or right of the document position marker or selection.

• 

Row insertion may be above or below the marker or selection.

Cutting and Deleting

  

With cut and paste operations, a dialog opens allowing you to specify the desired behavior. For example, you can delete the selected rows, or merely reset the contents of the selected cells.

Pasting

  

Pasting a table subselection into a table may result in the creation of additional rows or columns, overwriting existing cell content, or the insertion of a subtable within the active table cell.

Merging

  

You can merge cells across row or column boundaries. The resultant cell must be rectangular. The contents of the individual cells in the merge operation are concatenated in execution order.

Modifying the Physical Dimensions of a Table

  

The overall width of the table may be controlled in several ways.

  

The most direct way is to press the left mouse button while hovering over the left or right table boundary and drag the mouse left or right. Upon release of the mouse button, the table boundary is updated and the table layout is updated. This approach may also be used to resize the relative width of table columns.

  

Alternately, the size of the table may be controlled from the Table Properties dialog (from the Table menu, select Properties). Two sizing modes are supported:

• 

Fixed percentage of page width. Using the first option, the table adjusts its width whenever the width of the worksheet changes. This option is useful for ensuring that the entire content of the table fits onto the screen or printed page.

• 

Scale with zoom factor. The second option (scale with zoom factor) is used to preserve the layout of the table regardless of the size of the worksheet window or the zoom factor. If the table exceeds the width of the worksheet window, the horizontal scroll bar may be used to view the rightmost columns.

Modifying the Appearance of a Table Programmatically

  

It is possible to access some table properties programmatically using the DocumentTools package.  For details, see Table Properties using DocumentTools.

Modifying the Appearance of a Table

Table Borders

  

The style of exterior and interior borders is set using the Table Properties dialog.

• 

You can set all, none, or only some of the borders to be visible in a table.

• 

You can control the visibility of interior borders by using the Group submenu of the Table menu.

– 

Grouping rows or columns suppresses interior borders within the table selection.

– 

Grouping rows and columns requires that the interior border style is set to By row and column group.

• 

Hidden borders are made visible when the mouse hovers over a table. Note that this feature (border visibility on mouse roll over) can be disabled. There are two ways to do so: for all tables in the worksheet or for one table.

  

 To set the table border display settings for the entire worksheet:

1. 

From the View menu, select Show/Hide Contents.

2. 

In the Show Contents window, select Hidden Table Borders to show hidden table borders. Clear the check box to suppress the outline of the hidden table borders.

  

 To set the table border display settings for a table:

1. 

Click anywhere inside your table.

2. 

From the Table menu, select Properties.

3. 

In the Table Properties dialog, find the Show hidden borders drop-down list.

4. 

From the list, the options are:

• 

Never - Hidden table borders are never displayed.

• 

According to Show/Hide Setting -  The table obeys the global worksheet setting (default).

• 

Always - Hidden table borders are always displayed on mouse hover.

  

When you change this border display setting for an individual table to Never or Always, it overrides the global worksheet settings.

Cell Colors

  

You can select a background color for a single cell, or a selection of cells.

  

To set the background color, first highlight the cell or cells you want to have a particular color. From the Table menu, select Cell Color. Choose a color from the Select A Color dialog, by using one of the following tools:

• 

Select a pre-defined color from the Color Palette.

• 

Move the slider beside the Color Wheel to display a range of colors, then choose one from the wheel.

• 

Specify the RGB values of a color by moving the Color Value Sliders.

  

Once you have selected the color, click OK to color the highlighted cell(s).

  

To remove all background color from a cell or cells, highlight the cell(s), and from the Table menu, select Cell Color. In the Select A Color dialog, click None, then OK.

Alignment Options

  

The table alignment tools provide a mechanism to control the horizontal alignment of columns or vertical alignment of rows.

  

For column alignment, the current selection is expanded to encompass all rows in the table. The alignment choice applies to all cells within the expanded selection. If the worksheet does not contain a selection, the cursor position is used to identify the column.

  

Similarly, the selection is expanded to include all columns for vertical alignment options. The following table illustrates the vertical alignment options. The baseline option is very useful for aligning equations across multiple cells within a row of a table.

Controlling the Visibility of Cell Content

  

The Table Properties dialog includes two options to control the visibility of cell content. These options allow control over the visibility of Maple input and execution group boundaries. Thus, Maple input may be hidden in a table, even if input is set to visible for the worksheet in the View>Show/Hide Contents dialog. The formatting options provide a mechanism to create a table of results.

Working With Table Captions

  

Captions offer a way of adding a description to a table, drawing the reader's attention to a table, and identifying the table so it can be referenced from elsewhere in the worksheet. Maple provides the ability to add captions to tables within documents and worksheets. Table captions are generated sequentially. If you remove or insert a caption, Maple automatically re-numbers all table captions and updates cross references.

Adding a Caption to a Table

  

To add a caption to a table:

1. 

Click a table that you created in the worksheet.

2. 

From the Table menu, select Properties.

3. 

In the Table Properties dialog, click the Caption tab.

4. 

Select the Show Caption check box. By default, the Show Caption box is unchecked.

5. 

Select your display option from the available choices.

Available Choices for Table Caption Display Options

• 

Caption number only: The caption will be of the form Table #, where # is a sequentially generated numeric value based on the number of captions already in the worksheet.

• 

Caption title only: The caption will display only the description entered in the Title field.

• 

Caption number and title: The caption will display both the caption number and caption title. The caption will have the form Table #: <description_from_Title_field>

Changing the Alignment or Position of Table Captions

  

To change the alignment or position of a table caption for an individual table:

1. 

Click the table for which you would like to change the caption alignment or position.

2. 

From the Table menu, select Properties.

3. 

In the Table Properties dialog, click the Caption tab.

4. 

To adjust the position of the table caption to above the table click the Above radio button. Similarly, to have the table caption appear below the table, click the Below radio button.

5. 

To adjust the alignment so that the table caption is left aligned with the table, centered, or right aligned with the table, click the Left, Center, or Right radio buttons, respectively.

6. 

Click OK.

  

To change the alignment or position of a table caption globally in a document:

1. 

From the Format menu, select Captions.

2. 

In the Table tab, use the radio buttons to control caption position and alignment, as described in the previous section.

3. 

Click Apply To All Tables.

4. 

Click OK.

Removing a Caption From a Table

  

To remove a caption from a table:

1. 

Click a table that you created in the worksheet.

2. 

From the Table menu, select Properties.

3. 

In the Table Properties dialog, click the Caption tab.

4. 

Clear the Show Caption check box.

5. 

Click OK.

Removing Table Captions Globally From a Worksheet

  

To remove all table captions from a worksheet:

1. 

From the View menu, select Show/Hide Contents...

2. 

Clear the Table Captions check box.

3. 

Click OK.

Changing the Font Color and Size of Table Captions

  

To change the font color or font size of  table captions in a worksheet:

1. 

From the Format menu, select Styles....

2. 

In the Style Management window, select the Caption text style from the list.

3. 

Click the Modify button.

4. 

Once you have finished making your changes, click OK.

Applying a Table Cross-Reference

  

Tables provide formatted and summarized information that is easy for a reader to parse. By adding table cross-references to your document, you provide quick access to the table and make navigation of your document easier.

  

Applying a cross-reference is similar to applying an equation label. To apply a cross-reference in a worksheet or document:

1. 

Navigate to the position within the document or worksheet where the table will be referenced and switch to Text mode of input.  

2. 

From the Insert menu, select Label. Alternatively, use the shortcut keys Ctrl+L (Command+L on Macintosh). The Insert Label dialog is displayed. For the Type of label, select Table. Enter the table number for the table you want to reference in the Identifier field (for example, enter 1 if you want to reference Table 1).

  

Note: When you are inserting a cross-reference you can only reference tables in the same worksheet.

3. 

If you want to keep the reference to the same table, regardless of its table number, then right-click on the newly inserted table cross-reference and check Label Reference.

Printing Options

  

The Table Properties dialog contains options to control the placement of page breaks when printing. The user can force a table to fit on a single page, allow page breaks between rows, or allow page breaks within a row.

Execution Order Dependency

  

The order in which cells are executed by an "Execute All" may be set in the Table Properties dialog. The following tables illustrate the effect of execution order.

Classic Worksheet

  

Tables are flattened on export to the classic interface.

  

Before- Table in Standard Worksheet interface.

  

After- Table in Classic Worksheet interface.

Examples

Table of Values

  

This example illustrates how to set the visibility options for cell contents to display a table of values.

  

Table Settings:

1. 

From the Table menu, select Properties. The Table Properties dialog opens.

2. 

Set Table Size Mode to Scale with zoom factor.

3. 

Clear the check boxes for Show input and Show execution group boundaries.

Formatting Table Headers

  

The following table makes use of cell merging for formatting row and column headers, and row and column grouping to control the visibility of cell boundaries.

  

Table Settings:

  

Using the Table menu:

1. 

Merge the following sets of (Row,Column) cells: (1,1) to (2,2), (1,3) to (1,4), and (3,1) to (4,1).

2. 

Group columns 1 and 2, and columns 3 and 4.

3. 

Group rows 1 and 2, and rows 3 and 4.

  

Using the Table Properties dialog (from the Table menu, select Properties):

4. 

Change Table Size Mode to Scale with zoom factor.

5. 

Set Exterior Borders to None.

  

Using the Table menu:

6. 

Set Alignment of columns 3 and 4 to Center.

2-D Math and Plots

  

This example illustrates the use of tables to display 2-D math and plots side by side.

  

Table Settings:

  

Using the Table Properties dialog (from the Table menu, select Properties):

1. 

Set Exterior and Interior Borders to None.

2. 

Clear the check boxes for Show input and Show execution group boundaries.

  

Using the Table menu:

3. 

Change row Alignment to Center.

Table of Mathematical Expressions

  

This example illustrates using the baseline alignment option to align equations across columns in a table.

  

Table Settings:

  

Using the Table Properties dialog (from the Table menu, select Properties):

1. 

Set Exterior Border to Top and Bottom.

  

Using the Table menu:

2. 

Group columns 1 and 2.

3. 

Group rows 2 to 4.

4. 

Set row Alignment to Baseline for all rows.

See Also

worksheet/managing/hidecontent

 


Download Help Document

Was this information helpful?



Please add your Comment (Optional)
E-mail Address (Optional)
What is ? This question helps us to combat spam