Using Document Blocks - Maple Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : Create Maple Worksheets : Structure Worksheets with Execution Groups and Document Blocks : worksheet/documenting/documentblocks

Using Document Blocks

  

With the Document Block feature, you can create Maple worksheets or documents that present text and math in formats similar to those found in business and education documents. If your main purpose is to create a document, you can use Document Mode, which is a Maple worksheet comprised of document blocks.

  

With document blocks, note the following:

• 

Input prompts and execution groups are not displayed.

• 

(Optional) Before using document blocks, set your worksheet to display Markers. Icons representing document blocks are displayed in a vertical bar left of the associated text.

  

To activate markers:

• 

From the View menu, select Markers.

  

You can also create document blocks within Worksheet mode.

Applying Document Blocks in Worksheet Mode

  

General Process

1. 

Enter input at the Maple command prompt.

  

Note: These instructions are for Worksheet mode.

2. 

Execute the area, creating output that may be referenced elsewhere in the document. See Equation Labels.

3. 

Intersperse the area with the content that is to remain visible, adding references to the input and output in the appropriate locations.

4. 

Select the area (text and math content) you want to format.

5. 

From the Format menu, select Create Document Block.

6. 

From the View menu, select Inline Document Output.

  

The block displays text and 2-D math output only. You can select areas to display 2-D math input instead of output.

7. 

Select the output region you want to display as input. From the View menu, select Toggle Input/Output Display. The selected region displays input.

View Document Block Code

  

To view the contents, that is, all code and expanded execution groups within a document block, you must expand the document block.

1. 

Place the cursor in the document block region.

2. 

From the View menu, select Group and Block Management, and then select Expand Document Block.

3. 

To hide code again, select Collapse Document Block from the same list.

  

Note: Document blocks will always try to display something; output will be displayed if available. If there is no output, then input will be displayed.

Expand an Execution Group within a Document Block

  

An execution group is a grouping of Maple input with its corresponding Maple output. It is distinguished by a large square bracket called a group range at the left. As document blocks can contain many execution groups, you can select to expand an execution group within a document block.

1. 

Place the cursor in the document block region.

2. 

From the View menu, select Group and Block Management, and then Expand Execution Group.

3. 

To hide the group, select Collapse Execution Group from the same list.

Switch between 2-D Math Input and Output

1. 

Place the cursor in a 2-D math input or output section in a document block region.

2. 

From the View menu, select Toggle Input/Output Display.

2-D Math in Document Blocks

  

In document blocks, to execute all 2-D math input, use any of the following methods:

• 

Press Ctrl+=. This evaluates and displays results inline.

• 

Use the Edit menu item Evaluate and Display Inline. (This can also be invoked through the context-sensitive menu.)

• 

Use the Edit menu item Evaluate.

• 

Press Enter. This evaluates and displays results on the next line or, if set in the Options dialog, simply evaluates.

  

The dual behavior of the Enter key (Evaluate menu item) is set in the Display tab of the Options dialog. See Options>Display.

See Also

2-D Math, Ditto Operator, Document Mode, Documents and Worksheets, Edit Menu, Format Menu, Options>Display, View Menu


Download Help Document

Was this information helpful?



Please add your Comment (Optional)
E-mail Address (Optional)
What is ? This question helps us to combat spam