Troubleshooting Updated Models Created in MapleSim 4 or Earlier - MapleSim Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : MapleSim : Using MapleSim : Building a Model : Troubleshooting : errorMessage/updatingModels

Troubleshooting Updated Models Created in MapleSim 4 or Earlier

If you update a model created in MapleSim 4 or earlier for use in MapleSim 5 and then simulate that model using the Mark II engine in MapleSim 5, one of the following issues may occur:

• 

You receive results that are different from those generated by the Mark I engine

• 

Messages appear in the MapleSim debugging console

These issues may occur if your model has an inconsistent set of enforced initial conditions or if the initial configuration of your model was not fully specified.

Inconsistent Set of Initial Conditions

If an inconsistent set of initial conditions was specified for a model, and you simulate that model using the Mark I engine, the constraints and fixed initial conditions specified for the model would be relaxed and the engine will try to find a consistent initial configuration. In these cases, if you set the progress information level to Verbose, the following message will be displayed in the debugging console:

  reconfigure: inconsistent initial conditions; ignoring some constraints

If a consistent set of initial conditions is found, the simulation will proceed.

When you attempt to simulate the same model using the Mark II engine, the simulation will stop when inconsistent initial conditions are detected. In these cases, an error message such as

    (in dsolve/numeric/DAE/initialize) initial conditions do not satisfy the equations; error=1., tolerance=.1e-9, constraint=EQUATION 

or a more general message

    initialization failed, please check initial data

will appear, indicating that an inconsistency in the enforced initial conditions has been found or that better guess values are required to find a consistent initial configuration. This ensures that the initial configuration for the simulation is the one that you specified.

Underspecified Systems

If the initial configuration of a model is not fully specified, it is possible that the Mark I and Mark II engines will find different initial configurations for your model.

Solution: This issue can be resolved by enforcing the initial values for your model. For more information about enforcing initial values, see Specifying Initial Conditions. A fully specified model will then have the same initial configuration when either the Mark I and Mark II engine is used.

Note:  Although models that are opened in MapleSim 5 use the Mark II engine by default, the Mark I engine can be selected to help match the results between the two engines.

See Also

Updating Models Created in a Previous Release of MapleSim

Running a Simulation

Changing the Progress Information Level

Specifying Initial Conditions

 

 

 

 

 


Download Help Document

Was this information helpful?



Please add your Comment (Optional)
E-mail Address (Optional)
What is ? This question helps us to combat spam