Quick Help - Maple Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : Getting Started : worksheet/help/QuickHelpDetails

Quick Help

Toggle Math/Text

In Document mode, toggling between Text and Math modes switches between entering text and entering 2-D mathematical expressions x2y. In Worksheet mode, toggling between Math and Text modes switches between 2-D and 1-D Math commands. By default, Maple uses Math mode.

 

Use the F5 key to switch between Math and Text modes. Math mode is characterized by a slanted, italic prompt (/) whereas the Text mode is characterized by a regular prompt (|).

 

In this document, the following icons distinguish modes.

Document Mode

Worksheet Mode

In Document Mode

Examples

Steps

x2 is a function of x

x^2 F5 is a function of F5 x

A simple problem: 1+3 = 4

F5 A simple problem: F5 1 + 3 Ctrl+=

(Command+= for Macintosh)

Note: In Document mode, any statement to be evaluated must be entered in Math mode.

In Worksheet Mode

Examples

Steps

x3+x2&d;x

From the Expression palette, select fⅆx 

x^3 + x^2 Tab x

int(x^3+x^2, x);

F5

Enter text as it appears.

To display the Maple palettes, see Arranging Palettes in Your Worksheet.

Evaluate and Display on New Line

Use Enter to evaluate your mathematical expression or Maple command. Maple calculates and displays the result on a new line.

 

 

Examples

Steps

x3+xⅆx

From the Expression palette, select fⅆx  

x^3 + x Tab x and press Enter

factor(x^3+x);

Enter text as it appears and press Enter.

 

 

To display the result beside the original expression, see Evaluate and Display Inline.

Evaluate and Display Inline (Maple Document)

In Document mode, use Ctrl+=  to evaluate your mathematical expression or Maple command.

 

 

Example

Steps

1+1 = 2

1 + 1 Ctrl+= (Command+= for Macintosh)

 

Context menus display the result beside the original question.

 

 

Example

Steps

sinxdifferentiate w.r.t. xcosx

sin(x)

Right-click (Control-click, for Macintosh) sin(x). Select Differentiate>With Respect To>x

 

You can edit the results to replace the arrow with the text of your choice.

 

 

Example

Steps

The derivative of sinx is cosx 

Move to the beginning of the expression.

F5

The derivative of

Delete  differentiate w.r.t. x

F5  is

Leave Superscript/Subscript/Fraction

To leave the superscript, subscript, or denominator of a fraction, use the right-arrow key.

Example

Steps

x2

x^2

Right-arrow to leave the superscript region

xa

xa

x Ctrl+_  a (x Command+_ for Macintosh)

x__a

Right-arrow to leave the subscript region

 

1x+2y+3

1/x+2/y

Right-arrow to leave the denominator of 2y

+3

Right-arrow to leave the denominator

Note: In Maple, subscripts can be indexed or literal.  For details, see 2-D Math Shortcut Keys and Hints.

Complete Symbol/Complete Command

When you type a symbol name in Math mode, Esc (see command/symbol completion keys) automatically converts the name into a properly displayed symbol. When you type the first few letters of a symbol name, Esc displays a popup list of matching symbols. Use Tab to select the proper completion.

 

 

Example

Steps

x

sqrt then Esc then Tab x

 

In Math and Text modes, the command/symbol completion keys are used to complete a Maple command or a user-defined variable name. All possible completions are displayed in a popup list. If there is a unique choice, the command is completed automatically.

       

 

Example

Steps

Student[LinearAlgebra][GramSchmidt]

Stud Tab [L Tab [Gr 

Navigating Placeholders

The Expression palette and task templates use fill-in-the-blank placeholders. To fill the placeholders, complete the first entry and then Tab to the next.

The Tab key is also used for indenting in Text mode. The Tab icon allows you to set the Tab key to move between placeholders or to indent.

 

Tab icon off. Allows you to move between placeholders using the Tab key.

Tab icon on. Allows you to indent using the Tab key.

Maple Help

To display the Maple Help Navigator: Select Help>Maple Help or press Ctrl+F1.

 

To display Quick Help: Press F1.

 

To display the Quick Reference Card: Select Help>Quick Reference or press Ctrl+F2.

 

To display help on a particular topic: Enter ?topic or place the cursor on the topic name and press F2. For example ?factor displays the help page for the factor() command.

Math Editing Shortcuts

In addition to the palettes and mouse interactions, keyboard shortcuts are available for all operations.

 

Common Keyboard Shortcuts (See full list)

Symbol/Formats

Key

Example

Enter/exit 2-D Math

F5

Example using fraction: 14  (Math mode) versus 1/4 (Text mode)

Command/symbol completion

• 

Esc, Macintosh and Windows

• 

Ctrl+Space, Windows

• 

Command+Shift+Space, Macintosh

• 

Ctrl+Shift+Space, Linux

Context menus

• 

Right-click expression, Windows and Linux

• 

Control-click, Macintosh

Fraction1

/ (forward slash)

14 

Exponent (superscript)1

^ (caret)

x2

Indexed subscript1

Ctrl+_ (Command+_, Macintosh)

xa

Literal subscript1 (subscripted variable name)

__(two underscores)

xmax

Escape next character for entering "^"

\^ (caret)

u^v

Square root

sqrt+command/symbol completion keys

25

Navigating the expressions

Arrow keys

1x+12

 

1 use right arrow key to leave denominator, superscript, or subscript region

Interactive Assistants, Tutors, Task Templates, and Demonstrations

Access an extensive list of interactive assistants, tutors, task templates, and demonstrations through the Tools menu.

 

Tools>Assistants provides access to easy-to-use assistants that allow you to explore problems through point-and-click interfaces. Topics include analyzing ODEs and ODE systems, creating plots, converting units, and data analysis.

 

Tools>Tutors provides access to interactive tutors covering topics in precalculus, calculus, vector calculus, multivariate calculus, linear algebra, complex variables, numerical analysis and differential equations.

 

Tools>Tasks>Browse is the entry point to an extensive list of task templates, which show you the steps needed to solve a particular problem and provide you with a fill-in-the-blank template of the corresponding Maple command.

 

Tools>Demonstrations provides access to interactive demonstrations for exploring concepts in mathematics.

Units and Tolerances

Maple supports calculations with units and dimensions. The Tolerances package provides an environment to perform computations with quantities involving tolerances.

 

Mode

Examples

Steps

a:=4m = 4m

To define a variable a as 4 meters,

      a := 4

      From the Units (SI) palette, select m 

      Ctrl+= (Command+=, for Macintosh)

b:=1.5mach = 1.5M

To apply a unit not in palettes,

      b := 1.5

      From the Units (SI) palette, select unit 

      mach

      Ctrl+= (Command+=, for Macintosh)

xaffix unit kilogramxkg 

To apply units using context menus,

     Right-click (Control-click for Macintosh) x

     Select Units>Affix Unit>SI>kilogram

30cm+1.2msimplify units1.500000000m

To simplify the units in an expression,

     Right-click (Control-click for Macintosh) the expression

     Select Units>Simplify

3.5munits to FPS system11.48293963ft

To convert an expression with units to a different system of units,

     Right-click (Control-click for Macintosh) the expression

     Select Units>Convert>System>FPS

3.5mreplace units3.827646544yd

To convert an expression with units to different units,

     Right-click (Control-click for Macintosh) the expression

     Select Units>Replace Units

     In the dialog, enter yard

     Click OK

withTolerances

2±0.10 = 2.00 ± 0.100

To enter a quantity with an associated tolerance,

      2 pm Ctrl+Space (Command+Shift+Space, for Macintosh) 0.10

 

For more information on using units and dimensions, see Using Units and Dimensions in Maple Documents.

Assignments

Use := (colon equals) to assign a value to a variable.

 

Note: In Document mode, the assignment statement must be entered in Math mode.

Mode

Examples

Steps

Let a:=5

F5 Let F5 a:= 5 Enter

a := 5;

Enter text as it appears and press Enter.

 

Functions

To define a function, use the arrow notation.

 

Mode

Examples

Steps

f:=xx2 

f3 = 9 

From the Expression palette, select f:=ay

f Tab

x Tab

x^2

f(3)  Ctrl+= (Command+=, for Macintosh)

G := (x,y,z) -> x^2+y^2+z^2;

G(-1,0,1);

Enter text as it appears. Press enter to evaluate.

 

Equations

Equations are represented using the = sign.

y=mx+b

 

To assign an equation to a variable, use the assignment operator.

eqn y=mx+b

 

Once assigned to a variable name, you can use the name to manipulate the equation.

rhseqn= mx+b

 

Right-click Expression

To easily manipulate an expression in Maple, right-click the expression (Control-click, for Macintosh) to display a context-sensitive menu of applicable options.  

 

 

Example

Steps

x2

x^2

• 

Right-click the expression, Windows and Linux

• 

Control-click the expression, Macintosh

 

Context-sensitive menus are available for Maple input and output.

 

 

Example

Steps

diff(sin(x), x);

cosx

Enter text as it appears and press Enter.

• 

Right-click the expression output, Windows and Linux

• 

Control-click the expression output, Macintosh

 


Download Help Document

Was this information helpful?



Please add your Comment (Optional)
E-mail Address (Optional)
What is ? This question helps us to combat spam