requires - Maple Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : System : Libraries and Packages : Deprecated Packages and Commands : Deprecated commands : requires(deprecated)

requires

assert a load time dependency

 

Calling Sequence

Parameters

Description

Examples

Calling Sequence

requires(args::sequence(anything))

Parameters

args

-

(possibly empty) expression sequence of arguments

Description

  

Important: The requires command has been deprecated.

• 

The procedure requires is used to assert a load time dependency in a Maple library source file.

• 

If any of the arguments passed to requires are not of type procedure or of type table, then an error is signalled. Otherwise, NULL is returned.

• 

The purpose of this routine is to force an error to be generated if an attempt is made to load a file that depends, at load time, on some library routines that are not yet loaded into the repository.

Examples

Important: The requires command has been deprecated.

requiresint

Error, (in requires) load time requirement for int not satisfied

requirescrazy_nonexistent_function_or_table

Error, (in requires) load time requirement for crazy_nonexistent_function_or_table not satisfied

See Also

ASSERT

save

savelib

 


Download Help Document

Was this information helpful?



Please add your Comment (Optional)
E-mail Address (Optional)
What is ? This question helps us to combat spam