Part 8: Word Processing Tools - Maple Programming Help

Online Help

All Products    Maple    MapleSim

Home : Support : Online Help : Getting Started : Tutorials : MaplePortal/Tutorial8

Part 8: Word Processing Tools

Go to Maple Portal     Previous Tutorial     Next Tutorial



Word Processing Tools

Sections and Tables

Document Enhancements

See Also


Maple's Tutorials are designed to help you get started with Maple, learn about the key tools available in Maple, and lead you through a series of problems.


In Part 8: Word Processing Tools, you will learn about some of Maple's technical document creation features.


To try this material on your own, start with an empty Maple document. Perform the steps described in the left column of each table below.  The results of the steps are displayed in the right column for reference.


Refer to Help>Quick Reference for basic getting started tips.


Note for non-Windows users: The keystrokes given in this document are for Windows.  There will be differences for other platforms. If you are using a different platform, see Help>Quick Help for the list of the most common keystrokes.


Word Processing Tools

Maple contains numerous word processing tools to help you create professional-looking reports.  For your reference, here is a list of some of the more common ones.



Where to Find It

Built-in headings styles

Drop-down list on toolbar

Sections and subsections

Insert > Section, Insert > Subsection


Insert > Table

Font control and ability to define new styles

Toolbar buttons, Format > Styles...

Ability to insert images and other objects

Insert > Image

A spell-checker aware of mathematical terms

Tools > Spellcheck

Hyperlinks and bookmarks

Format > Convert To > Hyperlink

Format > Bookmarks...

Page numbers, headers, and footers

View > Header Footer...

Export to HTML

File > Export As...

Sections and Tables

The fundamental organization of a Maple document is controlled by using sections and tables.

Using Sections in a Document

Use sections in your Maple document to:


Organize content


Hide distracting code or detailed information 


To insert a section:  Insert>Section.  To create a subsection inside the current section, use Insert>Subsection.


To expand or collapse sections: View>Expand All Sections / Collapse All Sections

To expand or collapse one section: Click on the arrow beside the section name.


To organize existing content: Use the Indent and Outdent toolbar icons to shift selected text into a new subsection or out of a subsection level.

Enclose the selection in a section or subsection

Outdent the selection to the next section level, if possible.


To delete a section: Place the cursor in the title and press [Ctrl][Delete] or Edit>Delete Element

Using Tables

Tables can contain text, math, plots, graphics, and embedded components.  Use tables to:



Organize your content effectively, increasing readability and reducing wasted space


Align text and graphics


Control the layout of embedded components


To insert a table: Insert>Table



To change table size/column widths: Click and drag column boundaries

To add or delete rows and columns: Use the Table menu

To switch between navigation and indentation modes for the Tab key:  Use the Tab icon

Tab icon unselected.  Allows you to move between table cells using [Tab].

Tab icon selected.  Allows you to indent using [Tab].


To format a table: Table>Properties 



This dialog box allows you to adjust table properties. Options include:



Table Size Mode: There are two options:

Fixed percentage of page width

The width of the table is adjusted whenever the width of the worksheet changes. This option is useful for ensuring that the entire content of the table always fits onto the screen or printed page.

Scale with zoom factor

Preserves table appearance regardless of the size of the worksheet window or the zoom factor by using horizontal scroll when needed. Ensures line breaks occur in fixed locations, allowing you to control the breaks in long expressions. With this option, the table could be truncated when printing if it is too wide.


Set visibility of borders: As an example, in the previous bullet item a table is used to create two columns with the borders set to None.


Add table captions: Use to add a table numbering or titles.  Then, elsewhere in the document, you can easily refer to a table using a table cross-reference.


Set order of cell execution: Control the order in which math in the table is executed.



Note: To avoid confusion, ensure execution order is visibly obvious to reader.


For information on tables, see Overview of Tables.

For information on embedded components, see 9-Dynamic Applications.

Document Enhancements

Annotations and Drawing Tools


You can create annotations that will pop up when a user hovers over the annotated text or math.

To create an annotation:


Select the text or math to be annotated.


Click on Format>Annotate Selection and enter the note.


Click outside the entry box to finish entering text.  The selection will have a colored background indicating the annotation was added.


Move your mouse over the selection to see the annotation.




Type the math equation, y'=y2+y.


Select the equation, and from the Format menu, choose Annotate Selection.  Enter the note "Ref. p. 127, "Introductory Differential Equations.""


Move your mouse over the selection to see the annotation.



To edit or remove an annotation, place your cursor in the annotated text and from the Edit menu, choose Edit Annotation or Delete Annotation.

Drawing Tools and Plot Annotations

Using the drawing tools, you can sketch an idea in a canvas, draw on a plot, or draw on an image.


To draw on a plot, click on the plot, then click on the  button on the toolbar.  You can add additional information to plots such as text, 2-D math, lines, arrows, and shapes.  See 4-Plotting for an example using plot annotations.


To create a new drawing, insert a canvas from the Insert menu.

From the Drawing toolbar, you can use the following tools: selection tool, pencil (free style drawing), eraser, text insert, straight line, rectangle, rounded rectangle, oval, diamond, alignment, drawing outline, drawing fill, drawing linestyle, and drawing canvas properties.


You can hide the gridlines through the drawing canvas properties.


For more information on using the drawing tools, including how to rotate objects and how to fill an object with an image, see Drawing Tools.

Creating Hyperlinks

Hyperlinks in your document can link to:




Dictionary topic


Help topic


Different location in current document


Maplet application


Web page (URL)


Other Maple documents

To create a hyperlink:


Highlight the text that you want to make a hyperlink.


From the Format menu, select Convert To>Hyperlink. This option is also available through the context menu.


Specify the hyperlink Type and Target.  To link to a Maple document, choose Worksheet for the Type.


To insert an image hyperlink: 

1. From the Insert menu, select Hyperlink.

2. In the Hyperlink Properties dialog box, select the Image check box and click Choose Image for the file. The image appears as the link. You can resize the image as necessary. Click and drag from the corners of the image to resize.

3. Specify the hyperlink Type and Target.





Create a link to a help topic.

1. Type "For more information, see hyperlinks."

2. Highlight hyperlinks.  From the Format menu, select Convert To>Hyperlink.

3. In the Hyperlink Properties dialog, set the target to worksheet,managing,linking.

















4. Click OK.  Now, test the link.



For more information, see hyperlinks.




For more information, see hyperlinks.


To view or edit the properties of an existing hyperlink: Right-click on the link and choose Hyperlink Properties.

Creating Bookmarks

You can link to a specific location in a Maple document.  To do this, you will need to create a bookmark.


To display bookmark formatting icons, activate the Marker feature: View>Markers.


To insert a bookmark:

1. Place the cursor at the location at which to place the bookmark. For example, place the cursor in a section title.

2. From the Format menu, select Bookmarks. The Bookmark dialog opens, listing existing bookmarks in the document.

3. Click New. The Create Bookmark dialog opens. Enter a bookmark name and click Create.


Note: You can also rename and delete bookmarks from the Bookmark dialog.


To link to a bookmark: Follow the steps to create a hyperlink.  Enter the bookmark target under Bookmark in the Hyperlink Properties.

Using Startup Code

The Startup Code region allows you to enter Maple code to be executed every time the current document is reopened.


Startup code can include loaded packages, defined variables and procedures, and any other Maple commands.


The commands entered in the Startup Code region do not appear anywhere in the Maple document, and can only be accessed by opening the Startup Code Editor. This provides you with a cleaner way to generate Maple documents with no visible code.

To enter startup code:


From the Edit menu and select Startup Code. Alternatively, click the Edit startup code icon  in the toolbar. A dialog appears in which you can enter Maple commands.


Enter the desired Maple code.


When you are finished defining your startup code, and you have checked the code for syntax errors, save the code and exit, either select Save from the File menu, or click the Save button.


To check that your startup code works as desired, save the current document, close it, and then reopen it. You can then check that packages were loaded, variables were assigned, and other code was successfully compiled.

Advanced Document Features

You can hide document blocks, designate regions of the document for automatic execution, and use embedded components to further enhance your document.  You can use slideshow mode to share your document.  For more information, see Overview of Document Processing or use the Help System to find more information on a specific topic.

See Also

annotations, document blocks, document processing, startup code


Go to Maple Portal     Previous Tutorial     Next Tutorial

Download Help Document

Was this information helpful?

Please add your Comment (Optional)
E-mail Address (Optional)
What is ? This question helps us to combat spam