How Do I - Maple Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : Getting Started : How Do I... : HowDoI/PlotAFunction

How Do I

  

Plot a Function?

 

Maple has extensive plotting functionality to help you visualize the behavior of mathematical functions. The examples below show how to construct a graph of the function y = x2+5 x2 by using two different methods: using Maple's Context Menu system and using the interactive Plot Builder.

 

The generated plot can be manipulated; it can be scaled, zoomed, panned, and resized. For more details on plotting, refer to the comprehensive Maple Plotting Guide. For information about Maple commands used in plotting, see the help pages on plot, plot3d, and plottools.

 

Before you proceed, be sure to familiarize yourself with entering simple mathematical expressions. Open a new worksheet in Document mode, and ensure that you are in Math mode.

 

A video demonstration of the first method (and of plotting in general) is available online.

 

 

Using Maple's Context Menu System

Using the Interactive Plot Builder

Related Topics

Using Maple's Context Menu System

Follow the steps below to plot the function y=x2+5 x2.

 

Step

Description

Illustration

1

Type y=x2+5 x2.

2

Right-click the equation, and from the Context Menu, select Plots > 2-D Plot of Right Side.

Using the Interactive Plot Builder

Follow the steps below to plot the function y=x2+5 x2.

 

Step

Description

Illustration

1

Type the expression x2+5 x2. Do not type an equation, since the Plot Builder interprets equations as implicit plots.

2

Right-click the expression, and from the Context Menu, select Plots > Plot Builder. The Plot Builder dialog opens. Note that if the Plot Builder is accessed from the main menu (Tools > Assistants > Plot Builder...), then the expression x2+5 x2 must be entered manually.

3

The plot type and plot ranges for independent variables can be set here. Clicking Options opens a window where the settings for this plot can be changed. For this example, the default settings suffice.

4

Click Plot. The plot is displayed.

Related Topics

The How Do I... topics cover the essentials for doing mathematics in Maple. Learn more about available tools and features, such as palettes and context-sensitive menus.

How Do I...

...Enter a Complex Number?

...Enter a Function?

...Enter a Matrix?

...Enter a Simple Expression?

...Evaluate an Expression?

...Plot a Straight Line?

...Plot Multiple Functions?

...Select a Math Style?

...Solve an Ordinary Differential Equation?

...Work with Random Generators?

 

Tools and Features

Palettes

Context-Sensitive Menus

Command Completion

Equation Labels

Assistants

Maple Help

Plotting Guide

Applications

Example Worksheets

Manuals

Refer to Help>Quick Reference for basic Getting Started tips.

See Also

plot

Plotting Tutorial

Plot Builder

MaplePortal

Context-sensitive menus

Note for non-Windows users: The keystrokes given in this document are for Windows. There will be differences for other platforms. If you are using a different platform, see Help>Quick Help for the list of the most common keystrokes.


Download Help Document

Was this information helpful?



Please add your Comment (Optional)
E-mail Address (Optional)
What is ? This question helps us to combat spam